]> git.pld-linux.org Git - packages/wine.git/commitdiff
Merge commit 'a26a38' from DEVEL branch
authorJacek Konieczny <jajcus@jajcus.net>
Sat, 9 Jan 2016 16:23:42 +0000 (17:23 +0100)
committerJacek Konieczny <jajcus@jajcus.net>
Sat, 9 Jan 2016 16:23:42 +0000 (17:23 +0100)
(skipping the compholio patches on DEVEL)

1  2 
wine.spec

diff --combined wine.spec
index 2d28a0a83a043fd4aa4e179aefb287af2ee9e585,94b4f84e68da4230df7309855db358cf44453119..b079ea5ffc6663b42ed3542206f9b2e76bff61f4
+++ b/wine.spec
@@@ -1,32 -1,22 +1,33 @@@
  #
  # Conditional build:
- %bcond_without        alsa            # ALSA mm driver
- %bcond_without        capi            # CAPI 2.0 (ISDN) support
- %bcond_without        gstreamer       # GStreamer filters support
- %bcond_without        sane            # TWAIN DLL with scanning support (through SANE)
+ %bcond_without        alsa            # don't build ALSA mm driver
+ %bcond_without        capi            # don't build CAPI 2.0 (ISDN) support
+ %bcond_without        gstreamer       # don't build GStreamer filters support
+ %bcond_without        sane            # don't build TWAIN DLL with scanning support (through SANE)
 +%bcond_with   hal             # HAL dynamic device support [deprecated]
- %bcond_without        ldap            # LDAP DLL
- %bcond_without        cups            # CUPS printing support in winspool,wineps DLLs
+ %bcond_without        ldap            # don't build LDAP DLL
+ %bcond_without        cups            # without CUPS printing support in winspool,wineps DLLs
+ %bcond_without        netapi          # don't use the Samba NetAPI library
  #
  # NOTE: wine detects the following SONAMES for dlopen at build time:
 -#   libcrypto,libssl (wininet.dll)
 -#   libcups (winspool.dll.so,wineps.dll.so)
 -#   libcurses/libncurses (wineconsole program)
 +#   libGL (winex11.drv.so)
 +#   libOSMesa (gdi32.dll.so)
 +#   libX11 libXcomposite libXcursor libXext libXi libXinerama libXrandr libXrender libXxf86vm (winex11.drv.so)
 +#   libcapi20 (capi2032.dll.so)
 +#   libcups (winspool.drv.so)
 +#   libdbus (mountmgr.sys.so)
  #   libfontconfig (gdi32.dll.so)
 -#   libfreetype (wineps.dll.so,gdi32.dll.so)
 -#   libGL (x11drv.dll.so,ddraw.dll.so)
 -#   libX11, libXext, libXi, libXrender (x11drv.dll.so)
 -#   libpng (windowscodecs.dll: SONAME_LIBPNG in dlls/windowscodecs/pngformat.c)
 +#   libfreetype (gdi32.dll.so)
 +#   libgnutls (secur32.dll.so)
 +#   libhal (mountmgr.sys.so)
 +#   libjpeg (gphoto2.ds.so windowscodecs.dll.so)
 +#   libncurses (kernel32.dll.so)
 +#   libodbc (odbc32.dll.so)
 +#   libpng (windowscodecs.dll.so)
 +#   libsane (sane.ds.so)
 +#   libtiff (windowscodecs.dll.so)
 +#   libv4l1 (qcap.dll.so)
 +#   libxslt (msxml3.dll.so)
  # thus requires rebuild after change of any of the above.
  
  # library qualifier in rpm generated deps
@@@ -36,7 -26,7 +37,7 @@@
  %define       libqual %{nil}
  %endif
  
- %define               gecko_ver       2.21
+ %define               gecko_ver       2.24
  Summary:      Program that lets you launch Win applications
  Summary(es.UTF-8):    Ejecuta programas Windows en Linux
  Summary(pl.UTF-8):    Program pozwalający uruchamiać aplikacje Windows
@@@ -44,35 -34,33 +45,35 @@@ Summary(pt_BR.UTF-8):      Executa programa
  Name:         wine
  # 1.6.x – stable
  # 1.7.x – development (DEVEL branch)
- Version:      1.6.2
- Release:      2
+ Version:      1.7.18
+ Release:      0.1
  Epoch:                1
  License:      LGPL
  Group:                Applications/Emulators
  Source0:      http://downloads.sourceforge.net/wine/%{name}-%{version}.tar.bz2
- # Source0-md5:        0f6c56f86befe38e219090915f81f48a
+ # Source0-md5:        b13c19ef69a99f2aa6c0b3fd08ae8d90
  Source1:      http://downloads.sourceforge.net/wine/%{name}_gecko-%{gecko_ver}-x86.msi
- # Source1-md5:        432eb3a2d05c3f07df67864f53c87c60
+ # Source1-md5:        766bb034172f7f0a97443951a02a0df8
  Source2:      http://downloads.sourceforge.net/wine/%{name}_gecko-%{gecko_ver}-x86_64.msi
- # Source2-md5:        580bbabde1ec99ba9caa439c2dbca3f6
+ # Source2-md5:        1912fd191872c72d5f562283e44e8ab4
  Source3:      %{name}-uninstaller.desktop
  Patch0:               %{name}-gphoto2_bool.patch
  Patch1:               %{name}-makedep.patch
  Patch2:               %{name}-ncurses.patch
  Patch4:               %{name}-disable-valgrind.patch
  Patch5:               %{name}-ca_certificates.patch
- Patch6:               %{name}-manpaths.patch
- Patch7:               desktop.patch
- Patch8:               %{name}-wine64_man.patch
+ Patch6:               desktop.patch
+ Patch7:               %{name}-wine64_man.patch
  URL:          http://www.winehq.org/
 +BuildRequires:        Mesa-libOSMesa-devel
  BuildRequires:        OpenAL-devel >= 1.1
 -BuildRequires:        ocl-icd-libOpenCL-devel
 +BuildRequires:        OpenCL-devel
  BuildRequires:        OpenGL-GLU-devel
 +BuildRequires:        OpenGL-GLX-devel
+ BuildRequires:        Mesa-libOSMesa-devel
  %{?with_alsa:BuildRequires:   alsa-lib-devel}
  %{?with_arts:BuildRequires:   artsc-devel}
 -BuildRequires:        autoconf
 +BuildRequires:        autoconf >= 2.62
  BuildRequires:        automake
  BuildRequires:        bison
  %{?with_capi:BuildRequires:   capi4k-utils-devel}
  BuildRequires:        dbus-devel
  BuildRequires:        docbook-dtd31-sgml
  BuildRequires:        docbook-utils
 -BuildRequires:        flex
 +BuildRequires:        flex >= 2.5.33
  BuildRequires:        fontconfig-devel
  BuildRequires:        fontforge
  BuildRequires:        freetype-devel >= 2.0.5
 +# for findup used after make install
  BuildRequires:        fslint
 -BuildRequires:        gettext-devel
 +%ifarch %{x8664}
 +BuildRequires:        gcc >= 6:4.4
 +%endif
 +BuildRequires:        gettext-tools
  BuildRequires:        giflib-devel
  BuildRequires:        gnutls-devel
 -%{?with_gstreamer:BuildRequires:      gstreamer0.10-plugins-base-devel}
 -BuildRequires:        icoutils
 -BuildRequires:        lcms2-devel
 +%{?with_gstreamer:BuildRequires:      gstreamer0.10-devel >= 0.10}
 +%{?with_gstreamer:BuildRequires:      gstreamer0.10-plugins-base-devel >= 0.10}
 +%{?with_hal:BuildRequires:    hal-devel}
 +# for icotool used in build
 +BuildRequires:        icoutils >= 0.29.0
 +BuildRequires:        lcms2-devel >= 2
  BuildRequires:        libgphoto2-devel
  BuildRequires:        libgsm-devel
  BuildRequires:        libjpeg-devel
  BuildRequires:        libmpg123-devel >= 1.5.0
 +BuildRequires:        libpng-devel >= 1.5
 +BuildRequires:        libtiff-devel
  BuildRequires:        libtool
  BuildRequires:        libv4l-devel
 +BuildRequires:        libxml2-devel >= 2.0
  BuildRequires:        libxslt-devel
  BuildRequires:        ncurses-devel
  # db2* failed previously - probably openjade or opensp bug
 -BuildRequires:        libpng-devel >= 1.5
  BuildRequires:        openjade >= 1:1.3.3-0.pre1
  %{?with_ldap:BuildRequires:   openldap-devel}
  BuildRequires:        opensp >= 1:1.5.1
 -BuildRequires:        openssl-devel >= 0.9.7d
  BuildRequires:        pkgconfig
  BuildRequires:        prelink
+ BuildRequires:        samba-devel
  %{?with_sane:BuildRequires:   sane-backends-devel}
  BuildRequires:        unixODBC-devel >= 2.2.12-2
  #BuildRequires:       valgrind
 +BuildRequires:        xorg-lib-libX11-devel
  BuildRequires:        xorg-lib-libXcomposite-devel
  BuildRequires:        xorg-lib-libXcursor-devel
 +BuildRequires:        xorg-lib-libXext-devel
  BuildRequires:        xorg-lib-libXi-devel
  BuildRequires:        xorg-lib-libXinerama-devel
 -BuildRequires:        xorg-lib-libXmu-devel
  BuildRequires:        xorg-lib-libXrandr-devel
  BuildRequires:        xorg-lib-libXrender-devel
 -BuildRequires:        xorg-lib-libXxf86dga-devel
  BuildRequires:        xorg-lib-libXxf86vm-devel
 +BuildRequires:        zlib-devel
  Requires:     libfreetype.so.6%{libqual}
  Requires:     libpng16.so.16%{libqual}
  Requires(post):       /sbin/ldconfig
@@@ -147,10 -127,11 +149,10 @@@ Obsoletes:      wine-doc-pd
  Obsoletes:    wine-drv-arts
  Obsoletes:    wine-drv-jack
  Obsoletes:    wine-drv-nas
 -ExclusiveArch:        %{ix86} %{x8664}
 +ExclusiveArch:        %{ix86} %{x8664} arm
  ExcludeArch:  i386
  BuildRoot:    %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
  
 -%define               _noautoreqdep           libGL.so.1 libGLU.so.1
  %define               no_install_post_strip   1
  
  %define               _winedir                %{_datadir}/%{name}
@@@ -220,10 -201,11 +222,10 @@@ Group:          Applications/Emulator
  Requires:     %{name} = %{epoch}:%{version}-%{release}
  
  %description dll-capi
 -CAPI 2.0 (ISDN) implementation DLLs for Wine (through OpenGL).
 +CAPI 2.0 (ISDN) implementation DLLs for Wine.
  
  %description dll-capi -l pl.UTF-8
 -Biblioteki DLL z implementacją CAPI 2.0 (ISDN) dla Wine (poprzez
 -OpenGL).
 +Biblioteki DLL z implementacją CAPI 2.0 (ISDN) dla Wine.
  
  %package dll-d3d
  Summary:      Direct3D implementation DLLs for Wine
@@@ -265,15 -247,11 +267,15 @@@ Biblioteka DLL z implementacją TWAIN d
  
  %package dll-ldap
  Summary:      Win32 LDAP API DLL for Wine
 +Summary(pl.UTF-8):    Biblioteka DLL z implementacją API Win32 LDAP dla Wine
  Group:                Applications/Emulators
  Requires:     %{name} = %{epoch}:%{version}-%{release}
  
  %description dll-ldap
 -Lightweight Directory Access Protocol Library.
 +Lightweight Directory Access Protocol Library for Wine.
 +
 +%description dll-ldap -l pl.UTF-8
 +Biblioteka LDAP (Lightweight Directory Access Protocol) dla Wine.
  
  %package drv-alsa
  Summary:      ALSA driver for WINE mm.dll implementation
@@@ -295,9 -273,8 +297,8 @@@ Sterownik ALSA dla implementacji mm.dl
  %patch4 -p1
  %patch5 -p1
  %patch6 -p1
- %patch7 -p1
  %ifarch %{x8664}
- %patch8 -p1
+ %patch7 -p1
  %endif
  
  %build
@@@ -310,32 -287,41 +311,41 @@@ mv -f oic_winlogo_*.png %{name}.pn
  %ifarch %{x8664}
        --enable-win64 \
  %endif
 -      --with%{!?with_alsa:out}-alsa \
 -      --with%{!?with_capi:out}-capi \
 +      --with-alsa%{!?with_alsa:=no} \
 +      --with-capi%{!?with_capi:=no} \
        --with-cms \
        --with-coreaudio \
 -      --with%{!?with_cups:out}-cups \
 +      --with-cups%{!?with_cups:=no} \
        --with-curses \
+       --with-dbus \
        --with-fontconfig \
        --with-freetype \
+       --with-gphoto \
        --with-glu \
        --with-gnutls \
-       --with-gphoto \
        --with-gsm \
-       --with-gstreamer%{!?with_gstreamer:=no} \
-       --with-hal%{!?with_hal:=no} \
 -      --with%{!?with_gstreamer:out}-gstreamer \
 -      --without-hal \
++      %{__with_without gstreamer} \
++      %{__with_without hal} \
        --with-jpeg \
 -      --with%{!?with_ldap:out}-ldap \
 +      --with-ldap%{!?with_ldap:=no} \
        --with-mpg123 \
+       --with%{!?with_netapi:out}-netapi \
+       --with-openal \
+       --with-opencl \
        --with-opengl \
+       --with-openssl \
+       --with-osmesa \
        --with-oss \
        --with-png \
        --with-pthread \
-       --with-sane%{!?with_sane:=no} \
+       --with%{!?with_sane:out}-sane \
+       --with-tiff \
+       --with-v4l \
        --with-xcomposite \
        --with-xcursor \
        --with-xinerama \
        --with-xinput \
+       --with-xinput2 \
        --with-xml \
        --with-xrandr \
        --with-xrender \
        --with-xshm \
        --with-xslt \
        --with-xxf86vm \
-       --with-x
+       --with-x \
+       --with-zlib
  %{__make} depend
  %{__make}
  
@@@ -353,9 -340,7 +364,7 @@@ install -d $RPM_BUILD_ROOT{%{_mandir}/m
  %{__make} install \
        DESTDIR=$RPM_BUILD_ROOT
  
- findup -m $RPM_BUILD_ROOT%{_winedir}/fakedlls
- install -p tools/fnt2fon $RPM_BUILD_ROOT%{_bindir}
+ install -p tools/sfnt2fon/sfnt2fon $RPM_BUILD_ROOT%{_bindir}
  cp -a aclocal.m4 $RPM_BUILD_ROOT%{_aclocaldir}/wine.m4
  
  install -d \
@@@ -405,6 -390,10 +414,10 @@@ for p in $programs; d
        mv -f files.so. files.so
  done
  
+ for dir in $RPM_BUILD_ROOT%{_mandir}/*.UTF-8 ; do
+       mv "$dir" "${dir%.UTF-8}"
+ done
  %ifarch %{x8664}
  for langdir in "" de/ fr/ pl/ ; do
  mv $RPM_BUILD_ROOT%{_mandir}/${langdir}man1/{wine,wine64}.1
@@@ -520,7 -509,7 +533,7 @@@ f
  
  %files devel
  %defattr(644,root,root,755)
- %attr(755,root,root) %{_bindir}/fnt2fon
+ %attr(755,root,root) %{_bindir}/sfnt2fon
  %attr(755,root,root) %{_bindir}/function_grep.pl
  %attr(755,root,root) %{_bindir}/widl
  %attr(755,root,root) %{_bindir}/winebuild
  %endif
  
  # additional dependencies in *.so not separated (yet?) from main package
 -#   ddraw.dll.so,x11drv.dll.so depend on X11 libs
 -#   ole2disp.dll.so,oleaut32.dll.so,typelib.dll.so depend on lib(un)gif,libjpeg,libX11
 -#   ttydrv.dll.so depends on ncurses
 +#   ddraw.dll.so,winex11.drv.so depend on X11 libs
 +#   ole2disp.dll16.so,oleaut32.dll.so,typelib.dll16.so depend on libX11
This page took 0.037518 seconds and 4 git commands to generate.