]> git.pld-linux.org Git - packages/wine.git/blob - wine.spec
- release 2 (by relup.sh)
[packages/wine.git] / wine.spec
1 #
2 # Conditional build:
3 %bcond_without  alsa            # ALSA mm driver
4 %bcond_without  capi            # CAPI 2.0 (ISDN) support
5 %bcond_without  gstreamer       # GStreamer filters support
6 %bcond_without  sane            # TWAIN DLL with scanning support (through SANE)
7 %bcond_with     hal             # HAL dynamic device support [deprecated]
8 %bcond_without  ldap            # LDAP DLL
9 %bcond_without  cups            # CUPS printing support in winspool,wineps DLLs
10 #
11 # NOTE: wine detects the following SONAMES for dlopen at build time:
12 #   libGL (winex11.drv.so)
13 #   libOSMesa (gdi32.dll.so)
14 #   libX11 libXcomposite libXcursor libXext libXi libXinerama libXrandr libXrender libXxf86vm (winex11.drv.so)
15 #   libcapi20 (capi2032.dll.so)
16 #   libcups (winspool.drv.so)
17 #   libdbus (mountmgr.sys.so)
18 #   libfontconfig (gdi32.dll.so)
19 #   libfreetype (gdi32.dll.so)
20 #   libgnutls (secur32.dll.so)
21 #   libhal (mountmgr.sys.so)
22 #   libjpeg (gphoto2.ds.so windowscodecs.dll.so)
23 #   libncurses (kernel32.dll.so)
24 #   libodbc (odbc32.dll.so)
25 #   libpng (windowscodecs.dll.so)
26 #   libsane (sane.ds.so)
27 #   libtiff (windowscodecs.dll.so)
28 #   libv4l1 (qcap.dll.so)
29 #   libxslt (msxml3.dll.so)
30 # thus requires rebuild after change of any of the above.
31
32 # library qualifier in rpm generated deps
33 %ifarch %{x8664} ia64 ppc64 s390x sparc64
34 %define libqual ()(64bit)
35 %else
36 %define libqual %{nil}
37 %endif
38
39 %define         gecko_ver       2.21
40 Summary:        Program that lets you launch Win applications
41 Summary(es.UTF-8):      Ejecuta programas Windows en Linux
42 Summary(pl.UTF-8):      Program pozwalający uruchamiać aplikacje Windows
43 Summary(pt_BR.UTF-8):   Executa programas Windows no Linux
44 Name:           wine
45 # 1.6.x – stable
46 # 1.7.x – development (DEVEL branch)
47 Version:        1.6.2
48 Release:        2
49 Epoch:          1
50 License:        LGPL
51 Group:          Applications/Emulators
52 Source0:        http://downloads.sourceforge.net/wine/%{name}-%{version}.tar.bz2
53 # Source0-md5:  0f6c56f86befe38e219090915f81f48a
54 Source1:        http://downloads.sourceforge.net/wine/%{name}_gecko-%{gecko_ver}-x86.msi
55 # Source1-md5:  432eb3a2d05c3f07df67864f53c87c60
56 Source2:        http://downloads.sourceforge.net/wine/%{name}_gecko-%{gecko_ver}-x86_64.msi
57 # Source2-md5:  580bbabde1ec99ba9caa439c2dbca3f6
58 Source3:        %{name}-uninstaller.desktop
59 Patch0:         %{name}-gphoto2_bool.patch
60 Patch1:         %{name}-makedep.patch
61 Patch2:         %{name}-ncurses.patch
62 Patch4:         %{name}-disable-valgrind.patch
63 Patch5:         %{name}-ca_certificates.patch
64 Patch6:         %{name}-manpaths.patch
65 Patch7:         desktop.patch
66 Patch8:         %{name}-wine64_man.patch
67 URL:            http://www.winehq.org/
68 BuildRequires:  Mesa-libOSMesa-devel
69 BuildRequires:  OpenAL-devel >= 1.1
70 BuildRequires:  OpenCL-devel
71 BuildRequires:  OpenGL-GLU-devel
72 BuildRequires:  OpenGL-GLX-devel
73 %{?with_alsa:BuildRequires:     alsa-lib-devel}
74 %{?with_arts:BuildRequires:     artsc-devel}
75 BuildRequires:  autoconf >= 2.62
76 BuildRequires:  automake
77 BuildRequires:  bison
78 %{?with_capi:BuildRequires:     capi4k-utils-devel}
79 %{?with_cups:BuildRequires:     cups-devel}
80 BuildRequires:  dbus-devel
81 BuildRequires:  docbook-dtd31-sgml
82 BuildRequires:  docbook-utils
83 BuildRequires:  flex >= 2.5.33
84 BuildRequires:  fontconfig-devel
85 BuildRequires:  fontforge
86 BuildRequires:  freetype-devel >= 2.0.5
87 # for findup used after make install
88 BuildRequires:  fslint
89 %ifarch %{x8664}
90 BuildRequires:  gcc >= 6:4.4
91 %endif
92 BuildRequires:  gettext-tools
93 BuildRequires:  giflib-devel
94 BuildRequires:  gnutls-devel
95 %{?with_gstreamer:BuildRequires:        gstreamer0.10-devel >= 0.10}
96 %{?with_gstreamer:BuildRequires:        gstreamer0.10-plugins-base-devel >= 0.10}
97 %{?with_hal:BuildRequires:      hal-devel}
98 # for icotool used in build
99 BuildRequires:  icoutils >= 0.29.0
100 BuildRequires:  lcms2-devel >= 2
101 BuildRequires:  libgphoto2-devel
102 BuildRequires:  libgsm-devel
103 BuildRequires:  libjpeg-devel
104 BuildRequires:  libmpg123-devel >= 1.5.0
105 BuildRequires:  libpng-devel >= 1.5
106 BuildRequires:  libtiff-devel
107 BuildRequires:  libtool
108 BuildRequires:  libv4l-devel
109 BuildRequires:  libxml2-devel >= 2.0
110 BuildRequires:  libxslt-devel
111 BuildRequires:  ncurses-devel
112 # db2* failed previously - probably openjade or opensp bug
113 BuildRequires:  openjade >= 1:1.3.3-0.pre1
114 %{?with_ldap:BuildRequires:     openldap-devel}
115 BuildRequires:  opensp >= 1:1.5.1
116 BuildRequires:  pkgconfig
117 BuildRequires:  prelink
118 %{?with_sane:BuildRequires:     sane-backends-devel}
119 BuildRequires:  unixODBC-devel >= 2.2.12-2
120 #BuildRequires: valgrind
121 BuildRequires:  xorg-lib-libX11-devel
122 BuildRequires:  xorg-lib-libXcomposite-devel
123 BuildRequires:  xorg-lib-libXcursor-devel
124 BuildRequires:  xorg-lib-libXext-devel
125 BuildRequires:  xorg-lib-libXi-devel
126 BuildRequires:  xorg-lib-libXinerama-devel
127 BuildRequires:  xorg-lib-libXrandr-devel
128 BuildRequires:  xorg-lib-libXrender-devel
129 BuildRequires:  xorg-lib-libXxf86vm-devel
130 BuildRequires:  zlib-devel
131 Requires:       libfreetype.so.6%{libqual}
132 Requires:       libpng16.so.16%{libqual}
133 Requires(post): /sbin/ldconfig
134 Suggests:       binfmt-detector
135 Suggests:       ca-certificates
136 Suggests:       cabextract
137 Conflicts:      ca-certificates < 20080809-4
138 # for printing needs lpr
139 Suggests:       cups-clients
140 # for winelauncher
141 Suggests:       xorg-app-xmessage
142 # for ntlm_auth
143 Suggests:       samba-common >= 1:3.0.25
144 # link to wine/ntdll.dll.so, without any SONAME
145 Provides:       libntdll.dll.so
146 Obsoletes:      wine-doc-pdf
147 Obsoletes:      wine-drv-arts
148 Obsoletes:      wine-drv-jack
149 Obsoletes:      wine-drv-nas
150 ExclusiveArch:  %{ix86} %{x8664} arm
151 ExcludeArch:    i386
152 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
153
154 %define         no_install_post_strip   1
155
156 %define         _winedir                %{_datadir}/%{name}
157
158 %description
159 Wine is a program which allows running Microsoft Windows programs
160 (including DOS, Windows 3.x and Win32 executables) on Unix. It
161 consists of a program loader which loads and executes a Microsoft
162 Windows binary, and a library that implements Windows API calls using
163 their Unix or X11 equivalents. The library may also be used for
164 porting Win32 code into native Unix executables.
165
166 %description -l es.UTF-8
167 Ejecuta programas Windows en Linux.
168
169 %description -l pl.UTF-8
170 Wine jest programem dzięki któremu można uruchamiać programy napisane
171 dla Microsoft Windows pod systemami uniksowymi. Składa się on z
172 loadera, który pozwala wczytywać i uruchamiać programy w formacie
173 Microsoft Windows, oraz z biblioteki, która implementuje API Windows
174 przy użyciu odpowiedników uniksowych oraz z X11. Biblioteka może być
175 także wykorzystana do przenoszenia aplikacji Win32 do Uniksa.
176
177 %description -l pt_BR.UTF-8
178 O Wine é um programa que permite rodar programas MS-Windows no X11.
179 Ele consiste de um carregador de programa, que carrega e executa um
180 binário MS-Windows, e de uma biblioteca de emulação que traduz as
181 chamadas da API para as equivalentes Unix/X11.
182
183 %package devel
184 Summary:        Wine - header files
185 Summary(es.UTF-8):      Biblioteca de desarrollo de wine
186 Summary(pl.UTF-8):      Wine - pliki nagłowkowe
187 Summary(pt_BR.UTF-8):   Biblioteca de desenvolvimento do wine
188 Group:          Development/Libraries
189 Requires:       %{name} = %{epoch}:%{version}-%{release}
190
191 %description devel
192 Wine - header files.
193
194 %description devel -l es.UTF-8
195 Biblioteca de desarrollo de wine.
196
197 %description devel -l pl.UTF-8
198 Wine - pliki nagłówkowe.
199
200 %description devel -l pt_BR.UTF-8
201 Arquivos de inclusão e bibliotecas para desenvolver aplicações com o
202 WINE.
203
204 %package programs
205 Summary:        Wine - programs
206 Summary(pl.UTF-8):      Wine - programy
207 Group:          Applications
208 Requires:       %{name} = %{epoch}:%{version}-%{release}
209
210 %description programs
211 Wine - programs.
212
213 %description programs -l pl.UTF-8
214 Wine - programy.
215
216 %package dll-capi
217 Summary:        CAPI 2.0 (ISDN) implementation DLLs for Wine
218 Summary(pl.UTF-8):      Biblioteki DLL z implementacją CAPI 2.0 (ISDN) dla Wine
219 Group:          Applications/Emulators
220 Requires:       %{name} = %{epoch}:%{version}-%{release}
221
222 %description dll-capi
223 CAPI 2.0 (ISDN) implementation DLLs for Wine.
224
225 %description dll-capi -l pl.UTF-8
226 Biblioteki DLL z implementacją CAPI 2.0 (ISDN) dla Wine.
227
228 %package dll-d3d
229 Summary:        Direct3D implementation DLLs for Wine
230 Summary(pl.UTF-8):      Biblioteki DLL z implementacją Direct3D dla Wine
231 Group:          Applications/Emulators
232 Requires:       %{name} = %{epoch}:%{version}-%{release}
233 Requires:       OpenGL
234
235 %description dll-d3d
236 Direct3D implementation DLLs for Wine (through OpenGL).
237
238 %description dll-d3d -l pl.UTF-8
239 Biblioteki DLL z implementacją Direct3D dla Wine (poprzez OpenGL).
240
241 %package dll-gl
242 Summary:        OpenGL implementation DLLs for Wine
243 Summary(pl.UTF-8):      Biblioteki DLL z implementacją OpenGL dla Wine
244 Group:          Applications/Emulators
245 Requires:       %{name} = %{epoch}:%{version}-%{release}
246 Requires:       OpenGL
247
248 %description dll-gl
249 OpenGL implementation DLLs for Wine.
250
251 %description dll-gl -l pl.UTF-8
252 Biblioteki DLL z implementacją OpenGL dla Wine.
253
254 %package dll-twain
255 Summary:        TWAIN implementation DLL for Wine
256 Summary(pl.UTF-8):      Biblioteka DLL z implementacją TWAIN dla Wine
257 Group:          Applications/Emulators
258 Requires:       %{name} = %{epoch}:%{version}-%{release}
259
260 %description dll-twain
261 TWAIN implementation DLL for Wine (through SANE).
262
263 %description dll-twain -l pl.UTF-8
264 Biblioteka DLL z implementacją TWAIN dla Wine (poprzez SANE).
265
266 %package dll-ldap
267 Summary:        Win32 LDAP API DLL for Wine
268 Summary(pl.UTF-8):      Biblioteka DLL z implementacją API Win32 LDAP dla Wine
269 Group:          Applications/Emulators
270 Requires:       %{name} = %{epoch}:%{version}-%{release}
271
272 %description dll-ldap
273 Lightweight Directory Access Protocol Library for Wine.
274
275 %description dll-ldap -l pl.UTF-8
276 Biblioteka LDAP (Lightweight Directory Access Protocol) dla Wine.
277
278 %package drv-alsa
279 Summary:        ALSA driver for WINE mm.dll implementation
280 Summary(pl.UTF-8):      Sterownik ALSA dla implementacji mm.dll w Wine
281 Group:          Applications/Emulators
282 Requires:       %{name} = %{epoch}:%{version}-%{release}
283
284 %description drv-alsa
285 ALSA driver for WINE mm.dll (multimedia system) implementation.
286
287 %description drv-alsa -l pl.UTF-8
288 Sterownik ALSA dla implementacji mm.dll (systemu multimediów) w Wine.
289
290 %prep
291 %setup -q
292 %patch0 -p1
293 %patch1 -p1
294 %patch2 -p1
295 %patch4 -p1
296 %patch5 -p1
297 %patch6 -p1
298 %patch7 -p1
299 %ifarch %{x8664}
300 %patch8 -p1
301 %endif
302
303 %build
304 icotool -x --width=32 --height=32 --bit-depth=32 -o . dlls/user32/resources/oic_winlogo.ico
305 mv -f oic_winlogo_*.png %{name}.png
306
307 %{__autoconf}
308 %{__autoheader}
309 %configure \
310 %ifarch %{x8664}
311         --enable-win64 \
312 %endif
313         --with-alsa%{!?with_alsa:=no} \
314         --with-capi%{!?with_capi:=no} \
315         --with-cms \
316         --with-coreaudio \
317         --with-cups%{!?with_cups:=no} \
318         --with-curses \
319         --with-fontconfig \
320         --with-freetype \
321         --with-glu \
322         --with-gnutls \
323         --with-gphoto \
324         --with-gsm \
325         --with-gstreamer%{!?with_gstreamer:=no} \
326         --with-hal%{!?with_hal:=no} \
327         --with-jpeg \
328         --with-ldap%{!?with_ldap:=no} \
329         --with-mpg123 \
330         --with-opengl \
331         --with-oss \
332         --with-png \
333         --with-pthread \
334         --with-sane%{!?with_sane:=no} \
335         --with-xcomposite \
336         --with-xcursor \
337         --with-xinerama \
338         --with-xinput \
339         --with-xml \
340         --with-xrandr \
341         --with-xrender \
342         --with-xshape \
343         --with-xshm \
344         --with-xslt \
345         --with-xxf86vm \
346         --with-x
347 %{__make} depend
348 %{__make}
349
350 %install
351 rm -rf $RPM_BUILD_ROOT
352 install -d $RPM_BUILD_ROOT{%{_mandir}/man1,%{_aclocaldir}}
353 %{__make} install \
354         DESTDIR=$RPM_BUILD_ROOT
355
356 findup -m $RPM_BUILD_ROOT%{_winedir}/fakedlls
357
358 install -p tools/fnt2fon $RPM_BUILD_ROOT%{_bindir}
359 cp -a aclocal.m4 $RPM_BUILD_ROOT%{_aclocaldir}/wine.m4
360
361 install -d \
362         $RPM_BUILD_ROOT%{_winedir}/windows/{system,Desktop,Favorites,Fonts} \
363         "$RPM_BUILD_ROOT%{_winedir}/windows/Start Menu/Programs/Startup" \
364         $RPM_BUILD_ROOT%{_winedir}/windows/{SendTo,ShellNew,system32,NetHood} \
365         $RPM_BUILD_ROOT%{_winedir}/windows/{Profiles/Administrator,Recent} \
366         $RPM_BUILD_ROOT%{_winedir}/{"Program Files/Common Files","My Documents"}
367
368 touch $RPM_BUILD_ROOT%{_winedir}/{autoexec.bat,config.sys,windows/win.ini}
369 touch $RPM_BUILD_ROOT%{_winedir}/windows/system/{shell.dll,shell32.dll}
370 touch $RPM_BUILD_ROOT%{_winedir}/windows/system/{winsock.dll,wsock32.dll}
371
372 cat > $RPM_BUILD_ROOT%{_winedir}/windows/system.ini <<'EOF'
373 [mci]
374 cdaudio=mcicda.drv
375 sequencer=mciseq.drv
376 waveaudio=mciwave.drv
377 avivideo=mciavi.drv
378 videodisc=mcipionr.drv
379 vcr=mciviscd.drv
380 MPEGVideo=mciqtz.drv
381 EOF
382
383 # /sbin/chstk -e $RPM_BUILD_ROOT%{_bindir}/wine
384
385 dir=$(pwd)
386 > files.so
387 > files.programs
388 cd $RPM_BUILD_ROOT%{_libdir}/wine
389 for f in *.so; do
390         case $f in
391         capi2032.dll.so|d3d8.dll.so|d3d9.dll.so|d3dx8.dll.so|glu32.dll.so|opengl32.dll.so|sane.ds.so|twain.dll.so|twain_32.dll.so|winealsa.drv.so|wined3d.dll.so|wldap32.dll.so)
392                 ;;
393         *)
394                 echo "%attr(755,root,root) %{_libdir}/wine/$f" >> $dir/files.so
395         esac
396 done
397 cd -
398
399 programs="notepad regedit regsvr32 wineconsole winefile winemine winepath"
400 for p in $programs; do
401         echo "%attr(755,root,root) %{_bindir}/$p" >> files.programs
402         echo "%attr(755,root,root) %{_libdir}/wine/$p.exe.so" >> files.programs
403         echo "%{_mandir}/man1/$p.1*" >> files.programs
404         grep -v "$p\.exe\.so$" files.so > files.so.
405         mv -f files.so. files.so
406 done
407
408 %ifarch %{x8664}
409 for langdir in "" de/ fr/ pl/ ; do
410 mv $RPM_BUILD_ROOT%{_mandir}/${langdir}man1/{wine,wine64}.1
411 done
412 %endif
413
414 install -d $RPM_BUILD_ROOT%{_winedir}/gecko
415 %ifnarch %{x8664}
416 cp -p %{SOURCE1} $RPM_BUILD_ROOT%{_winedir}/gecko
417 %else
418 cp -p %{SOURCE2} $RPM_BUILD_ROOT%{_winedir}/gecko
419 %endif
420
421 install -d $RPM_BUILD_ROOT%{_pixmapsdir}
422 cp -p %{SOURCE3} $RPM_BUILD_ROOT%{_desktopdir}
423 cp -p %{name}.png $RPM_BUILD_ROOT%{_pixmapsdir}
424
425 %clean
426 rm -rf $RPM_BUILD_ROOT
427
428 %post
429 /sbin/ldconfig
430 %update_desktop_database
431
432 %postun -p /sbin/ldconfig
433
434 %triggerpostun -- wine < 1:0.9.12-1.9
435 rm -f /var/lock/subsys/wine
436 if [ -x /sbin/chkconfig ]; then
437         /sbin/chkconfig --del wine
438 fi
439
440 %files -f files.so
441 %defattr(644,root,root,755)
442 %doc README AUTHORS ANNOUNCE
443 %lang(de) %doc documentation/README.de
444 %lang(es) %doc documentation/README.es
445 %lang(fr) %doc documentation/README.fr
446 %lang(hu) %doc documentation/README.hu
447 %lang(it) %doc documentation/README.it
448 %lang(ko) %doc documentation/README.ko
449 %lang(nb) %doc documentation/README.no
450 %lang(pt) %doc documentation/README.pt
451 %lang(pt_BR) %doc documentation/README.pt_br
452 %lang(ru) %doc documentation/README.ru
453 %lang(sv) %doc documentation/README.sv
454 %lang(tr) %doc documentation/README.tr
455 %attr(755,root,root) %{_bindir}/msiexec
456 %ifnarch %{x8664}
457 %attr(755,root,root) %{_bindir}/wine
458 %else
459 %attr(755,root,root) %{_bindir}/wine64
460 %endif
461 %attr(755,root,root) %{_bindir}/wineboot
462 %attr(755,root,root) %{_bindir}/winedbg
463 %attr(755,root,root) %{_bindir}/winecfg
464 %ifnarch %{x8664}
465 %attr(755,root,root) %{_bindir}/wine-preloader
466 %else
467 %attr(755,root,root) %{_bindir}/wine64-preloader
468 %endif
469 %attr(755,root,root) %{_bindir}/wineserver
470 %attr(755,root,root) %{_libdir}/*.so*
471 %dir %{_libdir}/wine
472 %dir %{_libdir}/wine/fakedlls
473 %{_libdir}/wine/fakedlls/*.acm
474 %{_libdir}/wine/fakedlls/*.cpl
475 %{_libdir}/wine/fakedlls/*.dll
476 %ifarch %{ix86}
477 %{_libdir}/wine/fakedlls/*.dll16
478 %endif
479 %{_libdir}/wine/fakedlls/*.drv
480 %ifarch %{ix86}
481 %{_libdir}/wine/fakedlls/*.drv16
482 %endif
483 %{_libdir}/wine/fakedlls/*.ds
484 %{_libdir}/wine/fakedlls/*.exe
485 %ifarch %{ix86}
486 %{_libdir}/wine/fakedlls/*.exe16
487 %{_libdir}/wine/fakedlls/*.mod16
488 %endif
489 %{_libdir}/wine/fakedlls/*.ocx
490 %{_libdir}/wine/fakedlls/*.sys
491 %{_libdir}/wine/fakedlls/*.tlb
492 %ifarch %{ix86}
493 %{_libdir}/wine/fakedlls/*.vxd
494 %endif
495 %ifnarch %{x8664}
496 %{_mandir}/man1/wine.1*
497 %lang(de) %{_mandir}/de/man1/wine.1*
498 %lang(fr) %{_mandir}/fr/man1/wine.1*
499 %lang(pl) %{_mandir}/pl/man1/wine.1*
500 %else
501 %{_mandir}/man1/wine64.1*
502 %lang(de) %{_mandir}/de/man1/wine64.1*
503 %lang(fr) %{_mandir}/fr/man1/wine64.1*
504 %lang(pl) %{_mandir}/pl/man1/wine64.1*
505 %endif
506 %{_mandir}/man1/msiexec.1*
507 %{_mandir}/man1/wineboot.1*
508 %{_mandir}/man1/winecfg.1*
509 %{_mandir}/man1/winedbg.1*
510 %{_mandir}/man1/wineserver.1*
511 %lang(de) %{_mandir}/de/man1/wineserver.1*
512 %lang(fr) %{_mandir}/fr/man1/wineserver.1*
513 %{_winedir}
514 %{_desktopdir}/wine.desktop
515 %{_desktopdir}/wine-uninstaller.desktop
516 %{_pixmapsdir}/%{name}.png
517
518 %files programs -f files.programs
519 %defattr(644,root,root,755)
520
521 %files devel
522 %defattr(644,root,root,755)
523 %attr(755,root,root) %{_bindir}/fnt2fon
524 %attr(755,root,root) %{_bindir}/function_grep.pl
525 %attr(755,root,root) %{_bindir}/widl
526 %attr(755,root,root) %{_bindir}/winebuild
527 %attr(755,root,root) %{_bindir}/winedump
528 %attr(755,root,root) %{_bindir}/wineg++
529 %attr(755,root,root) %{_bindir}/winegcc
530 %attr(755,root,root) %{_bindir}/winemaker
531 %attr(755,root,root) %{_bindir}/winecpp
532 %attr(755,root,root) %{_bindir}/wmc
533 %attr(755,root,root) %{_bindir}/wrc
534 %{_libdir}/wine/lib*.def
535 # no shared variants, so not separated
536 %{_libdir}/wine/lib*.def.a
537 %{_libdir}/wine/libadsiid.a
538 %{_libdir}/wine/libdx*.a
539 %{_libdir}/wine/libstrmbase.a
540 %{_libdir}/wine/libstrmiids.a
541 %{_libdir}/wine/libuuid.a
542 %{_libdir}/wine/libwinecrt0.a
543 %{_includedir}/wine
544 %{_mandir}/man1/widl.1*
545 %{_mandir}/man1/winebuild.1*
546 %{_mandir}/man1/winecpp.1*
547 %{_mandir}/man1/winedump.1*
548 %{_mandir}/man1/winegcc.1*
549 %{_mandir}/man1/wineg++.1*
550 %{_mandir}/man1/winemaker.1*
551 %lang(de) %{_mandir}/de/man1/winemaker.1*
552 %lang(fr) %{_mandir}/fr/man1/winemaker.1*
553 %{_mandir}/man1/wmc.1*
554 %{_mandir}/man1/wrc.1*
555 %{_aclocaldir}/*.m4
556
557 %files dll-capi
558 %defattr(644,root,root,755)
559 %attr(755,root,root) %{_libdir}/wine/capi2032.dll.so
560
561 %files dll-d3d
562 %defattr(644,root,root,755)
563 %attr(755,root,root) %{_libdir}/wine/d3d8.dll.so
564 %attr(755,root,root) %{_libdir}/wine/d3d9.dll.so
565 %attr(755,root,root) %{_libdir}/wine/wined3d.dll.so
566
567 %files dll-gl
568 %defattr(644,root,root,755)
569 %attr(755,root,root) %{_libdir}/wine/glu32.dll.so
570 %attr(755,root,root) %{_libdir}/wine/opengl32.dll.so
571
572 %if %{with sane}
573 %files dll-twain
574 %defattr(644,root,root,755)
575 %attr(755,root,root) %{_libdir}/wine/sane.ds.so
576 %attr(755,root,root) %{_libdir}/wine/twain*.dll.so
577 %endif
578
579 %if %{with ldap}
580 %files dll-ldap
581 %defattr(644,root,root,755)
582 %attr(755,root,root) %{_libdir}/wine/wldap*.dll.so
583 %endif
584
585 %if %{with alsa}
586 %files drv-alsa
587 %defattr(644,root,root,755)
588 %attr(755,root,root) %{_libdir}/wine/winealsa.drv.so
589 %endif
590
591 # additional dependencies in *.so not separated (yet?) from main package
592 #   ddraw.dll.so,winex11.drv.so depend on X11 libs
593 #   ole2disp.dll16.so,oleaut32.dll.so,typelib.dll16.so depend on libX11
This page took 0.082499 seconds and 3 git commands to generate.