]> git.pld-linux.org Git - packages/valgrind.git/blame - valgrind.spec
- added glibc patch (glibc 2.21 support)
[packages/valgrind.git] / valgrind.spec
CommitLineData
23a3ecde
AM
1# TODO:
2# - fix CC detection in configure, so CC=gcc won't be needed
9ab8af97
JB
3#
4# Conditional build:
5%bcond_with mpi # MPI wrapper module
6#
9fd66024 7Summary: An open-source memory debugger
81257f7b 8Summary(pl.UTF-8): Otwarty odpluskwiacz pamięci
cccdc142 9Name: valgrind
2ea65fbf 10Version: 3.10.1
ef1230c9 11Release: 1
9ab8af97 12License: GPL v2+
c5631d09 13Group: Development/Tools
4ff172b5 14Source0: http://valgrind.org/downloads/%{name}-%{version}.tar.bz2
2ea65fbf 15# Source0-md5: 60ddae962bc79e7c95cfc4667245707f
5beaf085
KK
16Patch0: %{name}-native-cpuid.patch
17Patch1: %{name}-ld_linux_strlen.patch
9ab8af97 18Patch2: %{name}-glibc.patch
e0752a56 19URL: http://valgrind.org/
9ab8af97
JB
20BuildRequires: autoconf >= 2.50
21BuildRequires: automake >= 1:1.10
54375cc9 22BuildRequires: gcc >= 5:3.0
2ea65fbf 23# check in configure.ac:882 AC_MSG_CHECKING([the GLIBC_VERSION version])
3a93a74d 24BuildRequires: glibc-devel >= 6:2.2
9ab8af97 25BuildRequires: glibc-devel < 6:2.22
1abb996b 26BuildRequires: libgomp-devel
54375cc9 27BuildRequires: libstdc++-devel
9ab8af97 28%{?with_mpi:BuildRequires: mpi-devel}
11f54799 29Obsoletes: valgrind-callgrind
30Obsoletes: valgrind-calltree
54375cc9 31ExclusiveArch: %{ix86} %{x8664} arm ppc ppc64 s390x
cccdc142
JK
32BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
33
9fd66024 34%define _noautostrip .*/vgpreload.*\\.so
79e9a7b2
ER
35# ld portion broken
36%undefine with_ccache
a803692b 37
cccdc142 38%description
9fd66024 39Valgrind is a GPL'd system for debugging and profiling Linux programs.
40With the tools that come with Valgrind, you can automatically detect
6b924c54
JP
41many memory management and threading bugs, avoiding hours of
42frustrating bug-hunting, making your programs more stable. You can
43also perform detailed profiling to help speed up your programs.
cccdc142 44
f86a5f7e
JR
45%description -l pl.UTF-8
46Valgrind jest systemem służącym do odpluskwiania i profilowania
47programów na Linuksie. Używając dostarczanych z nim narzędzi można
6b924c54
JP
48automatycznie wykrywać wiele błędów związanych z zarządzaniem pamięcią
49i wątkowaniem, dzięki czemu unika się frustrującego polowania na
50błędy, a także czyni się programy bardziej stabilnymi. Możliwe jest
51również dokładne profilowanie, dzięki któremu programy zaczną szybciej
52pracować.
a3b1e5f5 53
cccdc142 54%prep
4ff172b5 55%setup -q
5beaf085 56%patch0 -p1
1dc3004f 57%patch1 -p1
9ab8af97 58%patch2 -p1
68bd9ee3 59
ef1230c9 60sed -i -e 's:^CFLAGS="-Wno-long-long":CFLAGS="$CFLAGS -Wno-long-long":' configure.ac
1437dfea 61
cccdc142 62%build
c594fc71 63%{__aclocal}
cccdc142 64%{__autoconf}
9ab8af97 65%{__autoheader}
cccdc142 66%{__automake}
e7968d53
PS
67
68ac_cv_path_GDB=/usr/bin/gdb \
9eb4ec2b 69%configure \
23a3ecde 70 CC=gcc \
1abb996b 71 --enable-tls \
68bd9ee3
AM
72%if %{_lib} != "lib"
73 --enable-only64bit \
74%endif
9eb4ec2b 75 LDFLAGS="" # no strip!
e7968d53 76
cccdc142
JK
77%{__make}
78
79%install
80rm -rf $RPM_BUILD_ROOT
81
a273c144
JB
82%{__make} install \
83 DESTDIR=$RPM_BUILD_ROOT
cccdc142 84
54375cc9 85%{__rm} -r $RPM_BUILD_ROOT%{_datadir}/doc
ef1230c9
AM
86cp -p docs/index.pdf docs/valgrind_manual.pdf
87cp -p docs/index.ps docs/valgrind_manual.ps
6b924c54 88
cccdc142
JK
89%clean
90rm -rf $RPM_BUILD_ROOT
91
92%files
93%defattr(644,root,root,755)
a15e5165 94%doc AUTHORS NEWS README README_MISSING_SYSCALL_OR_IOCTL
6b924c54 95%doc docs/html docs/valgrind_manual.pdf docs/valgrind_manual.ps
54375cc9
JB
96%attr(755,root,root) %{_bindir}/callgrind_annotate
97%attr(755,root,root) %{_bindir}/callgrind_control
98%attr(755,root,root) %{_bindir}/cg_annotate
99%attr(755,root,root) %{_bindir}/cg_diff
100%attr(755,root,root) %{_bindir}/cg_merge
101%attr(755,root,root) %{_bindir}/ms_print
102%attr(755,root,root) %{_bindir}/valgrind
ef1230c9 103%attr(755,root,root) %{_bindir}/valgrind-di-server
54375cc9
JB
104%attr(755,root,root) %{_bindir}/valgrind-listener
105%attr(755,root,root) %{_bindir}/vgdb
f1c36ddf 106%dir %{_libdir}/%{name}
1abb996b 107%attr(755,root,root) %{_libdir}/%{name}/*-linux
54375cc9 108%attr(755,root,root) %{_libdir}/%{name}/vgpreload_*-linux.so
9ab8af97
JB
109%if %{with mpi}
110# TODO: subpackage?
111%attr(755,root,root) %{_libdir}/%{name}/libmpiwrap-*-linux.so
112%endif
23a3ecde 113%{_libdir}/%{name}/*.xml
54375cc9
JB
114%{_libdir}/%{name}/default.supp
115%{_libdir}/%{name}/lib*-linux.a
116%{_includedir}/valgrind
117%{_mandir}/man1/callgrind_annotate.1*
118%{_mandir}/man1/callgrind_control.1*
119%{_mandir}/man1/cg_annotate.1*
ef1230c9
AM
120%{_mandir}/man1/cg_diff.1*
121%{_mandir}/man1/cg_merge.1*
54375cc9
JB
122%{_mandir}/man1/ms_print.1*
123%{_mandir}/man1/valgrind.1*
ef1230c9
AM
124%{_mandir}/man1/valgrind-listener.1*
125%{_mandir}/man1/vgdb.1*
54375cc9 126%{_pkgconfigdir}/valgrind.pc
This page took 0.044138 seconds and 4 git commands to generate.