]> git.pld-linux.org Git - packages/valgrind.git/blob - valgrind.spec
- added glibc patch (glibc 2.21 support)
[packages/valgrind.git] / valgrind.spec
1 # TODO:
2 # - fix CC detection in configure, so CC=gcc won't be needed
3 #
4 # Conditional build:
5 %bcond_with     mpi     # MPI wrapper module
6 #
7 Summary:        An open-source memory debugger
8 Summary(pl.UTF-8):      Otwarty odpluskwiacz pamięci
9 Name:           valgrind
10 Version:        3.10.1
11 Release:        1
12 License:        GPL v2+
13 Group:          Development/Tools
14 Source0:        http://valgrind.org/downloads/%{name}-%{version}.tar.bz2
15 # Source0-md5:  60ddae962bc79e7c95cfc4667245707f
16 Patch0:         %{name}-native-cpuid.patch
17 Patch1:         %{name}-ld_linux_strlen.patch
18 Patch2:         %{name}-glibc.patch
19 URL:            http://valgrind.org/
20 BuildRequires:  autoconf >= 2.50
21 BuildRequires:  automake >= 1:1.10
22 BuildRequires:  gcc >= 5:3.0
23 # check in configure.ac:882 AC_MSG_CHECKING([the GLIBC_VERSION version])
24 BuildRequires:  glibc-devel >= 6:2.2
25 BuildRequires:  glibc-devel < 6:2.22
26 BuildRequires:  libgomp-devel
27 BuildRequires:  libstdc++-devel
28 %{?with_mpi:BuildRequires:      mpi-devel}
29 Obsoletes:      valgrind-callgrind
30 Obsoletes:      valgrind-calltree
31 ExclusiveArch:  %{ix86} %{x8664} arm ppc ppc64 s390x
32 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
33
34 %define         _noautostrip    .*/vgpreload.*\\.so
35 # ld portion broken
36 %undefine       with_ccache
37
38 %description
39 Valgrind is a GPL'd system for debugging and profiling Linux programs.
40 With the tools that come with Valgrind, you can automatically detect
41 many memory management and threading bugs, avoiding hours of
42 frustrating bug-hunting, making your programs more stable. You can
43 also perform detailed profiling to help speed up your programs.
44
45 %description -l pl.UTF-8
46 Valgrind jest systemem służącym do odpluskwiania i profilowania
47 programów na Linuksie. Używając dostarczanych z nim narzędzi można
48 automatycznie wykrywać wiele błędów związanych z zarządzaniem pamięcią
49 i wątkowaniem, dzięki czemu unika się frustrującego polowania na
50 błędy, a także czyni się programy bardziej stabilnymi. Możliwe jest
51 również dokładne profilowanie, dzięki któremu programy zaczną szybciej
52 pracować.
53
54 %prep
55 %setup -q
56 %patch0 -p1
57 %patch1 -p1
58 %patch2 -p1
59
60 sed -i -e 's:^CFLAGS="-Wno-long-long":CFLAGS="$CFLAGS -Wno-long-long":' configure.ac
61
62 %build
63 %{__aclocal}
64 %{__autoconf}
65 %{__autoheader}
66 %{__automake}
67
68 ac_cv_path_GDB=/usr/bin/gdb \
69 %configure \
70         CC=gcc \
71         --enable-tls \
72 %if %{_lib} != "lib"
73         --enable-only64bit \
74 %endif
75         LDFLAGS="" # no strip!
76
77 %{__make}
78
79 %install
80 rm -rf $RPM_BUILD_ROOT
81
82 %{__make} install \
83         DESTDIR=$RPM_BUILD_ROOT
84
85 %{__rm} -r $RPM_BUILD_ROOT%{_datadir}/doc
86 cp -p docs/index.pdf docs/valgrind_manual.pdf
87 cp -p docs/index.ps docs/valgrind_manual.ps
88
89 %clean
90 rm -rf $RPM_BUILD_ROOT
91
92 %files
93 %defattr(644,root,root,755)
94 %doc AUTHORS NEWS README README_MISSING_SYSCALL_OR_IOCTL
95 %doc docs/html docs/valgrind_manual.pdf docs/valgrind_manual.ps
96 %attr(755,root,root) %{_bindir}/callgrind_annotate
97 %attr(755,root,root) %{_bindir}/callgrind_control
98 %attr(755,root,root) %{_bindir}/cg_annotate
99 %attr(755,root,root) %{_bindir}/cg_diff
100 %attr(755,root,root) %{_bindir}/cg_merge
101 %attr(755,root,root) %{_bindir}/ms_print
102 %attr(755,root,root) %{_bindir}/valgrind
103 %attr(755,root,root) %{_bindir}/valgrind-di-server
104 %attr(755,root,root) %{_bindir}/valgrind-listener
105 %attr(755,root,root) %{_bindir}/vgdb
106 %dir %{_libdir}/%{name}
107 %attr(755,root,root) %{_libdir}/%{name}/*-linux
108 %attr(755,root,root) %{_libdir}/%{name}/vgpreload_*-linux.so
109 %if %{with mpi}
110 # TODO: subpackage?
111 %attr(755,root,root) %{_libdir}/%{name}/libmpiwrap-*-linux.so
112 %endif
113 %{_libdir}/%{name}/*.xml
114 %{_libdir}/%{name}/default.supp
115 %{_libdir}/%{name}/lib*-linux.a
116 %{_includedir}/valgrind
117 %{_mandir}/man1/callgrind_annotate.1*
118 %{_mandir}/man1/callgrind_control.1*
119 %{_mandir}/man1/cg_annotate.1*
120 %{_mandir}/man1/cg_diff.1*
121 %{_mandir}/man1/cg_merge.1*
122 %{_mandir}/man1/ms_print.1*
123 %{_mandir}/man1/valgrind.1*
124 %{_mandir}/man1/valgrind-listener.1*
125 %{_mandir}/man1/vgdb.1*
126 %{_pkgconfigdir}/valgrind.pc
This page took 0.070484 seconds and 4 git commands to generate.