]> git.pld-linux.org Git - packages/valgrind.git/blame - valgrind.spec
Version: 3.10.0
[packages/valgrind.git] / valgrind.spec
CommitLineData
23a3ecde
AM
1# TODO:
2# - fix CC detection in configure, so CC=gcc won't be needed
9fd66024 3Summary: An open-source memory debugger
81257f7b 4Summary(pl.UTF-8): Otwarty odpluskwiacz pamięci
cccdc142 5Name: valgrind
33d3cc24 6Version: 3.10.0
ef1230c9 7Release: 1
cccdc142 8License: GPL
c5631d09 9Group: Development/Tools
4ff172b5 10Source0: http://valgrind.org/downloads/%{name}-%{version}.tar.bz2
33d3cc24 11# Source0-md5: 7c311a72a20388aceced1aa5573ce970
5beaf085
KK
12Patch0: %{name}-native-cpuid.patch
13Patch1: %{name}-ld_linux_strlen.patch
e0752a56 14URL: http://valgrind.org/
cccdc142
JK
15BuildRequires: autoconf
16BuildRequires: automake
54375cc9 17BuildRequires: gcc >= 5:3.0
3a93a74d 18BuildRequires: glibc-devel >= 6:2.2
33d3cc24 19BuildRequires: glibc-devel < 6:2.21
1abb996b 20BuildRequires: libgomp-devel
54375cc9 21BuildRequires: libstdc++-devel
11f54799 22Obsoletes: valgrind-callgrind
23Obsoletes: valgrind-calltree
54375cc9 24ExclusiveArch: %{ix86} %{x8664} arm ppc ppc64 s390x
cccdc142
JK
25BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
26
9fd66024 27%define _noautostrip .*/vgpreload.*\\.so
79e9a7b2
ER
28# ld portion broken
29%undefine with_ccache
a803692b 30
cccdc142 31%description
9fd66024 32Valgrind is a GPL'd system for debugging and profiling Linux programs.
33With the tools that come with Valgrind, you can automatically detect
6b924c54
JP
34many memory management and threading bugs, avoiding hours of
35frustrating bug-hunting, making your programs more stable. You can
36also perform detailed profiling to help speed up your programs.
cccdc142 37
f86a5f7e
JR
38%description -l pl.UTF-8
39Valgrind jest systemem służącym do odpluskwiania i profilowania
40programów na Linuksie. Używając dostarczanych z nim narzędzi można
6b924c54
JP
41automatycznie wykrywać wiele błędów związanych z zarządzaniem pamięcią
42i wątkowaniem, dzięki czemu unika się frustrującego polowania na
43błędy, a także czyni się programy bardziej stabilnymi. Możliwe jest
44również dokładne profilowanie, dzięki któremu programy zaczną szybciej
45pracować.
a3b1e5f5 46
cccdc142 47%prep
4ff172b5 48%setup -q
5beaf085 49%patch0 -p1
1dc3004f 50%patch1 -p1
68bd9ee3 51
ef1230c9 52sed -i -e 's:^CFLAGS="-Wno-long-long":CFLAGS="$CFLAGS -Wno-long-long":' configure.ac
1437dfea 53
cccdc142 54%build
c594fc71 55%{__aclocal}
1437dfea 56%{__autoheader}
cccdc142
JK
57%{__autoconf}
58%{__automake}
e7968d53
PS
59
60ac_cv_path_GDB=/usr/bin/gdb \
9eb4ec2b 61%configure \
23a3ecde 62 CC=gcc \
1abb996b 63 --enable-tls \
68bd9ee3
AM
64%if %{_lib} != "lib"
65 --enable-only64bit \
66%endif
9eb4ec2b 67 LDFLAGS="" # no strip!
e7968d53 68
cccdc142
JK
69%{__make}
70
71%install
72rm -rf $RPM_BUILD_ROOT
73
a273c144
JB
74%{__make} install \
75 DESTDIR=$RPM_BUILD_ROOT
cccdc142 76
54375cc9 77%{__rm} -r $RPM_BUILD_ROOT%{_datadir}/doc
ef1230c9
AM
78cp -p docs/index.pdf docs/valgrind_manual.pdf
79cp -p docs/index.ps docs/valgrind_manual.ps
6b924c54 80
cccdc142
JK
81%clean
82rm -rf $RPM_BUILD_ROOT
83
84%files
85%defattr(644,root,root,755)
a15e5165 86%doc AUTHORS NEWS README README_MISSING_SYSCALL_OR_IOCTL
6b924c54 87%doc docs/html docs/valgrind_manual.pdf docs/valgrind_manual.ps
54375cc9
JB
88%attr(755,root,root) %{_bindir}/callgrind_annotate
89%attr(755,root,root) %{_bindir}/callgrind_control
90%attr(755,root,root) %{_bindir}/cg_annotate
91%attr(755,root,root) %{_bindir}/cg_diff
92%attr(755,root,root) %{_bindir}/cg_merge
93%attr(755,root,root) %{_bindir}/ms_print
94%attr(755,root,root) %{_bindir}/valgrind
ef1230c9 95%attr(755,root,root) %{_bindir}/valgrind-di-server
54375cc9
JB
96%attr(755,root,root) %{_bindir}/valgrind-listener
97%attr(755,root,root) %{_bindir}/vgdb
f1c36ddf 98%dir %{_libdir}/%{name}
1abb996b 99%attr(755,root,root) %{_libdir}/%{name}/*-linux
54375cc9 100%attr(755,root,root) %{_libdir}/%{name}/vgpreload_*-linux.so
23a3ecde 101%{_libdir}/%{name}/*.xml
54375cc9
JB
102%{_libdir}/%{name}/default.supp
103%{_libdir}/%{name}/lib*-linux.a
104%{_includedir}/valgrind
105%{_mandir}/man1/callgrind_annotate.1*
106%{_mandir}/man1/callgrind_control.1*
107%{_mandir}/man1/cg_annotate.1*
ef1230c9
AM
108%{_mandir}/man1/cg_diff.1*
109%{_mandir}/man1/cg_merge.1*
54375cc9
JB
110%{_mandir}/man1/ms_print.1*
111%{_mandir}/man1/valgrind.1*
ef1230c9
AM
112%{_mandir}/man1/valgrind-listener.1*
113%{_mandir}/man1/vgdb.1*
54375cc9 114%{_pkgconfigdir}/valgrind.pc
This page took 0.046756 seconds and 4 git commands to generate.