]> git.pld-linux.org Git - packages/thunderbird.git/blob - icedove.spec
- compiles, but install fails
[packages/thunderbird.git] / icedove.spec
1 # TODO:
2 # - separate spec for enigmail
3 # - fix icedove (building) and installing nss/nspr libs!
4 # - build with system mozldap
5 #
6 # Conditional builds
7 %bcond_without  enigmail        # don't build enigmail - GPG/PGP support
8 %bcond_without  gnomeui         # disable gnomeui support
9 %bcond_without  gnomevfs        # disable GNOME comp. (gconf+libgnome+gnomevfs) and gnomevfs ext.
10 %bcond_without  gnome           # disable all GNOME components (gnome+gnomeui+gnomevfs)
11 %bcond_without  ldap            # disable e-mail address lookups in LDAP directories
12 %bcond_without  lightning       # disable sunbird calendar
13 %bcond_with             xulrunner       # build with system xulrunner
14
15 %if %{without gnome}
16 %undefine       with_gnomeui
17 %undefine       with_gnomevfs
18 %endif
19
20 %define         enigmail_ver            1.1.2
21
22 %if %{without xulrunner}
23 # The actual sqlite version (see RHBZ#480989):
24 %define         sqlite_build_version %(pkg-config --silence-errors --modversion sqlite3 2>/dev/null || echo ERROR)
25 %endif
26
27 Summary:        Icedove - email client
28 Summary(pl.UTF-8):      Icedove - klient poczty
29 Name:           icedove
30 Version:        3.1
31 Release:        0.2
32 License:        MPL 1.1 or GPL v2+ or LGPL v2.1+
33 Group:          Applications/Networking
34 Source0:        http://releases.mozilla.org/pub/mozilla.org/thunderbird/releases/%{version}/source/thunderbird-%{version}.source.tar.bz2
35 # Source0-md5:  feb4d737d568066076879a09bd0d506e
36 Source1:        http://www.mozilla-enigmail.org/download/source/enigmail-%{enigmail_ver}.tar.gz
37 # Source1-md5:  7d329d5e8afbbb28214ca1995beb09c9
38 Source2:        %{name}-branding.tar.bz2
39 # Source2-md5:  2da351522bdd7f4a3bd8aaff4c776976
40 Source3:        %{name}-rm_nonfree.sh
41 Source4:        %{name}.desktop
42 Source5:        %{name}.sh
43 Source6:        %{name}-enigmail.manifest
44 Patch0:         %{name}-branding.patch
45 Patch1:         %{name}-enigmail-shared.patch
46 Patch2:         %{name}-gcc.patch
47 Patch3:         %{name}-fonts.patch
48 Patch4:         %{name}-install.patch
49 Patch5:         %{name}-hunspell.patch
50 Patch6:         %{name}-prefs.patch
51 Patch7:         system-mozldap.patch
52 Patch8:         %{name}-makefile.patch
53 Patch9:         %{name}-libpng.patch
54 URL:            http://www.pld-linux.org/Packages/Icedove
55 %{?with_gnomevfs:BuildRequires: GConf2-devel >= 1.2.1}
56 BuildRequires:  automake
57 BuildRequires:  freetype-devel >= 1:2.1.8
58 %{?with_gnomevfs:BuildRequires: gnome-vfs2-devel >= 2.0}
59 BuildRequires:  gtk+2-devel >= 1:2.0.0
60 BuildRequires:  hunspell-devel
61 BuildRequires:  libIDL-devel >= 0.8.0
62 %{?with_gnomevfs:BuildRequires: libgnome-devel >= 2.0}
63 %{?with_gnomeui:BuildRequires:  libgnomeui-devel >= 2.2.0}
64 BuildRequires:  libjpeg-devel >= 6b
65 BuildRequires:  libpng-devel >= 1.2.0
66 BuildRequires:  libstdc++-devel
67 BuildRequires:  nspr-devel >= 1:4.8
68 BuildRequires:  nss-devel >= 1:3.12.0
69 BuildRequires:  pango-devel >= 1:1.1.0
70 BuildRequires:  pkgconfig
71 BuildRequires:  sed >= 4.0
72 BuildRequires:  sqlite3-devel >= 3.6.22
73 BuildRequires:  startup-notification-devel >= 0.8
74 BuildRequires:  xorg-lib-libXext-devel
75 BuildRequires:  xorg-lib-libXinerama-devel
76 BuildRequires:  xorg-lib-libXt-devel
77 BuildRequires:  zip
78 %if %{with xulrunner}
79 %else
80 Requires:       myspell-common
81 Requires:       nspr >= 1:4.6.1
82 Requires:       nss >= 1:3.11.3
83 Requires:       sqlite3 >= %{sqlite_build_version}
84 %endif
85 Obsoletes:      mozilla-thunderbird
86 Obsoletes:      mozilla-thunderbird-dictionary-en-US
87 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
88
89 %define         filterout_cpp           -D_FORTIFY_SOURCE=[0-9]+
90
91 # iceweasel/icedove/iceape provide their own versions
92 %define         _noautoreqdep           libgfxpsshar.so libgkgfx.so libgtkxtbin.so libjsj.so libxpcom_compat.so libxpcom_core.so libxpistub.so
93 %define         _noautoprovfiles        %{_libdir}/%{name}/components
94 # we don't want these to satisfy xulrunner-devel
95 %define         _noautoprov             libgtkembedmoz.so libmozjs.so libxpcom.so libxul.so
96 # and as we don't provide them, don't require either
97 %define         _noautoreq              libgtkembedmoz.so libmozjs.so libxpcom.so libxul.so
98
99 %description
100 Icedove is an open-source,fast and portable email client.
101
102 %description -l pl.UTF-8
103 Icedove jest open sourcowym, szybkim i przenośnym klientem poczty.
104
105 %package addon-lightning
106 Summary:        An integrated calendar for Icedove
107 Summary(pl.UTF-8):      Zintegrowany kalendarz dla Icedove
108 License:        MPL 1.1 or GPL v2+ or LGPL v2.1+
109 Group:          Applications/Networking
110 Requires:       %{name} = %{version}-%{release}
111
112 %description addon-lightning
113 Lightning is an calendar extension to Icedove email client.
114
115 %description addon-lightning -l pl.UTF-8
116 Lightning to rozszerzenie do klienta poczty Icedove dodające
117 funkcjonalność kalendarza.
118
119 %package addon-enigmail
120 Summary:        Extension for the authentication and encryption features provided by GnuPG
121 Summary(pl.UTF-8):      Rozszerzenie do uwierzytelniania i szyfrowania zapewnianego przez GnuPG
122 License:        MPL/LGPL
123 Group:          Applications/Networking
124 URL:            http://enigmail.mozdev.org/
125 Requires:       %{name} = %{version}-%{release}
126 Requires:       gnupg
127 Obsoletes:      mozilla-thunderbird-addon-enigmail
128
129 %description addon-enigmail
130 Enigmail is an extension to the Icedove mail client which allows users
131 to access the authentication and encryption features provided by
132 GnuPG.
133
134 Main Features:
135 - Encrypt/sign mail when sending, decrypt/authenticate received mail
136 - Support for inline-PGP (RFC 2440) and PGP/MIME (RFC 3156)
137 - Per-Account based encryption and signing defaults
138 - Per-Recipient rules for automated key selection, and
139   enabling/disabling encryption and signing
140 - OpenPGP key management interface
141
142 %description addon-enigmail -l pl.UTF-8
143 Enigmail to rozszerzenie klienta pocztowego Icedove pozwalające
144 użytkownikom na dostęp do uwierzytelniania i szyfrowania zapewnianego
145 przez GnuPG.
146
147 Główne możliwości:
148 - szyfrowanie/podpisywanie poczty przy wysyłaniu,
149   odszyfrowywanie/uwierzytelnianie poczty odebranej
150 - obsługa inline-PGP (RFC 2440) i PGP/MIME (RFC 3156)
151 - ustawienia domyślne szyfrowania i podpisywania dla każdego konta
152 - reguły automatycznego wyboru kluczy i włączenia szyfrowania oraz
153   podpisywania dla każdego adresata
154 - interfejs do zarządzania kluczami OpenPGP
155
156 %prep
157 %setup -qc
158 mv -f comm-1.9.2 mozilla
159 %setup -q -T -D -a2
160 cd mozilla
161 %{?with_enigmail:tar xvfz %{SOURCE1} -C mailnews/extensions}
162 /bin/sh %{SOURCE3}
163 %patch0 -p1
164 %{?with_enigmail:%patch1 -p1}
165 %patch2 -p1
166 %patch3 -p1
167 %patch4 -p1
168 %patch5 -p1
169 %patch6 -p1
170 %patch7 -p1
171 %patch8 -p0
172 %patch9 -p0
173
174 %build
175 cd mozilla
176 export CFLAGS="%{rpmcflags} `%{_bindir}/pkg-config mozilla-nspr --cflags-only-I`"
177 export CXXFLAGS="%{rpmcflags} `%{_bindir}/pkg-config mozilla-nspr --cflags-only-I`"
178
179 cp -f %{_datadir}/automake/config.* mozilla/build/autoconf
180 cp -f %{_datadir}/automake/config.* mozilla/nsprpub/build/autoconf
181 cp -f %{_datadir}/automake/config.* directory/c-sdk/config/autoconf
182
183 install -d libxul-sdk
184 ln -snf %{_libdir}/xulrunner-sdk libxul-sdk/sdk
185
186 cat << EOF > .mozconfig
187 mk_add_options MOZ_OBJDIR=@TOPSRCDIR@/obj-%{_target_cpu}
188
189 # Options for 'configure' (same as command-line options).
190 ac_add_options --prefix=%{_prefix}
191 ac_add_options --exec-prefix=%{_exec_prefix}
192 ac_add_options --bindir=%{_bindir}
193 ac_add_options --sbindir=%{_sbindir}
194 ac_add_options --sysconfdir=%{_sysconfdir}
195 ac_add_options --datadir=%{_datadir}
196 ac_add_options --includedir=%{_includedir}
197 ac_add_options --libdir=%{_libdir}
198 ac_add_options --libexecdir=%{_libexecdir}
199 ac_add_options --localstatedir=%{_localstatedir}
200 ac_add_options --sharedstatedir=%{_sharedstatedir}
201 ac_add_options --mandir=%{_mandir}
202 ac_add_options --infodir=%{_infodir}
203 %if %{?debug:1}0
204 ac_add_options --disable-optimize
205 ac_add_options --enable-debug
206 ac_add_options --enable-debug-modules
207 ac_add_options --enable-debugger-info-modules
208 ac_add_options --enable-crash-on-assert
209 %else
210 ac_add_options --disable-debug
211 ac_add_options --disable-debug-modules
212 ac_add_options --disable-logging
213 ac_add_options --enable-optimize="%{rpmcflags} -Os"
214 %endif
215 ac_add_options --disable-strip
216 ac_add_options --disable-strip-libs
217 %if %{with tests}
218 ac_add_options --enable-tests
219 %else
220 ac_add_options --disable-tests
221 %endif
222 %if %{with gnomeui}
223 ac_add_options --enable-gnomeui
224 %else
225 ac_add_options --disable-gnomeui
226 %endif
227 %if %{with gnomevfs}
228 ac_add_options --enable-gnomevfs
229 %else
230 ac_add_options --disable-gnomevfs
231 %endif
232 %if %{with ldap}
233 ac_add_options --enable-ldap
234 ac_add_options --with-system-ldap
235 %else
236 ac_add_options --disable-ldap
237 %endif
238 ac_add_options --disable-crashreporter
239 ac_add_options --disable-xterm-updates
240 ac_add_options --enable-postscript
241 %if %{with lightning}
242 ac_add_options --enable-calendar
243 %else
244 ac_add_options --disable-calendar
245 %endif
246 ac_add_options --disable-installer
247 ac_add_options --disable-jsd
248 ac_add_options --disable-updater
249 ac_add_options --disable-xprint
250 ac_add_options --disable-permissions
251 ac_add_options --disable-pref-extensions
252 ac_add_options --enable-canvas
253 ac_add_options --enable-crypto
254 ac_add_options --enable-mathml
255 ac_add_options --enable-pango
256 ac_add_options --enable-reorder
257 ac_add_options --enable-startup-notification
258 ac_add_options --enable-svg
259 ac_add_options --enable-system-cairo
260 ac_add_options --enable-system-hunspell
261 ac_add_options --enable-system-sqlite
262 ac_add_options --enable-xft
263 ac_add_options --enable-application=mail
264 ac_add_options --enable-default-toolkit=cairo-gtk2
265 ac_add_options --enable-xinerama
266 ac_add_options --with-distribution-id=org.pld-linux
267 ac_add_options --with-branding=icedove/branding
268 %if %{with xulrunner}
269 ac_add_options --with-libxul-sdk=$(pwd)/libxul-sdk
270 ac_add_options --enable-shared
271 %else
272 ac_add_options --enable-static
273 %endif
274 ac_add_options --with-pthreads
275 ac_add_options --with-system-bz2
276 ac_add_options --with-system-jpeg
277 ac_add_options --with-system-nspr
278 ac_add_options --with-system-nss
279 ac_add_options --with-system-png
280 ac_add_options --with-system-zlib
281 ac_add_options --enable-single-profile
282 ac_add_options --disable-profilesharing
283 ac_add_options --with-default-mozilla-five-home=%{_libdir}/%{name}
284 EOF
285
286 %{__make} -j1 -f client.mk build \
287         STRIP="/bin/true" \
288         CC="%{__cc}" \
289         CXX="%{__cxx}"
290
291 %if %{with enigmail}
292 cd mailnews/extensions/enigmail
293 ./makemake -r
294 %{__make} -C ../../../obj-%{_target_cpu}/mailnews/extensions/enigmail \
295         STRIP="/bin/true" \
296         CC="%{__cc}" \
297         CXX="%{__cxx}"
298 %endif
299
300 %install
301 rm -rf $RPM_BUILD_ROOT
302 install -d $RPM_BUILD_ROOT{%{_bindir},%{_libdir},%{_pixmapsdir},%{_desktopdir}} \
303                $RPM_BUILD_ROOT%{_datadir}/%{name}
304 install -d $RPM_BUILD_ROOT%{_libdir}/%{name}
305
306 cd mozilla
307 %{__make} -C obj-%{_target_cpu}/mail/installer stage-package \
308         DESTDIR=$RPM_BUILD_ROOT \
309         MOZ_PKG_APPDIR=%{_libdir}/%{name} \
310         PKG_SKIP_STRIP=1
311
312 # move arch independant ones to datadir
313 mv $RPM_BUILD_ROOT%{_libdir}/%{name}/chrome $RPM_BUILD_ROOT%{_datadir}/%{name}/chrome
314 mv $RPM_BUILD_ROOT%{_libdir}/%{name}/defaults $RPM_BUILD_ROOT%{_datadir}/%{name}/defaults
315 mv $RPM_BUILD_ROOT%{_libdir}/%{name}/greprefs $RPM_BUILD_ROOT%{_datadir}/%{name}/greprefs
316 mv $RPM_BUILD_ROOT%{_libdir}/%{name}/isp $RPM_BUILD_ROOT%{_datadir}/%{name}/isp
317 mv $RPM_BUILD_ROOT%{_libdir}/%{name}/res $RPM_BUILD_ROOT%{_datadir}/%{name}/res
318 ln -s ../../share/%{name}/chrome $RPM_BUILD_ROOT%{_libdir}/%{name}/chrome
319 ln -s ../../share/%{name}/defaults $RPM_BUILD_ROOT%{_libdir}/%{name}/defaults
320 ln -s ../../share/%{name}/greprefs $RPM_BUILD_ROOT%{_libdir}/%{name}/greprefs
321 ln -s ../../share/%{name}/isp $RPM_BUILD_ROOT%{_libdir}/%{name}/isp
322 ln -s ../../share/%{name}/res $RPM_BUILD_ROOT%{_libdir}/%{name}/res
323
324 rm -rf $RPM_BUILD_ROOT%{_libdir}/%{name}/dictionaries
325 ln -s %{_datadir}/myspell $RPM_BUILD_ROOT%{_libdir}/%{name}/dictionaries
326
327 %{__sed} -e 's,@LIBDIR@,%{_libdir},' %{SOURCE5} > $RPM_BUILD_ROOT%{_bindir}/icedove
328 ln -s %{name} $RPM_BUILD_ROOT%{_bindir}/thunderbird
329 ln -s %{name} $RPM_BUILD_ROOT%{_bindir}/mozilla-thunderbird
330
331 install %{SOURCE4} $RPM_BUILD_ROOT%{_desktopdir}/%{name}.desktop
332
333 %if %{with enigmail}
334 ext_dir=$RPM_BUILD_ROOT%{_libdir}/%{name}/extensions/\{847b3a00-7ab1-11d4-8f02-006008948af5\}
335 install -d $ext_dir/{chrome,components,defaults/preferences}
336 mv -f $RPM_BUILD_ROOT%{_libdir}/%{name}/chrome/enigmail.jar $ext_dir/chrome
337 mv -f $RPM_BUILD_ROOT%{_libdir}/%{name}/components/enig* $ext_dir/components
338 mv -f $RPM_BUILD_ROOT%{_libdir}/%{name}/components/libenigmime.so $ext_dir/components
339 mv -f $RPM_BUILD_ROOT%{_libdir}/%{name}/components/ipc.xpt $ext_dir/components
340 mv -f $RPM_BUILD_ROOT%{_libdir}/%{name}/defaults/preferences/enigmail.js $ext_dir/defaults/preferences
341 cp -f mailnews/extensions/enigmail/package/install.rdf $ext_dir
342 rm -rf $RPM_BUILD_ROOT%{_libdir}/%{name}/defaults/preferences
343 rm -f $RPM_BUILD_ROOT%{_libdir}/%{name}/chrome/enigmail-en-US.jar
344 rm -f $RPM_BUILD_ROOT%{_libdir}/%{name}/chrome/enigmail-skin.jar
345 rm -f $RPM_BUILD_ROOT%{_libdir}/%{name}/chrome/enigmime.jar
346 rm -rf $RPM_BUILD_ROOT%{_libdir}/%{name}/components/enig*
347 rm -f $RPM_BUILD_ROOT%{_libdir}/%{name}/components/libenigmime.so
348 rm -f $RPM_BUILD_ROOT%{_libdir}/%{name}/components/ipc.xpt
349 cp -f %{SOURCE6} $ext_dir/chrome.manifest
350 cp -f icedove/branding/content/icon64.png $RPM_BUILD_ROOT%{_pixmapsdir}/icedove.png
351 %endif
352
353 # remove unecessary stuff
354 rm $RPM_BUILD_ROOT%{_libdir}/%{name}/README.txt
355
356 # never package these
357 # nss
358 rm -f $RPM_BUILD_ROOT%{_libdir}/%{name}/lib{freebl3,nss3,nssckbi,nssdbm3,nssutil3,smime3,softokn3,ssl3}.*
359 # nspr
360 rm -f $RPM_BUILD_ROOT%{_libdir}/%{name}/lib{nspr4,plc4,plds4}.so
361 # mozldap
362 rm -f $RPM_BUILD_ROOT%{_libdir}/%{name}/lib{ldap,ldif,prldap,ssldap}60.so
363
364 %clean
365 rm -rf $RPM_BUILD_ROOT
366
367 %pretrans
368 if [ -d %{_libdir}/%{name}/dictionaries ] && [ ! -L %{_libdir}/%{name}/dictionaries ]; then
369         mv -v %{_libdir}/%{name}/dictionaries{,.rpmsave}
370 fi
371 for d in chrome defaults greprefs icons isp res; do
372         if [ -d %{_libdir}/%{name}/$d ] && [ ! -L %{_libdir}/%{name}/$d ]; then
373                 install -d %{_datadir}/%{name}
374                 mv %{_libdir}/%{name}/$d %{_datadir}/%{name}/$d
375         fi
376 done
377 exit 0
378
379 %files
380 %defattr(644,root,root,755)
381 %attr(755,root,root) %{_bindir}/icedove
382 %attr(755,root,root) %{_bindir}/mozilla-thunderbird
383 %attr(755,root,root) %{_bindir}/thunderbird
384 %dir %{_libdir}/%{name}
385 %{_libdir}/%{name}/*.ini
386 %dir %{_libdir}/%{name}/components
387 %attr(755,root,root) %{_libdir}/%{name}/components/*.so
388 %{_libdir}/%{name}/components/*.js
389 %{_libdir}/%{name}/components/*.xpt
390 %attr(755,root,root) %{_libdir}/%{name}/libmozjs.so
391 %attr(755,root,root) %{_libdir}/%{name}/libxpcom.so
392 %attr(755,root,root) %{_libdir}/%{name}/libxpcom_core.so
393 %attr(755,root,root) %{_libdir}/%{name}/*.sh
394 %attr(755,root,root) %{_libdir}/%{name}/*-bin
395 %attr(755,root,root) %{_libdir}/%{name}/mozilla-xremote-client
396 %attr(755,root,root) %{_libdir}/%{name}/icedove
397
398 # symlinks
399 %{_libdir}/%{name}/chrome
400 %{_libdir}/%{name}/defaults
401 %{_libdir}/%{name}/dictionaries
402 %{_libdir}/%{name}/greprefs
403 %{_libdir}/%{name}/isp
404 %{_libdir}/%{name}/res
405
406 %{_libdir}/%{name}/dependentlibs.list
407 %{_pixmapsdir}/*.png
408 %{_desktopdir}/*.desktop
409
410 %dir %{_datadir}/%{name}
411 %{_datadir}/%{name}/chrome
412 %{_datadir}/%{name}/defaults
413 %{_datadir}/%{name}/greprefs
414 %{_datadir}/%{name}/isp
415 %{_datadir}/%{name}/res
416
417 %dir %{_libdir}/%{name}/modules
418 %{_libdir}/%{name}/modules/*.js*
419 %dir %{_libdir}/%{name}/modules/activity
420 %{_libdir}/%{name}/modules/activity/*.js
421 %dir %{_libdir}/%{name}/modules/gloda
422 %{_libdir}/%{name}/modules/gloda/*.js
423
424 %dir %{_libdir}/%{name}/extensions
425 %{_libdir}/%{name}/extensions/{972ce4c6-7e08-4474-a285-3208198ce6fd}
426
427 %if %{with lightning}
428 %files addon-lightning
429 %defattr(644,root,root,755)
430 %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}
431 %{_libdir}/%{name}/extensions/calendar-timezones@mozilla.org
432 %endif
433
434 %if %{with enigmail}
435 %files addon-enigmail
436 %defattr(644,root,root,755)
437 %{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}
438 %endif
This page took 0.068197 seconds and 4 git commands to generate.