]> git.pld-linux.org Git - packages/thunderbird.git/blob - icedove.spec
- xulrunner vs static conflict each other
[packages/thunderbird.git] / icedove.spec
1 # TODO:
2 # - separate spec for enigmail
3 # - fix icedove (building) and installing nss/nspr libs!
4 # - build with system mozldap
5 #
6 # Conditional builds
7 %bcond_without  enigmail        # don't build enigmail - GPG/PGP support
8 %bcond_without  gnomeui         # disable gnomeui support
9 %bcond_without  gnomevfs        # disable GNOME comp. (gconf+libgnome+gnomevfs) and gnomevfs ext.
10 %bcond_without  gnome           # disable all GNOME components (gnome+gnomeui+gnomevfs)
11 %bcond_without  ldap            # disable e-mail address lookups in LDAP directories
12 %bcond_without  lightning       # disable sunbird calendar
13 %bcond_with             xulrunner       # build with system xulrunner
14
15 %if %{without gnome}
16 %undefine       with_gnomeui
17 %undefine       with_gnomevfs
18 %endif
19
20 %define         enigmail_ver            1.0.1
21
22 %if %{without xulrunner}
23 # The actual sqlite version (see RHBZ#480989):
24 %define         sqlite_build_version %(pkg-config --silence-errors --modversion sqlite3 2>/dev/null || echo ERROR)
25 %endif
26
27 Summary:        Icedove - email client
28 Summary(pl.UTF-8):      Icedove - klient poczty
29 Name:           icedove
30 Version:        3.0.4
31 Release:        4
32 License:        MPL 1.1 or GPL v2+ or LGPL v2.1+
33 Group:          Applications/Networking
34 Source0:        http://releases.mozilla.org/pub/mozilla.org/thunderbird/releases/%{version}/source/thunderbird-%{version}.source.tar.bz2
35 # Source0-md5:  bb87ca7e62d5869422137765126798be
36 Source1:        http://www.mozilla-enigmail.org/download/source/enigmail-%{enigmail_ver}.tar.gz
37 # Source1-md5:  508ca9ab0396afb49e82eda88014924b
38 Source2:        %{name}-branding.tar.bz2
39 # Source2-md5:  2da351522bdd7f4a3bd8aaff4c776976
40 Source3:        %{name}-rm_nonfree.sh
41 Source4:        %{name}.desktop
42 Source5:        %{name}.sh
43 Source6:        %{name}-enigmail.manifest
44 Patch0:         %{name}-branding.patch
45 Patch1:         %{name}-enigmail-shared.patch
46 Patch2:         %{name}-gcc.patch
47 Patch3:         %{name}-fonts.patch
48 Patch4:         %{name}-install.patch
49 Patch5:         %{name}-hunspell.patch
50 Patch6:         %{name}-prefs.patch
51 Patch7:         system-mozldap.patch
52 URL:            http://www.pld-linux.org/Packages/Icedove
53 %{?with_gnomevfs:BuildRequires: GConf2-devel >= 1.2.1}
54 BuildRequires:  automake
55 BuildRequires:  freetype-devel >= 1:2.1.8
56 %{?with_gnomevfs:BuildRequires: gnome-vfs2-devel >= 2.0}
57 BuildRequires:  gtk+2-devel >= 1:2.0.0
58 BuildRequires:  hunspell-devel
59 BuildRequires:  libIDL-devel >= 0.8.0
60 %{?with_gnomevfs:BuildRequires: libgnome-devel >= 2.0}
61 %{?with_gnomeui:BuildRequires:  libgnomeui-devel >= 2.2.0}
62 BuildRequires:  libjpeg-devel >= 6b
63 BuildRequires:  libpng-devel >= 1.2.0
64 BuildRequires:  libstdc++-devel
65 BuildRequires:  nspr-devel >= 1:4.8
66 BuildRequires:  nss-devel >= 1:3.12.0
67 BuildRequires:  sqlite3-devel
68 BuildRequires:  pango-devel >= 1:1.1.0
69 BuildRequires:  pkgconfig
70 BuildRequires:  sed >= 4.0
71 BuildRequires:  startup-notification-devel >= 0.8
72 BuildRequires:  xorg-lib-libXext-devel
73 BuildRequires:  xorg-lib-libXinerama-devel
74 BuildRequires:  xorg-lib-libXt-devel
75 BuildRequires:  zip
76 %if %{with xulrunner}
77 %else
78 Requires:       myspell-common
79 Requires:       sqlite3 >= %{sqlite_build_version}
80 Requires:       nspr >= 1:4.6.1
81 Requires:       nss >= 1:3.11.3
82 %endif
83 Obsoletes:      mozilla-thunderbird
84 Obsoletes:      mozilla-thunderbird-dictionary-en-US
85 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
86
87 %define         filterout_cpp           -D_FORTIFY_SOURCE=[0-9]+
88
89 # iceweasel/icedove/iceape provide their own versions
90 %define         _noautoreqdep           libgfxpsshar.so libgkgfx.so libgtkxtbin.so libjsj.so libxpcom_compat.so libxpcom_core.so libxpistub.so
91 %define         _noautoprovfiles        %{_libdir}/%{name}/components
92 # we don't want these to satisfy xulrunner-devel
93 %define         _noautoprov             libgtkembedmoz.so libmozjs.so libxpcom.so libxul.so
94 # and as we don't provide them, don't require either
95 %define         _noautoreq              libgtkembedmoz.so libmozjs.so libxpcom.so libxul.so
96
97 %description
98 Icedove is an open-source,fast and portable email client.
99
100 %description -l pl.UTF-8
101 Icedove jest open sourcowym, szybkim i przenośnym klientem poczty.
102
103 %package addon-lightning
104 Summary:        An integrated calendar for Icedove
105 Summary(pl.UTF-8):      Zintegrowany kalendarz dla Icedove
106 License:        MPL 1.1 or GPL v2+ or LGPL v2.1+
107 Group:          Applications/Networking
108 Requires:       %{name} = %{version}-%{release}
109
110 %description addon-lightning
111 Lightning is an calendar extension to Icedove email client.
112
113 %description addon-lightning -l pl.UTF-8
114 Lightning to rozszerzenie do klienta poczty Icedove dodające
115 funkcjonalność kalendarza.
116
117 %package addon-enigmail
118 Summary:        Extension for the authentication and encryption features provided by GnuPG
119 Summary(pl.UTF-8):      Rozszerzenie do uwierzytelniania i szyfrowania zapewnianego przez GnuPG
120 License:        MPL/LGPL
121 Group:          Applications/Networking
122 URL:            http://enigmail.mozdev.org/
123 Requires:       %{name} = %{version}-%{release}
124 Requires:       gnupg
125 Obsoletes:      mozilla-thunderbird-addon-enigmail
126
127 %description addon-enigmail
128 Enigmail is an extension to the Icedove mail client which allows users
129 to access the authentication and encryption features provided by
130 GnuPG.
131
132 Main Features:
133 - Encrypt/sign mail when sending, decrypt/authenticate received mail
134 - Support for inline-PGP (RFC 2440) and PGP/MIME (RFC 3156)
135 - Per-Account based encryption and signing defaults
136 - Per-Recipient rules for automated key selection, and
137   enabling/disabling encryption and signing
138 - OpenPGP key management interface
139
140 %description addon-enigmail -l pl.UTF-8
141 Enigmail to rozszerzenie klienta pocztowego Icedove pozwalające
142 użytkownikom na dostęp do uwierzytelniania i szyfrowania zapewnianego
143 przez GnuPG.
144
145 Główne możliwości:
146 - szyfrowanie/podpisywanie poczty przy wysyłaniu,
147   odszyfrowywanie/uwierzytelnianie poczty odebranej
148 - obsługa inline-PGP (RFC 2440) i PGP/MIME (RFC 3156)
149 - ustawienia domyślne szyfrowania i podpisywania dla każdego konta
150 - reguły automatycznego wyboru kluczy i włączenia szyfrowania oraz
151   podpisywania dla każdego adresata
152 - interfejs do zarządzania kluczami OpenPGP
153
154 %prep
155 %setup -qc
156 mv -f comm-1.9.1 mozilla
157 %setup -q -T -D -a2
158 cd mozilla
159 %{?with_enigmail:tar xvfz %{SOURCE1} -C mailnews/extensions}
160 /bin/sh %{SOURCE3}
161 %patch0 -p1
162 %{?with_enigmail:%patch1 -p1}
163 %patch2 -p1
164 %patch3 -p1
165 %patch4 -p1
166 %patch5 -p1
167 %patch6 -p1
168 %patch7 -p1
169
170 %build
171 cd mozilla
172 export CFLAGS="%{rpmcflags} `%{_bindir}/pkg-config mozilla-nspr --cflags-only-I`"
173 export CXXFLAGS="%{rpmcflags} `%{_bindir}/pkg-config mozilla-nspr --cflags-only-I`"
174
175 cp -f %{_datadir}/automake/config.* mozilla/build/autoconf
176 cp -f %{_datadir}/automake/config.* mozilla/nsprpub/build/autoconf
177 cp -f %{_datadir}/automake/config.* directory/c-sdk/config/autoconf
178
179 install -d libxul-sdk
180 ln -snf %{_libdir}/xulrunner-sdk libxul-sdk/sdk
181
182 cat << EOF > .mozconfig
183 mk_add_options MOZ_OBJDIR=@TOPSRCDIR@/obj-%{_target_cpu}
184
185 # Options for 'configure' (same as command-line options).
186 ac_add_options --prefix=%{_prefix}
187 ac_add_options --exec-prefix=%{_exec_prefix}
188 ac_add_options --bindir=%{_bindir}
189 ac_add_options --sbindir=%{_sbindir}
190 ac_add_options --sysconfdir=%{_sysconfdir}
191 ac_add_options --datadir=%{_datadir}
192 ac_add_options --includedir=%{_includedir}
193 ac_add_options --libdir=%{_libdir}
194 ac_add_options --libexecdir=%{_libexecdir}
195 ac_add_options --localstatedir=%{_localstatedir}
196 ac_add_options --sharedstatedir=%{_sharedstatedir}
197 ac_add_options --mandir=%{_mandir}
198 ac_add_options --infodir=%{_infodir}
199 %if %{?debug:1}0
200 ac_add_options --disable-optimize
201 ac_add_options --enable-debug
202 ac_add_options --enable-debug-modules
203 ac_add_options --enable-debugger-info-modules
204 ac_add_options --enable-crash-on-assert
205 %else
206 ac_add_options --disable-debug
207 ac_add_options --disable-debug-modules
208 ac_add_options --disable-logging
209 ac_add_options --enable-optimize="%{rpmcflags} -Os"
210 %endif
211 ac_add_options --disable-strip
212 ac_add_options --disable-strip-libs
213 %if %{with tests}
214 ac_add_options --enable-tests
215 %else
216 ac_add_options --disable-tests
217 %endif
218 %if %{with gnomeui}
219 ac_add_options --enable-gnomeui
220 %else
221 ac_add_options --disable-gnomeui
222 %endif
223 %if %{with gnomevfs}
224 ac_add_options --enable-gnomevfs
225 %else
226 ac_add_options --disable-gnomevfs
227 %endif
228 %if %{with ldap}
229 ac_add_options --enable-ldap
230 ac_add_options --with-system-ldap
231 %else
232 ac_add_options --disable-ldap
233 %endif
234 ac_add_options --disable-crashreporter
235 ac_add_options --disable-xterm-updates
236 ac_add_options --enable-postscript
237 %if %{with lightning}
238 ac_add_options --enable-calendar
239 %else
240 ac_add_options --disable-calendar
241 %endif
242 ac_add_options --disable-installer
243 ac_add_options --disable-jsd
244 ac_add_options --disable-updater
245 ac_add_options --disable-xprint
246 ac_add_options --disable-permissions
247 ac_add_options --disable-pref-extensions
248 ac_add_options --enable-canvas
249 ac_add_options --enable-crypto
250 ac_add_options --enable-mathml
251 ac_add_options --enable-pango
252 ac_add_options --enable-reorder
253 ac_add_options --enable-startup-notification
254 ac_add_options --enable-svg
255 ac_add_options --enable-system-cairo
256 ac_add_options --enable-system-hunspell
257 ac_add_options --enable-system-sqlite
258 ac_add_options --enable-xft
259 ac_add_options --enable-application=mail
260 ac_add_options --enable-default-toolkit=cairo-gtk2
261 ac_add_options --enable-xinerama
262 ac_add_options --with-distribution-id=org.pld-linux
263 ac_add_options --with-branding=icedove/branding
264 %if %{with xulrunner}
265 ac_add_options --with-libxul-sdk=$(pwd)/libxul-sdk
266 ac_add_options --enable-shared
267 %else
268 ac_add_options --enable-static
269 %endif
270 ac_add_options --with-pthreads
271 ac_add_options --with-system-bz2
272 ac_add_options --with-system-jpeg
273 ac_add_options --with-system-nspr
274 ac_add_options --with-system-nss
275 ac_add_options --with-system-png
276 ac_add_options --with-system-zlib
277 ac_add_options --enable-single-profile
278 ac_add_options --disable-profilesharing
279 ac_add_options --with-default-mozilla-five-home=%{_libdir}/%{name}
280 EOF
281
282 %{__make} -j1 -f client.mk build \
283         STRIP="/bin/true" \
284         CC="%{__cc}" \
285         CXX="%{__cxx}"
286
287 %if %{with enigmail}
288 cd mailnews/extensions/enigmail
289 ./makemake -r
290 %{__make} -C ../../../obj-%{_target_cpu}/mailnews/extensions/enigmail \
291         STRIP="/bin/true" \
292         CC="%{__cc}" \
293         CXX="%{__cxx}"
294 %endif
295
296 %install
297 rm -rf $RPM_BUILD_ROOT
298 install -d $RPM_BUILD_ROOT{%{_bindir},%{_libdir},%{_pixmapsdir},%{_desktopdir}} \
299                $RPM_BUILD_ROOT%{_datadir}/%{name}
300 install -d $RPM_BUILD_ROOT%{_libdir}/%{name}
301
302 cd mozilla
303 %{__make} -C obj-%{_target_cpu}/mail/installer stage-package \
304         DESTDIR=$RPM_BUILD_ROOT \
305         MOZ_PKG_APPDIR=%{_libdir}/%{name} \
306         PKG_SKIP_STRIP=1
307
308 # move arch independant ones to datadir
309 mv $RPM_BUILD_ROOT%{_libdir}/%{name}/chrome $RPM_BUILD_ROOT%{_datadir}/%{name}/chrome
310 mv $RPM_BUILD_ROOT%{_libdir}/%{name}/defaults $RPM_BUILD_ROOT%{_datadir}/%{name}/defaults
311 mv $RPM_BUILD_ROOT%{_libdir}/%{name}/greprefs $RPM_BUILD_ROOT%{_datadir}/%{name}/greprefs
312 mv $RPM_BUILD_ROOT%{_libdir}/%{name}/isp $RPM_BUILD_ROOT%{_datadir}/%{name}/isp
313 mv $RPM_BUILD_ROOT%{_libdir}/%{name}/res $RPM_BUILD_ROOT%{_datadir}/%{name}/res
314 ln -s ../../share/%{name}/chrome $RPM_BUILD_ROOT%{_libdir}/%{name}/chrome
315 ln -s ../../share/%{name}/defaults $RPM_BUILD_ROOT%{_libdir}/%{name}/defaults
316 ln -s ../../share/%{name}/greprefs $RPM_BUILD_ROOT%{_libdir}/%{name}/greprefs
317 ln -s ../../share/%{name}/isp $RPM_BUILD_ROOT%{_libdir}/%{name}/isp
318 ln -s ../../share/%{name}/res $RPM_BUILD_ROOT%{_libdir}/%{name}/res
319
320 rm -rf $RPM_BUILD_ROOT%{_libdir}/%{name}/dictionaries
321 ln -s %{_datadir}/myspell $RPM_BUILD_ROOT%{_libdir}/%{name}/dictionaries
322
323 %{__sed} -e 's,@LIBDIR@,%{_libdir},' %{SOURCE5} > $RPM_BUILD_ROOT%{_bindir}/icedove
324 ln -s %{name} $RPM_BUILD_ROOT%{_bindir}/thunderbird
325 ln -s %{name} $RPM_BUILD_ROOT%{_bindir}/mozilla-thunderbird
326
327 install %{SOURCE4} $RPM_BUILD_ROOT%{_desktopdir}/%{name}.desktop
328
329 %if %{with enigmail}
330 ext_dir=$RPM_BUILD_ROOT%{_libdir}/%{name}/extensions/\{847b3a00-7ab1-11d4-8f02-006008948af5\}
331 install -d $ext_dir/{chrome,components,defaults/preferences}
332 mv -f $RPM_BUILD_ROOT%{_libdir}/%{name}/chrome/enigmail.jar $ext_dir/chrome
333 mv -f $RPM_BUILD_ROOT%{_libdir}/%{name}/components/enig* $ext_dir/components
334 mv -f $RPM_BUILD_ROOT%{_libdir}/%{name}/components/libenigmime.so $ext_dir/components
335 mv -f $RPM_BUILD_ROOT%{_libdir}/%{name}/components/ipc.xpt $ext_dir/components
336 mv -f $RPM_BUILD_ROOT%{_libdir}/%{name}/defaults/preferences/enigmail.js $ext_dir/defaults/preferences
337 cp -f mailnews/extensions/enigmail/package/install.rdf $ext_dir
338 rm -rf $RPM_BUILD_ROOT%{_libdir}/%{name}/defaults/preferences
339 rm -f $RPM_BUILD_ROOT%{_libdir}/%{name}/chrome/enigmail-en-US.jar
340 rm -f $RPM_BUILD_ROOT%{_libdir}/%{name}/chrome/enigmail-skin.jar
341 rm -f $RPM_BUILD_ROOT%{_libdir}/%{name}/chrome/enigmime.jar
342 rm -rf $RPM_BUILD_ROOT%{_libdir}/%{name}/components/enig*
343 rm -f $RPM_BUILD_ROOT%{_libdir}/%{name}/components/libenigmime.so
344 rm -f $RPM_BUILD_ROOT%{_libdir}/%{name}/components/ipc.xpt
345 cp -f %{SOURCE6} $ext_dir/chrome.manifest
346 cp -f icedove/branding/content/icon64.png $RPM_BUILD_ROOT%{_pixmapsdir}/icedove.png
347 %endif
348
349 # remove unecessary stuff
350 rm $RPM_BUILD_ROOT%{_libdir}/%{name}/README.txt
351
352 # never package these
353 # nss
354 rm -f $RPM_BUILD_ROOT%{_libdir}/%{name}/lib{freebl3,nss3,nssckbi,nssdbm3,nssutil3,smime3,softokn3,ssl3}.*
355 # nspr
356 rm -f $RPM_BUILD_ROOT%{_libdir}/%{name}/lib{nspr4,plc4,plds4}.so
357 # mozldap
358 rm -f $RPM_BUILD_ROOT%{_libdir}/%{name}/lib{ldap,ldif,prldap,ssldap}60.so
359
360 %clean
361 rm -rf $RPM_BUILD_ROOT
362
363 %pretrans
364 if [ -d %{_libdir}/%{name}/dictionaries ] && [ ! -L %{_libdir}/%{name}/dictionaries ]; then
365         mv -v %{_libdir}/%{name}/dictionaries{,.rpmsave}
366 fi
367 for d in chrome defaults greprefs icons isp res; do
368         if [ -d %{_libdir}/%{name}/$d ] && [ ! -L %{_libdir}/%{name}/$d ]; then
369                 install -d %{_datadir}/%{name}
370                 mv %{_libdir}/%{name}/$d %{_datadir}/%{name}/$d
371         fi
372 done
373 exit 0
374
375 %files
376 %defattr(644,root,root,755)
377 %attr(755,root,root) %{_bindir}/icedove
378 %attr(755,root,root) %{_bindir}/mozilla-thunderbird
379 %attr(755,root,root) %{_bindir}/thunderbird
380 %dir %{_libdir}/%{name}
381 %{_libdir}/%{name}/*.ini
382 %dir %{_libdir}/%{name}/components
383 %attr(755,root,root) %{_libdir}/%{name}/components/*.so
384 %{_libdir}/%{name}/components/*.js
385 %{_libdir}/%{name}/components/*.xpt
386 %attr(755,root,root) %{_libdir}/%{name}/libmozjs.so
387 %attr(755,root,root) %{_libdir}/%{name}/libxpcom.so
388 %attr(755,root,root) %{_libdir}/%{name}/libxpcom_core.so
389 %attr(755,root,root) %{_libdir}/%{name}/*.sh
390 %attr(755,root,root) %{_libdir}/%{name}/*-bin
391 %attr(755,root,root) %{_libdir}/%{name}/mozilla-xremote-client
392 %attr(755,root,root) %{_libdir}/%{name}/icedove
393
394 # symlinks
395 %{_libdir}/%{name}/chrome
396 %{_libdir}/%{name}/defaults
397 %{_libdir}/%{name}/dictionaries
398 %{_libdir}/%{name}/greprefs
399 %{_libdir}/%{name}/isp
400 %{_libdir}/%{name}/res
401
402 %{_libdir}/%{name}/dependentlibs.list
403 %{_pixmapsdir}/*.png
404 %{_desktopdir}/*.desktop
405
406 %dir %{_datadir}/%{name}
407 %{_datadir}/%{name}/chrome
408 %{_datadir}/%{name}/defaults
409 %{_datadir}/%{name}/greprefs
410 %{_datadir}/%{name}/isp
411 %{_datadir}/%{name}/res
412
413 %dir %{_libdir}/%{name}/modules
414 %{_libdir}/%{name}/modules/*.js*
415 %dir %{_libdir}/%{name}/modules/activity
416 %{_libdir}/%{name}/modules/activity/*.js
417 %dir %{_libdir}/%{name}/modules/gloda
418 %{_libdir}/%{name}/modules/gloda/*.js
419
420 %dir %{_libdir}/%{name}/extensions
421 %{_libdir}/%{name}/extensions/{972ce4c6-7e08-4474-a285-3208198ce6fd}
422
423 %if %{with lightning}
424 %files addon-lightning
425 %defattr(644,root,root,755)
426 %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}
427 %{_libdir}/%{name}/extensions/calendar-timezones@mozilla.org
428 %endif
429
430 %if %{with enigmail}
431 %files addon-enigmail
432 %defattr(644,root,root,755)
433 %{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}
434 %endif
This page took 0.058991 seconds and 4 git commands to generate.