]> git.pld-linux.org Git - packages/thunderbird.git/blob - icedove.spec
- fixed build with libpng, thx arekm
[packages/thunderbird.git] / icedove.spec
1 #
2 # TODO:
3 # - CHECK all features of enigmail
4 # - separate spec for enigmail
5 # - update or remove -myspell.patch
6 # - package unpackaged files
7 # - update branding patch!!!
8 #
9 # Conditional builds
10 %bcond_without  enigmail        # don't build enigmail - GPG/PGP support
11 %bcond_without  gnomeui         # disable gnomeui support
12 %bcond_without  gnomevfs        # disable GNOME comp. (gconf+libgnome+gnomevfs) and gnomevfs ext.
13 %bcond_without  gnome           # disable all GNOME components (gnome+gnomeui+gnomevfs)
14 %bcond_without  ldap            # disable e-mail address lookups in LDAP directories
15 %bcond_without  lightning   # disable sunbird calendar
16 #
17 %if %{without gnome}
18 %undefine       with_gnomeui
19 %undefine       with_gnomevfs
20 %endif
21 %define         enigmail_ver            1.0.0
22
23 Summary:        Icedove - email client
24 Summary(pl.UTF-8):      Icedove - klient poczty
25 Name:           icedove
26 Version:        3.0.1
27 Release:        0.2
28 License:        MPL 1.1 or GPL v2+ or LGPL v2.1+
29 Group:          Applications/Networking
30 Source0:        http://releases.mozilla.org/pub/mozilla.org/thunderbird/releases/%{version}/source/thunderbird-%{version}.source.tar.bz2
31 # Source0-md5:  f004aa5ddf2a30b5df96e06df416b0c9
32 Source1:        http://www.mozilla-enigmail.org/download/source/enigmail-%{enigmail_ver}.tar.gz
33 # Source1-md5:  e3a6d379f1a72ac023751bdde2de750a
34 Source2:        %{name}-branding.tar.bz2
35 # Source2-md5:  e775b8cb658de32f30b403bc9b7950bf
36 Source3:        %{name}-rm_nonfree.sh
37 Source4:        %{name}.desktop
38 Source5:        %{name}.sh
39 Source6:        %{name}-enigmail.manifest
40 Patch0:         %{name}-branding.patch
41 Patch1:         %{name}-enigmail-shared.patch
42 Patch2:         %{name}-gcc.patch
43 Patch3:         %{name}-fonts.patch
44 Patch4:         %{name}-install.patch
45 Patch5:         %{name}-myspell.patch
46 Patch6:         %{name}-prefs.patch
47 Patch7:         %{name}-breakpad.patch
48 Patch8:         %{name}-libpng.patch
49 URL:            http://www.pld-linux.org/Packages/Icedove
50 %{?with_gnomevfs:BuildRequires: GConf2-devel >= 1.2.1}
51 BuildRequires:  automake
52 BuildRequires:  freetype-devel >= 1:2.1.8
53 %{?with_gnomevfs:BuildRequires: gnome-vfs2-devel >= 2.0}
54 BuildRequires:  gtk+2-devel >= 1:2.0.0
55 BuildRequires:  libIDL-devel >= 0.8.0
56 %{?with_gnomevfs:BuildRequires: libgnome-devel >= 2.0}
57 %{?with_gnomeui:BuildRequires:  libgnomeui-devel >= 2.2.0}
58 BuildRequires:  libjpeg-devel >= 6b
59 BuildRequires:  libpng-devel >= 1.2.0
60 BuildRequires:  libstdc++-devel
61 BuildRequires:  myspell-devel
62 BuildRequires:  nspr-devel >= 1:4.8
63 BuildRequires:  nss-devel >= 1:3.12.0
64 BuildRequires:  pango-devel >= 1:1.1.0
65 BuildRequires:  pkgconfig
66 BuildRequires:  sed >= 4.0
67 BuildRequires:  startup-notification-devel >= 0.8
68 BuildRequires:  xorg-lib-libXext-devel
69 BuildRequires:  xorg-lib-libXft-devel >= 2.1
70 BuildRequires:  xorg-lib-libXinerama-devel
71 BuildRequires:  xorg-lib-libXp-devel
72 BuildRequires:  xorg-lib-libXt-devel
73 BuildRequires:  zip
74 Requires:       myspell-common
75 Requires:       nspr >= 1:4.6.1
76 Requires:       nss >= 1:3.11.3
77 Obsoletes:      mozilla-thunderbird
78 Obsoletes:      mozilla-thunderbird-dictionary-en-US
79 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
80
81 %define         filterout_cpp           -D_FORTIFY_SOURCE=[0-9]+
82
83 # iceweasel/icedove/iceape provide their own versions
84 %define         _noautoreqdep           libgfxpsshar.so libgkgfx.so libgtkxtbin.so libjsj.so libxpcom_compat.so libxpcom_core.so libxpistub.so
85 %define         _noautoprovfiles        %{_libdir}/%{name}/components
86 # we don't want these to satisfy xulrunner-devel
87 %define         _noautoprov             libgtkembedmoz.so libldap50.so libmozjs.so libprldap50.so libssldap50.so libxpcom.so libxul.so
88 # and as we don't provide them, don't require either
89 %define         _noautoreq              libgtkembedmoz.so libldap50.so libmozjs.so libprldap50.so libssldap50.so libxpcom.so libxul.so
90
91 %description
92 Icedove is an open-source,fast and portable email client.
93
94 %description -l pl.UTF-8
95 Icedove jest open sourcowym, szybkim i przenośnym klientem poczty.
96
97 %package addon-enigmail
98 Summary:        Extension for the authentication and encryption features provided by GnuPG
99 Summary(pl.UTF-8):      Rozszerzenie do uwierzytelniania i szyfrowania zapewnianego przez GnuPG
100 License:        MPL/LGPL
101 Group:          Applications/Networking
102 URL:            http://enigmail.mozdev.org/
103 Requires:       %{name} = %{version}-%{release}
104 Requires:       gnupg
105 Obsoletes:      mozilla-thunderbird-addon-enigmail
106
107 %description addon-enigmail
108 Enigmail is an extension to the Icedove mail client which allows users
109 to access the authentication and encryption features provided by
110 GnuPG.
111
112 Main Features:
113 - Encrypt/sign mail when sending, decrypt/authenticate received mail
114 - Support for inline-PGP (RFC 2440) and PGP/MIME (RFC 3156)
115 - Per-Account based encryption and signing defaults
116 - Per-Recipient rules for automated key selection, and
117   enabling/disabling encryption and signing
118 - OpenPGP key management interface
119
120 %description addon-enigmail -l pl.UTF-8
121 Enigmail to rozszerzenie klienta pocztowego Icedove pozwalające
122 użytkownikom na dostęp do uwierzytelniania i szyfrowania zapewnianego
123 przez GnuPG.
124
125 Główne możliwości:
126 - szyfrowanie/podpisywanie poczty przy wysyłaniu,
127   odszyfrowywanie/uwierzytelnianie poczty odebranej
128 - obsługa inline-PGP (RFC 2440) i PGP/MIME (RFC 3156)
129 - ustawienia domyślne szyfrowania i podpisywania dla każdego konta
130 - reguły automatycznego wyboru kluczy i włączenia szyfrowania oraz
131   podpisywania dla każdego adresata
132 - interfejs do zarządzania kluczami OpenPGP
133
134 %prep
135 %setup -q -c -a2
136 cd comm-1.9.1
137 %{?with_enigmail:tar xvfz %{SOURCE1} -C mailnews/extensions}
138 /bin/sh %{SOURCE3}
139 %patch0 -p2
140 %{?with_enigmail:%patch1 -p1}
141 %patch2 -p1
142 %patch3 -p1
143 %patch4 -p1
144 #%patch5 -p1
145 %patch6 -p0
146 %patch7 -p1
147 %patch8 -p1
148
149 %build
150 cd comm-1.9.1
151 export CFLAGS="%{rpmcflags} `%{_bindir}/pkg-config mozilla-nspr --cflags-only-I`"
152 export CXXFLAGS="%{rpmcflags} `%{_bindir}/pkg-config mozilla-nspr --cflags-only-I`"
153
154 cp -f %{_datadir}/automake/config.* mozilla/build/autoconf
155 cp -f %{_datadir}/automake/config.* mozilla/nsprpub/build/autoconf
156 cp -f %{_datadir}/automake/config.* directory/c-sdk/config/autoconf
157
158 cat << 'EOF' > .mozconfig
159 mk_add_options MOZ_OBJDIR=@TOPSRCDIR@/obj-%{_target_cpu}
160
161 # Options for 'configure' (same as command-line options).
162 ac_add_options --prefix=%{_prefix}
163 ac_add_options --exec-prefix=%{_exec_prefix}
164 ac_add_options --bindir=%{_bindir}
165 ac_add_options --sbindir=%{_sbindir}
166 ac_add_options --sysconfdir=%{_sysconfdir}
167 ac_add_options --datadir=%{_datadir}
168 ac_add_options --includedir=%{_includedir}
169 ac_add_options --libdir=%{_libdir}
170 ac_add_options --libexecdir=%{_libexecdir}
171 ac_add_options --localstatedir=%{_localstatedir}
172 ac_add_options --sharedstatedir=%{_sharedstatedir}
173 ac_add_options --mandir=%{_mandir}
174 ac_add_options --infodir=%{_infodir}
175 %if %{?debug:1}0
176 ac_add_options --disable-optimize
177 ac_add_options --enable-debug
178 ac_add_options --enable-debug-modules
179 ac_add_options --enable-debugger-info-modules
180 ac_add_options --enable-crash-on-assert
181 %else
182 ac_add_options --disable-debug
183 ac_add_options --disable-debug-modules
184 ac_add_options --disable-logging
185 ac_add_options --enable-optimize="%{rpmcflags} -Os"
186 %endif
187 %if %{with tests}
188 ac_add_options --enable-tests
189 %else
190 ac_add_options --disable-tests
191 %endif
192 %if %{with gnomeui}
193 ac_add_options --enable-gnomeui
194 %else
195 ac_add_options --disable-gnomeui
196 %endif
197 %if %{with gnomevfs}
198 ac_add_options --enable-gnomevfs
199 %else
200 ac_add_options --disable-gnomevfs
201 %endif
202 %if %{with ldap}
203 ac_add_options --enable-ldap
204 %else
205 ac_add_options --disable-ldap
206 %endif
207 ac_add_options --disable-crashreporter
208 ac_add_options --disable-updater
209 ac_add_options --disable-xterm-updates
210 ac_add_options --enable-ldap
211 ac_add_options --enable-postscript
212 ac_add_options --enable-startup-notification
213 %if %{with lightning}
214 ac_add_options --enable-calendar
215 %else
216 ac_add_options --disable-calendar
217 %endif
218 ac_add_options --disable-installer
219 ac_add_options --disable-jsd
220 ac_add_options --disable-xprint
221 ac_add_options --disable-permissions
222 ac_add_options --disable-pref-extensions
223 ac_add_options --enable-canvas
224 ac_add_options --enable-crypto
225 ac_add_options --enable-default-toolkit="gtk2"
226 ac_add_options --enable-mathml
227 ac_add_options --enable-optimize="%{rpmcflags}"
228 ac_add_options --enable-pango
229 ac_add_options --enable-reorder
230 ac_add_options --enable-static
231 ac_add_options --disable-strip
232 ac_add_options --disable-strip-libs
233 ac_add_options --enable-system-cairo
234 ac_add_options --enable-system-myspell
235 ac_add_options --enable-svg
236 ac_add_options --enable-xft
237 ac_add_options --enable-application=mail
238 ac_add_options --enable-default-toolkit=cairo-gtk2
239 ac_add_options --enable-xinerama
240 ac_add_options --with-system-jpeg
241 ac_add_options --with-system-nspr
242 ac_add_options --with-system-nss
243 ac_add_options --with-system-png
244 ac_add_options --with-system-zlib
245 ac_add_options --with-pthreads
246 ac_add_options --enable-single-profile
247 ac_add_options --disable-profilesharing
248 ac_add_options --with-distribution-id=org.pld-linux
249 #ac_add_options --with-branding=icedove/branding
250 ac_add_options --with-default-mozilla-five-home=%{_libdir}/%{name}
251 EOF
252
253 %{__make} -j1 -f client.mk build \
254         STRIP="/bin/true" \
255         CC="%{__cc}" \
256         CXX="%{__cxx}"
257
258 %if %{with enigmail}
259 cd mailnews/extensions/enigmail
260 ./makemake -r
261 %{__make} -C ../../../obj-%{_target_cpu}/mailnews/extensions/enigmail \
262         STRIP="/bin/true" \
263         CC="%{__cc}" \
264         CXX="%{__cxx}"
265 %endif
266
267 %install
268 rm -rf $RPM_BUILD_ROOT
269 install -d $RPM_BUILD_ROOT{%{_bindir},%{_libdir},%{_pixmapsdir},%{_desktopdir}} \
270                $RPM_BUILD_ROOT%{_datadir}/%{name}
271 install -d $RPM_BUILD_ROOT%{_libdir}/%{name}
272
273 cd comm-1.9.1
274 %{__make} -C obj-%{_target_cpu}/mail/installer stage-package \
275         DESTDIR=$RPM_BUILD_ROOT \
276         MOZ_PKG_APPDIR=%{_libdir}/%{name} \
277         PKG_SKIP_STRIP=1
278
279 # move arch independant ones to datadir
280 mv $RPM_BUILD_ROOT%{_libdir}/%{name}/chrome $RPM_BUILD_ROOT%{_datadir}/%{name}/chrome
281 mv $RPM_BUILD_ROOT%{_libdir}/%{name}/defaults $RPM_BUILD_ROOT%{_datadir}/%{name}/defaults
282 mv $RPM_BUILD_ROOT%{_libdir}/%{name}/greprefs $RPM_BUILD_ROOT%{_datadir}/%{name}/greprefs
283 #mv $RPM_BUILD_ROOT%{_libdir}/%{name}/icons $RPM_BUILD_ROOT%{_datadir}/%{name}/icons
284 mv $RPM_BUILD_ROOT%{_libdir}/%{name}/isp $RPM_BUILD_ROOT%{_datadir}/%{name}/isp
285 mv $RPM_BUILD_ROOT%{_libdir}/%{name}/res $RPM_BUILD_ROOT%{_datadir}/%{name}/res
286 ln -s ../../share/%{name}/chrome $RPM_BUILD_ROOT%{_libdir}/%{name}/chrome
287 ln -s ../../share/%{name}/defaults $RPM_BUILD_ROOT%{_libdir}/%{name}/defaults
288 ln -s ../../share/%{name}/greprefs $RPM_BUILD_ROOT%{_libdir}/%{name}/greprefs
289 #ln -s ../../share/%{name}/icons $RPM_BUILD_ROOT%{_libdir}/%{name}/icons
290 ln -s ../../share/%{name}/isp $RPM_BUILD_ROOT%{_libdir}/%{name}/isp
291 ln -s ../../share/%{name}/res $RPM_BUILD_ROOT%{_libdir}/%{name}/res
292
293 rm -rf $RPM_BUILD_ROOT%{_libdir}/%{name}/dictionaries
294 ln -s %{_datadir}/myspell $RPM_BUILD_ROOT%{_libdir}/%{name}/dictionaries
295
296 %{__sed} -e 's,@LIBDIR@,%{_libdir},' %{SOURCE5} > $RPM_BUILD_ROOT%{_bindir}/icedove
297 ln -s %{name} $RPM_BUILD_ROOT%{_bindir}/thunderbird
298 ln -s %{name} $RPM_BUILD_ROOT%{_bindir}/mozilla-thunderbird
299
300 install %{SOURCE4} $RPM_BUILD_ROOT%{_desktopdir}/%{name}.desktop
301
302 %if %{with enigmail}
303 _enig_dir=$RPM_BUILD_ROOT%{_libdir}/%{name}/extensions/\{847b3a00-7ab1-11d4-8f02-006008948af5\}
304 install -d $_enig_dir/chrome
305 install -d $_enig_dir/components
306 install -d $_enig_dir/defaults/preferences
307 mv -f $RPM_BUILD_ROOT%{_libdir}/%{name}/chrome/enigmail.jar $_enig_dir/chrome
308 mv -f $RPM_BUILD_ROOT%{_libdir}/%{name}/components/enig* $_enig_dir/components
309 mv -f $RPM_BUILD_ROOT%{_libdir}/%{name}/components/libenigmime.so $_enig_dir/components
310 mv -f $RPM_BUILD_ROOT%{_libdir}/%{name}/components/ipc.xpt $_enig_dir/components
311 mv -f $RPM_BUILD_ROOT%{_libdir}/%{name}/defaults/preferences/enigmail.js $_enig_dir/defaults/preferences
312 cp -f mailnews/extensions/enigmail/package/install.rdf $_enig_dir
313 rm -rf $RPM_BUILD_ROOT%{_libdir}/%{name}/defaults/preferences
314 rm -f $RPM_BUILD_ROOT%{_libdir}/%{name}/chrome/enigmail-en-US.jar
315 rm -f $RPM_BUILD_ROOT%{_libdir}/%{name}/chrome/enigmail-skin.jar
316 rm -f $RPM_BUILD_ROOT%{_libdir}/%{name}/chrome/enigmime.jar
317 rm -rf $RPM_BUILD_ROOT%{_libdir}/%{name}/components/enig*
318 rm -f $RPM_BUILD_ROOT%{_libdir}/%{name}/components/libenigmime.so
319 rm -f $RPM_BUILD_ROOT%{_libdir}/%{name}/components/ipc.xpt
320 cp -f %{SOURCE6} $_enig_dir/chrome.manifest
321 #cp -f icedove/branding/content/icon64.png $RPM_BUILD_ROOT%{_pixmapsdir}/icedove.png
322 %endif
323
324 # win32 stuff
325 rm -f $RPM_BUILD_ROOT%{_libdir}/%{name}/dirver
326
327 %clean
328 rm -rf $RPM_BUILD_ROOT
329
330 %pretrans
331 if [ -d %{_libdir}/%{name}/dictionaries ] && [ ! -L %{_libdir}/%{name}/dictionaries ]; then
332         mv -v %{_libdir}/%{name}/dictionaries{,.rpmsave}
333 fi
334 for d in chrome defaults greprefs icons isp res; do
335         if [ -d %{_libdir}/%{name}/$d ] && [ ! -L %{_libdir}/%{name}/$d ]; then
336                 install -d %{_datadir}/%{name}
337                 mv %{_libdir}/%{name}/$d %{_datadir}/%{name}/$d
338         fi
339 done
340 exit 0
341
342 %files
343 %defattr(644,root,root,755)
344 %attr(755,root,root) %{_bindir}/icedove
345 %attr(755,root,root) %{_bindir}/mozilla-thunderbird
346 %attr(755,root,root) %{_bindir}/thunderbird
347 %dir %{_libdir}/%{name}
348 %{_libdir}/%{name}/*.ini
349 %dir %{_libdir}/%{name}/components
350 %attr(755,root,root) %{_libdir}/%{name}/components/*.so
351 %{_libdir}/%{name}/components/*.js
352 %{_libdir}/%{name}/components/*.xpt
353 %attr(755,root,root) %{_libdir}/%{name}/*.so
354 %attr(755,root,root) %{_libdir}/%{name}/*.sh
355 %attr(755,root,root) %{_libdir}/%{name}/*-bin
356 %attr(755,root,root) %{_libdir}/%{name}/mozilla-xremote-client
357 #%attr(755,root,root) %{_libdir}/%{name}/reg*
358 %attr(755,root,root) %{_libdir}/%{name}/icedove
359 %{_libdir}/%{name}/*.txt
360 #%attr(755,root,root) %{_libdir}/%{name}/x*
361
362 # symlinks
363 %{_libdir}/%{name}/chrome
364 %{_libdir}/%{name}/defaults
365 %{_libdir}/%{name}/dictionaries
366 %{_libdir}/%{name}/greprefs
367 #%{_libdir}/%{name}/icons
368 %{_libdir}/%{name}/isp
369 %{_libdir}/%{name}/res
370
371 %{_libdir}/%{name}/dependentlibs.list
372 #%{_libdir}/%{name}/updater
373 #%{_libdir}/%{name}/update.locale
374 #%{_pixmapsdir}/*.png
375 %{_desktopdir}/*.desktop
376
377 %dir %{_datadir}/%{name}
378 %{_datadir}/%{name}/chrome
379 %{_datadir}/%{name}/defaults
380 %{_datadir}/%{name}/greprefs
381 #%{_datadir}/%{name}/icons
382 %{_datadir}/%{name}/isp
383 %{_datadir}/%{name}/res
384
385 %dir %{_libdir}/%{name}/modules
386 %{_libdir}/%{name}/modules/*.js*
387 %dir %{_libdir}/%{name}/modules/activity
388 %{_libdir}/%{name}/modules/activity/*.js
389 %dir %{_libdir}/%{name}/modules/gloda
390 %{_libdir}/%{name}/modules/gloda/*.js
391
392 %dir %{_libdir}/%{name}/extensions
393 %{_libdir}/%{name}/extensions/{972ce4c6-7e08-4474-a285-3208198ce6fd}
394 %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}
395
396 %if %{with enigmail}
397 %files addon-enigmail
398 %defattr(644,root,root,755)
399 %{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}
400 %endif
This page took 0.082449 seconds and 4 git commands to generate.