]> git.pld-linux.org Git - packages/thunderbird.git/blob - icedove.spec
- fixed xulrunner version
[packages/thunderbird.git] / icedove.spec
1 # TODO:
2 # - separate spec for enigmail
3 # - build with system mozldap
4 #
5 # Conditional builds
6 %bcond_without  enigmail        # don't build enigmail - GPG/PGP support
7 %bcond_without  gnomeui         # disable gnomeui support
8 %bcond_without  gnome           # alias for gnomeui
9 %bcond_without  ldap            # disable e-mail address lookups in LDAP directories
10 %bcond_without  lightning       # disable Sunbird/Lightning calendar
11 %bcond_with     xulrunner       # system xulrunner
12 %bcond_with     crashreporter   # report crashes to crash-stats.mozilla.com
13
14 %if %{without gnome}
15 %undefine       with_gnomeui
16 %endif
17
18 %if 0%{?_enable_debug_packages} != 1
19 %undefine       crashreporter
20 %endif
21
22 %define         enigmail_ver    1.4.1
23 %define         nspr_ver        4.9
24 %define         nss_ver         3.13.3
25
26 # convert thunderbird release number to platform version: 12.0.x -> 12.0.x
27 %define         xulrunner_main  12.0
28 %define         xulrunner_ver   %(v=%{version}; echo %{xulrunner_main}${v#12.0})
29
30 %if %{without xulrunner}
31 # The actual sqlite version (see RHBZ#480989):
32 %define         sqlite_build_version %(pkg-config --silence-errors --modversion sqlite3 2>/dev/null || echo ERROR)
33 %endif
34
35 Summary:        Icedove - email client
36 Summary(pl.UTF-8):      Icedove - klient poczty
37 Name:           icedove
38 Version:        12.0.1
39 Release:        1
40 License:        MPL 1.1 or GPL v2+ or LGPL v2.1+
41 Group:          X11/Applications/Networking
42 Source0:        http://releases.mozilla.org/pub/mozilla.org/thunderbird/releases/%{version}/source/thunderbird-%{version}.source.tar.bz2
43 # Source0-md5:  64cacde4cb2b1e8736f1c3a0ea6a02db
44 Source1:        http://www.mozilla-enigmail.org/download/source/enigmail-%{enigmail_ver}.tar.gz
45 # Source1-md5:  0eba75fbcf8f0bb32d538df102fbb8e9
46 Source2:        %{name}-branding.tar.bz2
47 # Source2-md5:  2da351522bdd7f4a3bd8aaff4c776976
48 Source3:        %{name}-rm_nonfree.sh
49 Source4:        %{name}.desktop
50 Source5:        %{name}.sh
51 Patch0:         %{name}-branding.patch
52 Patch1:         %{name}-enigmail-shared.patch
53 Patch2:         %{name}-system-xulrunner.patch
54 Patch3:         %{name}-fonts.patch
55 Patch4:         %{name}-install.patch
56 Patch5:         %{name}-hunspell.patch
57 Patch6:         %{name}-prefs.patch
58 Patch7:         system-mozldap.patch
59 Patch8:         %{name}-makefile.patch
60 # this is only workaround, check if it is fixed with newer firefox
61 Patch9:         bug-722975-workaround.patch
62 Patch10:        %{name}-extensiondir.patch
63 Patch11:        crashreporter.patch
64 Patch12:        no-subshell.patch
65 URL:            http://www.pld-linux.org/Packages/Icedove
66 BuildRequires:  GConf2-devel >= 1.2.1
67 BuildRequires:  alsa-lib-devel
68 BuildRequires:  automake
69 BuildRequires:  bzip2-devel
70 BuildRequires:  cairo-devel >= 1.10
71 BuildRequires:  dbus-glib-devel >= 0.60
72 BuildRequires:  freetype-devel >= 1:2.1.8
73 BuildRequires:  glib2-devel >= 2.0
74 BuildRequires:  gtk+2-devel >= 2:2.10.0
75 BuildRequires:  hunspell-devel
76 BuildRequires:  libIDL-devel >= 0.8.0
77 %{?with_gnomeui:BuildRequires:  libgnome-devel >= 2.0}
78 %{?with_gnomeui:BuildRequires:  libgnome-keyring-devel}
79 %{?with_gnomeui:BuildRequires:  libgnomeui-devel >= 2.2.0}
80 BuildRequires:  libiw-devel
81 BuildRequires:  libjpeg-devel >= 6b
82 BuildRequires:  libnotify-devel >= 0.4
83 BuildRequires:  libpng-devel >= 1.4.1
84 BuildRequires:  libstdc++-devel
85 BuildRequires:  nspr-devel >= 1:%{nspr_ver}
86 BuildRequires:  nss-devel >= 1:%{nss_ver}
87 BuildRequires:  pango-devel >= 1:1.14.0
88 BuildRequires:  perl-base >= 1:5.6
89 BuildRequires:  pkgconfig
90 BuildRequires:  python >= 1:2.5
91 BuildRequires:  sed >= 4.0
92 BuildRequires:  sqlite3-devel >= 3.7.4
93 BuildRequires:  startup-notification-devel >= 0.8
94 BuildRequires:  xorg-lib-libXext-devel
95 BuildRequires:  xorg-lib-libXinerama-devel
96 BuildRequires:  xorg-lib-libXt-devel
97 BuildRequires:  yasm
98 BuildRequires:  zip
99 %if %{with xulrunner}
100 BuildRequires:  xulrunner-devel >= 2:%{xulrunner_ver}
101 %else
102 Requires:       myspell-common
103 Requires:       nspr >= 1:%{nspr_ver}
104 Requires:       nss >= 1:%{nss_ver}
105 Requires:       sqlite3 >= %{sqlite_build_version}
106 %endif
107 Requires(post): mktemp >= 1.5-18
108 %if %{with xulrunner}
109 %requires_eq_to xulrunner xulrunner-devel
110 %endif
111 Obsoletes:      mozilla-thunderbird
112 Obsoletes:      mozilla-thunderbird-dictionary-en-US
113 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
114
115 %define         filterout_cpp           -D_FORTIFY_SOURCE=[0-9]+
116
117 # iceweasel/icedove/iceape provide their own versions
118 %define         _noautoprovfiles        %{_libdir}/%{name}/components
119 %if %{without xulrunner}
120 # we don't want these to satisfy packages depending on xulrunner
121 %define         _noautoprov             libmozalloc.so libxpcom.so libxul.so
122 # and as we don't provide them, don't require either
123 %define         _noautoreq              libmozalloc.so libxpcom.so libxul.so
124 %endif
125
126 %define         topdir          %{_builddir}/%{name}-%{version}
127 %define         objdir          %{topdir}/obj-%{_target_cpu}
128
129 %description
130 Icedove is an open-source, fast and portable email client.
131
132 %description -l pl.UTF-8
133 Icedove jest mającym otwarte źródła, szybkim i przenośnym klientem
134 poczty.
135
136 %package addon-lightning
137 Summary:        An integrated calendar for Icedove
138 Summary(pl.UTF-8):      Zintegrowany kalendarz dla Icedove
139 License:        MPL 1.1 or GPL v2+ or LGPL v2.1+
140 Group:          Applications/Networking
141 Requires:       %{name} = %{version}-%{release}
142
143 %description addon-lightning
144 Lightning is an calendar extension to Icedove email client.
145
146 %description addon-lightning -l pl.UTF-8
147 Lightning to rozszerzenie do klienta poczty Icedove dodające
148 funkcjonalność kalendarza.
149
150 %package addon-enigmail
151 Summary:        Extension for the authentication and encryption features provided by GnuPG
152 Summary(pl.UTF-8):      Rozszerzenie do uwierzytelniania i szyfrowania zapewnianego przez GnuPG
153 License:        MPL/LGPL
154 Group:          Applications/Networking
155 URL:            http://enigmail.mozdev.org/
156 Requires:       %{name} = %{version}-%{release}
157 Requires:       gnupg
158 Obsoletes:      mozilla-thunderbird-addon-enigmail
159
160 %description addon-enigmail
161 Enigmail is an extension to the Icedove mail client which allows users
162 to access the authentication and encryption features provided by
163 GnuPG.
164
165 Main Features:
166 - Encrypt/sign mail when sending, decrypt/authenticate received mail
167 - Support for inline-PGP (RFC 2440) and PGP/MIME (RFC 3156)
168 - Per-Account based encryption and signing defaults
169 - Per-Recipient rules for automated key selection, and
170   enabling/disabling encryption and signing
171 - OpenPGP key management interface
172
173 %description addon-enigmail -l pl.UTF-8
174 Enigmail to rozszerzenie klienta pocztowego Icedove pozwalające
175 użytkownikom na dostęp do uwierzytelniania i szyfrowania zapewnianego
176 przez GnuPG.
177
178 Główne możliwości:
179 - szyfrowanie/podpisywanie poczty przy wysyłaniu,
180   odszyfrowywanie/uwierzytelnianie poczty odebranej
181 - obsługa inline-PGP (RFC 2440) i PGP/MIME (RFC 3156)
182 - ustawienia domyślne szyfrowania i podpisywania dla każdego konta
183 - reguły automatycznego wyboru kluczy i włączenia szyfrowania oraz
184   podpisywania dla każdego adresata
185 - interfejs do zarządzania kluczami OpenPGP
186
187 %prep
188 %setup -qc
189 mv comm-release mozilla
190 %setup -q -T -D -a2
191 cd mozilla
192 %{?with_enigmail:%{__gzip} -dc %{SOURCE1} | %{__tar} -xf - -C mailnews/extensions}
193 /bin/sh %{SOURCE3}
194 %patch0 -p1
195 %{?with_enigmail:%patch1 -p1}
196 %{?with_xulrunner:%patch2 -p1}
197 %patch3 -p1
198 %patch4 -p1
199 %patch6 -p1
200 %patch7 -p1
201 %patch8 -p2
202 cd mozilla
203 %patch9 -p1
204 cd -
205 %patch10 -p2
206 %patch11 -p2
207 %patch12 -p1
208
209 %build
210 cd mozilla
211 cp -f %{_datadir}/automake/config.* mozilla/build/autoconf
212 cp -f %{_datadir}/automake/config.* mozilla/nsprpub/build/autoconf
213 cp -f %{_datadir}/automake/config.* ldap/sdks/c-sdk/config/autoconf
214
215 cat << EOF > .mozconfig
216 mk_add_options MOZ_OBJDIR=%{objdir}
217
218 export CFLAGS="%{rpmcflags}"
219 export CXXFLAGS="%{rpmcflags}"
220
221 %if %{with crashreporter}
222 export MOZ_DEBUG_SYMBOLS=1
223 %endif
224
225 # Options for 'configure' (same as command-line options).
226 ac_add_options --prefix=%{_prefix}
227 ac_add_options --exec-prefix=%{_exec_prefix}
228 ac_add_options --bindir=%{_bindir}
229 ac_add_options --sbindir=%{_sbindir}
230 ac_add_options --sysconfdir=%{_sysconfdir}
231 ac_add_options --datadir=%{_datadir}
232 ac_add_options --includedir=%{_includedir}
233 ac_add_options --libdir=%{_libdir}
234 ac_add_options --libexecdir=%{_libexecdir}
235 ac_add_options --localstatedir=%{_localstatedir}
236 ac_add_options --sharedstatedir=%{_sharedstatedir}
237 ac_add_options --mandir=%{_mandir}
238 ac_add_options --infodir=%{_infodir}
239 %if %{?debug:1}0
240 ac_add_options --disable-optimize
241 ac_add_options --enable-debug
242 ac_add_options --enable-debug-modules
243 ac_add_options --enable-debugger-info-modules
244 ac_add_options --enable-crash-on-assert
245 %else
246 ac_add_options --disable-debug
247 ac_add_options --disable-debug-modules
248 ac_add_options --disable-logging
249 ac_add_options --enable-optimize="%{rpmcflags} -Os"
250 %endif
251 ac_add_options --disable-strip
252 ac_add_options --disable-strip-libs
253 %if %{with tests}
254 ac_add_options --enable-tests
255 %else
256 ac_add_options --disable-tests
257 %endif
258 ac_add_options --enable-gio
259 %if %{with gnomeui}
260 ac_add_options --enable-gnomeui
261 %else
262 ac_add_options --disable-gnomeui
263 %endif
264 ac_add_options --disable-gnomevfs
265 %if %{with ldap}
266 ac_add_options --enable-ldap
267 ac_add_options --with-system-ldap
268 %else
269 ac_add_options --disable-ldap
270 %endif
271 %if %{with crashreporter}
272 ac_add_options --enable-crashreporter
273 %else
274 ac_add_options --disable-crashreporter
275 %endif
276 ac_add_options --disable-xterm-updates
277 ac_add_options --enable-postscript
278 %if %{with lightning}
279 ac_add_options --enable-calendar
280 %else
281 ac_add_options --disable-calendar
282 %endif
283 ac_add_options --disable-installer
284 ac_add_options --disable-updater
285 ac_add_options --disable-xprint
286 ac_add_options --disable-permissions
287 ac_add_options --disable-pref-extensions
288 ac_add_options --enable-canvas
289 ac_add_options --enable-crypto
290 ac_add_options --enable-mathml
291 ac_add_options --enable-pango
292 ac_add_options --enable-reorder
293 ac_add_options --enable-startup-notification
294 ac_add_options --enable-svg
295 ac_add_options --enable-system-cairo
296 ac_add_options --enable-system-hunspell
297 ac_add_options --enable-system-sqlite
298 ac_add_options --enable-xft
299 ac_add_options --enable-application=mail
300 ac_add_options --enable-default-toolkit=cairo-gtk2
301 ac_add_options --enable-xinerama
302 ac_add_options --with-distribution-id=org.pld-linux
303 ac_add_options --with-branding=icedove/branding
304 %if %{with xulrunner}
305 ac_add_options --enable-shared-js
306 ac_add_options --with-libxul-sdk=$(pkg-config --variable=sdkdir libxul)
307 ac_add_options --with-system-libxul
308 %endif
309 ac_add_options --with-pthreads
310 ac_add_options --with-system-bz2
311 ac_add_options --with-system-jpeg
312 ac_add_options --with-system-nspr
313 ac_add_options --with-system-nss
314 ac_add_options --with-system-png
315 ac_add_options --with-system-zlib
316 ac_add_options --enable-single-profile
317 ac_add_options --disable-profilesharing
318 ac_add_options --with-default-mozilla-five-home=%{_libdir}/%{name}
319 EOF
320
321 %{__make} -j1 -f client.mk build \
322         STRIP="/bin/true" \
323         MOZ_MAKE_FLAGS="%{?_smp_mflags}" \
324         CC="%{__cc}" \
325         CXX="%{__cxx}"
326
327 %if %{with crashreporter}
328 # create debuginfo for crash-stats.mozilla.com
329 %{__make} -j1 -C obj-%{_target_cpu} buildsymbols
330 %endif
331
332 %if %{with enigmail}
333 cd mailnews/extensions/enigmail
334 ./makemake -r -o %{objdir}
335 %{__make} -C %{objdir}/mailnews/extensions/enigmail \
336         STRIP="/bin/true" \
337         CC="%{__cc}" \
338         CXX="%{__cxx}"
339 %endif
340
341 %install
342 rm -rf $RPM_BUILD_ROOT
343 install -d $RPM_BUILD_ROOT{%{_bindir},%{_libdir}/%{name},%{_datadir}/%{name},%{_pixmapsdir},%{_desktopdir}}
344
345 cd %{objdir}
346 %{__make} -C mail/installer stage-package \
347         DESTDIR=$RPM_BUILD_ROOT \
348         MOZ_PKG_DIR=%{_libdir}/%{name} \
349         PKG_SKIP_STRIP=1
350
351 %if %{with xulrunner}
352 # needed to find mozilla runtime
353 ln -s ../xulrunner $RPM_BUILD_ROOT%{_libdir}/%{name}/xulrunner
354 %endif
355  
356 # Enable crash reporter for Thunderbird application
357 %if %{with crashreporter}
358 %{__sed} -i -e 's/\[Crash Reporter\]/[Crash Reporter]\nEnabled=1/' $RPM_BUILD_ROOT%{_libdir}/%{name}/application.ini
359
360 # Add debuginfo for crash-stats.mozilla.com
361 install -d $RPM_BUILD_ROOT%{_exec_prefix}/lib/debug%{_libdir}/%{name}
362 cp -a mozilla/dist/%{name}-%{version}.en-US.linux-*.crashreporter-symbols.zip $RPM_BUILD_ROOT%{_prefix}/lib/debug%{_libdir}/%{name}
363 %endif
364
365 # copy manually lightning files, somewhy they are not installed by make
366 cp -a mozilla/dist/bin/extensions/calendar-timezones@mozilla.org \
367         mozilla/dist/bin/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103} \
368         $RPM_BUILD_ROOT%{_libdir}/%{name}/extensions
369
370 # move arch independant ones to datadir
371 mv $RPM_BUILD_ROOT%{_libdir}/%{name}/chrome $RPM_BUILD_ROOT%{_datadir}/%{name}/chrome
372 mv $RPM_BUILD_ROOT%{_libdir}/%{name}/defaults $RPM_BUILD_ROOT%{_datadir}/%{name}/defaults
373 mv $RPM_BUILD_ROOT%{_libdir}/%{name}/isp $RPM_BUILD_ROOT%{_datadir}/%{name}/isp
374 mv $RPM_BUILD_ROOT%{_libdir}/%{name}/modules $RPM_BUILD_ROOT%{_datadir}/%{name}/modules
375 mv $RPM_BUILD_ROOT%{_libdir}/%{name}/searchplugins $RPM_BUILD_ROOT%{_datadir}/%{name}/searchplugins
376 ln -s ../../share/%{name}/chrome $RPM_BUILD_ROOT%{_libdir}/%{name}/chrome
377 ln -s ../../share/%{name}/defaults $RPM_BUILD_ROOT%{_libdir}/%{name}/defaults
378 ln -s ../../share/%{name}/isp $RPM_BUILD_ROOT%{_libdir}/%{name}/isp
379 ln -s ../../share/%{name}/modules $RPM_BUILD_ROOT%{_libdir}/%{name}/modules
380 ln -s ../../share/%{name}/searchplugins $RPM_BUILD_ROOT%{_libdir}/%{name}/searchplugins
381 %if %{without xulrunner}
382 mv $RPM_BUILD_ROOT%{_libdir}/%{name}/res $RPM_BUILD_ROOT%{_datadir}/%{name}/res
383 ln -s ../../share/%{name}/res $RPM_BUILD_ROOT%{_libdir}/%{name}/res
384 %endif
385
386 # dir for arch independant extensions besides arch dependant extensions
387 # see mozilla/xpcom/build/nsXULAppAPI.h
388 # XRE_SYS_LOCAL_EXTENSION_PARENT_DIR and XRE_SYS_SHARE_EXTENSION_PARENT_DIR
389 install -d $RPM_BUILD_ROOT%{_datadir}/%{name}/extensions
390
391 %if %{without xulrunner}
392 %{__rm} -r $RPM_BUILD_ROOT%{_libdir}/%{name}/dictionaries
393 ln -s %{_datadir}/myspell $RPM_BUILD_ROOT%{_libdir}/%{name}/dictionaries
394 %{__rm} -r $RPM_BUILD_ROOT%{_libdir}/%{name}/hyphenation
395 ln -s %{_datadir}/myspell $RPM_BUILD_ROOT%{_libdir}/%{name}/hyphenation
396 %endif
397
398 %{__sed} -e 's,@LIBDIR@,%{_libdir},' %{SOURCE5} > $RPM_BUILD_ROOT%{_bindir}/icedove
399 ln -s %{name} $RPM_BUILD_ROOT%{_bindir}/thunderbird
400 ln -s %{name} $RPM_BUILD_ROOT%{_bindir}/mozilla-thunderbird
401
402 cp -p %{SOURCE4} $RPM_BUILD_ROOT%{_desktopdir}/%{name}.desktop
403 cp -p %{topdir}/mozilla/icedove/branding/content/icon64.png $RPM_BUILD_ROOT%{_pixmapsdir}/%{name}.png
404
405 # files created by regxpcom -register in post
406 touch $RPM_BUILD_ROOT%{_libdir}/%{name}/components/compreg.dat
407 touch $RPM_BUILD_ROOT%{_libdir}/%{name}/components/xpti.dat
408 cat << 'EOF' > $RPM_BUILD_ROOT%{_libdir}/%{name}/register
409 #!/bin/sh
410 umask 022
411 # make temporary HOME, as it attempts to touch files in $HOME/.mozilla
412 # dangerous if you run this with sudo with keep_env += HOME
413 # also TMPDIR could be pointing to sudo user's homedir so we reset that too.
414 t=$(mktemp -d)
415 %{__rm} -f %{_libdir}/%{name}/components/{compreg,xpti}.dat
416 TMPDIR= TMP= HOME=$t %{_libdir}/%{name}/icedove -register
417 rm -rf $t
418 EOF
419 chmod a+rx $RPM_BUILD_ROOT%{_libdir}/%{name}/register
420
421 %if %{with enigmail}
422 ext_dir=$RPM_BUILD_ROOT%{_libdir}/%{name}/extensions/\{847b3a00-7ab1-11d4-8f02-006008948af5\}
423 install -d $ext_dir/{chrome,components,defaults/preferences}
424 cd mozilla/dist/bin
425 #cp -rfLp chrome/enigmail.jar $ext_dir/chrome
426 #cp -rfLp chrome/enigmime.jar $ext_dir/chrome
427 cp -rfLp components/enig* $ext_dir/components
428 cp -rfLp components/libenigmime.so $ext_dir/components
429 cp -rfLp components/libipc.so $ext_dir/components
430 cp -rfLp components/ipc.xpt $ext_dir/components
431 cp -rfLp defaults/preferences/enigmail.js $ext_dir/defaults/preferences
432 cd -
433 cp -p %{topdir}/mozilla/mailnews/extensions/enigmail/package/install.rdf $ext_dir
434 cp -p %{topdir}/mozilla/mailnews/extensions/enigmail/package/chrome.manifest $ext_dir/chrome.manifest
435 %endif
436
437 # never package these. always remove
438 # nss
439 %{__rm} -f $RPM_BUILD_ROOT%{_libdir}/%{name}/lib{freebl3,nss3,nssckbi,nssdbm3,nssutil3,smime3,softokn3,ssl3}.*
440 # nspr
441 %{__rm} -f $RPM_BUILD_ROOT%{_libdir}/%{name}/lib{nspr4,plc4,plds4}.so
442 # mozldap
443 %{__rm} -f $RPM_BUILD_ROOT%{_libdir}/%{name}/lib{ldap,ldif,prldap,ssldap}60.so
444 # testpilot quiz
445 %{__rm} -f $RPM_BUILD_ROOT%{_libdir}/%{name}/distribution/extensions/tbtestpilot@labs.mozilla.com.xpi
446
447 %clean
448 rm -rf $RPM_BUILD_ROOT
449
450 %pretrans
451 if [ -d %{_libdir}/%{name}/dictionaries ] && [ ! -L %{_libdir}/%{name}/dictionaries ]; then
452         mv -v %{_libdir}/%{name}/dictionaries{,.rpmsave}
453 fi
454 for d in chrome defaults icons isp modules res searchplugins; do
455         if [ -d %{_libdir}/%{name}/$d ] && [ ! -L %{_libdir}/%{name}/$d ]; then
456                 install -d %{_datadir}/%{name}
457                 mv %{_libdir}/%{name}/$d %{_datadir}/%{name}/$d
458         fi
459 done
460 exit 0
461
462 %post
463 %{_libdir}/%{name}/register || :
464
465 %files
466 %defattr(644,root,root,755)
467 %attr(755,root,root) %{_bindir}/icedove
468 %attr(755,root,root) %{_bindir}/mozilla-thunderbird
469 %attr(755,root,root) %{_bindir}/thunderbird
470 %dir %{_libdir}/%{name}
471 %{_libdir}/%{name}/application.ini
472 %{_libdir}/%{name}/blocklist.xml
473 %{_libdir}/%{name}/chrome.manifest
474 %dir %{_libdir}/%{name}/components
475 %{_libdir}/%{name}/components/*.js
476 %{_libdir}/%{name}/components/*.xpt
477 %{_libdir}/%{name}/components/components.manifest
478 %{_libdir}/%{name}/components/interfaces.manifest
479 %attr(755,root,root) %{_libdir}/%{name}/*.sh
480 %attr(755,root,root) %{_libdir}/%{name}/*-bin
481 %attr(755,root,root) %{_libdir}/%{name}/icedove
482 %attr(755,root,root) %{_libdir}/%{name}/register
483 %if %{without xulrunner}
484 %{_libdir}/%{name}/platform.ini
485 %{_libdir}/%{name}/greprefs.js
486 %attr(755,root,root) %{_libdir}/%{name}/components/*.so
487 %attr(755,root,root) %{_libdir}/%{name}/libmozalloc.so
488 %attr(755,root,root) %{_libdir}/%{name}/libxpcom.so
489 %attr(755,root,root) %{_libdir}/%{name}/libxul.so
490 %attr(755,root,root) %{_libdir}/%{name}/mozilla-xremote-client
491 %attr(755,root,root) %{_libdir}/%{name}/plugin-container
492 %endif
493
494 # symlinks
495 %{_libdir}/%{name}/chrome
496 %{_libdir}/%{name}/defaults
497 %{_libdir}/%{name}/isp
498 %{_libdir}/%{name}/modules
499 %{_libdir}/%{name}/searchplugins
500 %if %{with xulrunner}
501 %{_libdir}/%{name}/xulrunner
502 %else
503 %{_libdir}/%{name}/dictionaries
504 %{_libdir}/%{name}/hyphenation
505 %{_libdir}/%{name}/res
506 %endif
507
508 %{_pixmapsdir}/icedove.png
509 %{_desktopdir}/icedove.desktop
510
511 %dir %{_datadir}/%{name}
512 %{_datadir}/%{name}/chrome
513 %{_datadir}/%{name}/defaults
514 %{_datadir}/%{name}/extensions
515 %{_datadir}/%{name}/isp
516 %{_datadir}/%{name}/modules
517 %{_datadir}/%{name}/searchplugins
518 %if %{without xulrunner}
519 %{_datadir}/%{name}/res
520 %endif
521
522 %if %{with crashreporter}
523 %attr(755,root,root) %{_libdir}/%{name}/crashreporter
524 %{_libdir}/%{name}/crashreporter.ini
525 %{_libdir}/%{name}/Throbber-small.gif
526 %endif
527
528 %dir %{_libdir}/%{name}/extensions
529 %{_libdir}/%{name}/extensions/{972ce4c6-7e08-4474-a285-3208198ce6fd}
530
531 # files created by regxpcom -register
532 %ghost %{_libdir}/%{name}/components/compreg.dat
533 %ghost %{_libdir}/%{name}/components/xpti.dat
534
535 %if %{with lightning}
536 %files addon-lightning
537 %defattr(644,root,root,755)
538 %dir %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}
539 %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/application.ini
540 %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/chrome
541 %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/chrome.manifest
542 %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/defaults
543 %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/install.rdf
544 %dir %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/components
545 %attr(755,root,root) %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/components/*.so
546 %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/components/*.js
547 %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/components/*.manifest
548 %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/components/*.xpt
549 %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/modules
550 %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/calendar-js
551 %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/timezones.sqlite
552 %{_libdir}/%{name}/extensions/calendar-timezones@mozilla.org
553 %endif
554
555 %if %{with enigmail}
556 %files addon-enigmail
557 %defattr(644,root,root,755)
558 %dir %{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}
559 %{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/defaults
560 %{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/chrome
561 %{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/chrome.manifest
562 %{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/install.rdf
563 %dir %{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/components
564 %attr(755,root,root) %{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/components/*.so
565 %{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/components/*.xpt
566 %{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/components/*.js
567 %endif
This page took 0.081632 seconds and 4 git commands to generate.