]> git.pld-linux.org Git - packages/thunderbird.git/blob - icedove.spec
- fix build with libnotify 0.7
[packages/thunderbird.git] / icedove.spec
1 # TODO:
2 # - separate spec for enigmail
3 # - fix icedove (building) and installing nss/nspr libs!
4 # - build with system mozldap
5 #
6 # Conditional builds
7 %bcond_without  enigmail        # don't build enigmail - GPG/PGP support
8 %bcond_without  gnomeui         # disable gnomeui support
9 %bcond_without  gnomevfs        # disable GNOME comp. (gconf+libgnome+gnomevfs) and gnomevfs ext.
10 %bcond_without  gnome           # disable all GNOME components (gnome+gnomeui+gnomevfs)
11 %bcond_without  ldap            # disable e-mail address lookups in LDAP directories
12 %bcond_without  lightning       # disable sunbird calendar
13 %bcond_with             xulrunner       # build with xulrunner
14 %bcond_with     crashreporter   # report crashes to crash-stats.mozilla.com
15
16 %if %{without gnome}
17 %undefine       with_gnomeui
18 %undefine       with_gnomevfs
19 %endif
20
21 %if %{?_enable_debug_packages} != 1
22 %undefine       crashreporter
23 %endif
24
25 %define         enigmail_ver            1.1.2
26
27 %if %{without xulrunner}
28 # The actual sqlite version (see RHBZ#480989):
29 %define         sqlite_build_version %(pkg-config --silence-errors --modversion sqlite3 2>/dev/null || echo ERROR)
30 %endif
31
32 Summary:        Icedove - email client
33 Summary(pl.UTF-8):      Icedove - klient poczty
34 Name:           icedove
35 Version:        3.1.9
36 Release:        3
37 License:        MPL 1.1 or GPL v2+ or LGPL v2.1+
38 Group:          X11/Applications/Networking
39 Source0:        http://releases.mozilla.org/pub/mozilla.org/thunderbird/releases/%{version}/source/thunderbird-%{version}.source.tar.bz2
40 # Source0-md5:  e6917c419d3aaa8083a1d4b53fb80d8c
41 Source1:        http://www.mozilla-enigmail.org/download/source/enigmail-%{enigmail_ver}.tar.gz
42 # Source1-md5:  7d329d5e8afbbb28214ca1995beb09c9
43 Source2:        %{name}-branding.tar.bz2
44 # Source2-md5:  2da351522bdd7f4a3bd8aaff4c776976
45 Source3:        %{name}-rm_nonfree.sh
46 Source4:        %{name}.desktop
47 Source5:        %{name}.sh
48 Patch0:         %{name}-branding.patch
49 Patch1:         %{name}-enigmail-shared.patch
50 Patch2:         %{name}-gcc.patch
51 Patch3:         %{name}-fonts.patch
52 Patch4:         %{name}-install.patch
53 Patch5:         %{name}-hunspell.patch
54 Patch6:         %{name}-prefs.patch
55 Patch7:         system-mozldap.patch
56 Patch8:         %{name}-makefile.patch
57 Patch9:         %{name}-libpng.patch
58 Patch10:        %{name}-extensiondir.patch
59 Patch11:        crashreporter.patch
60 Patch12:        no-subshell.patch
61 Patch13:        %{name}-libnotify.patch
62 URL:            http://www.pld-linux.org/Packages/Icedove
63 %{?with_gnomevfs:BuildRequires: GConf2-devel >= 1.2.1}
64 BuildRequires:  alsa-lib-devel
65 BuildRequires:  automake
66 BuildRequires:  bzip2-devel
67 BuildRequires:  freetype-devel >= 1:2.1.8
68 %{?with_gnomevfs:BuildRequires: gnome-vfs2-devel >= 2.0}
69 BuildRequires:  gtk+2-devel >= 1:2.0.0
70 BuildRequires:  hunspell-devel
71 BuildRequires:  libIDL-devel >= 0.8.0
72 %{?with_gnomevfs:BuildRequires: libgnome-devel >= 2.0}
73 %{?with_gnomeui:BuildRequires:  libgnome-keyring-devel}
74 %{?with_gnomeui:BuildRequires:  libgnomeui-devel >= 2.2.0}
75 BuildRequires:  libiw-devel
76 BuildRequires:  libjpeg-devel >= 6b
77 BuildRequires:  libnotify-devel >= 0.4
78 BuildRequires:  libpng-devel >= 1.2.0
79 BuildRequires:  libstdc++-devel
80 BuildRequires:  nspr-devel >= 1:4.8
81 BuildRequires:  nss-devel >= 1:3.12.0
82 BuildRequires:  pango-devel >= 1:1.1.0
83 BuildRequires:  pkgconfig
84 BuildRequires:  sed >= 4.0
85 BuildRequires:  sqlite3-devel >= 3.7.2-2
86 BuildRequires:  startup-notification-devel >= 0.8
87 BuildRequires:  xorg-lib-libXext-devel
88 BuildRequires:  xorg-lib-libXinerama-devel
89 BuildRequires:  xorg-lib-libXt-devel
90 BuildRequires:  zip
91 Requires(post): mktemp >= 1.5-18
92 %if %{with xulrunner}
93 %else
94 Requires:       myspell-common
95 Requires:       nspr >= 1:4.6.1
96 Requires:       nss >= 1:3.11.3
97 Requires:       sqlite3 >= %{sqlite_build_version}
98 %endif
99 Obsoletes:      mozilla-thunderbird
100 Obsoletes:      mozilla-thunderbird-dictionary-en-US
101 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
102
103 %define         filterout_cpp           -D_FORTIFY_SOURCE=[0-9]+
104
105 # iceweasel/icedove/iceape provide their own versions
106 %define         _noautoreqdep           libgfxpsshar.so libgkgfx.so libgtkxtbin.so libjsj.so libxpcom_compat.so libxpistub.so
107 %define         _noautoprovfiles        %{_libdir}/%{name}/components
108 # we don't want these to satisfy xulrunner-devel
109 %define         _noautoprov             libgtkembedmoz.so libmozjs.so libxpcom.so libxul.so libxpcom_core.so
110 # and as we don't provide them, don't require either
111 %define         _noautoreq              libgtkembedmoz.so libmozjs.so libxpcom.so libxul.so libxpcom_core.so
112
113 %define         topdir          %{_builddir}/%{name}-%{version}
114 %define         objdir          %{topdir}/obj-%{_target_cpu}
115
116 %description
117 Icedove is an open-source,fast and portable email client.
118
119 %description -l pl.UTF-8
120 Icedove jest open sourcowym, szybkim i przenośnym klientem poczty.
121
122 %package addon-lightning
123 Summary:        An integrated calendar for Icedove
124 Summary(pl.UTF-8):      Zintegrowany kalendarz dla Icedove
125 License:        MPL 1.1 or GPL v2+ or LGPL v2.1+
126 Group:          Applications/Networking
127 Requires:       %{name} = %{version}-%{release}
128
129 %description addon-lightning
130 Lightning is an calendar extension to Icedove email client.
131
132 %description addon-lightning -l pl.UTF-8
133 Lightning to rozszerzenie do klienta poczty Icedove dodające
134 funkcjonalność kalendarza.
135
136 %package addon-enigmail
137 Summary:        Extension for the authentication and encryption features provided by GnuPG
138 Summary(pl.UTF-8):      Rozszerzenie do uwierzytelniania i szyfrowania zapewnianego przez GnuPG
139 License:        MPL/LGPL
140 Group:          Applications/Networking
141 URL:            http://enigmail.mozdev.org/
142 Requires:       %{name} = %{version}-%{release}
143 Requires:       gnupg
144 Obsoletes:      mozilla-thunderbird-addon-enigmail
145
146 %description addon-enigmail
147 Enigmail is an extension to the Icedove mail client which allows users
148 to access the authentication and encryption features provided by
149 GnuPG.
150
151 Main Features:
152 - Encrypt/sign mail when sending, decrypt/authenticate received mail
153 - Support for inline-PGP (RFC 2440) and PGP/MIME (RFC 3156)
154 - Per-Account based encryption and signing defaults
155 - Per-Recipient rules for automated key selection, and
156   enabling/disabling encryption and signing
157 - OpenPGP key management interface
158
159 %description addon-enigmail -l pl.UTF-8
160 Enigmail to rozszerzenie klienta pocztowego Icedove pozwalające
161 użytkownikom na dostęp do uwierzytelniania i szyfrowania zapewnianego
162 przez GnuPG.
163
164 Główne możliwości:
165 - szyfrowanie/podpisywanie poczty przy wysyłaniu,
166   odszyfrowywanie/uwierzytelnianie poczty odebranej
167 - obsługa inline-PGP (RFC 2440) i PGP/MIME (RFC 3156)
168 - ustawienia domyślne szyfrowania i podpisywania dla każdego konta
169 - reguły automatycznego wyboru kluczy i włączenia szyfrowania oraz
170   podpisywania dla każdego adresata
171 - interfejs do zarządzania kluczami OpenPGP
172
173 %prep
174 %setup -qc
175 mv -f comm-1.9.2 mozilla
176 %setup -q -T -D -a2
177 cd mozilla
178 %{?with_enigmail:%{__gzip} -dc %{SOURCE1} | %{__tar} -xf - -C mailnews/extensions}
179 /bin/sh %{SOURCE3}
180 %patch0 -p1
181 %{?with_enigmail:%patch1 -p1}
182 %patch2 -p1
183 %patch3 -p1
184 %patch4 -p1
185 %patch5 -p1
186 %patch6 -p1
187 %patch7 -p1
188 %patch8 -p0
189 %patch9 -p0
190 %patch10 -p2
191 %patch11 -p2
192 %patch12 -p1
193 %patch13 -p1
194
195 %build
196 cd mozilla
197 cp -f %{_datadir}/automake/config.* mozilla/build/autoconf
198 cp -f %{_datadir}/automake/config.* mozilla/nsprpub/build/autoconf
199 cp -f %{_datadir}/automake/config.* directory/sdks/c-sdk/config/autoconf
200
201 install -d libxul-sdk
202 ln -snf %{_libdir}/xulrunner-sdk libxul-sdk/sdk
203
204 cat << EOF > .mozconfig
205 mk_add_options MOZ_OBJDIR=%{objdir}
206
207 export CFLAGS="%{rpmcflags}"
208 export CXXFLAGS="%{rpmcflags}"
209
210 %if %{with crashreporter}
211 export MOZ_DEBUG_SYMBOLS=1
212 %endif
213
214 # Options for 'configure' (same as command-line options).
215 ac_add_options --prefix=%{_prefix}
216 ac_add_options --exec-prefix=%{_exec_prefix}
217 ac_add_options --bindir=%{_bindir}
218 ac_add_options --sbindir=%{_sbindir}
219 ac_add_options --sysconfdir=%{_sysconfdir}
220 ac_add_options --datadir=%{_datadir}
221 ac_add_options --includedir=%{_includedir}
222 ac_add_options --libdir=%{_libdir}
223 ac_add_options --libexecdir=%{_libexecdir}
224 ac_add_options --localstatedir=%{_localstatedir}
225 ac_add_options --sharedstatedir=%{_sharedstatedir}
226 ac_add_options --mandir=%{_mandir}
227 ac_add_options --infodir=%{_infodir}
228 %if %{?debug:1}0
229 ac_add_options --disable-optimize
230 ac_add_options --enable-debug
231 ac_add_options --enable-debug-modules
232 ac_add_options --enable-debugger-info-modules
233 ac_add_options --enable-crash-on-assert
234 %else
235 ac_add_options --disable-debug
236 ac_add_options --disable-debug-modules
237 ac_add_options --disable-logging
238 ac_add_options --enable-optimize="%{rpmcflags} -Os"
239 %endif
240 ac_add_options --disable-strip
241 ac_add_options --disable-strip-libs
242 %if %{with tests}
243 ac_add_options --enable-tests
244 %else
245 ac_add_options --disable-tests
246 %endif
247 %if %{with gnomeui}
248 ac_add_options --enable-gnomeui
249 %else
250 ac_add_options --disable-gnomeui
251 %endif
252 %if %{with gnomevfs}
253 ac_add_options --enable-gnomevfs
254 %else
255 ac_add_options --disable-gnomevfs
256 %endif
257 %if %{with ldap}
258 ac_add_options --enable-ldap
259 ac_add_options --with-system-ldap
260 %else
261 ac_add_options --disable-ldap
262 %endif
263 %if %{with crashreporter}
264 ac_add_options --enable-crashreporter
265 %else
266 ac_add_options --disable-crashreporter
267 %endif
268 ac_add_options --disable-xterm-updates
269 ac_add_options --enable-postscript
270 %if %{with lightning}
271 ac_add_options --enable-calendar
272 %else
273 ac_add_options --disable-calendar
274 %endif
275 ac_add_options --disable-installer
276 ac_add_options --disable-jsd
277 ac_add_options --disable-updater
278 ac_add_options --disable-xprint
279 ac_add_options --disable-permissions
280 ac_add_options --disable-pref-extensions
281 ac_add_options --enable-canvas
282 ac_add_options --enable-crypto
283 ac_add_options --enable-mathml
284 ac_add_options --enable-pango
285 ac_add_options --enable-reorder
286 ac_add_options --enable-startup-notification
287 ac_add_options --enable-svg
288 ac_add_options --enable-system-cairo
289 ac_add_options --enable-system-hunspell
290 ac_add_options --enable-system-sqlite
291 ac_add_options --enable-xft
292 ac_add_options --enable-application=mail
293 ac_add_options --enable-default-toolkit=cairo-gtk2
294 ac_add_options --enable-xinerama
295 ac_add_options --with-distribution-id=org.pld-linux
296 ac_add_options --with-branding=icedove/branding
297 %if %{with xulrunner}
298 ac_add_options --with-libxul-sdk=$(pwd)/libxul-sdk
299 ac_add_options --enable-shared
300 %else
301 ac_add_options --enable-static
302 %endif
303 ac_add_options --with-pthreads
304 ac_add_options --with-system-bz2
305 ac_add_options --with-system-jpeg
306 ac_add_options --with-system-nspr
307 ac_add_options --with-system-nss
308 ac_add_options --with-system-png
309 ac_add_options --with-system-zlib
310 ac_add_options --enable-single-profile
311 ac_add_options --disable-profilesharing
312 ac_add_options --with-default-mozilla-five-home=%{_libdir}/%{name}
313 EOF
314
315 %{__make} -j1 -f client.mk build \
316         STRIP="/bin/true" \
317         MOZ_MAKE_FLAGS="%{?_smp_mflags}" \
318         CC="%{__cc}" \
319         CXX="%{__cxx}"
320
321 %if %{with crashreporter}
322 # create debuginfo for crash-stats.mozilla.com
323 %{__make} -j1 -C obj-%{_target_cpu} buildsymbols
324 %endif
325
326 %if %{with enigmail}
327 cd mailnews/extensions/enigmail
328 ./makemake -r -o %{objdir}
329 %{__make} -C %{objdir}/mailnews/extensions/enigmail \
330         STRIP="/bin/true" \
331         CC="%{__cc}" \
332         CXX="%{__cxx}"
333 %endif
334
335 %install
336 rm -rf $RPM_BUILD_ROOT
337 install -d $RPM_BUILD_ROOT{%{_bindir},%{_libdir}/%{name},%{_datadir}/%{name},%{_pixmapsdir},%{_desktopdir}}
338
339 cd %{objdir}
340 %{__make} -C mail/installer stage-package \
341         DESTDIR=$RPM_BUILD_ROOT \
342         MOZ_PKG_APPDIR=%{_libdir}/%{name} \
343         PKG_SKIP_STRIP=1
344
345 # Enable crash reporter for Firefox application
346 %if %{with crashreporter}
347 %{__sed} -i -e 's/\[Crash Reporter\]/[Crash Reporter]\nEnabled=1/' $RPM_BUILD_ROOT%{_libdir}/%{name}/application.ini
348
349 # Add debuginfo for crash-stats.mozilla.com
350 install -d $RPM_BUILD_ROOT%{_exec_prefix}/lib/debug%{_libdir}/%{name}
351 cp -a mozilla/dist/%{name}-%{version}.en-US.linux-*.crashreporter-symbols.zip $RPM_BUILD_ROOT%{_prefix}/lib/debug%{_libdir}/%{name}
352 %endif
353
354 # copy manually lightning files, somewhy they are not installed by make
355 cp -a mozilla/dist/bin/extensions/calendar-timezones@mozilla.org \
356         mozilla/dist/bin/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103} \
357         $RPM_BUILD_ROOT%{_libdir}/%{name}/extensions
358
359 # move arch independant ones to datadir
360 mv $RPM_BUILD_ROOT%{_libdir}/%{name}/chrome $RPM_BUILD_ROOT%{_datadir}/%{name}/chrome
361 mv $RPM_BUILD_ROOT%{_libdir}/%{name}/defaults $RPM_BUILD_ROOT%{_datadir}/%{name}/defaults
362 mv $RPM_BUILD_ROOT%{_libdir}/%{name}/greprefs $RPM_BUILD_ROOT%{_datadir}/%{name}/greprefs
363 mv $RPM_BUILD_ROOT%{_libdir}/%{name}/isp $RPM_BUILD_ROOT%{_datadir}/%{name}/isp
364 mv $RPM_BUILD_ROOT%{_libdir}/%{name}/modules $RPM_BUILD_ROOT%{_datadir}/%{name}/modules
365 mv $RPM_BUILD_ROOT%{_libdir}/%{name}/res $RPM_BUILD_ROOT%{_datadir}/%{name}/res
366 ln -s ../../share/%{name}/chrome $RPM_BUILD_ROOT%{_libdir}/%{name}/chrome
367 ln -s ../../share/%{name}/defaults $RPM_BUILD_ROOT%{_libdir}/%{name}/defaults
368 ln -s ../../share/%{name}/greprefs $RPM_BUILD_ROOT%{_libdir}/%{name}/greprefs
369 ln -s ../../share/%{name}/isp $RPM_BUILD_ROOT%{_libdir}/%{name}/isp
370 ln -s ../../share/%{name}/modules $RPM_BUILD_ROOT%{_libdir}/%{name}/modules
371 ln -s ../../share/%{name}/res $RPM_BUILD_ROOT%{_libdir}/%{name}/res
372
373 %{__rm} -r $RPM_BUILD_ROOT%{_libdir}/%{name}/dictionaries
374 ln -s %{_datadir}/myspell $RPM_BUILD_ROOT%{_libdir}/%{name}/dictionaries
375
376 %{__sed} -e 's,@LIBDIR@,%{_libdir},' %{SOURCE5} > $RPM_BUILD_ROOT%{_bindir}/icedove
377 ln -s %{name} $RPM_BUILD_ROOT%{_bindir}/thunderbird
378 ln -s %{name} $RPM_BUILD_ROOT%{_bindir}/mozilla-thunderbird
379
380 cp -a %{SOURCE4} $RPM_BUILD_ROOT%{_desktopdir}/%{name}.desktop
381 cp -a %{topdir}/mozilla/icedove/branding/content/icon64.png $RPM_BUILD_ROOT%{_pixmapsdir}/%{name}.png
382
383 # files created by regxpcom -register in post
384 touch $RPM_BUILD_ROOT%{_libdir}/%{name}/components/compreg.dat
385 touch $RPM_BUILD_ROOT%{_libdir}/%{name}/components/xpti.dat
386 cat << 'EOF' > $RPM_BUILD_ROOT%{_libdir}/%{name}/register
387 #!/bin/sh
388 umask 022
389 # make temporary HOME, as it attempts to touch files in $HOME/.mozilla
390 # dangerous if you run this with sudo with keep_env += HOME
391 # also TMPDIR could be pointing to sudo user's homedir so we reset that too.
392 t=$(mktemp -d)
393 %{__rm} %{_libdir}/%{name}/components/{compreg,xpti}.dat
394 TMPDIR= TMP= HOME=$t %{_libdir}/%{name}/icedove -register
395 rm -rf $t
396 EOF
397 chmod a+rx $RPM_BUILD_ROOT%{_libdir}/%{name}/register
398
399 %if %{with enigmail}
400 ext_dir=$RPM_BUILD_ROOT%{_libdir}/%{name}/extensions/\{847b3a00-7ab1-11d4-8f02-006008948af5\}
401 install -d $ext_dir/{chrome,components,defaults/preferences}
402 cd mozilla/dist/bin
403 cp -rfLp chrome/enigmail.jar $ext_dir/chrome
404 cp -rfLp chrome/enigmime.jar $ext_dir/chrome
405 cp -rfLp components/enig* $ext_dir/components
406 cp -rfLp components/libenigmime.so $ext_dir/components
407 cp -rfLp components/libipc.so $ext_dir/components
408 cp -rfLp components/ipc.xpt $ext_dir/components
409 cp -rfLp defaults/preferences/enigmail.js $ext_dir/defaults/preferences
410 cd -
411 cp -a %{topdir}/mozilla/mailnews/extensions/enigmail/package/install.rdf $ext_dir
412 cp -a %{topdir}/mozilla/mailnews/extensions/enigmail/package/chrome.manifest $ext_dir/chrome.manifest
413 %endif
414
415 # remove unecessary stuff
416 %{__rm} $RPM_BUILD_ROOT%{_libdir}/%{name}/README.txt
417 %{__rm} $RPM_BUILD_ROOT%{_libdir}/%{name}/components/components.list
418 %{__rm} $RPM_BUILD_ROOT%{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/components/components.list
419
420 # never package these. always remove
421 # nss
422 %{__rm} -f $RPM_BUILD_ROOT%{_libdir}/%{name}/lib{freebl3,nss3,nssckbi,nssdbm3,nssutil3,smime3,softokn3,ssl3}.*
423 # nspr
424 %{__rm} -f $RPM_BUILD_ROOT%{_libdir}/%{name}/lib{nspr4,plc4,plds4}.so
425 # mozldap
426 %{__rm} -f $RPM_BUILD_ROOT%{_libdir}/%{name}/lib{ldap,ldif,prldap,ssldap}60.so
427
428 %clean
429 rm -rf $RPM_BUILD_ROOT
430
431 %pretrans
432 if [ -d %{_libdir}/%{name}/dictionaries ] && [ ! -L %{_libdir}/%{name}/dictionaries ]; then
433         mv -v %{_libdir}/%{name}/dictionaries{,.rpmsave}
434 fi
435 for d in chrome defaults greprefs icons isp modules res; do
436         if [ -d %{_libdir}/%{name}/$d ] && [ ! -L %{_libdir}/%{name}/$d ]; then
437                 install -d %{_datadir}/%{name}
438                 mv %{_libdir}/%{name}/$d %{_datadir}/%{name}/$d
439         fi
440 done
441 exit 0
442
443 %post
444 %{_libdir}/%{name}/register || :
445
446 %files
447 %defattr(644,root,root,755)
448 %attr(755,root,root) %{_bindir}/icedove
449 %attr(755,root,root) %{_bindir}/mozilla-thunderbird
450 %attr(755,root,root) %{_bindir}/thunderbird
451 %dir %{_libdir}/%{name}
452 %{_libdir}/%{name}/application.ini
453 %{_libdir}/%{name}/platform.ini
454 %dir %{_libdir}/%{name}/components
455 %attr(755,root,root) %{_libdir}/%{name}/components/*.so
456 %{_libdir}/%{name}/components/*.js
457 %{_libdir}/%{name}/components/*.xpt
458 %attr(755,root,root) %{_libdir}/%{name}/libmozjs.so
459 %attr(755,root,root) %{_libdir}/%{name}/libxpcom.so
460 %attr(755,root,root) %{_libdir}/%{name}/libxpcom_core.so
461 %attr(755,root,root) %{_libdir}/%{name}/*.sh
462 %attr(755,root,root) %{_libdir}/%{name}/*-bin
463 %attr(755,root,root) %{_libdir}/%{name}/mozilla-xremote-client
464 %attr(755,root,root) %{_libdir}/%{name}/icedove
465 %attr(755,root,root) %{_libdir}/%{name}/register
466
467 # symlinks
468 %{_libdir}/%{name}/chrome
469 %{_libdir}/%{name}/defaults
470 %{_libdir}/%{name}/dictionaries
471 %{_libdir}/%{name}/greprefs
472 %{_libdir}/%{name}/isp
473 %{_libdir}/%{name}/modules
474 %{_libdir}/%{name}/res
475
476 %{_pixmapsdir}/*.png
477 %{_desktopdir}/*.desktop
478
479 %dir %{_datadir}/%{name}
480 %{_datadir}/%{name}/chrome
481 %{_datadir}/%{name}/defaults
482 %{_datadir}/%{name}/greprefs
483 %{_datadir}/%{name}/isp
484 %{_datadir}/%{name}/modules
485 %{_datadir}/%{name}/res
486
487 %if %{with crashreporter}
488 %attr(755,root,root) %{_libdir}/%{name}/crashreporter
489 %{_libdir}/%{name}/crashreporter.ini
490 %{_libdir}/%{name}/Throbber-small.gif
491 %endif
492
493 %dir %{_libdir}/%{name}/extensions
494 %{_libdir}/%{name}/extensions/{972ce4c6-7e08-4474-a285-3208198ce6fd}
495
496 # files created by regxpcom -register
497 %ghost %{_libdir}/%{name}/components/compreg.dat
498 %ghost %{_libdir}/%{name}/components/xpti.dat
499
500 %if %{with lightning}
501 %files addon-lightning
502 %defattr(644,root,root,755)
503 %dir %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}
504 %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/defaults
505 %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/chrome
506 %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/chrome.manifest
507 %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/install.rdf
508 %dir %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/components
509 %attr(755,root,root) %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/components/*.so
510 %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/components/*.xpt
511 %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/components/*.js
512 %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/modules
513 %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/calendar-js
514 %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/timezones.sqlite
515
516 %{_libdir}/%{name}/extensions/calendar-timezones@mozilla.org
517 %endif
518
519 %if %{with enigmail}
520 %files addon-enigmail
521 %defattr(644,root,root,755)
522 %dir %{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}
523 %{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/defaults
524 %{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/chrome
525 %{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/chrome.manifest
526 %{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/install.rdf
527 %dir %{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/components
528 %attr(755,root,root) %{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/components/*.so
529 %{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/components/*.xpt
530 %{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/components/*.js
531 %endif
This page took 0.184019 seconds and 4 git commands to generate.