]> git.pld-linux.org Git - packages/thunderbird.git/blob - icedove.spec
- removed outdated patches
[packages/thunderbird.git] / icedove.spec
1 #
2 # Conditional builds
3 %bcond_without  enigmail        # don't build enigmail - GPG/PGP support
4 %bcond_without  gnomeui         # disable gnomeui support
5 %bcond_without  gnomevfs        # disable GNOME comp. (gconf+libgnome+gnomevfs) and gnomevfs ext.
6 %bcond_without  gnome           # disable all GNOME components (gnome+gnomeui+gnomevfs)
7 %bcond_without  ldap            # disable e-mail address lookups in LDAP directories
8 #
9 %if %{without gnome}
10 %undefine       with_gnomeui
11 %undefine       with_gnomevfs
12 %endif
13 %define         enigmail_ver            1.0.0
14
15 Summary:        Icedove - email client
16 Summary(pl.UTF-8):      Icedove - klient poczty
17 Name:           icedove
18 Version:        3.0
19 Release:        0.1
20 License:        MPL 1.1 or GPL v2+ or LGPL v2.1+
21 Group:          Applications/Networking
22 Source0:        http://releases.mozilla.org/pub/mozilla.org/thunderbird/releases/%{version}/source/thunderbird-%{version}.source.tar.bz2
23 # Source0-md5:  9a564ac2489b1b0f9348dc298b913f6c
24 Source1:        http://www.mozilla-enigmail.org/download/source/enigmail-%{enigmail_ver}.tar.gz
25 # Source1-md5:  e3a6d379f1a72ac023751bdde2de750a
26 Source2:        %{name}-branding.tar.bz2
27 # Source2-md5:  e775b8cb658de32f30b403bc9b7950bf
28 Source3:        %{name}-rm_nonfree.sh
29 Source4:        %{name}.desktop
30 Source5:        %{name}.sh
31 Source6:        %{name}-enigmail.manifest
32 Patch0:         %{name}-branding.patch
33 Patch1:         %{name}-enigmail-shared.patch
34 Patch2:         %{name}-gcc.patch
35 Patch3:         %{name}-fonts.patch
36 Patch4:         %{name}-install.patch
37 Patch5:         %{name}-myspell.patch
38 Patch6:         %{name}-prefs.patch
39 URL:            http://www.pld-linux.org/Packages/Icedove
40 %{?with_gnomevfs:BuildRequires: GConf2-devel >= 1.2.1}
41 BuildRequires:  automake
42 BuildRequires:  freetype-devel >= 1:2.1.8
43 %{?with_gnomevfs:BuildRequires: gnome-vfs2-devel >= 2.0}
44 BuildRequires:  gtk+2-devel >= 1:2.0.0
45 BuildRequires:  libIDL-devel >= 0.8.0
46 %{?with_gnomevfs:BuildRequires: libgnome-devel >= 2.0}
47 %{?with_gnomeui:BuildRequires:  libgnomeui-devel >= 2.2.0}
48 BuildRequires:  libjpeg-devel >= 6b
49 BuildRequires:  libpng-devel >= 1.2.0
50 BuildRequires:  libstdc++-devel
51 BuildRequires:  myspell-devel
52 BuildRequires:  nspr-devel >= 1:4.8
53 BuildRequires:  nss-devel >= 1:3.12.0
54 BuildRequires:  pango-devel >= 1:1.1.0
55 BuildRequires:  sed >= 4.0
56 BuildRequires:  xorg-lib-libXext-devel
57 BuildRequires:  xorg-lib-libXft-devel >= 2.1
58 BuildRequires:  xorg-lib-libXinerama-devel
59 BuildRequires:  xorg-lib-libXp-devel
60 BuildRequires:  xorg-lib-libXt-devel
61 Requires:       myspell-common
62 Requires:       nspr >= 1:4.6.1
63 Requires:       nss >= 1:3.11.3
64 Obsoletes:      mozilla-thunderbird
65 Obsoletes:      mozilla-thunderbird-dictionary-en-US
66 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
67
68 %define         filterout_cpp           -D_FORTIFY_SOURCE=[0-9]+
69
70 # iceweasel/icedove/iceape provide their own versions
71 %define         _noautoreqdep           libgfxpsshar.so libgkgfx.so libgtkxtbin.so libjsj.so libxpcom_compat.so libxpcom_core.so libxpistub.so
72 %define         _noautoprovfiles        %{_libdir}/%{name}/components
73 # we don't want these to satisfy xulrunner-devel
74 %define         _noautoprov             libgtkembedmoz.so libldap50.so libmozjs.so libprldap50.so libssldap50.so libxpcom.so libxul.so
75 # and as we don't provide them, don't require either
76 %define         _noautoreq              libgtkembedmoz.so libldap50.so libmozjs.so libprldap50.so libssldap50.so libxpcom.so libxul.so
77
78 %description
79 Icedove is an open-source,fast and portable email client.
80
81 %description -l pl.UTF-8
82 Icedove jest open sourcowym, szybkim i przenośnym klientem poczty.
83
84 %package addon-enigmail
85 Summary:        Extension for the authentication and encryption features provided by GnuPG
86 Summary(pl.UTF-8):      Rozszerzenie do uwierzytelniania i szyfrowania zapewnianego przez GnuPG
87 License:        MPL/LGPL
88 Group:          Applications/Networking
89 URL:            http://enigmail.mozdev.org/
90 Requires:       %{name} = %{version}-%{release}
91 Obsoletes:      mozilla-thunderbird-addon-enigmail
92
93 %description addon-enigmail
94 Enigmail is an extension to the Icedove mail client which allows users
95 to access the authentication and encryption features provided by
96 GnuPG.
97
98 Main Features:
99 - Encrypt/sign mail when sending, decrypt/authenticate received mail
100 - Support for inline-PGP (RFC 2440) and PGP/MIME (RFC 3156)
101 - Per-Account based encryption and signing defaults
102 - Per-Recipient rules for automated key selection, and
103   enabling/disabling encryption and signing
104 - OpenPGP key management interface
105
106 %description addon-enigmail -l pl.UTF-8
107 Enigmail to rozszerzenie klienta pocztowego Icedove pozwalające
108 użytkownikom na dostęp do uwierzytelniania i szyfrowania zapewnianego
109 przez GnuPG.
110
111 Główne możliwości:
112 - szyfrowanie/podpisywanie poczty przy wysyłaniu,
113   odszyfrowywanie/uwierzytelnianie poczty odebranej
114 - obsługa inline-PGP (RFC 2440) i PGP/MIME (RFC 3156)
115 - ustawienia domyślne szyfrowania i podpisywania dla każdego konta
116 - reguły automatycznego wyboru kluczy i włączenia szyfrowania oraz
117   podpisywania dla każdego adresata
118 - interfejs do zarządzania kluczami OpenPGP
119
120 %prep
121 %setup -q -c -a2
122 cd comm-1.9.1
123 %{?with_enigmail:tar xvfz %{SOURCE1} -C mailnews/extensions}
124 /bin/sh %{SOURCE3}
125 %patch0 -p1
126 %{?with_enigmail:%patch1 -p1}
127 %patch2 -p1
128 %patch3 -p1
129 %patch4 -p1
130 #%patch5 -p1
131 %patch6 -p0
132
133 %build
134 cd comm-1.9.1
135 export CFLAGS="%{rpmcflags} `%{_bindir}/pkg-config mozilla-nspr --cflags-only-I`"
136 export CXXFLAGS="%{rpmcflags} `%{_bindir}/pkg-config mozilla-nspr --cflags-only-I`"
137
138 cp -f %{_datadir}/automake/config.* mozilla/build/autoconf
139 cp -f %{_datadir}/automake/config.* mozilla/nsprpub/build/autoconf
140 cp -f %{_datadir}/automake/config.* directory/c-sdk/config/autoconf
141
142 cat << 'EOF' > .mozconfig
143
144 mk_add_options MOZ_OBJDIR=@TOPSRCDIR@/obj-%{_target_cpu}
145
146 ac_add_options --prefix=%{_prefix}
147 ac_add_options --exec-prefix=%{_exec_prefix}
148 ac_add_options --bindir=%{_bindir}
149 ac_add_options --sbindir=%{_sbindir}
150 ac_add_options --sysconfdir=%{_sysconfdir}
151 ac_add_options --datadir=%{_datadir}
152 ac_add_options --includedir=%{_includedir}
153 ac_add_options --libdir=%{_libdir}
154 ac_add_options --libexecdir=%{_libexecdir}
155 ac_add_options --localstatedir=%{_localstatedir}
156 ac_add_options --sharedstatedir=%{_sharedstatedir}
157 ac_add_options --mandir=%{_mandir}
158 ac_add_options --infodir=%{_infodir}
159 %if %{?debug:1}0
160 ac_add_options --enable-debug
161 ac_add_options --enable-debug-modules
162 %else
163 ac_add_options --disable-debug
164 ac_add_options --disable-debug-modules
165 %endif
166 %if %{with tests}
167 ac_add_options --enable-tests
168 %else
169 ac_add_options --disable-tests
170 %endif
171 %if %{with gnomeui}
172 ac_add_options --enable-gnomeui
173 %else
174 ac_add_options --disable-gnomeui
175 %endif
176 %if %{with gnomevfs}
177 ac_add_options --enable-gnomevfs
178 %else
179 ac_add_options --disable-gnomevfs
180 %endif
181 %if %{with ldap}
182 ac_add_options --enable-ldap
183 %else
184 ac_add_options --disable-ldap
185 %endif
186 ac_add_options --enable-calendar
187 ac_add_options --disable-installer
188 ac_add_options --disable-jsd
189 ac_add_options --disable-xprint
190 ac_add_options --disable-permissions
191 ac_add_options --disable-pref-extensions
192 ac_add_options --enable-canvas
193 ac_add_options --enable-crypto
194 ac_add_options --enable-default-toolkit="gtk2"
195 ac_add_options --enable-mathml
196 ac_add_options --enable-optimize="%{rpmcflags}"
197 ac_add_options --enable-pango
198 ac_add_options --enable-reorder
199 ac_add_options --enable-static
200 ac_add_options --disable-strip
201 ac_add_options --disable-strip-libs
202 ac_add_options --enable-system-cairo
203 ac_add_options --enable-system-myspell
204 ac_add_options --enable-svg
205 ac_add_options --enable-xft
206 ac_add_options --enable-application=mail
207 ac_add_options --enable-default-toolkit=cairo-gtk2
208 ac_add_options --enable-xinerama
209 ac_add_options --with-system-jpeg
210 ac_add_options --with-system-nspr
211 ac_add_options --with-system-nss
212 ac_add_options --with-system-png
213 ac_add_options --with-system-zlib
214 ac_add_options --with-pthreads
215 ac_add_options --enable-single-profile
216 ac_add_options --disable-profilesharing
217 ac_add_options --with-distribution-id=org.pld-linux
218 #ac_add_options --with-branding=icedove/branding
219 ac_add_options --with-default-mozilla-five-home=%{_libdir}/%{name}
220 EOF
221
222 %{__make} -j1 -f client.mk build \
223         CC="%{__cc}" \
224         CXX="%{__cxx}"
225
226 %if %{with enigmail}
227         cd mailnews/extensions/enigmail
228         ./makemake -r
229         %{__make} -C ../../../obj-%{_target_cpu}/mailnews/extensions/enigmail
230 %endif
231
232 %install
233 rm -rf $RPM_BUILD_ROOT
234 install -d $RPM_BUILD_ROOT{%{_bindir},%{_libdir},%{_pixmapsdir},%{_desktopdir}} \
235                $RPM_BUILD_ROOT%{_datadir}/%{name}
236 install -d $RPM_BUILD_ROOT%{_libdir}/%{name}
237
238 cd comm-1.9.1
239 %{__make} -C obj-%{_target_cpu}/mail/installer stage-package \
240         DESTDIR=$RPM_BUILD_ROOT \
241         MOZ_PKG_APPDIR=%{_libdir}/%{name} \
242         PKG_SKIP_STRIP=1
243
244 # move arch independant ones to datadir
245 mv $RPM_BUILD_ROOT%{_libdir}/%{name}/chrome $RPM_BUILD_ROOT%{_datadir}/%{name}/chrome
246 mv $RPM_BUILD_ROOT%{_libdir}/%{name}/defaults $RPM_BUILD_ROOT%{_datadir}/%{name}/defaults
247 mv $RPM_BUILD_ROOT%{_libdir}/%{name}/greprefs $RPM_BUILD_ROOT%{_datadir}/%{name}/greprefs
248 mv $RPM_BUILD_ROOT%{_libdir}/%{name}/icons $RPM_BUILD_ROOT%{_datadir}/%{name}/icons
249 #mv $RPM_BUILD_ROOT%{_libdir}/%{name}/init.d $RPM_BUILD_ROOT%{_datadir}/%{name}/init.d
250 mv $RPM_BUILD_ROOT%{_libdir}/%{name}/isp $RPM_BUILD_ROOT%{_datadir}/%{name}/isp
251 mv $RPM_BUILD_ROOT%{_libdir}/%{name}/res $RPM_BUILD_ROOT%{_datadir}/%{name}/res
252 ln -s ../../share/%{name}/chrome $RPM_BUILD_ROOT%{_libdir}/%{name}/chrome
253 ln -s ../../share/%{name}/defaults $RPM_BUILD_ROOT%{_libdir}/%{name}/defaults
254 ln -s ../../share/%{name}/greprefs $RPM_BUILD_ROOT%{_libdir}/%{name}/greprefs
255 ln -s ../../share/%{name}/icons $RPM_BUILD_ROOT%{_libdir}/%{name}/icons
256 ln -s ../../share/%{name}/init.d $RPM_BUILD_ROOT%{_libdir}/%{name}/init.d
257 ln -s ../../share/%{name}/isp $RPM_BUILD_ROOT%{_libdir}/%{name}/isp
258 ln -s ../../share/%{name}/res $RPM_BUILD_ROOT%{_libdir}/%{name}/res
259
260 rm -rf $RPM_BUILD_ROOT%{_libdir}/%{name}/dictionaries
261 ln -s %{_datadir}/myspell $RPM_BUILD_ROOT%{_libdir}/%{name}/dictionaries
262
263 %{__sed} -e 's,@LIBDIR@,%{_libdir},' %{SOURCE5} > $RPM_BUILD_ROOT%{_bindir}/icedove
264 ln -s %{name} $RPM_BUILD_ROOT%{_bindir}/thunderbird
265 ln -s %{name} $RPM_BUILD_ROOT%{_bindir}/mozilla-thunderbird
266
267 install %{SOURCE4} $RPM_BUILD_ROOT%{_desktopdir}/%{name}.desktop
268
269 %if %{with enigmail}
270 _enig_dir=$RPM_BUILD_ROOT%{_libdir}/%{name}/extensions/\{847b3a00-7ab1-11d4-8f02-006008948af5\}
271 install -d $_enig_dir/chrome
272 install -d $_enig_dir/components
273 install -d $_enig_dir/defaults/preferences
274 mv -f $RPM_BUILD_ROOT%{_libdir}/%{name}/chrome/enigmail.jar $_enig_dir/chrome
275 #mv -f $RPM_BUILD_ROOT%{_libdir}/%{name}/chrome/enigmail-skin-seamonkey.jar $_enig_dir/chrome
276 mv -f $RPM_BUILD_ROOT%{_libdir}/%{name}/components/enig* $_enig_dir/components
277 mv -f $RPM_BUILD_ROOT%{_libdir}/%{name}/components/libenigmime.so $_enig_dir/components
278 #mv -f $RPM_BUILD_ROOT%{_libdir}/%{name}/components/libipc.so $_enig_dir/components
279 mv -f $RPM_BUILD_ROOT%{_libdir}/%{name}/components/ipc.xpt $_enig_dir/components
280 mv -f $RPM_BUILD_ROOT%{_libdir}/%{name}/defaults/preferences/enigmail.js $_enig_dir/defaults/preferences
281 cp -f mailnews/extensions/enigmail/package/install.rdf $_enig_dir
282 rm -rf $RPM_BUILD_ROOT%{_libdir}/%{name}/defaults/preferences
283 rm -f $RPM_BUILD_ROOT%{_libdir}/%{name}/chrome/enigmail-en-US.jar
284 rm -f $RPM_BUILD_ROOT%{_libdir}/%{name}/chrome/enigmail-skin.jar
285 rm -f $RPM_BUILD_ROOT%{_libdir}/%{name}/chrome/enigmime.jar
286 rm -rf $RPM_BUILD_ROOT%{_libdir}/%{name}/components/enig*
287 rm -f $RPM_BUILD_ROOT%{_libdir}/%{name}/components/libenigmime.so
288 rm -f $RPM_BUILD_ROOT%{_libdir}/%{name}/components/ipc.xpt
289 cp -f %{SOURCE6} $_enig_dir/chrome.manifest
290 #cp -f icedove/branding/content/icon64.png $RPM_BUILD_ROOT%{_pixmapsdir}/icedove.png
291 %endif
292
293 # win32 stuff
294 rm -f $RPM_BUILD_ROOT%{_libdir}/%{name}/dirver
295
296 %clean
297 rm -rf $RPM_BUILD_ROOT
298
299 %pretrans
300 if [ -d %{_libdir}/%{name}/dictionaries ] && [ ! -L %{_libdir}/%{name}/dictionaries ]; then
301         mv -v %{_libdir}/%{name}/dictionaries{,.rpmsave}
302 fi
303 for d in chrome defaults greprefs icons init.d isp res; do
304         if [ -d %{_libdir}/%{name}/$d ] && [ ! -L %{_libdir}/%{name}/$d ]; then
305                 install -d %{_datadir}/%{name}
306                 mv %{_libdir}/%{name}/$d %{_datadir}/%{name}/$d
307         fi
308 done
309 exit 0
310
311 %files
312 %defattr(644,root,root,755)
313 %attr(755,root,root) %{_bindir}/icedove
314 %attr(755,root,root) %{_bindir}/mozilla-thunderbird
315 %attr(755,root,root) %{_bindir}/thunderbird
316 %dir %{_libdir}/%{name}
317 %{_libdir}/%{name}/*.ini
318 %dir %{_libdir}/%{name}/components
319 %attr(755,root,root) %{_libdir}/%{name}/components/*.so
320 %{_libdir}/%{name}/components/*.js
321 %{_libdir}/%{name}/components/*.xpt
322 %attr(755,root,root) %{_libdir}/%{name}/*.so
323 %attr(755,root,root) %{_libdir}/%{name}/*.sh
324 %attr(755,root,root) %{_libdir}/%{name}/*-bin
325 %attr(755,root,root) %{_libdir}/%{name}/mozilla-xremote-client
326 #%attr(755,root,root) %{_libdir}/%{name}/reg*
327 #%attr(755,root,root) %{_libdir}/%{name}/icedove
328 %{_libdir}/%{name}/*.txt
329 #%attr(755,root,root) %{_libdir}/%{name}/x*
330
331 # symlinks
332 %{_libdir}/%{name}/chrome
333 %{_libdir}/%{name}/defaults
334 %{_libdir}/%{name}/dictionaries
335 %{_libdir}/%{name}/greprefs
336 %{_libdir}/%{name}/icons
337 %{_libdir}/%{name}/init.d
338 %{_libdir}/%{name}/isp
339 %{_libdir}/%{name}/res
340
341 %{_libdir}/%{name}/dependentlibs.list
342 %{_libdir}/%{name}/updater
343 #%{_pixmapsdir}/*.png
344 %{_desktopdir}/*.desktop
345
346 %dir %{_datadir}/%{name}
347 %{_datadir}/%{name}/chrome
348 %{_datadir}/%{name}/defaults
349 %{_datadir}/%{name}/greprefs
350 %{_datadir}/%{name}/icons
351 #%{_datadir}/%{name}/init.d
352 %{_datadir}/%{name}/isp
353 %{_datadir}/%{name}/res
354
355 %dir %{_libdir}/%{name}/modules
356 %{_libdir}/%{name}/modules/*.js*
357 %dir %{_libdir}/%{name}/modules/activity
358 %{_libdir}/%{name}/modules/activity/*.js
359 %dir %{_libdir}/%{name}/modules/gloda
360 %{_libdir}/%{name}/modules/gloda/*.js
361
362 %dir %{_libdir}/%{name}/extensions
363 %{_libdir}/%{name}/extensions/{972ce4c6-7e08-4474-a285-3208198ce6fd}
364
365 %if %{with enigmail}
366 %files addon-enigmail
367 %defattr(644,root,root,755)
368 %{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}
369 %endif
This page took 0.180862 seconds and 4 git commands to generate.