]> git.pld-linux.org Git - packages/thunderbird.git/blob - icedove.spec
- BR: xulrunner-devel for xulrunner bcond
[packages/thunderbird.git] / icedove.spec
1 # TODO:
2 # - separate spec for enigmail
3 # - fix icedove (building) and installing nss/nspr libs!
4 # - build with system mozldap
5 #
6 # Conditional builds
7 %bcond_without  enigmail        # don't build enigmail - GPG/PGP support
8 %bcond_without  gnomeui         # disable gnomeui support
9 %bcond_without  gnomevfs        # disable GNOME comp. (gconf+libgnome+gnomevfs) and gnomevfs ext.
10 %bcond_without  gnome           # disable all GNOME components (gnome+gnomeui+gnomevfs)
11 %bcond_without  ldap            # disable e-mail address lookups in LDAP directories
12 %bcond_without  lightning       # disable sunbird calendar
13 %bcond_without  xulrunner       # build with xulrunner
14 %bcond_with     crashreporter   # report crashes to crash-stats.mozilla.com
15
16 %if %{without gnome}
17 %undefine       with_gnomeui
18 %undefine       with_gnomevfs
19 %endif
20
21 %if 0%{?_enable_debug_packages} != 1
22 %undefine       crashreporter
23 %endif
24
25 %define         enigmail_ver    1.1.2
26 %define         nspr_ver                4.8.8
27 %define         nss_ver                 3.12.10
28
29 %if %{without xulrunner}
30 # The actual sqlite version (see RHBZ#480989):
31 %define         sqlite_build_version %(pkg-config --silence-errors --modversion sqlite3 2>/dev/null || echo ERROR)
32 %endif
33
34 Summary:        Icedove - email client
35 Summary(pl.UTF-8):      Icedove - klient poczty
36 Name:           icedove
37 Version:        6.0
38 Release:        0.1
39 License:        MPL 1.1 or GPL v2+ or LGPL v2.1+
40 Group:          X11/Applications/Networking
41 Source0:        http://releases.mozilla.org/pub/mozilla.org/thunderbird/releases/%{version}/source/thunderbird-%{version}.source.tar.bz2
42 # Source0-md5:  9ac741d238e95790cdeb5222e9b23ae8
43 Source1:        http://www.mozilla-enigmail.org/download/source/enigmail-%{enigmail_ver}.tar.gz
44 # Source1-md5:  7d329d5e8afbbb28214ca1995beb09c9
45 Source2:        %{name}-branding.tar.bz2
46 # Source2-md5:  2da351522bdd7f4a3bd8aaff4c776976
47 Source3:        %{name}-rm_nonfree.sh
48 Source4:        %{name}.desktop
49 Source5:        %{name}.sh
50 Patch0:         %{name}-branding.patch
51 Patch1:         %{name}-enigmail-shared.patch
52 Patch2:         %{name}-gcc.patch
53 Patch3:         %{name}-fonts.patch
54 Patch4:         %{name}-install.patch
55 Patch5:         %{name}-hunspell.patch
56 Patch6:         %{name}-prefs.patch
57 Patch7:         system-mozldap.patch
58 Patch8:         %{name}-makefile.patch
59 Patch10:        %{name}-extensiondir.patch
60 Patch11:        crashreporter.patch
61 Patch12:        no-subshell.patch
62 URL:            http://www.pld-linux.org/Packages/Icedove
63 %{?with_gnomevfs:BuildRequires: GConf2-devel >= 1.2.1}
64 BuildRequires:  alsa-lib-devel
65 BuildRequires:  automake
66 BuildRequires:  bzip2-devel
67 BuildRequires:  freetype-devel >= 1:2.1.8
68 %{?with_gnomevfs:BuildRequires: gnome-vfs2-devel >= 2.0}
69 BuildRequires:  gtk+2-devel >= 1:2.0.0
70 BuildRequires:  hunspell-devel
71 BuildRequires:  libIDL-devel >= 0.8.0
72 %{?with_gnomevfs:BuildRequires: libgnome-devel >= 2.0}
73 %{?with_gnomeui:BuildRequires:  libgnome-keyring-devel}
74 %{?with_gnomeui:BuildRequires:  libgnomeui-devel >= 2.2.0}
75 BuildRequires:  libiw-devel
76 BuildRequires:  libjpeg-devel >= 6b
77 BuildRequires:  libnotify-devel >= 0.4
78 BuildRequires:  libpng-devel >= 1.2.0
79 BuildRequires:  libstdc++-devel
80 BuildRequires:  nspr-devel >= 1:%{nspr_ver}
81 BuildRequires:  nss-devel >= 1:%{nss_ver}
82 BuildRequires:  pango-devel >= 1:1.1.0
83 BuildRequires:  pkgconfig
84 BuildRequires:  sed >= 4.0
85 BuildRequires:  sqlite3-devel >= 3.7.4
86 BuildRequires:  startup-notification-devel >= 0.8
87 BuildRequires:  xorg-lib-libXext-devel
88 BuildRequires:  xorg-lib-libXinerama-devel
89 BuildRequires:  xorg-lib-libXt-devel
90 BuildRequires:  zip
91 Requires(post): mktemp >= 1.5-18
92 %if %{with xulrunner}
93 BuildRequires:  xulrunner-devel
94 %else
95 Requires:       myspell-common
96 Requires:       nspr >= 1:%{nspr_ver}
97 Requires:       nss >= 1:%{nss_ver}
98 Requires:       sqlite3 >= %{sqlite_build_version}
99 %endif
100 Obsoletes:      mozilla-thunderbird
101 Obsoletes:      mozilla-thunderbird-dictionary-en-US
102 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
103
104 %define         filterout_cpp           -D_FORTIFY_SOURCE=[0-9]+
105
106 # iceweasel/icedove/iceape provide their own versions
107 %define         _noautoreqdep           libgfxpsshar.so libgkgfx.so libgtkxtbin.so libjsj.so libxpcom_compat.so libxpistub.so
108 %define         _noautoprovfiles        %{_libdir}/%{name}/components
109 # we don't want these to satisfy xulrunner-devel
110 %define         _noautoprov             libgtkembedmoz.so libmozjs.so libxpcom.so libxul.so libxpcom_core.so
111 # and as we don't provide them, don't require either
112 %define         _noautoreq              libgtkembedmoz.so libmozjs.so libxpcom.so libxul.so libxpcom_core.so
113
114 %define         topdir          %{_builddir}/%{name}-%{version}
115 %define         objdir          %{topdir}/obj-%{_target_cpu}
116
117 %description
118 Icedove is an open-source,fast and portable email client.
119
120 %description -l pl.UTF-8
121 Icedove jest open sourcowym, szybkim i przenośnym klientem poczty.
122
123 %package addon-lightning
124 Summary:        An integrated calendar for Icedove
125 Summary(pl.UTF-8):      Zintegrowany kalendarz dla Icedove
126 License:        MPL 1.1 or GPL v2+ or LGPL v2.1+
127 Group:          Applications/Networking
128 Requires:       %{name} = %{version}-%{release}
129
130 %description addon-lightning
131 Lightning is an calendar extension to Icedove email client.
132
133 %description addon-lightning -l pl.UTF-8
134 Lightning to rozszerzenie do klienta poczty Icedove dodające
135 funkcjonalność kalendarza.
136
137 %package addon-enigmail
138 Summary:        Extension for the authentication and encryption features provided by GnuPG
139 Summary(pl.UTF-8):      Rozszerzenie do uwierzytelniania i szyfrowania zapewnianego przez GnuPG
140 License:        MPL/LGPL
141 Group:          Applications/Networking
142 URL:            http://enigmail.mozdev.org/
143 Requires:       %{name} = %{version}-%{release}
144 Requires:       gnupg
145 Obsoletes:      mozilla-thunderbird-addon-enigmail
146
147 %description addon-enigmail
148 Enigmail is an extension to the Icedove mail client which allows users
149 to access the authentication and encryption features provided by
150 GnuPG.
151
152 Main Features:
153 - Encrypt/sign mail when sending, decrypt/authenticate received mail
154 - Support for inline-PGP (RFC 2440) and PGP/MIME (RFC 3156)
155 - Per-Account based encryption and signing defaults
156 - Per-Recipient rules for automated key selection, and
157   enabling/disabling encryption and signing
158 - OpenPGP key management interface
159
160 %description addon-enigmail -l pl.UTF-8
161 Enigmail to rozszerzenie klienta pocztowego Icedove pozwalające
162 użytkownikom na dostęp do uwierzytelniania i szyfrowania zapewnianego
163 przez GnuPG.
164
165 Główne możliwości:
166 - szyfrowanie/podpisywanie poczty przy wysyłaniu,
167   odszyfrowywanie/uwierzytelnianie poczty odebranej
168 - obsługa inline-PGP (RFC 2440) i PGP/MIME (RFC 3156)
169 - ustawienia domyślne szyfrowania i podpisywania dla każdego konta
170 - reguły automatycznego wyboru kluczy i włączenia szyfrowania oraz
171   podpisywania dla każdego adresata
172 - interfejs do zarządzania kluczami OpenPGP
173
174 %prep
175 %setup -qc
176 mv comm-release mozilla
177 %setup -q -T -D -a2
178 cd mozilla
179 %{?with_enigmail:%{__gzip} -dc %{SOURCE1} | %{__tar} -xf - -C mailnews/extensions}
180 /bin/sh %{SOURCE3}
181 %patch0 -p1
182 %{?with_enigmail:%patch1 -p1}
183 %patch2 -p1
184 %patch3 -p1
185 %patch4 -p1
186 %patch5 -p1
187 %patch6 -p1
188 %patch7 -p1
189 %patch8 -p2
190 %patch10 -p2
191 %patch11 -p2
192 %patch12 -p1
193
194 %build
195 cd mozilla
196 cp -f %{_datadir}/automake/config.* mozilla/build/autoconf
197 cp -f %{_datadir}/automake/config.* mozilla/nsprpub/build/autoconf
198 cp -f %{_datadir}/automake/config.* ldap/sdks/c-sdk/config/autoconf
199
200 install -d libxul-sdk
201 ln -snf %{_libdir}/xulrunner-sdk libxul-sdk/sdk
202
203 cat << EOF > .mozconfig
204 mk_add_options MOZ_OBJDIR=%{objdir}
205
206 export CFLAGS="%{rpmcflags} -fpermissive"
207 export CXXFLAGS="%{rpmcflags} -fpermissive"
208
209 %if %{with crashreporter}
210 export MOZ_DEBUG_SYMBOLS=1
211 %endif
212
213 # Options for 'configure' (same as command-line options).
214 ac_add_options --prefix=%{_prefix}
215 ac_add_options --exec-prefix=%{_exec_prefix}
216 ac_add_options --bindir=%{_bindir}
217 ac_add_options --sbindir=%{_sbindir}
218 ac_add_options --sysconfdir=%{_sysconfdir}
219 ac_add_options --datadir=%{_datadir}
220 ac_add_options --includedir=%{_includedir}
221 ac_add_options --libdir=%{_libdir}
222 ac_add_options --libexecdir=%{_libexecdir}
223 ac_add_options --localstatedir=%{_localstatedir}
224 ac_add_options --sharedstatedir=%{_sharedstatedir}
225 ac_add_options --mandir=%{_mandir}
226 ac_add_options --infodir=%{_infodir}
227 %if %{?debug:1}0
228 ac_add_options --disable-optimize
229 ac_add_options --enable-debug
230 ac_add_options --enable-debug-modules
231 ac_add_options --enable-debugger-info-modules
232 ac_add_options --enable-crash-on-assert
233 %else
234 ac_add_options --disable-debug
235 ac_add_options --disable-debug-modules
236 ac_add_options --disable-logging
237 ac_add_options --enable-optimize="%{rpmcflags} -Os"
238 %endif
239 ac_add_options --disable-strip
240 ac_add_options --disable-strip-libs
241 %if %{with tests}
242 ac_add_options --enable-tests
243 %else
244 ac_add_options --disable-tests
245 %endif
246 %if %{with gnomeui}
247 ac_add_options --enable-gnomeui
248 %else
249 ac_add_options --disable-gnomeui
250 %endif
251 %if %{with gnomevfs}
252 ac_add_options --enable-gnomevfs
253 %else
254 ac_add_options --disable-gnomevfs
255 %endif
256 %if %{with ldap}
257 ac_add_options --enable-ldap
258 ac_add_options --with-system-ldap
259 %else
260 ac_add_options --disable-ldap
261 %endif
262 %if %{with crashreporter}
263 ac_add_options --enable-crashreporter
264 %else
265 ac_add_options --disable-crashreporter
266 %endif
267 ac_add_options --disable-xterm-updates
268 ac_add_options --enable-postscript
269 %if %{with lightning}
270 ac_add_options --enable-calendar
271 %else
272 ac_add_options --disable-calendar
273 %endif
274 ac_add_options --disable-installer
275 ac_add_options --disable-jsd
276 ac_add_options --disable-updater
277 ac_add_options --disable-xprint
278 ac_add_options --disable-permissions
279 ac_add_options --disable-pref-extensions
280 ac_add_options --enable-canvas
281 ac_add_options --enable-crypto
282 ac_add_options --enable-mathml
283 ac_add_options --enable-pango
284 ac_add_options --enable-reorder
285 ac_add_options --enable-startup-notification
286 ac_add_options --enable-svg
287 ac_add_options --enable-system-cairo
288 ac_add_options --enable-system-hunspell
289 ac_add_options --enable-system-sqlite
290 ac_add_options --enable-xft
291 ac_add_options --enable-application=mail
292 ac_add_options --enable-default-toolkit=cairo-gtk2
293 ac_add_options --enable-xinerama
294 ac_add_options --with-distribution-id=org.pld-linux
295 ac_add_options --with-branding=icedove/branding
296 %if %{with xulrunner}
297 #ac_add_options --with-libxul-sdk=$(pwd)/libxul-sdk/sdk
298 ac_add_options --with-system-libxul
299 ac_add_options --enable-shared
300 ac_add_options --enable-libxul
301 %else
302 ac_add_options --disable-xul
303 %endif
304 ac_add_options --with-pthreads
305 ac_add_options --with-system-bz2
306 ac_add_options --with-system-jpeg
307 ac_add_options --with-system-nspr
308 ac_add_options --with-system-nss
309 ac_add_options --with-system-png
310 ac_add_options --with-system-zlib
311 ac_add_options --enable-single-profile
312 ac_add_options --disable-profilesharing
313 ac_add_options --with-default-mozilla-five-home=%{_libdir}/%{name}
314 EOF
315
316 %{__make} -j1 -f client.mk build \
317         STRIP="/bin/true" \
318         MOZ_MAKE_FLAGS="%{?_smp_mflags}" \
319         CC="%{__cc}" \
320         CXX="%{__cxx}"
321
322 %if %{with crashreporter}
323 # create debuginfo for crash-stats.mozilla.com
324 %{__make} -j1 -C obj-%{_target_cpu} buildsymbols
325 %endif
326
327 %if %{with enigmail}
328 cd mailnews/extensions/enigmail
329 ./makemake -r -o %{objdir}
330 %{__make} -C %{objdir}/mailnews/extensions/enigmail \
331         STRIP="/bin/true" \
332         CC="%{__cc}" \
333         CXX="%{__cxx}"
334 %endif
335
336 %install
337 rm -rf $RPM_BUILD_ROOT
338 install -d $RPM_BUILD_ROOT{%{_bindir},%{_libdir}/%{name},%{_datadir}/%{name},%{_pixmapsdir},%{_desktopdir}}
339
340 cd %{objdir}
341 %{__make} -C mail/installer stage-package \
342         DESTDIR=$RPM_BUILD_ROOT \
343         MOZ_PKG_APPDIR=%{_libdir}/%{name} \
344         PKG_SKIP_STRIP=1
345
346 # Enable crash reporter for Firefox application
347 %if %{with crashreporter}
348 %{__sed} -i -e 's/\[Crash Reporter\]/[Crash Reporter]\nEnabled=1/' $RPM_BUILD_ROOT%{_libdir}/%{name}/application.ini
349
350 # Add debuginfo for crash-stats.mozilla.com
351 install -d $RPM_BUILD_ROOT%{_exec_prefix}/lib/debug%{_libdir}/%{name}
352 cp -a mozilla/dist/%{name}-%{version}.en-US.linux-*.crashreporter-symbols.zip $RPM_BUILD_ROOT%{_prefix}/lib/debug%{_libdir}/%{name}
353 %endif
354
355 # copy manually lightning files, somewhy they are not installed by make
356 cp -a mozilla/dist/bin/extensions/calendar-timezones@mozilla.org \
357         mozilla/dist/bin/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103} \
358         $RPM_BUILD_ROOT%{_libdir}/%{name}/extensions
359
360 # move arch independant ones to datadir
361 mv $RPM_BUILD_ROOT%{_libdir}/%{name}/chrome $RPM_BUILD_ROOT%{_datadir}/%{name}/chrome
362 mv $RPM_BUILD_ROOT%{_libdir}/%{name}/defaults $RPM_BUILD_ROOT%{_datadir}/%{name}/defaults
363 mv $RPM_BUILD_ROOT%{_libdir}/%{name}/greprefs $RPM_BUILD_ROOT%{_datadir}/%{name}/greprefs
364 mv $RPM_BUILD_ROOT%{_libdir}/%{name}/isp $RPM_BUILD_ROOT%{_datadir}/%{name}/isp
365 mv $RPM_BUILD_ROOT%{_libdir}/%{name}/modules $RPM_BUILD_ROOT%{_datadir}/%{name}/modules
366 mv $RPM_BUILD_ROOT%{_libdir}/%{name}/res $RPM_BUILD_ROOT%{_datadir}/%{name}/res
367 ln -s ../../share/%{name}/chrome $RPM_BUILD_ROOT%{_libdir}/%{name}/chrome
368 ln -s ../../share/%{name}/defaults $RPM_BUILD_ROOT%{_libdir}/%{name}/defaults
369 ln -s ../../share/%{name}/greprefs $RPM_BUILD_ROOT%{_libdir}/%{name}/greprefs
370 ln -s ../../share/%{name}/isp $RPM_BUILD_ROOT%{_libdir}/%{name}/isp
371 ln -s ../../share/%{name}/modules $RPM_BUILD_ROOT%{_libdir}/%{name}/modules
372 ln -s ../../share/%{name}/res $RPM_BUILD_ROOT%{_libdir}/%{name}/res
373
374 # dir for arch independant extensions besides arch dependant extensions
375 # see mozilla/xpcom/build/nsXULAppAPI.h
376 # XRE_SYS_LOCAL_EXTENSION_PARENT_DIR and XRE_SYS_SHARE_EXTENSION_PARENT_DIR
377 install -d $RPM_BUILD_ROOT%{_datadir}/%{name}/extensions
378
379 %{__rm} -r $RPM_BUILD_ROOT%{_libdir}/%{name}/dictionaries
380 ln -s %{_datadir}/myspell $RPM_BUILD_ROOT%{_libdir}/%{name}/dictionaries
381
382 %{__sed} -e 's,@LIBDIR@,%{_libdir},' %{SOURCE5} > $RPM_BUILD_ROOT%{_bindir}/icedove
383 ln -s %{name} $RPM_BUILD_ROOT%{_bindir}/thunderbird
384 ln -s %{name} $RPM_BUILD_ROOT%{_bindir}/mozilla-thunderbird
385
386 cp -p %{SOURCE4} $RPM_BUILD_ROOT%{_desktopdir}/%{name}.desktop
387 cp -p %{topdir}/mozilla/icedove/branding/content/icon64.png $RPM_BUILD_ROOT%{_pixmapsdir}/%{name}.png
388
389 # files created by regxpcom -register in post
390 touch $RPM_BUILD_ROOT%{_libdir}/%{name}/components/compreg.dat
391 touch $RPM_BUILD_ROOT%{_libdir}/%{name}/components/xpti.dat
392 cat << 'EOF' > $RPM_BUILD_ROOT%{_libdir}/%{name}/register
393 #!/bin/sh
394 umask 022
395 # make temporary HOME, as it attempts to touch files in $HOME/.mozilla
396 # dangerous if you run this with sudo with keep_env += HOME
397 # also TMPDIR could be pointing to sudo user's homedir so we reset that too.
398 t=$(mktemp -d)
399 %{__rm} -f %{_libdir}/%{name}/components/{compreg,xpti}.dat
400 TMPDIR= TMP= HOME=$t %{_libdir}/%{name}/icedove -register
401 rm -rf $t
402 EOF
403 chmod a+rx $RPM_BUILD_ROOT%{_libdir}/%{name}/register
404
405 %if %{with enigmail}
406 ext_dir=$RPM_BUILD_ROOT%{_libdir}/%{name}/extensions/\{847b3a00-7ab1-11d4-8f02-006008948af5\}
407 install -d $ext_dir/{chrome,components,defaults/preferences}
408 cd mozilla/dist/bin
409 cp -rfLp chrome/enigmail.jar $ext_dir/chrome
410 cp -rfLp chrome/enigmime.jar $ext_dir/chrome
411 cp -rfLp components/enig* $ext_dir/components
412 cp -rfLp components/libenigmime.so $ext_dir/components
413 cp -rfLp components/libipc.so $ext_dir/components
414 cp -rfLp components/ipc.xpt $ext_dir/components
415 cp -rfLp defaults/preferences/enigmail.js $ext_dir/defaults/preferences
416 cd -
417 cp -p %{topdir}/mozilla/mailnews/extensions/enigmail/package/install.rdf $ext_dir
418 cp -p %{topdir}/mozilla/mailnews/extensions/enigmail/package/chrome.manifest $ext_dir/chrome.manifest
419 %endif
420
421 # remove unecessary stuff
422 %{__rm} $RPM_BUILD_ROOT%{_libdir}/%{name}/README.txt
423 %{__rm} $RPM_BUILD_ROOT%{_libdir}/%{name}/components/components.list
424 %{__rm} $RPM_BUILD_ROOT%{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/components/components.list
425
426 # never package these. always remove
427 # nss
428 %{__rm} -f $RPM_BUILD_ROOT%{_libdir}/%{name}/lib{freebl3,nss3,nssckbi,nssdbm3,nssutil3,smime3,softokn3,ssl3}.*
429 # nspr
430 %{__rm} -f $RPM_BUILD_ROOT%{_libdir}/%{name}/lib{nspr4,plc4,plds4}.so
431 # mozldap
432 %{__rm} -f $RPM_BUILD_ROOT%{_libdir}/%{name}/lib{ldap,ldif,prldap,ssldap}60.so
433
434 %clean
435 rm -rf $RPM_BUILD_ROOT
436
437 %pretrans
438 if [ -d %{_libdir}/%{name}/dictionaries ] && [ ! -L %{_libdir}/%{name}/dictionaries ]; then
439         mv -v %{_libdir}/%{name}/dictionaries{,.rpmsave}
440 fi
441 for d in chrome defaults greprefs icons isp modules res; do
442         if [ -d %{_libdir}/%{name}/$d ] && [ ! -L %{_libdir}/%{name}/$d ]; then
443                 install -d %{_datadir}/%{name}
444                 mv %{_libdir}/%{name}/$d %{_datadir}/%{name}/$d
445         fi
446 done
447 exit 0
448
449 %post
450 %{_libdir}/%{name}/register || :
451
452 %files
453 %defattr(644,root,root,755)
454 %attr(755,root,root) %{_bindir}/icedove
455 %attr(755,root,root) %{_bindir}/mozilla-thunderbird
456 %attr(755,root,root) %{_bindir}/thunderbird
457 %dir %{_libdir}/%{name}
458 %{_libdir}/%{name}/application.ini
459 %{_libdir}/%{name}/platform.ini
460 %dir %{_libdir}/%{name}/components
461 %attr(755,root,root) %{_libdir}/%{name}/components/*.so
462 %{_libdir}/%{name}/components/*.js
463 %{_libdir}/%{name}/components/*.xpt
464 %attr(755,root,root) %{_libdir}/%{name}/libmozjs.so
465 %attr(755,root,root) %{_libdir}/%{name}/libxpcom.so
466 %attr(755,root,root) %{_libdir}/%{name}/libxpcom_core.so
467 %attr(755,root,root) %{_libdir}/%{name}/*.sh
468 %attr(755,root,root) %{_libdir}/%{name}/*-bin
469 %attr(755,root,root) %{_libdir}/%{name}/mozilla-xremote-client
470 %attr(755,root,root) %{_libdir}/%{name}/icedove
471 %attr(755,root,root) %{_libdir}/%{name}/register
472
473 # symlinks
474 %{_libdir}/%{name}/chrome
475 %{_libdir}/%{name}/defaults
476 %{_libdir}/%{name}/dictionaries
477 %{_libdir}/%{name}/greprefs
478 %{_libdir}/%{name}/isp
479 %{_libdir}/%{name}/modules
480 %{_libdir}/%{name}/res
481
482 %{_pixmapsdir}/*.png
483 %{_desktopdir}/*.desktop
484
485 %dir %{_datadir}/%{name}
486 %{_datadir}/%{name}/chrome
487 %{_datadir}/%{name}/defaults
488 %{_datadir}/%{name}/greprefs
489 %{_datadir}/%{name}/isp
490 %{_datadir}/%{name}/modules
491 %{_datadir}/%{name}/res
492 %{_datadir}/%{name}/extensions
493
494 %if %{with crashreporter}
495 %attr(755,root,root) %{_libdir}/%{name}/crashreporter
496 %{_libdir}/%{name}/crashreporter.ini
497 %{_libdir}/%{name}/Throbber-small.gif
498 %endif
499
500 %dir %{_libdir}/%{name}/extensions
501 %{_libdir}/%{name}/extensions/{972ce4c6-7e08-4474-a285-3208198ce6fd}
502
503 # files created by regxpcom -register
504 %ghost %{_libdir}/%{name}/components/compreg.dat
505 %ghost %{_libdir}/%{name}/components/xpti.dat
506
507 %if %{with lightning}
508 %files addon-lightning
509 %defattr(644,root,root,755)
510 %dir %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}
511 %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/defaults
512 %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/chrome
513 %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/chrome.manifest
514 %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/install.rdf
515 %dir %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/components
516 %attr(755,root,root) %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/components/*.so
517 %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/components/*.xpt
518 %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/components/*.js
519 %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/modules
520 %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/calendar-js
521 %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/timezones.sqlite
522
523 %{_libdir}/%{name}/extensions/calendar-timezones@mozilla.org
524 %endif
525
526 %if %{with enigmail}
527 %files addon-enigmail
528 %defattr(644,root,root,755)
529 %dir %{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}
530 %{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/defaults
531 %{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/chrome
532 %{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/chrome.manifest
533 %{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/install.rdf
534 %dir %{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/components
535 %attr(755,root,root) %{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/components/*.so
536 %{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/components/*.xpt
537 %{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/components/*.js
538 %endif
This page took 0.074663 seconds and 4 git commands to generate.