]> git.pld-linux.org Git - packages/thunderbird.git/blob - icedove.spec
- prepare for 6.0
[packages/thunderbird.git] / icedove.spec
1 # TODO:
2 # - separate spec for enigmail
3 # - fix icedove (building) and installing nss/nspr libs!
4 # - build with system mozldap
5 #
6 # Conditional builds
7 %bcond_without  enigmail        # don't build enigmail - GPG/PGP support
8 %bcond_without  gnomeui         # disable gnomeui support
9 %bcond_without  gnomevfs        # disable GNOME comp. (gconf+libgnome+gnomevfs) and gnomevfs ext.
10 %bcond_without  gnome           # disable all GNOME components (gnome+gnomeui+gnomevfs)
11 %bcond_without  ldap            # disable e-mail address lookups in LDAP directories
12 %bcond_without  lightning       # disable sunbird calendar
13 %bcond_without  xulrunner       # build with xulrunner
14 %bcond_with     crashreporter   # report crashes to crash-stats.mozilla.com
15
16 %if %{without gnome}
17 %undefine       with_gnomeui
18 %undefine       with_gnomevfs
19 %endif
20
21 %if 0%{?_enable_debug_packages} != 1
22 %undefine       crashreporter
23 %endif
24
25 %define         enigmail_ver    1.1.2
26 %define         nspr_ver                4.8.8
27 %define         nss_ver                 3.12.10
28
29 %if %{without xulrunner}
30 # The actual sqlite version (see RHBZ#480989):
31 %define         sqlite_build_version %(pkg-config --silence-errors --modversion sqlite3 2>/dev/null || echo ERROR)
32 %endif
33
34 Summary:        Icedove - email client
35 Summary(pl.UTF-8):      Icedove - klient poczty
36 Name:           icedove
37 Version:        6.0
38 Release:        0.1
39 License:        MPL 1.1 or GPL v2+ or LGPL v2.1+
40 Group:          X11/Applications/Networking
41 Source0:        http://releases.mozilla.org/pub/mozilla.org/thunderbird/releases/%{version}/source/thunderbird-%{version}.source.tar.bz2
42 # Source0-md5:  9ac741d238e95790cdeb5222e9b23ae8
43 Source1:        http://www.mozilla-enigmail.org/download/source/enigmail-%{enigmail_ver}.tar.gz
44 # Source1-md5:  7d329d5e8afbbb28214ca1995beb09c9
45 Source2:        %{name}-branding.tar.bz2
46 # Source2-md5:  2da351522bdd7f4a3bd8aaff4c776976
47 Source3:        %{name}-rm_nonfree.sh
48 Source4:        %{name}.desktop
49 Source5:        %{name}.sh
50 Patch0:         %{name}-branding.patch
51 Patch1:         %{name}-enigmail-shared.patch
52 Patch2:         %{name}-gcc.patch
53 Patch3:         %{name}-fonts.patch
54 Patch4:         %{name}-install.patch
55 Patch5:         %{name}-hunspell.patch
56 Patch6:         %{name}-prefs.patch
57 Patch7:         system-mozldap.patch
58 Patch8:         %{name}-makefile.patch
59 Patch10:        %{name}-extensiondir.patch
60 Patch11:        crashreporter.patch
61 Patch12:        no-subshell.patch
62 URL:            http://www.pld-linux.org/Packages/Icedove
63 %{?with_gnomevfs:BuildRequires: GConf2-devel >= 1.2.1}
64 BuildRequires:  alsa-lib-devel
65 BuildRequires:  automake
66 BuildRequires:  bzip2-devel
67 BuildRequires:  freetype-devel >= 1:2.1.8
68 %{?with_gnomevfs:BuildRequires: gnome-vfs2-devel >= 2.0}
69 BuildRequires:  gtk+2-devel >= 1:2.0.0
70 BuildRequires:  hunspell-devel
71 BuildRequires:  libIDL-devel >= 0.8.0
72 %{?with_gnomevfs:BuildRequires: libgnome-devel >= 2.0}
73 %{?with_gnomeui:BuildRequires:  libgnome-keyring-devel}
74 %{?with_gnomeui:BuildRequires:  libgnomeui-devel >= 2.2.0}
75 BuildRequires:  libiw-devel
76 BuildRequires:  libjpeg-devel >= 6b
77 BuildRequires:  libnotify-devel >= 0.4
78 BuildRequires:  libpng-devel >= 1.2.0
79 BuildRequires:  libstdc++-devel
80 BuildRequires:  nspr-devel >= 1:%{nspr_ver}
81 BuildRequires:  nss-devel >= 1:%{nss_ver}
82 BuildRequires:  pango-devel >= 1:1.1.0
83 BuildRequires:  pkgconfig
84 BuildRequires:  sed >= 4.0
85 BuildRequires:  sqlite3-devel >= 3.7.4
86 BuildRequires:  startup-notification-devel >= 0.8
87 BuildRequires:  xorg-lib-libXext-devel
88 BuildRequires:  xorg-lib-libXinerama-devel
89 BuildRequires:  xorg-lib-libXt-devel
90 BuildRequires:  zip
91 Requires(post): mktemp >= 1.5-18
92 %if %{with xulrunner}
93 %else
94 Requires:       myspell-common
95 Requires:       nspr >= 1:%{nspr_ver}
96 Requires:       nss >= 1:%{nss_ver}
97 Requires:       sqlite3 >= %{sqlite_build_version}
98 %endif
99 Obsoletes:      mozilla-thunderbird
100 Obsoletes:      mozilla-thunderbird-dictionary-en-US
101 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
102
103 %define         filterout_cpp           -D_FORTIFY_SOURCE=[0-9]+
104
105 # iceweasel/icedove/iceape provide their own versions
106 %define         _noautoreqdep           libgfxpsshar.so libgkgfx.so libgtkxtbin.so libjsj.so libxpcom_compat.so libxpistub.so
107 %define         _noautoprovfiles        %{_libdir}/%{name}/components
108 # we don't want these to satisfy xulrunner-devel
109 %define         _noautoprov             libgtkembedmoz.so libmozjs.so libxpcom.so libxul.so libxpcom_core.so
110 # and as we don't provide them, don't require either
111 %define         _noautoreq              libgtkembedmoz.so libmozjs.so libxpcom.so libxul.so libxpcom_core.so
112
113 %define         topdir          %{_builddir}/%{name}-%{version}
114 %define         objdir          %{topdir}/obj-%{_target_cpu}
115
116 %description
117 Icedove is an open-source,fast and portable email client.
118
119 %description -l pl.UTF-8
120 Icedove jest open sourcowym, szybkim i przenośnym klientem poczty.
121
122 %package addon-lightning
123 Summary:        An integrated calendar for Icedove
124 Summary(pl.UTF-8):      Zintegrowany kalendarz dla Icedove
125 License:        MPL 1.1 or GPL v2+ or LGPL v2.1+
126 Group:          Applications/Networking
127 Requires:       %{name} = %{version}-%{release}
128
129 %description addon-lightning
130 Lightning is an calendar extension to Icedove email client.
131
132 %description addon-lightning -l pl.UTF-8
133 Lightning to rozszerzenie do klienta poczty Icedove dodające
134 funkcjonalność kalendarza.
135
136 %package addon-enigmail
137 Summary:        Extension for the authentication and encryption features provided by GnuPG
138 Summary(pl.UTF-8):      Rozszerzenie do uwierzytelniania i szyfrowania zapewnianego przez GnuPG
139 License:        MPL/LGPL
140 Group:          Applications/Networking
141 URL:            http://enigmail.mozdev.org/
142 Requires:       %{name} = %{version}-%{release}
143 Requires:       gnupg
144 Obsoletes:      mozilla-thunderbird-addon-enigmail
145
146 %description addon-enigmail
147 Enigmail is an extension to the Icedove mail client which allows users
148 to access the authentication and encryption features provided by
149 GnuPG.
150
151 Main Features:
152 - Encrypt/sign mail when sending, decrypt/authenticate received mail
153 - Support for inline-PGP (RFC 2440) and PGP/MIME (RFC 3156)
154 - Per-Account based encryption and signing defaults
155 - Per-Recipient rules for automated key selection, and
156   enabling/disabling encryption and signing
157 - OpenPGP key management interface
158
159 %description addon-enigmail -l pl.UTF-8
160 Enigmail to rozszerzenie klienta pocztowego Icedove pozwalające
161 użytkownikom na dostęp do uwierzytelniania i szyfrowania zapewnianego
162 przez GnuPG.
163
164 Główne możliwości:
165 - szyfrowanie/podpisywanie poczty przy wysyłaniu,
166   odszyfrowywanie/uwierzytelnianie poczty odebranej
167 - obsługa inline-PGP (RFC 2440) i PGP/MIME (RFC 3156)
168 - ustawienia domyślne szyfrowania i podpisywania dla każdego konta
169 - reguły automatycznego wyboru kluczy i włączenia szyfrowania oraz
170   podpisywania dla każdego adresata
171 - interfejs do zarządzania kluczami OpenPGP
172
173 %prep
174 %setup -qc
175 mv comm-release mozilla
176 %setup -q -T -D -a2
177 cd mozilla
178 %{?with_enigmail:%{__gzip} -dc %{SOURCE1} | %{__tar} -xf - -C mailnews/extensions}
179 /bin/sh %{SOURCE3}
180 %patch0 -p1
181 %{?with_enigmail:%patch1 -p1}
182 %patch2 -p1
183 %patch3 -p1
184 %patch4 -p1
185 %patch5 -p1
186 %patch6 -p1
187 %patch7 -p1
188 %patch8 -p2
189 %patch10 -p2
190 %patch11 -p2
191 %patch12 -p1
192
193 %build
194 cd mozilla
195 cp -f %{_datadir}/automake/config.* mozilla/build/autoconf
196 cp -f %{_datadir}/automake/config.* mozilla/nsprpub/build/autoconf
197 cp -f %{_datadir}/automake/config.* ldap/sdks/c-sdk/config/autoconf
198
199 install -d libxul-sdk
200 ln -snf %{_libdir}/xulrunner-sdk libxul-sdk/sdk
201
202 cat << EOF > .mozconfig
203 mk_add_options MOZ_OBJDIR=%{objdir}
204
205 export CFLAGS="%{rpmcflags} -fpermissive"
206 export CXXFLAGS="%{rpmcflags} -fpermissive"
207
208 %if %{with crashreporter}
209 export MOZ_DEBUG_SYMBOLS=1
210 %endif
211
212 # Options for 'configure' (same as command-line options).
213 ac_add_options --prefix=%{_prefix}
214 ac_add_options --exec-prefix=%{_exec_prefix}
215 ac_add_options --bindir=%{_bindir}
216 ac_add_options --sbindir=%{_sbindir}
217 ac_add_options --sysconfdir=%{_sysconfdir}
218 ac_add_options --datadir=%{_datadir}
219 ac_add_options --includedir=%{_includedir}
220 ac_add_options --libdir=%{_libdir}
221 ac_add_options --libexecdir=%{_libexecdir}
222 ac_add_options --localstatedir=%{_localstatedir}
223 ac_add_options --sharedstatedir=%{_sharedstatedir}
224 ac_add_options --mandir=%{_mandir}
225 ac_add_options --infodir=%{_infodir}
226 %if %{?debug:1}0
227 ac_add_options --disable-optimize
228 ac_add_options --enable-debug
229 ac_add_options --enable-debug-modules
230 ac_add_options --enable-debugger-info-modules
231 ac_add_options --enable-crash-on-assert
232 %else
233 ac_add_options --disable-debug
234 ac_add_options --disable-debug-modules
235 ac_add_options --disable-logging
236 ac_add_options --enable-optimize="%{rpmcflags} -Os"
237 %endif
238 ac_add_options --disable-strip
239 ac_add_options --disable-strip-libs
240 %if %{with tests}
241 ac_add_options --enable-tests
242 %else
243 ac_add_options --disable-tests
244 %endif
245 %if %{with gnomeui}
246 ac_add_options --enable-gnomeui
247 %else
248 ac_add_options --disable-gnomeui
249 %endif
250 %if %{with gnomevfs}
251 ac_add_options --enable-gnomevfs
252 %else
253 ac_add_options --disable-gnomevfs
254 %endif
255 %if %{with ldap}
256 ac_add_options --enable-ldap
257 ac_add_options --with-system-ldap
258 %else
259 ac_add_options --disable-ldap
260 %endif
261 %if %{with crashreporter}
262 ac_add_options --enable-crashreporter
263 %else
264 ac_add_options --disable-crashreporter
265 %endif
266 ac_add_options --disable-xterm-updates
267 ac_add_options --enable-postscript
268 %if %{with lightning}
269 ac_add_options --enable-calendar
270 %else
271 ac_add_options --disable-calendar
272 %endif
273 ac_add_options --disable-installer
274 ac_add_options --disable-jsd
275 ac_add_options --disable-updater
276 ac_add_options --disable-xprint
277 ac_add_options --disable-permissions
278 ac_add_options --disable-pref-extensions
279 ac_add_options --enable-canvas
280 ac_add_options --enable-crypto
281 ac_add_options --enable-mathml
282 ac_add_options --enable-pango
283 ac_add_options --enable-reorder
284 ac_add_options --enable-startup-notification
285 ac_add_options --enable-svg
286 ac_add_options --enable-system-cairo
287 ac_add_options --enable-system-hunspell
288 ac_add_options --enable-system-sqlite
289 ac_add_options --enable-xft
290 ac_add_options --enable-application=mail
291 ac_add_options --enable-default-toolkit=cairo-gtk2
292 ac_add_options --enable-xinerama
293 ac_add_options --with-distribution-id=org.pld-linux
294 ac_add_options --with-branding=icedove/branding
295 %if %{with xulrunner}
296 #ac_add_options --with-libxul-sdk=$(pwd)/libxul-sdk/sdk
297 ac_add_options --with-system-libxul
298 ac_add_options --enable-shared
299 ac_add_options --enable-libxul
300 %else
301 ac_add_options --disable-xul
302 %endif
303 ac_add_options --with-pthreads
304 ac_add_options --with-system-bz2
305 ac_add_options --with-system-jpeg
306 ac_add_options --with-system-nspr
307 ac_add_options --with-system-nss
308 ac_add_options --with-system-png
309 ac_add_options --with-system-zlib
310 ac_add_options --enable-single-profile
311 ac_add_options --disable-profilesharing
312 ac_add_options --with-default-mozilla-five-home=%{_libdir}/%{name}
313 EOF
314
315 %{__make} -j1 -f client.mk build \
316         STRIP="/bin/true" \
317         MOZ_MAKE_FLAGS="%{?_smp_mflags}" \
318         CC="%{__cc}" \
319         CXX="%{__cxx}"
320
321 %if %{with crashreporter}
322 # create debuginfo for crash-stats.mozilla.com
323 %{__make} -j1 -C obj-%{_target_cpu} buildsymbols
324 %endif
325
326 %if %{with enigmail}
327 cd mailnews/extensions/enigmail
328 ./makemake -r -o %{objdir}
329 %{__make} -C %{objdir}/mailnews/extensions/enigmail \
330         STRIP="/bin/true" \
331         CC="%{__cc}" \
332         CXX="%{__cxx}"
333 %endif
334
335 %install
336 rm -rf $RPM_BUILD_ROOT
337 install -d $RPM_BUILD_ROOT{%{_bindir},%{_libdir}/%{name},%{_datadir}/%{name},%{_pixmapsdir},%{_desktopdir}}
338
339 cd %{objdir}
340 %{__make} -C mail/installer stage-package \
341         DESTDIR=$RPM_BUILD_ROOT \
342         MOZ_PKG_APPDIR=%{_libdir}/%{name} \
343         PKG_SKIP_STRIP=1
344
345 # Enable crash reporter for Firefox application
346 %if %{with crashreporter}
347 %{__sed} -i -e 's/\[Crash Reporter\]/[Crash Reporter]\nEnabled=1/' $RPM_BUILD_ROOT%{_libdir}/%{name}/application.ini
348
349 # Add debuginfo for crash-stats.mozilla.com
350 install -d $RPM_BUILD_ROOT%{_exec_prefix}/lib/debug%{_libdir}/%{name}
351 cp -a mozilla/dist/%{name}-%{version}.en-US.linux-*.crashreporter-symbols.zip $RPM_BUILD_ROOT%{_prefix}/lib/debug%{_libdir}/%{name}
352 %endif
353
354 # copy manually lightning files, somewhy they are not installed by make
355 cp -a mozilla/dist/bin/extensions/calendar-timezones@mozilla.org \
356         mozilla/dist/bin/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103} \
357         $RPM_BUILD_ROOT%{_libdir}/%{name}/extensions
358
359 # move arch independant ones to datadir
360 mv $RPM_BUILD_ROOT%{_libdir}/%{name}/chrome $RPM_BUILD_ROOT%{_datadir}/%{name}/chrome
361 mv $RPM_BUILD_ROOT%{_libdir}/%{name}/defaults $RPM_BUILD_ROOT%{_datadir}/%{name}/defaults
362 mv $RPM_BUILD_ROOT%{_libdir}/%{name}/greprefs $RPM_BUILD_ROOT%{_datadir}/%{name}/greprefs
363 mv $RPM_BUILD_ROOT%{_libdir}/%{name}/isp $RPM_BUILD_ROOT%{_datadir}/%{name}/isp
364 mv $RPM_BUILD_ROOT%{_libdir}/%{name}/modules $RPM_BUILD_ROOT%{_datadir}/%{name}/modules
365 mv $RPM_BUILD_ROOT%{_libdir}/%{name}/res $RPM_BUILD_ROOT%{_datadir}/%{name}/res
366 ln -s ../../share/%{name}/chrome $RPM_BUILD_ROOT%{_libdir}/%{name}/chrome
367 ln -s ../../share/%{name}/defaults $RPM_BUILD_ROOT%{_libdir}/%{name}/defaults
368 ln -s ../../share/%{name}/greprefs $RPM_BUILD_ROOT%{_libdir}/%{name}/greprefs
369 ln -s ../../share/%{name}/isp $RPM_BUILD_ROOT%{_libdir}/%{name}/isp
370 ln -s ../../share/%{name}/modules $RPM_BUILD_ROOT%{_libdir}/%{name}/modules
371 ln -s ../../share/%{name}/res $RPM_BUILD_ROOT%{_libdir}/%{name}/res
372
373 # dir for arch independant extensions besides arch dependant extensions
374 # see mozilla/xpcom/build/nsXULAppAPI.h
375 # XRE_SYS_LOCAL_EXTENSION_PARENT_DIR and XRE_SYS_SHARE_EXTENSION_PARENT_DIR
376 install -d $RPM_BUILD_ROOT%{_datadir}/%{name}/extensions
377
378 %{__rm} -r $RPM_BUILD_ROOT%{_libdir}/%{name}/dictionaries
379 ln -s %{_datadir}/myspell $RPM_BUILD_ROOT%{_libdir}/%{name}/dictionaries
380
381 %{__sed} -e 's,@LIBDIR@,%{_libdir},' %{SOURCE5} > $RPM_BUILD_ROOT%{_bindir}/icedove
382 ln -s %{name} $RPM_BUILD_ROOT%{_bindir}/thunderbird
383 ln -s %{name} $RPM_BUILD_ROOT%{_bindir}/mozilla-thunderbird
384
385 cp -p %{SOURCE4} $RPM_BUILD_ROOT%{_desktopdir}/%{name}.desktop
386 cp -p %{topdir}/mozilla/icedove/branding/content/icon64.png $RPM_BUILD_ROOT%{_pixmapsdir}/%{name}.png
387
388 # files created by regxpcom -register in post
389 touch $RPM_BUILD_ROOT%{_libdir}/%{name}/components/compreg.dat
390 touch $RPM_BUILD_ROOT%{_libdir}/%{name}/components/xpti.dat
391 cat << 'EOF' > $RPM_BUILD_ROOT%{_libdir}/%{name}/register
392 #!/bin/sh
393 umask 022
394 # make temporary HOME, as it attempts to touch files in $HOME/.mozilla
395 # dangerous if you run this with sudo with keep_env += HOME
396 # also TMPDIR could be pointing to sudo user's homedir so we reset that too.
397 t=$(mktemp -d)
398 %{__rm} -f %{_libdir}/%{name}/components/{compreg,xpti}.dat
399 TMPDIR= TMP= HOME=$t %{_libdir}/%{name}/icedove -register
400 rm -rf $t
401 EOF
402 chmod a+rx $RPM_BUILD_ROOT%{_libdir}/%{name}/register
403
404 %if %{with enigmail}
405 ext_dir=$RPM_BUILD_ROOT%{_libdir}/%{name}/extensions/\{847b3a00-7ab1-11d4-8f02-006008948af5\}
406 install -d $ext_dir/{chrome,components,defaults/preferences}
407 cd mozilla/dist/bin
408 cp -rfLp chrome/enigmail.jar $ext_dir/chrome
409 cp -rfLp chrome/enigmime.jar $ext_dir/chrome
410 cp -rfLp components/enig* $ext_dir/components
411 cp -rfLp components/libenigmime.so $ext_dir/components
412 cp -rfLp components/libipc.so $ext_dir/components
413 cp -rfLp components/ipc.xpt $ext_dir/components
414 cp -rfLp defaults/preferences/enigmail.js $ext_dir/defaults/preferences
415 cd -
416 cp -p %{topdir}/mozilla/mailnews/extensions/enigmail/package/install.rdf $ext_dir
417 cp -p %{topdir}/mozilla/mailnews/extensions/enigmail/package/chrome.manifest $ext_dir/chrome.manifest
418 %endif
419
420 # remove unecessary stuff
421 %{__rm} $RPM_BUILD_ROOT%{_libdir}/%{name}/README.txt
422 %{__rm} $RPM_BUILD_ROOT%{_libdir}/%{name}/components/components.list
423 %{__rm} $RPM_BUILD_ROOT%{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/components/components.list
424
425 # never package these. always remove
426 # nss
427 %{__rm} -f $RPM_BUILD_ROOT%{_libdir}/%{name}/lib{freebl3,nss3,nssckbi,nssdbm3,nssutil3,smime3,softokn3,ssl3}.*
428 # nspr
429 %{__rm} -f $RPM_BUILD_ROOT%{_libdir}/%{name}/lib{nspr4,plc4,plds4}.so
430 # mozldap
431 %{__rm} -f $RPM_BUILD_ROOT%{_libdir}/%{name}/lib{ldap,ldif,prldap,ssldap}60.so
432
433 %clean
434 rm -rf $RPM_BUILD_ROOT
435
436 %pretrans
437 if [ -d %{_libdir}/%{name}/dictionaries ] && [ ! -L %{_libdir}/%{name}/dictionaries ]; then
438         mv -v %{_libdir}/%{name}/dictionaries{,.rpmsave}
439 fi
440 for d in chrome defaults greprefs icons isp modules res; do
441         if [ -d %{_libdir}/%{name}/$d ] && [ ! -L %{_libdir}/%{name}/$d ]; then
442                 install -d %{_datadir}/%{name}
443                 mv %{_libdir}/%{name}/$d %{_datadir}/%{name}/$d
444         fi
445 done
446 exit 0
447
448 %post
449 %{_libdir}/%{name}/register || :
450
451 %files
452 %defattr(644,root,root,755)
453 %attr(755,root,root) %{_bindir}/icedove
454 %attr(755,root,root) %{_bindir}/mozilla-thunderbird
455 %attr(755,root,root) %{_bindir}/thunderbird
456 %dir %{_libdir}/%{name}
457 %{_libdir}/%{name}/application.ini
458 %{_libdir}/%{name}/platform.ini
459 %dir %{_libdir}/%{name}/components
460 %attr(755,root,root) %{_libdir}/%{name}/components/*.so
461 %{_libdir}/%{name}/components/*.js
462 %{_libdir}/%{name}/components/*.xpt
463 %attr(755,root,root) %{_libdir}/%{name}/libmozjs.so
464 %attr(755,root,root) %{_libdir}/%{name}/libxpcom.so
465 %attr(755,root,root) %{_libdir}/%{name}/libxpcom_core.so
466 %attr(755,root,root) %{_libdir}/%{name}/*.sh
467 %attr(755,root,root) %{_libdir}/%{name}/*-bin
468 %attr(755,root,root) %{_libdir}/%{name}/mozilla-xremote-client
469 %attr(755,root,root) %{_libdir}/%{name}/icedove
470 %attr(755,root,root) %{_libdir}/%{name}/register
471
472 # symlinks
473 %{_libdir}/%{name}/chrome
474 %{_libdir}/%{name}/defaults
475 %{_libdir}/%{name}/dictionaries
476 %{_libdir}/%{name}/greprefs
477 %{_libdir}/%{name}/isp
478 %{_libdir}/%{name}/modules
479 %{_libdir}/%{name}/res
480
481 %{_pixmapsdir}/*.png
482 %{_desktopdir}/*.desktop
483
484 %dir %{_datadir}/%{name}
485 %{_datadir}/%{name}/chrome
486 %{_datadir}/%{name}/defaults
487 %{_datadir}/%{name}/greprefs
488 %{_datadir}/%{name}/isp
489 %{_datadir}/%{name}/modules
490 %{_datadir}/%{name}/res
491 %{_datadir}/%{name}/extensions
492
493 %if %{with crashreporter}
494 %attr(755,root,root) %{_libdir}/%{name}/crashreporter
495 %{_libdir}/%{name}/crashreporter.ini
496 %{_libdir}/%{name}/Throbber-small.gif
497 %endif
498
499 %dir %{_libdir}/%{name}/extensions
500 %{_libdir}/%{name}/extensions/{972ce4c6-7e08-4474-a285-3208198ce6fd}
501
502 # files created by regxpcom -register
503 %ghost %{_libdir}/%{name}/components/compreg.dat
504 %ghost %{_libdir}/%{name}/components/xpti.dat
505
506 %if %{with lightning}
507 %files addon-lightning
508 %defattr(644,root,root,755)
509 %dir %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}
510 %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/defaults
511 %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/chrome
512 %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/chrome.manifest
513 %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/install.rdf
514 %dir %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/components
515 %attr(755,root,root) %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/components/*.so
516 %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/components/*.xpt
517 %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/components/*.js
518 %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/modules
519 %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/calendar-js
520 %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/timezones.sqlite
521
522 %{_libdir}/%{name}/extensions/calendar-timezones@mozilla.org
523 %endif
524
525 %if %{with enigmail}
526 %files addon-enigmail
527 %defattr(644,root,root,755)
528 %dir %{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}
529 %{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/defaults
530 %{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/chrome
531 %{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/chrome.manifest
532 %{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/install.rdf
533 %dir %{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/components
534 %attr(755,root,root) %{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/components/*.so
535 %{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/components/*.xpt
536 %{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/components/*.js
537 %endif
This page took 0.192993 seconds and 4 git commands to generate.