]> git.pld-linux.org Git - packages/thunderbird.git/blob - icedove.spec
- include epoch in xulrunner_ver
[packages/thunderbird.git] / icedove.spec
1 # TODO:
2 # - separate spec for enigmail
3 # - build with system mozldap
4 #
5 # Conditional builds
6 %bcond_without  enigmail        # don't build enigmail - GPG/PGP support
7 %bcond_without  gnomeui         # disable gnomeui support
8 %bcond_without  gnome           # alias for gnomeui
9 %bcond_without  ldap            # disable e-mail address lookups in LDAP directories
10 %bcond_without  lightning       # disable Sunbird/Lightning calendar
11 %bcond_with     xulrunner       # system xulrunner
12 %bcond_with     crashreporter   # report crashes to crash-stats.mozilla.com
13
14 %if %{without gnome}
15 %undefine       with_gnomeui
16 %endif
17
18 %if 0%{?_enable_debug_packages} != 1
19 %undefine       crashreporter
20 %endif
21
22 %define         enigmail_ver    1.4.1
23 %define         nspr_ver        4.9
24 %define         nss_ver         3.13.3
25
26 %define         xulrunner_ver   2:12.0
27
28 %if %{without xulrunner}
29 # The actual sqlite version (see RHBZ#480989):
30 %define         sqlite_build_version %(pkg-config --silence-errors --modversion sqlite3 2>/dev/null || echo ERROR)
31 %endif
32
33 Summary:        Icedove - email client
34 Summary(pl.UTF-8):      Icedove - klient poczty
35 Name:           icedove
36 Version:        12.0.1
37 Release:        1
38 License:        MPL 1.1 or GPL v2+ or LGPL v2.1+
39 Group:          X11/Applications/Networking
40 Source0:        http://releases.mozilla.org/pub/mozilla.org/thunderbird/releases/%{version}/source/thunderbird-%{version}.source.tar.bz2
41 # Source0-md5:  64cacde4cb2b1e8736f1c3a0ea6a02db
42 Source1:        http://www.mozilla-enigmail.org/download/source/enigmail-%{enigmail_ver}.tar.gz
43 # Source1-md5:  0eba75fbcf8f0bb32d538df102fbb8e9
44 Source2:        %{name}-branding.tar.bz2
45 # Source2-md5:  2da351522bdd7f4a3bd8aaff4c776976
46 Source3:        %{name}-rm_nonfree.sh
47 Source4:        %{name}.desktop
48 Source5:        %{name}.sh
49 Patch0:         %{name}-branding.patch
50 Patch1:         %{name}-enigmail-shared.patch
51 Patch2:         %{name}-system-xulrunner.patch
52 Patch3:         %{name}-fonts.patch
53 Patch4:         %{name}-install.patch
54 Patch5:         %{name}-hunspell.patch
55 Patch6:         %{name}-prefs.patch
56 Patch7:         system-mozldap.patch
57 Patch8:         %{name}-makefile.patch
58 # this is only workaround, check if it is fixed with newer firefox
59 Patch9:         bug-722975-workaround.patch
60 Patch10:        %{name}-extensiondir.patch
61 Patch11:        crashreporter.patch
62 Patch12:        no-subshell.patch
63 URL:            http://www.pld-linux.org/Packages/Icedove
64 BuildRequires:  GConf2-devel >= 1.2.1
65 BuildRequires:  alsa-lib-devel
66 BuildRequires:  automake
67 BuildRequires:  bzip2-devel
68 BuildRequires:  cairo-devel >= 1.10
69 BuildRequires:  dbus-glib-devel >= 0.60
70 BuildRequires:  freetype-devel >= 1:2.1.8
71 BuildRequires:  glib2-devel >= 2.0
72 BuildRequires:  gtk+2-devel >= 2:2.10.0
73 BuildRequires:  hunspell-devel
74 BuildRequires:  libIDL-devel >= 0.8.0
75 %{?with_gnomeui:BuildRequires:  libgnome-devel >= 2.0}
76 %{?with_gnomeui:BuildRequires:  libgnome-keyring-devel}
77 %{?with_gnomeui:BuildRequires:  libgnomeui-devel >= 2.2.0}
78 BuildRequires:  libiw-devel
79 BuildRequires:  libjpeg-devel >= 6b
80 BuildRequires:  libnotify-devel >= 0.4
81 BuildRequires:  libpng-devel >= 1.4.1
82 BuildRequires:  libstdc++-devel
83 BuildRequires:  nspr-devel >= 1:%{nspr_ver}
84 BuildRequires:  nss-devel >= 1:%{nss_ver}
85 BuildRequires:  pango-devel >= 1:1.14.0
86 BuildRequires:  perl-base >= 1:5.6
87 BuildRequires:  pkgconfig
88 BuildRequires:  python >= 1:2.5
89 BuildRequires:  sed >= 4.0
90 BuildRequires:  sqlite3-devel >= 3.7.4
91 BuildRequires:  startup-notification-devel >= 0.8
92 BuildRequires:  xorg-lib-libXext-devel
93 BuildRequires:  xorg-lib-libXinerama-devel
94 BuildRequires:  xorg-lib-libXt-devel
95 BuildRequires:  yasm
96 BuildRequires:  zip
97 %if %{with xulrunner}
98 BuildRequires:  xulrunner-devel >= %{xulrunner_ver}
99 %else
100 Requires:       myspell-common
101 Requires:       nspr >= 1:%{nspr_ver}
102 Requires:       nss >= 1:%{nss_ver}
103 Requires:       sqlite3 >= %{sqlite_build_version}
104 %endif
105 Requires(post): mktemp >= 1.5-18
106 %if %{with xulrunner}
107 %requires_eq_to xulrunner xulrunner-devel
108 %endif
109 Obsoletes:      mozilla-thunderbird
110 Obsoletes:      mozilla-thunderbird-dictionary-en-US
111 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
112
113 %define         filterout_cpp           -D_FORTIFY_SOURCE=[0-9]+
114
115 # iceweasel/icedove/iceape provide their own versions
116 %define         _noautoprovfiles        %{_libdir}/%{name}/components
117 %if %{without xulrunner}
118 # we don't want these to satisfy packages depending on xulrunner
119 %define         _noautoprov             libmozalloc.so libxpcom.so libxul.so
120 # and as we don't provide them, don't require either
121 %define         _noautoreq              libmozalloc.so libxpcom.so libxul.so
122 %endif
123
124 %define         topdir          %{_builddir}/%{name}-%{version}
125 %define         objdir          %{topdir}/obj-%{_target_cpu}
126
127 %description
128 Icedove is an open-source, fast and portable email client.
129
130 %description -l pl.UTF-8
131 Icedove jest mającym otwarte źródła, szybkim i przenośnym klientem
132 poczty.
133
134 %package addon-lightning
135 Summary:        An integrated calendar for Icedove
136 Summary(pl.UTF-8):      Zintegrowany kalendarz dla Icedove
137 License:        MPL 1.1 or GPL v2+ or LGPL v2.1+
138 Group:          Applications/Networking
139 Requires:       %{name} = %{version}-%{release}
140
141 %description addon-lightning
142 Lightning is an calendar extension to Icedove email client.
143
144 %description addon-lightning -l pl.UTF-8
145 Lightning to rozszerzenie do klienta poczty Icedove dodające
146 funkcjonalność kalendarza.
147
148 %package addon-enigmail
149 Summary:        Extension for the authentication and encryption features provided by GnuPG
150 Summary(pl.UTF-8):      Rozszerzenie do uwierzytelniania i szyfrowania zapewnianego przez GnuPG
151 License:        MPL/LGPL
152 Group:          Applications/Networking
153 URL:            http://enigmail.mozdev.org/
154 Requires:       %{name} = %{version}-%{release}
155 Requires:       gnupg
156 Obsoletes:      mozilla-thunderbird-addon-enigmail
157
158 %description addon-enigmail
159 Enigmail is an extension to the Icedove mail client which allows users
160 to access the authentication and encryption features provided by
161 GnuPG.
162
163 Main Features:
164 - Encrypt/sign mail when sending, decrypt/authenticate received mail
165 - Support for inline-PGP (RFC 2440) and PGP/MIME (RFC 3156)
166 - Per-Account based encryption and signing defaults
167 - Per-Recipient rules for automated key selection, and
168   enabling/disabling encryption and signing
169 - OpenPGP key management interface
170
171 %description addon-enigmail -l pl.UTF-8
172 Enigmail to rozszerzenie klienta pocztowego Icedove pozwalające
173 użytkownikom na dostęp do uwierzytelniania i szyfrowania zapewnianego
174 przez GnuPG.
175
176 Główne możliwości:
177 - szyfrowanie/podpisywanie poczty przy wysyłaniu,
178   odszyfrowywanie/uwierzytelnianie poczty odebranej
179 - obsługa inline-PGP (RFC 2440) i PGP/MIME (RFC 3156)
180 - ustawienia domyślne szyfrowania i podpisywania dla każdego konta
181 - reguły automatycznego wyboru kluczy i włączenia szyfrowania oraz
182   podpisywania dla każdego adresata
183 - interfejs do zarządzania kluczami OpenPGP
184
185 %prep
186 %setup -qc
187 mv comm-release mozilla
188 %setup -q -T -D -a2
189 cd mozilla
190 %{?with_enigmail:%{__gzip} -dc %{SOURCE1} | %{__tar} -xf - -C mailnews/extensions}
191 /bin/sh %{SOURCE3}
192 %patch0 -p1
193 %{?with_enigmail:%patch1 -p1}
194 %{?with_xulrunner:%patch2 -p1}
195 %patch3 -p1
196 %patch4 -p1
197 %patch6 -p1
198 %patch7 -p1
199 %patch8 -p2
200 cd mozilla
201 %patch9 -p1
202 cd -
203 %patch10 -p2
204 %patch11 -p2
205 %patch12 -p1
206
207 %build
208 cd mozilla
209 cp -f %{_datadir}/automake/config.* mozilla/build/autoconf
210 cp -f %{_datadir}/automake/config.* mozilla/nsprpub/build/autoconf
211 cp -f %{_datadir}/automake/config.* ldap/sdks/c-sdk/config/autoconf
212
213 cat << EOF > .mozconfig
214 mk_add_options MOZ_OBJDIR=%{objdir}
215
216 export CFLAGS="%{rpmcflags}"
217 export CXXFLAGS="%{rpmcflags}"
218
219 %if %{with crashreporter}
220 export MOZ_DEBUG_SYMBOLS=1
221 %endif
222
223 # Options for 'configure' (same as command-line options).
224 ac_add_options --prefix=%{_prefix}
225 ac_add_options --exec-prefix=%{_exec_prefix}
226 ac_add_options --bindir=%{_bindir}
227 ac_add_options --sbindir=%{_sbindir}
228 ac_add_options --sysconfdir=%{_sysconfdir}
229 ac_add_options --datadir=%{_datadir}
230 ac_add_options --includedir=%{_includedir}
231 ac_add_options --libdir=%{_libdir}
232 ac_add_options --libexecdir=%{_libexecdir}
233 ac_add_options --localstatedir=%{_localstatedir}
234 ac_add_options --sharedstatedir=%{_sharedstatedir}
235 ac_add_options --mandir=%{_mandir}
236 ac_add_options --infodir=%{_infodir}
237 %if %{?debug:1}0
238 ac_add_options --disable-optimize
239 ac_add_options --enable-debug
240 ac_add_options --enable-debug-modules
241 ac_add_options --enable-debugger-info-modules
242 ac_add_options --enable-crash-on-assert
243 %else
244 ac_add_options --disable-debug
245 ac_add_options --disable-debug-modules
246 ac_add_options --disable-logging
247 ac_add_options --enable-optimize="%{rpmcflags} -Os"
248 %endif
249 ac_add_options --disable-strip
250 ac_add_options --disable-strip-libs
251 %if %{with tests}
252 ac_add_options --enable-tests
253 %else
254 ac_add_options --disable-tests
255 %endif
256 ac_add_options --enable-gio
257 %if %{with gnomeui}
258 ac_add_options --enable-gnomeui
259 %else
260 ac_add_options --disable-gnomeui
261 %endif
262 ac_add_options --disable-gnomevfs
263 %if %{with ldap}
264 ac_add_options --enable-ldap
265 ac_add_options --with-system-ldap
266 %else
267 ac_add_options --disable-ldap
268 %endif
269 %if %{with crashreporter}
270 ac_add_options --enable-crashreporter
271 %else
272 ac_add_options --disable-crashreporter
273 %endif
274 ac_add_options --disable-xterm-updates
275 ac_add_options --enable-postscript
276 %if %{with lightning}
277 ac_add_options --enable-calendar
278 %else
279 ac_add_options --disable-calendar
280 %endif
281 ac_add_options --disable-installer
282 ac_add_options --disable-updater
283 ac_add_options --disable-xprint
284 ac_add_options --disable-permissions
285 ac_add_options --disable-pref-extensions
286 ac_add_options --enable-canvas
287 ac_add_options --enable-crypto
288 ac_add_options --enable-mathml
289 ac_add_options --enable-pango
290 ac_add_options --enable-reorder
291 ac_add_options --enable-startup-notification
292 ac_add_options --enable-svg
293 ac_add_options --enable-system-cairo
294 ac_add_options --enable-system-hunspell
295 ac_add_options --enable-system-sqlite
296 ac_add_options --enable-xft
297 ac_add_options --enable-application=mail
298 ac_add_options --enable-default-toolkit=cairo-gtk2
299 ac_add_options --enable-xinerama
300 ac_add_options --with-distribution-id=org.pld-linux
301 ac_add_options --with-branding=icedove/branding
302 %if %{with xulrunner}
303 ac_add_options --enable-shared-js
304 ac_add_options --with-libxul-sdk=$(pkg-config --variable=sdkdir libxul)
305 ac_add_options --with-system-libxul
306 %endif
307 ac_add_options --with-pthreads
308 ac_add_options --with-system-bz2
309 ac_add_options --with-system-jpeg
310 ac_add_options --with-system-nspr
311 ac_add_options --with-system-nss
312 ac_add_options --with-system-png
313 ac_add_options --with-system-zlib
314 ac_add_options --enable-single-profile
315 ac_add_options --disable-profilesharing
316 ac_add_options --with-default-mozilla-five-home=%{_libdir}/%{name}
317 EOF
318
319 %{__make} -j1 -f client.mk build \
320         STRIP="/bin/true" \
321         MOZ_MAKE_FLAGS="%{?_smp_mflags}" \
322         CC="%{__cc}" \
323         CXX="%{__cxx}"
324
325 %if %{with crashreporter}
326 # create debuginfo for crash-stats.mozilla.com
327 %{__make} -j1 -C obj-%{_target_cpu} buildsymbols
328 %endif
329
330 %if %{with enigmail}
331 cd mailnews/extensions/enigmail
332 ./makemake -r -o %{objdir}
333 %{__make} -C %{objdir}/mailnews/extensions/enigmail \
334         STRIP="/bin/true" \
335         CC="%{__cc}" \
336         CXX="%{__cxx}"
337 %endif
338
339 %install
340 rm -rf $RPM_BUILD_ROOT
341 install -d $RPM_BUILD_ROOT{%{_bindir},%{_libdir}/%{name},%{_datadir}/%{name},%{_pixmapsdir},%{_desktopdir}}
342
343 cd %{objdir}
344 %{__make} -C mail/installer stage-package \
345         DESTDIR=$RPM_BUILD_ROOT \
346         MOZ_PKG_DIR=%{_libdir}/%{name} \
347         PKG_SKIP_STRIP=1
348
349 %if %{with xulrunner}
350 # needed to find mozilla runtime
351 ln -s ../xulrunner $RPM_BUILD_ROOT%{_libdir}/%{name}/xulrunner
352 %endif
353  
354 # Enable crash reporter for Thunderbird application
355 %if %{with crashreporter}
356 %{__sed} -i -e 's/\[Crash Reporter\]/[Crash Reporter]\nEnabled=1/' $RPM_BUILD_ROOT%{_libdir}/%{name}/application.ini
357
358 # Add debuginfo for crash-stats.mozilla.com
359 install -d $RPM_BUILD_ROOT%{_exec_prefix}/lib/debug%{_libdir}/%{name}
360 cp -a mozilla/dist/%{name}-%{version}.en-US.linux-*.crashreporter-symbols.zip $RPM_BUILD_ROOT%{_prefix}/lib/debug%{_libdir}/%{name}
361 %endif
362
363 # copy manually lightning files, somewhy they are not installed by make
364 cp -a mozilla/dist/bin/extensions/calendar-timezones@mozilla.org \
365         mozilla/dist/bin/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103} \
366         $RPM_BUILD_ROOT%{_libdir}/%{name}/extensions
367
368 # move arch independant ones to datadir
369 mv $RPM_BUILD_ROOT%{_libdir}/%{name}/chrome $RPM_BUILD_ROOT%{_datadir}/%{name}/chrome
370 mv $RPM_BUILD_ROOT%{_libdir}/%{name}/defaults $RPM_BUILD_ROOT%{_datadir}/%{name}/defaults
371 mv $RPM_BUILD_ROOT%{_libdir}/%{name}/isp $RPM_BUILD_ROOT%{_datadir}/%{name}/isp
372 mv $RPM_BUILD_ROOT%{_libdir}/%{name}/modules $RPM_BUILD_ROOT%{_datadir}/%{name}/modules
373 mv $RPM_BUILD_ROOT%{_libdir}/%{name}/searchplugins $RPM_BUILD_ROOT%{_datadir}/%{name}/searchplugins
374 ln -s ../../share/%{name}/chrome $RPM_BUILD_ROOT%{_libdir}/%{name}/chrome
375 ln -s ../../share/%{name}/defaults $RPM_BUILD_ROOT%{_libdir}/%{name}/defaults
376 ln -s ../../share/%{name}/isp $RPM_BUILD_ROOT%{_libdir}/%{name}/isp
377 ln -s ../../share/%{name}/modules $RPM_BUILD_ROOT%{_libdir}/%{name}/modules
378 ln -s ../../share/%{name}/searchplugins $RPM_BUILD_ROOT%{_libdir}/%{name}/searchplugins
379 %if %{without xulrunner}
380 mv $RPM_BUILD_ROOT%{_libdir}/%{name}/res $RPM_BUILD_ROOT%{_datadir}/%{name}/res
381 ln -s ../../share/%{name}/res $RPM_BUILD_ROOT%{_libdir}/%{name}/res
382 %endif
383
384 # dir for arch independant extensions besides arch dependant extensions
385 # see mozilla/xpcom/build/nsXULAppAPI.h
386 # XRE_SYS_LOCAL_EXTENSION_PARENT_DIR and XRE_SYS_SHARE_EXTENSION_PARENT_DIR
387 install -d $RPM_BUILD_ROOT%{_datadir}/%{name}/extensions
388
389 %if %{without xulrunner}
390 %{__rm} -r $RPM_BUILD_ROOT%{_libdir}/%{name}/dictionaries
391 ln -s %{_datadir}/myspell $RPM_BUILD_ROOT%{_libdir}/%{name}/dictionaries
392 %{__rm} -r $RPM_BUILD_ROOT%{_libdir}/%{name}/hyphenation
393 ln -s %{_datadir}/myspell $RPM_BUILD_ROOT%{_libdir}/%{name}/hyphenation
394 %endif
395
396 %{__sed} -e 's,@LIBDIR@,%{_libdir},' %{SOURCE5} > $RPM_BUILD_ROOT%{_bindir}/icedove
397 ln -s %{name} $RPM_BUILD_ROOT%{_bindir}/thunderbird
398 ln -s %{name} $RPM_BUILD_ROOT%{_bindir}/mozilla-thunderbird
399
400 cp -p %{SOURCE4} $RPM_BUILD_ROOT%{_desktopdir}/%{name}.desktop
401 cp -p %{topdir}/mozilla/icedove/branding/content/icon64.png $RPM_BUILD_ROOT%{_pixmapsdir}/%{name}.png
402
403 # files created by regxpcom -register in post
404 touch $RPM_BUILD_ROOT%{_libdir}/%{name}/components/compreg.dat
405 touch $RPM_BUILD_ROOT%{_libdir}/%{name}/components/xpti.dat
406 cat << 'EOF' > $RPM_BUILD_ROOT%{_libdir}/%{name}/register
407 #!/bin/sh
408 umask 022
409 # make temporary HOME, as it attempts to touch files in $HOME/.mozilla
410 # dangerous if you run this with sudo with keep_env += HOME
411 # also TMPDIR could be pointing to sudo user's homedir so we reset that too.
412 t=$(mktemp -d)
413 %{__rm} -f %{_libdir}/%{name}/components/{compreg,xpti}.dat
414 TMPDIR= TMP= HOME=$t %{_libdir}/%{name}/icedove -register
415 rm -rf $t
416 EOF
417 chmod a+rx $RPM_BUILD_ROOT%{_libdir}/%{name}/register
418
419 %if %{with enigmail}
420 ext_dir=$RPM_BUILD_ROOT%{_libdir}/%{name}/extensions/\{847b3a00-7ab1-11d4-8f02-006008948af5\}
421 install -d $ext_dir/{chrome,components,defaults/preferences}
422 cd mozilla/dist/bin
423 #cp -rfLp chrome/enigmail.jar $ext_dir/chrome
424 #cp -rfLp chrome/enigmime.jar $ext_dir/chrome
425 cp -rfLp components/enig* $ext_dir/components
426 cp -rfLp components/libenigmime.so $ext_dir/components
427 cp -rfLp components/libipc.so $ext_dir/components
428 cp -rfLp components/ipc.xpt $ext_dir/components
429 cp -rfLp defaults/preferences/enigmail.js $ext_dir/defaults/preferences
430 cd -
431 cp -p %{topdir}/mozilla/mailnews/extensions/enigmail/package/install.rdf $ext_dir
432 cp -p %{topdir}/mozilla/mailnews/extensions/enigmail/package/chrome.manifest $ext_dir/chrome.manifest
433 %endif
434
435 # never package these. always remove
436 # nss
437 %{__rm} -f $RPM_BUILD_ROOT%{_libdir}/%{name}/lib{freebl3,nss3,nssckbi,nssdbm3,nssutil3,smime3,softokn3,ssl3}.*
438 # nspr
439 %{__rm} -f $RPM_BUILD_ROOT%{_libdir}/%{name}/lib{nspr4,plc4,plds4}.so
440 # mozldap
441 %{__rm} -f $RPM_BUILD_ROOT%{_libdir}/%{name}/lib{ldap,ldif,prldap,ssldap}60.so
442 # testpilot quiz
443 %{__rm} -f $RPM_BUILD_ROOT%{_libdir}/%{name}/distribution/extensions/tbtestpilot@labs.mozilla.com.xpi
444
445 %clean
446 rm -rf $RPM_BUILD_ROOT
447
448 %pretrans
449 if [ -d %{_libdir}/%{name}/dictionaries ] && [ ! -L %{_libdir}/%{name}/dictionaries ]; then
450         mv -v %{_libdir}/%{name}/dictionaries{,.rpmsave}
451 fi
452 for d in chrome defaults icons isp modules res searchplugins; do
453         if [ -d %{_libdir}/%{name}/$d ] && [ ! -L %{_libdir}/%{name}/$d ]; then
454                 install -d %{_datadir}/%{name}
455                 mv %{_libdir}/%{name}/$d %{_datadir}/%{name}/$d
456         fi
457 done
458 exit 0
459
460 %post
461 %{_libdir}/%{name}/register || :
462
463 %files
464 %defattr(644,root,root,755)
465 %attr(755,root,root) %{_bindir}/icedove
466 %attr(755,root,root) %{_bindir}/mozilla-thunderbird
467 %attr(755,root,root) %{_bindir}/thunderbird
468 %dir %{_libdir}/%{name}
469 %{_libdir}/%{name}/application.ini
470 %{_libdir}/%{name}/blocklist.xml
471 %{_libdir}/%{name}/chrome.manifest
472 %dir %{_libdir}/%{name}/components
473 %{_libdir}/%{name}/components/*.js
474 %{_libdir}/%{name}/components/*.xpt
475 %{_libdir}/%{name}/components/components.manifest
476 %{_libdir}/%{name}/components/interfaces.manifest
477 %attr(755,root,root) %{_libdir}/%{name}/*.sh
478 %attr(755,root,root) %{_libdir}/%{name}/*-bin
479 %attr(755,root,root) %{_libdir}/%{name}/icedove
480 %attr(755,root,root) %{_libdir}/%{name}/register
481 %if %{without xulrunner}
482 %{_libdir}/%{name}/platform.ini
483 %{_libdir}/%{name}/greprefs.js
484 %attr(755,root,root) %{_libdir}/%{name}/components/*.so
485 %attr(755,root,root) %{_libdir}/%{name}/libmozalloc.so
486 %attr(755,root,root) %{_libdir}/%{name}/libxpcom.so
487 %attr(755,root,root) %{_libdir}/%{name}/libxul.so
488 %attr(755,root,root) %{_libdir}/%{name}/mozilla-xremote-client
489 %attr(755,root,root) %{_libdir}/%{name}/plugin-container
490 %endif
491
492 # symlinks
493 %{_libdir}/%{name}/chrome
494 %{_libdir}/%{name}/defaults
495 %{_libdir}/%{name}/isp
496 %{_libdir}/%{name}/modules
497 %{_libdir}/%{name}/searchplugins
498 %if %{with xulrunner}
499 %{_libdir}/%{name}/xulrunner
500 %else
501 %{_libdir}/%{name}/dictionaries
502 %{_libdir}/%{name}/hyphenation
503 %{_libdir}/%{name}/res
504 %endif
505
506 %{_pixmapsdir}/icedove.png
507 %{_desktopdir}/icedove.desktop
508
509 %dir %{_datadir}/%{name}
510 %{_datadir}/%{name}/chrome
511 %{_datadir}/%{name}/defaults
512 %{_datadir}/%{name}/extensions
513 %{_datadir}/%{name}/isp
514 %{_datadir}/%{name}/modules
515 %{_datadir}/%{name}/searchplugins
516 %if %{without xulrunner}
517 %{_datadir}/%{name}/res
518 %endif
519
520 %if %{with crashreporter}
521 %attr(755,root,root) %{_libdir}/%{name}/crashreporter
522 %{_libdir}/%{name}/crashreporter.ini
523 %{_libdir}/%{name}/Throbber-small.gif
524 %endif
525
526 %dir %{_libdir}/%{name}/extensions
527 %{_libdir}/%{name}/extensions/{972ce4c6-7e08-4474-a285-3208198ce6fd}
528
529 # files created by regxpcom -register
530 %ghost %{_libdir}/%{name}/components/compreg.dat
531 %ghost %{_libdir}/%{name}/components/xpti.dat
532
533 %if %{with lightning}
534 %files addon-lightning
535 %defattr(644,root,root,755)
536 %dir %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}
537 %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/application.ini
538 %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/chrome
539 %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/chrome.manifest
540 %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/defaults
541 %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/install.rdf
542 %dir %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/components
543 %attr(755,root,root) %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/components/*.so
544 %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/components/*.js
545 %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/components/*.manifest
546 %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/components/*.xpt
547 %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/modules
548 %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/calendar-js
549 %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/timezones.sqlite
550 %{_libdir}/%{name}/extensions/calendar-timezones@mozilla.org
551 %endif
552
553 %if %{with enigmail}
554 %files addon-enigmail
555 %defattr(644,root,root,755)
556 %dir %{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}
557 %{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/defaults
558 %{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/chrome
559 %{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/chrome.manifest
560 %{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/install.rdf
561 %dir %{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/components
562 %attr(755,root,root) %{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/components/*.so
563 %{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/components/*.xpt
564 %{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/components/*.js
565 %endif
This page took 0.066084 seconds and 4 git commands to generate.