]> git.pld-linux.org Git - packages/thunderbird.git/blob - icedove.spec
- xulrunner/icedove now requires libjpeg-turbo (with at least libjpeg 6b API), not...
[packages/thunderbird.git] / icedove.spec
1 # TODO:
2 # - separate spec for enigmail
3 # - build with system mozldap
4 #
5 # Conditional builds
6 %bcond_without  enigmail        # don't build enigmail - GPG/PGP support
7 %bcond_without  gnomeui         # disable gnomeui support
8 %bcond_without  gnome           # alias for gnomeui
9 %bcond_without  ldap            # disable e-mail address lookups in LDAP directories
10 %bcond_without  lightning       # disable Sunbird/Lightning calendar
11 %bcond_with     xulrunner       # system xulrunner
12 %bcond_with     crashreporter   # report crashes to crash-stats.mozilla.com
13
14 %if %{without gnome}
15 %undefine       with_gnomeui
16 %endif
17
18 %if 0%{?_enable_debug_packages} != 1
19 %undefine       crashreporter
20 %endif
21
22 %define         enigmail_ver    1.5.0
23 %define         nspr_ver        4.9.3
24 %define         nss_ver         3.14.1
25
26 %define         xulrunner_ver   2:17.0
27
28 %if %{without xulrunner}
29 # The actual sqlite version (see RHBZ#480989):
30 %define         sqlite_build_version %(pkg-config --silence-errors --modversion sqlite3 2>/dev/null || echo ERROR)
31 %endif
32
33 Summary:        Icedove - email client
34 Summary(pl.UTF-8):      Icedove - klient poczty
35 Name:           icedove
36 Version:        17.0.2
37 Release:        2
38 License:        MPL 1.1 or GPL v2+ or LGPL v2.1+
39 Group:          X11/Applications/Networking
40 Source0:        http://releases.mozilla.org/pub/mozilla.org/thunderbird/releases/%{version}/source/thunderbird-%{version}.source.tar.bz2
41 # Source0-md5:  9b7f15fbc672745571d47a3c0e227ca1
42 Source1:        http://www.mozilla-enigmail.org/download/source/enigmail-%{enigmail_ver}.tar.gz
43 # Source1-md5:  af4b3534417f32dc201765e4de6ecc86
44 Source2:        %{name}-branding.tar.bz2
45 # Source2-md5:  2da351522bdd7f4a3bd8aaff4c776976
46 Source3:        %{name}-rm_nonfree.sh
47 Source4:        %{name}.desktop
48 Source5:        %{name}.sh
49 Patch0:         %{name}-branding.patch
50 Patch1:         %{name}-enigmail-shared.patch
51 Patch2:         %{name}-system-xulrunner.patch
52 Patch3:         %{name}-fonts.patch
53 Patch4:         %{name}-install.patch
54 Patch5:         %{name}-hunspell.patch
55 Patch6:         %{name}-prefs.patch
56 Patch7:         system-mozldap.patch
57 Patch8:         %{name}-makefile.patch
58 Patch9:         system-cairo.patch
59 Patch10:        %{name}-extensiondir.patch
60 Patch11:        crashreporter.patch
61 Patch12:        no-subshell.patch
62 # Edit patch below and restore --system-site-packages when system virtualenv gets 1.7 upgrade
63 Patch13:        system-virtualenv.patch
64 URL:            http://www.pld-linux.org/Packages/Icedove
65 BuildRequires:  GConf2-devel >= 1.2.1
66 BuildRequires:  alsa-lib-devel
67 BuildRequires:  automake
68 BuildRequires:  bzip2-devel
69 BuildRequires:  cairo-devel >= 1.10
70 BuildRequires:  dbus-glib-devel >= 0.60
71 BuildRequires:  freetype-devel >= 1:2.1.8
72 BuildRequires:  glib2-devel >= 2.0
73 BuildRequires:  gtk+2-devel >= 2:2.10.0
74 BuildRequires:  hunspell-devel
75 BuildRequires:  libIDL-devel >= 0.8.0
76 %{?with_gnomeui:BuildRequires:  libgnome-devel >= 2.0}
77 %{?with_gnomeui:BuildRequires:  libgnome-keyring-devel}
78 %{?with_gnomeui:BuildRequires:  libgnomeui-devel >= 2.2.0}
79 BuildRequires:  libiw-devel
80 # requires libjpeg-turbo implementing at least libjpeg 6b API
81 BuildRequires:  libjpeg-devel >= 6b
82 BuildRequires:  libjpeg-turbo-devel
83 BuildRequires:  libnotify-devel >= 0.4
84 BuildRequires:  libpng-devel >= 1.4.1
85 BuildRequires:  libstdc++-devel
86 BuildRequires:  nspr-devel >= 1:%{nspr_ver}
87 BuildRequires:  nss-devel >= 1:%{nss_ver}
88 BuildRequires:  pango-devel >= 1:1.14.0
89 BuildRequires:  perl-base >= 1:5.6
90 BuildRequires:  pkgconfig
91 BuildRequires:  python >= 1:2.5
92 BuildRequires:  sed >= 4.0
93 BuildRequires:  sqlite3-devel >= 3.7.4
94 BuildRequires:  startup-notification-devel >= 0.8
95 BuildRequires:  xorg-lib-libXext-devel
96 BuildRequires:  xorg-lib-libXinerama-devel
97 BuildRequires:  xorg-lib-libXt-devel
98 BuildRequires:  yasm
99 BuildRequires:  zip
100 %if %{with xulrunner}
101 BuildRequires:  xulrunner-devel >= %{xulrunner_ver}
102 %else
103 Requires:       myspell-common
104 Requires:       nspr >= 1:%{nspr_ver}
105 Requires:       nss >= 1:%{nss_ver}
106 Requires:       sqlite3 >= %{sqlite_build_version}
107 %endif
108 Requires(post): mktemp >= 1.5-18
109 %if %{with xulrunner}
110 %requires_eq_to xulrunner xulrunner-devel
111 %endif
112 Requires:       libjpeg-turbo
113 Obsoletes:      mozilla-thunderbird
114 Obsoletes:      mozilla-thunderbird-dictionary-en-US
115 Conflicts:      icedove-lang-resources < %{version}
116 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
117
118 %define         filterout_cpp           -D_FORTIFY_SOURCE=[0-9]+
119
120 # iceweasel/icedove/iceape provide their own versions
121 %define         _noautoprovfiles        %{_libdir}/%{name}/components
122 %if %{without xulrunner}
123 # we don't want these to satisfy packages depending on xulrunner
124 %define         _noautoprov             libmozalloc.so libxpcom.so libxul.so
125 # and as we don't provide them, don't require either
126 %define         _noautoreq              libmozalloc.so libxpcom.so libxul.so
127 %endif
128
129 %define         topdir          %{_builddir}/%{name}-%{version}
130 %define         objdir          %{topdir}/obj-%{_target_cpu}
131
132 %description
133 Icedove is an open-source, fast and portable email client.
134
135 %description -l pl.UTF-8
136 Icedove jest mającym otwarte źródła, szybkim i przenośnym klientem
137 poczty.
138
139 %package addon-lightning
140 Summary:        An integrated calendar for Icedove
141 Summary(pl.UTF-8):      Zintegrowany kalendarz dla Icedove
142 License:        MPL 1.1 or GPL v2+ or LGPL v2.1+
143 Group:          Applications/Networking
144 Requires:       %{name} = %{version}-%{release}
145
146 %description addon-lightning
147 Lightning is an calendar extension to Icedove email client.
148
149 %description addon-lightning -l pl.UTF-8
150 Lightning to rozszerzenie do klienta poczty Icedove dodające
151 funkcjonalność kalendarza.
152
153 %package addon-enigmail
154 Summary:        Extension for the authentication and encryption features provided by GnuPG
155 Summary(pl.UTF-8):      Rozszerzenie do uwierzytelniania i szyfrowania zapewnianego przez GnuPG
156 License:        MPL/LGPL
157 Group:          Applications/Networking
158 URL:            http://enigmail.mozdev.org/
159 Requires:       %{name} = %{version}-%{release}
160 Requires:       gnupg
161 Obsoletes:      mozilla-thunderbird-addon-enigmail
162
163 %description addon-enigmail
164 Enigmail is an extension to the Icedove mail client which allows users
165 to access the authentication and encryption features provided by
166 GnuPG.
167
168 Main Features:
169 - Encrypt/sign mail when sending, decrypt/authenticate received mail
170 - Support for inline-PGP (RFC 2440) and PGP/MIME (RFC 3156)
171 - Per-Account based encryption and signing defaults
172 - Per-Recipient rules for automated key selection, and
173   enabling/disabling encryption and signing
174 - OpenPGP key management interface
175
176 %description addon-enigmail -l pl.UTF-8
177 Enigmail to rozszerzenie klienta pocztowego Icedove pozwalające
178 użytkownikom na dostęp do uwierzytelniania i szyfrowania zapewnianego
179 przez GnuPG.
180
181 Główne możliwości:
182 - szyfrowanie/podpisywanie poczty przy wysyłaniu,
183   odszyfrowywanie/uwierzytelnianie poczty odebranej
184 - obsługa inline-PGP (RFC 2440) i PGP/MIME (RFC 3156)
185 - ustawienia domyślne szyfrowania i podpisywania dla każdego konta
186 - reguły automatycznego wyboru kluczy i włączenia szyfrowania oraz
187   podpisywania dla każdego adresata
188 - interfejs do zarządzania kluczami OpenPGP
189
190 %prep
191 %setup -qc
192 mv comm-release mozilla
193 %setup -q -T -D -a2
194 cd mozilla
195 %{?with_enigmail:%{__gzip} -dc %{SOURCE1} | %{__tar} -xf - -C mailnews/extensions}
196 /bin/sh %{SOURCE3}
197 %patch0 -p1
198 %{?with_enigmail:%patch1 -p1}
199 %{?with_xulrunner:%patch2 -p1}
200 %patch3 -p1
201 %patch4 -p1
202 %patch6 -p1
203 %patch7 -p1
204 %patch8 -p2
205 %patch9 -p1
206 %patch10 -p2
207 %patch11 -p2
208 %patch12 -p1
209 %patch13 -p1
210
211 %build
212 cd mozilla
213 cp -f %{_datadir}/automake/config.* mozilla/build/autoconf
214 cp -f %{_datadir}/automake/config.* mozilla/nsprpub/build/autoconf
215 cp -f %{_datadir}/automake/config.* ldap/sdks/c-sdk/config/autoconf
216
217 cat << EOF > .mozconfig
218 mk_add_options MOZ_OBJDIR=%{objdir}
219
220 export CFLAGS="%{rpmcflags}"
221 export CXXFLAGS="%{rpmcflags}"
222
223 %if %{with crashreporter}
224 export MOZ_DEBUG_SYMBOLS=1
225 %endif
226
227 # Options for 'configure' (same as command-line options).
228 ac_add_options --prefix=%{_prefix}
229 ac_add_options --exec-prefix=%{_exec_prefix}
230 ac_add_options --bindir=%{_bindir}
231 ac_add_options --sbindir=%{_sbindir}
232 ac_add_options --sysconfdir=%{_sysconfdir}
233 ac_add_options --datadir=%{_datadir}
234 ac_add_options --includedir=%{_includedir}
235 ac_add_options --libdir=%{_libdir}
236 ac_add_options --libexecdir=%{_libexecdir}
237 ac_add_options --localstatedir=%{_localstatedir}
238 ac_add_options --sharedstatedir=%{_sharedstatedir}
239 ac_add_options --mandir=%{_mandir}
240 ac_add_options --infodir=%{_infodir}
241 %if %{?debug:1}0
242 ac_add_options --disable-optimize
243 ac_add_options --enable-debug
244 ac_add_options --enable-debug-modules
245 ac_add_options --enable-debugger-info-modules
246 ac_add_options --enable-crash-on-assert
247 %else
248 ac_add_options --disable-debug
249 ac_add_options --disable-debug-modules
250 ac_add_options --disable-logging
251 ac_add_options --enable-optimize="%{rpmcflags} -Os"
252 %endif
253 ac_add_options --disable-strip
254 ac_add_options --disable-strip-libs
255 %if %{with tests}
256 ac_add_options --enable-tests
257 %else
258 ac_add_options --disable-tests
259 %endif
260 ac_add_options --enable-gio
261 %if %{with gnomeui}
262 ac_add_options --enable-gnomeui
263 %else
264 ac_add_options --disable-gnomeui
265 %endif
266 ac_add_options --disable-gnomevfs
267 %if %{with ldap}
268 ac_add_options --enable-ldap
269 ac_add_options --with-system-ldap
270 %else
271 ac_add_options --disable-ldap
272 %endif
273 %if %{with crashreporter}
274 ac_add_options --enable-crashreporter
275 %else
276 ac_add_options --disable-crashreporter
277 %endif
278 ac_add_options --disable-xterm-updates
279 ac_add_options --enable-postscript
280 %if %{with lightning}
281 ac_add_options --enable-calendar
282 %else
283 ac_add_options --disable-calendar
284 %endif
285 ac_add_options --disable-installer
286 ac_add_options --disable-updater
287 ac_add_options --disable-xprint
288 ac_add_options --disable-permissions
289 ac_add_options --disable-pref-extensions
290 ac_add_options --enable-canvas
291 ac_add_options --enable-crypto
292 ac_add_options --enable-mathml
293 ac_add_options --enable-pango
294 ac_add_options --enable-reorder
295 ac_add_options --enable-startup-notification
296 ac_add_options --enable-svg
297 ac_add_options --enable-system-cairo
298 ac_add_options --enable-system-hunspell
299 ac_add_options --enable-system-sqlite
300 ac_add_options --enable-xft
301 ac_add_options --enable-application=mail
302 ac_add_options --enable-default-toolkit=cairo-gtk2
303 ac_add_options --enable-xinerama
304 ac_add_options --with-distribution-id=org.pld-linux
305 ac_add_options --with-branding=icedove/branding
306 %if %{with xulrunner}
307 ac_add_options --enable-shared-js
308 ac_add_options --with-libxul-sdk=$(pkg-config --variable=sdkdir libxul)
309 ac_add_options --with-system-libxul
310 %endif
311 ac_add_options --with-pthreads
312 ac_add_options --with-system-bz2
313 ac_add_options --with-system-jpeg
314 ac_add_options --with-system-nspr
315 ac_add_options --with-system-nss
316 ac_add_options --with-system-png
317 ac_add_options --with-system-zlib
318 ac_add_options --enable-single-profile
319 ac_add_options --disable-profilesharing
320 ac_add_options --with-default-mozilla-five-home=%{_libdir}/%{name}
321 EOF
322
323 %{__make} -j1 -f client.mk build \
324         STRIP="/bin/true" \
325         MOZ_MAKE_FLAGS="%{?_smp_mflags}" \
326         XLIBS="-lX11 -lXt" \
327         CC="%{__cc}" \
328         CXX="%{__cxx}"
329
330 %if %{with crashreporter}
331 # create debuginfo for crash-stats.mozilla.com
332 %{__make} -j1 -C obj-%{_target_cpu} buildsymbols
333 %endif
334
335 %if %{with enigmail}
336 cd mailnews/extensions/enigmail
337 ./makemake -r -o %{objdir}
338 %{__make} -C %{objdir}/mailnews/extensions/enigmail \
339         STRIP="/bin/true" \
340         CC="%{__cc}" \
341         CXX="%{__cxx}"
342
343 %{__make} -C %{objdir}/mailnews/extensions/enigmail xpi \
344         STRIP="/bin/true" \
345         CC="%{__cc}" \
346         CXX="%{__cxx}"
347 %endif
348
349 %install
350 rm -rf $RPM_BUILD_ROOT
351 install -d $RPM_BUILD_ROOT{%{_bindir},%{_libdir}/%{name},%{_datadir}/%{name},%{_pixmapsdir},%{_desktopdir}}
352
353 cd %{objdir}
354 %{__make} -C mail/installer stage-package \
355         DESTDIR=$RPM_BUILD_ROOT \
356         MOZ_PKG_DIR=%{_libdir}/%{name} \
357         PKG_SKIP_STRIP=1
358
359 %if %{with xulrunner}
360 # needed to find mozilla runtime
361 ln -s ../xulrunner $RPM_BUILD_ROOT%{_libdir}/%{name}/xulrunner
362 %endif
363  
364 # Enable crash reporter for Thunderbird application
365 %if %{with crashreporter}
366 %{__sed} -i -e 's/\[Crash Reporter\]/[Crash Reporter]\nEnabled=1/' $RPM_BUILD_ROOT%{_libdir}/%{name}/application.ini
367
368 # Add debuginfo for crash-stats.mozilla.com
369 install -d $RPM_BUILD_ROOT%{_exec_prefix}/lib/debug%{_libdir}/%{name}
370 cp -a mozilla/dist/%{name}-%{version}.en-US.linux-*.crashreporter-symbols.zip $RPM_BUILD_ROOT%{_prefix}/lib/debug%{_libdir}/%{name}
371 %endif
372
373 # copy manually lightning files, somewhy they are not installed by make
374 cp -a mozilla/dist/bin/extensions/calendar-timezones@mozilla.org \
375         mozilla/dist/bin/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103} \
376         $RPM_BUILD_ROOT%{_libdir}/%{name}/extensions
377
378 # move arch independant ones to datadir
379 mv $RPM_BUILD_ROOT%{_libdir}/%{name}/chrome $RPM_BUILD_ROOT%{_datadir}/%{name}/chrome
380 mv $RPM_BUILD_ROOT%{_libdir}/%{name}/defaults $RPM_BUILD_ROOT%{_datadir}/%{name}/defaults
381 mv $RPM_BUILD_ROOT%{_libdir}/%{name}/isp $RPM_BUILD_ROOT%{_datadir}/%{name}/isp
382 mv $RPM_BUILD_ROOT%{_libdir}/%{name}/modules $RPM_BUILD_ROOT%{_datadir}/%{name}/modules
383 mv $RPM_BUILD_ROOT%{_libdir}/%{name}/searchplugins $RPM_BUILD_ROOT%{_datadir}/%{name}/searchplugins
384 ln -s ../../share/%{name}/chrome $RPM_BUILD_ROOT%{_libdir}/%{name}/chrome
385 ln -s ../../share/%{name}/defaults $RPM_BUILD_ROOT%{_libdir}/%{name}/defaults
386 ln -s ../../share/%{name}/isp $RPM_BUILD_ROOT%{_libdir}/%{name}/isp
387 ln -s ../../share/%{name}/modules $RPM_BUILD_ROOT%{_libdir}/%{name}/modules
388 ln -s ../../share/%{name}/searchplugins $RPM_BUILD_ROOT%{_libdir}/%{name}/searchplugins
389 %if %{without xulrunner}
390 mv $RPM_BUILD_ROOT%{_libdir}/%{name}/res $RPM_BUILD_ROOT%{_datadir}/%{name}/res
391 ln -s ../../share/%{name}/res $RPM_BUILD_ROOT%{_libdir}/%{name}/res
392 %endif
393
394 # dir for arch independant extensions besides arch dependant extensions
395 # see mozilla/xpcom/build/nsXULAppAPI.h
396 # XRE_SYS_LOCAL_EXTENSION_PARENT_DIR and XRE_SYS_SHARE_EXTENSION_PARENT_DIR
397 install -d $RPM_BUILD_ROOT%{_datadir}/%{name}/extensions
398
399 %if %{without xulrunner}
400 %{__rm} -r $RPM_BUILD_ROOT%{_libdir}/%{name}/dictionaries
401 ln -s %{_datadir}/myspell $RPM_BUILD_ROOT%{_libdir}/%{name}/dictionaries
402 %{__rm} -r $RPM_BUILD_ROOT%{_libdir}/%{name}/hyphenation
403 ln -s %{_datadir}/myspell $RPM_BUILD_ROOT%{_libdir}/%{name}/hyphenation
404 %endif
405
406 %{__sed} -e "s|%MOZAPPDIR%|%{_libdir}/%{name}|" \
407          -e "s|%MOZ_APP_DISPLAYNAME%|Icedove|" \
408         %{topdir}/mozilla/mozilla/build/unix/mozilla.in > $RPM_BUILD_ROOT%{_libdir}/%{name}/icedove
409
410 %{__sed} -e 's,@LIBDIR@,%{_libdir},' %{SOURCE5} > $RPM_BUILD_ROOT%{_bindir}/icedove
411 ln -s %{name} $RPM_BUILD_ROOT%{_bindir}/thunderbird
412 ln -s %{name} $RPM_BUILD_ROOT%{_bindir}/mozilla-thunderbird
413
414 cp -p %{SOURCE4} $RPM_BUILD_ROOT%{_desktopdir}/%{name}.desktop
415 cp -p %{topdir}/mozilla/icedove/branding/content/icon64.png $RPM_BUILD_ROOT%{_pixmapsdir}/%{name}.png
416
417 # files created by regxpcom -register in post
418 touch $RPM_BUILD_ROOT%{_libdir}/%{name}/components/compreg.dat
419 touch $RPM_BUILD_ROOT%{_libdir}/%{name}/components/xpti.dat
420 cat << 'EOF' > $RPM_BUILD_ROOT%{_libdir}/%{name}/register
421 #!/bin/sh
422 umask 022
423 # make temporary HOME, as it attempts to touch files in $HOME/.mozilla
424 # dangerous if you run this with sudo with keep_env += HOME
425 # also TMPDIR could be pointing to sudo user's homedir so we reset that too.
426 t=$(mktemp -d)
427 %{__rm} -f %{_libdir}/%{name}/components/{compreg,xpti}.dat
428 TMPDIR= TMP= HOME=$t %{_libdir}/%{name}/icedove -register
429 rm -rf $t
430 EOF
431 chmod a+rx $RPM_BUILD_ROOT%{_libdir}/%{name}/register
432
433 %if %{with enigmail}
434 ext_dir=$RPM_BUILD_ROOT%{_libdir}/%{name}/extensions/\{847b3a00-7ab1-11d4-8f02-006008948af5\}
435 install -d $ext_dir/{chrome,components,defaults/preferences,modules}
436 cd mozilla/dist/bin
437 cp -rfLp chrome/enigmail.jar $ext_dir/chrome
438 cp -rfLp components/enig* $ext_dir/components
439 cp -rfLp components/libenigmime.so $ext_dir/components
440 cp -rfLp defaults/preferences/enigmail.js $ext_dir/defaults/preferences
441 cp -rfLp modules/{commonFuncs,enigmailCommon,keyManagement,pipeConsole,subprocess}.jsm $ext_dir/modules
442 cp -rfLp modules/{subprocess_worker_unix,subprocess_worker_win}.js $ext_dir/modules
443 cd -
444 cp -p %{topdir}/mozilla/mailnews/extensions/enigmail/package/install.rdf $ext_dir
445 cp -p %{topdir}/mozilla/mailnews/extensions/enigmail/package/chrome.manifest $ext_dir/chrome.manifest
446 %endif
447
448 # never package these. always remove
449 # nss
450 %{__rm} -f $RPM_BUILD_ROOT%{_libdir}/%{name}/lib{freebl3,nss3,nssckbi,nssdbm3,nssutil3,smime3,softokn3,ssl3}.*
451 # nspr
452 %{__rm} -f $RPM_BUILD_ROOT%{_libdir}/%{name}/lib{nspr4,plc4,plds4}.so
453 # mozldap
454 %{__rm} -f $RPM_BUILD_ROOT%{_libdir}/%{name}/lib{ldap,ldif,prldap,ssldap}60.so
455 # testpilot quiz
456 %{__rm} -f $RPM_BUILD_ROOT%{_libdir}/%{name}/distribution/extensions/tbtestpilot@labs.mozilla.com.xpi
457
458 %clean
459 rm -rf $RPM_BUILD_ROOT
460
461 %pretrans
462 if [ -d %{_libdir}/%{name}/dictionaries ] && [ ! -L %{_libdir}/%{name}/dictionaries ]; then
463         mv -v %{_libdir}/%{name}/dictionaries{,.rpmsave}
464 fi
465 for d in chrome defaults icons isp modules res searchplugins; do
466         if [ -d %{_libdir}/%{name}/$d ] && [ ! -L %{_libdir}/%{name}/$d ]; then
467                 install -d %{_datadir}/%{name}
468                 mv %{_libdir}/%{name}/$d %{_datadir}/%{name}/$d
469         fi
470 done
471 exit 0
472
473 %post
474 %{_libdir}/%{name}/register || :
475
476 %files
477 %defattr(644,root,root,755)
478 %attr(755,root,root) %{_bindir}/icedove
479 %attr(755,root,root) %{_bindir}/mozilla-thunderbird
480 %attr(755,root,root) %{_bindir}/thunderbird
481 %dir %{_libdir}/%{name}
482 %{_libdir}/%{name}/application.ini
483 %{_libdir}/%{name}/blocklist.xml
484 %{_libdir}/%{name}/chrome.manifest
485 %dir %{_libdir}/%{name}/components
486 %{_libdir}/%{name}/components/*.js
487 %{_libdir}/%{name}/components/*.xpt
488 %{_libdir}/%{name}/components/components.manifest
489 %{_libdir}/%{name}/components/interfaces.manifest
490 %attr(755,root,root) %{_libdir}/%{name}/*.sh
491 %attr(755,root,root) %{_libdir}/%{name}/*-bin
492 %attr(755,root,root) %{_libdir}/%{name}/icedove
493 %attr(755,root,root) %{_libdir}/%{name}/register
494 %if %{without xulrunner}
495 %{_libdir}/%{name}/platform.ini
496 %{_libdir}/%{name}/greprefs.js
497 %attr(755,root,root) %{_libdir}/%{name}/components/*.so
498 %attr(755,root,root) %{_libdir}/%{name}/libmozalloc.so
499 %attr(755,root,root) %{_libdir}/%{name}/libxpcom.so
500 %attr(755,root,root) %{_libdir}/%{name}/libxul.so
501 %attr(755,root,root) %{_libdir}/%{name}/mozilla-xremote-client
502 %attr(755,root,root) %{_libdir}/%{name}/plugin-container
503 %endif
504
505 # symlinks
506 %{_libdir}/%{name}/chrome
507 %{_libdir}/%{name}/defaults
508 %{_libdir}/%{name}/isp
509 %{_libdir}/%{name}/modules
510 %{_libdir}/%{name}/searchplugins
511 %if %{with xulrunner}
512 %{_libdir}/%{name}/xulrunner
513 %else
514 %{_libdir}/%{name}/dictionaries
515 %{_libdir}/%{name}/hyphenation
516 %{_libdir}/%{name}/res
517 %endif
518
519 %{_pixmapsdir}/icedove.png
520 %{_desktopdir}/icedove.desktop
521
522 %dir %{_datadir}/%{name}
523 %{_datadir}/%{name}/chrome
524 %{_datadir}/%{name}/defaults
525 %{_datadir}/%{name}/extensions
526 %{_datadir}/%{name}/isp
527 %{_datadir}/%{name}/modules
528 %if %{with enigmail}
529 %exclude %{_datadir}/%{name}/modules/commonFuncs.jsm
530 %exclude %{_datadir}/%{name}/modules/enigmailCommon.jsm
531 %exclude %{_datadir}/%{name}/modules/keyManagement.jsm
532 %exclude %{_datadir}/%{name}/modules/pipeConsole.jsm
533 %exclude %{_datadir}/%{name}/modules/subprocess.jsm
534 %exclude %{_datadir}/%{name}/modules/subprocess_worker_unix.js
535 %exclude %{_datadir}/%{name}/modules/subprocess_worker_win.js
536 %endif
537 %{_datadir}/%{name}/searchplugins
538 %if %{without xulrunner}
539 %{_datadir}/%{name}/res
540 %endif
541
542 %if %{with crashreporter}
543 %attr(755,root,root) %{_libdir}/%{name}/crashreporter
544 %{_libdir}/%{name}/crashreporter.ini
545 %{_libdir}/%{name}/Throbber-small.gif
546 %endif
547
548 %dir %{_libdir}/%{name}/extensions
549 %{_libdir}/%{name}/extensions/{972ce4c6-7e08-4474-a285-3208198ce6fd}
550
551 # files created by regxpcom -register
552 %ghost %{_libdir}/%{name}/components/compreg.dat
553 %ghost %{_libdir}/%{name}/components/xpti.dat
554
555 %if %{with lightning}
556 %files addon-lightning
557 %defattr(644,root,root,755)
558 %dir %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}
559 %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/application.ini
560 %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/chrome
561 %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/chrome.manifest
562 %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/defaults
563 %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/install.rdf
564 %dir %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/components
565 %attr(755,root,root) %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/components/*.so
566 %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/components/*.js
567 %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/components/*.manifest
568 %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/components/*.xpt
569 %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/modules
570 %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/calendar-js
571 %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/timezones.sqlite
572 %{_libdir}/%{name}/extensions/calendar-timezones@mozilla.org
573 %endif
574
575 %if %{with enigmail}
576 %files addon-enigmail
577 %defattr(644,root,root,755)
578 %dir %{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}
579 %{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/defaults
580 %{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/chrome
581 %{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/chrome.manifest
582 %{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/install.rdf
583 %dir %{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/components
584 %attr(755,root,root) %{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/components/*.so
585 %{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/components/*.xpt
586 %{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/components/*.js
587 %dir %{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/modules
588 %{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/modules/*.jsm
589 %{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/modules/*.js
590 %endif
This page took 1.331903 seconds and 4 git commands to generate.