]> git.pld-linux.org Git - packages/thunderbird.git/blob - icedove.spec
- up to 9.0.1
[packages/thunderbird.git] / icedove.spec
1 # TODO:
2 # - separate spec for enigmail
3 # - build with system mozldap
4 # - replace gnome-vfs2 with gio
5 # - files:
6 #   /usr/lib/icedove/hyphenation/hyph_en_US.dic
7 # - enigmail - new version needed
8 #
9 # Conditional builds
10 %bcond_without  enigmail        # don't build enigmail - GPG/PGP support
11 %bcond_without  gnomeui         # disable gnomeui support
12 %bcond_without  gnomevfs        # disable GNOME comp. (gconf+libgnome+gnomevfs) and gnomevfs ext.
13 %bcond_without  gnome           # disable all GNOME components (gnome+gnomeui+gnomevfs)
14 %bcond_without  ldap            # disable e-mail address lookups in LDAP directories
15 %bcond_without  lightning       # disable Sunbird/Lightning calendar
16 %bcond_without  xulrunner       # build with xulrunner
17 %bcond_with     crashreporter   # report crashes to crash-stats.mozilla.com
18
19 %if %{without gnome}
20 %undefine       with_gnomeui
21 %undefine       with_gnomevfs
22 %endif
23
24 %if 0%{?_enable_debug_packages} != 1
25 %undefine       crashreporter
26 %endif
27
28 %define         enigmail_ver    1.3.4
29 %define         nspr_ver        4.8.8
30 %define         nss_ver         3.12.10
31
32 # convert firefox release number to platform version: 7.0.x -> 7.0.x
33 %define         xulrunner_main  9.0
34 %define         xulrunner_ver   %(v=%{version}; echo %{xulrunner_main}${v#9.0})
35
36 %if %{without xulrunner}
37 # The actual sqlite version (see RHBZ#480989):
38 %define         sqlite_build_version %(pkg-config --silence-errors --modversion sqlite3 2>/dev/null || echo ERROR)
39 %endif
40
41 Summary:        Icedove - email client
42 Summary(pl.UTF-8):      Icedove - klient poczty
43 Name:           icedove
44 Version:        9.0.1
45 Release:        0.1
46 License:        MPL 1.1 or GPL v2+ or LGPL v2.1+
47 Group:          X11/Applications/Networking
48 Source0:        http://releases.mozilla.org/pub/mozilla.org/thunderbird/releases/%{version}/source/thunderbird-%{version}.source.tar.bz2
49 # Source0-md5:  a5904751dbd33074682b438b732fdbab
50 Source1:        http://www.mozilla-enigmail.org/download/source/enigmail-%{enigmail_ver}.tar.gz
51 # Source1-md5:  2b5f188791811d248b6ff1fc51a5806a
52 Source2:        %{name}-branding.tar.bz2
53 # Source2-md5:  2da351522bdd7f4a3bd8aaff4c776976
54 Source3:        %{name}-rm_nonfree.sh
55 Source4:        %{name}.desktop
56 Source5:        %{name}.sh
57 Patch0:         %{name}-branding.patch
58 Patch1:         %{name}-enigmail-shared.patch
59 Patch2:         %{name}-gcc.patch
60 Patch3:         %{name}-fonts.patch
61 Patch4:         %{name}-install.patch
62 Patch5:         %{name}-hunspell.patch
63 Patch6:         %{name}-prefs.patch
64 Patch7:         system-mozldap.patch
65 Patch8:         %{name}-makefile.patch
66 Patch10:        %{name}-extensiondir.patch
67 Patch11:        crashreporter.patch
68 Patch12:        no-subshell.patch
69 URL:            http://www.pld-linux.org/Packages/Icedove
70 %{?with_gnomevfs:BuildRequires: GConf2-devel >= 1.2.1}
71 BuildRequires:  alsa-lib-devel
72 BuildRequires:  automake
73 BuildRequires:  bzip2-devel
74 BuildRequires:  cairo-devel >= 1.10
75 BuildRequires:  dbus-glib-devel >= 0.60
76 BuildRequires:  freetype-devel >= 1:2.1.8
77 %{?with_gnomevfs:BuildRequires: gnome-vfs2-devel >= 2.0}
78 BuildRequires:  gtk+2-devel >= 2:2.10.0
79 BuildRequires:  hunspell-devel
80 BuildRequires:  libIDL-devel >= 0.8.0
81 %{?with_gnomevfs:BuildRequires: libgnome-devel >= 2.0}
82 %{?with_gnomeui:BuildRequires:  libgnome-keyring-devel}
83 %{?with_gnomeui:BuildRequires:  libgnomeui-devel >= 2.2.0}
84 BuildRequires:  libiw-devel
85 BuildRequires:  libjpeg-devel >= 6b
86 BuildRequires:  libnotify-devel >= 0.4
87 BuildRequires:  libpng-devel >= 1.4.1
88 BuildRequires:  libstdc++-devel
89 BuildRequires:  nspr-devel >= 1:%{nspr_ver}
90 BuildRequires:  nss-devel >= 1:%{nss_ver}
91 BuildRequires:  pango-devel >= 1:1.1.0
92 BuildRequires:  perl-base >= 1:5.6
93 BuildRequires:  pkgconfig
94 BuildRequires:  python >= 1:2.5
95 BuildRequires:  sed >= 4.0
96 BuildRequires:  sqlite3-devel >= 3.7.4
97 BuildRequires:  startup-notification-devel >= 0.8
98 BuildRequires:  xorg-lib-libXext-devel
99 BuildRequires:  xorg-lib-libXinerama-devel
100 BuildRequires:  xorg-lib-libXt-devel
101 BuildRequires:  yasm
102 BuildRequires:  zip
103 %if %{with xulrunner}
104 BuildRequires:  xulrunner-devel >= 2:%{xulrunner_ver}
105 %else
106 Requires:       myspell-common
107 Requires:       nspr >= 1:%{nspr_ver}
108 Requires:       nss >= 1:%{nss_ver}
109 Requires:       sqlite3 >= %{sqlite_build_version}
110 %endif
111 Requires(post): mktemp >= 1.5-18
112 %if %{with xulrunner}
113 %requires_eq_to xulrunner xulrunner-devel
114 %endif
115 Obsoletes:      mozilla-thunderbird
116 Obsoletes:      mozilla-thunderbird-dictionary-en-US
117 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
118
119 %define         filterout_cpp           -D_FORTIFY_SOURCE=[0-9]+
120
121 # iceweasel/icedove/iceape provide their own versions
122 %define         _noautoreqdep           libgfxpsshar.so libgkgfx.so libgtkxtbin.so libjsj.so libxpcom_compat.so libxpistub.so
123 %define         _noautoprovfiles        %{_libdir}/%{name}/components
124 # we don't want these to satisfy xulrunner-devel
125 %define         _noautoprov             libgtkembedmoz.so libmozjs.so libxpcom.so libxul.so libxpcom_core.so
126 # and as we don't provide them, don't require either
127 %define         _noautoreq              libgtkembedmoz.so libmozjs.so libxpcom.so libxul.so libxpcom_core.so
128
129 %define         topdir          %{_builddir}/%{name}-%{version}
130 %define         objdir          %{topdir}/obj-%{_target_cpu}
131
132 %description
133 Icedove is an open-source, fast and portable email client.
134
135 %description -l pl.UTF-8
136 Icedove jest mającym otwarte źródła, szybkim i przenośnym klientem
137 poczty.
138
139 %package addon-lightning
140 Summary:        An integrated calendar for Icedove
141 Summary(pl.UTF-8):      Zintegrowany kalendarz dla Icedove
142 License:        MPL 1.1 or GPL v2+ or LGPL v2.1+
143 Group:          Applications/Networking
144 Requires:       %{name} = %{version}-%{release}
145
146 %description addon-lightning
147 Lightning is an calendar extension to Icedove email client.
148
149 %description addon-lightning -l pl.UTF-8
150 Lightning to rozszerzenie do klienta poczty Icedove dodające
151 funkcjonalność kalendarza.
152
153 %package addon-enigmail
154 Summary:        Extension for the authentication and encryption features provided by GnuPG
155 Summary(pl.UTF-8):      Rozszerzenie do uwierzytelniania i szyfrowania zapewnianego przez GnuPG
156 License:        MPL/LGPL
157 Group:          Applications/Networking
158 URL:            http://enigmail.mozdev.org/
159 Requires:       %{name} = %{version}-%{release}
160 Requires:       gnupg
161 Obsoletes:      mozilla-thunderbird-addon-enigmail
162
163 %description addon-enigmail
164 Enigmail is an extension to the Icedove mail client which allows users
165 to access the authentication and encryption features provided by
166 GnuPG.
167
168 Main Features:
169 - Encrypt/sign mail when sending, decrypt/authenticate received mail
170 - Support for inline-PGP (RFC 2440) and PGP/MIME (RFC 3156)
171 - Per-Account based encryption and signing defaults
172 - Per-Recipient rules for automated key selection, and
173   enabling/disabling encryption and signing
174 - OpenPGP key management interface
175
176 %description addon-enigmail -l pl.UTF-8
177 Enigmail to rozszerzenie klienta pocztowego Icedove pozwalające
178 użytkownikom na dostęp do uwierzytelniania i szyfrowania zapewnianego
179 przez GnuPG.
180
181 Główne możliwości:
182 - szyfrowanie/podpisywanie poczty przy wysyłaniu,
183   odszyfrowywanie/uwierzytelnianie poczty odebranej
184 - obsługa inline-PGP (RFC 2440) i PGP/MIME (RFC 3156)
185 - ustawienia domyślne szyfrowania i podpisywania dla każdego konta
186 - reguły automatycznego wyboru kluczy i włączenia szyfrowania oraz
187   podpisywania dla każdego adresata
188 - interfejs do zarządzania kluczami OpenPGP
189
190 %prep
191 %setup -qc
192 mv comm-release mozilla
193 %setup -q -T -D -a2
194 cd mozilla
195 %{?with_enigmail:%{__gzip} -dc %{SOURCE1} | %{__tar} -xf - -C mailnews/extensions}
196 /bin/sh %{SOURCE3}
197 %patch0 -p1
198 %{?with_enigmail:%patch1 -p1}
199 %patch2 -p1
200 %patch3 -p1
201 %patch4 -p1
202 %patch6 -p1
203 %patch7 -p1
204 %patch8 -p2
205 %patch10 -p2
206 %patch11 -p2
207 %patch12 -p1
208
209 %build
210 cd mozilla
211 cp -f %{_datadir}/automake/config.* mozilla/build/autoconf
212 cp -f %{_datadir}/automake/config.* mozilla/nsprpub/build/autoconf
213 cp -f %{_datadir}/automake/config.* ldap/sdks/c-sdk/config/autoconf
214
215 install -d libxul-sdk
216 ln -snf %{_libdir}/xulrunner-sdk libxul-sdk/sdk
217
218 cat << EOF > .mozconfig
219 mk_add_options MOZ_OBJDIR=%{objdir}
220
221 export CFLAGS="%{rpmcflags} -fpermissive -I/usr/include/xulrunner"
222 export CXXFLAGS="%{rpmcflags} -fpermissive -I/usr/include/xulrunner"
223
224 %if %{with crashreporter}
225 export MOZ_DEBUG_SYMBOLS=1
226 %endif
227
228 # Options for 'configure' (same as command-line options).
229 ac_add_options --prefix=%{_prefix}
230 ac_add_options --exec-prefix=%{_exec_prefix}
231 ac_add_options --bindir=%{_bindir}
232 ac_add_options --sbindir=%{_sbindir}
233 ac_add_options --sysconfdir=%{_sysconfdir}
234 ac_add_options --datadir=%{_datadir}
235 ac_add_options --includedir=%{_includedir}
236 ac_add_options --libdir=%{_libdir}
237 ac_add_options --libexecdir=%{_libexecdir}
238 ac_add_options --localstatedir=%{_localstatedir}
239 ac_add_options --sharedstatedir=%{_sharedstatedir}
240 ac_add_options --mandir=%{_mandir}
241 ac_add_options --infodir=%{_infodir}
242 %if %{?debug:1}0
243 ac_add_options --disable-optimize
244 ac_add_options --enable-debug
245 ac_add_options --enable-debug-modules
246 ac_add_options --enable-debugger-info-modules
247 ac_add_options --enable-crash-on-assert
248 %else
249 ac_add_options --disable-debug
250 ac_add_options --disable-debug-modules
251 ac_add_options --disable-logging
252 ac_add_options --enable-optimize="%{rpmcflags} -Os"
253 %endif
254 ac_add_options --disable-strip
255 ac_add_options --disable-strip-libs
256 %if %{with tests}
257 ac_add_options --enable-tests
258 %else
259 ac_add_options --disable-tests
260 %endif
261 %if %{with gnomeui}
262 ac_add_options --enable-gnomeui
263 %else
264 ac_add_options --disable-gnomeui
265 %endif
266 %if %{with gnomevfs}
267 ac_add_options --enable-gnomevfs
268 %else
269 ac_add_options --disable-gnomevfs
270 %endif
271 %if %{with ldap}
272 ac_add_options --enable-ldap
273 ac_add_options --with-system-ldap
274 %else
275 ac_add_options --disable-ldap
276 %endif
277 %if %{with crashreporter}
278 ac_add_options --enable-crashreporter
279 %else
280 ac_add_options --disable-crashreporter
281 %endif
282 ac_add_options --disable-xterm-updates
283 ac_add_options --enable-postscript
284 %if %{with lightning}
285 ac_add_options --enable-calendar
286 %else
287 ac_add_options --disable-calendar
288 %endif
289 ac_add_options --disable-installer
290 ac_add_options --disable-jsd
291 ac_add_options --disable-updater
292 ac_add_options --disable-xprint
293 ac_add_options --disable-permissions
294 ac_add_options --disable-pref-extensions
295 ac_add_options --enable-canvas
296 ac_add_options --enable-crypto
297 ac_add_options --enable-mathml
298 ac_add_options --enable-pango
299 ac_add_options --enable-reorder
300 ac_add_options --enable-startup-notification
301 ac_add_options --enable-svg
302 ac_add_options --enable-system-cairo
303 ac_add_options --enable-system-hunspell
304 ac_add_options --enable-system-sqlite
305 ac_add_options --enable-xft
306 ac_add_options --enable-application=mail
307 ac_add_options --enable-default-toolkit=cairo-gtk2
308 ac_add_options --enable-xinerama
309 ac_add_options --with-distribution-id=org.pld-linux
310 ac_add_options --with-branding=icedove/branding
311 %if %{with xulrunner}
312 #ac_add_options --with-libxul-sdk=$(pwd)/libxul-sdk/sdk
313 ac_add_options --with-system-libxul
314 ac_add_options --enable-shared
315 ac_add_options --enable-libxul
316 %else
317 ac_add_options --disable-xul
318 %endif
319 ac_add_options --with-pthreads
320 ac_add_options --with-system-bz2
321 ac_add_options --with-system-jpeg
322 ac_add_options --with-system-nspr
323 ac_add_options --with-system-nss
324 ac_add_options --with-system-png
325 ac_add_options --with-system-zlib
326 ac_add_options --enable-single-profile
327 ac_add_options --disable-profilesharing
328 ac_add_options --with-default-mozilla-five-home=%{_libdir}/%{name}
329 EOF
330
331 %{__make} -j1 -f client.mk build \
332         STRIP="/bin/true" \
333         MOZ_MAKE_FLAGS="%{?_smp_mflags}" \
334         CC="%{__cc}" \
335         CXX="%{__cxx}"
336
337 %if %{with crashreporter}
338 # create debuginfo for crash-stats.mozilla.com
339 %{__make} -j1 -C obj-%{_target_cpu} buildsymbols
340 %endif
341
342 %if %{with enigmail}
343 cd mailnews/extensions/enigmail
344 ./makemake -r -o %{objdir}
345 %{__make} -C %{objdir}/mailnews/extensions/enigmail \
346         STRIP="/bin/true" \
347         CC="%{__cc}" \
348         CXX="%{__cxx}"
349 %endif
350
351 %install
352 rm -rf $RPM_BUILD_ROOT
353 install -d $RPM_BUILD_ROOT{%{_bindir},%{_libdir}/%{name},%{_datadir}/%{name},%{_pixmapsdir},%{_desktopdir}}
354
355 cd %{objdir}
356 %{__make} -C mail/installer stage-package \
357         DESTDIR=$RPM_BUILD_ROOT \
358         MOZ_PKG_DIR=%{_libdir}/%{name} \
359         PKG_SKIP_STRIP=1
360
361 # Enable crash reporter for Firefox application
362 %if %{with crashreporter}
363 %{__sed} -i -e 's/\[Crash Reporter\]/[Crash Reporter]\nEnabled=1/' $RPM_BUILD_ROOT%{_libdir}/%{name}/application.ini
364
365 # Add debuginfo for crash-stats.mozilla.com
366 install -d $RPM_BUILD_ROOT%{_exec_prefix}/lib/debug%{_libdir}/%{name}
367 cp -a mozilla/dist/%{name}-%{version}.en-US.linux-*.crashreporter-symbols.zip $RPM_BUILD_ROOT%{_prefix}/lib/debug%{_libdir}/%{name}
368 %endif
369
370 # copy manually lightning files, somewhy they are not installed by make
371 cp -a mozilla/dist/bin/extensions/calendar-timezones@mozilla.org \
372         mozilla/dist/bin/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103} \
373         $RPM_BUILD_ROOT%{_libdir}/%{name}/extensions
374
375 # move arch independant ones to datadir
376 mv $RPM_BUILD_ROOT%{_libdir}/%{name}/chrome $RPM_BUILD_ROOT%{_datadir}/%{name}/chrome
377 mv $RPM_BUILD_ROOT%{_libdir}/%{name}/defaults $RPM_BUILD_ROOT%{_datadir}/%{name}/defaults
378 mv $RPM_BUILD_ROOT%{_libdir}/%{name}/isp $RPM_BUILD_ROOT%{_datadir}/%{name}/isp
379 mv $RPM_BUILD_ROOT%{_libdir}/%{name}/modules $RPM_BUILD_ROOT%{_datadir}/%{name}/modules
380 mv $RPM_BUILD_ROOT%{_libdir}/%{name}/res $RPM_BUILD_ROOT%{_datadir}/%{name}/res
381 ln -s ../../share/%{name}/chrome $RPM_BUILD_ROOT%{_libdir}/%{name}/chrome
382 ln -s ../../share/%{name}/defaults $RPM_BUILD_ROOT%{_libdir}/%{name}/defaults
383 ln -s ../../share/%{name}/isp $RPM_BUILD_ROOT%{_libdir}/%{name}/isp
384 ln -s ../../share/%{name}/modules $RPM_BUILD_ROOT%{_libdir}/%{name}/modules
385 ln -s ../../share/%{name}/res $RPM_BUILD_ROOT%{_libdir}/%{name}/res
386
387 # dir for arch independant extensions besides arch dependant extensions
388 # see mozilla/xpcom/build/nsXULAppAPI.h
389 # XRE_SYS_LOCAL_EXTENSION_PARENT_DIR and XRE_SYS_SHARE_EXTENSION_PARENT_DIR
390 install -d $RPM_BUILD_ROOT%{_datadir}/%{name}/extensions
391
392 %{__rm} -r $RPM_BUILD_ROOT%{_libdir}/%{name}/dictionaries
393 ln -s %{_datadir}/myspell $RPM_BUILD_ROOT%{_libdir}/%{name}/dictionaries
394
395 %{__sed} -e 's,@LIBDIR@,%{_libdir},' %{SOURCE5} > $RPM_BUILD_ROOT%{_bindir}/icedove
396 ln -s %{name} $RPM_BUILD_ROOT%{_bindir}/thunderbird
397 ln -s %{name} $RPM_BUILD_ROOT%{_bindir}/mozilla-thunderbird
398
399 cp -p %{SOURCE4} $RPM_BUILD_ROOT%{_desktopdir}/%{name}.desktop
400 cp -p %{topdir}/mozilla/icedove/branding/content/icon64.png $RPM_BUILD_ROOT%{_pixmapsdir}/%{name}.png
401
402 # files created by regxpcom -register in post
403 touch $RPM_BUILD_ROOT%{_libdir}/%{name}/components/compreg.dat
404 touch $RPM_BUILD_ROOT%{_libdir}/%{name}/components/xpti.dat
405 cat << 'EOF' > $RPM_BUILD_ROOT%{_libdir}/%{name}/register
406 #!/bin/sh
407 umask 022
408 # make temporary HOME, as it attempts to touch files in $HOME/.mozilla
409 # dangerous if you run this with sudo with keep_env += HOME
410 # also TMPDIR could be pointing to sudo user's homedir so we reset that too.
411 t=$(mktemp -d)
412 %{__rm} -f %{_libdir}/%{name}/components/{compreg,xpti}.dat
413 TMPDIR= TMP= HOME=$t %{_libdir}/%{name}/icedove -register
414 rm -rf $t
415 EOF
416 chmod a+rx $RPM_BUILD_ROOT%{_libdir}/%{name}/register
417
418 %if %{with enigmail}
419 ext_dir=$RPM_BUILD_ROOT%{_libdir}/%{name}/extensions/\{847b3a00-7ab1-11d4-8f02-006008948af5\}
420 install -d $ext_dir/{chrome,components,defaults/preferences}
421 cd mozilla/dist/bin
422 #cp -rfLp chrome/enigmail.jar $ext_dir/chrome
423 #cp -rfLp chrome/enigmime.jar $ext_dir/chrome
424 cp -rfLp components/enig* $ext_dir/components
425 cp -rfLp components/libenigmime.so $ext_dir/components
426 cp -rfLp components/libipc.so $ext_dir/components
427 cp -rfLp components/ipc.xpt $ext_dir/components
428 cp -rfLp defaults/preferences/enigmail.js $ext_dir/defaults/preferences
429 cd -
430 cp -p %{topdir}/mozilla/mailnews/extensions/enigmail/package/install.rdf $ext_dir
431 cp -p %{topdir}/mozilla/mailnews/extensions/enigmail/package/chrome.manifest $ext_dir/chrome.manifest
432 %endif
433
434 # remove unecessary stuff
435 #%%{__rm} $RPM_BUILD_ROOT%{_libdir}/%{name}/README.txt
436 #%%{__rm} $RPM_BUILD_ROOT%{_libdir}/%{name}/components/components.list
437 #%%{__rm} $RPM_BUILD_ROOT%{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/components/components.list
438
439 # never package these. always remove
440 # nss
441 %{__rm} -f $RPM_BUILD_ROOT%{_libdir}/%{name}/lib{freebl3,nss3,nssckbi,nssdbm3,nssutil3,smime3,softokn3,ssl3}.*
442 # nspr
443 %{__rm} -f $RPM_BUILD_ROOT%{_libdir}/%{name}/lib{nspr4,plc4,plds4}.so
444 # mozldap
445 %{__rm} -f $RPM_BUILD_ROOT%{_libdir}/%{name}/lib{ldap,ldif,prldap,ssldap}60.so
446
447 %clean
448 rm -rf $RPM_BUILD_ROOT
449
450 %pretrans
451 if [ -d %{_libdir}/%{name}/dictionaries ] && [ ! -L %{_libdir}/%{name}/dictionaries ]; then
452         mv -v %{_libdir}/%{name}/dictionaries{,.rpmsave}
453 fi
454 for d in chrome defaults icons isp modules res; do
455         if [ -d %{_libdir}/%{name}/$d ] && [ ! -L %{_libdir}/%{name}/$d ]; then
456                 install -d %{_datadir}/%{name}
457                 mv %{_libdir}/%{name}/$d %{_datadir}/%{name}/$d
458         fi
459 done
460 exit 0
461
462 %post
463 %{_libdir}/%{name}/register || :
464
465 %files
466 %defattr(644,root,root,755)
467 %attr(755,root,root) %{_bindir}/icedove
468 %attr(755,root,root) %{_bindir}/mozilla-thunderbird
469 %attr(755,root,root) %{_bindir}/thunderbird
470 %dir %{_libdir}/%{name}
471 %{_libdir}/%{name}/application.ini
472 %{_libdir}/%{name}/platform.ini
473 %{_libdir}/%{name}/blocklist.xml
474 %{_libdir}/%{name}/chrome.manifest
475 %{_libdir}/%{name}/greprefs.js
476 %dir %{_libdir}/%{name}/components
477 %attr(755,root,root) %{_libdir}/%{name}/components/*.so
478 %{_libdir}/%{name}/components/*.js
479 %{_libdir}/%{name}/components/*.xpt
480 %{_libdir}/%{name}/components/components.manifest
481 %{_libdir}/%{name}/components/interfaces.manifest
482 %attr(755,root,root) %{_libdir}/%{name}/libmozalloc.so
483 #%%attr(755,root,root) %{_libdir}/%{name}/libmozjs.so
484 %attr(755,root,root) %{_libdir}/%{name}/libxpcom.so
485 #%%attr(755,root,root) %{_libdir}/%{name}/libxpcom_core.so
486 %attr(755,root,root) %{_libdir}/%{name}/libxul.so
487 %attr(755,root,root) %{_libdir}/%{name}/*.sh
488 %attr(755,root,root) %{_libdir}/%{name}/*-bin
489 %attr(755,root,root) %{_libdir}/%{name}/mozilla-xremote-client
490 %attr(755,root,root) %{_libdir}/%{name}/icedove
491 %attr(755,root,root) %{_libdir}/%{name}/plugin-container
492 %attr(755,root,root) %{_libdir}/%{name}/register
493
494 # symlinks
495 %{_libdir}/%{name}/chrome
496 %{_libdir}/%{name}/defaults
497 %{_libdir}/%{name}/dictionaries
498 #%%{_libdir}/%{name}/greprefs
499 %{_libdir}/%{name}/isp
500 %{_libdir}/%{name}/modules
501 %{_libdir}/%{name}/res
502
503 %{_pixmapsdir}/*.png
504 %{_desktopdir}/*.desktop
505
506 %dir %{_datadir}/%{name}
507 %{_datadir}/%{name}/chrome
508 %{_datadir}/%{name}/defaults
509 #%%{_datadir}/%{name}/greprefs
510 %{_datadir}/%{name}/isp
511 %{_datadir}/%{name}/modules
512 %{_datadir}/%{name}/res
513 %{_datadir}/%{name}/extensions
514
515 %if %{with crashreporter}
516 %attr(755,root,root) %{_libdir}/%{name}/crashreporter
517 %{_libdir}/%{name}/crashreporter.ini
518 %{_libdir}/%{name}/Throbber-small.gif
519 %endif
520
521 %dir %{_libdir}/%{name}/extensions
522 %{_libdir}/%{name}/extensions/{972ce4c6-7e08-4474-a285-3208198ce6fd}
523
524 # files created by regxpcom -register
525 %ghost %{_libdir}/%{name}/components/compreg.dat
526 %ghost %{_libdir}/%{name}/components/xpti.dat
527
528 %if %{with lightning}
529 %files addon-lightning
530 %defattr(644,root,root,755)
531 %dir %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}
532 %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/application.ini
533 %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/chrome
534 %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/chrome.manifest
535 %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/defaults
536 %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/install.rdf
537 %dir %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/components
538 %attr(755,root,root) %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/components/*.so
539 %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/components/*.js
540 %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/components/*.manifest
541 %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/components/*.xpt
542 %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/modules
543 %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/calendar-js
544 %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/timezones.sqlite
545 %{_libdir}/%{name}/extensions/calendar-timezones@mozilla.org
546 %endif
547
548 %if %{with enigmail}
549 %files addon-enigmail
550 %defattr(644,root,root,755)
551 %dir %{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}
552 %{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/defaults
553 %{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/chrome
554 %{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/chrome.manifest
555 %{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/install.rdf
556 %dir %{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/components
557 %attr(755,root,root) %{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/components/*.so
558 %{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/components/*.xpt
559 %{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/components/*.js
560 %endif
This page took 0.201528 seconds and 4 git commands to generate.