]> git.pld-linux.org Git - packages/thunderbird.git/blob - icedove.spec
- package more files
[packages/thunderbird.git] / icedove.spec
1 # TODO:
2 # - separate spec for enigmail
3 # - build with system mozldap
4 # - replace gnome-vfs2 with gio
5 # - files:
6 #   /usr/lib/icedove/blocklist.xml
7 #   /usr/lib/icedove/chrome.manifest
8 #   /usr/lib/icedove/components/components.manifest
9 #   /usr/lib/icedove/components/interfaces.manifest
10 #   /usr/lib/icedove/greprefs.js
11 #   /usr/lib/icedove/hyphenation/hyph_en_US.dic
12 #
13 # Conditional builds
14 %bcond_without  enigmail        # don't build enigmail - GPG/PGP support
15 %bcond_without  gnomeui         # disable gnomeui support
16 %bcond_without  gnomevfs        # disable GNOME comp. (gconf+libgnome+gnomevfs) and gnomevfs ext.
17 %bcond_without  gnome           # disable all GNOME components (gnome+gnomeui+gnomevfs)
18 %bcond_without  ldap            # disable e-mail address lookups in LDAP directories
19 %bcond_without  lightning       # disable Sunbird/Lightning calendar
20 %bcond_without  xulrunner       # build with xulrunner
21 %bcond_with     crashreporter   # report crashes to crash-stats.mozilla.com
22
23 %if %{without gnome}
24 %undefine       with_gnomeui
25 %undefine       with_gnomevfs
26 %endif
27
28 %if 0%{?_enable_debug_packages} != 1
29 %undefine       crashreporter
30 %endif
31
32 %define         enigmail_ver    1.3.2
33 %define         nspr_ver        4.8.8
34 %define         nss_ver         3.12.10
35
36 # convert firefox release number to platform version: 7.0.x -> 7.0.x
37 %define         xulrunner_main  7.0
38 %define         xulrunner_ver   %(v=%{version}; echo %{xulrunner_main}${v#7.0})
39
40 %if %{without xulrunner}
41 # The actual sqlite version (see RHBZ#480989):
42 %define         sqlite_build_version %(pkg-config --silence-errors --modversion sqlite3 2>/dev/null || echo ERROR)
43 %endif
44
45 Summary:        Icedove - email client
46 Summary(pl.UTF-8):      Icedove - klient poczty
47 Name:           icedove
48 Version:        7.0.1
49 Release:        0.1
50 License:        MPL 1.1 or GPL v2+ or LGPL v2.1+
51 Group:          X11/Applications/Networking
52 Source0:        http://releases.mozilla.org/pub/mozilla.org/thunderbird/releases/%{version}/source/thunderbird-%{version}.source.tar.bz2
53 # Source0-md5:  ad177fe5202deabda44882ff5c871f1b
54 Source1:        http://www.mozilla-enigmail.org/download/source/enigmail-%{enigmail_ver}.tar.gz
55 # Source1-md5:  2318d60320dc6c3db3c34d968bb7d533
56 Source2:        %{name}-branding.tar.bz2
57 # Source2-md5:  2da351522bdd7f4a3bd8aaff4c776976
58 Source3:        %{name}-rm_nonfree.sh
59 Source4:        %{name}.desktop
60 Source5:        %{name}.sh
61 Patch0:         %{name}-branding.patch
62 Patch1:         %{name}-enigmail-shared.patch
63 Patch2:         %{name}-gcc.patch
64 Patch3:         %{name}-fonts.patch
65 Patch4:         %{name}-install.patch
66 Patch5:         %{name}-hunspell.patch
67 Patch6:         %{name}-prefs.patch
68 Patch7:         system-mozldap.patch
69 Patch8:         %{name}-makefile.patch
70 Patch10:        %{name}-extensiondir.patch
71 Patch11:        crashreporter.patch
72 Patch12:        no-subshell.patch
73 URL:            http://www.pld-linux.org/Packages/Icedove
74 %{?with_gnomevfs:BuildRequires: GConf2-devel >= 1.2.1}
75 BuildRequires:  alsa-lib-devel
76 BuildRequires:  automake
77 BuildRequires:  bzip2-devel
78 BuildRequires:  cairo-devel >= 1.10
79 BuildRequires:  dbus-glib-devel >= 0.60
80 BuildRequires:  freetype-devel >= 1:2.1.8
81 %{?with_gnomevfs:BuildRequires: gnome-vfs2-devel >= 2.0}
82 BuildRequires:  gtk+2-devel >= 2:2.10.0
83 BuildRequires:  hunspell-devel
84 BuildRequires:  libIDL-devel >= 0.8.0
85 %{?with_gnomevfs:BuildRequires: libgnome-devel >= 2.0}
86 %{?with_gnomeui:BuildRequires:  libgnome-keyring-devel}
87 %{?with_gnomeui:BuildRequires:  libgnomeui-devel >= 2.2.0}
88 BuildRequires:  libiw-devel
89 BuildRequires:  libjpeg-devel >= 6b
90 BuildRequires:  libnotify-devel >= 0.4
91 BuildRequires:  libpng-devel >= 1.4.1
92 BuildRequires:  libstdc++-devel
93 BuildRequires:  nspr-devel >= 1:%{nspr_ver}
94 BuildRequires:  nss-devel >= 1:%{nss_ver}
95 BuildRequires:  pango-devel >= 1:1.1.0
96 BuildRequires:  perl-base >= 1:5.6
97 BuildRequires:  pkgconfig
98 BuildRequires:  python >= 1:2.5
99 BuildRequires:  sed >= 4.0
100 BuildRequires:  sqlite3-devel >= 3.7.4
101 BuildRequires:  startup-notification-devel >= 0.8
102 BuildRequires:  xorg-lib-libXext-devel
103 BuildRequires:  xorg-lib-libXinerama-devel
104 BuildRequires:  xorg-lib-libXt-devel
105 BuildRequires:  yasm
106 BuildRequires:  zip
107 %if %{with xulrunner}
108 BuildRequires:  xulrunner-devel >= 2:%{xulrunner_ver}
109 %else
110 Requires:       myspell-common
111 Requires:       nspr >= 1:%{nspr_ver}
112 Requires:       nss >= 1:%{nss_ver}
113 Requires:       sqlite3 >= %{sqlite_build_version}
114 %endif
115 Requires(post): mktemp >= 1.5-18
116 %if %{with xulrunner}
117 %requires_eq_to xulrunner xulrunner-devel
118 %endif
119 Obsoletes:      mozilla-thunderbird
120 Obsoletes:      mozilla-thunderbird-dictionary-en-US
121 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
122
123 %define         filterout_cpp           -D_FORTIFY_SOURCE=[0-9]+
124
125 # iceweasel/icedove/iceape provide their own versions
126 %define         _noautoreqdep           libgfxpsshar.so libgkgfx.so libgtkxtbin.so libjsj.so libxpcom_compat.so libxpistub.so
127 %define         _noautoprovfiles        %{_libdir}/%{name}/components
128 # we don't want these to satisfy xulrunner-devel
129 %define         _noautoprov             libgtkembedmoz.so libmozjs.so libxpcom.so libxul.so libxpcom_core.so
130 # and as we don't provide them, don't require either
131 %define         _noautoreq              libgtkembedmoz.so libmozjs.so libxpcom.so libxul.so libxpcom_core.so
132
133 %define         topdir          %{_builddir}/%{name}-%{version}
134 %define         objdir          %{topdir}/obj-%{_target_cpu}
135
136 %description
137 Icedove is an open-source,fast and portable email client.
138
139 %description -l pl.UTF-8
140 Icedove jest open sourcowym, szybkim i przenośnym klientem poczty.
141
142 %package addon-lightning
143 Summary:        An integrated calendar for Icedove
144 Summary(pl.UTF-8):      Zintegrowany kalendarz dla Icedove
145 License:        MPL 1.1 or GPL v2+ or LGPL v2.1+
146 Group:          Applications/Networking
147 Requires:       %{name} = %{version}-%{release}
148
149 %description addon-lightning
150 Lightning is an calendar extension to Icedove email client.
151
152 %description addon-lightning -l pl.UTF-8
153 Lightning to rozszerzenie do klienta poczty Icedove dodające
154 funkcjonalność kalendarza.
155
156 %package addon-enigmail
157 Summary:        Extension for the authentication and encryption features provided by GnuPG
158 Summary(pl.UTF-8):      Rozszerzenie do uwierzytelniania i szyfrowania zapewnianego przez GnuPG
159 License:        MPL/LGPL
160 Group:          Applications/Networking
161 URL:            http://enigmail.mozdev.org/
162 Requires:       %{name} = %{version}-%{release}
163 Requires:       gnupg
164 Obsoletes:      mozilla-thunderbird-addon-enigmail
165
166 %description addon-enigmail
167 Enigmail is an extension to the Icedove mail client which allows users
168 to access the authentication and encryption features provided by
169 GnuPG.
170
171 Main Features:
172 - Encrypt/sign mail when sending, decrypt/authenticate received mail
173 - Support for inline-PGP (RFC 2440) and PGP/MIME (RFC 3156)
174 - Per-Account based encryption and signing defaults
175 - Per-Recipient rules for automated key selection, and
176   enabling/disabling encryption and signing
177 - OpenPGP key management interface
178
179 %description addon-enigmail -l pl.UTF-8
180 Enigmail to rozszerzenie klienta pocztowego Icedove pozwalające
181 użytkownikom na dostęp do uwierzytelniania i szyfrowania zapewnianego
182 przez GnuPG.
183
184 Główne możliwości:
185 - szyfrowanie/podpisywanie poczty przy wysyłaniu,
186   odszyfrowywanie/uwierzytelnianie poczty odebranej
187 - obsługa inline-PGP (RFC 2440) i PGP/MIME (RFC 3156)
188 - ustawienia domyślne szyfrowania i podpisywania dla każdego konta
189 - reguły automatycznego wyboru kluczy i włączenia szyfrowania oraz
190   podpisywania dla każdego adresata
191 - interfejs do zarządzania kluczami OpenPGP
192
193 %prep
194 %setup -qc
195 mv comm-release mozilla
196 %setup -q -T -D -a2
197 cd mozilla
198 %{?with_enigmail:%{__gzip} -dc %{SOURCE1} | %{__tar} -xf - -C mailnews/extensions}
199 /bin/sh %{SOURCE3}
200 %patch0 -p1
201 %{?with_enigmail:%patch1 -p1}
202 %patch2 -p1
203 %patch3 -p1
204 %patch4 -p1
205 %patch6 -p1
206 %patch7 -p1
207 %patch8 -p2
208 %patch10 -p2
209 %patch11 -p2
210 %patch12 -p1
211
212 %build
213 cd mozilla
214 cp -f %{_datadir}/automake/config.* mozilla/build/autoconf
215 cp -f %{_datadir}/automake/config.* mozilla/nsprpub/build/autoconf
216 cp -f %{_datadir}/automake/config.* ldap/sdks/c-sdk/config/autoconf
217
218 install -d libxul-sdk
219 ln -snf %{_libdir}/xulrunner-sdk libxul-sdk/sdk
220
221 cat << EOF > .mozconfig
222 mk_add_options MOZ_OBJDIR=%{objdir}
223
224 export CFLAGS="%{rpmcflags} -fpermissive -I/usr/include/xulrunner"
225 export CXXFLAGS="%{rpmcflags} -fpermissive -I/usr/include/xulrunner"
226
227 %if %{with crashreporter}
228 export MOZ_DEBUG_SYMBOLS=1
229 %endif
230
231 # Options for 'configure' (same as command-line options).
232 ac_add_options --prefix=%{_prefix}
233 ac_add_options --exec-prefix=%{_exec_prefix}
234 ac_add_options --bindir=%{_bindir}
235 ac_add_options --sbindir=%{_sbindir}
236 ac_add_options --sysconfdir=%{_sysconfdir}
237 ac_add_options --datadir=%{_datadir}
238 ac_add_options --includedir=%{_includedir}
239 ac_add_options --libdir=%{_libdir}
240 ac_add_options --libexecdir=%{_libexecdir}
241 ac_add_options --localstatedir=%{_localstatedir}
242 ac_add_options --sharedstatedir=%{_sharedstatedir}
243 ac_add_options --mandir=%{_mandir}
244 ac_add_options --infodir=%{_infodir}
245 %if %{?debug:1}0
246 ac_add_options --disable-optimize
247 ac_add_options --enable-debug
248 ac_add_options --enable-debug-modules
249 ac_add_options --enable-debugger-info-modules
250 ac_add_options --enable-crash-on-assert
251 %else
252 ac_add_options --disable-debug
253 ac_add_options --disable-debug-modules
254 ac_add_options --disable-logging
255 ac_add_options --enable-optimize="%{rpmcflags} -Os"
256 %endif
257 ac_add_options --disable-strip
258 ac_add_options --disable-strip-libs
259 %if %{with tests}
260 ac_add_options --enable-tests
261 %else
262 ac_add_options --disable-tests
263 %endif
264 %if %{with gnomeui}
265 ac_add_options --enable-gnomeui
266 %else
267 ac_add_options --disable-gnomeui
268 %endif
269 %if %{with gnomevfs}
270 ac_add_options --enable-gnomevfs
271 %else
272 ac_add_options --disable-gnomevfs
273 %endif
274 %if %{with ldap}
275 ac_add_options --enable-ldap
276 ac_add_options --with-system-ldap
277 %else
278 ac_add_options --disable-ldap
279 %endif
280 %if %{with crashreporter}
281 ac_add_options --enable-crashreporter
282 %else
283 ac_add_options --disable-crashreporter
284 %endif
285 ac_add_options --disable-xterm-updates
286 ac_add_options --enable-postscript
287 %if %{with lightning}
288 ac_add_options --enable-calendar
289 %else
290 ac_add_options --disable-calendar
291 %endif
292 ac_add_options --disable-installer
293 ac_add_options --disable-jsd
294 ac_add_options --disable-updater
295 ac_add_options --disable-xprint
296 ac_add_options --disable-permissions
297 ac_add_options --disable-pref-extensions
298 ac_add_options --enable-canvas
299 ac_add_options --enable-crypto
300 ac_add_options --enable-mathml
301 ac_add_options --enable-pango
302 ac_add_options --enable-reorder
303 ac_add_options --enable-startup-notification
304 ac_add_options --enable-svg
305 ac_add_options --enable-system-cairo
306 ac_add_options --enable-system-hunspell
307 ac_add_options --enable-system-sqlite
308 ac_add_options --enable-xft
309 ac_add_options --enable-application=mail
310 ac_add_options --enable-default-toolkit=cairo-gtk2
311 ac_add_options --enable-xinerama
312 ac_add_options --with-distribution-id=org.pld-linux
313 ac_add_options --with-branding=icedove/branding
314 %if %{with xulrunner}
315 #ac_add_options --with-libxul-sdk=$(pwd)/libxul-sdk/sdk
316 ac_add_options --with-system-libxul
317 ac_add_options --enable-shared
318 ac_add_options --enable-libxul
319 %else
320 ac_add_options --disable-xul
321 %endif
322 ac_add_options --with-pthreads
323 ac_add_options --with-system-bz2
324 ac_add_options --with-system-jpeg
325 ac_add_options --with-system-nspr
326 ac_add_options --with-system-nss
327 ac_add_options --with-system-png
328 ac_add_options --with-system-zlib
329 ac_add_options --enable-single-profile
330 ac_add_options --disable-profilesharing
331 ac_add_options --with-default-mozilla-five-home=%{_libdir}/%{name}
332 EOF
333
334 %{__make} -j1 -f client.mk build \
335         STRIP="/bin/true" \
336         MOZ_MAKE_FLAGS="%{?_smp_mflags}" \
337         CC="%{__cc}" \
338         CXX="%{__cxx}"
339
340 %if %{with crashreporter}
341 # create debuginfo for crash-stats.mozilla.com
342 %{__make} -j1 -C obj-%{_target_cpu} buildsymbols
343 %endif
344
345 %if %{with enigmail}
346 cd mailnews/extensions/enigmail
347 ./makemake -r -o %{objdir}
348 %{__make} -C %{objdir}/mailnews/extensions/enigmail \
349         STRIP="/bin/true" \
350         CC="%{__cc}" \
351         CXX="%{__cxx}"
352 %endif
353
354 %install
355 rm -rf $RPM_BUILD_ROOT
356 install -d $RPM_BUILD_ROOT{%{_bindir},%{_libdir}/%{name},%{_datadir}/%{name},%{_pixmapsdir},%{_desktopdir}}
357
358 cd %{objdir}
359 %{__make} -C mail/installer stage-package \
360         DESTDIR=$RPM_BUILD_ROOT \
361         MOZ_PKG_DIR=%{_libdir}/%{name} \
362         PKG_SKIP_STRIP=1
363
364 # Enable crash reporter for Firefox application
365 %if %{with crashreporter}
366 %{__sed} -i -e 's/\[Crash Reporter\]/[Crash Reporter]\nEnabled=1/' $RPM_BUILD_ROOT%{_libdir}/%{name}/application.ini
367
368 # Add debuginfo for crash-stats.mozilla.com
369 install -d $RPM_BUILD_ROOT%{_exec_prefix}/lib/debug%{_libdir}/%{name}
370 cp -a mozilla/dist/%{name}-%{version}.en-US.linux-*.crashreporter-symbols.zip $RPM_BUILD_ROOT%{_prefix}/lib/debug%{_libdir}/%{name}
371 %endif
372
373 # copy manually lightning files, somewhy they are not installed by make
374 cp -a mozilla/dist/bin/extensions/calendar-timezones@mozilla.org \
375         mozilla/dist/bin/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103} \
376         $RPM_BUILD_ROOT%{_libdir}/%{name}/extensions
377
378 # move arch independant ones to datadir
379 mv $RPM_BUILD_ROOT%{_libdir}/%{name}/chrome $RPM_BUILD_ROOT%{_datadir}/%{name}/chrome
380 mv $RPM_BUILD_ROOT%{_libdir}/%{name}/defaults $RPM_BUILD_ROOT%{_datadir}/%{name}/defaults
381 #mv $RPM_BUILD_ROOT%{_libdir}/%{name}/greprefs $RPM_BUILD_ROOT%{_datadir}/%{name}/greprefs
382 mv $RPM_BUILD_ROOT%{_libdir}/%{name}/isp $RPM_BUILD_ROOT%{_datadir}/%{name}/isp
383 mv $RPM_BUILD_ROOT%{_libdir}/%{name}/modules $RPM_BUILD_ROOT%{_datadir}/%{name}/modules
384 mv $RPM_BUILD_ROOT%{_libdir}/%{name}/res $RPM_BUILD_ROOT%{_datadir}/%{name}/res
385 ln -s ../../share/%{name}/chrome $RPM_BUILD_ROOT%{_libdir}/%{name}/chrome
386 ln -s ../../share/%{name}/defaults $RPM_BUILD_ROOT%{_libdir}/%{name}/defaults
387 #ln -s ../../share/%{name}/greprefs $RPM_BUILD_ROOT%{_libdir}/%{name}/greprefs
388 ln -s ../../share/%{name}/isp $RPM_BUILD_ROOT%{_libdir}/%{name}/isp
389 ln -s ../../share/%{name}/modules $RPM_BUILD_ROOT%{_libdir}/%{name}/modules
390 ln -s ../../share/%{name}/res $RPM_BUILD_ROOT%{_libdir}/%{name}/res
391
392 # dir for arch independant extensions besides arch dependant extensions
393 # see mozilla/xpcom/build/nsXULAppAPI.h
394 # XRE_SYS_LOCAL_EXTENSION_PARENT_DIR and XRE_SYS_SHARE_EXTENSION_PARENT_DIR
395 install -d $RPM_BUILD_ROOT%{_datadir}/%{name}/extensions
396
397 %{__rm} -r $RPM_BUILD_ROOT%{_libdir}/%{name}/dictionaries
398 ln -s %{_datadir}/myspell $RPM_BUILD_ROOT%{_libdir}/%{name}/dictionaries
399
400 %{__sed} -e 's,@LIBDIR@,%{_libdir},' %{SOURCE5} > $RPM_BUILD_ROOT%{_bindir}/icedove
401 ln -s %{name} $RPM_BUILD_ROOT%{_bindir}/thunderbird
402 ln -s %{name} $RPM_BUILD_ROOT%{_bindir}/mozilla-thunderbird
403
404 cp -p %{SOURCE4} $RPM_BUILD_ROOT%{_desktopdir}/%{name}.desktop
405 cp -p %{topdir}/mozilla/icedove/branding/content/icon64.png $RPM_BUILD_ROOT%{_pixmapsdir}/%{name}.png
406
407 # files created by regxpcom -register in post
408 touch $RPM_BUILD_ROOT%{_libdir}/%{name}/components/compreg.dat
409 touch $RPM_BUILD_ROOT%{_libdir}/%{name}/components/xpti.dat
410 cat << 'EOF' > $RPM_BUILD_ROOT%{_libdir}/%{name}/register
411 #!/bin/sh
412 umask 022
413 # make temporary HOME, as it attempts to touch files in $HOME/.mozilla
414 # dangerous if you run this with sudo with keep_env += HOME
415 # also TMPDIR could be pointing to sudo user's homedir so we reset that too.
416 t=$(mktemp -d)
417 %{__rm} -f %{_libdir}/%{name}/components/{compreg,xpti}.dat
418 TMPDIR= TMP= HOME=$t %{_libdir}/%{name}/icedove -register
419 rm -rf $t
420 EOF
421 chmod a+rx $RPM_BUILD_ROOT%{_libdir}/%{name}/register
422
423 %if %{with enigmail}
424 ext_dir=$RPM_BUILD_ROOT%{_libdir}/%{name}/extensions/\{847b3a00-7ab1-11d4-8f02-006008948af5\}
425 install -d $ext_dir/{chrome,components,defaults/preferences}
426 cd mozilla/dist/bin
427 #cp -rfLp chrome/enigmail.jar $ext_dir/chrome
428 #cp -rfLp chrome/enigmime.jar $ext_dir/chrome
429 cp -rfLp components/enig* $ext_dir/components
430 cp -rfLp components/libenigmime.so $ext_dir/components
431 cp -rfLp components/libipc.so $ext_dir/components
432 cp -rfLp components/ipc.xpt $ext_dir/components
433 cp -rfLp defaults/preferences/enigmail.js $ext_dir/defaults/preferences
434 cd -
435 cp -p %{topdir}/mozilla/mailnews/extensions/enigmail/package/install.rdf $ext_dir
436 cp -p %{topdir}/mozilla/mailnews/extensions/enigmail/package/chrome.manifest $ext_dir/chrome.manifest
437 %endif
438
439 # remove unecessary stuff
440 %{__rm} $RPM_BUILD_ROOT%{_libdir}/%{name}/README.txt
441 #%%{__rm} $RPM_BUILD_ROOT%{_libdir}/%{name}/components/components.list
442 #%%{__rm} $RPM_BUILD_ROOT%{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/components/components.list
443
444 # never package these. always remove
445 # nss
446 %{__rm} -f $RPM_BUILD_ROOT%{_libdir}/%{name}/lib{freebl3,nss3,nssckbi,nssdbm3,nssutil3,smime3,softokn3,ssl3}.*
447 # nspr
448 %{__rm} -f $RPM_BUILD_ROOT%{_libdir}/%{name}/lib{nspr4,plc4,plds4}.so
449 # mozldap
450 %{__rm} -f $RPM_BUILD_ROOT%{_libdir}/%{name}/lib{ldap,ldif,prldap,ssldap}60.so
451
452 %clean
453 rm -rf $RPM_BUILD_ROOT
454
455 %pretrans
456 if [ -d %{_libdir}/%{name}/dictionaries ] && [ ! -L %{_libdir}/%{name}/dictionaries ]; then
457         mv -v %{_libdir}/%{name}/dictionaries{,.rpmsave}
458 fi
459 for d in chrome defaults greprefs icons isp modules res; do
460         if [ -d %{_libdir}/%{name}/$d ] && [ ! -L %{_libdir}/%{name}/$d ]; then
461                 install -d %{_datadir}/%{name}
462                 mv %{_libdir}/%{name}/$d %{_datadir}/%{name}/$d
463         fi
464 done
465 exit 0
466
467 %post
468 %{_libdir}/%{name}/register || :
469
470 %files
471 %defattr(644,root,root,755)
472 %attr(755,root,root) %{_bindir}/icedove
473 %attr(755,root,root) %{_bindir}/mozilla-thunderbird
474 %attr(755,root,root) %{_bindir}/thunderbird
475 %dir %{_libdir}/%{name}
476 %{_libdir}/%{name}/application.ini
477 %{_libdir}/%{name}/platform.ini
478 %dir %{_libdir}/%{name}/components
479 %attr(755,root,root) %{_libdir}/%{name}/components/*.so
480 %{_libdir}/%{name}/components/*.js
481 %{_libdir}/%{name}/components/*.xpt
482 %attr(755,root,root) %{_libdir}/%{name}/libmozalloc.so
483 #%%attr(755,root,root) %{_libdir}/%{name}/libmozjs.so
484 %attr(755,root,root) %{_libdir}/%{name}/libxpcom.so
485 #%%attr(755,root,root) %{_libdir}/%{name}/libxpcom_core.so
486 %attr(755,root,root) %{_libdir}/%{name}/libxul.so
487 %attr(755,root,root) %{_libdir}/%{name}/*.sh
488 %attr(755,root,root) %{_libdir}/%{name}/*-bin
489 %attr(755,root,root) %{_libdir}/%{name}/mozilla-xremote-client
490 %attr(755,root,root) %{_libdir}/%{name}/icedove
491 %attr(755,root,root) %{_libdir}/%{name}/plugin-container
492 %attr(755,root,root) %{_libdir}/%{name}/register
493
494 # symlinks
495 %{_libdir}/%{name}/chrome
496 %{_libdir}/%{name}/defaults
497 %{_libdir}/%{name}/dictionaries
498 #%%{_libdir}/%{name}/greprefs
499 %{_libdir}/%{name}/isp
500 %{_libdir}/%{name}/modules
501 %{_libdir}/%{name}/res
502
503 %{_pixmapsdir}/*.png
504 %{_desktopdir}/*.desktop
505
506 %dir %{_datadir}/%{name}
507 %{_datadir}/%{name}/chrome
508 %{_datadir}/%{name}/defaults
509 #%%{_datadir}/%{name}/greprefs
510 %{_datadir}/%{name}/isp
511 %{_datadir}/%{name}/modules
512 %{_datadir}/%{name}/res
513 %{_datadir}/%{name}/extensions
514
515 %if %{with crashreporter}
516 %attr(755,root,root) %{_libdir}/%{name}/crashreporter
517 %{_libdir}/%{name}/crashreporter.ini
518 %{_libdir}/%{name}/Throbber-small.gif
519 %endif
520
521 %dir %{_libdir}/%{name}/extensions
522 %{_libdir}/%{name}/extensions/{972ce4c6-7e08-4474-a285-3208198ce6fd}
523
524 # files created by regxpcom -register
525 %ghost %{_libdir}/%{name}/components/compreg.dat
526 %ghost %{_libdir}/%{name}/components/xpti.dat
527
528 %if %{with lightning}
529 %files addon-lightning
530 %defattr(644,root,root,755)
531 %dir %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}
532 %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/application.ini
533 %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/chrome
534 %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/chrome.manifest
535 %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/defaults
536 %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/install.rdf
537 %dir %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/components
538 %attr(755,root,root) %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/components/*.so
539 %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/components/*.js
540 %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/components/*.manifest
541 %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/components/*.xpt
542 %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/modules
543 %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/calendar-js
544 %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/timezones.sqlite
545 %{_libdir}/%{name}/extensions/calendar-timezones@mozilla.org
546 %endif
547
548 %if %{with enigmail}
549 %files addon-enigmail
550 %defattr(644,root,root,755)
551 %dir %{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}
552 %{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/defaults
553 %{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/chrome
554 %{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/chrome.manifest
555 %{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/install.rdf
556 %dir %{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/components
557 %attr(755,root,root) %{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/components/*.so
558 %{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/components/*.xpt
559 %{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/components/*.js
560 %endif
This page took 0.130135 seconds and 4 git commands to generate.