]> git.pld-linux.org Git - packages/thunderbird.git/blob - icedove.spec
- added sh patch (fixes argumentless for taking last positional args)
[packages/thunderbird.git] / icedove.spec
1 # TODO:
2 # - separate spec for enigmail
3 # - build with system mozldap
4 #
5 # Conditional builds
6 %bcond_without  enigmail        # don't build enigmail - GPG/PGP support
7 %bcond_without  ldap            # disable e-mail address lookups in LDAP directories
8 %bcond_without  lightning       # disable Sunbird/Lightning calendar
9 %bcond_with     xulrunner       # system xulrunner
10 %bcond_with     crashreporter   # report crashes to crash-stats.mozilla.com
11
12 %if 0%{?_enable_debug_packages} != 1
13 %undefine       crashreporter
14 %endif
15
16 %define         enigmail_ver    1.6
17 %define         nspr_ver        4.9.3
18 %define         nss_ver         3.15.3.1
19
20 %define         xulrunner_ver   2:24.0
21
22 %if %{without xulrunner}
23 # The actual sqlite version (see RHBZ#480989):
24 %define         sqlite_build_version %(pkg-config --silence-errors --modversion sqlite3 2>/dev/null || echo ERROR)
25 %endif
26
27 Summary:        Icedove - email client
28 Summary(pl.UTF-8):      Icedove - klient poczty
29 Name:           icedove
30 Version:        24.5.0
31 Release:        1
32 License:        MPL 1.1 or GPL v2+ or LGPL v2.1+
33 Group:          X11/Applications/Mail
34 Source0:        http://releases.mozilla.org/pub/mozilla.org/thunderbird/releases/%{version}/source/thunderbird-%{version}.source.tar.bz2
35 # Source0-md5:  dbe164c48e42c04b4959910eda2e52ca
36 Source1:        http://www.mozilla-enigmail.org/download/source/enigmail-%{enigmail_ver}.tar.gz
37 # Source1-md5:  4a2bbcb020bdb282a660fda8c70d5608
38 Source2:        %{name}-branding.tar.bz2
39 # Source2-md5:  d8e6897870bf288fdf264c0e9ef85f7d
40 Source3:        %{name}-rm_nonfree.sh
41 Source4:        %{name}.desktop
42 Source5:        %{name}.sh
43 Patch0:         %{name}-branding.patch
44 Patch1:         %{name}-enigmail-shared.patch
45 Patch2:         %{name}-sh.patch
46 Patch3:         %{name}-fonts.patch
47 Patch6:         %{name}-prefs.patch
48 Patch7:         system-mozldap.patch
49 Patch8:         %{name}-makefile.patch
50 Patch10:        %{name}-extensiondir.patch
51 Patch11:        crashreporter.patch
52 Patch12:        no-subshell.patch
53 # Edit patch below and restore --system-site-packages when system virtualenv gets 1.7 upgrade
54 Patch13:        system-virtualenv.patch
55 Patch14:        gyp-slashism.patch
56 Patch15:        enable-addons.patch
57 URL:            http://www.pld-linux.org/Packages/Icedove
58 BuildRequires:  GConf2-devel >= 1.2.1
59 BuildRequires:  alsa-lib-devel
60 BuildRequires:  automake
61 BuildRequires:  bzip2-devel
62 BuildRequires:  cairo-devel >= 1.10
63 BuildRequires:  dbus-glib-devel >= 0.60
64 BuildRequires:  freetype-devel >= 1:2.1.8
65 BuildRequires:  glib2-devel >= 2.0
66 BuildRequires:  gstreamer0.10-devel
67 BuildRequires:  gstreamer0.10-plugins-base-devel
68 BuildRequires:  gtk+2-devel >= 2:2.10.0
69 BuildRequires:  hunspell-devel
70 BuildRequires:  libIDL-devel >= 0.8.0
71 BuildRequires:  libevent-devel
72 BuildRequires:  libiw-devel
73 # requires libjpeg-turbo implementing at least libjpeg 6b API
74 BuildRequires:  libjpeg-devel >= 6b
75 BuildRequires:  libjpeg-turbo-devel
76 BuildRequires:  libnotify-devel >= 0.4
77 BuildRequires:  libpng-devel >= 1.4.1
78 BuildRequires:  libstdc++-devel
79 BuildRequires:  mozldap-devel
80 BuildRequires:  nspr-devel >= 1:%{nspr_ver}
81 BuildRequires:  nss-devel >= 1:%{nss_ver}
82 BuildRequires:  pango-devel >= 1:1.14.0
83 BuildRequires:  perl-base >= 1:5.6
84 BuildRequires:  python-virtualenv
85 BuildRequires:  pkgconfig
86 BuildRequires:  python >= 1:2.5
87 BuildRequires:  sed >= 4.0
88 BuildRequires:  sqlite3-devel >= 3.7.4
89 BuildRequires:  startup-notification-devel >= 0.8
90 BuildRequires:  libvpx-devel >= 1.0.0
91 BuildRequires:  xorg-lib-libXext-devel
92 BuildRequires:  xorg-lib-libXinerama-devel
93 BuildRequires:  xorg-lib-libXt-devel
94 BuildRequires:  yasm
95 BuildRequires:  zip
96 %if %{with xulrunner}
97 BuildRequires:  xulrunner-devel >= %{xulrunner_ver}
98 %else
99 Requires:       myspell-common
100 Requires:       nspr >= 1:%{nspr_ver}
101 Requires:       nss >= 1:%{nss_ver}
102 Requires:       sqlite3 >= %{sqlite_build_version}
103 %endif
104 Requires(post): mktemp >= 1.5-18
105 %if %{with xulrunner}
106 %requires_eq_to xulrunner xulrunner-devel
107 %endif
108 Requires:       libjpeg-turbo
109 Obsoletes:      mozilla-thunderbird
110 Obsoletes:      mozilla-thunderbird-dictionary-en-US
111 Conflicts:      icedove-lang-resources < %{version}
112 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
113
114 %define         filterout_cpp           -D_FORTIFY_SOURCE=[0-9]+
115
116 # iceweasel/icedove/iceape provide their own versions
117 %define         _noautoprovfiles        %{_libdir}/%{name}/components
118 %if %{without xulrunner}
119 # we don't want these to satisfy packages depending on xulrunner
120 %define         _noautoprov             libmozalloc.so libxpcom.so libxul.so
121 # and as we don't provide them, don't require either
122 %define         _noautoreq              libmozalloc.so libxpcom.so libxul.so
123 %endif
124
125 %define         topdir          %{_builddir}/%{name}-%{version}
126 %define         objdir          %{topdir}/obj-%{_target_cpu}
127
128 %description
129 Icedove is an open-source, fast and portable email client.
130
131 %description -l pl.UTF-8
132 Icedove jest mającym otwarte źródła, szybkim i przenośnym klientem
133 poczty.
134
135 %package addon-lightning
136 Summary:        An integrated calendar for Icedove
137 Summary(pl.UTF-8):      Zintegrowany kalendarz dla Icedove
138 License:        MPL 1.1 or GPL v2+ or LGPL v2.1+
139 Group:          Applications/Networking
140 Requires:       %{name} = %{version}-%{release}
141
142 %description addon-lightning
143 Lightning is an calendar extension to Icedove email client.
144
145 %description addon-lightning -l pl.UTF-8
146 Lightning to rozszerzenie do klienta poczty Icedove dodające
147 funkcjonalność kalendarza.
148
149 %package addon-enigmail
150 Summary:        Extension for the authentication and encryption features provided by GnuPG
151 Summary(pl.UTF-8):      Rozszerzenie do uwierzytelniania i szyfrowania zapewnianego przez GnuPG
152 License:        MPL/LGPL
153 Group:          Applications/Networking
154 URL:            http://enigmail.mozdev.org/
155 Requires:       %{name} = %{version}-%{release}
156 Requires:       gnupg
157 Obsoletes:      mozilla-thunderbird-addon-enigmail
158
159 %description addon-enigmail
160 Enigmail is an extension to the Icedove mail client which allows users
161 to access the authentication and encryption features provided by
162 GnuPG.
163
164 Main Features:
165 - Encrypt/sign mail when sending, decrypt/authenticate received mail
166 - Support for inline-PGP (RFC 2440) and PGP/MIME (RFC 3156)
167 - Per-Account based encryption and signing defaults
168 - Per-Recipient rules for automated key selection, and
169   enabling/disabling encryption and signing
170 - OpenPGP key management interface
171
172 %description addon-enigmail -l pl.UTF-8
173 Enigmail to rozszerzenie klienta pocztowego Icedove pozwalające
174 użytkownikom na dostęp do uwierzytelniania i szyfrowania zapewnianego
175 przez GnuPG.
176
177 Główne możliwości:
178 - szyfrowanie/podpisywanie poczty przy wysyłaniu,
179   odszyfrowywanie/uwierzytelnianie poczty odebranej
180 - obsługa inline-PGP (RFC 2440) i PGP/MIME (RFC 3156)
181 - ustawienia domyślne szyfrowania i podpisywania dla każdego konta
182 - reguły automatycznego wyboru kluczy i włączenia szyfrowania oraz
183   podpisywania dla każdego adresata
184 - interfejs do zarządzania kluczami OpenPGP
185
186 %prep
187 %setup -qc
188 mv comm-esr24 mozilla
189 %setup -q -T -D -a2
190 cd mozilla
191 %{?with_enigmail:%{__gzip} -dc %{SOURCE1} | %{__tar} -xf - -C mailnews/extensions}
192 /bin/sh %{SOURCE3}
193 %patch0 -p1
194 %{?with_enigmail:%patch1 -p1}
195 %patch2 -p1
196 %patch3 -p1
197 %patch6 -p1
198 %patch7 -p1
199 %patch8 -p2
200 %patch10 -p2
201 #patch11 -p2
202 %patch12 -p1
203 %patch13 -p1
204 %patch14 -p1
205 %patch15 -p1
206
207 # the entire check in that configure is so wrong, it's simpler to just workaround it here temporarily
208 %{__sed} -i -e 's|min_nss_version=3.15.3.1|min_nss_version=3.15.3|' mozilla/configure
209
210 %build
211 cd mozilla
212 cp -f %{_datadir}/automake/config.* mozilla/build/autoconf
213 cp -f %{_datadir}/automake/config.* mozilla/nsprpub/build/autoconf
214 cp -f %{_datadir}/automake/config.* ldap/sdks/c-sdk/config/autoconf
215
216 cat << EOF > .mozconfig
217 mk_add_options MOZ_OBJDIR=%{objdir}
218
219 export CFLAGS="%{rpmcflags}"
220 export CXXFLAGS="%{rpmcflags}"
221
222 %if %{with crashreporter}
223 export MOZ_DEBUG_SYMBOLS=1
224 %endif
225
226 # Options for 'configure' (same as command-line options).
227 ac_add_options --prefix=%{_prefix}
228 ac_add_options --exec-prefix=%{_exec_prefix}
229 ac_add_options --bindir=%{_bindir}
230 ac_add_options --sbindir=%{_sbindir}
231 ac_add_options --sysconfdir=%{_sysconfdir}
232 ac_add_options --datadir=%{_datadir}
233 ac_add_options --includedir=%{_includedir}
234 ac_add_options --libdir=%{_libdir}
235 ac_add_options --libexecdir=%{_libexecdir}
236 ac_add_options --localstatedir=%{_localstatedir}
237 ac_add_options --sharedstatedir=%{_sharedstatedir}
238 ac_add_options --mandir=%{_mandir}
239 ac_add_options --infodir=%{_infodir}
240 %if %{?debug:1}0
241 ac_add_options --disable-optimize
242 ac_add_options --enable-debug
243 ac_add_options --enable-debug-modules
244 ac_add_options --enable-debugger-info-modules
245 ac_add_options --enable-crash-on-assert
246 %else
247 ac_add_options --disable-debug
248 ac_add_options --disable-debug-modules
249 ac_add_options --disable-logging
250 ac_add_options --enable-optimize="%{rpmcflags} -Os"
251 %endif
252 ac_add_options --disable-strip
253 ac_add_options --disable-strip-libs
254 %if %{with tests}
255 ac_add_options --enable-tests
256 %else
257 ac_add_options --disable-tests
258 %endif
259 ac_add_options --enable-gio
260 ac_add_options --disable-gnomeui
261 ac_add_options --disable-gnomevfs
262 %if %{with ldap}
263 ac_add_options --enable-ldap
264 ac_add_options --with-system-ldap
265 %else
266 ac_add_options --disable-ldap
267 %endif
268 %if %{with crashreporter}
269 ac_add_options --enable-crashreporter
270 %else
271 ac_add_options --disable-crashreporter
272 %endif
273 ac_add_options --disable-xterm-updates
274 ac_add_options --enable-postscript
275 %if %{with lightning}
276 ac_add_options --enable-calendar
277 %else
278 ac_add_options --disable-calendar
279 %endif
280 ac_add_options --disable-elf-dynstr-gc
281 ac_add_options --disable-installer
282 ac_add_options --disable-javaxpcom
283 ac_add_options --disable-updater
284 ac_add_options --enable-crypto
285 ac_add_options --enable-libxul
286 ac_add_options --enable-pango
287 ac_add_options --enable-shared-js
288 ac_add_options --enable-startup-notification
289 ac_add_options --enable-system-cairo
290 ac_add_options --enable-system-hunspell
291 ac_add_options --enable-system-sqlite
292 ac_add_options --enable-application=mail
293 ac_add_options --with-distribution-id=org.pld-linux
294 ac_add_options --with-branding=icedove/branding
295 %if %{with xulrunner}
296 ac_add_options --with-system-libxul
297 ac_add_options --with-libxul-sdk=$(pkg-config --variable=sdkdir libxul)
298 %endif
299 ac_add_options --with-pthreads
300 ac_add_options --with-system-bz2
301 ac_add_options --with-system-ffi
302 ac_add_options --with-system-jpeg
303 ac_add_options --with-system-libevent
304 ac_add_options --with-system-libvpx
305 ac_add_options --with-system-nspr
306 ac_add_options --with-system-nss
307 ac_add_options --with-system-png
308 ac_add_options --with-system-zlib
309 ac_add_options --enable-single-profile
310 ac_add_options --disable-profilesharing
311 ac_add_options --with-default-mozilla-five-home=%{_libdir}/%{name}
312 EOF
313
314 mkdir -p %{objdir}/config
315 ln -s %{topdir}/mozilla/config/*.mk %{objdir}/config
316
317 %{__make} -j1 -f client.mk build \
318         STRIP="/bin/true" \
319         MOZ_MAKE_FLAGS="%{?_smp_mflags}" \
320         installdir=%{_libdir}/%{name} \
321         XLIBS="-lX11 -lXt" \
322         CC="%{__cc}" \
323         CXX="%{__cxx}"
324
325 %if %{with crashreporter}
326 # create debuginfo for crash-stats.mozilla.com
327 %{__make} -j1 -C obj-%{_target_cpu} buildsymbols
328 %endif
329
330 %if %{with enigmail}
331 cd mailnews/extensions/enigmail
332 ./makemake -r -o %{objdir}
333 %{__make} -j1 -C %{objdir}/mailnews/extensions/enigmail \
334         STRIP="/bin/true" \
335         CC="%{__cc}" \
336         CXX="%{__cxx}"
337
338 %{__make} -j1 -C %{objdir}/mailnews/extensions/enigmail xpi \
339         STRIP="/bin/true" \
340         CC="%{__cc}" \
341         CXX="%{__cxx}"
342 %endif
343
344 %install
345 rm -rf $RPM_BUILD_ROOT
346 install -d $RPM_BUILD_ROOT{%{_bindir},%{_libdir}/%{name},%{_datadir}/%{name},%{_pixmapsdir},%{_desktopdir}}
347
348 cd %{objdir}
349 %{__make} -C mail/installer stage-package \
350         DESTDIR=$RPM_BUILD_ROOT \
351         installdir=%{_libdir}/%{name} \
352         PKG_SKIP_STRIP=1
353
354 %{__make} -C icedove/branding install \
355         DESTDIR=$RPM_BUILD_ROOT
356
357 cp -a mozilla/dist/icedove/* $RPM_BUILD_ROOT%{_libdir}/%{name}/
358  
359 %if %{with xulrunner}
360 # needed to find mozilla runtime
361 ln -s ../xulrunner $RPM_BUILD_ROOT%{_libdir}/%{name}/xulrunner
362 %endif
363  
364 # Enable crash reporter for Thunderbird application
365 %if %{with crashreporter}
366 %{__sed} -i -e 's/\[Crash Reporter\]/[Crash Reporter]\nEnabled=1/' $RPM_BUILD_ROOT%{_libdir}/%{name}/application.ini
367
368 # Add debuginfo for crash-stats.mozilla.com
369 install -d $RPM_BUILD_ROOT%{_exec_prefix}/lib/debug%{_libdir}/%{name}
370 cp -a mozilla/dist/%{name}-%{version}.en-US.linux-*.crashreporter-symbols.zip $RPM_BUILD_ROOT%{_prefix}/lib/debug%{_libdir}/%{name}
371 %endif
372
373 # copy manually lightning files, somewhy they are not installed by make
374 cp -a mozilla/dist/bin/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103} \
375         $RPM_BUILD_ROOT%{_libdir}/%{name}/extensions
376
377 # move arch independant ones to datadir
378 mv $RPM_BUILD_ROOT%{_libdir}/%{name}/searchplugins $RPM_BUILD_ROOT%{_datadir}/%{name}/searchplugins
379 ln -s ../../share/%{name}/searchplugins $RPM_BUILD_ROOT%{_libdir}/%{name}/searchplugins
380
381 # dir for arch independant extensions besides arch dependant extensions
382 # see mozilla/xpcom/build/nsXULAppAPI.h
383 # XRE_SYS_LOCAL_EXTENSION_PARENT_DIR and XRE_SYS_SHARE_EXTENSION_PARENT_DIR
384 install -d $RPM_BUILD_ROOT%{_datadir}/%{name}/extensions
385
386 %if %{without xulrunner}
387 %{__rm} -r $RPM_BUILD_ROOT%{_libdir}/%{name}/dictionaries
388 ln -s %{_datadir}/myspell $RPM_BUILD_ROOT%{_libdir}/%{name}/dictionaries
389 %endif
390
391 %{__sed} -e "s|%MOZAPPDIR%|%{_libdir}/%{name}|" \
392          -e "s|%MOZ_APP_DISPLAYNAME%|Icedove|" \
393         %{topdir}/mozilla/mozilla/build/unix/mozilla.in > $RPM_BUILD_ROOT%{_libdir}/%{name}/icedove
394
395 %{__sed} -e 's,@LIBDIR@,%{_libdir},' %{SOURCE5} > $RPM_BUILD_ROOT%{_bindir}/icedove
396 ln -s %{name} $RPM_BUILD_ROOT%{_bindir}/thunderbird
397 ln -s %{name} $RPM_BUILD_ROOT%{_bindir}/mozilla-thunderbird
398
399 # install icons and desktop file
400 cp -p %{topdir}/mozilla/icedove/branding/content/icon64.png $RPM_BUILD_ROOT%{_pixmapsdir}/%{name}.png
401 for i in 16 32 48 64 128 256; do
402         install -d $RPM_BUILD_ROOT%{_iconsdir}/hicolor/${i}x${i}/apps
403         cp -a %{topdir}/mozilla/icedove/branding/icedove${i}.png \
404                 $RPM_BUILD_ROOT%{_iconsdir}/hicolor/${i}x${i}/apps/icedove.png
405 done
406 install -d $RPM_BUILD_ROOT%{_iconsdir}/hicolor/scalable/apps
407 cp -a %{topdir}/mozilla/icedove/branding/icedove.svg $RPM_BUILD_ROOT%{_iconsdir}/hicolor/scalable/apps/icedove.svg
408
409 cp -p %{SOURCE4} $RPM_BUILD_ROOT%{_desktopdir}/%{name}.desktop
410
411 # files created by regxpcom -register in post
412 touch $RPM_BUILD_ROOT%{_libdir}/%{name}/components/compreg.dat
413 touch $RPM_BUILD_ROOT%{_libdir}/%{name}/components/xpti.dat
414 cat << 'EOF' > $RPM_BUILD_ROOT%{_libdir}/%{name}/register
415 #!/bin/sh
416 umask 022
417 # make temporary HOME, as it attempts to touch files in $HOME/.mozilla
418 # dangerous if you run this with sudo with keep_env += HOME
419 # also TMPDIR could be pointing to sudo user's homedir so we reset that too.
420 t=$(mktemp -d)
421 %{__rm} -f %{_libdir}/%{name}/components/{compreg,xpti}.dat
422 TMPDIR= TMP= HOME=$t %{_libdir}/%{name}/icedove -register
423 rm -rf $t
424 EOF
425 chmod a+rx $RPM_BUILD_ROOT%{_libdir}/%{name}/register
426
427 %if %{with enigmail}
428 ext_dir=$RPM_BUILD_ROOT%{_libdir}/%{name}/extensions/\{847b3a00-7ab1-11d4-8f02-006008948af5\}
429 install -d $ext_dir/{chrome,components,defaults/preferences,modules}
430 cd mozilla/dist/bin
431 cp -rfLp chrome/enigmail.jar $ext_dir/chrome
432 cp -rfLp components/enig* $ext_dir/components
433 cp -rfLp defaults/preferences/enigmail.js $ext_dir/defaults/preferences
434 cp -rfLp modules/{commonFuncs,enigmailCommon,keyManagement,pipeConsole,subprocess}.jsm $ext_dir/modules
435 cp -rfLp modules/{subprocess_worker_unix,subprocess_worker_win}.js $ext_dir/modules
436 cd -
437 cp -p %{topdir}/mozilla/mailnews/extensions/enigmail/package/install.rdf $ext_dir
438 cp -p %{topdir}/mozilla/mailnews/extensions/enigmail/package/chrome.manifest $ext_dir/chrome.manifest
439 %endif
440
441 # mozldap
442 %{__sed} -i '/lib\(ldap\|ldif\|prldap\)60.so/d' $RPM_BUILD_ROOT%{_libdir}/%{name}/dependentlibs.list
443 %{__rm} $RPM_BUILD_ROOT%{_libdir}/%{name}/lib{ldap,ldif,prldap}60.so
444
445 %clean
446 rm -rf $RPM_BUILD_ROOT
447
448 %pretrans
449 if [ -d %{_libdir}/%{name}/dictionaries ] && [ ! -L %{_libdir}/%{name}/dictionaries ]; then
450         mv -v %{_libdir}/%{name}/dictionaries{,.rpmsave}
451 fi
452 for d in chrome defaults icons isp modules res searchplugins; do
453         if [ -d %{_libdir}/%{name}/$d ] && [ ! -L %{_libdir}/%{name}/$d ]; then
454                 install -d %{_datadir}/%{name}
455                 mv %{_libdir}/%{name}/$d %{_datadir}/%{name}/$d
456         fi
457 done
458 exit 0
459
460 %post
461 %{_libdir}/%{name}/register || :
462
463 %files
464 %defattr(644,root,root,755)
465 %attr(755,root,root) %{_bindir}/icedove
466 %attr(755,root,root) %{_bindir}/mozilla-thunderbird
467 %attr(755,root,root) %{_bindir}/thunderbird
468 %dir %{_libdir}/%{name}
469 %{_libdir}/%{name}/application.ini
470 %{_libdir}/%{name}/blocklist.xml
471 %{_libdir}/%{name}/chrome.manifest
472 %dir %{_libdir}/%{name}/components
473 %{_libdir}/%{name}/components/components.manifest
474 %attr(755,root,root) %{_libdir}/%{name}/*.sh
475 %attr(755,root,root) %{_libdir}/%{name}/*-bin
476 %attr(755,root,root) %{_libdir}/%{name}/icedove
477 %attr(755,root,root) %{_libdir}/%{name}/register
478 %{_libdir}/%{name}/omni.ja
479 %if %{without xulrunner}
480 %{_libdir}/%{name}/dependentlibs.list
481 %{_libdir}/%{name}/platform.ini
482 #%{_libdir}/%{name}/greprefs.js
483 %attr(755,root,root) %{_libdir}/%{name}/components/*.so
484 %attr(755,root,root) %{_libdir}/%{name}/libmozalloc.so
485 %attr(755,root,root) %{_libdir}/%{name}/libmozjs.so
486 %attr(755,root,root) %{_libdir}/%{name}/libxul.so
487 %attr(755,root,root) %{_libdir}/%{name}/mozilla-xremote-client
488 %attr(755,root,root) %{_libdir}/%{name}/plugin-container
489 %endif
490
491 # symlinks
492 %{_libdir}/%{name}/chrome
493 %{_libdir}/%{name}/defaults
494 %{_libdir}/%{name}/isp
495 #%{_libdir}/%{name}/modules
496 %{_libdir}/%{name}/searchplugins
497 %if %{with xulrunner}
498 %{_libdir}/%{name}/xulrunner
499 %else
500 %{_libdir}/%{name}/dictionaries
501 %endif
502
503 %{_pixmapsdir}/icedove.png
504 %{_desktopdir}/icedove.desktop
505
506 %dir %{_datadir}/%{name}
507 %{_datadir}/%{name}/extensions
508 %{_datadir}/%{name}/searchplugins
509
510 %if %{with crashreporter}
511 %attr(755,root,root) %{_libdir}/%{name}/crashreporter
512 %{_libdir}/%{name}/crashreporter.ini
513 %{_libdir}/%{name}/Throbber-small.gif
514 %endif
515
516 %dir %{_libdir}/%{name}/extensions
517 %{_libdir}/%{name}/extensions/{972ce4c6-7e08-4474-a285-3208198ce6fd}
518
519 # files created by regxpcom -register
520 %ghost %{_libdir}/%{name}/components/compreg.dat
521 %ghost %{_libdir}/%{name}/components/xpti.dat
522
523 %{_iconsdir}/hicolor/*/apps/icedove.*
524
525 %if %{with lightning}
526 %files addon-lightning
527 %defattr(644,root,root,755)
528 %dir %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}
529 %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/application.ini
530 %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/chrome
531 %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/chrome.manifest
532 %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/defaults
533 %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/install.rdf
534 %dir %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/components
535 %attr(755,root,root) %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/components/*.so
536 %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/components/*.js
537 %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/components/*.manifest
538 %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/components/*.xpt
539 %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/modules
540 %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/calendar-js
541 %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/timezones.sqlite
542 %endif
543
544 %if %{with enigmail}
545 %files addon-enigmail
546 %defattr(644,root,root,755)
547 %dir %{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}
548 %{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/defaults
549 %{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/chrome
550 %{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/chrome.manifest
551 %{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/install.rdf
552 %dir %{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/components
553 %{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/components/*.xpt
554 %{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/components/*.js
555 %dir %{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/modules
556 %{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/modules/*.jsm
557 %{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/modules/*.js
558 %endif
This page took 0.081201 seconds and 4 git commands to generate.