]> git.pld-linux.org Git - packages/thunderbird.git/blob - icedove.spec
- threaded build is possible
[packages/thunderbird.git] / icedove.spec
1 #
2 # TODO:
3 # - CHECK all features of enigmail
4 # - separate spec for enigmail
5 # - update or remove -myspell.patch
6 # - package unpackaged files
7 # - update branding patch!!!
8 #
9 # Conditional builds
10 %bcond_without  enigmail        # don't build enigmail - GPG/PGP support
11 %bcond_without  gnomeui         # disable gnomeui support
12 %bcond_without  gnomevfs        # disable GNOME comp. (gconf+libgnome+gnomevfs) and gnomevfs ext.
13 %bcond_without  gnome           # disable all GNOME components (gnome+gnomeui+gnomevfs)
14 %bcond_without  ldap            # disable e-mail address lookups in LDAP directories
15 %bcond_without  lightning   # disable sunbird calendar
16 #
17 %if %{without gnome}
18 %undefine       with_gnomeui
19 %undefine       with_gnomevfs
20 %endif
21 %define         enigmail_ver            1.0.0
22
23 Summary:        Icedove - email client
24 Summary(pl.UTF-8):      Icedove - klient poczty
25 Name:           icedove
26 Version:        3.0
27 Release:        0.3
28 License:        MPL 1.1 or GPL v2+ or LGPL v2.1+
29 Group:          Applications/Networking
30 Source0:        http://releases.mozilla.org/pub/mozilla.org/thunderbird/releases/%{version}/source/thunderbird-%{version}.source.tar.bz2
31 # Source0-md5:  9a564ac2489b1b0f9348dc298b913f6c
32 Source1:        http://www.mozilla-enigmail.org/download/source/enigmail-%{enigmail_ver}.tar.gz
33 # Source1-md5:  e3a6d379f1a72ac023751bdde2de750a
34 Source2:        %{name}-branding.tar.bz2
35 # Source2-md5:  e775b8cb658de32f30b403bc9b7950bf
36 Source3:        %{name}-rm_nonfree.sh
37 Source4:        %{name}.desktop
38 Source5:        %{name}.sh
39 Source6:        %{name}-enigmail.manifest
40 Patch0:         %{name}-branding.patch
41 Patch1:         %{name}-enigmail-shared.patch
42 Patch2:         %{name}-gcc.patch
43 Patch3:         %{name}-fonts.patch
44 Patch4:         %{name}-install.patch
45 Patch5:         %{name}-myspell.patch
46 Patch6:         %{name}-prefs.patch
47 Patch7:         %{name}-breakpad.patch
48 URL:            http://www.pld-linux.org/Packages/Icedove
49 %{?with_gnomevfs:BuildRequires: GConf2-devel >= 1.2.1}
50 BuildRequires:  automake
51 BuildRequires:  freetype-devel >= 1:2.1.8
52 %{?with_gnomevfs:BuildRequires: gnome-vfs2-devel >= 2.0}
53 BuildRequires:  gtk+2-devel >= 1:2.0.0
54 BuildRequires:  libIDL-devel >= 0.8.0
55 %{?with_gnomevfs:BuildRequires: libgnome-devel >= 2.0}
56 %{?with_gnomeui:BuildRequires:  libgnomeui-devel >= 2.2.0}
57 BuildRequires:  libjpeg-devel >= 6b
58 BuildRequires:  libpng-devel >= 1.2.0
59 BuildRequires:  libstdc++-devel
60 BuildRequires:  myspell-devel
61 BuildRequires:  nspr-devel >= 1:4.8
62 BuildRequires:  nss-devel >= 1:3.12.0
63 BuildRequires:  pango-devel >= 1:1.1.0
64 BuildRequires:  sed >= 4.0
65 BuildRequires:  xorg-lib-libXext-devel
66 BuildRequires:  xorg-lib-libXft-devel >= 2.1
67 BuildRequires:  xorg-lib-libXinerama-devel
68 BuildRequires:  xorg-lib-libXp-devel
69 BuildRequires:  xorg-lib-libXt-devel
70 Requires:       myspell-common
71 Requires:       nspr >= 1:4.6.1
72 Requires:       nss >= 1:3.11.3
73 Obsoletes:      mozilla-thunderbird
74 Obsoletes:      mozilla-thunderbird-dictionary-en-US
75 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
76
77 %define         filterout_cpp           -D_FORTIFY_SOURCE=[0-9]+
78
79 # iceweasel/icedove/iceape provide their own versions
80 %define         _noautoreqdep           libgfxpsshar.so libgkgfx.so libgtkxtbin.so libjsj.so libxpcom_compat.so libxpcom_core.so libxpistub.so
81 %define         _noautoprovfiles        %{_libdir}/%{name}/components
82 # we don't want these to satisfy xulrunner-devel
83 %define         _noautoprov             libgtkembedmoz.so libldap50.so libmozjs.so libprldap50.so libssldap50.so libxpcom.so libxul.so
84 # and as we don't provide them, don't require either
85 %define         _noautoreq              libgtkembedmoz.so libldap50.so libmozjs.so libprldap50.so libssldap50.so libxpcom.so libxul.so
86
87 %description
88 Icedove is an open-source,fast and portable email client.
89
90 %description -l pl.UTF-8
91 Icedove jest open sourcowym, szybkim i przenośnym klientem poczty.
92
93 %package addon-enigmail
94 Summary:        Extension for the authentication and encryption features provided by GnuPG
95 Summary(pl.UTF-8):      Rozszerzenie do uwierzytelniania i szyfrowania zapewnianego przez GnuPG
96 License:        MPL/LGPL
97 Group:          Applications/Networking
98 URL:            http://enigmail.mozdev.org/
99 Requires:       %{name} = %{version}-%{release}
100 Requires:       gnupg
101 Obsoletes:      mozilla-thunderbird-addon-enigmail
102
103 %description addon-enigmail
104 Enigmail is an extension to the Icedove mail client which allows users
105 to access the authentication and encryption features provided by
106 GnuPG.
107
108 Main Features:
109 - Encrypt/sign mail when sending, decrypt/authenticate received mail
110 - Support for inline-PGP (RFC 2440) and PGP/MIME (RFC 3156)
111 - Per-Account based encryption and signing defaults
112 - Per-Recipient rules for automated key selection, and
113   enabling/disabling encryption and signing
114 - OpenPGP key management interface
115
116 %description addon-enigmail -l pl.UTF-8
117 Enigmail to rozszerzenie klienta pocztowego Icedove pozwalające
118 użytkownikom na dostęp do uwierzytelniania i szyfrowania zapewnianego
119 przez GnuPG.
120
121 Główne możliwości:
122 - szyfrowanie/podpisywanie poczty przy wysyłaniu,
123   odszyfrowywanie/uwierzytelnianie poczty odebranej
124 - obsługa inline-PGP (RFC 2440) i PGP/MIME (RFC 3156)
125 - ustawienia domyślne szyfrowania i podpisywania dla każdego konta
126 - reguły automatycznego wyboru kluczy i włączenia szyfrowania oraz
127   podpisywania dla każdego adresata
128 - interfejs do zarządzania kluczami OpenPGP
129
130 %prep
131 %setup -q -c -a2
132 cd comm-1.9.1
133 %{?with_enigmail:tar xvfz %{SOURCE1} -C mailnews/extensions}
134 /bin/sh %{SOURCE3}
135 %patch0 -p2
136 %{?with_enigmail:%patch1 -p1}
137 %patch2 -p1
138 %patch3 -p1
139 %patch4 -p1
140 #%patch5 -p1
141 %patch6 -p0
142 %patch7 -p1
143
144 %build
145 cd comm-1.9.1
146 export CFLAGS="%{rpmcflags} `%{_bindir}/pkg-config mozilla-nspr --cflags-only-I`"
147 export CXXFLAGS="%{rpmcflags} `%{_bindir}/pkg-config mozilla-nspr --cflags-only-I`"
148
149 cp -f %{_datadir}/automake/config.* mozilla/build/autoconf
150 cp -f %{_datadir}/automake/config.* mozilla/nsprpub/build/autoconf
151 cp -f %{_datadir}/automake/config.* directory/c-sdk/config/autoconf
152
153 cat << 'EOF' > .mozconfig
154 mk_add_options MOZ_OBJDIR=@TOPSRCDIR@/obj-%{_target_cpu}
155
156 # Options for 'configure' (same as command-line options).
157 ac_add_options --prefix=%{_prefix}
158 ac_add_options --exec-prefix=%{_exec_prefix}
159 ac_add_options --bindir=%{_bindir}
160 ac_add_options --sbindir=%{_sbindir}
161 ac_add_options --sysconfdir=%{_sysconfdir}
162 ac_add_options --datadir=%{_datadir}
163 ac_add_options --includedir=%{_includedir}
164 ac_add_options --libdir=%{_libdir}
165 ac_add_options --libexecdir=%{_libexecdir}
166 ac_add_options --localstatedir=%{_localstatedir}
167 ac_add_options --sharedstatedir=%{_sharedstatedir}
168 ac_add_options --mandir=%{_mandir}
169 ac_add_options --infodir=%{_infodir}
170 %if %{?debug:1}0
171 ac_add_options --disable-optimize
172 ac_add_options --enable-debug
173 ac_add_options --enable-debug-modules
174 ac_add_options --enable-debugger-info-modules
175 ac_add_options --enable-crash-on-assert
176 %else
177 ac_add_options --disable-debug
178 ac_add_options --disable-debug-modules
179 ac_add_options --disable-logging
180 ac_add_options --enable-optimize="%{rpmcflags} -Os"
181 %endif
182 %if %{with tests}
183 ac_add_options --enable-tests
184 %else
185 ac_add_options --disable-tests
186 %endif
187 %if %{with gnomeui}
188 ac_add_options --enable-gnomeui
189 %else
190 ac_add_options --disable-gnomeui
191 %endif
192 %if %{with gnomevfs}
193 ac_add_options --enable-gnomevfs
194 %else
195 ac_add_options --disable-gnomevfs
196 %endif
197 %if %{with ldap}
198 ac_add_options --enable-ldap
199 %else
200 ac_add_options --disable-ldap
201 %endif
202 ac_add_options --disable-crashreporter
203 ac_add_options --disable-updater
204 ac_add_options --disable-xterm-updates
205 ac_add_options --enable-ldap
206 ac_add_options --enable-postscript
207 ac_add_options --enable-startup-notification
208 %if %{with lightning}
209 ac_add_options --enable-calendar
210 %else
211 ac_add_options --disable-calendar
212 %endif
213 ac_add_options --disable-installer
214 ac_add_options --disable-jsd
215 ac_add_options --disable-xprint
216 ac_add_options --disable-permissions
217 ac_add_options --disable-pref-extensions
218 ac_add_options --enable-canvas
219 ac_add_options --enable-crypto
220 ac_add_options --enable-default-toolkit="gtk2"
221 ac_add_options --enable-mathml
222 ac_add_options --enable-optimize="%{rpmcflags}"
223 ac_add_options --enable-pango
224 ac_add_options --enable-reorder
225 ac_add_options --enable-static
226 ac_add_options --disable-strip
227 ac_add_options --disable-strip-libs
228 ac_add_options --enable-system-cairo
229 ac_add_options --enable-system-myspell
230 ac_add_options --enable-svg
231 ac_add_options --enable-xft
232 ac_add_options --enable-application=mail
233 ac_add_options --enable-default-toolkit=cairo-gtk2
234 ac_add_options --enable-xinerama
235 ac_add_options --with-system-jpeg
236 ac_add_options --with-system-nspr
237 ac_add_options --with-system-nss
238 ac_add_options --with-system-png
239 ac_add_options --with-system-zlib
240 ac_add_options --with-pthreads
241 ac_add_options --enable-single-profile
242 ac_add_options --disable-profilesharing
243 ac_add_options --with-distribution-id=org.pld-linux
244 #ac_add_options --with-branding=icedove/branding
245 ac_add_options --with-default-mozilla-five-home=%{_libdir}/%{name}
246 EOF
247
248 %{__make} -f client.mk build \
249         STRIP="/bin/true" \
250         CC="%{__cc}" \
251         CXX="%{__cxx}"
252
253 %if %{with enigmail}
254 cd mailnews/extensions/enigmail
255 ./makemake -r
256 %{__make} -C ../../../obj-%{_target_cpu}/mailnews/extensions/enigmail \
257         STRIP="/bin/true" \
258         CC="%{__cc}" \
259         CXX="%{__cxx}"
260 %endif
261
262 %install
263 rm -rf $RPM_BUILD_ROOT
264 install -d $RPM_BUILD_ROOT{%{_bindir},%{_libdir},%{_pixmapsdir},%{_desktopdir}} \
265                $RPM_BUILD_ROOT%{_datadir}/%{name}
266 install -d $RPM_BUILD_ROOT%{_libdir}/%{name}
267
268 cd comm-1.9.1
269 %{__make} -C obj-%{_target_cpu}/mail/installer stage-package \
270         DESTDIR=$RPM_BUILD_ROOT \
271         MOZ_PKG_APPDIR=%{_libdir}/%{name} \
272         PKG_SKIP_STRIP=1
273
274 # move arch independant ones to datadir
275 mv $RPM_BUILD_ROOT%{_libdir}/%{name}/chrome $RPM_BUILD_ROOT%{_datadir}/%{name}/chrome
276 mv $RPM_BUILD_ROOT%{_libdir}/%{name}/defaults $RPM_BUILD_ROOT%{_datadir}/%{name}/defaults
277 mv $RPM_BUILD_ROOT%{_libdir}/%{name}/greprefs $RPM_BUILD_ROOT%{_datadir}/%{name}/greprefs
278 #mv $RPM_BUILD_ROOT%{_libdir}/%{name}/icons $RPM_BUILD_ROOT%{_datadir}/%{name}/icons
279 mv $RPM_BUILD_ROOT%{_libdir}/%{name}/isp $RPM_BUILD_ROOT%{_datadir}/%{name}/isp
280 mv $RPM_BUILD_ROOT%{_libdir}/%{name}/res $RPM_BUILD_ROOT%{_datadir}/%{name}/res
281 ln -s ../../share/%{name}/chrome $RPM_BUILD_ROOT%{_libdir}/%{name}/chrome
282 ln -s ../../share/%{name}/defaults $RPM_BUILD_ROOT%{_libdir}/%{name}/defaults
283 ln -s ../../share/%{name}/greprefs $RPM_BUILD_ROOT%{_libdir}/%{name}/greprefs
284 #ln -s ../../share/%{name}/icons $RPM_BUILD_ROOT%{_libdir}/%{name}/icons
285 ln -s ../../share/%{name}/isp $RPM_BUILD_ROOT%{_libdir}/%{name}/isp
286 ln -s ../../share/%{name}/res $RPM_BUILD_ROOT%{_libdir}/%{name}/res
287
288 rm -rf $RPM_BUILD_ROOT%{_libdir}/%{name}/dictionaries
289 ln -s %{_datadir}/myspell $RPM_BUILD_ROOT%{_libdir}/%{name}/dictionaries
290
291 %{__sed} -e 's,@LIBDIR@,%{_libdir},' %{SOURCE5} > $RPM_BUILD_ROOT%{_bindir}/icedove
292 ln -s %{name} $RPM_BUILD_ROOT%{_bindir}/thunderbird
293 ln -s %{name} $RPM_BUILD_ROOT%{_bindir}/mozilla-thunderbird
294
295 install %{SOURCE4} $RPM_BUILD_ROOT%{_desktopdir}/%{name}.desktop
296
297 %if %{with enigmail}
298 _enig_dir=$RPM_BUILD_ROOT%{_libdir}/%{name}/extensions/\{847b3a00-7ab1-11d4-8f02-006008948af5\}
299 install -d $_enig_dir/chrome
300 install -d $_enig_dir/components
301 install -d $_enig_dir/defaults/preferences
302 mv -f $RPM_BUILD_ROOT%{_libdir}/%{name}/chrome/enigmail.jar $_enig_dir/chrome
303 mv -f $RPM_BUILD_ROOT%{_libdir}/%{name}/components/enig* $_enig_dir/components
304 mv -f $RPM_BUILD_ROOT%{_libdir}/%{name}/components/libenigmime.so $_enig_dir/components
305 mv -f $RPM_BUILD_ROOT%{_libdir}/%{name}/components/ipc.xpt $_enig_dir/components
306 mv -f $RPM_BUILD_ROOT%{_libdir}/%{name}/defaults/preferences/enigmail.js $_enig_dir/defaults/preferences
307 cp -f mailnews/extensions/enigmail/package/install.rdf $_enig_dir
308 rm -rf $RPM_BUILD_ROOT%{_libdir}/%{name}/defaults/preferences
309 rm -f $RPM_BUILD_ROOT%{_libdir}/%{name}/chrome/enigmail-en-US.jar
310 rm -f $RPM_BUILD_ROOT%{_libdir}/%{name}/chrome/enigmail-skin.jar
311 rm -f $RPM_BUILD_ROOT%{_libdir}/%{name}/chrome/enigmime.jar
312 rm -rf $RPM_BUILD_ROOT%{_libdir}/%{name}/components/enig*
313 rm -f $RPM_BUILD_ROOT%{_libdir}/%{name}/components/libenigmime.so
314 rm -f $RPM_BUILD_ROOT%{_libdir}/%{name}/components/ipc.xpt
315 cp -f %{SOURCE6} $_enig_dir/chrome.manifest
316 #cp -f icedove/branding/content/icon64.png $RPM_BUILD_ROOT%{_pixmapsdir}/icedove.png
317 %endif
318
319 # win32 stuff
320 rm -f $RPM_BUILD_ROOT%{_libdir}/%{name}/dirver
321
322 %clean
323 rm -rf $RPM_BUILD_ROOT
324
325 %pretrans
326 if [ -d %{_libdir}/%{name}/dictionaries ] && [ ! -L %{_libdir}/%{name}/dictionaries ]; then
327         mv -v %{_libdir}/%{name}/dictionaries{,.rpmsave}
328 fi
329 for d in chrome defaults greprefs icons isp res; do
330         if [ -d %{_libdir}/%{name}/$d ] && [ ! -L %{_libdir}/%{name}/$d ]; then
331                 install -d %{_datadir}/%{name}
332                 mv %{_libdir}/%{name}/$d %{_datadir}/%{name}/$d
333         fi
334 done
335 exit 0
336
337 %files
338 %defattr(644,root,root,755)
339 %attr(755,root,root) %{_bindir}/icedove
340 %attr(755,root,root) %{_bindir}/mozilla-thunderbird
341 %attr(755,root,root) %{_bindir}/thunderbird
342 %dir %{_libdir}/%{name}
343 %{_libdir}/%{name}/*.ini
344 %dir %{_libdir}/%{name}/components
345 %attr(755,root,root) %{_libdir}/%{name}/components/*.so
346 %{_libdir}/%{name}/components/*.js
347 %{_libdir}/%{name}/components/*.xpt
348 %attr(755,root,root) %{_libdir}/%{name}/*.so
349 %attr(755,root,root) %{_libdir}/%{name}/*.sh
350 %attr(755,root,root) %{_libdir}/%{name}/*-bin
351 %attr(755,root,root) %{_libdir}/%{name}/mozilla-xremote-client
352 #%attr(755,root,root) %{_libdir}/%{name}/reg*
353 %attr(755,root,root) %{_libdir}/%{name}/icedove
354 %{_libdir}/%{name}/*.txt
355 #%attr(755,root,root) %{_libdir}/%{name}/x*
356
357 # symlinks
358 %{_libdir}/%{name}/chrome
359 %{_libdir}/%{name}/defaults
360 %{_libdir}/%{name}/dictionaries
361 %{_libdir}/%{name}/greprefs
362 #%{_libdir}/%{name}/icons
363 %{_libdir}/%{name}/isp
364 %{_libdir}/%{name}/res
365
366 %{_libdir}/%{name}/dependentlibs.list
367 #%{_libdir}/%{name}/updater
368 #%{_libdir}/%{name}/update.locale
369 #%{_pixmapsdir}/*.png
370 %{_desktopdir}/*.desktop
371
372 %dir %{_datadir}/%{name}
373 %{_datadir}/%{name}/chrome
374 %{_datadir}/%{name}/defaults
375 %{_datadir}/%{name}/greprefs
376 #%{_datadir}/%{name}/icons
377 %{_datadir}/%{name}/isp
378 %{_datadir}/%{name}/res
379
380 %dir %{_libdir}/%{name}/modules
381 %{_libdir}/%{name}/modules/*.js*
382 %dir %{_libdir}/%{name}/modules/activity
383 %{_libdir}/%{name}/modules/activity/*.js
384 %dir %{_libdir}/%{name}/modules/gloda
385 %{_libdir}/%{name}/modules/gloda/*.js
386
387 %dir %{_libdir}/%{name}/extensions
388 %{_libdir}/%{name}/extensions/{972ce4c6-7e08-4474-a285-3208198ce6fd}
389 %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}
390
391 %if %{with enigmail}
392 %files addon-enigmail
393 %defattr(644,root,root,755)
394 %{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}
395 %endif
This page took 0.05943 seconds and 4 git commands to generate.