]> git.pld-linux.org Git - packages/thunderbird.git/blob - icedove.spec
- dropped BR: myspell-devel (support removed), xorg-lib-libXft-devel,
[packages/thunderbird.git] / icedove.spec
1 #
2 # TODO:
3 # - CHECK all features of enigmail
4 # - separate spec for enigmail
5 # - remove -myspell.patch
6 # - package unpackaged files
7 # - update branding patch!!!
8 # - fix hunspell and enable
9 #
10 # Conditional builds
11 %bcond_without  enigmail        # don't build enigmail - GPG/PGP support
12 %bcond_without  gnomeui         # disable gnomeui support
13 %bcond_without  gnomevfs        # disable GNOME comp. (gconf+libgnome+gnomevfs) and gnomevfs ext.
14 %bcond_without  gnome           # disable all GNOME components (gnome+gnomeui+gnomevfs)
15 %bcond_without  ldap            # disable e-mail address lookups in LDAP directories
16 %bcond_without  lightning   # disable sunbird calendar
17 #
18 %if %{without gnome}
19 %undefine       with_gnomeui
20 %undefine       with_gnomevfs
21 %endif
22 %define         enigmail_ver            1.0.0
23
24 Summary:        Icedove - email client
25 Summary(pl.UTF-8):      Icedove - klient poczty
26 Name:           icedove
27 Version:        3.0.1
28 Release:        0.2
29 License:        MPL 1.1 or GPL v2+ or LGPL v2.1+
30 Group:          Applications/Networking
31 Source0:        http://releases.mozilla.org/pub/mozilla.org/thunderbird/releases/%{version}/source/thunderbird-%{version}.source.tar.bz2
32 # Source0-md5:  f004aa5ddf2a30b5df96e06df416b0c9
33 Source1:        http://www.mozilla-enigmail.org/download/source/enigmail-%{enigmail_ver}.tar.gz
34 # Source1-md5:  e3a6d379f1a72ac023751bdde2de750a
35 Source2:        %{name}-branding.tar.bz2
36 # Source2-md5:  e775b8cb658de32f30b403bc9b7950bf
37 Source3:        %{name}-rm_nonfree.sh
38 Source4:        %{name}.desktop
39 Source5:        %{name}.sh
40 Source6:        %{name}-enigmail.manifest
41 Patch0:         %{name}-branding.patch
42 Patch1:         %{name}-enigmail-shared.patch
43 Patch2:         %{name}-gcc.patch
44 Patch3:         %{name}-fonts.patch
45 Patch4:         %{name}-install.patch
46 Patch5:         %{name}-myspell.patch
47 Patch6:         %{name}-prefs.patch
48 Patch7:         %{name}-breakpad.patch
49 Patch8:         %{name}-libpng.patch
50 URL:            http://www.pld-linux.org/Packages/Icedove
51 %{?with_gnomevfs:BuildRequires: GConf2-devel >= 1.2.1}
52 BuildRequires:  automake
53 BuildRequires:  freetype-devel >= 1:2.1.8
54 %{?with_gnomevfs:BuildRequires: gnome-vfs2-devel >= 2.0}
55 BuildRequires:  gtk+2-devel >= 1:2.0.0
56 #BuildRequires: hunspell-devel
57 BuildRequires:  libIDL-devel >= 0.8.0
58 %{?with_gnomevfs:BuildRequires: libgnome-devel >= 2.0}
59 %{?with_gnomeui:BuildRequires:  libgnomeui-devel >= 2.2.0}
60 BuildRequires:  libjpeg-devel >= 6b
61 BuildRequires:  libpng-devel >= 1.2.0
62 BuildRequires:  libstdc++-devel
63 BuildRequires:  nspr-devel >= 1:4.8
64 BuildRequires:  nss-devel >= 1:3.12.0
65 BuildRequires:  pango-devel >= 1:1.1.0
66 BuildRequires:  pkgconfig
67 BuildRequires:  sed >= 4.0
68 BuildRequires:  startup-notification-devel >= 0.8
69 BuildRequires:  xorg-lib-libXext-devel
70 BuildRequires:  xorg-lib-libXinerama-devel
71 BuildRequires:  xorg-lib-libXt-devel
72 BuildRequires:  zip
73 Requires:       myspell-common
74 Requires:       nspr >= 1:4.6.1
75 Requires:       nss >= 1:3.11.3
76 Obsoletes:      mozilla-thunderbird
77 Obsoletes:      mozilla-thunderbird-dictionary-en-US
78 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
79
80 %define         filterout_cpp           -D_FORTIFY_SOURCE=[0-9]+
81
82 # iceweasel/icedove/iceape provide their own versions
83 %define         _noautoreqdep           libgfxpsshar.so libgkgfx.so libgtkxtbin.so libjsj.so libxpcom_compat.so libxpcom_core.so libxpistub.so
84 %define         _noautoprovfiles        %{_libdir}/%{name}/components
85 # we don't want these to satisfy xulrunner-devel
86 %define         _noautoprov             libgtkembedmoz.so libldap50.so libmozjs.so libprldap50.so libssldap50.so libxpcom.so libxul.so
87 # and as we don't provide them, don't require either
88 %define         _noautoreq              libgtkembedmoz.so libldap50.so libmozjs.so libprldap50.so libssldap50.so libxpcom.so libxul.so
89
90 %description
91 Icedove is an open-source,fast and portable email client.
92
93 %description -l pl.UTF-8
94 Icedove jest open sourcowym, szybkim i przenośnym klientem poczty.
95
96 %package addon-enigmail
97 Summary:        Extension for the authentication and encryption features provided by GnuPG
98 Summary(pl.UTF-8):      Rozszerzenie do uwierzytelniania i szyfrowania zapewnianego przez GnuPG
99 License:        MPL/LGPL
100 Group:          Applications/Networking
101 URL:            http://enigmail.mozdev.org/
102 Requires:       %{name} = %{version}-%{release}
103 Requires:       gnupg
104 Obsoletes:      mozilla-thunderbird-addon-enigmail
105
106 %description addon-enigmail
107 Enigmail is an extension to the Icedove mail client which allows users
108 to access the authentication and encryption features provided by
109 GnuPG.
110
111 Main Features:
112 - Encrypt/sign mail when sending, decrypt/authenticate received mail
113 - Support for inline-PGP (RFC 2440) and PGP/MIME (RFC 3156)
114 - Per-Account based encryption and signing defaults
115 - Per-Recipient rules for automated key selection, and
116   enabling/disabling encryption and signing
117 - OpenPGP key management interface
118
119 %description addon-enigmail -l pl.UTF-8
120 Enigmail to rozszerzenie klienta pocztowego Icedove pozwalające
121 użytkownikom na dostęp do uwierzytelniania i szyfrowania zapewnianego
122 przez GnuPG.
123
124 Główne możliwości:
125 - szyfrowanie/podpisywanie poczty przy wysyłaniu,
126   odszyfrowywanie/uwierzytelnianie poczty odebranej
127 - obsługa inline-PGP (RFC 2440) i PGP/MIME (RFC 3156)
128 - ustawienia domyślne szyfrowania i podpisywania dla każdego konta
129 - reguły automatycznego wyboru kluczy i włączenia szyfrowania oraz
130   podpisywania dla każdego adresata
131 - interfejs do zarządzania kluczami OpenPGP
132
133 %prep
134 %setup -q -c -a2
135 cd comm-1.9.1
136 %{?with_enigmail:tar xvfz %{SOURCE1} -C mailnews/extensions}
137 /bin/sh %{SOURCE3}
138 %patch0 -p2
139 %{?with_enigmail:%patch1 -p1}
140 %patch2 -p1
141 %patch3 -p1
142 %patch4 -p1
143 #%patch5 -p1
144 %patch6 -p0
145 %patch7 -p1
146 %patch8 -p1
147
148 %build
149 cd comm-1.9.1
150 export CFLAGS="%{rpmcflags} `%{_bindir}/pkg-config mozilla-nspr --cflags-only-I`"
151 export CXXFLAGS="%{rpmcflags} `%{_bindir}/pkg-config mozilla-nspr --cflags-only-I`"
152
153 cp -f %{_datadir}/automake/config.* mozilla/build/autoconf
154 cp -f %{_datadir}/automake/config.* mozilla/nsprpub/build/autoconf
155 cp -f %{_datadir}/automake/config.* directory/c-sdk/config/autoconf
156
157 cat << 'EOF' > .mozconfig
158 mk_add_options MOZ_OBJDIR=@TOPSRCDIR@/obj-%{_target_cpu}
159
160 # Options for 'configure' (same as command-line options).
161 ac_add_options --prefix=%{_prefix}
162 ac_add_options --exec-prefix=%{_exec_prefix}
163 ac_add_options --bindir=%{_bindir}
164 ac_add_options --sbindir=%{_sbindir}
165 ac_add_options --sysconfdir=%{_sysconfdir}
166 ac_add_options --datadir=%{_datadir}
167 ac_add_options --includedir=%{_includedir}
168 ac_add_options --libdir=%{_libdir}
169 ac_add_options --libexecdir=%{_libexecdir}
170 ac_add_options --localstatedir=%{_localstatedir}
171 ac_add_options --sharedstatedir=%{_sharedstatedir}
172 ac_add_options --mandir=%{_mandir}
173 ac_add_options --infodir=%{_infodir}
174 %if %{?debug:1}0
175 ac_add_options --disable-optimize
176 ac_add_options --enable-debug
177 ac_add_options --enable-debug-modules
178 ac_add_options --enable-debugger-info-modules
179 ac_add_options --enable-crash-on-assert
180 %else
181 ac_add_options --disable-debug
182 ac_add_options --disable-debug-modules
183 ac_add_options --disable-logging
184 ac_add_options --enable-optimize="%{rpmcflags} -Os"
185 %endif
186 %if %{with tests}
187 ac_add_options --enable-tests
188 %else
189 ac_add_options --disable-tests
190 %endif
191 %if %{with gnomeui}
192 ac_add_options --enable-gnomeui
193 %else
194 ac_add_options --disable-gnomeui
195 %endif
196 %if %{with gnomevfs}
197 ac_add_options --enable-gnomevfs
198 %else
199 ac_add_options --disable-gnomevfs
200 %endif
201 %if %{with ldap}
202 ac_add_options --enable-ldap
203 %else
204 ac_add_options --disable-ldap
205 %endif
206 ac_add_options --disable-crashreporter
207 ac_add_options --disable-updater
208 ac_add_options --disable-xterm-updates
209 ac_add_options --enable-ldap
210 ac_add_options --enable-postscript
211 ac_add_options --enable-startup-notification
212 %if %{with lightning}
213 ac_add_options --enable-calendar
214 %else
215 ac_add_options --disable-calendar
216 %endif
217 ac_add_options --disable-installer
218 ac_add_options --disable-jsd
219 ac_add_options --disable-xprint
220 ac_add_options --disable-permissions
221 ac_add_options --disable-pref-extensions
222 ac_add_options --enable-canvas
223 ac_add_options --enable-crypto
224 ac_add_options --enable-default-toolkit="gtk2"
225 ac_add_options --enable-mathml
226 ac_add_options --enable-optimize="%{rpmcflags}"
227 ac_add_options --enable-pango
228 ac_add_options --enable-reorder
229 ac_add_options --enable-static
230 ac_add_options --disable-strip
231 ac_add_options --disable-strip-libs
232 ac_add_options --enable-system-cairo
233 #ac_add_options --enable-system-hunspell
234 ac_add_options --enable-svg
235 ac_add_options --enable-xft
236 ac_add_options --enable-application=mail
237 ac_add_options --enable-default-toolkit=cairo-gtk2
238 ac_add_options --enable-xinerama
239 ac_add_options --with-system-jpeg
240 ac_add_options --with-system-nspr
241 ac_add_options --with-system-nss
242 ac_add_options --with-system-png
243 ac_add_options --with-system-zlib
244 ac_add_options --with-pthreads
245 ac_add_options --enable-single-profile
246 ac_add_options --disable-profilesharing
247 ac_add_options --with-distribution-id=org.pld-linux
248 #ac_add_options --with-branding=icedove/branding
249 ac_add_options --with-default-mozilla-five-home=%{_libdir}/%{name}
250 EOF
251
252 %{__make} -j1 -f client.mk build \
253         STRIP="/bin/true" \
254         CC="%{__cc}" \
255         CXX="%{__cxx}"
256
257 %if %{with enigmail}
258 cd mailnews/extensions/enigmail
259 ./makemake -r
260 %{__make} -C ../../../obj-%{_target_cpu}/mailnews/extensions/enigmail \
261         STRIP="/bin/true" \
262         CC="%{__cc}" \
263         CXX="%{__cxx}"
264 %endif
265
266 %install
267 rm -rf $RPM_BUILD_ROOT
268 install -d $RPM_BUILD_ROOT{%{_bindir},%{_libdir},%{_pixmapsdir},%{_desktopdir}} \
269                $RPM_BUILD_ROOT%{_datadir}/%{name}
270 install -d $RPM_BUILD_ROOT%{_libdir}/%{name}
271
272 cd comm-1.9.1
273 %{__make} -C obj-%{_target_cpu}/mail/installer stage-package \
274         DESTDIR=$RPM_BUILD_ROOT \
275         MOZ_PKG_APPDIR=%{_libdir}/%{name} \
276         PKG_SKIP_STRIP=1
277
278 # move arch independant ones to datadir
279 mv $RPM_BUILD_ROOT%{_libdir}/%{name}/chrome $RPM_BUILD_ROOT%{_datadir}/%{name}/chrome
280 mv $RPM_BUILD_ROOT%{_libdir}/%{name}/defaults $RPM_BUILD_ROOT%{_datadir}/%{name}/defaults
281 mv $RPM_BUILD_ROOT%{_libdir}/%{name}/greprefs $RPM_BUILD_ROOT%{_datadir}/%{name}/greprefs
282 #mv $RPM_BUILD_ROOT%{_libdir}/%{name}/icons $RPM_BUILD_ROOT%{_datadir}/%{name}/icons
283 mv $RPM_BUILD_ROOT%{_libdir}/%{name}/isp $RPM_BUILD_ROOT%{_datadir}/%{name}/isp
284 mv $RPM_BUILD_ROOT%{_libdir}/%{name}/res $RPM_BUILD_ROOT%{_datadir}/%{name}/res
285 ln -s ../../share/%{name}/chrome $RPM_BUILD_ROOT%{_libdir}/%{name}/chrome
286 ln -s ../../share/%{name}/defaults $RPM_BUILD_ROOT%{_libdir}/%{name}/defaults
287 ln -s ../../share/%{name}/greprefs $RPM_BUILD_ROOT%{_libdir}/%{name}/greprefs
288 #ln -s ../../share/%{name}/icons $RPM_BUILD_ROOT%{_libdir}/%{name}/icons
289 ln -s ../../share/%{name}/isp $RPM_BUILD_ROOT%{_libdir}/%{name}/isp
290 ln -s ../../share/%{name}/res $RPM_BUILD_ROOT%{_libdir}/%{name}/res
291
292 rm -rf $RPM_BUILD_ROOT%{_libdir}/%{name}/dictionaries
293 ln -s %{_datadir}/myspell $RPM_BUILD_ROOT%{_libdir}/%{name}/dictionaries
294
295 %{__sed} -e 's,@LIBDIR@,%{_libdir},' %{SOURCE5} > $RPM_BUILD_ROOT%{_bindir}/icedove
296 ln -s %{name} $RPM_BUILD_ROOT%{_bindir}/thunderbird
297 ln -s %{name} $RPM_BUILD_ROOT%{_bindir}/mozilla-thunderbird
298
299 install %{SOURCE4} $RPM_BUILD_ROOT%{_desktopdir}/%{name}.desktop
300
301 %if %{with enigmail}
302 _enig_dir=$RPM_BUILD_ROOT%{_libdir}/%{name}/extensions/\{847b3a00-7ab1-11d4-8f02-006008948af5\}
303 install -d $_enig_dir/chrome
304 install -d $_enig_dir/components
305 install -d $_enig_dir/defaults/preferences
306 mv -f $RPM_BUILD_ROOT%{_libdir}/%{name}/chrome/enigmail.jar $_enig_dir/chrome
307 mv -f $RPM_BUILD_ROOT%{_libdir}/%{name}/components/enig* $_enig_dir/components
308 mv -f $RPM_BUILD_ROOT%{_libdir}/%{name}/components/libenigmime.so $_enig_dir/components
309 mv -f $RPM_BUILD_ROOT%{_libdir}/%{name}/components/ipc.xpt $_enig_dir/components
310 mv -f $RPM_BUILD_ROOT%{_libdir}/%{name}/defaults/preferences/enigmail.js $_enig_dir/defaults/preferences
311 cp -f mailnews/extensions/enigmail/package/install.rdf $_enig_dir
312 rm -rf $RPM_BUILD_ROOT%{_libdir}/%{name}/defaults/preferences
313 rm -f $RPM_BUILD_ROOT%{_libdir}/%{name}/chrome/enigmail-en-US.jar
314 rm -f $RPM_BUILD_ROOT%{_libdir}/%{name}/chrome/enigmail-skin.jar
315 rm -f $RPM_BUILD_ROOT%{_libdir}/%{name}/chrome/enigmime.jar
316 rm -rf $RPM_BUILD_ROOT%{_libdir}/%{name}/components/enig*
317 rm -f $RPM_BUILD_ROOT%{_libdir}/%{name}/components/libenigmime.so
318 rm -f $RPM_BUILD_ROOT%{_libdir}/%{name}/components/ipc.xpt
319 cp -f %{SOURCE6} $_enig_dir/chrome.manifest
320 #cp -f icedove/branding/content/icon64.png $RPM_BUILD_ROOT%{_pixmapsdir}/icedove.png
321 %endif
322
323 # win32 stuff
324 rm -f $RPM_BUILD_ROOT%{_libdir}/%{name}/dirver
325
326 %clean
327 rm -rf $RPM_BUILD_ROOT
328
329 %pretrans
330 if [ -d %{_libdir}/%{name}/dictionaries ] && [ ! -L %{_libdir}/%{name}/dictionaries ]; then
331         mv -v %{_libdir}/%{name}/dictionaries{,.rpmsave}
332 fi
333 for d in chrome defaults greprefs icons isp res; do
334         if [ -d %{_libdir}/%{name}/$d ] && [ ! -L %{_libdir}/%{name}/$d ]; then
335                 install -d %{_datadir}/%{name}
336                 mv %{_libdir}/%{name}/$d %{_datadir}/%{name}/$d
337         fi
338 done
339 exit 0
340
341 %files
342 %defattr(644,root,root,755)
343 %attr(755,root,root) %{_bindir}/icedove
344 %attr(755,root,root) %{_bindir}/mozilla-thunderbird
345 %attr(755,root,root) %{_bindir}/thunderbird
346 %dir %{_libdir}/%{name}
347 %{_libdir}/%{name}/*.ini
348 %dir %{_libdir}/%{name}/components
349 %attr(755,root,root) %{_libdir}/%{name}/components/*.so
350 %{_libdir}/%{name}/components/*.js
351 %{_libdir}/%{name}/components/*.xpt
352 %attr(755,root,root) %{_libdir}/%{name}/*.so
353 %attr(755,root,root) %{_libdir}/%{name}/*.sh
354 %attr(755,root,root) %{_libdir}/%{name}/*-bin
355 %attr(755,root,root) %{_libdir}/%{name}/mozilla-xremote-client
356 #%attr(755,root,root) %{_libdir}/%{name}/reg*
357 %attr(755,root,root) %{_libdir}/%{name}/icedove
358 %{_libdir}/%{name}/*.txt
359 #%attr(755,root,root) %{_libdir}/%{name}/x*
360
361 # symlinks
362 %{_libdir}/%{name}/chrome
363 %{_libdir}/%{name}/defaults
364 %{_libdir}/%{name}/dictionaries
365 %{_libdir}/%{name}/greprefs
366 #%{_libdir}/%{name}/icons
367 %{_libdir}/%{name}/isp
368 %{_libdir}/%{name}/res
369
370 %{_libdir}/%{name}/dependentlibs.list
371 #%{_libdir}/%{name}/updater
372 #%{_libdir}/%{name}/update.locale
373 #%{_pixmapsdir}/*.png
374 %{_desktopdir}/*.desktop
375
376 %dir %{_datadir}/%{name}
377 %{_datadir}/%{name}/chrome
378 %{_datadir}/%{name}/defaults
379 %{_datadir}/%{name}/greprefs
380 #%{_datadir}/%{name}/icons
381 %{_datadir}/%{name}/isp
382 %{_datadir}/%{name}/res
383
384 %dir %{_libdir}/%{name}/modules
385 %{_libdir}/%{name}/modules/*.js*
386 %dir %{_libdir}/%{name}/modules/activity
387 %{_libdir}/%{name}/modules/activity/*.js
388 %dir %{_libdir}/%{name}/modules/gloda
389 %{_libdir}/%{name}/modules/gloda/*.js
390
391 %dir %{_libdir}/%{name}/extensions
392 %{_libdir}/%{name}/extensions/{972ce4c6-7e08-4474-a285-3208198ce6fd}
393 %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}
394
395 %if %{with enigmail}
396 %files addon-enigmail
397 %defattr(644,root,root,755)
398 %{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}
399 %endif
This page took 0.051074 seconds and 4 git commands to generate.