]> git.pld-linux.org Git - packages/thunderbird.git/blob - icedove.spec
Updated icedove to 14.0
[packages/thunderbird.git] / icedove.spec
1 # TODO:
2 # - separate spec for enigmail
3 # - build with system mozldap
4 #
5 # Conditional builds
6 %bcond_without  enigmail        # don't build enigmail - GPG/PGP support
7 %bcond_without  gnomeui         # disable gnomeui support
8 %bcond_without  gnome           # alias for gnomeui
9 %bcond_without  ldap            # disable e-mail address lookups in LDAP directories
10 %bcond_without  lightning       # disable Sunbird/Lightning calendar
11 %bcond_with     xulrunner       # system xulrunner
12 %bcond_with     crashreporter   # report crashes to crash-stats.mozilla.com
13
14 %if %{without gnome}
15 %undefine       with_gnomeui
16 %endif
17
18 %if 0%{?_enable_debug_packages} != 1
19 %undefine       crashreporter
20 %endif
21
22 %define         enigmail_ver    1.4.3
23 %define         nspr_ver        4.9
24 %define         nss_ver         3.13.3
25
26 %define         xulrunner_ver   2:13.0
27
28 %if %{without xulrunner}
29 # The actual sqlite version (see RHBZ#480989):
30 %define         sqlite_build_version %(pkg-config --silence-errors --modversion sqlite3 2>/dev/null || echo ERROR)
31 %endif
32
33 Summary:        Icedove - email client
34 Summary(pl.UTF-8):      Icedove - klient poczty
35 Name:           icedove
36 Version:        14.0
37 Release:        1
38 License:        MPL 1.1 or GPL v2+ or LGPL v2.1+
39 Group:          X11/Applications/Networking
40 Source0:        http://releases.mozilla.org/pub/mozilla.org/thunderbird/releases/%{version}/source/thunderbird-%{version}.source.tar.bz2
41 # Source0-md5:  64dcfaa0aa47aa5fd8588090503fac9d
42 Source1:        http://www.mozilla-enigmail.org/download/source/enigmail-%{enigmail_ver}.tar.gz
43 # Source1-md5:  4a253db11436a32ef81d5917c4ee6e25
44 Source2:        %{name}-branding.tar.bz2
45 # Source2-md5:  2da351522bdd7f4a3bd8aaff4c776976
46 Source3:        %{name}-rm_nonfree.sh
47 Source4:        %{name}.desktop
48 Source5:        %{name}.sh
49 Patch0:         %{name}-branding.patch
50 Patch1:         %{name}-enigmail-shared.patch
51 Patch2:         %{name}-system-xulrunner.patch
52 Patch3:         %{name}-fonts.patch
53 Patch4:         %{name}-install.patch
54 Patch5:         %{name}-hunspell.patch
55 Patch6:         %{name}-prefs.patch
56 Patch7:         system-mozldap.patch
57 Patch8:         %{name}-makefile.patch
58 Patch9:         system-cairo.patch
59 Patch10:        %{name}-extensiondir.patch
60 Patch11:        crashreporter.patch
61 Patch12:        no-subshell.patch
62 URL:            http://www.pld-linux.org/Packages/Icedove
63 BuildRequires:  GConf2-devel >= 1.2.1
64 BuildRequires:  alsa-lib-devel
65 BuildRequires:  automake
66 BuildRequires:  bzip2-devel
67 BuildRequires:  cairo-devel >= 1.10
68 BuildRequires:  dbus-glib-devel >= 0.60
69 BuildRequires:  freetype-devel >= 1:2.1.8
70 BuildRequires:  glib2-devel >= 2.0
71 BuildRequires:  gtk+2-devel >= 2:2.10.0
72 BuildRequires:  hunspell-devel
73 BuildRequires:  libIDL-devel >= 0.8.0
74 %{?with_gnomeui:BuildRequires:  libgnome-devel >= 2.0}
75 %{?with_gnomeui:BuildRequires:  libgnome-keyring-devel}
76 %{?with_gnomeui:BuildRequires:  libgnomeui-devel >= 2.2.0}
77 BuildRequires:  libiw-devel
78 BuildRequires:  libjpeg-devel >= 6b
79 BuildRequires:  libnotify-devel >= 0.4
80 BuildRequires:  libpng-devel >= 1.4.1
81 BuildRequires:  libstdc++-devel
82 BuildRequires:  nspr-devel >= 1:%{nspr_ver}
83 BuildRequires:  nss-devel >= 1:%{nss_ver}
84 BuildRequires:  pango-devel >= 1:1.14.0
85 BuildRequires:  perl-base >= 1:5.6
86 BuildRequires:  pkgconfig
87 BuildRequires:  python >= 1:2.5
88 BuildRequires:  sed >= 4.0
89 BuildRequires:  sqlite3-devel >= 3.7.4
90 BuildRequires:  startup-notification-devel >= 0.8
91 BuildRequires:  xorg-lib-libXext-devel
92 BuildRequires:  xorg-lib-libXinerama-devel
93 BuildRequires:  xorg-lib-libXt-devel
94 BuildRequires:  yasm
95 BuildRequires:  zip
96 %if %{with xulrunner}
97 BuildRequires:  xulrunner-devel >= %{xulrunner_ver}
98 %else
99 Requires:       myspell-common
100 Requires:       nspr >= 1:%{nspr_ver}
101 Requires:       nss >= 1:%{nss_ver}
102 Requires:       sqlite3 >= %{sqlite_build_version}
103 %endif
104 Requires(post): mktemp >= 1.5-18
105 %if %{with xulrunner}
106 %requires_eq_to xulrunner xulrunner-devel
107 %endif
108 Obsoletes:      mozilla-thunderbird
109 Obsoletes:      mozilla-thunderbird-dictionary-en-US
110 Conflicts:      icedove-lang-resources < %{version}
111 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
112
113 %define         filterout_cpp           -D_FORTIFY_SOURCE=[0-9]+
114
115 # iceweasel/icedove/iceape provide their own versions
116 %define         _noautoprovfiles        %{_libdir}/%{name}/components
117 %if %{without xulrunner}
118 # we don't want these to satisfy packages depending on xulrunner
119 %define         _noautoprov             libmozalloc.so libxpcom.so libxul.so
120 # and as we don't provide them, don't require either
121 %define         _noautoreq              libmozalloc.so libxpcom.so libxul.so
122 %endif
123
124 %define         topdir          %{_builddir}/%{name}-%{version}
125 %define         objdir          %{topdir}/obj-%{_target_cpu}
126
127 %description
128 Icedove is an open-source, fast and portable email client.
129
130 %description -l pl.UTF-8
131 Icedove jest mającym otwarte źródła, szybkim i przenośnym klientem
132 poczty.
133
134 %package addon-lightning
135 Summary:        An integrated calendar for Icedove
136 Summary(pl.UTF-8):      Zintegrowany kalendarz dla Icedove
137 License:        MPL 1.1 or GPL v2+ or LGPL v2.1+
138 Group:          Applications/Networking
139 Requires:       %{name} = %{version}-%{release}
140
141 %description addon-lightning
142 Lightning is an calendar extension to Icedove email client.
143
144 %description addon-lightning -l pl.UTF-8
145 Lightning to rozszerzenie do klienta poczty Icedove dodające
146 funkcjonalność kalendarza.
147
148 %package addon-enigmail
149 Summary:        Extension for the authentication and encryption features provided by GnuPG
150 Summary(pl.UTF-8):      Rozszerzenie do uwierzytelniania i szyfrowania zapewnianego przez GnuPG
151 License:        MPL/LGPL
152 Group:          Applications/Networking
153 URL:            http://enigmail.mozdev.org/
154 Requires:       %{name} = %{version}-%{release}
155 Requires:       gnupg
156 Obsoletes:      mozilla-thunderbird-addon-enigmail
157
158 %description addon-enigmail
159 Enigmail is an extension to the Icedove mail client which allows users
160 to access the authentication and encryption features provided by
161 GnuPG.
162
163 Main Features:
164 - Encrypt/sign mail when sending, decrypt/authenticate received mail
165 - Support for inline-PGP (RFC 2440) and PGP/MIME (RFC 3156)
166 - Per-Account based encryption and signing defaults
167 - Per-Recipient rules for automated key selection, and
168   enabling/disabling encryption and signing
169 - OpenPGP key management interface
170
171 %description addon-enigmail -l pl.UTF-8
172 Enigmail to rozszerzenie klienta pocztowego Icedove pozwalające
173 użytkownikom na dostęp do uwierzytelniania i szyfrowania zapewnianego
174 przez GnuPG.
175
176 Główne możliwości:
177 - szyfrowanie/podpisywanie poczty przy wysyłaniu,
178   odszyfrowywanie/uwierzytelnianie poczty odebranej
179 - obsługa inline-PGP (RFC 2440) i PGP/MIME (RFC 3156)
180 - ustawienia domyślne szyfrowania i podpisywania dla każdego konta
181 - reguły automatycznego wyboru kluczy i włączenia szyfrowania oraz
182   podpisywania dla każdego adresata
183 - interfejs do zarządzania kluczami OpenPGP
184
185 %prep
186 %setup -qc
187 mv comm-release mozilla
188 %setup -q -T -D -a2
189 cd mozilla
190 %{?with_enigmail:%{__gzip} -dc %{SOURCE1} | %{__tar} -xf - -C mailnews/extensions}
191 /bin/sh %{SOURCE3}
192 %patch0 -p1
193 %{?with_enigmail:%patch1 -p1}
194 %{?with_xulrunner:%patch2 -p1}
195 %patch3 -p1
196 %patch4 -p1
197 %patch6 -p1
198 %patch7 -p1
199 %patch8 -p2
200 %patch9 -p1
201 %patch10 -p2
202 %patch11 -p2
203 %patch12 -p1
204
205 %build
206 cd mozilla
207 cp -f %{_datadir}/automake/config.* mozilla/build/autoconf
208 cp -f %{_datadir}/automake/config.* mozilla/nsprpub/build/autoconf
209 cp -f %{_datadir}/automake/config.* ldap/sdks/c-sdk/config/autoconf
210
211 cat << EOF > .mozconfig
212 mk_add_options MOZ_OBJDIR=%{objdir}
213
214 export CFLAGS="%{rpmcflags}"
215 export CXXFLAGS="%{rpmcflags}"
216
217 %if %{with crashreporter}
218 export MOZ_DEBUG_SYMBOLS=1
219 %endif
220
221 # Options for 'configure' (same as command-line options).
222 ac_add_options --prefix=%{_prefix}
223 ac_add_options --exec-prefix=%{_exec_prefix}
224 ac_add_options --bindir=%{_bindir}
225 ac_add_options --sbindir=%{_sbindir}
226 ac_add_options --sysconfdir=%{_sysconfdir}
227 ac_add_options --datadir=%{_datadir}
228 ac_add_options --includedir=%{_includedir}
229 ac_add_options --libdir=%{_libdir}
230 ac_add_options --libexecdir=%{_libexecdir}
231 ac_add_options --localstatedir=%{_localstatedir}
232 ac_add_options --sharedstatedir=%{_sharedstatedir}
233 ac_add_options --mandir=%{_mandir}
234 ac_add_options --infodir=%{_infodir}
235 %if %{?debug:1}0
236 ac_add_options --disable-optimize
237 ac_add_options --enable-debug
238 ac_add_options --enable-debug-modules
239 ac_add_options --enable-debugger-info-modules
240 ac_add_options --enable-crash-on-assert
241 %else
242 ac_add_options --disable-debug
243 ac_add_options --disable-debug-modules
244 ac_add_options --disable-logging
245 ac_add_options --enable-optimize="%{rpmcflags} -Os"
246 %endif
247 ac_add_options --disable-strip
248 ac_add_options --disable-strip-libs
249 %if %{with tests}
250 ac_add_options --enable-tests
251 %else
252 ac_add_options --disable-tests
253 %endif
254 ac_add_options --enable-gio
255 %if %{with gnomeui}
256 ac_add_options --enable-gnomeui
257 %else
258 ac_add_options --disable-gnomeui
259 %endif
260 ac_add_options --disable-gnomevfs
261 %if %{with ldap}
262 ac_add_options --enable-ldap
263 ac_add_options --with-system-ldap
264 %else
265 ac_add_options --disable-ldap
266 %endif
267 %if %{with crashreporter}
268 ac_add_options --enable-crashreporter
269 %else
270 ac_add_options --disable-crashreporter
271 %endif
272 ac_add_options --disable-xterm-updates
273 ac_add_options --enable-postscript
274 %if %{with lightning}
275 ac_add_options --enable-calendar
276 %else
277 ac_add_options --disable-calendar
278 %endif
279 ac_add_options --disable-installer
280 ac_add_options --disable-updater
281 ac_add_options --disable-xprint
282 ac_add_options --disable-permissions
283 ac_add_options --disable-pref-extensions
284 ac_add_options --enable-canvas
285 ac_add_options --enable-crypto
286 ac_add_options --enable-mathml
287 ac_add_options --enable-pango
288 ac_add_options --enable-reorder
289 ac_add_options --enable-startup-notification
290 ac_add_options --enable-svg
291 ac_add_options --enable-system-cairo
292 ac_add_options --enable-system-hunspell
293 ac_add_options --enable-system-sqlite
294 ac_add_options --enable-xft
295 ac_add_options --enable-application=mail
296 ac_add_options --enable-default-toolkit=cairo-gtk2
297 ac_add_options --enable-xinerama
298 ac_add_options --with-distribution-id=org.pld-linux
299 ac_add_options --with-branding=icedove/branding
300 %if %{with xulrunner}
301 ac_add_options --enable-shared-js
302 ac_add_options --with-libxul-sdk=$(pkg-config --variable=sdkdir libxul)
303 ac_add_options --with-system-libxul
304 %endif
305 ac_add_options --with-pthreads
306 ac_add_options --with-system-bz2
307 ac_add_options --with-system-jpeg
308 ac_add_options --with-system-nspr
309 ac_add_options --with-system-nss
310 ac_add_options --with-system-png
311 ac_add_options --with-system-zlib
312 ac_add_options --enable-single-profile
313 ac_add_options --disable-profilesharing
314 ac_add_options --with-default-mozilla-five-home=%{_libdir}/%{name}
315 EOF
316
317 %{__make} -j1 -f client.mk build \
318         STRIP="/bin/true" \
319         MOZ_MAKE_FLAGS="%{?_smp_mflags}" \
320         CC="%{__cc}" \
321         CXX="%{__cxx}"
322
323 %if %{with crashreporter}
324 # create debuginfo for crash-stats.mozilla.com
325 %{__make} -j1 -C obj-%{_target_cpu} buildsymbols
326 %endif
327
328 %if %{with enigmail}
329 cd mailnews/extensions/enigmail
330 ./makemake -r -o %{objdir}
331 %{__make} -C %{objdir}/mailnews/extensions/enigmail \
332         STRIP="/bin/true" \
333         CC="%{__cc}" \
334         CXX="%{__cxx}"
335
336 %{__make} -C %{objdir}/mailnews/extensions/enigmail xpi \
337         STRIP="/bin/true" \
338         CC="%{__cc}" \
339         CXX="%{__cxx}"
340 %endif
341
342 %install
343 rm -rf $RPM_BUILD_ROOT
344 install -d $RPM_BUILD_ROOT{%{_bindir},%{_libdir}/%{name},%{_datadir}/%{name},%{_pixmapsdir},%{_desktopdir}}
345
346 cd %{objdir}
347 %{__make} -C mail/installer stage-package \
348         DESTDIR=$RPM_BUILD_ROOT \
349         MOZ_PKG_DIR=%{_libdir}/%{name} \
350         PKG_SKIP_STRIP=1
351
352 %if %{with xulrunner}
353 # needed to find mozilla runtime
354 ln -s ../xulrunner $RPM_BUILD_ROOT%{_libdir}/%{name}/xulrunner
355 %endif
356  
357 # Enable crash reporter for Thunderbird application
358 %if %{with crashreporter}
359 %{__sed} -i -e 's/\[Crash Reporter\]/[Crash Reporter]\nEnabled=1/' $RPM_BUILD_ROOT%{_libdir}/%{name}/application.ini
360
361 # Add debuginfo for crash-stats.mozilla.com
362 install -d $RPM_BUILD_ROOT%{_exec_prefix}/lib/debug%{_libdir}/%{name}
363 cp -a mozilla/dist/%{name}-%{version}.en-US.linux-*.crashreporter-symbols.zip $RPM_BUILD_ROOT%{_prefix}/lib/debug%{_libdir}/%{name}
364 %endif
365
366 # copy manually lightning files, somewhy they are not installed by make
367 cp -a mozilla/dist/bin/extensions/calendar-timezones@mozilla.org \
368         mozilla/dist/bin/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103} \
369         $RPM_BUILD_ROOT%{_libdir}/%{name}/extensions
370
371 # move arch independant ones to datadir
372 mv $RPM_BUILD_ROOT%{_libdir}/%{name}/chrome $RPM_BUILD_ROOT%{_datadir}/%{name}/chrome
373 mv $RPM_BUILD_ROOT%{_libdir}/%{name}/defaults $RPM_BUILD_ROOT%{_datadir}/%{name}/defaults
374 mv $RPM_BUILD_ROOT%{_libdir}/%{name}/isp $RPM_BUILD_ROOT%{_datadir}/%{name}/isp
375 mv $RPM_BUILD_ROOT%{_libdir}/%{name}/modules $RPM_BUILD_ROOT%{_datadir}/%{name}/modules
376 mv $RPM_BUILD_ROOT%{_libdir}/%{name}/searchplugins $RPM_BUILD_ROOT%{_datadir}/%{name}/searchplugins
377 ln -s ../../share/%{name}/chrome $RPM_BUILD_ROOT%{_libdir}/%{name}/chrome
378 ln -s ../../share/%{name}/defaults $RPM_BUILD_ROOT%{_libdir}/%{name}/defaults
379 ln -s ../../share/%{name}/isp $RPM_BUILD_ROOT%{_libdir}/%{name}/isp
380 ln -s ../../share/%{name}/modules $RPM_BUILD_ROOT%{_libdir}/%{name}/modules
381 ln -s ../../share/%{name}/searchplugins $RPM_BUILD_ROOT%{_libdir}/%{name}/searchplugins
382 %if %{without xulrunner}
383 mv $RPM_BUILD_ROOT%{_libdir}/%{name}/res $RPM_BUILD_ROOT%{_datadir}/%{name}/res
384 ln -s ../../share/%{name}/res $RPM_BUILD_ROOT%{_libdir}/%{name}/res
385 %endif
386
387 # dir for arch independant extensions besides arch dependant extensions
388 # see mozilla/xpcom/build/nsXULAppAPI.h
389 # XRE_SYS_LOCAL_EXTENSION_PARENT_DIR and XRE_SYS_SHARE_EXTENSION_PARENT_DIR
390 install -d $RPM_BUILD_ROOT%{_datadir}/%{name}/extensions
391
392 %if %{without xulrunner}
393 %{__rm} -r $RPM_BUILD_ROOT%{_libdir}/%{name}/dictionaries
394 ln -s %{_datadir}/myspell $RPM_BUILD_ROOT%{_libdir}/%{name}/dictionaries
395 %{__rm} -r $RPM_BUILD_ROOT%{_libdir}/%{name}/hyphenation
396 ln -s %{_datadir}/myspell $RPM_BUILD_ROOT%{_libdir}/%{name}/hyphenation
397 %endif
398
399 %{__sed} -e "s|%MOZAPPDIR%|%{_libdir}/%{name}|" \
400          -e "s|%MOZ_APP_DISPLAYNAME%|Icedove|" \
401         %{topdir}/mozilla/mozilla/build/unix/mozilla.in > $RPM_BUILD_ROOT%{_libdir}/%{name}/icedove
402
403 %{__sed} -e 's,@LIBDIR@,%{_libdir},' %{SOURCE5} > $RPM_BUILD_ROOT%{_bindir}/icedove
404 ln -s %{name} $RPM_BUILD_ROOT%{_bindir}/thunderbird
405 ln -s %{name} $RPM_BUILD_ROOT%{_bindir}/mozilla-thunderbird
406
407 cp -p %{SOURCE4} $RPM_BUILD_ROOT%{_desktopdir}/%{name}.desktop
408 cp -p %{topdir}/mozilla/icedove/branding/content/icon64.png $RPM_BUILD_ROOT%{_pixmapsdir}/%{name}.png
409
410 # files created by regxpcom -register in post
411 touch $RPM_BUILD_ROOT%{_libdir}/%{name}/components/compreg.dat
412 touch $RPM_BUILD_ROOT%{_libdir}/%{name}/components/xpti.dat
413 cat << 'EOF' > $RPM_BUILD_ROOT%{_libdir}/%{name}/register
414 #!/bin/sh
415 umask 022
416 # make temporary HOME, as it attempts to touch files in $HOME/.mozilla
417 # dangerous if you run this with sudo with keep_env += HOME
418 # also TMPDIR could be pointing to sudo user's homedir so we reset that too.
419 t=$(mktemp -d)
420 %{__rm} -f %{_libdir}/%{name}/components/{compreg,xpti}.dat
421 TMPDIR= TMP= HOME=$t %{_libdir}/%{name}/icedove -register
422 rm -rf $t
423 EOF
424 chmod a+rx $RPM_BUILD_ROOT%{_libdir}/%{name}/register
425
426 %if %{with enigmail}
427 ext_dir=$RPM_BUILD_ROOT%{_libdir}/%{name}/extensions/\{847b3a00-7ab1-11d4-8f02-006008948af5\}
428 install -d $ext_dir/{chrome,components,defaults/preferences,modules}
429 cd mozilla/dist/bin
430 cp -rfLp chrome/enigmail.jar $ext_dir/chrome
431 cp -rfLp components/enig* $ext_dir/components
432 cp -rfLp components/libenigmime.so $ext_dir/components
433 cp -rfLp components/libipc.so $ext_dir/components
434 cp -rfLp components/ipc.xpt $ext_dir/components
435 cp -rfLp defaults/preferences/enigmail.js $ext_dir/defaults/preferences
436 cp -rfLp modules/{commonFuncs,enigmailCommon,keyManagement,pipeConsole,pipeTransport,subprocess}.jsm $ext_dir/modules
437 cp -rfLp modules/{subprocess_worker_unix,subprocess_worker_win}.js $ext_dir/modules
438 cd -
439 cp -p %{topdir}/mozilla/mailnews/extensions/enigmail/package/install.rdf $ext_dir
440 cp -p %{topdir}/mozilla/mailnews/extensions/enigmail/package/chrome.manifest $ext_dir/chrome.manifest
441 %endif
442
443 # never package these. always remove
444 # nss
445 %{__rm} -f $RPM_BUILD_ROOT%{_libdir}/%{name}/lib{freebl3,nss3,nssckbi,nssdbm3,nssutil3,smime3,softokn3,ssl3}.*
446 # nspr
447 %{__rm} -f $RPM_BUILD_ROOT%{_libdir}/%{name}/lib{nspr4,plc4,plds4}.so
448 # mozldap
449 %{__rm} -f $RPM_BUILD_ROOT%{_libdir}/%{name}/lib{ldap,ldif,prldap,ssldap}60.so
450 # testpilot quiz
451 %{__rm} -f $RPM_BUILD_ROOT%{_libdir}/%{name}/distribution/extensions/tbtestpilot@labs.mozilla.com.xpi
452
453 %clean
454 rm -rf $RPM_BUILD_ROOT
455
456 %pretrans
457 if [ -d %{_libdir}/%{name}/dictionaries ] && [ ! -L %{_libdir}/%{name}/dictionaries ]; then
458         mv -v %{_libdir}/%{name}/dictionaries{,.rpmsave}
459 fi
460 for d in chrome defaults icons isp modules res searchplugins; do
461         if [ -d %{_libdir}/%{name}/$d ] && [ ! -L %{_libdir}/%{name}/$d ]; then
462                 install -d %{_datadir}/%{name}
463                 mv %{_libdir}/%{name}/$d %{_datadir}/%{name}/$d
464         fi
465 done
466 exit 0
467
468 %post
469 %{_libdir}/%{name}/register || :
470
471 %files
472 %defattr(644,root,root,755)
473 %attr(755,root,root) %{_bindir}/icedove
474 %attr(755,root,root) %{_bindir}/mozilla-thunderbird
475 %attr(755,root,root) %{_bindir}/thunderbird
476 %dir %{_libdir}/%{name}
477 %{_libdir}/%{name}/application.ini
478 %{_libdir}/%{name}/blocklist.xml
479 %{_libdir}/%{name}/chrome.manifest
480 %dir %{_libdir}/%{name}/components
481 %{_libdir}/%{name}/components/*.js
482 %{_libdir}/%{name}/components/*.xpt
483 %{_libdir}/%{name}/components/components.manifest
484 %{_libdir}/%{name}/components/interfaces.manifest
485 %attr(755,root,root) %{_libdir}/%{name}/*.sh
486 %attr(755,root,root) %{_libdir}/%{name}/*-bin
487 %attr(755,root,root) %{_libdir}/%{name}/icedove
488 %attr(755,root,root) %{_libdir}/%{name}/register
489 %if %{without xulrunner}
490 %{_libdir}/%{name}/platform.ini
491 %{_libdir}/%{name}/greprefs.js
492 %attr(755,root,root) %{_libdir}/%{name}/components/*.so
493 %attr(755,root,root) %{_libdir}/%{name}/libmozalloc.so
494 %attr(755,root,root) %{_libdir}/%{name}/libxpcom.so
495 %attr(755,root,root) %{_libdir}/%{name}/libxul.so
496 %attr(755,root,root) %{_libdir}/%{name}/mozilla-xremote-client
497 %attr(755,root,root) %{_libdir}/%{name}/plugin-container
498 %endif
499
500 # symlinks
501 %{_libdir}/%{name}/chrome
502 %{_libdir}/%{name}/defaults
503 %{_libdir}/%{name}/isp
504 %{_libdir}/%{name}/modules
505 %{_libdir}/%{name}/searchplugins
506 %if %{with xulrunner}
507 %{_libdir}/%{name}/xulrunner
508 %else
509 %{_libdir}/%{name}/dictionaries
510 %{_libdir}/%{name}/hyphenation
511 %{_libdir}/%{name}/res
512 %endif
513
514 %{_pixmapsdir}/icedove.png
515 %{_desktopdir}/icedove.desktop
516
517 %dir %{_datadir}/%{name}
518 %{_datadir}/%{name}/chrome
519 %{_datadir}/%{name}/defaults
520 %{_datadir}/%{name}/extensions
521 %{_datadir}/%{name}/isp
522 %{_datadir}/%{name}/modules
523 %if %{with enigmail}
524 %exclude %{_datadir}/%{name}/modules/commonFuncs.jsm
525 %exclude %{_datadir}/%{name}/modules/enigmailCommon.jsm
526 %exclude %{_datadir}/%{name}/modules/keyManagement.jsm
527 %exclude %{_datadir}/%{name}/modules/pipeConsole.jsm
528 %exclude %{_datadir}/%{name}/modules/pipeTransport.jsm
529 %exclude %{_datadir}/%{name}/modules/subprocess.jsm
530 %exclude %{_datadir}/%{name}/modules/subprocess_worker_unix.js
531 %exclude %{_datadir}/%{name}/modules/subprocess_worker_win.js
532 %endif
533 %{_datadir}/%{name}/searchplugins
534 %if %{without xulrunner}
535 %{_datadir}/%{name}/res
536 %endif
537
538 %if %{with crashreporter}
539 %attr(755,root,root) %{_libdir}/%{name}/crashreporter
540 %{_libdir}/%{name}/crashreporter.ini
541 %{_libdir}/%{name}/Throbber-small.gif
542 %endif
543
544 %dir %{_libdir}/%{name}/extensions
545 %{_libdir}/%{name}/extensions/{972ce4c6-7e08-4474-a285-3208198ce6fd}
546
547 # files created by regxpcom -register
548 %ghost %{_libdir}/%{name}/components/compreg.dat
549 %ghost %{_libdir}/%{name}/components/xpti.dat
550
551 %if %{with lightning}
552 %files addon-lightning
553 %defattr(644,root,root,755)
554 %dir %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}
555 %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/application.ini
556 %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/chrome
557 %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/chrome.manifest
558 %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/defaults
559 %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/install.rdf
560 %dir %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/components
561 %attr(755,root,root) %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/components/*.so
562 %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/components/*.js
563 %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/components/*.manifest
564 %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/components/*.xpt
565 %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/modules
566 %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/calendar-js
567 %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/timezones.sqlite
568 %{_libdir}/%{name}/extensions/calendar-timezones@mozilla.org
569 %endif
570
571 %if %{with enigmail}
572 %files addon-enigmail
573 %defattr(644,root,root,755)
574 %dir %{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}
575 %{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/defaults
576 %{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/chrome
577 %{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/chrome.manifest
578 %{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/install.rdf
579 %dir %{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/components
580 %attr(755,root,root) %{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/components/*.so
581 %{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/components/*.xpt
582 %{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/components/*.js
583 %dir %{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/modules
584 %{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/modules/*.jsm
585 %{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/modules/*.js
586 %endif
This page took 0.113456 seconds and 4 git commands to generate.