]> git.pld-linux.org Git - packages/thunderbird.git/blob - icedove.spec
- more CVE entries and security blockers for icedove (upgrade required)
[packages/thunderbird.git] / icedove.spec
1 #
2 # TODO:
3 #   - CHECK all features of enigmail
4 #   - separate spec for enigmail
5 #
6 # Conditional builds
7 %bcond_without  enigmail        # don't build enigmail - GPG/PGP support
8 %bcond_without  gnomeui         # disable gnomeui support
9 %bcond_without  gnomevfs        # disable GNOME comp. (gconf+libgnome+gnomevfs) and gnomevfs ext.
10 %bcond_without  gnome           # disable all GNOME components (gnome+gnomeui+gnomevfs)
11 %bcond_without  ldap            # disable e-mail address lookups in LDAP directories
12 #
13 %if %{without gnome}
14 %undefine       with_gnomeui
15 %undefine       with_gnomevfs
16 %endif
17 %define         enigmail_ver            0.95.7
18
19 Summary:        Icedove - email client
20 Summary(pl.UTF-8):      Icedove - klient poczty
21 Name:           icedove
22 Version:        2.0.0.17
23 Release:        1
24 License:        MPL 1.1 or GPL v2+ or LGPL v2.1+
25 Group:          Applications/Networking
26 Source0:        http://releases.mozilla.org/pub/mozilla.org/thunderbird/releases/%{version}/source/thunderbird-%{version}-source.tar.bz2
27 # Source0-md5:  3adb8fabdc26a5859c55b9ce241edb3f
28 Source1:        http://www.mozilla-enigmail.org/download/source/enigmail-%{enigmail_ver}.tar.gz
29 # Source1-md5:  bbee59bab58b97e33e85015a5ae5de7b
30 Source2:        %{name}-branding.tar.bz2
31 # Source2-md5:  e775b8cb658de32f30b403bc9b7950bf
32 Source3:        %{name}-rm_nonfree.sh
33 Source4:        %{name}.desktop
34 Source5:        %{name}.sh
35 Source6:        %{name}-enigmail.manifest
36 Patch0:         %{name}-branding.patch
37 Patch1:         %{name}-lib_path.patch
38 Patch2:         %{name}-enigmail-shared.patch
39 Patch3:         %{name}-gcc.patch
40 Patch4:         %{name}-fonts.patch
41 Patch5:         %{name}-install.patch
42 Patch6:         %{name}-myspell.patch
43 Patch7:         %{name}-regionNames.patch
44 Patch8:         %{name}-prefs.patch
45 URL:            http://www.pld-linux.org/Packages/Icedove
46 # Upgrade to 2.0.0.18:
47 BuildRequires:  security(CVE-2008-4582)
48 BuildRequires:  security(CVE-2008-5012)
49 BuildRequires:  security(CVE-2008-5014)
50 BuildRequires:  security(CVE-2008-5016)
51 BuildRequires:  security(CVE-2008-5017)
52 BuildRequires:  security(CVE-2008-5018)
53 BuildRequires:  security(CVE-2008-5021)
54 BuildRequires:  security(CVE-2008-5022)
55 BuildRequires:  security(CVE-2008-5023)
56 BuildRequires:  security(CVE-2008-5024)
57 ######
58 %{?with_gnomevfs:BuildRequires: GConf2-devel >= 1.2.1}
59 BuildRequires:  automake
60 BuildRequires:  freetype-devel >= 1:2.1.8
61 %{?with_gnomevfs:BuildRequires: gnome-vfs2-devel >= 2.0}
62 BuildRequires:  gtk+2-devel >= 1:2.0.0
63 BuildRequires:  libIDL-devel >= 0.8.0
64 %{?with_gnomevfs:BuildRequires: libgnome-devel >= 2.0}
65 %{?with_gnomeui:BuildRequires:  libgnomeui-devel >= 2.2.0}
66 BuildRequires:  libjpeg-devel >= 6b
67 BuildRequires:  libpng-devel >= 1.2.0
68 BuildRequires:  libstdc++-devel
69 BuildRequires:  myspell-devel
70 BuildRequires:  nspr-devel >= 1:4.6.1
71 BuildRequires:  nss-devel >= 1:3.11.3
72 BuildRequires:  pango-devel >= 1:1.1.0
73 BuildRequires:  sed >= 4.0
74 BuildRequires:  xorg-lib-libXext-devel
75 BuildRequires:  xorg-lib-libXft-devel >= 2.1
76 BuildRequires:  xorg-lib-libXinerama-devel
77 BuildRequires:  xorg-lib-libXp-devel
78 BuildRequires:  xorg-lib-libXt-devel
79 Requires:       myspell-common
80 Requires:       nspr >= 1:4.6.1
81 Requires:       nss >= 1:3.11.3
82 Obsoletes:      mozilla-thunderbird
83 Obsoletes:      mozilla-thunderbird-dictionary-en-US
84 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
85
86 %define         filterout_cpp           -D_FORTIFY_SOURCE=[0-9]+
87
88 # iceweasel/icedove/iceape provide their own versions
89 %define         _noautoreqdep           libgfxpsshar.so libgkgfx.so libgtkxtbin.so libjsj.so libxpcom_compat.so libxpcom_core.so libxpistub.so
90 %define         _noautoprovfiles        %{_libdir}/%{name}/components
91 # we don't want these to satisfy xulrunner-devel
92 %define         _noautoprov             libgtkembedmoz.so libldap50.so libmozjs.so libprldap50.so libssldap50.so libxpcom.so libxul.so
93 # and as we don't provide them, don't require either
94 %define         _noautoreq              libgtkembedmoz.so libldap50.so libmozjs.so libprldap50.so libssldap50.so libxpcom.so libxul.so
95
96 %description
97 Icedove is an open-source,fast and portable email client.
98
99 %description -l pl.UTF-8
100 Icedove jest open sourcowym, szybkim i przenośnym klientem poczty.
101
102 %package addon-enigmail
103 Summary:        Extension for the authentication and encryption features provided by GnuPG
104 Summary(pl.UTF-8):      Rozszerzenie do uwierzytelniania i szyfrowania zapewnianego przez GnuPG
105 License:        MPL/LGPL
106 Group:          Applications/Networking
107 URL:            http://enigmail.mozdev.org/
108 Requires:       %{name} = %{version}-%{release}
109 Obsoletes:      mozilla-thunderbird-addon-enigmail
110
111 %description addon-enigmail
112 Enigmail is an extension to the Icedove mail client which allows users
113 to access the authentication and encryption features provided by
114 GnuPG.
115
116 Main Features:
117 - Encrypt/sign mail when sending, decrypt/authenticate received mail
118 - Support for inline-PGP (RFC 2440) and PGP/MIME (RFC 3156)
119 - Per-Account based encryption and signing defaults
120 - Per-Recipient rules for automated key selection, and
121   enabling/disabling encryption and signing
122 - OpenPGP key management interface
123
124 %description addon-enigmail -l pl.UTF-8
125 Enigmail to rozszerzenie klienta pocztowego Icedove pozwalające
126 użytkownikom na dostęp do uwierzytelniania i szyfrowania
127 zapewnianego przez GnuPG.
128
129 Główne możliwości:
130 - szyfrowanie/podpisywanie poczty przy wysyłaniu,
131   odszyfrowywanie/uwierzytelnianie poczty odebranej
132 - obsługa inline-PGP (RFC 2440) i PGP/MIME (RFC 3156)
133 - ustawienia domyślne szyfrowania i podpisywania dla każdego konta
134 - reguły automatycznego wyboru kluczy i włączenia szyfrowania oraz
135   podpisywania dla każdego adresata
136 - interfejs do zarządzania kluczami OpenPGP
137
138 %prep
139 %setup -q -c -a2
140 cd mozilla
141 %{?with_enigmail:tar xvfz %{SOURCE1} -C mailnews/extensions}
142 /bin/sh %{SOURCE3}
143 %patch0 -p1
144 %patch1 -p1
145 %{?with_enigmail:%patch2 -p1}
146 %patch3 -p1
147 %patch4 -p1
148 %patch5 -p1
149 %patch6 -p1
150 %patch7 -p1
151 %patch8 -p1
152
153 :> config/gcc_hidden.h
154
155 %build
156 cd mozilla
157 export CFLAGS="%{rpmcflags} `%{_bindir}/pkg-config mozilla-nspr --cflags-only-I`"
158 export CXXFLAGS="%{rpmcflags} `%{_bindir}/pkg-config mozilla-nspr --cflags-only-I`"
159
160 cp -f %{_datadir}/automake/config.* build/autoconf
161 cp -f %{_datadir}/automake/config.* nsprpub/build/autoconf
162 cp -f %{_datadir}/automake/config.* directory/c-sdk/config/autoconf
163
164 cat << 'EOF' > .mozconfig
165 . $topsrcdir/mail/config/mozconfig
166
167 ac_add_options --prefix=%{_prefix}
168 ac_add_options --exec-prefix=%{_exec_prefix}
169 ac_add_options --bindir=%{_bindir}
170 ac_add_options --sbindir=%{_sbindir}
171 ac_add_options --sysconfdir=%{_sysconfdir}
172 ac_add_options --datadir=%{_datadir}
173 ac_add_options --includedir=%{_includedir}
174 ac_add_options --libdir=%{_libdir}
175 ac_add_options --libexecdir=%{_libexecdir}
176 ac_add_options --localstatedir=%{_localstatedir}
177 ac_add_options --sharedstatedir=%{_sharedstatedir}
178 ac_add_options --mandir=%{_mandir}
179 ac_add_options --infodir=%{_infodir}
180 %if %{?debug:1}0
181 ac_add_options --enable-debug
182 ac_add_options --enable-debug-modules
183 %else
184 ac_add_options --disable-debug
185 ac_add_options --disable-debug-modules
186 %endif
187 %if %{with tests}
188 ac_add_options --enable-tests
189 %else
190 ac_add_options --disable-tests
191 %endif
192 %if %{with gnomeui}
193 ac_add_options --enable-gnomeui
194 %else
195 ac_add_options --disable-gnomeui
196 %endif
197 %if %{with gnomevfs}
198 ac_add_options --enable-gnomevfs
199 %else
200 ac_add_options --disable-gnomevfs
201 %endif
202 %if %{with ldap}
203 ac_add_options --enable-ldap
204 %else
205 ac_add_options --disable-ldap
206 %endif
207 ac_add_options --disable-installer
208 ac_add_options --disable-jsd
209 ac_add_options --disable-xprint
210 ac_add_options --enable-canvas
211 ac_add_options --enable-crypto
212 ac_add_options --enable-default-toolkit="gtk2"
213 ac_add_options --enable-extensions="pref,cookie,wallet,spellcheck"
214 ac_add_options --enable-mathml
215 ac_add_options --enable-optimize="%{rpmcflags}"
216 ac_add_options --enable-pango
217 ac_add_options --enable-reorder
218 ac_add_options --disable-strip
219 ac_add_options --disable-strip-libs
220 ac_add_options --enable-system-cairo
221 ac_add_options --enable-system-myspell
222 ac_add_options --enable-svg
223 ac_add_options --enable-xft
224 ac_add_options --enable-xinerama
225 ac_add_options --with-system-jpeg
226 ac_add_options --with-system-nspr
227 ac_add_options --with-system-nss
228 ac_add_options --with-system-png
229 ac_add_options --with-system-zlib
230 ac_add_options --with-pthreads
231 ac_add_options --enable-single-profile
232 ac_add_options --disable-profilesharing
233 ac_add_options --with-branding=icedove/branding
234 ac_add_options --with-default-mozilla-five-home=%{_libdir}/%{name}
235 EOF
236
237 %{__make} -j1 -f client.mk build_all \
238         CC="%{__cc}" \
239         CXX="%{__cxx}"
240
241 %if %{with enigmail}
242         cd mailnews/extensions/enigmail
243         ./makemake -r
244         %{__make}
245 %endif
246
247 %install
248 rm -rf $RPM_BUILD_ROOT
249 install -d $RPM_BUILD_ROOT{%{_bindir},%{_libdir},%{_pixmapsdir},%{_desktopdir}} \
250         $RPM_BUILD_ROOT%{_datadir}/%{name}
251
252 cd mozilla
253 %{__make} -C xpinstall/packager stage-package \
254         DESTDIR=$RPM_BUILD_ROOT \
255         MOZ_PKG_APPDIR=%{_libdir}/%{name} \
256         PKG_SKIP_STRIP=1
257
258 # move arch independant ones to datadir
259 mv $RPM_BUILD_ROOT%{_libdir}/%{name}/chrome $RPM_BUILD_ROOT%{_datadir}/%{name}/chrome
260 mv $RPM_BUILD_ROOT%{_libdir}/%{name}/defaults $RPM_BUILD_ROOT%{_datadir}/%{name}/defaults
261 mv $RPM_BUILD_ROOT%{_libdir}/%{name}/greprefs $RPM_BUILD_ROOT%{_datadir}/%{name}/greprefs
262 mv $RPM_BUILD_ROOT%{_libdir}/%{name}/icons $RPM_BUILD_ROOT%{_datadir}/%{name}/icons
263 mv $RPM_BUILD_ROOT%{_libdir}/%{name}/init.d $RPM_BUILD_ROOT%{_datadir}/%{name}/init.d
264 mv $RPM_BUILD_ROOT%{_libdir}/%{name}/isp $RPM_BUILD_ROOT%{_datadir}/%{name}/isp
265 mv $RPM_BUILD_ROOT%{_libdir}/%{name}/res $RPM_BUILD_ROOT%{_datadir}/%{name}/res
266 ln -s ../../share/%{name}/chrome $RPM_BUILD_ROOT%{_libdir}/%{name}/chrome
267 ln -s ../../share/%{name}/defaults $RPM_BUILD_ROOT%{_libdir}/%{name}/defaults
268 ln -s ../../share/%{name}/greprefs $RPM_BUILD_ROOT%{_libdir}/%{name}/greprefs
269 ln -s ../../share/%{name}/icons $RPM_BUILD_ROOT%{_libdir}/%{name}/icons
270 ln -s ../../share/%{name}/init.d $RPM_BUILD_ROOT%{_libdir}/%{name}/init.d
271 ln -s ../../share/%{name}/isp $RPM_BUILD_ROOT%{_libdir}/%{name}/isp
272 ln -s ../../share/%{name}/res $RPM_BUILD_ROOT%{_libdir}/%{name}/res
273
274 rm -rf $RPM_BUILD_ROOT%{_libdir}/%{name}/dictionaries
275 ln -s %{_datadir}/myspell $RPM_BUILD_ROOT%{_libdir}/%{name}/dictionaries
276
277 %{__sed} -e 's,@LIBDIR@,%{_libdir},' %{SOURCE5} > $RPM_BUILD_ROOT%{_bindir}/icedove
278 ln -s %{name} $RPM_BUILD_ROOT%{_bindir}/thunderbird
279 ln -s %{name} $RPM_BUILD_ROOT%{_bindir}/mozilla-thunderbird
280
281 install %{SOURCE4} $RPM_BUILD_ROOT%{_desktopdir}/%{name}.desktop
282
283 %if %{with enigmail}
284 _enig_dir=$RPM_BUILD_ROOT%{_libdir}/%{name}/extensions/\{847b3a00-7ab1-11d4-8f02-006008948af5\}
285 install -d $_enig_dir/chrome
286 install -d $_enig_dir/components
287 install -d $_enig_dir/defaults/preferences
288 mv -f $RPM_BUILD_ROOT%{_libdir}/%{name}/chrome/enigmail.jar $_enig_dir/chrome
289 mv -f $RPM_BUILD_ROOT%{_libdir}/%{name}/chrome/enigmail-skin-tbird.jar $_enig_dir/chrome
290 mv -f $RPM_BUILD_ROOT%{_libdir}/%{name}/components/enig* $_enig_dir/components
291 mv -f $RPM_BUILD_ROOT%{_libdir}/%{name}/components/libenigmime.so $_enig_dir/components
292 mv -f $RPM_BUILD_ROOT%{_libdir}/%{name}/components/ipc.xpt $_enig_dir/components
293 mv -f $RPM_BUILD_ROOT%{_libdir}/%{name}/defaults/preferences/enigmail.js $_enig_dir/defaults/preferences
294 cp -f mailnews/extensions/enigmail/package/install.rdf $_enig_dir
295 rm -rf $RPM_BUILD_ROOT%{_libdir}/%{name}/defaults/preferences
296 rm -f $RPM_BUILD_ROOT%{_libdir}/%{name}/chrome/enigmail-en-US.jar
297 rm -f $RPM_BUILD_ROOT%{_libdir}/%{name}/chrome/enigmail-skin.jar
298 rm -f $RPM_BUILD_ROOT%{_libdir}/%{name}/chrome/enigmime.jar
299 rm -rf $RPM_BUILD_ROOT%{_libdir}/%{name}/components/enig*
300 rm -f $RPM_BUILD_ROOT%{_libdir}/%{name}/components/libenigmime.so
301 rm -f $RPM_BUILD_ROOT%{_libdir}/%{name}/components/ipc.xpt
302 cp -f %{SOURCE6} $_enig_dir/chrome.manifest
303 cp -f icedove/branding/content/icon64.png $RPM_BUILD_ROOT%{_pixmapsdir}/icedove.png
304 %endif
305
306 # win32 stuff
307 rm -f $RPM_BUILD_ROOT%{_libdir}/%{name}/dirver
308
309 %clean
310 rm -rf $RPM_BUILD_ROOT
311
312 %pretrans
313 if [ -d %{_libdir}/%{name}/dictionaries ] && [ ! -L %{_libdir}/%{name}/dictionaries ]; then
314         mv -v %{_libdir}/%{name}/dictionaries{,.rpmsave}
315 fi
316 for d in chrome defaults greprefs icons init.d isp res; do
317         if [ -d %{_libdir}/%{name}/$d ] && [ ! -L %{_libdir}/%{name}/$d ]; then
318                 install -d %{_datadir}/%{name}
319                 mv %{_libdir}/%{name}/$d %{_datadir}/%{name}/$d
320         fi
321 done
322 exit 0
323
324 %files
325 %defattr(644,root,root,755)
326 %attr(755,root,root) %{_bindir}/icedove
327 %attr(755,root,root) %{_bindir}/mozilla-thunderbird
328 %attr(755,root,root) %{_bindir}/thunderbird
329 %dir %{_libdir}/%{name}
330 %dir %{_libdir}/%{name}/components
331 %attr(755,root,root) %{_libdir}/%{name}/components/*.so
332 %{_libdir}/%{name}/components/*.js
333 %{_libdir}/%{name}/components/*.xpt
334 %attr(755,root,root) %{_libdir}/%{name}/*.so
335 %attr(755,root,root) %{_libdir}/%{name}/*.sh
336 %attr(755,root,root) %{_libdir}/%{name}/*-bin
337 %attr(755,root,root) %{_libdir}/%{name}/mozilla-xremote-client
338 %attr(755,root,root) %{_libdir}/%{name}/reg*
339 %attr(755,root,root) %{_libdir}/%{name}/icedove
340 %{_libdir}/%{name}/*.txt
341 %attr(755,root,root) %{_libdir}/%{name}/x*
342
343 # symlinks
344 %{_libdir}/%{name}/chrome
345 %{_libdir}/%{name}/defaults
346 %{_libdir}/%{name}/dictionaries
347 %{_libdir}/%{name}/greprefs
348 %{_libdir}/%{name}/icons
349 %{_libdir}/%{name}/init.d
350 %{_libdir}/%{name}/isp
351 %{_libdir}/%{name}/res
352
353 %{_libdir}/%{name}/dependentlibs.list
354 %{_libdir}/%{name}/updater
355 %{_libdir}/%{name}/updater.ini
356 %{_pixmapsdir}/*.png
357 %{_desktopdir}/*.desktop
358
359 %dir %{_datadir}/%{name}
360 %{_datadir}/%{name}/chrome
361 %{_datadir}/%{name}/defaults
362 %{_datadir}/%{name}/greprefs
363 %{_datadir}/%{name}/icons
364 %{_datadir}/%{name}/init.d
365 %{_datadir}/%{name}/isp
366 %{_datadir}/%{name}/res
367
368 %dir %{_libdir}/%{name}/extensions
369 %{_libdir}/%{name}/extensions/{972ce4c6-7e08-4474-a285-3208198ce6fd}
370
371 %if %{with enigmail}
372 %files addon-enigmail
373 %defattr(644,root,root,755)
374 %{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}
375 %endif
This page took 0.0893969999999999 seconds and 4 git commands to generate.