]> git.pld-linux.org Git - packages/thunderbird.git/blob - icedove.spec
- up to 10.0.1
[packages/thunderbird.git] / icedove.spec
1 # TODO:
2 # - separate spec for enigmail
3 # - build with system mozldap
4 # - enigmail - new version needed
5 #
6 # Conditional builds
7 %bcond_without  enigmail        # don't build enigmail - GPG/PGP support
8 %bcond_without  gnomeui         # disable gnomeui support
9 %bcond_without  gnome           # alias for gnomeui
10 %bcond_without  ldap            # disable e-mail address lookups in LDAP directories
11 %bcond_without  lightning       # disable Sunbird/Lightning calendar
12 %bcond_without  xulrunner       # build with xulrunner
13 %bcond_with     crashreporter   # report crashes to crash-stats.mozilla.com
14
15 %if %{without gnome}
16 %undefine       with_gnomeui
17 %endif
18
19 %if 0%{?_enable_debug_packages} != 1
20 %undefine       crashreporter
21 %endif
22
23 %define         enigmail_ver    1.3.5
24 %define         nspr_ver        4.8.8
25 %define         nss_ver         3.12.10
26
27 # convert firefox release number to platform version: 9.0.x -> 9.0.x
28 %define         xulrunner_main  10.0
29 %define         xulrunner_ver   %(v=%{version}; echo %{xulrunner_main}${v#10.0})
30
31 %if %{without xulrunner}
32 # The actual sqlite version (see RHBZ#480989):
33 %define         sqlite_build_version %(pkg-config --silence-errors --modversion sqlite3 2>/dev/null || echo ERROR)
34 %endif
35
36 Summary:        Icedove - email client
37 Summary(pl.UTF-8):      Icedove - klient poczty
38 Name:           icedove
39 Version:        10.0.1
40 Release:        1
41 License:        MPL 1.1 or GPL v2+ or LGPL v2.1+
42 Group:          X11/Applications/Networking
43 Source0:        http://releases.mozilla.org/pub/mozilla.org/thunderbird/releases/%{version}/source/thunderbird-%{version}.source.tar.bz2
44 # Source0-md5:  623c32d9deae370383e1422b1ea48061
45 Source1:        http://www.mozilla-enigmail.org/download/source/enigmail-%{enigmail_ver}.tar.gz
46 # Source1-md5:  1b008b0d106e238c11e4bead08126bc0
47 Source2:        %{name}-branding.tar.bz2
48 # Source2-md5:  2da351522bdd7f4a3bd8aaff4c776976
49 Source3:        %{name}-rm_nonfree.sh
50 Source4:        %{name}.desktop
51 Source5:        %{name}.sh
52 Patch0:         %{name}-branding.patch
53 Patch1:         %{name}-enigmail-shared.patch
54 Patch2:         %{name}-gcc.patch
55 Patch3:         %{name}-fonts.patch
56 Patch4:         %{name}-install.patch
57 Patch5:         %{name}-hunspell.patch
58 Patch6:         %{name}-prefs.patch
59 Patch7:         system-mozldap.patch
60 Patch8:         %{name}-makefile.patch
61 #Patch9:                %{name}-libpng.patch
62 Patch10:        %{name}-extensiondir.patch
63 Patch11:        crashreporter.patch
64 Patch12:        no-subshell.patch
65 URL:            http://www.pld-linux.org/Packages/Icedove
66 BuildRequires:  GConf2-devel >= 1.2.1
67 BuildRequires:  alsa-lib-devel
68 BuildRequires:  automake
69 BuildRequires:  bzip2-devel
70 BuildRequires:  cairo-devel >= 1.10
71 BuildRequires:  dbus-glib-devel >= 0.60
72 BuildRequires:  freetype-devel >= 1:2.1.8
73 BuildRequires:  glib2-devel >= 2.0
74 BuildRequires:  gtk+2-devel >= 2:2.10.0
75 BuildRequires:  hunspell-devel
76 BuildRequires:  libIDL-devel >= 0.8.0
77 %{?with_gnomeui:BuildRequires:  libgnome-devel >= 2.0}
78 %{?with_gnomeui:BuildRequires:  libgnome-keyring-devel}
79 %{?with_gnomeui:BuildRequires:  libgnomeui-devel >= 2.2.0}
80 BuildRequires:  libiw-devel
81 BuildRequires:  libjpeg-devel >= 6b
82 BuildRequires:  libnotify-devel >= 0.4
83 BuildRequires:  libpng-devel >= 1.4.1
84 BuildRequires:  libstdc++-devel
85 BuildRequires:  nspr-devel >= 1:%{nspr_ver}
86 BuildRequires:  nss-devel >= 1:%{nss_ver}
87 BuildRequires:  pango-devel >= 1:1.1.0
88 BuildRequires:  perl-base >= 1:5.6
89 BuildRequires:  pkgconfig
90 BuildRequires:  python >= 1:2.5
91 BuildRequires:  sed >= 4.0
92 BuildRequires:  sqlite3-devel >= 3.7.4
93 BuildRequires:  startup-notification-devel >= 0.8
94 BuildRequires:  xorg-lib-libXext-devel
95 BuildRequires:  xorg-lib-libXinerama-devel
96 BuildRequires:  xorg-lib-libXt-devel
97 BuildRequires:  yasm
98 BuildRequires:  zip
99 %if %{with xulrunner}
100 BuildRequires:  xulrunner-devel >= 2:%{xulrunner_ver}
101 %else
102 Requires:       myspell-common
103 Requires:       nspr >= 1:%{nspr_ver}
104 Requires:       nss >= 1:%{nss_ver}
105 Requires:       sqlite3 >= %{sqlite_build_version}
106 %endif
107 Requires(post): mktemp >= 1.5-18
108 %if %{with xulrunner}
109 %requires_eq_to xulrunner xulrunner-devel
110 %endif
111 Obsoletes:      mozilla-thunderbird
112 Obsoletes:      mozilla-thunderbird-dictionary-en-US
113 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
114
115 %define         filterout_cpp           -D_FORTIFY_SOURCE=[0-9]+
116
117 # iceweasel/icedove/iceape provide their own versions
118 %define         _noautoreqdep           libgfxpsshar.so libgkgfx.so libgtkxtbin.so libjsj.so libxpcom_compat.so libxpistub.so
119 %define         _noautoprovfiles        %{_libdir}/%{name}/components
120 # we don't want these to satisfy xulrunner-devel
121 %define         _noautoprov             libgtkembedmoz.so libmozjs.so libxpcom.so libxul.so libxpcom_core.so
122 # and as we don't provide them, don't require either
123 %define         _noautoreq              libgtkembedmoz.so libmozjs.so libxpcom.so libxul.so libxpcom_core.so
124
125 %define         topdir          %{_builddir}/%{name}-%{version}
126 %define         objdir          %{topdir}/obj-%{_target_cpu}
127
128 %description
129 Icedove is an open-source, fast and portable email client.
130
131 %description -l pl.UTF-8
132 Icedove jest mającym otwarte źródła, szybkim i przenośnym klientem
133 poczty.
134
135 %package addon-lightning
136 Summary:        An integrated calendar for Icedove
137 Summary(pl.UTF-8):      Zintegrowany kalendarz dla Icedove
138 License:        MPL 1.1 or GPL v2+ or LGPL v2.1+
139 Group:          Applications/Networking
140 Requires:       %{name} = %{version}-%{release}
141
142 %description addon-lightning
143 Lightning is an calendar extension to Icedove email client.
144
145 %description addon-lightning -l pl.UTF-8
146 Lightning to rozszerzenie do klienta poczty Icedove dodające
147 funkcjonalność kalendarza.
148
149 %package addon-enigmail
150 Summary:        Extension for the authentication and encryption features provided by GnuPG
151 Summary(pl.UTF-8):      Rozszerzenie do uwierzytelniania i szyfrowania zapewnianego przez GnuPG
152 License:        MPL/LGPL
153 Group:          Applications/Networking
154 URL:            http://enigmail.mozdev.org/
155 Requires:       %{name} = %{version}-%{release}
156 Requires:       gnupg
157 Obsoletes:      mozilla-thunderbird-addon-enigmail
158
159 %description addon-enigmail
160 Enigmail is an extension to the Icedove mail client which allows users
161 to access the authentication and encryption features provided by
162 GnuPG.
163
164 Main Features:
165 - Encrypt/sign mail when sending, decrypt/authenticate received mail
166 - Support for inline-PGP (RFC 2440) and PGP/MIME (RFC 3156)
167 - Per-Account based encryption and signing defaults
168 - Per-Recipient rules for automated key selection, and
169   enabling/disabling encryption and signing
170 - OpenPGP key management interface
171
172 %description addon-enigmail -l pl.UTF-8
173 Enigmail to rozszerzenie klienta pocztowego Icedove pozwalające
174 użytkownikom na dostęp do uwierzytelniania i szyfrowania zapewnianego
175 przez GnuPG.
176
177 Główne możliwości:
178 - szyfrowanie/podpisywanie poczty przy wysyłaniu,
179   odszyfrowywanie/uwierzytelnianie poczty odebranej
180 - obsługa inline-PGP (RFC 2440) i PGP/MIME (RFC 3156)
181 - ustawienia domyślne szyfrowania i podpisywania dla każdego konta
182 - reguły automatycznego wyboru kluczy i włączenia szyfrowania oraz
183   podpisywania dla każdego adresata
184 - interfejs do zarządzania kluczami OpenPGP
185
186 %prep
187 %setup -qc
188 mv comm-release mozilla
189 %setup -q -T -D -a2
190 cd mozilla
191 %{?with_enigmail:%{__gzip} -dc %{SOURCE1} | %{__tar} -xf - -C mailnews/extensions}
192 /bin/sh %{SOURCE3}
193 %patch0 -p1
194 %{?with_enigmail:%patch1 -p1}
195 %patch2 -p1
196 %patch3 -p1
197 %patch4 -p1
198 %patch6 -p1
199 %patch7 -p1
200 %patch8 -p2
201 #%patch9 -p1
202 %patch10 -p2
203 %patch11 -p2
204 %patch12 -p1
205
206 %build
207 cd mozilla
208 cp -f %{_datadir}/automake/config.* mozilla/build/autoconf
209 cp -f %{_datadir}/automake/config.* mozilla/nsprpub/build/autoconf
210 cp -f %{_datadir}/automake/config.* ldap/sdks/c-sdk/config/autoconf
211
212 install -d libxul-sdk
213 ln -snf %{_libdir}/xulrunner-sdk libxul-sdk/sdk
214
215 cat << EOF > .mozconfig
216 mk_add_options MOZ_OBJDIR=%{objdir}
217
218 export CFLAGS="%{rpmcflags} -fpermissive -I/usr/include/xulrunner"
219 export CXXFLAGS="%{rpmcflags} -fpermissive -I/usr/include/xulrunner"
220
221 %if %{with crashreporter}
222 export MOZ_DEBUG_SYMBOLS=1
223 %endif
224
225 # Options for 'configure' (same as command-line options).
226 ac_add_options --prefix=%{_prefix}
227 ac_add_options --exec-prefix=%{_exec_prefix}
228 ac_add_options --bindir=%{_bindir}
229 ac_add_options --sbindir=%{_sbindir}
230 ac_add_options --sysconfdir=%{_sysconfdir}
231 ac_add_options --datadir=%{_datadir}
232 ac_add_options --includedir=%{_includedir}
233 ac_add_options --libdir=%{_libdir}
234 ac_add_options --libexecdir=%{_libexecdir}
235 ac_add_options --localstatedir=%{_localstatedir}
236 ac_add_options --sharedstatedir=%{_sharedstatedir}
237 ac_add_options --mandir=%{_mandir}
238 ac_add_options --infodir=%{_infodir}
239 %if %{?debug:1}0
240 ac_add_options --disable-optimize
241 ac_add_options --enable-debug
242 ac_add_options --enable-debug-modules
243 ac_add_options --enable-debugger-info-modules
244 ac_add_options --enable-crash-on-assert
245 %else
246 ac_add_options --disable-debug
247 ac_add_options --disable-debug-modules
248 ac_add_options --disable-logging
249 ac_add_options --enable-optimize="%{rpmcflags} -Os"
250 %endif
251 ac_add_options --disable-strip
252 ac_add_options --disable-strip-libs
253 %if %{with tests}
254 ac_add_options --enable-tests
255 %else
256 ac_add_options --disable-tests
257 %endif
258 ac_add_options --enable-gio
259 %if %{with gnomeui}
260 ac_add_options --enable-gnomeui
261 %else
262 ac_add_options --disable-gnomeui
263 %endif
264 ac_add_options --disable-gnomevfs
265 %if %{with ldap}
266 ac_add_options --enable-ldap
267 ac_add_options --with-system-ldap
268 %else
269 ac_add_options --disable-ldap
270 %endif
271 %if %{with crashreporter}
272 ac_add_options --enable-crashreporter
273 %else
274 ac_add_options --disable-crashreporter
275 %endif
276 ac_add_options --disable-xterm-updates
277 ac_add_options --enable-postscript
278 %if %{with lightning}
279 ac_add_options --enable-calendar
280 %else
281 ac_add_options --disable-calendar
282 %endif
283 ac_add_options --disable-installer
284 ac_add_options --disable-jsd
285 ac_add_options --disable-updater
286 ac_add_options --disable-xprint
287 ac_add_options --disable-permissions
288 ac_add_options --disable-pref-extensions
289 ac_add_options --enable-canvas
290 ac_add_options --enable-crypto
291 ac_add_options --enable-mathml
292 ac_add_options --enable-pango
293 ac_add_options --enable-reorder
294 ac_add_options --enable-startup-notification
295 ac_add_options --enable-svg
296 ac_add_options --enable-system-cairo
297 ac_add_options --enable-system-hunspell
298 ac_add_options --enable-system-sqlite
299 ac_add_options --enable-xft
300 ac_add_options --enable-application=mail
301 ac_add_options --enable-default-toolkit=cairo-gtk2
302 ac_add_options --enable-xinerama
303 ac_add_options --with-distribution-id=org.pld-linux
304 ac_add_options --with-branding=icedove/branding
305 %if %{with xulrunner}
306 #ac_add_options --with-libxul-sdk=$(pwd)/libxul-sdk/sdk
307 ac_add_options --with-system-libxul
308 ac_add_options --enable-shared
309 ac_add_options --enable-libxul
310 %else
311 ac_add_options --disable-xul
312 %endif
313 ac_add_options --with-pthreads
314 ac_add_options --with-system-bz2
315 ac_add_options --with-system-jpeg
316 ac_add_options --with-system-nspr
317 ac_add_options --with-system-nss
318 ac_add_options --with-system-png
319 ac_add_options --with-system-zlib
320 ac_add_options --enable-single-profile
321 ac_add_options --disable-profilesharing
322 ac_add_options --with-default-mozilla-five-home=%{_libdir}/%{name}
323 EOF
324
325 %{__make} -j1 -f client.mk build \
326         STRIP="/bin/true" \
327         MOZ_MAKE_FLAGS="%{?_smp_mflags}" \
328         CC="%{__cc}" \
329         CXX="%{__cxx}"
330
331 %if %{with crashreporter}
332 # create debuginfo for crash-stats.mozilla.com
333 %{__make} -j1 -C obj-%{_target_cpu} buildsymbols
334 %endif
335
336 %if %{with enigmail}
337 cd mailnews/extensions/enigmail
338 ./makemake -r -o %{objdir}
339 %{__make} -C %{objdir}/mailnews/extensions/enigmail \
340         STRIP="/bin/true" \
341         CC="%{__cc}" \
342         CXX="%{__cxx}"
343 %endif
344
345 %install
346 rm -rf $RPM_BUILD_ROOT
347 install -d $RPM_BUILD_ROOT{%{_bindir},%{_libdir}/%{name},%{_datadir}/%{name},%{_pixmapsdir},%{_desktopdir}}
348
349 cd %{objdir}
350 %{__make} -C mail/installer stage-package \
351         DESTDIR=$RPM_BUILD_ROOT \
352         MOZ_PKG_DIR=%{_libdir}/%{name} \
353         PKG_SKIP_STRIP=1
354
355 # Enable crash reporter for Firefox application
356 %if %{with crashreporter}
357 %{__sed} -i -e 's/\[Crash Reporter\]/[Crash Reporter]\nEnabled=1/' $RPM_BUILD_ROOT%{_libdir}/%{name}/application.ini
358
359 # Add debuginfo for crash-stats.mozilla.com
360 install -d $RPM_BUILD_ROOT%{_exec_prefix}/lib/debug%{_libdir}/%{name}
361 cp -a mozilla/dist/%{name}-%{version}.en-US.linux-*.crashreporter-symbols.zip $RPM_BUILD_ROOT%{_prefix}/lib/debug%{_libdir}/%{name}
362 %endif
363
364 # copy manually lightning files, somewhy they are not installed by make
365 cp -a mozilla/dist/bin/extensions/calendar-timezones@mozilla.org \
366         mozilla/dist/bin/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103} \
367         $RPM_BUILD_ROOT%{_libdir}/%{name}/extensions
368
369 # move arch independant ones to datadir
370 mv $RPM_BUILD_ROOT%{_libdir}/%{name}/chrome $RPM_BUILD_ROOT%{_datadir}/%{name}/chrome
371 mv $RPM_BUILD_ROOT%{_libdir}/%{name}/defaults $RPM_BUILD_ROOT%{_datadir}/%{name}/defaults
372 mv $RPM_BUILD_ROOT%{_libdir}/%{name}/isp $RPM_BUILD_ROOT%{_datadir}/%{name}/isp
373 mv $RPM_BUILD_ROOT%{_libdir}/%{name}/modules $RPM_BUILD_ROOT%{_datadir}/%{name}/modules
374 mv $RPM_BUILD_ROOT%{_libdir}/%{name}/res $RPM_BUILD_ROOT%{_datadir}/%{name}/res
375 ln -s ../../share/%{name}/chrome $RPM_BUILD_ROOT%{_libdir}/%{name}/chrome
376 ln -s ../../share/%{name}/defaults $RPM_BUILD_ROOT%{_libdir}/%{name}/defaults
377 ln -s ../../share/%{name}/isp $RPM_BUILD_ROOT%{_libdir}/%{name}/isp
378 ln -s ../../share/%{name}/modules $RPM_BUILD_ROOT%{_libdir}/%{name}/modules
379 ln -s ../../share/%{name}/res $RPM_BUILD_ROOT%{_libdir}/%{name}/res
380
381 # dir for arch independant extensions besides arch dependant extensions
382 # see mozilla/xpcom/build/nsXULAppAPI.h
383 # XRE_SYS_LOCAL_EXTENSION_PARENT_DIR and XRE_SYS_SHARE_EXTENSION_PARENT_DIR
384 install -d $RPM_BUILD_ROOT%{_datadir}/%{name}/extensions
385
386 %{__rm} -r $RPM_BUILD_ROOT%{_libdir}/%{name}/dictionaries
387 ln -s %{_datadir}/myspell $RPM_BUILD_ROOT%{_libdir}/%{name}/dictionaries
388
389 %{__rm} -r $RPM_BUILD_ROOT%{_libdir}/%{name}/hyphenation
390 ln -s %{_datadir}/myspell $RPM_BUILD_ROOT%{_libdir}/%{name}/hyphenation
391
392 %{__sed} -e 's,@LIBDIR@,%{_libdir},' %{SOURCE5} > $RPM_BUILD_ROOT%{_bindir}/icedove
393 ln -s %{name} $RPM_BUILD_ROOT%{_bindir}/thunderbird
394 ln -s %{name} $RPM_BUILD_ROOT%{_bindir}/mozilla-thunderbird
395
396 cp -p %{SOURCE4} $RPM_BUILD_ROOT%{_desktopdir}/%{name}.desktop
397 cp -p %{topdir}/mozilla/icedove/branding/content/icon64.png $RPM_BUILD_ROOT%{_pixmapsdir}/%{name}.png
398
399 # files created by regxpcom -register in post
400 touch $RPM_BUILD_ROOT%{_libdir}/%{name}/components/compreg.dat
401 touch $RPM_BUILD_ROOT%{_libdir}/%{name}/components/xpti.dat
402 cat << 'EOF' > $RPM_BUILD_ROOT%{_libdir}/%{name}/register
403 #!/bin/sh
404 umask 022
405 # make temporary HOME, as it attempts to touch files in $HOME/.mozilla
406 # dangerous if you run this with sudo with keep_env += HOME
407 # also TMPDIR could be pointing to sudo user's homedir so we reset that too.
408 t=$(mktemp -d)
409 %{__rm} -f %{_libdir}/%{name}/components/{compreg,xpti}.dat
410 TMPDIR= TMP= HOME=$t %{_libdir}/%{name}/icedove -register
411 rm -rf $t
412 EOF
413 chmod a+rx $RPM_BUILD_ROOT%{_libdir}/%{name}/register
414
415 %if %{with enigmail}
416 ext_dir=$RPM_BUILD_ROOT%{_libdir}/%{name}/extensions/\{847b3a00-7ab1-11d4-8f02-006008948af5\}
417 install -d $ext_dir/{chrome,components,defaults/preferences}
418 cd mozilla/dist/bin
419 #cp -rfLp chrome/enigmail.jar $ext_dir/chrome
420 #cp -rfLp chrome/enigmime.jar $ext_dir/chrome
421 cp -rfLp components/enig* $ext_dir/components
422 cp -rfLp components/libenigmime.so $ext_dir/components
423 cp -rfLp components/libipc.so $ext_dir/components
424 cp -rfLp components/ipc.xpt $ext_dir/components
425 cp -rfLp defaults/preferences/enigmail.js $ext_dir/defaults/preferences
426 cd -
427 cp -p %{topdir}/mozilla/mailnews/extensions/enigmail/package/install.rdf $ext_dir
428 cp -p %{topdir}/mozilla/mailnews/extensions/enigmail/package/chrome.manifest $ext_dir/chrome.manifest
429 %endif
430
431 # remove unecessary stuff
432 #%%{__rm} $RPM_BUILD_ROOT%{_libdir}/%{name}/README.txt
433 #%%{__rm} $RPM_BUILD_ROOT%{_libdir}/%{name}/components/components.list
434 #%%{__rm} $RPM_BUILD_ROOT%{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/components/components.list
435
436 # never package these. always remove
437 # nss
438 %{__rm} -f $RPM_BUILD_ROOT%{_libdir}/%{name}/lib{freebl3,nss3,nssckbi,nssdbm3,nssutil3,smime3,softokn3,ssl3}.*
439 # nspr
440 %{__rm} -f $RPM_BUILD_ROOT%{_libdir}/%{name}/lib{nspr4,plc4,plds4}.so
441 # mozldap
442 %{__rm} -f $RPM_BUILD_ROOT%{_libdir}/%{name}/lib{ldap,ldif,prldap,ssldap}60.so
443
444 %clean
445 rm -rf $RPM_BUILD_ROOT
446
447 %pretrans
448 if [ -d %{_libdir}/%{name}/dictionaries ] && [ ! -L %{_libdir}/%{name}/dictionaries ]; then
449         mv -v %{_libdir}/%{name}/dictionaries{,.rpmsave}
450 fi
451 for d in chrome defaults icons isp modules res; do
452         if [ -d %{_libdir}/%{name}/$d ] && [ ! -L %{_libdir}/%{name}/$d ]; then
453                 install -d %{_datadir}/%{name}
454                 mv %{_libdir}/%{name}/$d %{_datadir}/%{name}/$d
455         fi
456 done
457 exit 0
458
459 %post
460 %{_libdir}/%{name}/register || :
461
462 %files
463 %defattr(644,root,root,755)
464 %attr(755,root,root) %{_bindir}/icedove
465 %attr(755,root,root) %{_bindir}/mozilla-thunderbird
466 %attr(755,root,root) %{_bindir}/thunderbird
467 %dir %{_libdir}/%{name}
468 %{_libdir}/%{name}/application.ini
469 %{_libdir}/%{name}/platform.ini
470 %{_libdir}/%{name}/blocklist.xml
471 %{_libdir}/%{name}/chrome.manifest
472 %{_libdir}/%{name}/greprefs.js
473 %dir %{_libdir}/%{name}/components
474 %attr(755,root,root) %{_libdir}/%{name}/components/*.so
475 %{_libdir}/%{name}/components/*.js
476 %{_libdir}/%{name}/components/*.xpt
477 %{_libdir}/%{name}/components/components.manifest
478 %{_libdir}/%{name}/components/interfaces.manifest
479 %attr(755,root,root) %{_libdir}/%{name}/libmozalloc.so
480 %attr(755,root,root) %{_libdir}/%{name}/libxpcom.so
481 %attr(755,root,root) %{_libdir}/%{name}/libxul.so
482 %attr(755,root,root) %{_libdir}/%{name}/*.sh
483 %attr(755,root,root) %{_libdir}/%{name}/*-bin
484 %attr(755,root,root) %{_libdir}/%{name}/mozilla-xremote-client
485 %attr(755,root,root) %{_libdir}/%{name}/icedove
486 %attr(755,root,root) %{_libdir}/%{name}/plugin-container
487 %attr(755,root,root) %{_libdir}/%{name}/register
488
489 # symlinks
490 %{_libdir}/%{name}/chrome
491 %{_libdir}/%{name}/defaults
492 %{_libdir}/%{name}/dictionaries
493 %{_libdir}/%{name}/hyphenation
494 %{_libdir}/%{name}/isp
495 %{_libdir}/%{name}/modules
496 %{_libdir}/%{name}/res
497
498 %{_pixmapsdir}/*.png
499 %{_desktopdir}/*.desktop
500
501 %dir %{_datadir}/%{name}
502 %{_datadir}/%{name}/chrome
503 %{_datadir}/%{name}/defaults
504 #%%{_datadir}/%{name}/greprefs
505 %{_datadir}/%{name}/isp
506 %{_datadir}/%{name}/modules
507 %{_datadir}/%{name}/res
508 %{_datadir}/%{name}/extensions
509
510 %if %{with crashreporter}
511 %attr(755,root,root) %{_libdir}/%{name}/crashreporter
512 %{_libdir}/%{name}/crashreporter.ini
513 %{_libdir}/%{name}/Throbber-small.gif
514 %endif
515
516 %dir %{_libdir}/%{name}/extensions
517 %{_libdir}/%{name}/extensions/{972ce4c6-7e08-4474-a285-3208198ce6fd}
518
519 # files created by regxpcom -register
520 %ghost %{_libdir}/%{name}/components/compreg.dat
521 %ghost %{_libdir}/%{name}/components/xpti.dat
522
523 %if %{with lightning}
524 %files addon-lightning
525 %defattr(644,root,root,755)
526 %dir %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}
527 %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/application.ini
528 %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/chrome
529 %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/chrome.manifest
530 %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/defaults
531 %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/install.rdf
532 %dir %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/components
533 %attr(755,root,root) %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/components/*.so
534 %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/components/*.js
535 %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/components/*.manifest
536 %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/components/*.xpt
537 %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/modules
538 %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/calendar-js
539 %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/timezones.sqlite
540 %{_libdir}/%{name}/extensions/calendar-timezones@mozilla.org
541 %endif
542
543 %if %{with enigmail}
544 %files addon-enigmail
545 %defattr(644,root,root,755)
546 %dir %{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}
547 %{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/defaults
548 %{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/chrome
549 %{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/chrome.manifest
550 %{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/install.rdf
551 %dir %{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/components
552 %attr(755,root,root) %{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/components/*.so
553 %{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/components/*.xpt
554 %{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/components/*.js
555 %endif
This page took 0.63535 seconds and 4 git commands to generate.