]> git.pld-linux.org Git - packages/thunderbird.git/blob - icedove.spec
- updated to 11.0
[packages/thunderbird.git] / icedove.spec
1 # TODO:
2 # - separate spec for enigmail
3 # - build with system mozldap
4 #
5 # Conditional builds
6 %bcond_without  enigmail        # don't build enigmail - GPG/PGP support
7 %bcond_without  gnomeui         # disable gnomeui support
8 %bcond_without  gnome           # alias for gnomeui
9 %bcond_without  ldap            # disable e-mail address lookups in LDAP directories
10 %bcond_without  lightning       # disable Sunbird/Lightning calendar
11 %bcond_with     xulrunner       # system xulrunner
12 %bcond_with     crashreporter   # report crashes to crash-stats.mozilla.com
13
14 %if %{without gnome}
15 %undefine       with_gnomeui
16 %endif
17
18 %if 0%{?_enable_debug_packages} != 1
19 %undefine       crashreporter
20 %endif
21
22 %define         enigmail_ver    1.4
23 %define         nspr_ver        4.9
24 %define         nss_ver         3.13.3
25
26 # convert thunderbird release number to platform version: 11.0.x -> 11.0.x
27 %define         xulrunner_main  11.0
28 %define         xulrunner_ver   %(v=%{version}; echo %{xulrunner_main}${v#11.0})
29
30 %if %{without xulrunner}
31 # The actual sqlite version (see RHBZ#480989):
32 %define         sqlite_build_version %(pkg-config --silence-errors --modversion sqlite3 2>/dev/null || echo ERROR)
33 %endif
34
35 Summary:        Icedove - email client
36 Summary(pl.UTF-8):      Icedove - klient poczty
37 Name:           icedove
38 Version:        11.0
39 Release:        1
40 License:        MPL 1.1 or GPL v2+ or LGPL v2.1+
41 Group:          X11/Applications/Networking
42 Source0:        http://releases.mozilla.org/pub/mozilla.org/thunderbird/releases/%{version}/source/thunderbird-%{version}.source.tar.bz2
43 # Source0-md5:  1d7127a3282e62d95eb9b59d47291b70
44 Source1:        http://www.mozilla-enigmail.org/download/source/enigmail-%{enigmail_ver}.tar.gz
45 # Source1-md5:  5cf3d9720ed1cda1b22eabe5457772c2
46 Source2:        %{name}-branding.tar.bz2
47 # Source2-md5:  2da351522bdd7f4a3bd8aaff4c776976
48 Source3:        %{name}-rm_nonfree.sh
49 Source4:        %{name}.desktop
50 Source5:        %{name}.sh
51 Patch0:         %{name}-branding.patch
52 Patch1:         %{name}-enigmail-shared.patch
53 Patch2:         %{name}-system-xulrunner.patch
54 Patch3:         %{name}-fonts.patch
55 Patch4:         %{name}-install.patch
56 Patch5:         %{name}-hunspell.patch
57 Patch6:         %{name}-prefs.patch
58 Patch7:         system-mozldap.patch
59 Patch8:         %{name}-makefile.patch
60
61 Patch10:        %{name}-extensiondir.patch
62 Patch11:        crashreporter.patch
63 Patch12:        no-subshell.patch
64 URL:            http://www.pld-linux.org/Packages/Icedove
65 BuildRequires:  GConf2-devel >= 1.2.1
66 BuildRequires:  alsa-lib-devel
67 BuildRequires:  automake
68 BuildRequires:  bzip2-devel
69 BuildRequires:  cairo-devel >= 1.10
70 BuildRequires:  dbus-glib-devel >= 0.60
71 BuildRequires:  freetype-devel >= 1:2.1.8
72 BuildRequires:  glib2-devel >= 2.0
73 BuildRequires:  gtk+2-devel >= 2:2.10.0
74 BuildRequires:  hunspell-devel
75 BuildRequires:  libIDL-devel >= 0.8.0
76 %{?with_gnomeui:BuildRequires:  libgnome-devel >= 2.0}
77 %{?with_gnomeui:BuildRequires:  libgnome-keyring-devel}
78 %{?with_gnomeui:BuildRequires:  libgnomeui-devel >= 2.2.0}
79 BuildRequires:  libiw-devel
80 BuildRequires:  libjpeg-devel >= 6b
81 BuildRequires:  libnotify-devel >= 0.4
82 BuildRequires:  libpng-devel >= 1.4.1
83 BuildRequires:  libstdc++-devel
84 BuildRequires:  nspr-devel >= 1:%{nspr_ver}
85 BuildRequires:  nss-devel >= 1:%{nss_ver}
86 BuildRequires:  pango-devel >= 1:1.1.0
87 BuildRequires:  perl-base >= 1:5.6
88 BuildRequires:  pkgconfig
89 BuildRequires:  python >= 1:2.5
90 BuildRequires:  sed >= 4.0
91 BuildRequires:  sqlite3-devel >= 3.7.4
92 BuildRequires:  startup-notification-devel >= 0.8
93 BuildRequires:  xorg-lib-libXext-devel
94 BuildRequires:  xorg-lib-libXinerama-devel
95 BuildRequires:  xorg-lib-libXt-devel
96 BuildRequires:  yasm
97 BuildRequires:  zip
98 %if %{with xulrunner}
99 BuildRequires:  xulrunner-devel >= 2:%{xulrunner_ver}
100 %else
101 Requires:       myspell-common
102 Requires:       nspr >= 1:%{nspr_ver}
103 Requires:       nss >= 1:%{nss_ver}
104 Requires:       sqlite3 >= %{sqlite_build_version}
105 %endif
106 Requires(post): mktemp >= 1.5-18
107 %if %{with xulrunner}
108 %requires_eq_to xulrunner xulrunner-devel
109 %endif
110 Obsoletes:      mozilla-thunderbird
111 Obsoletes:      mozilla-thunderbird-dictionary-en-US
112 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
113
114 %define         filterout_cpp           -D_FORTIFY_SOURCE=[0-9]+
115
116 # iceweasel/icedove/iceape provide their own versions
117 %define         _noautoprovfiles        %{_libdir}/%{name}/components
118 # we don't want these to satisfy xulrunner-devel
119 %define         _noautoprov             libmozjs.so libxpcom.so libxul.so
120 # and as we don't provide them, don't require either
121 %define         _noautoreq              libmozjs.so libxpcom.so libxul.so
122
123 %define         topdir          %{_builddir}/%{name}-%{version}
124 %define         objdir          %{topdir}/obj-%{_target_cpu}
125
126 %description
127 Icedove is an open-source, fast and portable email client.
128
129 %description -l pl.UTF-8
130 Icedove jest mającym otwarte źródła, szybkim i przenośnym klientem
131 poczty.
132
133 %package addon-lightning
134 Summary:        An integrated calendar for Icedove
135 Summary(pl.UTF-8):      Zintegrowany kalendarz dla Icedove
136 License:        MPL 1.1 or GPL v2+ or LGPL v2.1+
137 Group:          Applications/Networking
138 Requires:       %{name} = %{version}-%{release}
139
140 %description addon-lightning
141 Lightning is an calendar extension to Icedove email client.
142
143 %description addon-lightning -l pl.UTF-8
144 Lightning to rozszerzenie do klienta poczty Icedove dodające
145 funkcjonalność kalendarza.
146
147 %package addon-enigmail
148 Summary:        Extension for the authentication and encryption features provided by GnuPG
149 Summary(pl.UTF-8):      Rozszerzenie do uwierzytelniania i szyfrowania zapewnianego przez GnuPG
150 License:        MPL/LGPL
151 Group:          Applications/Networking
152 URL:            http://enigmail.mozdev.org/
153 Requires:       %{name} = %{version}-%{release}
154 Requires:       gnupg
155 Obsoletes:      mozilla-thunderbird-addon-enigmail
156
157 %description addon-enigmail
158 Enigmail is an extension to the Icedove mail client which allows users
159 to access the authentication and encryption features provided by
160 GnuPG.
161
162 Main Features:
163 - Encrypt/sign mail when sending, decrypt/authenticate received mail
164 - Support for inline-PGP (RFC 2440) and PGP/MIME (RFC 3156)
165 - Per-Account based encryption and signing defaults
166 - Per-Recipient rules for automated key selection, and
167   enabling/disabling encryption and signing
168 - OpenPGP key management interface
169
170 %description addon-enigmail -l pl.UTF-8
171 Enigmail to rozszerzenie klienta pocztowego Icedove pozwalające
172 użytkownikom na dostęp do uwierzytelniania i szyfrowania zapewnianego
173 przez GnuPG.
174
175 Główne możliwości:
176 - szyfrowanie/podpisywanie poczty przy wysyłaniu,
177   odszyfrowywanie/uwierzytelnianie poczty odebranej
178 - obsługa inline-PGP (RFC 2440) i PGP/MIME (RFC 3156)
179 - ustawienia domyślne szyfrowania i podpisywania dla każdego konta
180 - reguły automatycznego wyboru kluczy i włączenia szyfrowania oraz
181   podpisywania dla każdego adresata
182 - interfejs do zarządzania kluczami OpenPGP
183
184 %prep
185 %setup -qc
186 mv comm-release mozilla
187 %setup -q -T -D -a2
188 cd mozilla
189 %{?with_enigmail:%{__gzip} -dc %{SOURCE1} | %{__tar} -xf - -C mailnews/extensions}
190 /bin/sh %{SOURCE3}
191 %patch0 -p1
192 %{?with_enigmail:%patch1 -p1}
193 %{?with_system_xulrunner:%patch2 -p1}
194 %patch3 -p1
195 %patch4 -p1
196 %patch6 -p1
197 %patch7 -p1
198 %patch8 -p2
199 %patch10 -p2
200 %patch11 -p2
201 %patch12 -p1
202
203 %build
204 cd mozilla
205 cp -f %{_datadir}/automake/config.* mozilla/build/autoconf
206 cp -f %{_datadir}/automake/config.* mozilla/nsprpub/build/autoconf
207 cp -f %{_datadir}/automake/config.* ldap/sdks/c-sdk/config/autoconf
208
209 cat << EOF > .mozconfig
210 mk_add_options MOZ_OBJDIR=%{objdir}
211
212 export CFLAGS="%{rpmcflags}"
213 # use c++0x for char16_t (like in xulrunner 10.0.x)
214 export CXXFLAGS="%{rpmcflags}%{?with_system_xulrunner: -std=gnu++0x}"
215
216 %if %{with crashreporter}
217 export MOZ_DEBUG_SYMBOLS=1
218 %endif
219
220 # Options for 'configure' (same as command-line options).
221 ac_add_options --prefix=%{_prefix}
222 ac_add_options --exec-prefix=%{_exec_prefix}
223 ac_add_options --bindir=%{_bindir}
224 ac_add_options --sbindir=%{_sbindir}
225 ac_add_options --sysconfdir=%{_sysconfdir}
226 ac_add_options --datadir=%{_datadir}
227 ac_add_options --includedir=%{_includedir}
228 ac_add_options --libdir=%{_libdir}
229 ac_add_options --libexecdir=%{_libexecdir}
230 ac_add_options --localstatedir=%{_localstatedir}
231 ac_add_options --sharedstatedir=%{_sharedstatedir}
232 ac_add_options --mandir=%{_mandir}
233 ac_add_options --infodir=%{_infodir}
234 %if %{?debug:1}0
235 ac_add_options --disable-optimize
236 ac_add_options --enable-debug
237 ac_add_options --enable-debug-modules
238 ac_add_options --enable-debugger-info-modules
239 ac_add_options --enable-crash-on-assert
240 %else
241 ac_add_options --disable-debug
242 ac_add_options --disable-debug-modules
243 ac_add_options --disable-logging
244 ac_add_options --enable-optimize="%{rpmcflags} -Os"
245 %endif
246 ac_add_options --disable-strip
247 ac_add_options --disable-strip-libs
248 %if %{with tests}
249 ac_add_options --enable-tests
250 %else
251 ac_add_options --disable-tests
252 %endif
253 ac_add_options --enable-gio
254 %if %{with gnomeui}
255 ac_add_options --enable-gnomeui
256 %else
257 ac_add_options --disable-gnomeui
258 %endif
259 ac_add_options --disable-gnomevfs
260 %if %{with ldap}
261 ac_add_options --enable-ldap
262 ac_add_options --with-system-ldap
263 %else
264 ac_add_options --disable-ldap
265 %endif
266 %if %{with crashreporter}
267 ac_add_options --enable-crashreporter
268 %else
269 ac_add_options --disable-crashreporter
270 %endif
271 ac_add_options --disable-xterm-updates
272 ac_add_options --enable-postscript
273 %if %{with lightning}
274 ac_add_options --enable-calendar
275 %else
276 ac_add_options --disable-calendar
277 %endif
278 ac_add_options --disable-installer
279 ac_add_options --disable-updater
280 ac_add_options --disable-xprint
281 ac_add_options --disable-permissions
282 ac_add_options --disable-pref-extensions
283 ac_add_options --enable-canvas
284 ac_add_options --enable-crypto
285 ac_add_options --enable-mathml
286 ac_add_options --enable-pango
287 ac_add_options --enable-reorder
288 ac_add_options --enable-startup-notification
289 ac_add_options --enable-svg
290 ac_add_options --enable-system-cairo
291 ac_add_options --enable-system-hunspell
292 ac_add_options --enable-system-sqlite
293 ac_add_options --enable-xft
294 ac_add_options --enable-application=mail
295 ac_add_options --enable-default-toolkit=cairo-gtk2
296 ac_add_options --enable-xinerama
297 ac_add_options --with-distribution-id=org.pld-linux
298 ac_add_options --with-branding=icedove/branding
299 %if %{with xulrunner}
300 ac_add_options --enable-shared-js
301 ac_add_options --with-libxul-sdk=$(pkg-config --variable=sdkdir libxul)
302 ac_add_options --with-system-libxul
303 %endif
304 ac_add_options --with-pthreads
305 ac_add_options --with-system-bz2
306 ac_add_options --with-system-jpeg
307 ac_add_options --with-system-nspr
308 ac_add_options --with-system-nss
309 ac_add_options --with-system-png
310 ac_add_options --with-system-zlib
311 ac_add_options --enable-single-profile
312 ac_add_options --disable-profilesharing
313 ac_add_options --with-default-mozilla-five-home=%{_libdir}/%{name}
314 EOF
315
316 %{__make} -j1 -f client.mk build \
317         STRIP="/bin/true" \
318         MOZ_MAKE_FLAGS="%{?_smp_mflags}" \
319         CC="%{__cc}" \
320         CXX="%{__cxx}"
321
322 %if %{with crashreporter}
323 # create debuginfo for crash-stats.mozilla.com
324 %{__make} -j1 -C obj-%{_target_cpu} buildsymbols
325 %endif
326
327 %if %{with enigmail}
328 cd mailnews/extensions/enigmail
329 ./makemake -r -o %{objdir}
330 %{__make} -C %{objdir}/mailnews/extensions/enigmail \
331         STRIP="/bin/true" \
332         CC="%{__cc}" \
333         CXX="%{__cxx}"
334 %endif
335
336 %install
337 rm -rf $RPM_BUILD_ROOT
338 install -d $RPM_BUILD_ROOT{%{_bindir},%{_libdir}/%{name},%{_datadir}/%{name},%{_pixmapsdir},%{_desktopdir}}
339
340 cd %{objdir}
341 %{__make} -C mail/installer stage-package \
342         DESTDIR=$RPM_BUILD_ROOT \
343         MOZ_PKG_DIR=%{_libdir}/%{name} \
344         PKG_SKIP_STRIP=1
345
346 # Enable crash reporter for Firefox application
347 %if %{with crashreporter}
348 %{__sed} -i -e 's/\[Crash Reporter\]/[Crash Reporter]\nEnabled=1/' $RPM_BUILD_ROOT%{_libdir}/%{name}/application.ini
349
350 # Add debuginfo for crash-stats.mozilla.com
351 install -d $RPM_BUILD_ROOT%{_exec_prefix}/lib/debug%{_libdir}/%{name}
352 cp -a mozilla/dist/%{name}-%{version}.en-US.linux-*.crashreporter-symbols.zip $RPM_BUILD_ROOT%{_prefix}/lib/debug%{_libdir}/%{name}
353 %endif
354
355 # copy manually lightning files, somewhy they are not installed by make
356 cp -a mozilla/dist/bin/extensions/calendar-timezones@mozilla.org \
357         mozilla/dist/bin/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103} \
358         $RPM_BUILD_ROOT%{_libdir}/%{name}/extensions
359
360 # move arch independant ones to datadir
361 mv $RPM_BUILD_ROOT%{_libdir}/%{name}/chrome $RPM_BUILD_ROOT%{_datadir}/%{name}/chrome
362 mv $RPM_BUILD_ROOT%{_libdir}/%{name}/defaults $RPM_BUILD_ROOT%{_datadir}/%{name}/defaults
363 mv $RPM_BUILD_ROOT%{_libdir}/%{name}/isp $RPM_BUILD_ROOT%{_datadir}/%{name}/isp
364 mv $RPM_BUILD_ROOT%{_libdir}/%{name}/modules $RPM_BUILD_ROOT%{_datadir}/%{name}/modules
365 mv $RPM_BUILD_ROOT%{_libdir}/%{name}/res $RPM_BUILD_ROOT%{_datadir}/%{name}/res
366 mv $RPM_BUILD_ROOT%{_libdir}/%{name}/searchplugins $RPM_BUILD_ROOT%{_datadir}/%{name}/searchplugins
367 ln -s ../../share/%{name}/chrome $RPM_BUILD_ROOT%{_libdir}/%{name}/chrome
368 ln -s ../../share/%{name}/defaults $RPM_BUILD_ROOT%{_libdir}/%{name}/defaults
369 ln -s ../../share/%{name}/isp $RPM_BUILD_ROOT%{_libdir}/%{name}/isp
370 ln -s ../../share/%{name}/modules $RPM_BUILD_ROOT%{_libdir}/%{name}/modules
371 ln -s ../../share/%{name}/res $RPM_BUILD_ROOT%{_libdir}/%{name}/res
372 ln -s ../../share/%{name}/searchplugins $RPM_BUILD_ROOT%{_libdir}/%{name}/searchplugins
373
374 # dir for arch independant extensions besides arch dependant extensions
375 # see mozilla/xpcom/build/nsXULAppAPI.h
376 # XRE_SYS_LOCAL_EXTENSION_PARENT_DIR and XRE_SYS_SHARE_EXTENSION_PARENT_DIR
377 install -d $RPM_BUILD_ROOT%{_datadir}/%{name}/extensions
378
379 %{__rm} -r $RPM_BUILD_ROOT%{_libdir}/%{name}/dictionaries
380 ln -s %{_datadir}/myspell $RPM_BUILD_ROOT%{_libdir}/%{name}/dictionaries
381
382 %{__rm} -r $RPM_BUILD_ROOT%{_libdir}/%{name}/hyphenation
383 ln -s %{_datadir}/myspell $RPM_BUILD_ROOT%{_libdir}/%{name}/hyphenation
384
385 %{__sed} -e 's,@LIBDIR@,%{_libdir},' %{SOURCE5} > $RPM_BUILD_ROOT%{_bindir}/icedove
386 ln -s %{name} $RPM_BUILD_ROOT%{_bindir}/thunderbird
387 ln -s %{name} $RPM_BUILD_ROOT%{_bindir}/mozilla-thunderbird
388
389 cp -p %{SOURCE4} $RPM_BUILD_ROOT%{_desktopdir}/%{name}.desktop
390 cp -p %{topdir}/mozilla/icedove/branding/content/icon64.png $RPM_BUILD_ROOT%{_pixmapsdir}/%{name}.png
391
392 # files created by regxpcom -register in post
393 touch $RPM_BUILD_ROOT%{_libdir}/%{name}/components/compreg.dat
394 touch $RPM_BUILD_ROOT%{_libdir}/%{name}/components/xpti.dat
395 cat << 'EOF' > $RPM_BUILD_ROOT%{_libdir}/%{name}/register
396 #!/bin/sh
397 umask 022
398 # make temporary HOME, as it attempts to touch files in $HOME/.mozilla
399 # dangerous if you run this with sudo with keep_env += HOME
400 # also TMPDIR could be pointing to sudo user's homedir so we reset that too.
401 t=$(mktemp -d)
402 %{__rm} -f %{_libdir}/%{name}/components/{compreg,xpti}.dat
403 TMPDIR= TMP= HOME=$t %{_libdir}/%{name}/icedove -register
404 rm -rf $t
405 EOF
406 chmod a+rx $RPM_BUILD_ROOT%{_libdir}/%{name}/register
407
408 %if %{with enigmail}
409 ext_dir=$RPM_BUILD_ROOT%{_libdir}/%{name}/extensions/\{847b3a00-7ab1-11d4-8f02-006008948af5\}
410 install -d $ext_dir/{chrome,components,defaults/preferences}
411 cd mozilla/dist/bin
412 #cp -rfLp chrome/enigmail.jar $ext_dir/chrome
413 #cp -rfLp chrome/enigmime.jar $ext_dir/chrome
414 cp -rfLp components/enig* $ext_dir/components
415 cp -rfLp components/libenigmime.so $ext_dir/components
416 cp -rfLp components/libipc.so $ext_dir/components
417 cp -rfLp components/ipc.xpt $ext_dir/components
418 cp -rfLp defaults/preferences/enigmail.js $ext_dir/defaults/preferences
419 cd -
420 cp -p %{topdir}/mozilla/mailnews/extensions/enigmail/package/install.rdf $ext_dir
421 cp -p %{topdir}/mozilla/mailnews/extensions/enigmail/package/chrome.manifest $ext_dir/chrome.manifest
422 %endif
423
424 # never package these. always remove
425 # nss
426 %{__rm} -f $RPM_BUILD_ROOT%{_libdir}/%{name}/lib{freebl3,nss3,nssckbi,nssdbm3,nssutil3,smime3,softokn3,ssl3}.*
427 # nspr
428 %{__rm} -f $RPM_BUILD_ROOT%{_libdir}/%{name}/lib{nspr4,plc4,plds4}.so
429 # mozldap
430 %{__rm} -f $RPM_BUILD_ROOT%{_libdir}/%{name}/lib{ldap,ldif,prldap,ssldap}60.so
431
432 %clean
433 rm -rf $RPM_BUILD_ROOT
434
435 %pretrans
436 if [ -d %{_libdir}/%{name}/dictionaries ] && [ ! -L %{_libdir}/%{name}/dictionaries ]; then
437         mv -v %{_libdir}/%{name}/dictionaries{,.rpmsave}
438 fi
439 for d in chrome defaults icons isp modules res searchplugins; do
440         if [ -d %{_libdir}/%{name}/$d ] && [ ! -L %{_libdir}/%{name}/$d ]; then
441                 install -d %{_datadir}/%{name}
442                 mv %{_libdir}/%{name}/$d %{_datadir}/%{name}/$d
443         fi
444 done
445 exit 0
446
447 %post
448 %{_libdir}/%{name}/register || :
449
450 %files
451 %defattr(644,root,root,755)
452 %attr(755,root,root) %{_bindir}/icedove
453 %attr(755,root,root) %{_bindir}/mozilla-thunderbird
454 %attr(755,root,root) %{_bindir}/thunderbird
455 %dir %{_libdir}/%{name}
456 %{_libdir}/%{name}/application.ini
457 %{_libdir}/%{name}/platform.ini
458 %{_libdir}/%{name}/blocklist.xml
459 %{_libdir}/%{name}/chrome.manifest
460 %{_libdir}/%{name}/greprefs.js
461 %dir %{_libdir}/%{name}/components
462 %attr(755,root,root) %{_libdir}/%{name}/components/*.so
463 %{_libdir}/%{name}/components/*.js
464 %{_libdir}/%{name}/components/*.xpt
465 %{_libdir}/%{name}/components/components.manifest
466 %{_libdir}/%{name}/components/interfaces.manifest
467 %attr(755,root,root) %{_libdir}/%{name}/libmozalloc.so
468 %attr(755,root,root) %{_libdir}/%{name}/libxpcom.so
469 %attr(755,root,root) %{_libdir}/%{name}/libxul.so
470 %attr(755,root,root) %{_libdir}/%{name}/*.sh
471 %attr(755,root,root) %{_libdir}/%{name}/*-bin
472 %attr(755,root,root) %{_libdir}/%{name}/mozilla-xremote-client
473 %attr(755,root,root) %{_libdir}/%{name}/icedove
474 %attr(755,root,root) %{_libdir}/%{name}/plugin-container
475 %attr(755,root,root) %{_libdir}/%{name}/register
476
477 # symlinks
478 %{_libdir}/%{name}/chrome
479 %{_libdir}/%{name}/defaults
480 %{_libdir}/%{name}/dictionaries
481 %{_libdir}/%{name}/hyphenation
482 %{_libdir}/%{name}/isp
483 %{_libdir}/%{name}/modules
484 %{_libdir}/%{name}/res
485 %{_libdir}/%{name}/searchplugins
486
487 %{_pixmapsdir}/icedove.png
488 %{_desktopdir}/icedove.desktop
489
490 %dir %{_datadir}/%{name}
491 %{_datadir}/%{name}/chrome
492 %{_datadir}/%{name}/defaults
493 %{_datadir}/%{name}/extensions
494 %{_datadir}/%{name}/isp
495 %{_datadir}/%{name}/modules
496 %{_datadir}/%{name}/res
497 %{_datadir}/%{name}/searchplugins
498
499 %if %{with crashreporter}
500 %attr(755,root,root) %{_libdir}/%{name}/crashreporter
501 %{_libdir}/%{name}/crashreporter.ini
502 %{_libdir}/%{name}/Throbber-small.gif
503 %endif
504
505 %dir %{_libdir}/%{name}/extensions
506 %{_libdir}/%{name}/extensions/{972ce4c6-7e08-4474-a285-3208198ce6fd}
507
508 # files created by regxpcom -register
509 %ghost %{_libdir}/%{name}/components/compreg.dat
510 %ghost %{_libdir}/%{name}/components/xpti.dat
511
512 %if %{with lightning}
513 %files addon-lightning
514 %defattr(644,root,root,755)
515 %dir %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}
516 %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/application.ini
517 %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/chrome
518 %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/chrome.manifest
519 %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/defaults
520 %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/install.rdf
521 %dir %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/components
522 %attr(755,root,root) %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/components/*.so
523 %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/components/*.js
524 %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/components/*.manifest
525 %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/components/*.xpt
526 %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/modules
527 %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/calendar-js
528 %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/timezones.sqlite
529 %{_libdir}/%{name}/extensions/calendar-timezones@mozilla.org
530 %endif
531
532 %if %{with enigmail}
533 %files addon-enigmail
534 %defattr(644,root,root,755)
535 %dir %{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}
536 %{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/defaults
537 %{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/chrome
538 %{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/chrome.manifest
539 %{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/install.rdf
540 %dir %{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/components
541 %attr(755,root,root) %{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/components/*.so
542 %{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/components/*.xpt
543 %{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/components/*.js
544 %endif
This page took 0.09578 seconds and 4 git commands to generate.