]> git.pld-linux.org Git - packages/thunderbird.git/blob - icedove.spec
- dropped gnome-vfs2, enabled gio
[packages/thunderbird.git] / icedove.spec
1 # TODO:
2 # - separate spec for enigmail
3 # - build with system mozldap
4 # - files:
5 #   /usr/lib/icedove/hyphenation/hyph_en_US.dic (and more, more hyph dicts)
6 # - enigmail - new version needed
7 #
8 # Conditional builds
9 %bcond_without  enigmail        # don't build enigmail - GPG/PGP support
10 %bcond_without  gnomeui         # disable gnomeui support
11 %bcond_without  gnome           # alias for gnomeui
12 %bcond_without  ldap            # disable e-mail address lookups in LDAP directories
13 %bcond_without  lightning       # disable Sunbird/Lightning calendar
14 %bcond_without  xulrunner       # build with xulrunner
15 %bcond_with     crashreporter   # report crashes to crash-stats.mozilla.com
16
17 %if %{without gnome}
18 %undefine       with_gnomeui
19 %endif
20
21 %if 0%{?_enable_debug_packages} != 1
22 %undefine       crashreporter
23 %endif
24
25 %define         enigmail_ver    1.3.4
26 %define         nspr_ver        4.8.8
27 %define         nss_ver         3.12.10
28
29 # convert firefox release number to platform version: 9.0.x -> 9.0.x
30 %define         xulrunner_main  9.0
31 %define         xulrunner_ver   %(v=%{version}; echo %{xulrunner_main}${v#9.0})
32
33 %if %{without xulrunner}
34 # The actual sqlite version (see RHBZ#480989):
35 %define         sqlite_build_version %(pkg-config --silence-errors --modversion sqlite3 2>/dev/null || echo ERROR)
36 %endif
37
38 Summary:        Icedove - email client
39 Summary(pl.UTF-8):      Icedove - klient poczty
40 Name:           icedove
41 Version:        9.0.1
42 Release:        0.1
43 License:        MPL 1.1 or GPL v2+ or LGPL v2.1+
44 Group:          X11/Applications/Networking
45 Source0:        http://releases.mozilla.org/pub/mozilla.org/thunderbird/releases/%{version}/source/thunderbird-%{version}.source.tar.bz2
46 # Source0-md5:  a5904751dbd33074682b438b732fdbab
47 Source1:        http://www.mozilla-enigmail.org/download/source/enigmail-%{enigmail_ver}.tar.gz
48 # Source1-md5:  2b5f188791811d248b6ff1fc51a5806a
49 Source2:        %{name}-branding.tar.bz2
50 # Source2-md5:  2da351522bdd7f4a3bd8aaff4c776976
51 Source3:        %{name}-rm_nonfree.sh
52 Source4:        %{name}.desktop
53 Source5:        %{name}.sh
54 Patch0:         %{name}-branding.patch
55 Patch1:         %{name}-enigmail-shared.patch
56 Patch2:         %{name}-gcc.patch
57 Patch3:         %{name}-fonts.patch
58 Patch4:         %{name}-install.patch
59 Patch5:         %{name}-hunspell.patch
60 Patch6:         %{name}-prefs.patch
61 Patch7:         system-mozldap.patch
62 Patch8:         %{name}-makefile.patch
63 Patch9:         %{name}-libpng.patch
64 Patch10:        %{name}-extensiondir.patch
65 Patch11:        crashreporter.patch
66 Patch12:        no-subshell.patch
67 URL:            http://www.pld-linux.org/Packages/Icedove
68 BuildRequires:  GConf2-devel >= 1.2.1
69 BuildRequires:  alsa-lib-devel
70 BuildRequires:  automake
71 BuildRequires:  bzip2-devel
72 BuildRequires:  cairo-devel >= 1.10
73 BuildRequires:  dbus-glib-devel >= 0.60
74 BuildRequires:  freetype-devel >= 1:2.1.8
75 BuildRequires:  glib2-devel >= 2.0
76 BuildRequires:  gtk+2-devel >= 2:2.10.0
77 BuildRequires:  hunspell-devel
78 BuildRequires:  libIDL-devel >= 0.8.0
79 %{?with_gnomeui:BuildRequires:  libgnome-devel >= 2.0}
80 %{?with_gnomeui:BuildRequires:  libgnome-keyring-devel}
81 %{?with_gnomeui:BuildRequires:  libgnomeui-devel >= 2.2.0}
82 BuildRequires:  libiw-devel
83 BuildRequires:  libjpeg-devel >= 6b
84 BuildRequires:  libnotify-devel >= 0.4
85 BuildRequires:  libpng-devel >= 1.4.1
86 BuildRequires:  libstdc++-devel
87 BuildRequires:  nspr-devel >= 1:%{nspr_ver}
88 BuildRequires:  nss-devel >= 1:%{nss_ver}
89 BuildRequires:  pango-devel >= 1:1.1.0
90 BuildRequires:  perl-base >= 1:5.6
91 BuildRequires:  pkgconfig
92 BuildRequires:  python >= 1:2.5
93 BuildRequires:  sed >= 4.0
94 BuildRequires:  sqlite3-devel >= 3.7.4
95 BuildRequires:  startup-notification-devel >= 0.8
96 BuildRequires:  xorg-lib-libXext-devel
97 BuildRequires:  xorg-lib-libXinerama-devel
98 BuildRequires:  xorg-lib-libXt-devel
99 BuildRequires:  yasm
100 BuildRequires:  zip
101 %if %{with xulrunner}
102 BuildRequires:  xulrunner-devel >= 2:%{xulrunner_ver}
103 %else
104 Requires:       myspell-common
105 Requires:       nspr >= 1:%{nspr_ver}
106 Requires:       nss >= 1:%{nss_ver}
107 Requires:       sqlite3 >= %{sqlite_build_version}
108 %endif
109 Requires(post): mktemp >= 1.5-18
110 %if %{with xulrunner}
111 %requires_eq_to xulrunner xulrunner-devel
112 %endif
113 Obsoletes:      mozilla-thunderbird
114 Obsoletes:      mozilla-thunderbird-dictionary-en-US
115 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
116
117 %define         filterout_cpp           -D_FORTIFY_SOURCE=[0-9]+
118
119 # iceweasel/icedove/iceape provide their own versions
120 %define         _noautoreqdep           libgfxpsshar.so libgkgfx.so libgtkxtbin.so libjsj.so libxpcom_compat.so libxpistub.so
121 %define         _noautoprovfiles        %{_libdir}/%{name}/components
122 # we don't want these to satisfy xulrunner-devel
123 %define         _noautoprov             libgtkembedmoz.so libmozjs.so libxpcom.so libxul.so libxpcom_core.so
124 # and as we don't provide them, don't require either
125 %define         _noautoreq              libgtkembedmoz.so libmozjs.so libxpcom.so libxul.so libxpcom_core.so
126
127 %define         topdir          %{_builddir}/%{name}-%{version}
128 %define         objdir          %{topdir}/obj-%{_target_cpu}
129
130 %description
131 Icedove is an open-source, fast and portable email client.
132
133 %description -l pl.UTF-8
134 Icedove jest mającym otwarte źródła, szybkim i przenośnym klientem
135 poczty.
136
137 %package addon-lightning
138 Summary:        An integrated calendar for Icedove
139 Summary(pl.UTF-8):      Zintegrowany kalendarz dla Icedove
140 License:        MPL 1.1 or GPL v2+ or LGPL v2.1+
141 Group:          Applications/Networking
142 Requires:       %{name} = %{version}-%{release}
143
144 %description addon-lightning
145 Lightning is an calendar extension to Icedove email client.
146
147 %description addon-lightning -l pl.UTF-8
148 Lightning to rozszerzenie do klienta poczty Icedove dodające
149 funkcjonalność kalendarza.
150
151 %package addon-enigmail
152 Summary:        Extension for the authentication and encryption features provided by GnuPG
153 Summary(pl.UTF-8):      Rozszerzenie do uwierzytelniania i szyfrowania zapewnianego przez GnuPG
154 License:        MPL/LGPL
155 Group:          Applications/Networking
156 URL:            http://enigmail.mozdev.org/
157 Requires:       %{name} = %{version}-%{release}
158 Requires:       gnupg
159 Obsoletes:      mozilla-thunderbird-addon-enigmail
160
161 %description addon-enigmail
162 Enigmail is an extension to the Icedove mail client which allows users
163 to access the authentication and encryption features provided by
164 GnuPG.
165
166 Main Features:
167 - Encrypt/sign mail when sending, decrypt/authenticate received mail
168 - Support for inline-PGP (RFC 2440) and PGP/MIME (RFC 3156)
169 - Per-Account based encryption and signing defaults
170 - Per-Recipient rules for automated key selection, and
171   enabling/disabling encryption and signing
172 - OpenPGP key management interface
173
174 %description addon-enigmail -l pl.UTF-8
175 Enigmail to rozszerzenie klienta pocztowego Icedove pozwalające
176 użytkownikom na dostęp do uwierzytelniania i szyfrowania zapewnianego
177 przez GnuPG.
178
179 Główne możliwości:
180 - szyfrowanie/podpisywanie poczty przy wysyłaniu,
181   odszyfrowywanie/uwierzytelnianie poczty odebranej
182 - obsługa inline-PGP (RFC 2440) i PGP/MIME (RFC 3156)
183 - ustawienia domyślne szyfrowania i podpisywania dla każdego konta
184 - reguły automatycznego wyboru kluczy i włączenia szyfrowania oraz
185   podpisywania dla każdego adresata
186 - interfejs do zarządzania kluczami OpenPGP
187
188 %prep
189 %setup -qc
190 mv comm-release mozilla
191 %setup -q -T -D -a2
192 cd mozilla
193 %{?with_enigmail:%{__gzip} -dc %{SOURCE1} | %{__tar} -xf - -C mailnews/extensions}
194 /bin/sh %{SOURCE3}
195 %patch0 -p1
196 %{?with_enigmail:%patch1 -p1}
197 %patch2 -p1
198 %patch3 -p1
199 %patch4 -p1
200 %patch6 -p1
201 %patch7 -p1
202 %patch8 -p2
203 %patch9 -p1
204 %patch10 -p2
205 %patch11 -p2
206 %patch12 -p1
207
208 %build
209 cd mozilla
210 cp -f %{_datadir}/automake/config.* mozilla/build/autoconf
211 cp -f %{_datadir}/automake/config.* mozilla/nsprpub/build/autoconf
212 cp -f %{_datadir}/automake/config.* ldap/sdks/c-sdk/config/autoconf
213
214 install -d libxul-sdk
215 ln -snf %{_libdir}/xulrunner-sdk libxul-sdk/sdk
216
217 cat << EOF > .mozconfig
218 mk_add_options MOZ_OBJDIR=%{objdir}
219
220 export CFLAGS="%{rpmcflags} -fpermissive -I/usr/include/xulrunner"
221 export CXXFLAGS="%{rpmcflags} -fpermissive -I/usr/include/xulrunner"
222
223 %if %{with crashreporter}
224 export MOZ_DEBUG_SYMBOLS=1
225 %endif
226
227 # Options for 'configure' (same as command-line options).
228 ac_add_options --prefix=%{_prefix}
229 ac_add_options --exec-prefix=%{_exec_prefix}
230 ac_add_options --bindir=%{_bindir}
231 ac_add_options --sbindir=%{_sbindir}
232 ac_add_options --sysconfdir=%{_sysconfdir}
233 ac_add_options --datadir=%{_datadir}
234 ac_add_options --includedir=%{_includedir}
235 ac_add_options --libdir=%{_libdir}
236 ac_add_options --libexecdir=%{_libexecdir}
237 ac_add_options --localstatedir=%{_localstatedir}
238 ac_add_options --sharedstatedir=%{_sharedstatedir}
239 ac_add_options --mandir=%{_mandir}
240 ac_add_options --infodir=%{_infodir}
241 %if %{?debug:1}0
242 ac_add_options --disable-optimize
243 ac_add_options --enable-debug
244 ac_add_options --enable-debug-modules
245 ac_add_options --enable-debugger-info-modules
246 ac_add_options --enable-crash-on-assert
247 %else
248 ac_add_options --disable-debug
249 ac_add_options --disable-debug-modules
250 ac_add_options --disable-logging
251 ac_add_options --enable-optimize="%{rpmcflags} -Os"
252 %endif
253 ac_add_options --disable-strip
254 ac_add_options --disable-strip-libs
255 %if %{with tests}
256 ac_add_options --enable-tests
257 %else
258 ac_add_options --disable-tests
259 %endif
260 ac_add_options --enable-gio
261 %if %{with gnomeui}
262 ac_add_options --enable-gnomeui
263 %else
264 ac_add_options --disable-gnomeui
265 %endif
266 ac_add_options --disable-gnomevfs
267 %if %{with ldap}
268 ac_add_options --enable-ldap
269 ac_add_options --with-system-ldap
270 %else
271 ac_add_options --disable-ldap
272 %endif
273 %if %{with crashreporter}
274 ac_add_options --enable-crashreporter
275 %else
276 ac_add_options --disable-crashreporter
277 %endif
278 ac_add_options --disable-xterm-updates
279 ac_add_options --enable-postscript
280 %if %{with lightning}
281 ac_add_options --enable-calendar
282 %else
283 ac_add_options --disable-calendar
284 %endif
285 ac_add_options --disable-installer
286 ac_add_options --disable-jsd
287 ac_add_options --disable-updater
288 ac_add_options --disable-xprint
289 ac_add_options --disable-permissions
290 ac_add_options --disable-pref-extensions
291 ac_add_options --enable-canvas
292 ac_add_options --enable-crypto
293 ac_add_options --enable-mathml
294 ac_add_options --enable-pango
295 ac_add_options --enable-reorder
296 ac_add_options --enable-startup-notification
297 ac_add_options --enable-svg
298 ac_add_options --enable-system-cairo
299 ac_add_options --enable-system-hunspell
300 ac_add_options --enable-system-sqlite
301 ac_add_options --enable-xft
302 ac_add_options --enable-application=mail
303 ac_add_options --enable-default-toolkit=cairo-gtk2
304 ac_add_options --enable-xinerama
305 ac_add_options --with-distribution-id=org.pld-linux
306 ac_add_options --with-branding=icedove/branding
307 %if %{with xulrunner}
308 #ac_add_options --with-libxul-sdk=$(pwd)/libxul-sdk/sdk
309 ac_add_options --with-system-libxul
310 ac_add_options --enable-shared
311 ac_add_options --enable-libxul
312 %else
313 ac_add_options --disable-xul
314 %endif
315 ac_add_options --with-pthreads
316 ac_add_options --with-system-bz2
317 ac_add_options --with-system-jpeg
318 ac_add_options --with-system-nspr
319 ac_add_options --with-system-nss
320 ac_add_options --with-system-png
321 ac_add_options --with-system-zlib
322 ac_add_options --enable-single-profile
323 ac_add_options --disable-profilesharing
324 ac_add_options --with-default-mozilla-five-home=%{_libdir}/%{name}
325 EOF
326
327 %{__make} -j1 -f client.mk build \
328         STRIP="/bin/true" \
329         MOZ_MAKE_FLAGS="%{?_smp_mflags}" \
330         CC="%{__cc}" \
331         CXX="%{__cxx}"
332
333 %if %{with crashreporter}
334 # create debuginfo for crash-stats.mozilla.com
335 %{__make} -j1 -C obj-%{_target_cpu} buildsymbols
336 %endif
337
338 %if %{with enigmail}
339 cd mailnews/extensions/enigmail
340 ./makemake -r -o %{objdir}
341 %{__make} -C %{objdir}/mailnews/extensions/enigmail \
342         STRIP="/bin/true" \
343         CC="%{__cc}" \
344         CXX="%{__cxx}"
345 %endif
346
347 %install
348 rm -rf $RPM_BUILD_ROOT
349 install -d $RPM_BUILD_ROOT{%{_bindir},%{_libdir}/%{name},%{_datadir}/%{name},%{_pixmapsdir},%{_desktopdir}}
350
351 cd %{objdir}
352 %{__make} -C mail/installer stage-package \
353         DESTDIR=$RPM_BUILD_ROOT \
354         MOZ_PKG_DIR=%{_libdir}/%{name} \
355         PKG_SKIP_STRIP=1
356
357 # Enable crash reporter for Firefox application
358 %if %{with crashreporter}
359 %{__sed} -i -e 's/\[Crash Reporter\]/[Crash Reporter]\nEnabled=1/' $RPM_BUILD_ROOT%{_libdir}/%{name}/application.ini
360
361 # Add debuginfo for crash-stats.mozilla.com
362 install -d $RPM_BUILD_ROOT%{_exec_prefix}/lib/debug%{_libdir}/%{name}
363 cp -a mozilla/dist/%{name}-%{version}.en-US.linux-*.crashreporter-symbols.zip $RPM_BUILD_ROOT%{_prefix}/lib/debug%{_libdir}/%{name}
364 %endif
365
366 # copy manually lightning files, somewhy they are not installed by make
367 cp -a mozilla/dist/bin/extensions/calendar-timezones@mozilla.org \
368         mozilla/dist/bin/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103} \
369         $RPM_BUILD_ROOT%{_libdir}/%{name}/extensions
370
371 # move arch independant ones to datadir
372 mv $RPM_BUILD_ROOT%{_libdir}/%{name}/chrome $RPM_BUILD_ROOT%{_datadir}/%{name}/chrome
373 mv $RPM_BUILD_ROOT%{_libdir}/%{name}/defaults $RPM_BUILD_ROOT%{_datadir}/%{name}/defaults
374 mv $RPM_BUILD_ROOT%{_libdir}/%{name}/isp $RPM_BUILD_ROOT%{_datadir}/%{name}/isp
375 mv $RPM_BUILD_ROOT%{_libdir}/%{name}/modules $RPM_BUILD_ROOT%{_datadir}/%{name}/modules
376 mv $RPM_BUILD_ROOT%{_libdir}/%{name}/res $RPM_BUILD_ROOT%{_datadir}/%{name}/res
377 ln -s ../../share/%{name}/chrome $RPM_BUILD_ROOT%{_libdir}/%{name}/chrome
378 ln -s ../../share/%{name}/defaults $RPM_BUILD_ROOT%{_libdir}/%{name}/defaults
379 ln -s ../../share/%{name}/isp $RPM_BUILD_ROOT%{_libdir}/%{name}/isp
380 ln -s ../../share/%{name}/modules $RPM_BUILD_ROOT%{_libdir}/%{name}/modules
381 ln -s ../../share/%{name}/res $RPM_BUILD_ROOT%{_libdir}/%{name}/res
382
383 # dir for arch independant extensions besides arch dependant extensions
384 # see mozilla/xpcom/build/nsXULAppAPI.h
385 # XRE_SYS_LOCAL_EXTENSION_PARENT_DIR and XRE_SYS_SHARE_EXTENSION_PARENT_DIR
386 install -d $RPM_BUILD_ROOT%{_datadir}/%{name}/extensions
387
388 %{__rm} -r $RPM_BUILD_ROOT%{_libdir}/%{name}/dictionaries
389 ln -s %{_datadir}/myspell $RPM_BUILD_ROOT%{_libdir}/%{name}/dictionaries
390
391 %{__sed} -e 's,@LIBDIR@,%{_libdir},' %{SOURCE5} > $RPM_BUILD_ROOT%{_bindir}/icedove
392 ln -s %{name} $RPM_BUILD_ROOT%{_bindir}/thunderbird
393 ln -s %{name} $RPM_BUILD_ROOT%{_bindir}/mozilla-thunderbird
394
395 cp -p %{SOURCE4} $RPM_BUILD_ROOT%{_desktopdir}/%{name}.desktop
396 cp -p %{topdir}/mozilla/icedove/branding/content/icon64.png $RPM_BUILD_ROOT%{_pixmapsdir}/%{name}.png
397
398 # files created by regxpcom -register in post
399 touch $RPM_BUILD_ROOT%{_libdir}/%{name}/components/compreg.dat
400 touch $RPM_BUILD_ROOT%{_libdir}/%{name}/components/xpti.dat
401 cat << 'EOF' > $RPM_BUILD_ROOT%{_libdir}/%{name}/register
402 #!/bin/sh
403 umask 022
404 # make temporary HOME, as it attempts to touch files in $HOME/.mozilla
405 # dangerous if you run this with sudo with keep_env += HOME
406 # also TMPDIR could be pointing to sudo user's homedir so we reset that too.
407 t=$(mktemp -d)
408 %{__rm} -f %{_libdir}/%{name}/components/{compreg,xpti}.dat
409 TMPDIR= TMP= HOME=$t %{_libdir}/%{name}/icedove -register
410 rm -rf $t
411 EOF
412 chmod a+rx $RPM_BUILD_ROOT%{_libdir}/%{name}/register
413
414 %if %{with enigmail}
415 ext_dir=$RPM_BUILD_ROOT%{_libdir}/%{name}/extensions/\{847b3a00-7ab1-11d4-8f02-006008948af5\}
416 install -d $ext_dir/{chrome,components,defaults/preferences}
417 cd mozilla/dist/bin
418 #cp -rfLp chrome/enigmail.jar $ext_dir/chrome
419 #cp -rfLp chrome/enigmime.jar $ext_dir/chrome
420 cp -rfLp components/enig* $ext_dir/components
421 cp -rfLp components/libenigmime.so $ext_dir/components
422 cp -rfLp components/libipc.so $ext_dir/components
423 cp -rfLp components/ipc.xpt $ext_dir/components
424 cp -rfLp defaults/preferences/enigmail.js $ext_dir/defaults/preferences
425 cd -
426 cp -p %{topdir}/mozilla/mailnews/extensions/enigmail/package/install.rdf $ext_dir
427 cp -p %{topdir}/mozilla/mailnews/extensions/enigmail/package/chrome.manifest $ext_dir/chrome.manifest
428 %endif
429
430 # remove unecessary stuff
431 #%%{__rm} $RPM_BUILD_ROOT%{_libdir}/%{name}/README.txt
432 #%%{__rm} $RPM_BUILD_ROOT%{_libdir}/%{name}/components/components.list
433 #%%{__rm} $RPM_BUILD_ROOT%{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/components/components.list
434
435 # never package these. always remove
436 # nss
437 %{__rm} -f $RPM_BUILD_ROOT%{_libdir}/%{name}/lib{freebl3,nss3,nssckbi,nssdbm3,nssutil3,smime3,softokn3,ssl3}.*
438 # nspr
439 %{__rm} -f $RPM_BUILD_ROOT%{_libdir}/%{name}/lib{nspr4,plc4,plds4}.so
440 # mozldap
441 %{__rm} -f $RPM_BUILD_ROOT%{_libdir}/%{name}/lib{ldap,ldif,prldap,ssldap}60.so
442
443 %clean
444 rm -rf $RPM_BUILD_ROOT
445
446 %pretrans
447 if [ -d %{_libdir}/%{name}/dictionaries ] && [ ! -L %{_libdir}/%{name}/dictionaries ]; then
448         mv -v %{_libdir}/%{name}/dictionaries{,.rpmsave}
449 fi
450 for d in chrome defaults icons isp modules res; do
451         if [ -d %{_libdir}/%{name}/$d ] && [ ! -L %{_libdir}/%{name}/$d ]; then
452                 install -d %{_datadir}/%{name}
453                 mv %{_libdir}/%{name}/$d %{_datadir}/%{name}/$d
454         fi
455 done
456 exit 0
457
458 %post
459 %{_libdir}/%{name}/register || :
460
461 %files
462 %defattr(644,root,root,755)
463 %attr(755,root,root) %{_bindir}/icedove
464 %attr(755,root,root) %{_bindir}/mozilla-thunderbird
465 %attr(755,root,root) %{_bindir}/thunderbird
466 %dir %{_libdir}/%{name}
467 %{_libdir}/%{name}/application.ini
468 %{_libdir}/%{name}/platform.ini
469 %{_libdir}/%{name}/blocklist.xml
470 %{_libdir}/%{name}/chrome.manifest
471 %{_libdir}/%{name}/greprefs.js
472 %dir %{_libdir}/%{name}/components
473 %attr(755,root,root) %{_libdir}/%{name}/components/*.so
474 %{_libdir}/%{name}/components/*.js
475 %{_libdir}/%{name}/components/*.xpt
476 %{_libdir}/%{name}/components/components.manifest
477 %{_libdir}/%{name}/components/interfaces.manifest
478 %attr(755,root,root) %{_libdir}/%{name}/libmozalloc.so
479 #%%attr(755,root,root) %{_libdir}/%{name}/libmozjs.so
480 %attr(755,root,root) %{_libdir}/%{name}/libxpcom.so
481 #%%attr(755,root,root) %{_libdir}/%{name}/libxpcom_core.so
482 %attr(755,root,root) %{_libdir}/%{name}/libxul.so
483 %attr(755,root,root) %{_libdir}/%{name}/*.sh
484 %attr(755,root,root) %{_libdir}/%{name}/*-bin
485 %attr(755,root,root) %{_libdir}/%{name}/mozilla-xremote-client
486 %attr(755,root,root) %{_libdir}/%{name}/icedove
487 %attr(755,root,root) %{_libdir}/%{name}/plugin-container
488 %attr(755,root,root) %{_libdir}/%{name}/register
489
490 # symlinks
491 %{_libdir}/%{name}/chrome
492 %{_libdir}/%{name}/defaults
493 %{_libdir}/%{name}/dictionaries
494 #%%{_libdir}/%{name}/greprefs
495 %{_libdir}/%{name}/isp
496 %{_libdir}/%{name}/modules
497 %{_libdir}/%{name}/res
498
499 %{_pixmapsdir}/*.png
500 %{_desktopdir}/*.desktop
501
502 %dir %{_datadir}/%{name}
503 %{_datadir}/%{name}/chrome
504 %{_datadir}/%{name}/defaults
505 #%%{_datadir}/%{name}/greprefs
506 %{_datadir}/%{name}/isp
507 %{_datadir}/%{name}/modules
508 %{_datadir}/%{name}/res
509 %{_datadir}/%{name}/extensions
510
511 %if %{with crashreporter}
512 %attr(755,root,root) %{_libdir}/%{name}/crashreporter
513 %{_libdir}/%{name}/crashreporter.ini
514 %{_libdir}/%{name}/Throbber-small.gif
515 %endif
516
517 %dir %{_libdir}/%{name}/extensions
518 %{_libdir}/%{name}/extensions/{972ce4c6-7e08-4474-a285-3208198ce6fd}
519
520 # files created by regxpcom -register
521 %ghost %{_libdir}/%{name}/components/compreg.dat
522 %ghost %{_libdir}/%{name}/components/xpti.dat
523
524 %if %{with lightning}
525 %files addon-lightning
526 %defattr(644,root,root,755)
527 %dir %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}
528 %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/application.ini
529 %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/chrome
530 %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/chrome.manifest
531 %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/defaults
532 %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/install.rdf
533 %dir %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/components
534 %attr(755,root,root) %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/components/*.so
535 %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/components/*.js
536 %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/components/*.manifest
537 %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/components/*.xpt
538 %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/modules
539 %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/calendar-js
540 %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/timezones.sqlite
541 %{_libdir}/%{name}/extensions/calendar-timezones@mozilla.org
542 %endif
543
544 %if %{with enigmail}
545 %files addon-enigmail
546 %defattr(644,root,root,755)
547 %dir %{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}
548 %{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/defaults
549 %{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/chrome
550 %{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/chrome.manifest
551 %{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/install.rdf
552 %dir %{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/components
553 %attr(755,root,root) %{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/components/*.so
554 %{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/components/*.xpt
555 %{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/components/*.js
556 %endif
This page took 0.092333 seconds and 4 git commands to generate.