]> git.pld-linux.org Git - packages/thunderbird.git/blob - icedove.spec
- BR: alsa-lib-devel, bzip2-devel, libiw-devel, libnotify-devel
[packages/thunderbird.git] / icedove.spec
1 # TODO:
2 # - separate spec for enigmail
3 # - fix icedove (building) and installing nss/nspr libs!
4 # - build with system mozldap
5 # - about dialog broken:
6 #XML Parsing Error: undefined entity
7 #Location: chrome://messenger/content/aboutDialog.xul
8 #Line Number 27, Column 37:        <description id="copyright">&logoTrademark;</description>
9 #------------------------------------^
10 #
11 # Conditional builds
12 %bcond_without  enigmail        # don't build enigmail - GPG/PGP support
13 %bcond_without  gnomeui         # disable gnomeui support
14 %bcond_without  gnomevfs        # disable GNOME comp. (gconf+libgnome+gnomevfs) and gnomevfs ext.
15 %bcond_without  gnome           # disable all GNOME components (gnome+gnomeui+gnomevfs)
16 %bcond_without  ldap            # disable e-mail address lookups in LDAP directories
17 %bcond_without  lightning       # disable sunbird calendar
18 %bcond_with             xulrunner       # build with xulrunner
19 %bcond_with     crashreporter   # report crashes to crash-stats.mozilla.com
20
21 %if %{without gnome}
22 %undefine       with_gnomeui
23 %undefine       with_gnomevfs
24 %endif
25
26 %if %{?_enable_debug_packages} != 1
27 %undefine       crashreporter
28 %endif
29
30 %define         enigmail_ver            1.1.2
31
32 %if %{without xulrunner}
33 # The actual sqlite version (see RHBZ#480989):
34 %define         sqlite_build_version %(pkg-config --silence-errors --modversion sqlite3 2>/dev/null || echo ERROR)
35 %endif
36
37 Summary:        Icedove - email client
38 Summary(pl.UTF-8):      Icedove - klient poczty
39 Name:           icedove
40 Version:        3.1.2
41 Release:        0.10
42 License:        MPL 1.1 or GPL v2+ or LGPL v2.1+
43 Group:          X11/Applications/Networking
44 Source0:        http://releases.mozilla.org/pub/mozilla.org/thunderbird/releases/%{version}/source/thunderbird-%{version}.source.tar.bz2
45 # Source0-md5:  48e80576a7af70e64d30a5162364525a
46 Source1:        http://www.mozilla-enigmail.org/download/source/enigmail-%{enigmail_ver}.tar.gz
47 # Source1-md5:  7d329d5e8afbbb28214ca1995beb09c9
48 Source2:        %{name}-branding.tar.bz2
49 # Source2-md5:  85fdf877e2f1bc41329d8086ef5cf0f1
50 Source3:        %{name}-rm_nonfree.sh
51 Source4:        %{name}.desktop
52 Source5:        %{name}.sh
53 Patch0:         %{name}-branding.patch
54 Patch1:         %{name}-enigmail-shared.patch
55 Patch2:         %{name}-gcc.patch
56 Patch3:         %{name}-fonts.patch
57 Patch4:         %{name}-install.patch
58 Patch5:         %{name}-hunspell.patch
59 Patch6:         %{name}-prefs.patch
60 Patch7:         system-mozldap.patch
61 Patch8:         %{name}-makefile.patch
62 Patch9:         %{name}-libpng.patch
63 Patch10:        %{name}-extensiondir.patch
64 Patch11:        crashreporter.patch
65 URL:            http://www.pld-linux.org/Packages/Icedove
66 %{?with_gnomevfs:BuildRequires: GConf2-devel >= 1.2.1}
67 BuildRequires:  alsa-lib-devel
68 BuildRequires:  automake
69 BuildRequires:  bzip2-devel
70 BuildRequires:  freetype-devel >= 1:2.1.8
71 %{?with_gnomevfs:BuildRequires: gnome-vfs2-devel >= 2.0}
72 BuildRequires:  gtk+2-devel >= 1:2.0.0
73 BuildRequires:  hunspell-devel
74 BuildRequires:  libIDL-devel >= 0.8.0
75 %{?with_gnomevfs:BuildRequires: libgnome-devel >= 2.0}
76 %{?with_gnomeui:BuildRequires:  libgnome-keyring-devel}
77 %{?with_gnomeui:BuildRequires:  libgnomeui-devel >= 2.2.0}
78 BuildRequires:  libiw-devel
79 BuildRequires:  libjpeg-devel >= 6b
80 BuildRequires:  libnotify-devel >= 0.4
81 BuildRequires:  libpng-devel >= 1.2.0
82 BuildRequires:  libstdc++-devel
83 BuildRequires:  nspr-devel >= 1:4.8
84 BuildRequires:  nss-devel >= 1:3.12.0
85 BuildRequires:  pango-devel >= 1:1.1.0
86 BuildRequires:  pkgconfig
87 BuildRequires:  sed >= 4.0
88 BuildRequires:  sqlite3-devel >= 3.6.22
89 BuildRequires:  startup-notification-devel >= 0.8
90 BuildRequires:  xorg-lib-libXext-devel
91 BuildRequires:  xorg-lib-libXinerama-devel
92 BuildRequires:  xorg-lib-libXt-devel
93 BuildRequires:  zip
94 %if %{with xulrunner}
95 %else
96 Requires:       myspell-common
97 Requires:       nspr >= 1:4.6.1
98 Requires:       nss >= 1:3.11.3
99 Requires:       sqlite3 >= %{sqlite_build_version}
100 %endif
101 Obsoletes:      mozilla-thunderbird
102 Obsoletes:      mozilla-thunderbird-dictionary-en-US
103 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
104
105 %define         filterout_cpp           -D_FORTIFY_SOURCE=[0-9]+
106
107 # iceweasel/icedove/iceape provide their own versions
108 %define         _noautoreqdep           libgfxpsshar.so libgkgfx.so libgtkxtbin.so libjsj.so libxpcom_compat.so libxpcom_core.so libxpistub.so
109 %define         _noautoprovfiles        %{_libdir}/%{name}/components
110 # we don't want these to satisfy xulrunner-devel
111 %define         _noautoprov             libgtkembedmoz.so libmozjs.so libxpcom.so libxul.so
112 # and as we don't provide them, don't require either
113 %define         _noautoreq              libgtkembedmoz.so libmozjs.so libxpcom.so libxul.so
114
115 %description
116 Icedove is an open-source,fast and portable email client.
117
118 %description -l pl.UTF-8
119 Icedove jest open sourcowym, szybkim i przenośnym klientem poczty.
120
121 %package addon-lightning
122 Summary:        An integrated calendar for Icedove
123 Summary(pl.UTF-8):      Zintegrowany kalendarz dla Icedove
124 License:        MPL 1.1 or GPL v2+ or LGPL v2.1+
125 Group:          Applications/Networking
126 Requires:       %{name} = %{version}-%{release}
127
128 %description addon-lightning
129 Lightning is an calendar extension to Icedove email client.
130
131 %description addon-lightning -l pl.UTF-8
132 Lightning to rozszerzenie do klienta poczty Icedove dodające
133 funkcjonalność kalendarza.
134
135 %package addon-enigmail
136 Summary:        Extension for the authentication and encryption features provided by GnuPG
137 Summary(pl.UTF-8):      Rozszerzenie do uwierzytelniania i szyfrowania zapewnianego przez GnuPG
138 License:        MPL/LGPL
139 Group:          Applications/Networking
140 URL:            http://enigmail.mozdev.org/
141 Requires:       %{name} = %{version}-%{release}
142 Requires:       gnupg
143 Obsoletes:      mozilla-thunderbird-addon-enigmail
144
145 %description addon-enigmail
146 Enigmail is an extension to the Icedove mail client which allows users
147 to access the authentication and encryption features provided by
148 GnuPG.
149
150 Main Features:
151 - Encrypt/sign mail when sending, decrypt/authenticate received mail
152 - Support for inline-PGP (RFC 2440) and PGP/MIME (RFC 3156)
153 - Per-Account based encryption and signing defaults
154 - Per-Recipient rules for automated key selection, and
155   enabling/disabling encryption and signing
156 - OpenPGP key management interface
157
158 %description addon-enigmail -l pl.UTF-8
159 Enigmail to rozszerzenie klienta pocztowego Icedove pozwalające
160 użytkownikom na dostęp do uwierzytelniania i szyfrowania zapewnianego
161 przez GnuPG.
162
163 Główne możliwości:
164 - szyfrowanie/podpisywanie poczty przy wysyłaniu,
165   odszyfrowywanie/uwierzytelnianie poczty odebranej
166 - obsługa inline-PGP (RFC 2440) i PGP/MIME (RFC 3156)
167 - ustawienia domyślne szyfrowania i podpisywania dla każdego konta
168 - reguły automatycznego wyboru kluczy i włączenia szyfrowania oraz
169   podpisywania dla każdego adresata
170 - interfejs do zarządzania kluczami OpenPGP
171
172 %prep
173 %setup -qc
174 mv -f comm-1.9.2 mozilla
175 %setup -q -T -D -a2
176 cd mozilla
177 %{?with_enigmail:tar xvfz %{SOURCE1} -C mailnews/extensions}
178 /bin/sh %{SOURCE3}
179 %patch0 -p1
180 %{?with_enigmail:%patch1 -p1}
181 %patch2 -p1
182 %patch3 -p1
183 %patch4 -p1
184 %patch5 -p1
185 %patch6 -p1
186 %patch7 -p1
187 %patch8 -p0
188 %patch9 -p0
189 %patch10 -p2
190 %patch11 -p2
191
192 %build
193 cd mozilla
194 cp -f %{_datadir}/automake/config.* mozilla/build/autoconf
195 cp -f %{_datadir}/automake/config.* mozilla/nsprpub/build/autoconf
196 cp -f %{_datadir}/automake/config.* directory/c-sdk/config/autoconf
197
198 install -d libxul-sdk
199 ln -snf %{_libdir}/xulrunner-sdk libxul-sdk/sdk
200
201 cat << EOF > .mozconfig
202 mk_add_options MOZ_OBJDIR=@TOPSRCDIR@/obj-%{_target_cpu}
203
204 export CFLAGS="%{rpmcflags}"
205 export CXXFLAGS="%{rpmcflags}"
206
207 %if %{with crashreporter}
208 export MOZ_DEBUG_SYMBOLS=1
209 %endif
210
211 # Options for 'configure' (same as command-line options).
212 ac_add_options --prefix=%{_prefix}
213 ac_add_options --exec-prefix=%{_exec_prefix}
214 ac_add_options --bindir=%{_bindir}
215 ac_add_options --sbindir=%{_sbindir}
216 ac_add_options --sysconfdir=%{_sysconfdir}
217 ac_add_options --datadir=%{_datadir}
218 ac_add_options --includedir=%{_includedir}
219 ac_add_options --libdir=%{_libdir}
220 ac_add_options --libexecdir=%{_libexecdir}
221 ac_add_options --localstatedir=%{_localstatedir}
222 ac_add_options --sharedstatedir=%{_sharedstatedir}
223 ac_add_options --mandir=%{_mandir}
224 ac_add_options --infodir=%{_infodir}
225 %if %{?debug:1}0
226 ac_add_options --disable-optimize
227 ac_add_options --enable-debug
228 ac_add_options --enable-debug-modules
229 ac_add_options --enable-debugger-info-modules
230 ac_add_options --enable-crash-on-assert
231 %else
232 ac_add_options --disable-debug
233 ac_add_options --disable-debug-modules
234 ac_add_options --disable-logging
235 ac_add_options --enable-optimize="%{rpmcflags} -Os"
236 %endif
237 ac_add_options --disable-strip
238 ac_add_options --disable-strip-libs
239 %if %{with tests}
240 ac_add_options --enable-tests
241 %else
242 ac_add_options --disable-tests
243 %endif
244 %if %{with gnomeui}
245 ac_add_options --enable-gnomeui
246 %else
247 ac_add_options --disable-gnomeui
248 %endif
249 %if %{with gnomevfs}
250 ac_add_options --enable-gnomevfs
251 %else
252 ac_add_options --disable-gnomevfs
253 %endif
254 %if %{with ldap}
255 ac_add_options --enable-ldap
256 ac_add_options --with-system-ldap
257 %else
258 ac_add_options --disable-ldap
259 %endif
260 %if %{with crashreporter}
261 ac_add_options --enable-crashreporter
262 %else
263 ac_add_options --disable-crashreporter
264 %endif
265 ac_add_options --disable-xterm-updates
266 ac_add_options --enable-postscript
267 %if %{with lightning}
268 ac_add_options --enable-calendar
269 %else
270 ac_add_options --disable-calendar
271 %endif
272 ac_add_options --disable-installer
273 ac_add_options --disable-jsd
274 ac_add_options --disable-updater
275 ac_add_options --disable-xprint
276 ac_add_options --disable-permissions
277 ac_add_options --disable-pref-extensions
278 ac_add_options --enable-canvas
279 ac_add_options --enable-crypto
280 ac_add_options --enable-mathml
281 ac_add_options --enable-pango
282 ac_add_options --enable-reorder
283 ac_add_options --enable-startup-notification
284 ac_add_options --enable-svg
285 ac_add_options --enable-system-cairo
286 ac_add_options --enable-system-hunspell
287 ac_add_options --enable-system-sqlite
288 ac_add_options --enable-xft
289 ac_add_options --enable-application=mail
290 ac_add_options --enable-default-toolkit=cairo-gtk2
291 ac_add_options --enable-xinerama
292 ac_add_options --with-distribution-id=org.pld-linux
293 ac_add_options --with-branding=icedove/branding
294 %if %{with xulrunner}
295 ac_add_options --with-libxul-sdk=$(pwd)/libxul-sdk
296 ac_add_options --enable-shared
297 %else
298 ac_add_options --enable-static
299 %endif
300 ac_add_options --with-pthreads
301 ac_add_options --with-system-bz2
302 ac_add_options --with-system-jpeg
303 ac_add_options --with-system-nspr
304 ac_add_options --with-system-nss
305 ac_add_options --with-system-png
306 ac_add_options --with-system-zlib
307 ac_add_options --enable-single-profile
308 ac_add_options --disable-profilesharing
309 ac_add_options --with-default-mozilla-five-home=%{_libdir}/%{name}
310 EOF
311
312 %{__make} -j1 -f client.mk build \
313         STRIP="/bin/true" \
314         MOZ_MAKE_FLAGS="%{?_smp_mflags}" \
315         CC="%{__cc}" \
316         CXX="%{__cxx}"
317
318 %if %{with crashreporter}
319 # create debuginfo for crash-stats.mozilla.com
320 %{__make} -j1 -C obj-%{_target_cpu} buildsymbols
321 %endif
322
323 %if %{with enigmail}
324 top=$(pwd)
325 cd mailnews/extensions/enigmail
326 ./makemake -r -o $top/obj-%{_target_cpu}
327 %{__make} -C $top/obj-%{_target_cpu}/mailnews/extensions/enigmail \
328         STRIP="/bin/true" \
329         CC="%{__cc}" \
330         CXX="%{__cxx}"
331 %endif
332
333 %install
334 rm -rf $RPM_BUILD_ROOT
335 install -d $RPM_BUILD_ROOT{%{_bindir},%{_libdir}/%{name},%{_datadir}/%{name},%{_pixmapsdir},%{_desktopdir}}
336
337 cd mozilla/obj-%{_target_cpu}
338 %{__make} -C mail/installer stage-package \
339         DESTDIR=$RPM_BUILD_ROOT \
340         MOZ_PKG_APPDIR=%{_libdir}/%{name} \
341         PKG_SKIP_STRIP=1
342
343 # Enable crash reporter for Firefox application
344 %if %{with crashreporter}
345 %{__sed} -i -e 's/\[Crash Reporter\]/[Crash Reporter]\nEnabled=1/' $RPM_BUILD_ROOT%{_libdir}/%{name}/application.ini
346
347 # Add debuginfo for crash-stats.mozilla.com
348 install -d $RPM_BUILD_ROOT%{_exec_prefix}/lib/debug%{_libdir}/%{name}
349 cp -a mozilla/dist/%{name}-%{version}.en-US.linux-*.crashreporter-symbols.zip $RPM_BUILD_ROOT%{_prefix}/lib/debug%{_libdir}/%{name}
350 %endif
351
352 # copy manually lightning files, somewhy they are not installed by make
353 cp -a mozilla/dist/bin/extensions/calendar-timezones@mozilla.org \
354         mozilla/dist/bin/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103} \
355         $RPM_BUILD_ROOT%{_libdir}/%{name}/extensions
356
357 # move arch independant ones to datadir
358 mv $RPM_BUILD_ROOT%{_libdir}/%{name}/chrome $RPM_BUILD_ROOT%{_datadir}/%{name}/chrome
359 mv $RPM_BUILD_ROOT%{_libdir}/%{name}/defaults $RPM_BUILD_ROOT%{_datadir}/%{name}/defaults
360 mv $RPM_BUILD_ROOT%{_libdir}/%{name}/greprefs $RPM_BUILD_ROOT%{_datadir}/%{name}/greprefs
361 mv $RPM_BUILD_ROOT%{_libdir}/%{name}/isp $RPM_BUILD_ROOT%{_datadir}/%{name}/isp
362 mv $RPM_BUILD_ROOT%{_libdir}/%{name}/modules $RPM_BUILD_ROOT%{_datadir}/%{name}/modules
363 mv $RPM_BUILD_ROOT%{_libdir}/%{name}/res $RPM_BUILD_ROOT%{_datadir}/%{name}/res
364 ln -s ../../share/%{name}/chrome $RPM_BUILD_ROOT%{_libdir}/%{name}/chrome
365 ln -s ../../share/%{name}/defaults $RPM_BUILD_ROOT%{_libdir}/%{name}/defaults
366 ln -s ../../share/%{name}/greprefs $RPM_BUILD_ROOT%{_libdir}/%{name}/greprefs
367 ln -s ../../share/%{name}/isp $RPM_BUILD_ROOT%{_libdir}/%{name}/isp
368 ln -s ../../share/%{name}/modules $RPM_BUILD_ROOT%{_libdir}/%{name}/modules
369 ln -s ../../share/%{name}/res $RPM_BUILD_ROOT%{_libdir}/%{name}/res
370
371 rm -rf $RPM_BUILD_ROOT%{_libdir}/%{name}/dictionaries
372 ln -s %{_datadir}/myspell $RPM_BUILD_ROOT%{_libdir}/%{name}/dictionaries
373
374 %{__sed} -e 's,@LIBDIR@,%{_libdir},' %{SOURCE5} > $RPM_BUILD_ROOT%{_bindir}/icedove
375 ln -s %{name} $RPM_BUILD_ROOT%{_bindir}/thunderbird
376 ln -s %{name} $RPM_BUILD_ROOT%{_bindir}/mozilla-thunderbird
377
378 cp -a %{SOURCE4} $RPM_BUILD_ROOT%{_desktopdir}/%{name}.desktop
379 cp -a ../icedove/branding/content/icon64.png $RPM_BUILD_ROOT%{_pixmapsdir}/%{name}.png
380
381 # files created by regxpcom -register
382 touch $RPM_BUILD_ROOT%{_libdir}/%{name}/components/compreg.dat
383 touch $RPM_BUILD_ROOT%{_libdir}/%{name}/components/xpti.dat
384
385 %if %{with enigmail}
386 ext_dir=$RPM_BUILD_ROOT%{_libdir}/%{name}/extensions/\{847b3a00-7ab1-11d4-8f02-006008948af5\}
387 install -d $ext_dir/{chrome,components,defaults/preferences}
388 cd mozilla/dist/bin
389 cp -rfLp chrome/enigmail.jar $ext_dir/chrome
390 cp -rfLp chrome/enigmime.jar $ext_dir/chrome
391 cp -rfLp components/enig* $ext_dir/components
392 cp -rfLp components/libenigmime.so $ext_dir/components
393 cp -rfLp components/libipc.so $ext_dir/components
394 cp -rfLp components/ipc.xpt $ext_dir/components
395 cp -rfLp defaults/preferences/enigmail.js $ext_dir/defaults/preferences
396 cd -
397 cp -a ../mailnews/extensions/enigmail/package/install.rdf $ext_dir
398 cp -a ../mailnews/extensions/enigmail/package/chrome.manifest $ext_dir/chrome.manifest
399 %endif
400
401 # remove unecessary stuff
402 rm $RPM_BUILD_ROOT%{_libdir}/%{name}/README.txt
403 rm $RPM_BUILD_ROOT%{_libdir}/%{name}/components/components.list
404 rm $RPM_BUILD_ROOT%{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/components/components.list
405
406 # never package these
407 # nss
408 rm -f $RPM_BUILD_ROOT%{_libdir}/%{name}/lib{freebl3,nss3,nssckbi,nssdbm3,nssutil3,smime3,softokn3,ssl3}.*
409 # nspr
410 rm -f $RPM_BUILD_ROOT%{_libdir}/%{name}/lib{nspr4,plc4,plds4}.so
411 # mozldap
412 rm -f $RPM_BUILD_ROOT%{_libdir}/%{name}/lib{ldap,ldif,prldap,ssldap}60.so
413
414 %clean
415 rm -rf $RPM_BUILD_ROOT
416
417 %pretrans
418 if [ -d %{_libdir}/%{name}/dictionaries ] && [ ! -L %{_libdir}/%{name}/dictionaries ]; then
419         mv -v %{_libdir}/%{name}/dictionaries{,.rpmsave}
420 fi
421 for d in chrome defaults greprefs icons isp modules res; do
422         if [ -d %{_libdir}/%{name}/$d ] && [ ! -L %{_libdir}/%{name}/$d ]; then
423                 install -d %{_datadir}/%{name}
424                 mv %{_libdir}/%{name}/$d %{_datadir}/%{name}/$d
425         fi
426 done
427 exit 0
428
429 %files
430 %defattr(644,root,root,755)
431 %attr(755,root,root) %{_bindir}/icedove
432 %attr(755,root,root) %{_bindir}/mozilla-thunderbird
433 %attr(755,root,root) %{_bindir}/thunderbird
434 %dir %{_libdir}/%{name}
435 %{_libdir}/%{name}/application.ini
436 %{_libdir}/%{name}/platform.ini
437 %dir %{_libdir}/%{name}/components
438 %attr(755,root,root) %{_libdir}/%{name}/components/*.so
439 %{_libdir}/%{name}/components/*.js
440 %{_libdir}/%{name}/components/*.xpt
441 %attr(755,root,root) %{_libdir}/%{name}/libmozjs.so
442 %attr(755,root,root) %{_libdir}/%{name}/libxpcom.so
443 %attr(755,root,root) %{_libdir}/%{name}/libxpcom_core.so
444 %attr(755,root,root) %{_libdir}/%{name}/*.sh
445 %attr(755,root,root) %{_libdir}/%{name}/*-bin
446 %attr(755,root,root) %{_libdir}/%{name}/mozilla-xremote-client
447 %attr(755,root,root) %{_libdir}/%{name}/icedove
448
449 # symlinks
450 %{_libdir}/%{name}/chrome
451 %{_libdir}/%{name}/defaults
452 %{_libdir}/%{name}/dictionaries
453 %{_libdir}/%{name}/greprefs
454 %{_libdir}/%{name}/isp
455 %{_libdir}/%{name}/modules
456 %{_libdir}/%{name}/res
457
458 %{_pixmapsdir}/*.png
459 %{_desktopdir}/*.desktop
460
461 %dir %{_datadir}/%{name}
462 %{_datadir}/%{name}/chrome
463 %{_datadir}/%{name}/defaults
464 %{_datadir}/%{name}/greprefs
465 %{_datadir}/%{name}/isp
466 %{_datadir}/%{name}/modules
467 %{_datadir}/%{name}/res
468
469 %if %{with crashreporter}
470 %attr(755,root,root) %{_libdir}/%{name}/crashreporter
471 %{_libdir}/%{name}/crashreporter.ini
472 %{_libdir}/%{name}/Throbber-small.gif
473 %endif
474
475 %dir %{_libdir}/%{name}/extensions
476 %{_libdir}/%{name}/extensions/{972ce4c6-7e08-4474-a285-3208198ce6fd}
477
478 # files created by regxpcom -register
479 %ghost %{_libdir}/%{name}/components/compreg.dat
480 %ghost %{_libdir}/%{name}/components/xpti.dat
481
482 %if %{with lightning}
483 %files addon-lightning
484 %defattr(644,root,root,755)
485 %dir %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}
486 %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/defaults
487 %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/chrome
488 %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/chrome.manifest
489 %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/install.rdf
490 %dir %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/components
491 %attr(755,root,root) %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/components/*.so
492 %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/components/*.xpt
493 %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/components/*.js
494 %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/modules
495 %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/calendar-js
496 %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/timezones.sqlite
497
498 %{_libdir}/%{name}/extensions/calendar-timezones@mozilla.org
499 %endif
500
501 %if %{with enigmail}
502 %files addon-enigmail
503 %defattr(644,root,root,755)
504 %dir %{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}
505 %{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/defaults
506 %{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/chrome
507 %{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/chrome.manifest
508 %{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/install.rdf
509 %dir %{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/components
510 %attr(755,root,root) %{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/components/*.so
511 %{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/components/*.xpt
512 %{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/components/*.js
513 %endif
This page took 0.063431 seconds and 4 git commands to generate.