]> git.pld-linux.org Git - packages/thunderbird.git/blob - icedove.spec
- remove dup patch
[packages/thunderbird.git] / icedove.spec
1 # TODO:
2 # - separate spec for enigmail
3 # - fix icedove (building) and installing nss/nspr libs!
4 # - build with system mozldap
5 #
6 # Conditional builds
7 %bcond_without  enigmail        # don't build enigmail - GPG/PGP support
8 %bcond_without  gnomeui         # disable gnomeui support
9 %bcond_without  gnomevfs        # disable GNOME comp. (gconf+libgnome+gnomevfs) and gnomevfs ext.
10 %bcond_without  gnome           # disable all GNOME components (gnome+gnomeui+gnomevfs)
11 %bcond_without  ldap            # disable e-mail address lookups in LDAP directories
12 %bcond_without  lightning       # disable sunbird calendar
13 %bcond_without  xulrunner       # build with xulrunner
14 %bcond_with     crashreporter   # report crashes to crash-stats.mozilla.com
15
16 %if %{without gnome}
17 %undefine       with_gnomeui
18 %undefine       with_gnomevfs
19 %endif
20
21 %if 0%{?_enable_debug_packages} != 1
22 %undefine       crashreporter
23 %endif
24
25 %define         enigmail_ver    1.3.2
26 %define         nspr_ver                4.8.8
27 %define         nss_ver                 3.12.10
28
29 # convert firefox release number to platform version: 6.0.x -> 6.0.x
30 %define         xulrunner_main  7.0
31 %define         xulrunner_ver   %(v=%{version}; echo %{xulrunner_main}${v#7.0})
32
33 %if %{without xulrunner}
34 # The actual sqlite version (see RHBZ#480989):
35 %define         sqlite_build_version %(pkg-config --silence-errors --modversion sqlite3 2>/dev/null || echo ERROR)
36 %endif
37
38 Summary:        Icedove - email client
39 Summary(pl.UTF-8):      Icedove - klient poczty
40 Name:           icedove
41 Version:        7.0
42 Release:        0.2
43 License:        MPL 1.1 or GPL v2+ or LGPL v2.1+
44 Group:          X11/Applications/Networking
45 Source0:        http://releases.mozilla.org/pub/mozilla.org/thunderbird/releases/%{version}/source/thunderbird-%{version}.source.tar.bz2
46 # Source0-md5:  6a4b2dbdc2324f52c019a3a8dee6dad4
47 Source1:        http://www.mozilla-enigmail.org/download/source/enigmail-%{enigmail_ver}.tar.gz
48 # Source1-md5:  2318d60320dc6c3db3c34d968bb7d533
49 Source2:        %{name}-branding.tar.bz2
50 # Source2-md5:  2da351522bdd7f4a3bd8aaff4c776976
51 Source3:        %{name}-rm_nonfree.sh
52 Source4:        %{name}.desktop
53 Source5:        %{name}.sh
54 Patch0:         %{name}-branding.patch
55 Patch1:         %{name}-enigmail-shared.patch
56 Patch2:         %{name}-gcc.patch
57 Patch3:         %{name}-fonts.patch
58 Patch4:         %{name}-install.patch
59 Patch5:         %{name}-hunspell.patch
60 Patch6:         %{name}-prefs.patch
61 Patch7:         system-mozldap.patch
62 Patch8:         %{name}-makefile.patch
63 Patch10:        %{name}-extensiondir.patch
64 Patch11:        crashreporter.patch
65 Patch12:        no-subshell.patch
66 URL:            http://www.pld-linux.org/Packages/Icedove
67 %{?with_gnomevfs:BuildRequires: GConf2-devel >= 1.2.1}
68 BuildRequires:  alsa-lib-devel
69 BuildRequires:  automake
70 BuildRequires:  bzip2-devel
71 BuildRequires:  freetype-devel >= 1:2.1.8
72 %{?with_gnomevfs:BuildRequires: gnome-vfs2-devel >= 2.0}
73 BuildRequires:  gtk+2-devel >= 1:2.0.0
74 BuildRequires:  hunspell-devel
75 BuildRequires:  libIDL-devel >= 0.8.0
76 %{?with_gnomevfs:BuildRequires: libgnome-devel >= 2.0}
77 %{?with_gnomeui:BuildRequires:  libgnome-keyring-devel}
78 %{?with_gnomeui:BuildRequires:  libgnomeui-devel >= 2.2.0}
79 BuildRequires:  libiw-devel
80 BuildRequires:  libjpeg-devel >= 6b
81 BuildRequires:  libnotify-devel >= 0.4
82 BuildRequires:  libpng-devel >= 1.2.0
83 BuildRequires:  libstdc++-devel
84 BuildRequires:  nspr-devel >= 1:%{nspr_ver}
85 BuildRequires:  nss-devel >= 1:%{nss_ver}
86 BuildRequires:  pango-devel >= 1:1.1.0
87 BuildRequires:  pkgconfig
88 BuildRequires:  sed >= 4.0
89 BuildRequires:  sqlite3-devel >= 3.7.4
90 BuildRequires:  startup-notification-devel >= 0.8
91 BuildRequires:  xorg-lib-libXext-devel
92 BuildRequires:  xorg-lib-libXinerama-devel
93 BuildRequires:  xorg-lib-libXt-devel
94 BuildRequires:  yasm
95 BuildRequires:  zip
96 %if %{with xulrunner}
97 BuildRequires:  xulrunner-devel >= 2:%{xulrunner_ver}
98 %else
99 Requires:       myspell-common
100 Requires:       nspr >= 1:%{nspr_ver}
101 Requires:       nss >= 1:%{nss_ver}
102 Requires:       sqlite3 >= %{sqlite_build_version}
103 %endif
104 Requires(post): mktemp >= 1.5-18
105 %if %{with xulrunner}
106 %requires_eq_to xulrunner xulrunner-devel
107 %endif
108 Obsoletes:      mozilla-thunderbird
109 Obsoletes:      mozilla-thunderbird-dictionary-en-US
110 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
111
112 %define         filterout_cpp           -D_FORTIFY_SOURCE=[0-9]+
113
114 # iceweasel/icedove/iceape provide their own versions
115 %define         _noautoreqdep           libgfxpsshar.so libgkgfx.so libgtkxtbin.so libjsj.so libxpcom_compat.so libxpistub.so
116 %define         _noautoprovfiles        %{_libdir}/%{name}/components
117 # we don't want these to satisfy xulrunner-devel
118 %define         _noautoprov             libgtkembedmoz.so libmozjs.so libxpcom.so libxul.so libxpcom_core.so
119 # and as we don't provide them, don't require either
120 %define         _noautoreq              libgtkembedmoz.so libmozjs.so libxpcom.so libxul.so libxpcom_core.so
121
122 %define         topdir          %{_builddir}/%{name}-%{version}
123 %define         objdir          %{topdir}/obj-%{_target_cpu}
124
125 %description
126 Icedove is an open-source,fast and portable email client.
127
128 %description -l pl.UTF-8
129 Icedove jest open sourcowym, szybkim i przenośnym klientem poczty.
130
131 %package addon-lightning
132 Summary:        An integrated calendar for Icedove
133 Summary(pl.UTF-8):      Zintegrowany kalendarz dla Icedove
134 License:        MPL 1.1 or GPL v2+ or LGPL v2.1+
135 Group:          Applications/Networking
136 Requires:       %{name} = %{version}-%{release}
137
138 %description addon-lightning
139 Lightning is an calendar extension to Icedove email client.
140
141 %description addon-lightning -l pl.UTF-8
142 Lightning to rozszerzenie do klienta poczty Icedove dodające
143 funkcjonalność kalendarza.
144
145 %package addon-enigmail
146 Summary:        Extension for the authentication and encryption features provided by GnuPG
147 Summary(pl.UTF-8):      Rozszerzenie do uwierzytelniania i szyfrowania zapewnianego przez GnuPG
148 License:        MPL/LGPL
149 Group:          Applications/Networking
150 URL:            http://enigmail.mozdev.org/
151 Requires:       %{name} = %{version}-%{release}
152 Requires:       gnupg
153 Obsoletes:      mozilla-thunderbird-addon-enigmail
154
155 %description addon-enigmail
156 Enigmail is an extension to the Icedove mail client which allows users
157 to access the authentication and encryption features provided by
158 GnuPG.
159
160 Main Features:
161 - Encrypt/sign mail when sending, decrypt/authenticate received mail
162 - Support for inline-PGP (RFC 2440) and PGP/MIME (RFC 3156)
163 - Per-Account based encryption and signing defaults
164 - Per-Recipient rules for automated key selection, and
165   enabling/disabling encryption and signing
166 - OpenPGP key management interface
167
168 %description addon-enigmail -l pl.UTF-8
169 Enigmail to rozszerzenie klienta pocztowego Icedove pozwalające
170 użytkownikom na dostęp do uwierzytelniania i szyfrowania zapewnianego
171 przez GnuPG.
172
173 Główne możliwości:
174 - szyfrowanie/podpisywanie poczty przy wysyłaniu,
175   odszyfrowywanie/uwierzytelnianie poczty odebranej
176 - obsługa inline-PGP (RFC 2440) i PGP/MIME (RFC 3156)
177 - ustawienia domyślne szyfrowania i podpisywania dla każdego konta
178 - reguły automatycznego wyboru kluczy i włączenia szyfrowania oraz
179   podpisywania dla każdego adresata
180 - interfejs do zarządzania kluczami OpenPGP
181
182 %prep
183 %setup -qc
184 mv comm-release mozilla
185 %setup -q -T -D -a2
186 cd mozilla
187 %{?with_enigmail:%{__gzip} -dc %{SOURCE1} | %{__tar} -xf - -C mailnews/extensions}
188 /bin/sh %{SOURCE3}
189 %patch0 -p1
190 %{?with_enigmail:%patch1 -p1}
191 %patch2 -p1
192 %patch3 -p1
193 %patch4 -p1
194 %patch6 -p1
195 %patch7 -p1
196 %patch8 -p2
197 %patch10 -p2
198 %patch11 -p2
199 %patch12 -p1
200
201 %build
202 cd mozilla
203 cp -f %{_datadir}/automake/config.* mozilla/build/autoconf
204 cp -f %{_datadir}/automake/config.* mozilla/nsprpub/build/autoconf
205 cp -f %{_datadir}/automake/config.* ldap/sdks/c-sdk/config/autoconf
206
207 install -d libxul-sdk
208 ln -snf %{_libdir}/xulrunner-sdk libxul-sdk/sdk
209
210 cat << EOF > .mozconfig
211 mk_add_options MOZ_OBJDIR=%{objdir}
212
213 export CFLAGS="%{rpmcflags} -fpermissive -I/usr/include/xulrunner"
214 export CXXFLAGS="%{rpmcflags} -fpermissive -I/usr/include/xulrunner"
215
216 %if %{with crashreporter}
217 export MOZ_DEBUG_SYMBOLS=1
218 %endif
219
220 # Options for 'configure' (same as command-line options).
221 ac_add_options --prefix=%{_prefix}
222 ac_add_options --exec-prefix=%{_exec_prefix}
223 ac_add_options --bindir=%{_bindir}
224 ac_add_options --sbindir=%{_sbindir}
225 ac_add_options --sysconfdir=%{_sysconfdir}
226 ac_add_options --datadir=%{_datadir}
227 ac_add_options --includedir=%{_includedir}
228 ac_add_options --libdir=%{_libdir}
229 ac_add_options --libexecdir=%{_libexecdir}
230 ac_add_options --localstatedir=%{_localstatedir}
231 ac_add_options --sharedstatedir=%{_sharedstatedir}
232 ac_add_options --mandir=%{_mandir}
233 ac_add_options --infodir=%{_infodir}
234 %if %{?debug:1}0
235 ac_add_options --disable-optimize
236 ac_add_options --enable-debug
237 ac_add_options --enable-debug-modules
238 ac_add_options --enable-debugger-info-modules
239 ac_add_options --enable-crash-on-assert
240 %else
241 ac_add_options --disable-debug
242 ac_add_options --disable-debug-modules
243 ac_add_options --disable-logging
244 ac_add_options --enable-optimize="%{rpmcflags} -Os"
245 %endif
246 ac_add_options --disable-strip
247 ac_add_options --disable-strip-libs
248 %if %{with tests}
249 ac_add_options --enable-tests
250 %else
251 ac_add_options --disable-tests
252 %endif
253 %if %{with gnomeui}
254 ac_add_options --enable-gnomeui
255 %else
256 ac_add_options --disable-gnomeui
257 %endif
258 %if %{with gnomevfs}
259 ac_add_options --enable-gnomevfs
260 %else
261 ac_add_options --disable-gnomevfs
262 %endif
263 %if %{with ldap}
264 ac_add_options --enable-ldap
265 ac_add_options --with-system-ldap
266 %else
267 ac_add_options --disable-ldap
268 %endif
269 %if %{with crashreporter}
270 ac_add_options --enable-crashreporter
271 %else
272 ac_add_options --disable-crashreporter
273 %endif
274 ac_add_options --disable-xterm-updates
275 ac_add_options --enable-postscript
276 %if %{with lightning}
277 ac_add_options --enable-calendar
278 %else
279 ac_add_options --disable-calendar
280 %endif
281 ac_add_options --disable-installer
282 ac_add_options --disable-jsd
283 ac_add_options --disable-updater
284 ac_add_options --disable-xprint
285 ac_add_options --disable-permissions
286 ac_add_options --disable-pref-extensions
287 ac_add_options --enable-canvas
288 ac_add_options --enable-crypto
289 ac_add_options --enable-mathml
290 ac_add_options --enable-pango
291 ac_add_options --enable-reorder
292 ac_add_options --enable-startup-notification
293 ac_add_options --enable-svg
294 ac_add_options --enable-system-cairo
295 ac_add_options --enable-system-hunspell
296 ac_add_options --enable-system-sqlite
297 ac_add_options --enable-xft
298 ac_add_options --enable-application=mail
299 ac_add_options --enable-default-toolkit=cairo-gtk2
300 ac_add_options --enable-xinerama
301 ac_add_options --with-distribution-id=org.pld-linux
302 ac_add_options --with-branding=icedove/branding
303 %if %{with xulrunner}
304 #ac_add_options --with-libxul-sdk=$(pwd)/libxul-sdk/sdk
305 ac_add_options --with-system-libxul
306 ac_add_options --enable-shared
307 ac_add_options --enable-libxul
308 %else
309 ac_add_options --disable-xul
310 %endif
311 ac_add_options --with-pthreads
312 ac_add_options --with-system-bz2
313 ac_add_options --with-system-jpeg
314 ac_add_options --with-system-nspr
315 ac_add_options --with-system-nss
316 ac_add_options --with-system-png
317 ac_add_options --with-system-zlib
318 ac_add_options --enable-single-profile
319 ac_add_options --disable-profilesharing
320 ac_add_options --with-default-mozilla-five-home=%{_libdir}/%{name}
321 EOF
322
323 %{__make} -j1 -f client.mk build \
324         STRIP="/bin/true" \
325         MOZ_MAKE_FLAGS="%{?_smp_mflags}" \
326         CC="%{__cc}" \
327         CXX="%{__cxx}"
328
329 %if %{with crashreporter}
330 # create debuginfo for crash-stats.mozilla.com
331 %{__make} -j1 -C obj-%{_target_cpu} buildsymbols
332 %endif
333
334 %if %{with enigmail}
335 cd mailnews/extensions/enigmail
336 ./makemake -r -o %{objdir}
337 %{__make} -C %{objdir}/mailnews/extensions/enigmail \
338         STRIP="/bin/true" \
339         CC="%{__cc}" \
340         CXX="%{__cxx}"
341 %endif
342
343 %install
344 rm -rf $RPM_BUILD_ROOT
345 install -d $RPM_BUILD_ROOT{%{_bindir},%{_libdir}/%{name},%{_datadir}/%{name},%{_pixmapsdir},%{_desktopdir}}
346
347 cd %{objdir}
348 %{__make} -C mail/installer stage-package \
349         DESTDIR=$RPM_BUILD_ROOT \
350         MOZ_PKG_DIR=%{_libdir}/%{name} \
351         PKG_SKIP_STRIP=1
352
353 # Enable crash reporter for Firefox application
354 %if %{with crashreporter}
355 %{__sed} -i -e 's/\[Crash Reporter\]/[Crash Reporter]\nEnabled=1/' $RPM_BUILD_ROOT%{_libdir}/%{name}/application.ini
356
357 # Add debuginfo for crash-stats.mozilla.com
358 install -d $RPM_BUILD_ROOT%{_exec_prefix}/lib/debug%{_libdir}/%{name}
359 cp -a mozilla/dist/%{name}-%{version}.en-US.linux-*.crashreporter-symbols.zip $RPM_BUILD_ROOT%{_prefix}/lib/debug%{_libdir}/%{name}
360 %endif
361
362 # copy manually lightning files, somewhy they are not installed by make
363 cp -a mozilla/dist/bin/extensions/calendar-timezones@mozilla.org \
364         mozilla/dist/bin/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103} \
365         $RPM_BUILD_ROOT%{_libdir}/%{name}/extensions
366
367 # move arch independant ones to datadir
368 mv $RPM_BUILD_ROOT%{_libdir}/%{name}/chrome $RPM_BUILD_ROOT%{_datadir}/%{name}/chrome
369 mv $RPM_BUILD_ROOT%{_libdir}/%{name}/defaults $RPM_BUILD_ROOT%{_datadir}/%{name}/defaults
370 #mv $RPM_BUILD_ROOT%{_libdir}/%{name}/greprefs $RPM_BUILD_ROOT%{_datadir}/%{name}/greprefs
371 mv $RPM_BUILD_ROOT%{_libdir}/%{name}/isp $RPM_BUILD_ROOT%{_datadir}/%{name}/isp
372 mv $RPM_BUILD_ROOT%{_libdir}/%{name}/modules $RPM_BUILD_ROOT%{_datadir}/%{name}/modules
373 mv $RPM_BUILD_ROOT%{_libdir}/%{name}/res $RPM_BUILD_ROOT%{_datadir}/%{name}/res
374 ln -s ../../share/%{name}/chrome $RPM_BUILD_ROOT%{_libdir}/%{name}/chrome
375 ln -s ../../share/%{name}/defaults $RPM_BUILD_ROOT%{_libdir}/%{name}/defaults
376 #ln -s ../../share/%{name}/greprefs $RPM_BUILD_ROOT%{_libdir}/%{name}/greprefs
377 ln -s ../../share/%{name}/isp $RPM_BUILD_ROOT%{_libdir}/%{name}/isp
378 ln -s ../../share/%{name}/modules $RPM_BUILD_ROOT%{_libdir}/%{name}/modules
379 ln -s ../../share/%{name}/res $RPM_BUILD_ROOT%{_libdir}/%{name}/res
380
381 # dir for arch independant extensions besides arch dependant extensions
382 # see mozilla/xpcom/build/nsXULAppAPI.h
383 # XRE_SYS_LOCAL_EXTENSION_PARENT_DIR and XRE_SYS_SHARE_EXTENSION_PARENT_DIR
384 install -d $RPM_BUILD_ROOT%{_datadir}/%{name}/extensions
385
386 %{__rm} -r $RPM_BUILD_ROOT%{_libdir}/%{name}/dictionaries
387 ln -s %{_datadir}/myspell $RPM_BUILD_ROOT%{_libdir}/%{name}/dictionaries
388
389 %{__sed} -e 's,@LIBDIR@,%{_libdir},' %{SOURCE5} > $RPM_BUILD_ROOT%{_bindir}/icedove
390 ln -s %{name} $RPM_BUILD_ROOT%{_bindir}/thunderbird
391 ln -s %{name} $RPM_BUILD_ROOT%{_bindir}/mozilla-thunderbird
392
393 cp -p %{SOURCE4} $RPM_BUILD_ROOT%{_desktopdir}/%{name}.desktop
394 cp -p %{topdir}/mozilla/icedove/branding/content/icon64.png $RPM_BUILD_ROOT%{_pixmapsdir}/%{name}.png
395
396 # files created by regxpcom -register in post
397 touch $RPM_BUILD_ROOT%{_libdir}/%{name}/components/compreg.dat
398 touch $RPM_BUILD_ROOT%{_libdir}/%{name}/components/xpti.dat
399 cat << 'EOF' > $RPM_BUILD_ROOT%{_libdir}/%{name}/register
400 #!/bin/sh
401 umask 022
402 # make temporary HOME, as it attempts to touch files in $HOME/.mozilla
403 # dangerous if you run this with sudo with keep_env += HOME
404 # also TMPDIR could be pointing to sudo user's homedir so we reset that too.
405 t=$(mktemp -d)
406 %{__rm} -f %{_libdir}/%{name}/components/{compreg,xpti}.dat
407 TMPDIR= TMP= HOME=$t %{_libdir}/%{name}/icedove -register
408 rm -rf $t
409 EOF
410 chmod a+rx $RPM_BUILD_ROOT%{_libdir}/%{name}/register
411
412 %if %{with enigmail}
413 ext_dir=$RPM_BUILD_ROOT%{_libdir}/%{name}/extensions/\{847b3a00-7ab1-11d4-8f02-006008948af5\}
414 install -d $ext_dir/{chrome,components,defaults/preferences}
415 cd mozilla/dist/bin
416 #cp -rfLp chrome/enigmail.jar $ext_dir/chrome
417 #cp -rfLp chrome/enigmime.jar $ext_dir/chrome
418 cp -rfLp components/enig* $ext_dir/components
419 cp -rfLp components/libenigmime.so $ext_dir/components
420 cp -rfLp components/libipc.so $ext_dir/components
421 cp -rfLp components/ipc.xpt $ext_dir/components
422 cp -rfLp defaults/preferences/enigmail.js $ext_dir/defaults/preferences
423 cd -
424 cp -p %{topdir}/mozilla/mailnews/extensions/enigmail/package/install.rdf $ext_dir
425 cp -p %{topdir}/mozilla/mailnews/extensions/enigmail/package/chrome.manifest $ext_dir/chrome.manifest
426 %endif
427
428 # remove unecessary stuff
429 %{__rm} $RPM_BUILD_ROOT%{_libdir}/%{name}/README.txt
430 #%%{__rm} $RPM_BUILD_ROOT%{_libdir}/%{name}/components/components.list
431 #%%{__rm} $RPM_BUILD_ROOT%{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/components/components.list
432
433 # never package these. always remove
434 # nss
435 %{__rm} -f $RPM_BUILD_ROOT%{_libdir}/%{name}/lib{freebl3,nss3,nssckbi,nssdbm3,nssutil3,smime3,softokn3,ssl3}.*
436 # nspr
437 %{__rm} -f $RPM_BUILD_ROOT%{_libdir}/%{name}/lib{nspr4,plc4,plds4}.so
438 # mozldap
439 %{__rm} -f $RPM_BUILD_ROOT%{_libdir}/%{name}/lib{ldap,ldif,prldap,ssldap}60.so
440
441 %clean
442 rm -rf $RPM_BUILD_ROOT
443
444 %pretrans
445 if [ -d %{_libdir}/%{name}/dictionaries ] && [ ! -L %{_libdir}/%{name}/dictionaries ]; then
446         mv -v %{_libdir}/%{name}/dictionaries{,.rpmsave}
447 fi
448 for d in chrome defaults greprefs icons isp modules res; do
449         if [ -d %{_libdir}/%{name}/$d ] && [ ! -L %{_libdir}/%{name}/$d ]; then
450                 install -d %{_datadir}/%{name}
451                 mv %{_libdir}/%{name}/$d %{_datadir}/%{name}/$d
452         fi
453 done
454 exit 0
455
456 %post
457 %{_libdir}/%{name}/register || :
458
459 %files
460 %defattr(644,root,root,755)
461 %attr(755,root,root) %{_bindir}/icedove
462 %attr(755,root,root) %{_bindir}/mozilla-thunderbird
463 %attr(755,root,root) %{_bindir}/thunderbird
464 %dir %{_libdir}/%{name}
465 %{_libdir}/%{name}/application.ini
466 %{_libdir}/%{name}/platform.ini
467 %dir %{_libdir}/%{name}/components
468 %attr(755,root,root) %{_libdir}/%{name}/components/*.so
469 %{_libdir}/%{name}/components/*.js
470 %{_libdir}/%{name}/components/*.xpt
471 %attr(755,root,root) %{_libdir}/%{name}/libmozalloc.so
472 #%%attr(755,root,root) %{_libdir}/%{name}/libmozjs.so
473 %attr(755,root,root) %{_libdir}/%{name}/libxpcom.so
474 #%%attr(755,root,root) %{_libdir}/%{name}/libxpcom_core.so
475 %attr(755,root,root) %{_libdir}/%{name}/libxul.so
476 %attr(755,root,root) %{_libdir}/%{name}/*.sh
477 %attr(755,root,root) %{_libdir}/%{name}/*-bin
478 %attr(755,root,root) %{_libdir}/%{name}/mozilla-xremote-client
479 %attr(755,root,root) %{_libdir}/%{name}/icedove
480 %attr(755,root,root) %{_libdir}/%{name}/register
481
482 # symlinks
483 %{_libdir}/%{name}/chrome
484 %{_libdir}/%{name}/defaults
485 %{_libdir}/%{name}/dictionaries
486 #%%{_libdir}/%{name}/greprefs
487 %{_libdir}/%{name}/isp
488 %{_libdir}/%{name}/modules
489 %{_libdir}/%{name}/res
490
491 %{_pixmapsdir}/*.png
492 %{_desktopdir}/*.desktop
493
494 %dir %{_datadir}/%{name}
495 %{_datadir}/%{name}/chrome
496 %{_datadir}/%{name}/defaults
497 #%%{_datadir}/%{name}/greprefs
498 %{_datadir}/%{name}/isp
499 %{_datadir}/%{name}/modules
500 %{_datadir}/%{name}/res
501 %{_datadir}/%{name}/extensions
502
503 %if %{with crashreporter}
504 %attr(755,root,root) %{_libdir}/%{name}/crashreporter
505 %{_libdir}/%{name}/crashreporter.ini
506 %{_libdir}/%{name}/Throbber-small.gif
507 %endif
508
509 %dir %{_libdir}/%{name}/extensions
510 %{_libdir}/%{name}/extensions/{972ce4c6-7e08-4474-a285-3208198ce6fd}
511
512 # files created by regxpcom -register
513 %ghost %{_libdir}/%{name}/components/compreg.dat
514 %ghost %{_libdir}/%{name}/components/xpti.dat
515
516 %if %{with lightning}
517 %files addon-lightning
518 %defattr(644,root,root,755)
519 %dir %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}
520 %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/defaults
521 %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/chrome
522 %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/chrome.manifest
523 %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/install.rdf
524 %dir %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/components
525 %attr(755,root,root) %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/components/*.so
526 %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/components/*.xpt
527 %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/components/*.js
528 %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/modules
529 %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/calendar-js
530 %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/timezones.sqlite
531
532 %{_libdir}/%{name}/extensions/calendar-timezones@mozilla.org
533 %endif
534
535 %if %{with enigmail}
536 %files addon-enigmail
537 %defattr(644,root,root,755)
538 %dir %{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}
539 %{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/defaults
540 %{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/chrome
541 %{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/chrome.manifest
542 %{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/install.rdf
543 %dir %{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/components
544 %attr(755,root,root) %{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/components/*.so
545 %{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/components/*.xpt
546 %{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/components/*.js
547 %endif
This page took 0.071328 seconds and 4 git commands to generate.