]> git.pld-linux.org Git - packages/thunderbird.git/blob - icedove.spec
- up to 13.0
[packages/thunderbird.git] / icedove.spec
1 # TODO:
2 # - separate spec for enigmail
3 # - build with system mozldap
4 #
5 # Conditional builds
6 %bcond_without  enigmail        # don't build enigmail - GPG/PGP support
7 %bcond_without  gnomeui         # disable gnomeui support
8 %bcond_without  gnome           # alias for gnomeui
9 %bcond_without  ldap            # disable e-mail address lookups in LDAP directories
10 %bcond_without  lightning       # disable Sunbird/Lightning calendar
11 %bcond_with     xulrunner       # system xulrunner
12 %bcond_with     crashreporter   # report crashes to crash-stats.mozilla.com
13
14 %if %{without gnome}
15 %undefine       with_gnomeui
16 %endif
17
18 %if 0%{?_enable_debug_packages} != 1
19 %undefine       crashreporter
20 %endif
21
22 %define         enigmail_ver    1.4.2
23 %define         nspr_ver        4.9
24 %define         nss_ver         3.13.3
25
26 %define         xulrunner_ver   2:13.0
27
28 %if %{without xulrunner}
29 # The actual sqlite version (see RHBZ#480989):
30 %define         sqlite_build_version %(pkg-config --silence-errors --modversion sqlite3 2>/dev/null || echo ERROR)
31 %endif
32
33 Summary:        Icedove - email client
34 Summary(pl.UTF-8):      Icedove - klient poczty
35 Name:           icedove
36 Version:        13.0
37 Release:        1
38 License:        MPL 1.1 or GPL v2+ or LGPL v2.1+
39 Group:          X11/Applications/Networking
40 Source0:        http://releases.mozilla.org/pub/mozilla.org/thunderbird/releases/%{version}/source/thunderbird-%{version}.source.tar.bz2
41 # Source0-md5:  0134c67c30e8598f2a64ea004d5bc4bc
42 Source1:        http://www.mozilla-enigmail.org/download/source/enigmail-%{enigmail_ver}.tar.gz
43 # Source1-md5:  ed608e1cd4cd20b96f7f5afdbf081141
44 Source2:        %{name}-branding.tar.bz2
45 # Source2-md5:  2da351522bdd7f4a3bd8aaff4c776976
46 Source3:        %{name}-rm_nonfree.sh
47 Source4:        %{name}.desktop
48 Source5:        %{name}.sh
49 Patch0:         %{name}-branding.patch
50 Patch1:         %{name}-enigmail-shared.patch
51 Patch2:         %{name}-system-xulrunner.patch
52 Patch3:         %{name}-fonts.patch
53 Patch4:         %{name}-install.patch
54 Patch5:         %{name}-hunspell.patch
55 Patch6:         %{name}-prefs.patch
56 Patch7:         system-mozldap.patch
57 Patch8:         %{name}-makefile.patch
58 Patch9:         system-cairo.patch
59 Patch10:        %{name}-extensiondir.patch
60 Patch11:        crashreporter.patch
61 Patch12:        no-subshell.patch
62 URL:            http://www.pld-linux.org/Packages/Icedove
63 BuildRequires:  GConf2-devel >= 1.2.1
64 BuildRequires:  alsa-lib-devel
65 BuildRequires:  automake
66 BuildRequires:  bzip2-devel
67 BuildRequires:  cairo-devel >= 1.10
68 BuildRequires:  dbus-glib-devel >= 0.60
69 BuildRequires:  freetype-devel >= 1:2.1.8
70 BuildRequires:  glib2-devel >= 2.0
71 BuildRequires:  gtk+2-devel >= 2:2.10.0
72 BuildRequires:  hunspell-devel
73 BuildRequires:  libIDL-devel >= 0.8.0
74 %{?with_gnomeui:BuildRequires:  libgnome-devel >= 2.0}
75 %{?with_gnomeui:BuildRequires:  libgnome-keyring-devel}
76 %{?with_gnomeui:BuildRequires:  libgnomeui-devel >= 2.2.0}
77 BuildRequires:  libiw-devel
78 BuildRequires:  libjpeg-devel >= 6b
79 BuildRequires:  libnotify-devel >= 0.4
80 BuildRequires:  libpng-devel >= 1.4.1
81 BuildRequires:  libstdc++-devel
82 BuildRequires:  nspr-devel >= 1:%{nspr_ver}
83 BuildRequires:  nss-devel >= 1:%{nss_ver}
84 BuildRequires:  pango-devel >= 1:1.14.0
85 BuildRequires:  perl-base >= 1:5.6
86 BuildRequires:  pkgconfig
87 BuildRequires:  python >= 1:2.5
88 BuildRequires:  sed >= 4.0
89 BuildRequires:  sqlite3-devel >= 3.7.4
90 BuildRequires:  startup-notification-devel >= 0.8
91 BuildRequires:  xorg-lib-libXext-devel
92 BuildRequires:  xorg-lib-libXinerama-devel
93 BuildRequires:  xorg-lib-libXt-devel
94 BuildRequires:  yasm
95 BuildRequires:  zip
96 %if %{with xulrunner}
97 BuildRequires:  xulrunner-devel >= %{xulrunner_ver}
98 %else
99 Requires:       myspell-common
100 Requires:       nspr >= 1:%{nspr_ver}
101 Requires:       nss >= 1:%{nss_ver}
102 Requires:       sqlite3 >= %{sqlite_build_version}
103 %endif
104 Requires(post): mktemp >= 1.5-18
105 %if %{with xulrunner}
106 %requires_eq_to xulrunner xulrunner-devel
107 %endif
108 Obsoletes:      mozilla-thunderbird
109 Obsoletes:      mozilla-thunderbird-dictionary-en-US
110 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
111
112 %define         filterout_cpp           -D_FORTIFY_SOURCE=[0-9]+
113
114 # iceweasel/icedove/iceape provide their own versions
115 %define         _noautoprovfiles        %{_libdir}/%{name}/components
116 %if %{without xulrunner}
117 # we don't want these to satisfy packages depending on xulrunner
118 %define         _noautoprov             libmozalloc.so libxpcom.so libxul.so
119 # and as we don't provide them, don't require either
120 %define         _noautoreq              libmozalloc.so libxpcom.so libxul.so
121 %endif
122
123 %define         topdir          %{_builddir}/%{name}-%{version}
124 %define         objdir          %{topdir}/obj-%{_target_cpu}
125
126 %description
127 Icedove is an open-source, fast and portable email client.
128
129 %description -l pl.UTF-8
130 Icedove jest mającym otwarte źródła, szybkim i przenośnym klientem
131 poczty.
132
133 %package addon-lightning
134 Summary:        An integrated calendar for Icedove
135 Summary(pl.UTF-8):      Zintegrowany kalendarz dla Icedove
136 License:        MPL 1.1 or GPL v2+ or LGPL v2.1+
137 Group:          Applications/Networking
138 Requires:       %{name} = %{version}-%{release}
139
140 %description addon-lightning
141 Lightning is an calendar extension to Icedove email client.
142
143 %description addon-lightning -l pl.UTF-8
144 Lightning to rozszerzenie do klienta poczty Icedove dodające
145 funkcjonalność kalendarza.
146
147 %package addon-enigmail
148 Summary:        Extension for the authentication and encryption features provided by GnuPG
149 Summary(pl.UTF-8):      Rozszerzenie do uwierzytelniania i szyfrowania zapewnianego przez GnuPG
150 License:        MPL/LGPL
151 Group:          Applications/Networking
152 URL:            http://enigmail.mozdev.org/
153 Requires:       %{name} = %{version}-%{release}
154 Requires:       gnupg
155 Obsoletes:      mozilla-thunderbird-addon-enigmail
156
157 %description addon-enigmail
158 Enigmail is an extension to the Icedove mail client which allows users
159 to access the authentication and encryption features provided by
160 GnuPG.
161
162 Main Features:
163 - Encrypt/sign mail when sending, decrypt/authenticate received mail
164 - Support for inline-PGP (RFC 2440) and PGP/MIME (RFC 3156)
165 - Per-Account based encryption and signing defaults
166 - Per-Recipient rules for automated key selection, and
167   enabling/disabling encryption and signing
168 - OpenPGP key management interface
169
170 %description addon-enigmail -l pl.UTF-8
171 Enigmail to rozszerzenie klienta pocztowego Icedove pozwalające
172 użytkownikom na dostęp do uwierzytelniania i szyfrowania zapewnianego
173 przez GnuPG.
174
175 Główne możliwości:
176 - szyfrowanie/podpisywanie poczty przy wysyłaniu,
177   odszyfrowywanie/uwierzytelnianie poczty odebranej
178 - obsługa inline-PGP (RFC 2440) i PGP/MIME (RFC 3156)
179 - ustawienia domyślne szyfrowania i podpisywania dla każdego konta
180 - reguły automatycznego wyboru kluczy i włączenia szyfrowania oraz
181   podpisywania dla każdego adresata
182 - interfejs do zarządzania kluczami OpenPGP
183
184 %prep
185 %setup -qc
186 mv comm-release mozilla
187 %setup -q -T -D -a2
188 cd mozilla
189 %{?with_enigmail:%{__gzip} -dc %{SOURCE1} | %{__tar} -xf - -C mailnews/extensions}
190 /bin/sh %{SOURCE3}
191 %patch0 -p1
192 %{?with_enigmail:%patch1 -p1}
193 %{?with_xulrunner:%patch2 -p1}
194 %patch3 -p1
195 %patch4 -p1
196 %patch6 -p1
197 %patch7 -p1
198 %patch8 -p2
199 %patch9 -p1
200 %patch10 -p2
201 %patch11 -p2
202 %patch12 -p1
203
204 %build
205 cd mozilla
206 cp -f %{_datadir}/automake/config.* mozilla/build/autoconf
207 cp -f %{_datadir}/automake/config.* mozilla/nsprpub/build/autoconf
208 cp -f %{_datadir}/automake/config.* ldap/sdks/c-sdk/config/autoconf
209
210 cat << EOF > .mozconfig
211 mk_add_options MOZ_OBJDIR=%{objdir}
212
213 export CFLAGS="%{rpmcflags}"
214 export CXXFLAGS="%{rpmcflags}"
215
216 %if %{with crashreporter}
217 export MOZ_DEBUG_SYMBOLS=1
218 %endif
219
220 # Options for 'configure' (same as command-line options).
221 ac_add_options --prefix=%{_prefix}
222 ac_add_options --exec-prefix=%{_exec_prefix}
223 ac_add_options --bindir=%{_bindir}
224 ac_add_options --sbindir=%{_sbindir}
225 ac_add_options --sysconfdir=%{_sysconfdir}
226 ac_add_options --datadir=%{_datadir}
227 ac_add_options --includedir=%{_includedir}
228 ac_add_options --libdir=%{_libdir}
229 ac_add_options --libexecdir=%{_libexecdir}
230 ac_add_options --localstatedir=%{_localstatedir}
231 ac_add_options --sharedstatedir=%{_sharedstatedir}
232 ac_add_options --mandir=%{_mandir}
233 ac_add_options --infodir=%{_infodir}
234 %if %{?debug:1}0
235 ac_add_options --disable-optimize
236 ac_add_options --enable-debug
237 ac_add_options --enable-debug-modules
238 ac_add_options --enable-debugger-info-modules
239 ac_add_options --enable-crash-on-assert
240 %else
241 ac_add_options --disable-debug
242 ac_add_options --disable-debug-modules
243 ac_add_options --disable-logging
244 ac_add_options --enable-optimize="%{rpmcflags} -Os"
245 %endif
246 ac_add_options --disable-strip
247 ac_add_options --disable-strip-libs
248 %if %{with tests}
249 ac_add_options --enable-tests
250 %else
251 ac_add_options --disable-tests
252 %endif
253 ac_add_options --enable-gio
254 %if %{with gnomeui}
255 ac_add_options --enable-gnomeui
256 %else
257 ac_add_options --disable-gnomeui
258 %endif
259 ac_add_options --disable-gnomevfs
260 %if %{with ldap}
261 ac_add_options --enable-ldap
262 ac_add_options --with-system-ldap
263 %else
264 ac_add_options --disable-ldap
265 %endif
266 %if %{with crashreporter}
267 ac_add_options --enable-crashreporter
268 %else
269 ac_add_options --disable-crashreporter
270 %endif
271 ac_add_options --disable-xterm-updates
272 ac_add_options --enable-postscript
273 %if %{with lightning}
274 ac_add_options --enable-calendar
275 %else
276 ac_add_options --disable-calendar
277 %endif
278 ac_add_options --disable-installer
279 ac_add_options --disable-updater
280 ac_add_options --disable-xprint
281 ac_add_options --disable-permissions
282 ac_add_options --disable-pref-extensions
283 ac_add_options --enable-canvas
284 ac_add_options --enable-crypto
285 ac_add_options --enable-mathml
286 ac_add_options --enable-pango
287 ac_add_options --enable-reorder
288 ac_add_options --enable-startup-notification
289 ac_add_options --enable-svg
290 ac_add_options --enable-system-cairo
291 ac_add_options --enable-system-hunspell
292 ac_add_options --enable-system-sqlite
293 ac_add_options --enable-xft
294 ac_add_options --enable-application=mail
295 ac_add_options --enable-default-toolkit=cairo-gtk2
296 ac_add_options --enable-xinerama
297 ac_add_options --with-distribution-id=org.pld-linux
298 ac_add_options --with-branding=icedove/branding
299 %if %{with xulrunner}
300 ac_add_options --enable-shared-js
301 ac_add_options --with-libxul-sdk=$(pkg-config --variable=sdkdir libxul)
302 ac_add_options --with-system-libxul
303 %endif
304 ac_add_options --with-pthreads
305 ac_add_options --with-system-bz2
306 ac_add_options --with-system-jpeg
307 ac_add_options --with-system-nspr
308 ac_add_options --with-system-nss
309 ac_add_options --with-system-png
310 ac_add_options --with-system-zlib
311 ac_add_options --enable-single-profile
312 ac_add_options --disable-profilesharing
313 ac_add_options --with-default-mozilla-five-home=%{_libdir}/%{name}
314 EOF
315
316 %{__make} -j1 -f client.mk build \
317         STRIP="/bin/true" \
318         MOZ_MAKE_FLAGS="%{?_smp_mflags}" \
319         CC="%{__cc}" \
320         CXX="%{__cxx}"
321
322 %if %{with crashreporter}
323 # create debuginfo for crash-stats.mozilla.com
324 %{__make} -j1 -C obj-%{_target_cpu} buildsymbols
325 %endif
326
327 %if %{with enigmail}
328 cd mailnews/extensions/enigmail
329 ./makemake -r -o %{objdir}
330 %{__make} -C %{objdir}/mailnews/extensions/enigmail \
331         STRIP="/bin/true" \
332         CC="%{__cc}" \
333         CXX="%{__cxx}"
334 %endif
335
336 %install
337 rm -rf $RPM_BUILD_ROOT
338 install -d $RPM_BUILD_ROOT{%{_bindir},%{_libdir}/%{name},%{_datadir}/%{name},%{_pixmapsdir},%{_desktopdir}}
339
340 cd %{objdir}
341 %{__make} -C mail/installer stage-package \
342         DESTDIR=$RPM_BUILD_ROOT \
343         MOZ_PKG_DIR=%{_libdir}/%{name} \
344         PKG_SKIP_STRIP=1
345
346 %if %{with xulrunner}
347 # needed to find mozilla runtime
348 ln -s ../xulrunner $RPM_BUILD_ROOT%{_libdir}/%{name}/xulrunner
349 %endif
350  
351 # Enable crash reporter for Thunderbird application
352 %if %{with crashreporter}
353 %{__sed} -i -e 's/\[Crash Reporter\]/[Crash Reporter]\nEnabled=1/' $RPM_BUILD_ROOT%{_libdir}/%{name}/application.ini
354
355 # Add debuginfo for crash-stats.mozilla.com
356 install -d $RPM_BUILD_ROOT%{_exec_prefix}/lib/debug%{_libdir}/%{name}
357 cp -a mozilla/dist/%{name}-%{version}.en-US.linux-*.crashreporter-symbols.zip $RPM_BUILD_ROOT%{_prefix}/lib/debug%{_libdir}/%{name}
358 %endif
359
360 # copy manually lightning files, somewhy they are not installed by make
361 cp -a mozilla/dist/bin/extensions/calendar-timezones@mozilla.org \
362         mozilla/dist/bin/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103} \
363         $RPM_BUILD_ROOT%{_libdir}/%{name}/extensions
364
365 # move arch independant ones to datadir
366 mv $RPM_BUILD_ROOT%{_libdir}/%{name}/chrome $RPM_BUILD_ROOT%{_datadir}/%{name}/chrome
367 mv $RPM_BUILD_ROOT%{_libdir}/%{name}/defaults $RPM_BUILD_ROOT%{_datadir}/%{name}/defaults
368 mv $RPM_BUILD_ROOT%{_libdir}/%{name}/isp $RPM_BUILD_ROOT%{_datadir}/%{name}/isp
369 mv $RPM_BUILD_ROOT%{_libdir}/%{name}/modules $RPM_BUILD_ROOT%{_datadir}/%{name}/modules
370 mv $RPM_BUILD_ROOT%{_libdir}/%{name}/searchplugins $RPM_BUILD_ROOT%{_datadir}/%{name}/searchplugins
371 ln -s ../../share/%{name}/chrome $RPM_BUILD_ROOT%{_libdir}/%{name}/chrome
372 ln -s ../../share/%{name}/defaults $RPM_BUILD_ROOT%{_libdir}/%{name}/defaults
373 ln -s ../../share/%{name}/isp $RPM_BUILD_ROOT%{_libdir}/%{name}/isp
374 ln -s ../../share/%{name}/modules $RPM_BUILD_ROOT%{_libdir}/%{name}/modules
375 ln -s ../../share/%{name}/searchplugins $RPM_BUILD_ROOT%{_libdir}/%{name}/searchplugins
376 %if %{without xulrunner}
377 mv $RPM_BUILD_ROOT%{_libdir}/%{name}/res $RPM_BUILD_ROOT%{_datadir}/%{name}/res
378 ln -s ../../share/%{name}/res $RPM_BUILD_ROOT%{_libdir}/%{name}/res
379 %endif
380
381 # dir for arch independant extensions besides arch dependant extensions
382 # see mozilla/xpcom/build/nsXULAppAPI.h
383 # XRE_SYS_LOCAL_EXTENSION_PARENT_DIR and XRE_SYS_SHARE_EXTENSION_PARENT_DIR
384 install -d $RPM_BUILD_ROOT%{_datadir}/%{name}/extensions
385
386 %if %{without xulrunner}
387 %{__rm} -r $RPM_BUILD_ROOT%{_libdir}/%{name}/dictionaries
388 ln -s %{_datadir}/myspell $RPM_BUILD_ROOT%{_libdir}/%{name}/dictionaries
389 %{__rm} -r $RPM_BUILD_ROOT%{_libdir}/%{name}/hyphenation
390 ln -s %{_datadir}/myspell $RPM_BUILD_ROOT%{_libdir}/%{name}/hyphenation
391 %endif
392
393 %{__sed} -e 's,@LIBDIR@,%{_libdir},' %{SOURCE5} > $RPM_BUILD_ROOT%{_bindir}/icedove
394 ln -s %{name} $RPM_BUILD_ROOT%{_bindir}/thunderbird
395 ln -s %{name} $RPM_BUILD_ROOT%{_bindir}/mozilla-thunderbird
396
397 cp -p %{SOURCE4} $RPM_BUILD_ROOT%{_desktopdir}/%{name}.desktop
398 cp -p %{topdir}/mozilla/icedove/branding/content/icon64.png $RPM_BUILD_ROOT%{_pixmapsdir}/%{name}.png
399
400 # files created by regxpcom -register in post
401 touch $RPM_BUILD_ROOT%{_libdir}/%{name}/components/compreg.dat
402 touch $RPM_BUILD_ROOT%{_libdir}/%{name}/components/xpti.dat
403 cat << 'EOF' > $RPM_BUILD_ROOT%{_libdir}/%{name}/register
404 #!/bin/sh
405 umask 022
406 # make temporary HOME, as it attempts to touch files in $HOME/.mozilla
407 # dangerous if you run this with sudo with keep_env += HOME
408 # also TMPDIR could be pointing to sudo user's homedir so we reset that too.
409 t=$(mktemp -d)
410 %{__rm} -f %{_libdir}/%{name}/components/{compreg,xpti}.dat
411 TMPDIR= TMP= HOME=$t %{_libdir}/%{name}/icedove -register
412 rm -rf $t
413 EOF
414 chmod a+rx $RPM_BUILD_ROOT%{_libdir}/%{name}/register
415
416 %if %{with enigmail}
417 ext_dir=$RPM_BUILD_ROOT%{_libdir}/%{name}/extensions/\{847b3a00-7ab1-11d4-8f02-006008948af5\}
418 install -d $ext_dir/{chrome,components,defaults/preferences}
419 cd mozilla/dist/bin
420 #cp -rfLp chrome/enigmail.jar $ext_dir/chrome
421 #cp -rfLp chrome/enigmime.jar $ext_dir/chrome
422 cp -rfLp components/enig* $ext_dir/components
423 cp -rfLp components/libenigmime.so $ext_dir/components
424 cp -rfLp components/libipc.so $ext_dir/components
425 cp -rfLp components/ipc.xpt $ext_dir/components
426 cp -rfLp defaults/preferences/enigmail.js $ext_dir/defaults/preferences
427 cd -
428 cp -p %{topdir}/mozilla/mailnews/extensions/enigmail/package/install.rdf $ext_dir
429 cp -p %{topdir}/mozilla/mailnews/extensions/enigmail/package/chrome.manifest $ext_dir/chrome.manifest
430 %endif
431
432 # never package these. always remove
433 # nss
434 %{__rm} -f $RPM_BUILD_ROOT%{_libdir}/%{name}/lib{freebl3,nss3,nssckbi,nssdbm3,nssutil3,smime3,softokn3,ssl3}.*
435 # nspr
436 %{__rm} -f $RPM_BUILD_ROOT%{_libdir}/%{name}/lib{nspr4,plc4,plds4}.so
437 # mozldap
438 %{__rm} -f $RPM_BUILD_ROOT%{_libdir}/%{name}/lib{ldap,ldif,prldap,ssldap}60.so
439 # testpilot quiz
440 %{__rm} -f $RPM_BUILD_ROOT%{_libdir}/%{name}/distribution/extensions/tbtestpilot@labs.mozilla.com.xpi
441
442 %clean
443 rm -rf $RPM_BUILD_ROOT
444
445 %pretrans
446 if [ -d %{_libdir}/%{name}/dictionaries ] && [ ! -L %{_libdir}/%{name}/dictionaries ]; then
447         mv -v %{_libdir}/%{name}/dictionaries{,.rpmsave}
448 fi
449 for d in chrome defaults icons isp modules res searchplugins; do
450         if [ -d %{_libdir}/%{name}/$d ] && [ ! -L %{_libdir}/%{name}/$d ]; then
451                 install -d %{_datadir}/%{name}
452                 mv %{_libdir}/%{name}/$d %{_datadir}/%{name}/$d
453         fi
454 done
455 exit 0
456
457 %post
458 %{_libdir}/%{name}/register || :
459
460 %files
461 %defattr(644,root,root,755)
462 %attr(755,root,root) %{_bindir}/icedove
463 %attr(755,root,root) %{_bindir}/mozilla-thunderbird
464 %attr(755,root,root) %{_bindir}/thunderbird
465 %dir %{_libdir}/%{name}
466 %{_libdir}/%{name}/application.ini
467 %{_libdir}/%{name}/blocklist.xml
468 %{_libdir}/%{name}/chrome.manifest
469 %dir %{_libdir}/%{name}/components
470 %{_libdir}/%{name}/components/*.js
471 %{_libdir}/%{name}/components/*.xpt
472 %{_libdir}/%{name}/components/components.manifest
473 %{_libdir}/%{name}/components/interfaces.manifest
474 %attr(755,root,root) %{_libdir}/%{name}/*.sh
475 %attr(755,root,root) %{_libdir}/%{name}/*-bin
476 %attr(755,root,root) %{_libdir}/%{name}/icedove
477 %attr(755,root,root) %{_libdir}/%{name}/register
478 %if %{without xulrunner}
479 %{_libdir}/%{name}/platform.ini
480 %{_libdir}/%{name}/greprefs.js
481 %attr(755,root,root) %{_libdir}/%{name}/components/*.so
482 %attr(755,root,root) %{_libdir}/%{name}/libmozalloc.so
483 %attr(755,root,root) %{_libdir}/%{name}/libxpcom.so
484 %attr(755,root,root) %{_libdir}/%{name}/libxul.so
485 %attr(755,root,root) %{_libdir}/%{name}/mozilla-xremote-client
486 %attr(755,root,root) %{_libdir}/%{name}/plugin-container
487 %endif
488
489 # symlinks
490 %{_libdir}/%{name}/chrome
491 %{_libdir}/%{name}/defaults
492 %{_libdir}/%{name}/isp
493 %{_libdir}/%{name}/modules
494 %{_libdir}/%{name}/searchplugins
495 %if %{with xulrunner}
496 %{_libdir}/%{name}/xulrunner
497 %else
498 %{_libdir}/%{name}/dictionaries
499 %{_libdir}/%{name}/hyphenation
500 %{_libdir}/%{name}/res
501 %endif
502
503 %{_pixmapsdir}/icedove.png
504 %{_desktopdir}/icedove.desktop
505
506 %dir %{_datadir}/%{name}
507 %{_datadir}/%{name}/chrome
508 %{_datadir}/%{name}/defaults
509 %{_datadir}/%{name}/extensions
510 %{_datadir}/%{name}/isp
511 %{_datadir}/%{name}/modules
512 %{_datadir}/%{name}/searchplugins
513 %if %{without xulrunner}
514 %{_datadir}/%{name}/res
515 %endif
516
517 %if %{with crashreporter}
518 %attr(755,root,root) %{_libdir}/%{name}/crashreporter
519 %{_libdir}/%{name}/crashreporter.ini
520 %{_libdir}/%{name}/Throbber-small.gif
521 %endif
522
523 %dir %{_libdir}/%{name}/extensions
524 %{_libdir}/%{name}/extensions/{972ce4c6-7e08-4474-a285-3208198ce6fd}
525
526 # files created by regxpcom -register
527 %ghost %{_libdir}/%{name}/components/compreg.dat
528 %ghost %{_libdir}/%{name}/components/xpti.dat
529
530 %if %{with lightning}
531 %files addon-lightning
532 %defattr(644,root,root,755)
533 %dir %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}
534 %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/application.ini
535 %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/chrome
536 %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/chrome.manifest
537 %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/defaults
538 %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/install.rdf
539 %dir %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/components
540 %attr(755,root,root) %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/components/*.so
541 %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/components/*.js
542 %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/components/*.manifest
543 %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/components/*.xpt
544 %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/modules
545 %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/calendar-js
546 %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/timezones.sqlite
547 %{_libdir}/%{name}/extensions/calendar-timezones@mozilla.org
548 %endif
549
550 %if %{with enigmail}
551 %files addon-enigmail
552 %defattr(644,root,root,755)
553 %dir %{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}
554 %{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/defaults
555 %{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/chrome
556 %{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/chrome.manifest
557 %{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/install.rdf
558 %dir %{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/components
559 %attr(755,root,root) %{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/components/*.so
560 %{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/components/*.xpt
561 %{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/components/*.js
562 %endif
This page took 0.072272 seconds and 4 git commands to generate.