]> git.pld-linux.org Git - packages/thunderbird.git/blob - icedove.spec
- cleaned up obsolete entries from _noauto* lists; explicit pixmaps/desktop files
[packages/thunderbird.git] / icedove.spec
1 # TODO:
2 # - separate spec for enigmail
3 # - build with system mozldap
4 #
5 # Conditional builds
6 %bcond_without  enigmail        # don't build enigmail - GPG/PGP support
7 %bcond_without  gnomeui         # disable gnomeui support
8 %bcond_without  gnome           # alias for gnomeui
9 %bcond_without  ldap            # disable e-mail address lookups in LDAP directories
10 %bcond_without  lightning       # disable Sunbird/Lightning calendar
11 %bcond_without  xulrunner       # build with xulrunner
12 %bcond_with     crashreporter   # report crashes to crash-stats.mozilla.com
13
14 %if %{without gnome}
15 %undefine       with_gnomeui
16 %endif
17
18 %if 0%{?_enable_debug_packages} != 1
19 %undefine       crashreporter
20 %endif
21
22 %define         enigmail_ver    1.3.5
23 %define         nspr_ver        4.8.8
24 %define         nss_ver         3.12.10
25
26 # convert thunderbird release number to platform version: 9.0.x -> 9.0.x
27 %define         xulrunner_main  10.0
28 %define         xulrunner_ver   %(v=%{version}; echo %{xulrunner_main}${v#10.0})
29
30 %if %{without xulrunner}
31 # The actual sqlite version (see RHBZ#480989):
32 %define         sqlite_build_version %(pkg-config --silence-errors --modversion sqlite3 2>/dev/null || echo ERROR)
33 %endif
34
35 Summary:        Icedove - email client
36 Summary(pl.UTF-8):      Icedove - klient poczty
37 Name:           icedove
38 Version:        10.0.2
39 Release:        3
40 License:        MPL 1.1 or GPL v2+ or LGPL v2.1+
41 Group:          X11/Applications/Networking
42 Source0:        http://releases.mozilla.org/pub/mozilla.org/thunderbird/releases/%{version}/source/thunderbird-%{version}.source.tar.bz2
43 # Source0-md5:  624bef982d7ac610b1175737d9905150
44 Source1:        http://www.mozilla-enigmail.org/download/source/enigmail-%{enigmail_ver}.tar.gz
45 # Source1-md5:  1b008b0d106e238c11e4bead08126bc0
46 Source2:        %{name}-branding.tar.bz2
47 # Source2-md5:  2da351522bdd7f4a3bd8aaff4c776976
48 Source3:        %{name}-rm_nonfree.sh
49 Source4:        %{name}.desktop
50 Source5:        %{name}.sh
51 Patch0:         %{name}-branding.patch
52 Patch1:         %{name}-enigmail-shared.patch
53 Patch2:         %{name}-gcc.patch
54 Patch3:         %{name}-fonts.patch
55 Patch4:         %{name}-install.patch
56 Patch5:         %{name}-hunspell.patch
57 Patch6:         %{name}-prefs.patch
58 Patch7:         system-mozldap.patch
59 Patch8:         %{name}-makefile.patch
60
61 Patch10:        %{name}-extensiondir.patch
62 Patch11:        crashreporter.patch
63 Patch12:        no-subshell.patch
64 URL:            http://www.pld-linux.org/Packages/Icedove
65 BuildRequires:  GConf2-devel >= 1.2.1
66 BuildRequires:  alsa-lib-devel
67 BuildRequires:  automake
68 BuildRequires:  bzip2-devel
69 BuildRequires:  cairo-devel >= 1.10
70 BuildRequires:  dbus-glib-devel >= 0.60
71 BuildRequires:  freetype-devel >= 1:2.1.8
72 BuildRequires:  glib2-devel >= 2.0
73 BuildRequires:  gtk+2-devel >= 2:2.10.0
74 BuildRequires:  hunspell-devel
75 BuildRequires:  libIDL-devel >= 0.8.0
76 %{?with_gnomeui:BuildRequires:  libgnome-devel >= 2.0}
77 %{?with_gnomeui:BuildRequires:  libgnome-keyring-devel}
78 %{?with_gnomeui:BuildRequires:  libgnomeui-devel >= 2.2.0}
79 BuildRequires:  libiw-devel
80 BuildRequires:  libjpeg-devel >= 6b
81 BuildRequires:  libnotify-devel >= 0.4
82 BuildRequires:  libpng-devel >= 1.4.1
83 BuildRequires:  libstdc++-devel
84 BuildRequires:  nspr-devel >= 1:%{nspr_ver}
85 BuildRequires:  nss-devel >= 1:%{nss_ver}
86 BuildRequires:  pango-devel >= 1:1.1.0
87 BuildRequires:  perl-base >= 1:5.6
88 BuildRequires:  pkgconfig
89 BuildRequires:  python >= 1:2.5
90 BuildRequires:  sed >= 4.0
91 BuildRequires:  sqlite3-devel >= 3.7.4
92 BuildRequires:  startup-notification-devel >= 0.8
93 BuildRequires:  xorg-lib-libXext-devel
94 BuildRequires:  xorg-lib-libXinerama-devel
95 BuildRequires:  xorg-lib-libXt-devel
96 BuildRequires:  yasm
97 BuildRequires:  zip
98 %if %{with xulrunner}
99 BuildRequires:  xulrunner-devel >= 2:%{xulrunner_ver}
100 %else
101 Requires:       myspell-common
102 Requires:       nspr >= 1:%{nspr_ver}
103 Requires:       nss >= 1:%{nss_ver}
104 Requires:       sqlite3 >= %{sqlite_build_version}
105 %endif
106 Requires(post): mktemp >= 1.5-18
107 %if %{with xulrunner}
108 %requires_eq_to xulrunner xulrunner-devel
109 %endif
110 Obsoletes:      mozilla-thunderbird
111 Obsoletes:      mozilla-thunderbird-dictionary-en-US
112 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
113
114 %define         filterout_cpp           -D_FORTIFY_SOURCE=[0-9]+
115
116 # iceweasel/icedove/iceape provide their own versions
117 %define         _noautoprovfiles        %{_libdir}/%{name}/components
118 # we don't want these to satisfy xulrunner-devel
119 %define         _noautoprov             libmozjs.so libxpcom.so libxul.so
120 # and as we don't provide them, don't require either
121 %define         _noautoreq              libmozjs.so libxpcom.so libxul.so
122
123 %define         topdir          %{_builddir}/%{name}-%{version}
124 %define         objdir          %{topdir}/obj-%{_target_cpu}
125
126 %description
127 Icedove is an open-source, fast and portable email client.
128
129 %description -l pl.UTF-8
130 Icedove jest mającym otwarte źródła, szybkim i przenośnym klientem
131 poczty.
132
133 %package addon-lightning
134 Summary:        An integrated calendar for Icedove
135 Summary(pl.UTF-8):      Zintegrowany kalendarz dla Icedove
136 License:        MPL 1.1 or GPL v2+ or LGPL v2.1+
137 Group:          Applications/Networking
138 Requires:       %{name} = %{version}-%{release}
139
140 %description addon-lightning
141 Lightning is an calendar extension to Icedove email client.
142
143 %description addon-lightning -l pl.UTF-8
144 Lightning to rozszerzenie do klienta poczty Icedove dodające
145 funkcjonalność kalendarza.
146
147 %package addon-enigmail
148 Summary:        Extension for the authentication and encryption features provided by GnuPG
149 Summary(pl.UTF-8):      Rozszerzenie do uwierzytelniania i szyfrowania zapewnianego przez GnuPG
150 License:        MPL/LGPL
151 Group:          Applications/Networking
152 URL:            http://enigmail.mozdev.org/
153 Requires:       %{name} = %{version}-%{release}
154 Requires:       gnupg
155 Obsoletes:      mozilla-thunderbird-addon-enigmail
156
157 %description addon-enigmail
158 Enigmail is an extension to the Icedove mail client which allows users
159 to access the authentication and encryption features provided by
160 GnuPG.
161
162 Main Features:
163 - Encrypt/sign mail when sending, decrypt/authenticate received mail
164 - Support for inline-PGP (RFC 2440) and PGP/MIME (RFC 3156)
165 - Per-Account based encryption and signing defaults
166 - Per-Recipient rules for automated key selection, and
167   enabling/disabling encryption and signing
168 - OpenPGP key management interface
169
170 %description addon-enigmail -l pl.UTF-8
171 Enigmail to rozszerzenie klienta pocztowego Icedove pozwalające
172 użytkownikom na dostęp do uwierzytelniania i szyfrowania zapewnianego
173 przez GnuPG.
174
175 Główne możliwości:
176 - szyfrowanie/podpisywanie poczty przy wysyłaniu,
177   odszyfrowywanie/uwierzytelnianie poczty odebranej
178 - obsługa inline-PGP (RFC 2440) i PGP/MIME (RFC 3156)
179 - ustawienia domyślne szyfrowania i podpisywania dla każdego konta
180 - reguły automatycznego wyboru kluczy i włączenia szyfrowania oraz
181   podpisywania dla każdego adresata
182 - interfejs do zarządzania kluczami OpenPGP
183
184 %prep
185 %setup -qc
186 mv comm-release mozilla
187 %setup -q -T -D -a2
188 cd mozilla
189 %{?with_enigmail:%{__gzip} -dc %{SOURCE1} | %{__tar} -xf - -C mailnews/extensions}
190 /bin/sh %{SOURCE3}
191 %patch0 -p1
192 %{?with_enigmail:%patch1 -p1}
193 %patch2 -p1
194 %patch3 -p1
195 %patch4 -p1
196 %patch6 -p1
197 %patch7 -p1
198 %patch8 -p2
199 %patch10 -p2
200 %patch11 -p2
201 %patch12 -p1
202
203 %build
204 cd mozilla
205 cp -f %{_datadir}/automake/config.* mozilla/build/autoconf
206 cp -f %{_datadir}/automake/config.* mozilla/nsprpub/build/autoconf
207 cp -f %{_datadir}/automake/config.* ldap/sdks/c-sdk/config/autoconf
208
209 install -d libxul-sdk
210 ln -snf %{_libdir}/xulrunner-sdk libxul-sdk/sdk
211
212 cat << EOF > .mozconfig
213 mk_add_options MOZ_OBJDIR=%{objdir}
214
215 export CFLAGS="%{rpmcflags} -fpermissive -I/usr/include/xulrunner"
216 export CXXFLAGS="%{rpmcflags} -fpermissive -I/usr/include/xulrunner"
217
218 %if %{with crashreporter}
219 export MOZ_DEBUG_SYMBOLS=1
220 %endif
221
222 # Options for 'configure' (same as command-line options).
223 ac_add_options --prefix=%{_prefix}
224 ac_add_options --exec-prefix=%{_exec_prefix}
225 ac_add_options --bindir=%{_bindir}
226 ac_add_options --sbindir=%{_sbindir}
227 ac_add_options --sysconfdir=%{_sysconfdir}
228 ac_add_options --datadir=%{_datadir}
229 ac_add_options --includedir=%{_includedir}
230 ac_add_options --libdir=%{_libdir}
231 ac_add_options --libexecdir=%{_libexecdir}
232 ac_add_options --localstatedir=%{_localstatedir}
233 ac_add_options --sharedstatedir=%{_sharedstatedir}
234 ac_add_options --mandir=%{_mandir}
235 ac_add_options --infodir=%{_infodir}
236 %if %{?debug:1}0
237 ac_add_options --disable-optimize
238 ac_add_options --enable-debug
239 ac_add_options --enable-debug-modules
240 ac_add_options --enable-debugger-info-modules
241 ac_add_options --enable-crash-on-assert
242 %else
243 ac_add_options --disable-debug
244 ac_add_options --disable-debug-modules
245 ac_add_options --disable-logging
246 ac_add_options --enable-optimize="%{rpmcflags} -Os"
247 %endif
248 ac_add_options --disable-strip
249 ac_add_options --disable-strip-libs
250 %if %{with tests}
251 ac_add_options --enable-tests
252 %else
253 ac_add_options --disable-tests
254 %endif
255 ac_add_options --enable-gio
256 %if %{with gnomeui}
257 ac_add_options --enable-gnomeui
258 %else
259 ac_add_options --disable-gnomeui
260 %endif
261 ac_add_options --disable-gnomevfs
262 %if %{with ldap}
263 ac_add_options --enable-ldap
264 ac_add_options --with-system-ldap
265 %else
266 ac_add_options --disable-ldap
267 %endif
268 %if %{with crashreporter}
269 ac_add_options --enable-crashreporter
270 %else
271 ac_add_options --disable-crashreporter
272 %endif
273 ac_add_options --disable-xterm-updates
274 ac_add_options --enable-postscript
275 %if %{with lightning}
276 ac_add_options --enable-calendar
277 %else
278 ac_add_options --disable-calendar
279 %endif
280 ac_add_options --disable-installer
281 ac_add_options --disable-jsd
282 ac_add_options --disable-updater
283 ac_add_options --disable-xprint
284 ac_add_options --disable-permissions
285 ac_add_options --disable-pref-extensions
286 ac_add_options --enable-canvas
287 ac_add_options --enable-crypto
288 ac_add_options --enable-mathml
289 ac_add_options --enable-pango
290 ac_add_options --enable-reorder
291 ac_add_options --enable-startup-notification
292 ac_add_options --enable-svg
293 ac_add_options --enable-system-cairo
294 ac_add_options --enable-system-hunspell
295 ac_add_options --enable-system-sqlite
296 ac_add_options --enable-xft
297 ac_add_options --enable-application=mail
298 ac_add_options --enable-default-toolkit=cairo-gtk2
299 ac_add_options --enable-xinerama
300 ac_add_options --with-distribution-id=org.pld-linux
301 ac_add_options --with-branding=icedove/branding
302 %if %{with xulrunner}
303 #ac_add_options --with-libxul-sdk=$(pwd)/libxul-sdk/sdk
304 ac_add_options --with-system-libxul
305 ac_add_options --enable-shared
306 ac_add_options --enable-libxul
307 %else
308 ac_add_options --disable-xul
309 %endif
310 ac_add_options --with-pthreads
311 ac_add_options --with-system-bz2
312 ac_add_options --with-system-jpeg
313 ac_add_options --with-system-nspr
314 ac_add_options --with-system-nss
315 ac_add_options --with-system-png
316 ac_add_options --with-system-zlib
317 ac_add_options --enable-single-profile
318 ac_add_options --disable-profilesharing
319 ac_add_options --with-default-mozilla-five-home=%{_libdir}/%{name}
320 EOF
321
322 %{__make} -j1 -f client.mk build \
323         STRIP="/bin/true" \
324         MOZ_MAKE_FLAGS="%{?_smp_mflags}" \
325         CC="%{__cc}" \
326         CXX="%{__cxx}"
327
328 %if %{with crashreporter}
329 # create debuginfo for crash-stats.mozilla.com
330 %{__make} -j1 -C obj-%{_target_cpu} buildsymbols
331 %endif
332
333 %if %{with enigmail}
334 cd mailnews/extensions/enigmail
335 ./makemake -r -o %{objdir}
336 %{__make} -C %{objdir}/mailnews/extensions/enigmail \
337         STRIP="/bin/true" \
338         CC="%{__cc}" \
339         CXX="%{__cxx}"
340 %endif
341
342 %install
343 rm -rf $RPM_BUILD_ROOT
344 install -d $RPM_BUILD_ROOT{%{_bindir},%{_libdir}/%{name},%{_datadir}/%{name},%{_pixmapsdir},%{_desktopdir}}
345
346 cd %{objdir}
347 %{__make} -C mail/installer stage-package \
348         DESTDIR=$RPM_BUILD_ROOT \
349         MOZ_PKG_DIR=%{_libdir}/%{name} \
350         PKG_SKIP_STRIP=1
351
352 # Enable crash reporter for Firefox application
353 %if %{with crashreporter}
354 %{__sed} -i -e 's/\[Crash Reporter\]/[Crash Reporter]\nEnabled=1/' $RPM_BUILD_ROOT%{_libdir}/%{name}/application.ini
355
356 # Add debuginfo for crash-stats.mozilla.com
357 install -d $RPM_BUILD_ROOT%{_exec_prefix}/lib/debug%{_libdir}/%{name}
358 cp -a mozilla/dist/%{name}-%{version}.en-US.linux-*.crashreporter-symbols.zip $RPM_BUILD_ROOT%{_prefix}/lib/debug%{_libdir}/%{name}
359 %endif
360
361 # copy manually lightning files, somewhy they are not installed by make
362 cp -a mozilla/dist/bin/extensions/calendar-timezones@mozilla.org \
363         mozilla/dist/bin/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103} \
364         $RPM_BUILD_ROOT%{_libdir}/%{name}/extensions
365
366 # move arch independant ones to datadir
367 mv $RPM_BUILD_ROOT%{_libdir}/%{name}/chrome $RPM_BUILD_ROOT%{_datadir}/%{name}/chrome
368 mv $RPM_BUILD_ROOT%{_libdir}/%{name}/defaults $RPM_BUILD_ROOT%{_datadir}/%{name}/defaults
369 mv $RPM_BUILD_ROOT%{_libdir}/%{name}/isp $RPM_BUILD_ROOT%{_datadir}/%{name}/isp
370 mv $RPM_BUILD_ROOT%{_libdir}/%{name}/modules $RPM_BUILD_ROOT%{_datadir}/%{name}/modules
371 mv $RPM_BUILD_ROOT%{_libdir}/%{name}/res $RPM_BUILD_ROOT%{_datadir}/%{name}/res
372 mv $RPM_BUILD_ROOT%{_libdir}/%{name}/searchplugins $RPM_BUILD_ROOT%{_datadir}/%{name}/searchplugins
373 ln -s ../../share/%{name}/chrome $RPM_BUILD_ROOT%{_libdir}/%{name}/chrome
374 ln -s ../../share/%{name}/defaults $RPM_BUILD_ROOT%{_libdir}/%{name}/defaults
375 ln -s ../../share/%{name}/isp $RPM_BUILD_ROOT%{_libdir}/%{name}/isp
376 ln -s ../../share/%{name}/modules $RPM_BUILD_ROOT%{_libdir}/%{name}/modules
377 ln -s ../../share/%{name}/res $RPM_BUILD_ROOT%{_libdir}/%{name}/res
378 ln -s ../../share/%{name}/searchplugins $RPM_BUILD_ROOT%{_libdir}/%{name}/searchplugins
379
380 # dir for arch independant extensions besides arch dependant extensions
381 # see mozilla/xpcom/build/nsXULAppAPI.h
382 # XRE_SYS_LOCAL_EXTENSION_PARENT_DIR and XRE_SYS_SHARE_EXTENSION_PARENT_DIR
383 install -d $RPM_BUILD_ROOT%{_datadir}/%{name}/extensions
384
385 %{__rm} -r $RPM_BUILD_ROOT%{_libdir}/%{name}/dictionaries
386 ln -s %{_datadir}/myspell $RPM_BUILD_ROOT%{_libdir}/%{name}/dictionaries
387
388 %{__rm} -r $RPM_BUILD_ROOT%{_libdir}/%{name}/hyphenation
389 ln -s %{_datadir}/myspell $RPM_BUILD_ROOT%{_libdir}/%{name}/hyphenation
390
391 %{__sed} -e 's,@LIBDIR@,%{_libdir},' %{SOURCE5} > $RPM_BUILD_ROOT%{_bindir}/icedove
392 ln -s %{name} $RPM_BUILD_ROOT%{_bindir}/thunderbird
393 ln -s %{name} $RPM_BUILD_ROOT%{_bindir}/mozilla-thunderbird
394
395 cp -p %{SOURCE4} $RPM_BUILD_ROOT%{_desktopdir}/%{name}.desktop
396 cp -p %{topdir}/mozilla/icedove/branding/content/icon64.png $RPM_BUILD_ROOT%{_pixmapsdir}/%{name}.png
397
398 # files created by regxpcom -register in post
399 touch $RPM_BUILD_ROOT%{_libdir}/%{name}/components/compreg.dat
400 touch $RPM_BUILD_ROOT%{_libdir}/%{name}/components/xpti.dat
401 cat << 'EOF' > $RPM_BUILD_ROOT%{_libdir}/%{name}/register
402 #!/bin/sh
403 umask 022
404 # make temporary HOME, as it attempts to touch files in $HOME/.mozilla
405 # dangerous if you run this with sudo with keep_env += HOME
406 # also TMPDIR could be pointing to sudo user's homedir so we reset that too.
407 t=$(mktemp -d)
408 %{__rm} -f %{_libdir}/%{name}/components/{compreg,xpti}.dat
409 TMPDIR= TMP= HOME=$t %{_libdir}/%{name}/icedove -register
410 rm -rf $t
411 EOF
412 chmod a+rx $RPM_BUILD_ROOT%{_libdir}/%{name}/register
413
414 %if %{with enigmail}
415 ext_dir=$RPM_BUILD_ROOT%{_libdir}/%{name}/extensions/\{847b3a00-7ab1-11d4-8f02-006008948af5\}
416 install -d $ext_dir/{chrome,components,defaults/preferences}
417 cd mozilla/dist/bin
418 #cp -rfLp chrome/enigmail.jar $ext_dir/chrome
419 #cp -rfLp chrome/enigmime.jar $ext_dir/chrome
420 cp -rfLp components/enig* $ext_dir/components
421 cp -rfLp components/libenigmime.so $ext_dir/components
422 cp -rfLp components/libipc.so $ext_dir/components
423 cp -rfLp components/ipc.xpt $ext_dir/components
424 cp -rfLp defaults/preferences/enigmail.js $ext_dir/defaults/preferences
425 cd -
426 cp -p %{topdir}/mozilla/mailnews/extensions/enigmail/package/install.rdf $ext_dir
427 cp -p %{topdir}/mozilla/mailnews/extensions/enigmail/package/chrome.manifest $ext_dir/chrome.manifest
428 %endif
429
430 # remove unecessary stuff
431 #%%{__rm} $RPM_BUILD_ROOT%{_libdir}/%{name}/README.txt
432 #%%{__rm} $RPM_BUILD_ROOT%{_libdir}/%{name}/components/components.list
433 #%%{__rm} $RPM_BUILD_ROOT%{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/components/components.list
434
435 # never package these. always remove
436 # nss
437 %{__rm} -f $RPM_BUILD_ROOT%{_libdir}/%{name}/lib{freebl3,nss3,nssckbi,nssdbm3,nssutil3,smime3,softokn3,ssl3}.*
438 # nspr
439 %{__rm} -f $RPM_BUILD_ROOT%{_libdir}/%{name}/lib{nspr4,plc4,plds4}.so
440 # mozldap
441 %{__rm} -f $RPM_BUILD_ROOT%{_libdir}/%{name}/lib{ldap,ldif,prldap,ssldap}60.so
442
443 %clean
444 rm -rf $RPM_BUILD_ROOT
445
446 %pretrans
447 if [ -d %{_libdir}/%{name}/dictionaries ] && [ ! -L %{_libdir}/%{name}/dictionaries ]; then
448         mv -v %{_libdir}/%{name}/dictionaries{,.rpmsave}
449 fi
450 for d in chrome defaults icons isp modules res searchplugins; do
451         if [ -d %{_libdir}/%{name}/$d ] && [ ! -L %{_libdir}/%{name}/$d ]; then
452                 install -d %{_datadir}/%{name}
453                 mv %{_libdir}/%{name}/$d %{_datadir}/%{name}/$d
454         fi
455 done
456 exit 0
457
458 %post
459 %{_libdir}/%{name}/register || :
460
461 %files
462 %defattr(644,root,root,755)
463 %attr(755,root,root) %{_bindir}/icedove
464 %attr(755,root,root) %{_bindir}/mozilla-thunderbird
465 %attr(755,root,root) %{_bindir}/thunderbird
466 %dir %{_libdir}/%{name}
467 %{_libdir}/%{name}/application.ini
468 %{_libdir}/%{name}/platform.ini
469 %{_libdir}/%{name}/blocklist.xml
470 %{_libdir}/%{name}/chrome.manifest
471 %{_libdir}/%{name}/greprefs.js
472 %dir %{_libdir}/%{name}/components
473 %attr(755,root,root) %{_libdir}/%{name}/components/*.so
474 %{_libdir}/%{name}/components/*.js
475 %{_libdir}/%{name}/components/*.xpt
476 %{_libdir}/%{name}/components/components.manifest
477 %{_libdir}/%{name}/components/interfaces.manifest
478 %attr(755,root,root) %{_libdir}/%{name}/libmozalloc.so
479 %attr(755,root,root) %{_libdir}/%{name}/libxpcom.so
480 %attr(755,root,root) %{_libdir}/%{name}/libxul.so
481 %attr(755,root,root) %{_libdir}/%{name}/*.sh
482 %attr(755,root,root) %{_libdir}/%{name}/*-bin
483 %attr(755,root,root) %{_libdir}/%{name}/mozilla-xremote-client
484 %attr(755,root,root) %{_libdir}/%{name}/icedove
485 %attr(755,root,root) %{_libdir}/%{name}/plugin-container
486 %attr(755,root,root) %{_libdir}/%{name}/register
487
488 # symlinks
489 %{_libdir}/%{name}/chrome
490 %{_libdir}/%{name}/defaults
491 %{_libdir}/%{name}/dictionaries
492 %{_libdir}/%{name}/hyphenation
493 %{_libdir}/%{name}/isp
494 %{_libdir}/%{name}/modules
495 %{_libdir}/%{name}/res
496 %{_libdir}/%{name}/searchplugins
497
498 %{_pixmapsdir}/icedove.png
499 %{_desktopdir}/icedove.desktop
500
501 %dir %{_datadir}/%{name}
502 %{_datadir}/%{name}/chrome
503 %{_datadir}/%{name}/defaults
504 %{_datadir}/%{name}/extensions
505 %{_datadir}/%{name}/isp
506 %{_datadir}/%{name}/modules
507 %{_datadir}/%{name}/res
508 %{_datadir}/%{name}/searchplugins
509
510 %if %{with crashreporter}
511 %attr(755,root,root) %{_libdir}/%{name}/crashreporter
512 %{_libdir}/%{name}/crashreporter.ini
513 %{_libdir}/%{name}/Throbber-small.gif
514 %endif
515
516 %dir %{_libdir}/%{name}/extensions
517 %{_libdir}/%{name}/extensions/{972ce4c6-7e08-4474-a285-3208198ce6fd}
518
519 # files created by regxpcom -register
520 %ghost %{_libdir}/%{name}/components/compreg.dat
521 %ghost %{_libdir}/%{name}/components/xpti.dat
522
523 %if %{with lightning}
524 %files addon-lightning
525 %defattr(644,root,root,755)
526 %dir %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}
527 %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/application.ini
528 %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/chrome
529 %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/chrome.manifest
530 %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/defaults
531 %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/install.rdf
532 %dir %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/components
533 %attr(755,root,root) %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/components/*.so
534 %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/components/*.js
535 %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/components/*.manifest
536 %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/components/*.xpt
537 %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/modules
538 %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/calendar-js
539 %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/timezones.sqlite
540 %{_libdir}/%{name}/extensions/calendar-timezones@mozilla.org
541 %endif
542
543 %if %{with enigmail}
544 %files addon-enigmail
545 %defattr(644,root,root,755)
546 %dir %{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}
547 %{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/defaults
548 %{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/chrome
549 %{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/chrome.manifest
550 %{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/install.rdf
551 %dir %{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/components
552 %attr(755,root,root) %{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/components/*.so
553 %{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/components/*.xpt
554 %{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/components/*.js
555 %endif
This page took 0.130346 seconds and 4 git commands to generate.