]> git.pld-linux.org Git - packages/thunderbird.git/blob - icedove.spec
- obsoleted
[packages/thunderbird.git] / icedove.spec
1 #
2 # TODO:
3 # - separate spec for enigmail
4 #
5 # Conditional builds
6 %bcond_without  enigmail        # don't build enigmail - GPG/PGP support
7 %bcond_without  gnomeui         # disable gnomeui support
8 %bcond_without  gnomevfs        # disable GNOME comp. (gconf+libgnome+gnomevfs) and gnomevfs ext.
9 %bcond_without  gnome           # disable all GNOME components (gnome+gnomeui+gnomevfs)
10 %bcond_without  ldap            # disable e-mail address lookups in LDAP directories
11 %bcond_without  lightning       # disable sunbird calendar
12 %bcond_with             xulrunner       # build with system xulrunner
13
14 %if %{without gnome}
15 %undefine       with_gnomeui
16 %undefine       with_gnomevfs
17 %endif
18
19 %define         enigmail_ver            1.0.1
20
21 Summary:        Icedove - email client
22 Summary(pl.UTF-8):      Icedove - klient poczty
23 Name:           icedove
24 Version:        3.0.4
25 Release:        1
26 License:        MPL 1.1 or GPL v2+ or LGPL v2.1+
27 Group:          Applications/Networking
28 Source0:        http://releases.mozilla.org/pub/mozilla.org/thunderbird/releases/%{version}/source/thunderbird-%{version}.source.tar.bz2
29 # Source0-md5:  bb87ca7e62d5869422137765126798be
30 Source1:        http://www.mozilla-enigmail.org/download/source/enigmail-%{enigmail_ver}.tar.gz
31 # Source1-md5:  508ca9ab0396afb49e82eda88014924b
32 Source2:        %{name}-branding.tar.bz2
33 # Source2-md5:  2da351522bdd7f4a3bd8aaff4c776976
34 Source3:        %{name}-rm_nonfree.sh
35 Source4:        %{name}.desktop
36 Source5:        %{name}.sh
37 Source6:        %{name}-enigmail.manifest
38 Patch0:         %{name}-branding.patch
39 Patch1:         %{name}-enigmail-shared.patch
40 Patch2:         %{name}-gcc.patch
41 Patch3:         %{name}-fonts.patch
42 Patch4:         %{name}-install.patch
43 Patch5:         %{name}-hunspell.patch
44 Patch6:         %{name}-prefs.patch
45 URL:            http://www.pld-linux.org/Packages/Icedove
46 %{?with_gnomevfs:BuildRequires: GConf2-devel >= 1.2.1}
47 BuildRequires:  automake
48 BuildRequires:  freetype-devel >= 1:2.1.8
49 %{?with_gnomevfs:BuildRequires: gnome-vfs2-devel >= 2.0}
50 BuildRequires:  gtk+2-devel >= 1:2.0.0
51 BuildRequires:  hunspell-devel
52 BuildRequires:  libIDL-devel >= 0.8.0
53 %{?with_gnomevfs:BuildRequires: libgnome-devel >= 2.0}
54 %{?with_gnomeui:BuildRequires:  libgnomeui-devel >= 2.2.0}
55 BuildRequires:  libjpeg-devel >= 6b
56 BuildRequires:  libpng-devel >= 1.2.0
57 BuildRequires:  libstdc++-devel
58 BuildRequires:  nspr-devel >= 1:4.8
59 BuildRequires:  nss-devel >= 1:3.12.0
60 BuildRequires:  pango-devel >= 1:1.1.0
61 BuildRequires:  pkgconfig
62 BuildRequires:  sed >= 4.0
63 BuildRequires:  startup-notification-devel >= 0.8
64 BuildRequires:  xorg-lib-libXext-devel
65 BuildRequires:  xorg-lib-libXinerama-devel
66 BuildRequires:  xorg-lib-libXt-devel
67 BuildRequires:  zip
68 Requires:       myspell-common
69 Requires:       nspr >= 1:4.6.1
70 Requires:       nss >= 1:3.11.3
71 Obsoletes:      mozilla-thunderbird
72 Obsoletes:      mozilla-thunderbird-dictionary-en-US
73 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
74
75 %define         filterout_cpp           -D_FORTIFY_SOURCE=[0-9]+
76
77 # iceweasel/icedove/iceape provide their own versions
78 %define         _noautoreqdep           libgfxpsshar.so libgkgfx.so libgtkxtbin.so libjsj.so libxpcom_compat.so libxpcom_core.so libxpistub.so
79 %define         _noautoprovfiles        %{_libdir}/%{name}/components
80 # we don't want these to satisfy xulrunner-devel
81 %define         _noautoprov             libgtkembedmoz.so libldap50.so libmozjs.so libprldap50.so libssldap50.so libxpcom.so libxul.so
82 # and as we don't provide them, don't require either
83 %define         _noautoreq              libgtkembedmoz.so libldap50.so libmozjs.so libprldap50.so libssldap50.so libxpcom.so libxul.so
84
85 %description
86 Icedove is an open-source,fast and portable email client.
87
88 %description -l pl.UTF-8
89 Icedove jest open sourcowym, szybkim i przenośnym klientem poczty.
90
91 %package addon-lightning
92 Summary:        An integrated calendar for Icedove
93 Summary(pl.UTF-8):      Zintegrowany kalendarz dla Icedove
94 License:        MPL 1.1 or GPL v2+ or LGPL v2.1+
95 Group:          Applications/Networking
96 Requires:       %{name} = %{version}-%{release}
97
98 %description addon-lightning
99 Lightning is an calendar extension to Icedove email client.
100
101 %description addon-lightning -l pl.UTF-8
102 Lightning to rozszerzenie do klienta poczty Icedove dodające
103 funkcjonalność kalendarza.
104
105 %package addon-enigmail
106 Summary:        Extension for the authentication and encryption features provided by GnuPG
107 Summary(pl.UTF-8):      Rozszerzenie do uwierzytelniania i szyfrowania zapewnianego przez GnuPG
108 License:        MPL/LGPL
109 Group:          Applications/Networking
110 URL:            http://enigmail.mozdev.org/
111 Requires:       %{name} = %{version}-%{release}
112 Requires:       gnupg
113 Obsoletes:      mozilla-thunderbird-addon-enigmail
114
115 %description addon-enigmail
116 Enigmail is an extension to the Icedove mail client which allows users
117 to access the authentication and encryption features provided by
118 GnuPG.
119
120 Main Features:
121 - Encrypt/sign mail when sending, decrypt/authenticate received mail
122 - Support for inline-PGP (RFC 2440) and PGP/MIME (RFC 3156)
123 - Per-Account based encryption and signing defaults
124 - Per-Recipient rules for automated key selection, and
125   enabling/disabling encryption and signing
126 - OpenPGP key management interface
127
128 %description addon-enigmail -l pl.UTF-8
129 Enigmail to rozszerzenie klienta pocztowego Icedove pozwalające
130 użytkownikom na dostęp do uwierzytelniania i szyfrowania zapewnianego
131 przez GnuPG.
132
133 Główne możliwości:
134 - szyfrowanie/podpisywanie poczty przy wysyłaniu,
135   odszyfrowywanie/uwierzytelnianie poczty odebranej
136 - obsługa inline-PGP (RFC 2440) i PGP/MIME (RFC 3156)
137 - ustawienia domyślne szyfrowania i podpisywania dla każdego konta
138 - reguły automatycznego wyboru kluczy i włączenia szyfrowania oraz
139   podpisywania dla każdego adresata
140 - interfejs do zarządzania kluczami OpenPGP
141
142 %prep
143 %setup -qc
144 mv -f comm-1.9.1 mozilla
145 %setup -q -T -D -a2
146 cd mozilla
147 %{?with_enigmail:tar xvfz %{SOURCE1} -C mailnews/extensions}
148 /bin/sh %{SOURCE3}
149 %patch0 -p1
150 %{?with_enigmail:%patch1 -p1}
151 %patch2 -p1
152 %patch3 -p1
153 %patch4 -p1
154 %patch5 -p1
155 %patch6 -p1
156
157 %build
158 cd mozilla
159 export CFLAGS="%{rpmcflags} `%{_bindir}/pkg-config mozilla-nspr --cflags-only-I`"
160 export CXXFLAGS="%{rpmcflags} `%{_bindir}/pkg-config mozilla-nspr --cflags-only-I`"
161
162 cp -f %{_datadir}/automake/config.* mozilla/build/autoconf
163 cp -f %{_datadir}/automake/config.* mozilla/nsprpub/build/autoconf
164 cp -f %{_datadir}/automake/config.* directory/c-sdk/config/autoconf
165
166 cat << 'EOF' > .mozconfig
167 mk_add_options MOZ_OBJDIR=@TOPSRCDIR@/obj-%{_target_cpu}
168
169 # Options for 'configure' (same as command-line options).
170 ac_add_options --prefix=%{_prefix}
171 ac_add_options --exec-prefix=%{_exec_prefix}
172 ac_add_options --bindir=%{_bindir}
173 ac_add_options --sbindir=%{_sbindir}
174 ac_add_options --sysconfdir=%{_sysconfdir}
175 ac_add_options --datadir=%{_datadir}
176 ac_add_options --includedir=%{_includedir}
177 ac_add_options --libdir=%{_libdir}
178 ac_add_options --libexecdir=%{_libexecdir}
179 ac_add_options --localstatedir=%{_localstatedir}
180 ac_add_options --sharedstatedir=%{_sharedstatedir}
181 ac_add_options --mandir=%{_mandir}
182 ac_add_options --infodir=%{_infodir}
183 %if %{?debug:1}0
184 ac_add_options --disable-optimize
185 ac_add_options --enable-debug
186 ac_add_options --enable-debug-modules
187 ac_add_options --enable-debugger-info-modules
188 ac_add_options --enable-crash-on-assert
189 %else
190 ac_add_options --disable-debug
191 ac_add_options --disable-debug-modules
192 ac_add_options --disable-logging
193 ac_add_options --enable-optimize="%{rpmcflags} -Os"
194 %endif
195 ac_add_options --disable-strip
196 ac_add_options --disable-strip-libs
197 %if %{with tests}
198 ac_add_options --enable-tests
199 %else
200 ac_add_options --disable-tests
201 %endif
202 %if %{with gnomeui}
203 ac_add_options --enable-gnomeui
204 %else
205 ac_add_options --disable-gnomeui
206 %endif
207 %if %{with gnomevfs}
208 ac_add_options --enable-gnomevfs
209 %else
210 ac_add_options --disable-gnomevfs
211 %endif
212 %if %{with ldap}
213 ac_add_options --enable-ldap
214 %else
215 ac_add_options --disable-ldap
216 %endif
217 ac_add_options --disable-crashreporter
218 ac_add_options --disable-xterm-updates
219 ac_add_options --enable-postscript
220 %if %{with lightning}
221 ac_add_options --enable-calendar
222 %else
223 ac_add_options --disable-calendar
224 %endif
225 ac_add_options --disable-installer
226 ac_add_options --disable-jsd
227 ac_add_options --disable-updater
228 ac_add_options --disable-xprint
229 ac_add_options --disable-permissions
230 ac_add_options --disable-pref-extensions
231 ac_add_options --enable-canvas
232 ac_add_options --enable-crypto
233 ac_add_options --enable-mathml
234 ac_add_options --enable-pango
235 ac_add_options --enable-reorder
236 ac_add_options --enable-static
237 ac_add_options --enable-startup-notification
238 ac_add_options --enable-svg
239 ac_add_options --enable-system-cairo
240 ac_add_options --enable-system-hunspell
241 ac_add_options --enable-xft
242 ac_add_options --enable-application=mail
243 ac_add_options --enable-default-toolkit=cairo-gtk2
244 ac_add_options --enable-xinerama
245 ac_add_options --with-distribution-id=org.pld-linux
246 ac_add_options --with-branding=icedove/branding
247 %if %{with xulrunner}
248 ac_add_options --with-libxul-sdk=%{_libdir}/xulrunner-sdk
249 %endif
250 ac_add_options --with-pthreads
251 ac_add_options --with-system-bz2
252 ac_add_options --with-system-jpeg
253 ac_add_options --with-system-nspr
254 ac_add_options --with-system-nss
255 ac_add_options --with-system-png
256 ac_add_options --with-system-zlib
257 ac_add_options --enable-single-profile
258 ac_add_options --disable-profilesharing
259 ac_add_options --with-default-mozilla-five-home=%{_libdir}/%{name}
260 EOF
261
262 %{__make} -j1 -f client.mk build \
263         STRIP="/bin/true" \
264         CC="%{__cc}" \
265         CXX="%{__cxx}"
266
267 %if %{with enigmail}
268 cd mailnews/extensions/enigmail
269 ./makemake -r
270 %{__make} -C ../../../obj-%{_target_cpu}/mailnews/extensions/enigmail \
271         STRIP="/bin/true" \
272         CC="%{__cc}" \
273         CXX="%{__cxx}"
274 %endif
275
276 %install
277 rm -rf $RPM_BUILD_ROOT
278 install -d $RPM_BUILD_ROOT{%{_bindir},%{_libdir},%{_pixmapsdir},%{_desktopdir}} \
279                $RPM_BUILD_ROOT%{_datadir}/%{name}
280 install -d $RPM_BUILD_ROOT%{_libdir}/%{name}
281
282 cd mozilla
283 %{__make} -C obj-%{_target_cpu}/mail/installer stage-package \
284         DESTDIR=$RPM_BUILD_ROOT \
285         MOZ_PKG_APPDIR=%{_libdir}/%{name} \
286         PKG_SKIP_STRIP=1
287
288 # move arch independant ones to datadir
289 mv $RPM_BUILD_ROOT%{_libdir}/%{name}/chrome $RPM_BUILD_ROOT%{_datadir}/%{name}/chrome
290 mv $RPM_BUILD_ROOT%{_libdir}/%{name}/defaults $RPM_BUILD_ROOT%{_datadir}/%{name}/defaults
291 mv $RPM_BUILD_ROOT%{_libdir}/%{name}/greprefs $RPM_BUILD_ROOT%{_datadir}/%{name}/greprefs
292 mv $RPM_BUILD_ROOT%{_libdir}/%{name}/isp $RPM_BUILD_ROOT%{_datadir}/%{name}/isp
293 mv $RPM_BUILD_ROOT%{_libdir}/%{name}/res $RPM_BUILD_ROOT%{_datadir}/%{name}/res
294 ln -s ../../share/%{name}/chrome $RPM_BUILD_ROOT%{_libdir}/%{name}/chrome
295 ln -s ../../share/%{name}/defaults $RPM_BUILD_ROOT%{_libdir}/%{name}/defaults
296 ln -s ../../share/%{name}/greprefs $RPM_BUILD_ROOT%{_libdir}/%{name}/greprefs
297 ln -s ../../share/%{name}/isp $RPM_BUILD_ROOT%{_libdir}/%{name}/isp
298 ln -s ../../share/%{name}/res $RPM_BUILD_ROOT%{_libdir}/%{name}/res
299
300 rm -rf $RPM_BUILD_ROOT%{_libdir}/%{name}/dictionaries
301 ln -s %{_datadir}/myspell $RPM_BUILD_ROOT%{_libdir}/%{name}/dictionaries
302
303 %{__sed} -e 's,@LIBDIR@,%{_libdir},' %{SOURCE5} > $RPM_BUILD_ROOT%{_bindir}/icedove
304 ln -s %{name} $RPM_BUILD_ROOT%{_bindir}/thunderbird
305 ln -s %{name} $RPM_BUILD_ROOT%{_bindir}/mozilla-thunderbird
306
307 install %{SOURCE4} $RPM_BUILD_ROOT%{_desktopdir}/%{name}.desktop
308
309 %if %{with enigmail}
310 _enig_dir=$RPM_BUILD_ROOT%{_libdir}/%{name}/extensions/\{847b3a00-7ab1-11d4-8f02-006008948af5\}
311 install -d $_enig_dir/chrome
312 install -d $_enig_dir/components
313 install -d $_enig_dir/defaults/preferences
314 mv -f $RPM_BUILD_ROOT%{_libdir}/%{name}/chrome/enigmail.jar $_enig_dir/chrome
315 mv -f $RPM_BUILD_ROOT%{_libdir}/%{name}/components/enig* $_enig_dir/components
316 mv -f $RPM_BUILD_ROOT%{_libdir}/%{name}/components/libenigmime.so $_enig_dir/components
317 mv -f $RPM_BUILD_ROOT%{_libdir}/%{name}/components/ipc.xpt $_enig_dir/components
318 mv -f $RPM_BUILD_ROOT%{_libdir}/%{name}/defaults/preferences/enigmail.js $_enig_dir/defaults/preferences
319 cp -f mailnews/extensions/enigmail/package/install.rdf $_enig_dir
320 rm -rf $RPM_BUILD_ROOT%{_libdir}/%{name}/defaults/preferences
321 rm -f $RPM_BUILD_ROOT%{_libdir}/%{name}/chrome/enigmail-en-US.jar
322 rm -f $RPM_BUILD_ROOT%{_libdir}/%{name}/chrome/enigmail-skin.jar
323 rm -f $RPM_BUILD_ROOT%{_libdir}/%{name}/chrome/enigmime.jar
324 rm -rf $RPM_BUILD_ROOT%{_libdir}/%{name}/components/enig*
325 rm -f $RPM_BUILD_ROOT%{_libdir}/%{name}/components/libenigmime.so
326 rm -f $RPM_BUILD_ROOT%{_libdir}/%{name}/components/ipc.xpt
327 cp -f %{SOURCE6} $_enig_dir/chrome.manifest
328 cp -f icedove/branding/content/icon64.png $RPM_BUILD_ROOT%{_pixmapsdir}/icedove.png
329 %endif
330
331 # win32 stuff
332 rm -f $RPM_BUILD_ROOT%{_libdir}/%{name}/dirver
333
334 %clean
335 rm -rf $RPM_BUILD_ROOT
336
337 %pretrans
338 if [ -d %{_libdir}/%{name}/dictionaries ] && [ ! -L %{_libdir}/%{name}/dictionaries ]; then
339         mv -v %{_libdir}/%{name}/dictionaries{,.rpmsave}
340 fi
341 for d in chrome defaults greprefs icons isp res; do
342         if [ -d %{_libdir}/%{name}/$d ] && [ ! -L %{_libdir}/%{name}/$d ]; then
343                 install -d %{_datadir}/%{name}
344                 mv %{_libdir}/%{name}/$d %{_datadir}/%{name}/$d
345         fi
346 done
347 exit 0
348
349 %files
350 %defattr(644,root,root,755)
351 %attr(755,root,root) %{_bindir}/icedove
352 %attr(755,root,root) %{_bindir}/mozilla-thunderbird
353 %attr(755,root,root) %{_bindir}/thunderbird
354 %dir %{_libdir}/%{name}
355 %{_libdir}/%{name}/*.ini
356 %dir %{_libdir}/%{name}/components
357 %attr(755,root,root) %{_libdir}/%{name}/components/*.so
358 %{_libdir}/%{name}/components/*.js
359 %{_libdir}/%{name}/components/*.xpt
360 %attr(755,root,root) %{_libdir}/%{name}/*.so
361 %attr(755,root,root) %{_libdir}/%{name}/*.sh
362 %attr(755,root,root) %{_libdir}/%{name}/*-bin
363 %attr(755,root,root) %{_libdir}/%{name}/mozilla-xremote-client
364 %attr(755,root,root) %{_libdir}/%{name}/icedove
365
366 # symlinks
367 %{_libdir}/%{name}/chrome
368 %{_libdir}/%{name}/defaults
369 %{_libdir}/%{name}/dictionaries
370 %{_libdir}/%{name}/greprefs
371 %{_libdir}/%{name}/isp
372 %{_libdir}/%{name}/res
373
374 %{_libdir}/%{name}/dependentlibs.list
375 %{_pixmapsdir}/*.png
376 %{_desktopdir}/*.desktop
377
378 %dir %{_datadir}/%{name}
379 %{_datadir}/%{name}/chrome
380 %{_datadir}/%{name}/defaults
381 %{_datadir}/%{name}/greprefs
382 %{_datadir}/%{name}/isp
383 %{_datadir}/%{name}/res
384
385 %dir %{_libdir}/%{name}/modules
386 %{_libdir}/%{name}/modules/*.js*
387 %dir %{_libdir}/%{name}/modules/activity
388 %{_libdir}/%{name}/modules/activity/*.js
389 %dir %{_libdir}/%{name}/modules/gloda
390 %{_libdir}/%{name}/modules/gloda/*.js
391
392 %dir %{_libdir}/%{name}/extensions
393 %{_libdir}/%{name}/extensions/{972ce4c6-7e08-4474-a285-3208198ce6fd}
394
395 %if %{with lightning}
396 %files addon-lightning
397 %defattr(644,root,root,755)
398 %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}
399 %{_libdir}/%{name}/extensions/calendar-timezones@mozilla.org
400 %endif
401
402 %if %{with enigmail}
403 %files addon-enigmail
404 %defattr(644,root,root,755)
405 %{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}
406 %endif
This page took 0.09439 seconds and 4 git commands to generate.