]> git.pld-linux.org Git - packages/thunderbird.git/blob - icedove.spec
- added gyp-slashism patch (try to eliminate double slashes) to fix debuginfo problem
[packages/thunderbird.git] / icedove.spec
1 # TODO:
2 # - separate spec for enigmail
3 # - build with system mozldap
4 #
5 # Conditional builds
6 %bcond_without  enigmail        # don't build enigmail - GPG/PGP support
7 %bcond_without  gnomeui         # disable gnomeui support
8 %bcond_without  gnome           # alias for gnomeui
9 %bcond_without  ldap            # disable e-mail address lookups in LDAP directories
10 %bcond_without  lightning       # disable Sunbird/Lightning calendar
11 %bcond_with     xulrunner       # system xulrunner
12 %bcond_with     crashreporter   # report crashes to crash-stats.mozilla.com
13
14 %if %{without gnome}
15 %undefine       with_gnomeui
16 %endif
17
18 %if 0%{?_enable_debug_packages} != 1
19 %undefine       crashreporter
20 %endif
21
22 %define         enigmail_ver    1.5.0
23 %define         nspr_ver        4.9.3
24 %define         nss_ver         3.14.1
25
26 %define         xulrunner_ver   2:17.0
27
28 %if %{without xulrunner}
29 # The actual sqlite version (see RHBZ#480989):
30 %define         sqlite_build_version %(pkg-config --silence-errors --modversion sqlite3 2>/dev/null || echo ERROR)
31 %endif
32
33 Summary:        Icedove - email client
34 Summary(pl.UTF-8):      Icedove - klient poczty
35 Name:           icedove
36 Version:        17.0.2
37 Release:        2
38 License:        MPL 1.1 or GPL v2+ or LGPL v2.1+
39 Group:          X11/Applications/Networking
40 Source0:        http://releases.mozilla.org/pub/mozilla.org/thunderbird/releases/%{version}/source/thunderbird-%{version}.source.tar.bz2
41 # Source0-md5:  9b7f15fbc672745571d47a3c0e227ca1
42 Source1:        http://www.mozilla-enigmail.org/download/source/enigmail-%{enigmail_ver}.tar.gz
43 # Source1-md5:  af4b3534417f32dc201765e4de6ecc86
44 Source2:        %{name}-branding.tar.bz2
45 # Source2-md5:  2da351522bdd7f4a3bd8aaff4c776976
46 Source3:        %{name}-rm_nonfree.sh
47 Source4:        %{name}.desktop
48 Source5:        %{name}.sh
49 Patch0:         %{name}-branding.patch
50 Patch1:         %{name}-enigmail-shared.patch
51 Patch2:         %{name}-system-xulrunner.patch
52 Patch3:         %{name}-fonts.patch
53 Patch4:         %{name}-install.patch
54 Patch5:         %{name}-hunspell.patch
55 Patch6:         %{name}-prefs.patch
56 Patch7:         system-mozldap.patch
57 Patch8:         %{name}-makefile.patch
58 Patch9:         system-cairo.patch
59 Patch10:        %{name}-extensiondir.patch
60 Patch11:        crashreporter.patch
61 Patch12:        no-subshell.patch
62 # Edit patch below and restore --system-site-packages when system virtualenv gets 1.7 upgrade
63 Patch13:        system-virtualenv.patch
64 Patch14:        gyp-slashism.patch
65 URL:            http://www.pld-linux.org/Packages/Icedove
66 BuildRequires:  GConf2-devel >= 1.2.1
67 BuildRequires:  alsa-lib-devel
68 BuildRequires:  automake
69 BuildRequires:  bzip2-devel
70 BuildRequires:  cairo-devel >= 1.10
71 BuildRequires:  dbus-glib-devel >= 0.60
72 BuildRequires:  freetype-devel >= 1:2.1.8
73 BuildRequires:  glib2-devel >= 2.0
74 BuildRequires:  gtk+2-devel >= 2:2.10.0
75 BuildRequires:  hunspell-devel
76 BuildRequires:  libIDL-devel >= 0.8.0
77 %{?with_gnomeui:BuildRequires:  libgnome-devel >= 2.0}
78 %{?with_gnomeui:BuildRequires:  libgnome-keyring-devel}
79 %{?with_gnomeui:BuildRequires:  libgnomeui-devel >= 2.2.0}
80 BuildRequires:  libiw-devel
81 BuildRequires:  libjpeg-devel >= 6b
82 BuildRequires:  libnotify-devel >= 0.4
83 BuildRequires:  libpng-devel >= 1.4.1
84 BuildRequires:  libstdc++-devel
85 BuildRequires:  nspr-devel >= 1:%{nspr_ver}
86 BuildRequires:  nss-devel >= 1:%{nss_ver}
87 BuildRequires:  pango-devel >= 1:1.14.0
88 BuildRequires:  perl-base >= 1:5.6
89 BuildRequires:  pkgconfig
90 BuildRequires:  python >= 1:2.5
91 BuildRequires:  sed >= 4.0
92 BuildRequires:  sqlite3-devel >= 3.7.4
93 BuildRequires:  startup-notification-devel >= 0.8
94 BuildRequires:  xorg-lib-libXext-devel
95 BuildRequires:  xorg-lib-libXinerama-devel
96 BuildRequires:  xorg-lib-libXt-devel
97 BuildRequires:  yasm
98 BuildRequires:  zip
99 %if %{with xulrunner}
100 BuildRequires:  xulrunner-devel >= %{xulrunner_ver}
101 %else
102 Requires:       myspell-common
103 Requires:       nspr >= 1:%{nspr_ver}
104 Requires:       nss >= 1:%{nss_ver}
105 Requires:       sqlite3 >= %{sqlite_build_version}
106 %endif
107 Requires(post): mktemp >= 1.5-18
108 %if %{with xulrunner}
109 %requires_eq_to xulrunner xulrunner-devel
110 %endif
111 Obsoletes:      mozilla-thunderbird
112 Obsoletes:      mozilla-thunderbird-dictionary-en-US
113 Conflicts:      icedove-lang-resources < %{version}
114 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
115
116 %define         filterout_cpp           -D_FORTIFY_SOURCE=[0-9]+
117
118 # iceweasel/icedove/iceape provide their own versions
119 %define         _noautoprovfiles        %{_libdir}/%{name}/components
120 %if %{without xulrunner}
121 # we don't want these to satisfy packages depending on xulrunner
122 %define         _noautoprov             libmozalloc.so libxpcom.so libxul.so
123 # and as we don't provide them, don't require either
124 %define         _noautoreq              libmozalloc.so libxpcom.so libxul.so
125 %endif
126
127 %define         topdir          %{_builddir}/%{name}-%{version}
128 %define         objdir          %{topdir}/obj-%{_target_cpu}
129
130 %description
131 Icedove is an open-source, fast and portable email client.
132
133 %description -l pl.UTF-8
134 Icedove jest mającym otwarte źródła, szybkim i przenośnym klientem
135 poczty.
136
137 %package addon-lightning
138 Summary:        An integrated calendar for Icedove
139 Summary(pl.UTF-8):      Zintegrowany kalendarz dla Icedove
140 License:        MPL 1.1 or GPL v2+ or LGPL v2.1+
141 Group:          Applications/Networking
142 Requires:       %{name} = %{version}-%{release}
143
144 %description addon-lightning
145 Lightning is an calendar extension to Icedove email client.
146
147 %description addon-lightning -l pl.UTF-8
148 Lightning to rozszerzenie do klienta poczty Icedove dodające
149 funkcjonalność kalendarza.
150
151 %package addon-enigmail
152 Summary:        Extension for the authentication and encryption features provided by GnuPG
153 Summary(pl.UTF-8):      Rozszerzenie do uwierzytelniania i szyfrowania zapewnianego przez GnuPG
154 License:        MPL/LGPL
155 Group:          Applications/Networking
156 URL:            http://enigmail.mozdev.org/
157 Requires:       %{name} = %{version}-%{release}
158 Requires:       gnupg
159 Obsoletes:      mozilla-thunderbird-addon-enigmail
160
161 %description addon-enigmail
162 Enigmail is an extension to the Icedove mail client which allows users
163 to access the authentication and encryption features provided by
164 GnuPG.
165
166 Main Features:
167 - Encrypt/sign mail when sending, decrypt/authenticate received mail
168 - Support for inline-PGP (RFC 2440) and PGP/MIME (RFC 3156)
169 - Per-Account based encryption and signing defaults
170 - Per-Recipient rules for automated key selection, and
171   enabling/disabling encryption and signing
172 - OpenPGP key management interface
173
174 %description addon-enigmail -l pl.UTF-8
175 Enigmail to rozszerzenie klienta pocztowego Icedove pozwalające
176 użytkownikom na dostęp do uwierzytelniania i szyfrowania zapewnianego
177 przez GnuPG.
178
179 Główne możliwości:
180 - szyfrowanie/podpisywanie poczty przy wysyłaniu,
181   odszyfrowywanie/uwierzytelnianie poczty odebranej
182 - obsługa inline-PGP (RFC 2440) i PGP/MIME (RFC 3156)
183 - ustawienia domyślne szyfrowania i podpisywania dla każdego konta
184 - reguły automatycznego wyboru kluczy i włączenia szyfrowania oraz
185   podpisywania dla każdego adresata
186 - interfejs do zarządzania kluczami OpenPGP
187
188 %prep
189 %setup -qc
190 mv comm-release mozilla
191 %setup -q -T -D -a2
192 cd mozilla
193 %{?with_enigmail:%{__gzip} -dc %{SOURCE1} | %{__tar} -xf - -C mailnews/extensions}
194 /bin/sh %{SOURCE3}
195 %patch0 -p1
196 %{?with_enigmail:%patch1 -p1}
197 %{?with_xulrunner:%patch2 -p1}
198 %patch3 -p1
199 %patch4 -p1
200 %patch6 -p1
201 %patch7 -p1
202 %patch8 -p2
203 %patch9 -p1
204 %patch10 -p2
205 %patch11 -p2
206 %patch12 -p1
207 %patch13 -p1
208 %patch14 -p1
209
210 %build
211 cd mozilla
212 cp -f %{_datadir}/automake/config.* mozilla/build/autoconf
213 cp -f %{_datadir}/automake/config.* mozilla/nsprpub/build/autoconf
214 cp -f %{_datadir}/automake/config.* ldap/sdks/c-sdk/config/autoconf
215
216 cat << EOF > .mozconfig
217 mk_add_options MOZ_OBJDIR=%{objdir}
218
219 export CFLAGS="%{rpmcflags}"
220 export CXXFLAGS="%{rpmcflags}"
221
222 %if %{with crashreporter}
223 export MOZ_DEBUG_SYMBOLS=1
224 %endif
225
226 # Options for 'configure' (same as command-line options).
227 ac_add_options --prefix=%{_prefix}
228 ac_add_options --exec-prefix=%{_exec_prefix}
229 ac_add_options --bindir=%{_bindir}
230 ac_add_options --sbindir=%{_sbindir}
231 ac_add_options --sysconfdir=%{_sysconfdir}
232 ac_add_options --datadir=%{_datadir}
233 ac_add_options --includedir=%{_includedir}
234 ac_add_options --libdir=%{_libdir}
235 ac_add_options --libexecdir=%{_libexecdir}
236 ac_add_options --localstatedir=%{_localstatedir}
237 ac_add_options --sharedstatedir=%{_sharedstatedir}
238 ac_add_options --mandir=%{_mandir}
239 ac_add_options --infodir=%{_infodir}
240 %if %{?debug:1}0
241 ac_add_options --disable-optimize
242 ac_add_options --enable-debug
243 ac_add_options --enable-debug-modules
244 ac_add_options --enable-debugger-info-modules
245 ac_add_options --enable-crash-on-assert
246 %else
247 ac_add_options --disable-debug
248 ac_add_options --disable-debug-modules
249 ac_add_options --disable-logging
250 ac_add_options --enable-optimize="%{rpmcflags} -Os"
251 %endif
252 ac_add_options --disable-strip
253 ac_add_options --disable-strip-libs
254 %if %{with tests}
255 ac_add_options --enable-tests
256 %else
257 ac_add_options --disable-tests
258 %endif
259 ac_add_options --enable-gio
260 %if %{with gnomeui}
261 ac_add_options --enable-gnomeui
262 %else
263 ac_add_options --disable-gnomeui
264 %endif
265 ac_add_options --disable-gnomevfs
266 %if %{with ldap}
267 ac_add_options --enable-ldap
268 ac_add_options --with-system-ldap
269 %else
270 ac_add_options --disable-ldap
271 %endif
272 %if %{with crashreporter}
273 ac_add_options --enable-crashreporter
274 %else
275 ac_add_options --disable-crashreporter
276 %endif
277 ac_add_options --disable-xterm-updates
278 ac_add_options --enable-postscript
279 %if %{with lightning}
280 ac_add_options --enable-calendar
281 %else
282 ac_add_options --disable-calendar
283 %endif
284 ac_add_options --disable-installer
285 ac_add_options --disable-updater
286 ac_add_options --disable-xprint
287 ac_add_options --disable-permissions
288 ac_add_options --disable-pref-extensions
289 ac_add_options --enable-canvas
290 ac_add_options --enable-crypto
291 ac_add_options --enable-mathml
292 ac_add_options --enable-pango
293 ac_add_options --enable-reorder
294 ac_add_options --enable-startup-notification
295 ac_add_options --enable-svg
296 ac_add_options --enable-system-cairo
297 ac_add_options --enable-system-hunspell
298 ac_add_options --enable-system-sqlite
299 ac_add_options --enable-xft
300 ac_add_options --enable-application=mail
301 ac_add_options --enable-default-toolkit=cairo-gtk2
302 ac_add_options --enable-xinerama
303 ac_add_options --with-distribution-id=org.pld-linux
304 ac_add_options --with-branding=icedove/branding
305 %if %{with xulrunner}
306 ac_add_options --enable-shared-js
307 ac_add_options --with-libxul-sdk=$(pkg-config --variable=sdkdir libxul)
308 ac_add_options --with-system-libxul
309 %endif
310 ac_add_options --with-pthreads
311 ac_add_options --with-system-bz2
312 ac_add_options --with-system-jpeg
313 ac_add_options --with-system-nspr
314 ac_add_options --with-system-nss
315 ac_add_options --with-system-png
316 ac_add_options --with-system-zlib
317 ac_add_options --enable-single-profile
318 ac_add_options --disable-profilesharing
319 ac_add_options --with-default-mozilla-five-home=%{_libdir}/%{name}
320 EOF
321
322 %{__make} -j1 -f client.mk build \
323         STRIP="/bin/true" \
324         MOZ_MAKE_FLAGS="%{?_smp_mflags}" \
325         XLIBS="-lX11 -lXt" \
326         CC="%{__cc}" \
327         CXX="%{__cxx}"
328
329 %if %{with crashreporter}
330 # create debuginfo for crash-stats.mozilla.com
331 %{__make} -j1 -C obj-%{_target_cpu} buildsymbols
332 %endif
333
334 %if %{with enigmail}
335 cd mailnews/extensions/enigmail
336 ./makemake -r -o %{objdir}
337 %{__make} -C %{objdir}/mailnews/extensions/enigmail \
338         STRIP="/bin/true" \
339         CC="%{__cc}" \
340         CXX="%{__cxx}"
341
342 %{__make} -C %{objdir}/mailnews/extensions/enigmail xpi \
343         STRIP="/bin/true" \
344         CC="%{__cc}" \
345         CXX="%{__cxx}"
346 %endif
347
348 %install
349 rm -rf $RPM_BUILD_ROOT
350 install -d $RPM_BUILD_ROOT{%{_bindir},%{_libdir}/%{name},%{_datadir}/%{name},%{_pixmapsdir},%{_desktopdir}}
351
352 cd %{objdir}
353 %{__make} -C mail/installer stage-package \
354         DESTDIR=$RPM_BUILD_ROOT \
355         MOZ_PKG_DIR=%{_libdir}/%{name} \
356         PKG_SKIP_STRIP=1
357
358 %if %{with xulrunner}
359 # needed to find mozilla runtime
360 ln -s ../xulrunner $RPM_BUILD_ROOT%{_libdir}/%{name}/xulrunner
361 %endif
362  
363 # Enable crash reporter for Thunderbird application
364 %if %{with crashreporter}
365 %{__sed} -i -e 's/\[Crash Reporter\]/[Crash Reporter]\nEnabled=1/' $RPM_BUILD_ROOT%{_libdir}/%{name}/application.ini
366
367 # Add debuginfo for crash-stats.mozilla.com
368 install -d $RPM_BUILD_ROOT%{_exec_prefix}/lib/debug%{_libdir}/%{name}
369 cp -a mozilla/dist/%{name}-%{version}.en-US.linux-*.crashreporter-symbols.zip $RPM_BUILD_ROOT%{_prefix}/lib/debug%{_libdir}/%{name}
370 %endif
371
372 # copy manually lightning files, somewhy they are not installed by make
373 cp -a mozilla/dist/bin/extensions/calendar-timezones@mozilla.org \
374         mozilla/dist/bin/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103} \
375         $RPM_BUILD_ROOT%{_libdir}/%{name}/extensions
376
377 # move arch independant ones to datadir
378 mv $RPM_BUILD_ROOT%{_libdir}/%{name}/chrome $RPM_BUILD_ROOT%{_datadir}/%{name}/chrome
379 mv $RPM_BUILD_ROOT%{_libdir}/%{name}/defaults $RPM_BUILD_ROOT%{_datadir}/%{name}/defaults
380 mv $RPM_BUILD_ROOT%{_libdir}/%{name}/isp $RPM_BUILD_ROOT%{_datadir}/%{name}/isp
381 mv $RPM_BUILD_ROOT%{_libdir}/%{name}/modules $RPM_BUILD_ROOT%{_datadir}/%{name}/modules
382 mv $RPM_BUILD_ROOT%{_libdir}/%{name}/searchplugins $RPM_BUILD_ROOT%{_datadir}/%{name}/searchplugins
383 ln -s ../../share/%{name}/chrome $RPM_BUILD_ROOT%{_libdir}/%{name}/chrome
384 ln -s ../../share/%{name}/defaults $RPM_BUILD_ROOT%{_libdir}/%{name}/defaults
385 ln -s ../../share/%{name}/isp $RPM_BUILD_ROOT%{_libdir}/%{name}/isp
386 ln -s ../../share/%{name}/modules $RPM_BUILD_ROOT%{_libdir}/%{name}/modules
387 ln -s ../../share/%{name}/searchplugins $RPM_BUILD_ROOT%{_libdir}/%{name}/searchplugins
388 %if %{without xulrunner}
389 mv $RPM_BUILD_ROOT%{_libdir}/%{name}/res $RPM_BUILD_ROOT%{_datadir}/%{name}/res
390 ln -s ../../share/%{name}/res $RPM_BUILD_ROOT%{_libdir}/%{name}/res
391 %endif
392
393 # dir for arch independant extensions besides arch dependant extensions
394 # see mozilla/xpcom/build/nsXULAppAPI.h
395 # XRE_SYS_LOCAL_EXTENSION_PARENT_DIR and XRE_SYS_SHARE_EXTENSION_PARENT_DIR
396 install -d $RPM_BUILD_ROOT%{_datadir}/%{name}/extensions
397
398 %if %{without xulrunner}
399 %{__rm} -r $RPM_BUILD_ROOT%{_libdir}/%{name}/dictionaries
400 ln -s %{_datadir}/myspell $RPM_BUILD_ROOT%{_libdir}/%{name}/dictionaries
401 %{__rm} -r $RPM_BUILD_ROOT%{_libdir}/%{name}/hyphenation
402 ln -s %{_datadir}/myspell $RPM_BUILD_ROOT%{_libdir}/%{name}/hyphenation
403 %endif
404
405 %{__sed} -e "s|%MOZAPPDIR%|%{_libdir}/%{name}|" \
406          -e "s|%MOZ_APP_DISPLAYNAME%|Icedove|" \
407         %{topdir}/mozilla/mozilla/build/unix/mozilla.in > $RPM_BUILD_ROOT%{_libdir}/%{name}/icedove
408
409 %{__sed} -e 's,@LIBDIR@,%{_libdir},' %{SOURCE5} > $RPM_BUILD_ROOT%{_bindir}/icedove
410 ln -s %{name} $RPM_BUILD_ROOT%{_bindir}/thunderbird
411 ln -s %{name} $RPM_BUILD_ROOT%{_bindir}/mozilla-thunderbird
412
413 cp -p %{SOURCE4} $RPM_BUILD_ROOT%{_desktopdir}/%{name}.desktop
414 cp -p %{topdir}/mozilla/icedove/branding/content/icon64.png $RPM_BUILD_ROOT%{_pixmapsdir}/%{name}.png
415
416 # files created by regxpcom -register in post
417 touch $RPM_BUILD_ROOT%{_libdir}/%{name}/components/compreg.dat
418 touch $RPM_BUILD_ROOT%{_libdir}/%{name}/components/xpti.dat
419 cat << 'EOF' > $RPM_BUILD_ROOT%{_libdir}/%{name}/register
420 #!/bin/sh
421 umask 022
422 # make temporary HOME, as it attempts to touch files in $HOME/.mozilla
423 # dangerous if you run this with sudo with keep_env += HOME
424 # also TMPDIR could be pointing to sudo user's homedir so we reset that too.
425 t=$(mktemp -d)
426 %{__rm} -f %{_libdir}/%{name}/components/{compreg,xpti}.dat
427 TMPDIR= TMP= HOME=$t %{_libdir}/%{name}/icedove -register
428 rm -rf $t
429 EOF
430 chmod a+rx $RPM_BUILD_ROOT%{_libdir}/%{name}/register
431
432 %if %{with enigmail}
433 ext_dir=$RPM_BUILD_ROOT%{_libdir}/%{name}/extensions/\{847b3a00-7ab1-11d4-8f02-006008948af5\}
434 install -d $ext_dir/{chrome,components,defaults/preferences,modules}
435 cd mozilla/dist/bin
436 cp -rfLp chrome/enigmail.jar $ext_dir/chrome
437 cp -rfLp components/enig* $ext_dir/components
438 cp -rfLp components/libenigmime.so $ext_dir/components
439 cp -rfLp defaults/preferences/enigmail.js $ext_dir/defaults/preferences
440 cp -rfLp modules/{commonFuncs,enigmailCommon,keyManagement,pipeConsole,subprocess}.jsm $ext_dir/modules
441 cp -rfLp modules/{subprocess_worker_unix,subprocess_worker_win}.js $ext_dir/modules
442 cd -
443 cp -p %{topdir}/mozilla/mailnews/extensions/enigmail/package/install.rdf $ext_dir
444 cp -p %{topdir}/mozilla/mailnews/extensions/enigmail/package/chrome.manifest $ext_dir/chrome.manifest
445 %endif
446
447 # never package these. always remove
448 # nss
449 %{__rm} -f $RPM_BUILD_ROOT%{_libdir}/%{name}/lib{freebl3,nss3,nssckbi,nssdbm3,nssutil3,smime3,softokn3,ssl3}.*
450 # nspr
451 %{__rm} -f $RPM_BUILD_ROOT%{_libdir}/%{name}/lib{nspr4,plc4,plds4}.so
452 # mozldap
453 %{__rm} -f $RPM_BUILD_ROOT%{_libdir}/%{name}/lib{ldap,ldif,prldap,ssldap}60.so
454 # testpilot quiz
455 %{__rm} -f $RPM_BUILD_ROOT%{_libdir}/%{name}/distribution/extensions/tbtestpilot@labs.mozilla.com.xpi
456
457 %clean
458 rm -rf $RPM_BUILD_ROOT
459
460 %pretrans
461 if [ -d %{_libdir}/%{name}/dictionaries ] && [ ! -L %{_libdir}/%{name}/dictionaries ]; then
462         mv -v %{_libdir}/%{name}/dictionaries{,.rpmsave}
463 fi
464 for d in chrome defaults icons isp modules res searchplugins; do
465         if [ -d %{_libdir}/%{name}/$d ] && [ ! -L %{_libdir}/%{name}/$d ]; then
466                 install -d %{_datadir}/%{name}
467                 mv %{_libdir}/%{name}/$d %{_datadir}/%{name}/$d
468         fi
469 done
470 exit 0
471
472 %post
473 %{_libdir}/%{name}/register || :
474
475 %files
476 %defattr(644,root,root,755)
477 %attr(755,root,root) %{_bindir}/icedove
478 %attr(755,root,root) %{_bindir}/mozilla-thunderbird
479 %attr(755,root,root) %{_bindir}/thunderbird
480 %dir %{_libdir}/%{name}
481 %{_libdir}/%{name}/application.ini
482 %{_libdir}/%{name}/blocklist.xml
483 %{_libdir}/%{name}/chrome.manifest
484 %dir %{_libdir}/%{name}/components
485 %{_libdir}/%{name}/components/*.js
486 %{_libdir}/%{name}/components/*.xpt
487 %{_libdir}/%{name}/components/components.manifest
488 %{_libdir}/%{name}/components/interfaces.manifest
489 %attr(755,root,root) %{_libdir}/%{name}/*.sh
490 %attr(755,root,root) %{_libdir}/%{name}/*-bin
491 %attr(755,root,root) %{_libdir}/%{name}/icedove
492 %attr(755,root,root) %{_libdir}/%{name}/register
493 %if %{without xulrunner}
494 %{_libdir}/%{name}/platform.ini
495 %{_libdir}/%{name}/greprefs.js
496 %attr(755,root,root) %{_libdir}/%{name}/components/*.so
497 %attr(755,root,root) %{_libdir}/%{name}/libmozalloc.so
498 %attr(755,root,root) %{_libdir}/%{name}/libxpcom.so
499 %attr(755,root,root) %{_libdir}/%{name}/libxul.so
500 %attr(755,root,root) %{_libdir}/%{name}/mozilla-xremote-client
501 %attr(755,root,root) %{_libdir}/%{name}/plugin-container
502 %endif
503
504 # symlinks
505 %{_libdir}/%{name}/chrome
506 %{_libdir}/%{name}/defaults
507 %{_libdir}/%{name}/isp
508 %{_libdir}/%{name}/modules
509 %{_libdir}/%{name}/searchplugins
510 %if %{with xulrunner}
511 %{_libdir}/%{name}/xulrunner
512 %else
513 %{_libdir}/%{name}/dictionaries
514 %{_libdir}/%{name}/hyphenation
515 %{_libdir}/%{name}/res
516 %endif
517
518 %{_pixmapsdir}/icedove.png
519 %{_desktopdir}/icedove.desktop
520
521 %dir %{_datadir}/%{name}
522 %{_datadir}/%{name}/chrome
523 %{_datadir}/%{name}/defaults
524 %{_datadir}/%{name}/extensions
525 %{_datadir}/%{name}/isp
526 %{_datadir}/%{name}/modules
527 %if %{with enigmail}
528 %exclude %{_datadir}/%{name}/modules/commonFuncs.jsm
529 %exclude %{_datadir}/%{name}/modules/enigmailCommon.jsm
530 %exclude %{_datadir}/%{name}/modules/keyManagement.jsm
531 %exclude %{_datadir}/%{name}/modules/pipeConsole.jsm
532 %exclude %{_datadir}/%{name}/modules/subprocess.jsm
533 %exclude %{_datadir}/%{name}/modules/subprocess_worker_unix.js
534 %exclude %{_datadir}/%{name}/modules/subprocess_worker_win.js
535 %endif
536 %{_datadir}/%{name}/searchplugins
537 %if %{without xulrunner}
538 %{_datadir}/%{name}/res
539 %endif
540
541 %if %{with crashreporter}
542 %attr(755,root,root) %{_libdir}/%{name}/crashreporter
543 %{_libdir}/%{name}/crashreporter.ini
544 %{_libdir}/%{name}/Throbber-small.gif
545 %endif
546
547 %dir %{_libdir}/%{name}/extensions
548 %{_libdir}/%{name}/extensions/{972ce4c6-7e08-4474-a285-3208198ce6fd}
549
550 # files created by regxpcom -register
551 %ghost %{_libdir}/%{name}/components/compreg.dat
552 %ghost %{_libdir}/%{name}/components/xpti.dat
553
554 %if %{with lightning}
555 %files addon-lightning
556 %defattr(644,root,root,755)
557 %dir %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}
558 %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/application.ini
559 %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/chrome
560 %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/chrome.manifest
561 %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/defaults
562 %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/install.rdf
563 %dir %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/components
564 %attr(755,root,root) %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/components/*.so
565 %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/components/*.js
566 %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/components/*.manifest
567 %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/components/*.xpt
568 %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/modules
569 %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/calendar-js
570 %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/timezones.sqlite
571 %{_libdir}/%{name}/extensions/calendar-timezones@mozilla.org
572 %endif
573
574 %if %{with enigmail}
575 %files addon-enigmail
576 %defattr(644,root,root,755)
577 %dir %{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}
578 %{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/defaults
579 %{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/chrome
580 %{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/chrome.manifest
581 %{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/install.rdf
582 %dir %{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/components
583 %attr(755,root,root) %{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/components/*.so
584 %{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/components/*.xpt
585 %{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/components/*.js
586 %dir %{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/modules
587 %{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/modules/*.jsm
588 %{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/modules/*.js
589 %endif
This page took 0.094325 seconds and 4 git commands to generate.