]> git.pld-linux.org Git - packages/thunderbird.git/blob - icedove.spec
- start adjusting files
[packages/thunderbird.git] / icedove.spec
1 # TODO:
2 # - separate spec for enigmail
3 # - fix icedove (building) and installing nss/nspr libs!
4 # - build with system mozldap
5 #
6 # Conditional builds
7 %bcond_without  enigmail        # don't build enigmail - GPG/PGP support
8 %bcond_without  gnomeui         # disable gnomeui support
9 %bcond_without  gnomevfs        # disable GNOME comp. (gconf+libgnome+gnomevfs) and gnomevfs ext.
10 %bcond_without  gnome           # disable all GNOME components (gnome+gnomeui+gnomevfs)
11 %bcond_without  ldap            # disable e-mail address lookups in LDAP directories
12 %bcond_without  lightning       # disable sunbird calendar
13 %bcond_without  xulrunner       # build with xulrunner
14 %bcond_with     crashreporter   # report crashes to crash-stats.mozilla.com
15
16 %if %{without gnome}
17 %undefine       with_gnomeui
18 %undefine       with_gnomevfs
19 %endif
20
21 %if 0%{?_enable_debug_packages} != 1
22 %undefine       crashreporter
23 %endif
24
25 %define         enigmail_ver    1.3.2
26 %define         nspr_ver                4.8.8
27 %define         nss_ver                 3.12.10
28
29 %if %{without xulrunner}
30 # The actual sqlite version (see RHBZ#480989):
31 %define         sqlite_build_version %(pkg-config --silence-errors --modversion sqlite3 2>/dev/null || echo ERROR)
32 %endif
33
34 Summary:        Icedove - email client
35 Summary(pl.UTF-8):      Icedove - klient poczty
36 Name:           icedove
37 Version:        6.0.2
38 Release:        0.1
39 License:        MPL 1.1 or GPL v2+ or LGPL v2.1+
40 Group:          X11/Applications/Networking
41 Source0:        http://releases.mozilla.org/pub/mozilla.org/thunderbird/releases/%{version}/source/thunderbird-%{version}.source.tar.bz2
42 # Source0-md5:  917a667fe21cfd103092dbc23a112192
43 Source1:        http://www.mozilla-enigmail.org/download/source/enigmail-%{enigmail_ver}.tar.gz
44 # Source1-md5:  2318d60320dc6c3db3c34d968bb7d533
45 Source2:        %{name}-branding.tar.bz2
46 # Source2-md5:  2da351522bdd7f4a3bd8aaff4c776976
47 Source3:        %{name}-rm_nonfree.sh
48 Source4:        %{name}.desktop
49 Source5:        %{name}.sh
50 Patch0:         %{name}-branding.patch
51 Patch1:         %{name}-enigmail-shared.patch
52 Patch2:         %{name}-gcc.patch
53 Patch3:         %{name}-fonts.patch
54 Patch4:         %{name}-install.patch
55 Patch5:         %{name}-hunspell.patch
56 Patch6:         %{name}-prefs.patch
57 Patch7:         system-mozldap.patch
58 Patch8:         %{name}-makefile.patch
59 Patch10:        %{name}-extensiondir.patch
60 Patch11:        crashreporter.patch
61 Patch12:        no-subshell.patch
62 URL:            http://www.pld-linux.org/Packages/Icedove
63 %{?with_gnomevfs:BuildRequires: GConf2-devel >= 1.2.1}
64 BuildRequires:  alsa-lib-devel
65 BuildRequires:  automake
66 BuildRequires:  bzip2-devel
67 BuildRequires:  freetype-devel >= 1:2.1.8
68 %{?with_gnomevfs:BuildRequires: gnome-vfs2-devel >= 2.0}
69 BuildRequires:  gtk+2-devel >= 1:2.0.0
70 BuildRequires:  hunspell-devel
71 BuildRequires:  libIDL-devel >= 0.8.0
72 %{?with_gnomevfs:BuildRequires: libgnome-devel >= 2.0}
73 %{?with_gnomeui:BuildRequires:  libgnome-keyring-devel}
74 %{?with_gnomeui:BuildRequires:  libgnomeui-devel >= 2.2.0}
75 BuildRequires:  libiw-devel
76 BuildRequires:  libjpeg-devel >= 6b
77 BuildRequires:  libnotify-devel >= 0.4
78 BuildRequires:  libpng-devel >= 1.2.0
79 BuildRequires:  libstdc++-devel
80 BuildRequires:  nspr-devel >= 1:%{nspr_ver}
81 BuildRequires:  nss-devel >= 1:%{nss_ver}
82 BuildRequires:  pango-devel >= 1:1.1.0
83 BuildRequires:  pkgconfig
84 BuildRequires:  sed >= 4.0
85 BuildRequires:  sqlite3-devel >= 3.7.4
86 BuildRequires:  startup-notification-devel >= 0.8
87 BuildRequires:  xorg-lib-libXext-devel
88 BuildRequires:  xorg-lib-libXinerama-devel
89 BuildRequires:  xorg-lib-libXt-devel
90 BuildRequires:  yasm
91 BuildRequires:  zip
92 Requires(post): mktemp >= 1.5-18
93 %if %{with xulrunner}
94 BuildRequires:  xulrunner-devel
95 %else
96 Requires:       myspell-common
97 Requires:       nspr >= 1:%{nspr_ver}
98 Requires:       nss >= 1:%{nss_ver}
99 Requires:       sqlite3 >= %{sqlite_build_version}
100 %endif
101 Obsoletes:      mozilla-thunderbird
102 Obsoletes:      mozilla-thunderbird-dictionary-en-US
103 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
104
105 %define         filterout_cpp           -D_FORTIFY_SOURCE=[0-9]+
106
107 # iceweasel/icedove/iceape provide their own versions
108 %define         _noautoreqdep           libgfxpsshar.so libgkgfx.so libgtkxtbin.so libjsj.so libxpcom_compat.so libxpistub.so
109 %define         _noautoprovfiles        %{_libdir}/%{name}/components
110 # we don't want these to satisfy xulrunner-devel
111 %define         _noautoprov             libgtkembedmoz.so libmozjs.so libxpcom.so libxul.so libxpcom_core.so
112 # and as we don't provide them, don't require either
113 %define         _noautoreq              libgtkembedmoz.so libmozjs.so libxpcom.so libxul.so libxpcom_core.so
114
115 %define         topdir          %{_builddir}/%{name}-%{version}
116 %define         objdir          %{topdir}/obj-%{_target_cpu}
117
118 %description
119 Icedove is an open-source,fast and portable email client.
120
121 %description -l pl.UTF-8
122 Icedove jest open sourcowym, szybkim i przenośnym klientem poczty.
123
124 %package addon-lightning
125 Summary:        An integrated calendar for Icedove
126 Summary(pl.UTF-8):      Zintegrowany kalendarz dla Icedove
127 License:        MPL 1.1 or GPL v2+ or LGPL v2.1+
128 Group:          Applications/Networking
129 Requires:       %{name} = %{version}-%{release}
130
131 %description addon-lightning
132 Lightning is an calendar extension to Icedove email client.
133
134 %description addon-lightning -l pl.UTF-8
135 Lightning to rozszerzenie do klienta poczty Icedove dodające
136 funkcjonalność kalendarza.
137
138 %package addon-enigmail
139 Summary:        Extension for the authentication and encryption features provided by GnuPG
140 Summary(pl.UTF-8):      Rozszerzenie do uwierzytelniania i szyfrowania zapewnianego przez GnuPG
141 License:        MPL/LGPL
142 Group:          Applications/Networking
143 URL:            http://enigmail.mozdev.org/
144 Requires:       %{name} = %{version}-%{release}
145 Requires:       gnupg
146 Obsoletes:      mozilla-thunderbird-addon-enigmail
147
148 %description addon-enigmail
149 Enigmail is an extension to the Icedove mail client which allows users
150 to access the authentication and encryption features provided by
151 GnuPG.
152
153 Main Features:
154 - Encrypt/sign mail when sending, decrypt/authenticate received mail
155 - Support for inline-PGP (RFC 2440) and PGP/MIME (RFC 3156)
156 - Per-Account based encryption and signing defaults
157 - Per-Recipient rules for automated key selection, and
158   enabling/disabling encryption and signing
159 - OpenPGP key management interface
160
161 %description addon-enigmail -l pl.UTF-8
162 Enigmail to rozszerzenie klienta pocztowego Icedove pozwalające
163 użytkownikom na dostęp do uwierzytelniania i szyfrowania zapewnianego
164 przez GnuPG.
165
166 Główne możliwości:
167 - szyfrowanie/podpisywanie poczty przy wysyłaniu,
168   odszyfrowywanie/uwierzytelnianie poczty odebranej
169 - obsługa inline-PGP (RFC 2440) i PGP/MIME (RFC 3156)
170 - ustawienia domyślne szyfrowania i podpisywania dla każdego konta
171 - reguły automatycznego wyboru kluczy i włączenia szyfrowania oraz
172   podpisywania dla każdego adresata
173 - interfejs do zarządzania kluczami OpenPGP
174
175 %prep
176 %setup -qc
177 mv comm-release mozilla
178 %setup -q -T -D -a2
179 cd mozilla
180 %{?with_enigmail:%{__gzip} -dc %{SOURCE1} | %{__tar} -xf - -C mailnews/extensions}
181 /bin/sh %{SOURCE3}
182 %patch0 -p1
183 %{?with_enigmail:%patch1 -p1}
184 %patch2 -p1
185 %patch3 -p1
186 %patch4 -p1
187 %patch5 -p1
188 %patch6 -p1
189 %patch7 -p1
190 %patch8 -p2
191 %patch10 -p2
192 %patch11 -p2
193 %patch12 -p1
194
195 %build
196 cd mozilla
197 cp -f %{_datadir}/automake/config.* mozilla/build/autoconf
198 cp -f %{_datadir}/automake/config.* mozilla/nsprpub/build/autoconf
199 cp -f %{_datadir}/automake/config.* ldap/sdks/c-sdk/config/autoconf
200
201 install -d libxul-sdk
202 ln -snf %{_libdir}/xulrunner-sdk libxul-sdk/sdk
203
204 cat << EOF > .mozconfig
205 mk_add_options MOZ_OBJDIR=%{objdir}
206
207 export CFLAGS="%{rpmcflags} -fpermissive -I/usr/include/xulrunner"
208 export CXXFLAGS="%{rpmcflags} -fpermissive -I/usr/include/xulrunner"
209
210 %if %{with crashreporter}
211 export MOZ_DEBUG_SYMBOLS=1
212 %endif
213
214 # Options for 'configure' (same as command-line options).
215 ac_add_options --prefix=%{_prefix}
216 ac_add_options --exec-prefix=%{_exec_prefix}
217 ac_add_options --bindir=%{_bindir}
218 ac_add_options --sbindir=%{_sbindir}
219 ac_add_options --sysconfdir=%{_sysconfdir}
220 ac_add_options --datadir=%{_datadir}
221 ac_add_options --includedir=%{_includedir}
222 ac_add_options --libdir=%{_libdir}
223 ac_add_options --libexecdir=%{_libexecdir}
224 ac_add_options --localstatedir=%{_localstatedir}
225 ac_add_options --sharedstatedir=%{_sharedstatedir}
226 ac_add_options --mandir=%{_mandir}
227 ac_add_options --infodir=%{_infodir}
228 %if %{?debug:1}0
229 ac_add_options --disable-optimize
230 ac_add_options --enable-debug
231 ac_add_options --enable-debug-modules
232 ac_add_options --enable-debugger-info-modules
233 ac_add_options --enable-crash-on-assert
234 %else
235 ac_add_options --disable-debug
236 ac_add_options --disable-debug-modules
237 ac_add_options --disable-logging
238 ac_add_options --enable-optimize="%{rpmcflags} -Os"
239 %endif
240 ac_add_options --disable-strip
241 ac_add_options --disable-strip-libs
242 %if %{with tests}
243 ac_add_options --enable-tests
244 %else
245 ac_add_options --disable-tests
246 %endif
247 %if %{with gnomeui}
248 ac_add_options --enable-gnomeui
249 %else
250 ac_add_options --disable-gnomeui
251 %endif
252 %if %{with gnomevfs}
253 ac_add_options --enable-gnomevfs
254 %else
255 ac_add_options --disable-gnomevfs
256 %endif
257 %if %{with ldap}
258 ac_add_options --enable-ldap
259 ac_add_options --with-system-ldap
260 %else
261 ac_add_options --disable-ldap
262 %endif
263 %if %{with crashreporter}
264 ac_add_options --enable-crashreporter
265 %else
266 ac_add_options --disable-crashreporter
267 %endif
268 ac_add_options --disable-xterm-updates
269 ac_add_options --enable-postscript
270 %if %{with lightning}
271 ac_add_options --enable-calendar
272 %else
273 ac_add_options --disable-calendar
274 %endif
275 ac_add_options --disable-installer
276 ac_add_options --disable-jsd
277 ac_add_options --disable-updater
278 ac_add_options --disable-xprint
279 ac_add_options --disable-permissions
280 ac_add_options --disable-pref-extensions
281 ac_add_options --enable-canvas
282 ac_add_options --enable-crypto
283 ac_add_options --enable-mathml
284 ac_add_options --enable-pango
285 ac_add_options --enable-reorder
286 ac_add_options --enable-startup-notification
287 ac_add_options --enable-svg
288 ac_add_options --enable-system-cairo
289 ac_add_options --enable-system-hunspell
290 ac_add_options --enable-system-sqlite
291 ac_add_options --enable-xft
292 ac_add_options --enable-application=mail
293 ac_add_options --enable-default-toolkit=cairo-gtk2
294 ac_add_options --enable-xinerama
295 ac_add_options --with-distribution-id=org.pld-linux
296 ac_add_options --with-branding=icedove/branding
297 %if %{with xulrunner}
298 #ac_add_options --with-libxul-sdk=$(pwd)/libxul-sdk/sdk
299 ac_add_options --with-system-libxul
300 ac_add_options --enable-shared
301 ac_add_options --enable-libxul
302 %else
303 ac_add_options --disable-xul
304 %endif
305 ac_add_options --with-pthreads
306 ac_add_options --with-system-bz2
307 ac_add_options --with-system-jpeg
308 ac_add_options --with-system-nspr
309 ac_add_options --with-system-nss
310 ac_add_options --with-system-png
311 ac_add_options --with-system-zlib
312 ac_add_options --enable-single-profile
313 ac_add_options --disable-profilesharing
314 ac_add_options --with-default-mozilla-five-home=%{_libdir}/%{name}
315 EOF
316
317 %{__make} -j1 -f client.mk build \
318         STRIP="/bin/true" \
319         MOZ_MAKE_FLAGS="%{?_smp_mflags}" \
320         CC="%{__cc}" \
321         CXX="%{__cxx}"
322
323 %if %{with crashreporter}
324 # create debuginfo for crash-stats.mozilla.com
325 %{__make} -j1 -C obj-%{_target_cpu} buildsymbols
326 %endif
327
328 %if %{with enigmail}
329 cd mailnews/extensions/enigmail
330 ./makemake -r -o %{objdir}
331 %{__make} -C %{objdir}/mailnews/extensions/enigmail \
332         STRIP="/bin/true" \
333         CC="%{__cc}" \
334         CXX="%{__cxx}"
335 %endif
336
337 %install
338 rm -rf $RPM_BUILD_ROOT
339 install -d $RPM_BUILD_ROOT{%{_bindir},%{_libdir}/%{name},%{_datadir}/%{name},%{_pixmapsdir},%{_desktopdir}}
340
341 cd %{objdir}
342 %{__make} -C mail/installer stage-package \
343         DESTDIR=$RPM_BUILD_ROOT \
344         MOZ_PKG_DIR=%{_libdir}/%{name} \
345         PKG_SKIP_STRIP=1
346
347 # Enable crash reporter for Firefox application
348 %if %{with crashreporter}
349 %{__sed} -i -e 's/\[Crash Reporter\]/[Crash Reporter]\nEnabled=1/' $RPM_BUILD_ROOT%{_libdir}/%{name}/application.ini
350
351 # Add debuginfo for crash-stats.mozilla.com
352 install -d $RPM_BUILD_ROOT%{_exec_prefix}/lib/debug%{_libdir}/%{name}
353 cp -a mozilla/dist/%{name}-%{version}.en-US.linux-*.crashreporter-symbols.zip $RPM_BUILD_ROOT%{_prefix}/lib/debug%{_libdir}/%{name}
354 %endif
355
356 # copy manually lightning files, somewhy they are not installed by make
357 cp -a mozilla/dist/bin/extensions/calendar-timezones@mozilla.org \
358         mozilla/dist/bin/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103} \
359         $RPM_BUILD_ROOT%{_libdir}/%{name}/extensions
360
361 # move arch independant ones to datadir
362 mv $RPM_BUILD_ROOT%{_libdir}/%{name}/chrome $RPM_BUILD_ROOT%{_datadir}/%{name}/chrome
363 mv $RPM_BUILD_ROOT%{_libdir}/%{name}/defaults $RPM_BUILD_ROOT%{_datadir}/%{name}/defaults
364 #mv $RPM_BUILD_ROOT%{_libdir}/%{name}/greprefs $RPM_BUILD_ROOT%{_datadir}/%{name}/greprefs
365 mv $RPM_BUILD_ROOT%{_libdir}/%{name}/isp $RPM_BUILD_ROOT%{_datadir}/%{name}/isp
366 mv $RPM_BUILD_ROOT%{_libdir}/%{name}/modules $RPM_BUILD_ROOT%{_datadir}/%{name}/modules
367 mv $RPM_BUILD_ROOT%{_libdir}/%{name}/res $RPM_BUILD_ROOT%{_datadir}/%{name}/res
368 ln -s ../../share/%{name}/chrome $RPM_BUILD_ROOT%{_libdir}/%{name}/chrome
369 ln -s ../../share/%{name}/defaults $RPM_BUILD_ROOT%{_libdir}/%{name}/defaults
370 #ln -s ../../share/%{name}/greprefs $RPM_BUILD_ROOT%{_libdir}/%{name}/greprefs
371 ln -s ../../share/%{name}/isp $RPM_BUILD_ROOT%{_libdir}/%{name}/isp
372 ln -s ../../share/%{name}/modules $RPM_BUILD_ROOT%{_libdir}/%{name}/modules
373 ln -s ../../share/%{name}/res $RPM_BUILD_ROOT%{_libdir}/%{name}/res
374
375 # dir for arch independant extensions besides arch dependant extensions
376 # see mozilla/xpcom/build/nsXULAppAPI.h
377 # XRE_SYS_LOCAL_EXTENSION_PARENT_DIR and XRE_SYS_SHARE_EXTENSION_PARENT_DIR
378 install -d $RPM_BUILD_ROOT%{_datadir}/%{name}/extensions
379
380 %{__rm} -r $RPM_BUILD_ROOT%{_libdir}/%{name}/dictionaries
381 ln -s %{_datadir}/myspell $RPM_BUILD_ROOT%{_libdir}/%{name}/dictionaries
382
383 %{__sed} -e 's,@LIBDIR@,%{_libdir},' %{SOURCE5} > $RPM_BUILD_ROOT%{_bindir}/icedove
384 ln -s %{name} $RPM_BUILD_ROOT%{_bindir}/thunderbird
385 ln -s %{name} $RPM_BUILD_ROOT%{_bindir}/mozilla-thunderbird
386
387 cp -p %{SOURCE4} $RPM_BUILD_ROOT%{_desktopdir}/%{name}.desktop
388 cp -p %{topdir}/mozilla/icedove/branding/content/icon64.png $RPM_BUILD_ROOT%{_pixmapsdir}/%{name}.png
389
390 # files created by regxpcom -register in post
391 touch $RPM_BUILD_ROOT%{_libdir}/%{name}/components/compreg.dat
392 touch $RPM_BUILD_ROOT%{_libdir}/%{name}/components/xpti.dat
393 cat << 'EOF' > $RPM_BUILD_ROOT%{_libdir}/%{name}/register
394 #!/bin/sh
395 umask 022
396 # make temporary HOME, as it attempts to touch files in $HOME/.mozilla
397 # dangerous if you run this with sudo with keep_env += HOME
398 # also TMPDIR could be pointing to sudo user's homedir so we reset that too.
399 t=$(mktemp -d)
400 %{__rm} -f %{_libdir}/%{name}/components/{compreg,xpti}.dat
401 TMPDIR= TMP= HOME=$t %{_libdir}/%{name}/icedove -register
402 rm -rf $t
403 EOF
404 chmod a+rx $RPM_BUILD_ROOT%{_libdir}/%{name}/register
405
406 %if %{with enigmail}
407 ext_dir=$RPM_BUILD_ROOT%{_libdir}/%{name}/extensions/\{847b3a00-7ab1-11d4-8f02-006008948af5\}
408 install -d $ext_dir/{chrome,components,defaults/preferences}
409 cd mozilla/dist/bin
410 #cp -rfLp chrome/enigmail.jar $ext_dir/chrome
411 #cp -rfLp chrome/enigmime.jar $ext_dir/chrome
412 cp -rfLp components/enig* $ext_dir/components
413 cp -rfLp components/libenigmime.so $ext_dir/components
414 cp -rfLp components/libipc.so $ext_dir/components
415 cp -rfLp components/ipc.xpt $ext_dir/components
416 cp -rfLp defaults/preferences/enigmail.js $ext_dir/defaults/preferences
417 cd -
418 cp -p %{topdir}/mozilla/mailnews/extensions/enigmail/package/install.rdf $ext_dir
419 cp -p %{topdir}/mozilla/mailnews/extensions/enigmail/package/chrome.manifest $ext_dir/chrome.manifest
420 %endif
421
422 # remove unecessary stuff
423 %{__rm} $RPM_BUILD_ROOT%{_libdir}/%{name}/README.txt
424 #%%{__rm} $RPM_BUILD_ROOT%{_libdir}/%{name}/components/components.list
425 #%%{__rm} $RPM_BUILD_ROOT%{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/components/components.list
426
427 # never package these. always remove
428 # nss
429 %{__rm} -f $RPM_BUILD_ROOT%{_libdir}/%{name}/lib{freebl3,nss3,nssckbi,nssdbm3,nssutil3,smime3,softokn3,ssl3}.*
430 # nspr
431 %{__rm} -f $RPM_BUILD_ROOT%{_libdir}/%{name}/lib{nspr4,plc4,plds4}.so
432 # mozldap
433 %{__rm} -f $RPM_BUILD_ROOT%{_libdir}/%{name}/lib{ldap,ldif,prldap,ssldap}60.so
434
435 %clean
436 rm -rf $RPM_BUILD_ROOT
437
438 %pretrans
439 if [ -d %{_libdir}/%{name}/dictionaries ] && [ ! -L %{_libdir}/%{name}/dictionaries ]; then
440         mv -v %{_libdir}/%{name}/dictionaries{,.rpmsave}
441 fi
442 for d in chrome defaults greprefs icons isp modules res; do
443         if [ -d %{_libdir}/%{name}/$d ] && [ ! -L %{_libdir}/%{name}/$d ]; then
444                 install -d %{_datadir}/%{name}
445                 mv %{_libdir}/%{name}/$d %{_datadir}/%{name}/$d
446         fi
447 done
448 exit 0
449
450 %post
451 %{_libdir}/%{name}/register || :
452
453 %files
454 %defattr(644,root,root,755)
455 %attr(755,root,root) %{_bindir}/icedove
456 %attr(755,root,root) %{_bindir}/mozilla-thunderbird
457 %attr(755,root,root) %{_bindir}/thunderbird
458 %dir %{_libdir}/%{name}
459 %{_libdir}/%{name}/application.ini
460 %{_libdir}/%{name}/platform.ini
461 %dir %{_libdir}/%{name}/components
462 %attr(755,root,root) %{_libdir}/%{name}/components/*.so
463 %{_libdir}/%{name}/components/*.js
464 %{_libdir}/%{name}/components/*.xpt
465 %attr(755,root,root) %{_libdir}/%{name}/libmozalloc.so
466 #%%attr(755,root,root) %{_libdir}/%{name}/libmozjs.so
467 %attr(755,root,root) %{_libdir}/%{name}/libxpcom.so
468 #%%attr(755,root,root) %{_libdir}/%{name}/libxpcom_core.so
469 %attr(755,root,root) %{_libdir}/%{name}/libxul.so
470 %attr(755,root,root) %{_libdir}/%{name}/*.sh
471 %attr(755,root,root) %{_libdir}/%{name}/*-bin
472 %attr(755,root,root) %{_libdir}/%{name}/mozilla-xremote-client
473 %attr(755,root,root) %{_libdir}/%{name}/icedove
474 %attr(755,root,root) %{_libdir}/%{name}/register
475
476 # symlinks
477 %{_libdir}/%{name}/chrome
478 %{_libdir}/%{name}/defaults
479 %{_libdir}/%{name}/dictionaries
480 #%%{_libdir}/%{name}/greprefs
481 %{_libdir}/%{name}/isp
482 %{_libdir}/%{name}/modules
483 %{_libdir}/%{name}/res
484
485 %{_pixmapsdir}/*.png
486 %{_desktopdir}/*.desktop
487
488 %dir %{_datadir}/%{name}
489 %{_datadir}/%{name}/chrome
490 %{_datadir}/%{name}/defaults
491 #%%{_datadir}/%{name}/greprefs
492 %{_datadir}/%{name}/isp
493 %{_datadir}/%{name}/modules
494 %{_datadir}/%{name}/res
495 %{_datadir}/%{name}/extensions
496
497 %if %{with crashreporter}
498 %attr(755,root,root) %{_libdir}/%{name}/crashreporter
499 %{_libdir}/%{name}/crashreporter.ini
500 %{_libdir}/%{name}/Throbber-small.gif
501 %endif
502
503 %dir %{_libdir}/%{name}/extensions
504 %{_libdir}/%{name}/extensions/{972ce4c6-7e08-4474-a285-3208198ce6fd}
505
506 # files created by regxpcom -register
507 %ghost %{_libdir}/%{name}/components/compreg.dat
508 %ghost %{_libdir}/%{name}/components/xpti.dat
509
510 %if %{with lightning}
511 %files addon-lightning
512 %defattr(644,root,root,755)
513 %dir %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}
514 %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/defaults
515 %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/chrome
516 %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/chrome.manifest
517 %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/install.rdf
518 %dir %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/components
519 %attr(755,root,root) %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/components/*.so
520 %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/components/*.xpt
521 %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/components/*.js
522 %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/modules
523 %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/calendar-js
524 %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/timezones.sqlite
525
526 %{_libdir}/%{name}/extensions/calendar-timezones@mozilla.org
527 %endif
528
529 %if %{with enigmail}
530 %files addon-enigmail
531 %defattr(644,root,root,755)
532 %dir %{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}
533 %{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/defaults
534 %{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/chrome
535 %{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/chrome.manifest
536 %{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/install.rdf
537 %dir %{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/components
538 %attr(755,root,root) %{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/components/*.so
539 %{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/components/*.xpt
540 %{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/components/*.js
541 %endif
This page took 0.943991 seconds and 4 git commands to generate.