]> git.pld-linux.org Git - packages/thunderbird.git/blob - icedove.spec
- updated to 17.0, enigmail 1.4.6
[packages/thunderbird.git] / icedove.spec
1 # TODO:
2 # - separate spec for enigmail
3 # - build with system mozldap
4 #
5 # Conditional builds
6 %bcond_without  enigmail        # don't build enigmail - GPG/PGP support
7 %bcond_without  gnomeui         # disable gnomeui support
8 %bcond_without  gnome           # alias for gnomeui
9 %bcond_without  ldap            # disable e-mail address lookups in LDAP directories
10 %bcond_without  lightning       # disable Sunbird/Lightning calendar
11 %bcond_with     xulrunner       # system xulrunner
12 %bcond_with     crashreporter   # report crashes to crash-stats.mozilla.com
13
14 %if %{without gnome}
15 %undefine       with_gnomeui
16 %endif
17
18 %if 0%{?_enable_debug_packages} != 1
19 %undefine       crashreporter
20 %endif
21
22 %define         enigmail_ver    1.4.6
23 %define         nspr_ver        4.9
24 %define         nss_ver         3.13.3
25
26 %define         xulrunner_ver   2:15.0
27
28 %if %{without xulrunner}
29 # The actual sqlite version (see RHBZ#480989):
30 %define         sqlite_build_version %(pkg-config --silence-errors --modversion sqlite3 2>/dev/null || echo ERROR)
31 %endif
32
33 Summary:        Icedove - email client
34 Summary(pl.UTF-8):      Icedove - klient poczty
35 Name:           icedove
36 Version:        17.0
37 Release:        0.1
38 License:        MPL 1.1 or GPL v2+ or LGPL v2.1+
39 Group:          X11/Applications/Networking
40 Source0:        http://releases.mozilla.org/pub/mozilla.org/thunderbird/releases/%{version}/source/thunderbird-%{version}.source.tar.bz2
41 # Source0-md5:  f3690660044337273efb52f79cb15b0e
42 Source1:        http://www.mozilla-enigmail.org/download/source/enigmail-%{enigmail_ver}.tar.gz
43 # Source1-md5:  3d42cff27e0f8da24bdabf8363d8261f
44 Source2:        %{name}-branding.tar.bz2
45 # Source2-md5:  2da351522bdd7f4a3bd8aaff4c776976
46 Source3:        %{name}-rm_nonfree.sh
47 Source4:        %{name}.desktop
48 Source5:        %{name}.sh
49 Patch0:         %{name}-branding.patch
50 Patch1:         %{name}-enigmail-shared.patch
51 Patch2:         %{name}-system-xulrunner.patch
52 Patch3:         %{name}-fonts.patch
53 Patch4:         %{name}-install.patch
54 Patch5:         %{name}-hunspell.patch
55 Patch6:         %{name}-prefs.patch
56 Patch7:         system-mozldap.patch
57 Patch8:         %{name}-makefile.patch
58 Patch9:         system-cairo.patch
59 Patch10:        %{name}-extensiondir.patch
60 Patch11:        crashreporter.patch
61 Patch12:        no-subshell.patch
62 # Edit patch below and restore --system-site-packages when system virtualenv gets 1.7 upgrade
63 Patch13:        system-virtualenv.patch
64 URL:            http://www.pld-linux.org/Packages/Icedove
65 BuildRequires:  GConf2-devel >= 1.2.1
66 BuildRequires:  alsa-lib-devel
67 BuildRequires:  automake
68 BuildRequires:  bzip2-devel
69 BuildRequires:  cairo-devel >= 1.10
70 BuildRequires:  dbus-glib-devel >= 0.60
71 BuildRequires:  freetype-devel >= 1:2.1.8
72 BuildRequires:  glib2-devel >= 2.0
73 BuildRequires:  gtk+2-devel >= 2:2.10.0
74 BuildRequires:  hunspell-devel
75 BuildRequires:  libIDL-devel >= 0.8.0
76 %{?with_gnomeui:BuildRequires:  libgnome-devel >= 2.0}
77 %{?with_gnomeui:BuildRequires:  libgnome-keyring-devel}
78 %{?with_gnomeui:BuildRequires:  libgnomeui-devel >= 2.2.0}
79 BuildRequires:  libiw-devel
80 BuildRequires:  libjpeg-devel >= 6b
81 BuildRequires:  libnotify-devel >= 0.4
82 BuildRequires:  libpng-devel >= 1.4.1
83 BuildRequires:  libstdc++-devel
84 BuildRequires:  nspr-devel >= 1:%{nspr_ver}
85 BuildRequires:  nss-devel >= 1:%{nss_ver}
86 BuildRequires:  pango-devel >= 1:1.14.0
87 BuildRequires:  perl-base >= 1:5.6
88 BuildRequires:  pkgconfig
89 BuildRequires:  python >= 1:2.5
90 BuildRequires:  sed >= 4.0
91 BuildRequires:  sqlite3-devel >= 3.7.4
92 BuildRequires:  startup-notification-devel >= 0.8
93 BuildRequires:  xorg-lib-libXext-devel
94 BuildRequires:  xorg-lib-libXinerama-devel
95 BuildRequires:  xorg-lib-libXt-devel
96 BuildRequires:  yasm
97 BuildRequires:  zip
98 %if %{with xulrunner}
99 BuildRequires:  xulrunner-devel >= %{xulrunner_ver}
100 %else
101 Requires:       myspell-common
102 Requires:       nspr >= 1:%{nspr_ver}
103 Requires:       nss >= 1:%{nss_ver}
104 Requires:       sqlite3 >= %{sqlite_build_version}
105 %endif
106 Requires(post): mktemp >= 1.5-18
107 %if %{with xulrunner}
108 %requires_eq_to xulrunner xulrunner-devel
109 %endif
110 Obsoletes:      mozilla-thunderbird
111 Obsoletes:      mozilla-thunderbird-dictionary-en-US
112 Conflicts:      icedove-lang-resources < %{version}
113 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
114
115 %define         filterout_cpp           -D_FORTIFY_SOURCE=[0-9]+
116
117 # iceweasel/icedove/iceape provide their own versions
118 %define         _noautoprovfiles        %{_libdir}/%{name}/components
119 %if %{without xulrunner}
120 # we don't want these to satisfy packages depending on xulrunner
121 %define         _noautoprov             libmozalloc.so libxpcom.so libxul.so
122 # and as we don't provide them, don't require either
123 %define         _noautoreq              libmozalloc.so libxpcom.so libxul.so
124 %endif
125
126 %define         topdir          %{_builddir}/%{name}-%{version}
127 %define         objdir          %{topdir}/obj-%{_target_cpu}
128
129 %description
130 Icedove is an open-source, fast and portable email client.
131
132 %description -l pl.UTF-8
133 Icedove jest mającym otwarte źródła, szybkim i przenośnym klientem
134 poczty.
135
136 %package addon-lightning
137 Summary:        An integrated calendar for Icedove
138 Summary(pl.UTF-8):      Zintegrowany kalendarz dla Icedove
139 License:        MPL 1.1 or GPL v2+ or LGPL v2.1+
140 Group:          Applications/Networking
141 Requires:       %{name} = %{version}-%{release}
142
143 %description addon-lightning
144 Lightning is an calendar extension to Icedove email client.
145
146 %description addon-lightning -l pl.UTF-8
147 Lightning to rozszerzenie do klienta poczty Icedove dodające
148 funkcjonalność kalendarza.
149
150 %package addon-enigmail
151 Summary:        Extension for the authentication and encryption features provided by GnuPG
152 Summary(pl.UTF-8):      Rozszerzenie do uwierzytelniania i szyfrowania zapewnianego przez GnuPG
153 License:        MPL/LGPL
154 Group:          Applications/Networking
155 URL:            http://enigmail.mozdev.org/
156 Requires:       %{name} = %{version}-%{release}
157 Requires:       gnupg
158 Obsoletes:      mozilla-thunderbird-addon-enigmail
159
160 %description addon-enigmail
161 Enigmail is an extension to the Icedove mail client which allows users
162 to access the authentication and encryption features provided by
163 GnuPG.
164
165 Main Features:
166 - Encrypt/sign mail when sending, decrypt/authenticate received mail
167 - Support for inline-PGP (RFC 2440) and PGP/MIME (RFC 3156)
168 - Per-Account based encryption and signing defaults
169 - Per-Recipient rules for automated key selection, and
170   enabling/disabling encryption and signing
171 - OpenPGP key management interface
172
173 %description addon-enigmail -l pl.UTF-8
174 Enigmail to rozszerzenie klienta pocztowego Icedove pozwalające
175 użytkownikom na dostęp do uwierzytelniania i szyfrowania zapewnianego
176 przez GnuPG.
177
178 Główne możliwości:
179 - szyfrowanie/podpisywanie poczty przy wysyłaniu,
180   odszyfrowywanie/uwierzytelnianie poczty odebranej
181 - obsługa inline-PGP (RFC 2440) i PGP/MIME (RFC 3156)
182 - ustawienia domyślne szyfrowania i podpisywania dla każdego konta
183 - reguły automatycznego wyboru kluczy i włączenia szyfrowania oraz
184   podpisywania dla każdego adresata
185 - interfejs do zarządzania kluczami OpenPGP
186
187 %prep
188 %setup -qc
189 mv comm-release mozilla
190 %setup -q -T -D -a2
191 cd mozilla
192 %{?with_enigmail:%{__gzip} -dc %{SOURCE1} | %{__tar} -xf - -C mailnews/extensions}
193 /bin/sh %{SOURCE3}
194 %patch0 -p1
195 %{?with_enigmail:%patch1 -p1}
196 %{?with_xulrunner:%patch2 -p1}
197 %patch3 -p1
198 %patch4 -p1
199 %patch6 -p1
200 %patch7 -p1
201 %patch8 -p2
202 %patch9 -p1
203 %patch10 -p2
204 %patch11 -p2
205 %patch12 -p1
206 %patch13 -p1
207
208 %build
209 cd mozilla
210 cp -f %{_datadir}/automake/config.* mozilla/build/autoconf
211 cp -f %{_datadir}/automake/config.* mozilla/nsprpub/build/autoconf
212 cp -f %{_datadir}/automake/config.* ldap/sdks/c-sdk/config/autoconf
213
214 cat << EOF > .mozconfig
215 mk_add_options MOZ_OBJDIR=%{objdir}
216
217 export CFLAGS="%{rpmcflags}"
218 export CXXFLAGS="%{rpmcflags}"
219
220 %if %{with crashreporter}
221 export MOZ_DEBUG_SYMBOLS=1
222 %endif
223
224 # Options for 'configure' (same as command-line options).
225 ac_add_options --prefix=%{_prefix}
226 ac_add_options --exec-prefix=%{_exec_prefix}
227 ac_add_options --bindir=%{_bindir}
228 ac_add_options --sbindir=%{_sbindir}
229 ac_add_options --sysconfdir=%{_sysconfdir}
230 ac_add_options --datadir=%{_datadir}
231 ac_add_options --includedir=%{_includedir}
232 ac_add_options --libdir=%{_libdir}
233 ac_add_options --libexecdir=%{_libexecdir}
234 ac_add_options --localstatedir=%{_localstatedir}
235 ac_add_options --sharedstatedir=%{_sharedstatedir}
236 ac_add_options --mandir=%{_mandir}
237 ac_add_options --infodir=%{_infodir}
238 %if %{?debug:1}0
239 ac_add_options --disable-optimize
240 ac_add_options --enable-debug
241 ac_add_options --enable-debug-modules
242 ac_add_options --enable-debugger-info-modules
243 ac_add_options --enable-crash-on-assert
244 %else
245 ac_add_options --disable-debug
246 ac_add_options --disable-debug-modules
247 ac_add_options --disable-logging
248 ac_add_options --enable-optimize="%{rpmcflags} -Os"
249 %endif
250 ac_add_options --disable-strip
251 ac_add_options --disable-strip-libs
252 %if %{with tests}
253 ac_add_options --enable-tests
254 %else
255 ac_add_options --disable-tests
256 %endif
257 ac_add_options --enable-gio
258 %if %{with gnomeui}
259 ac_add_options --enable-gnomeui
260 %else
261 ac_add_options --disable-gnomeui
262 %endif
263 ac_add_options --disable-gnomevfs
264 %if %{with ldap}
265 ac_add_options --enable-ldap
266 ac_add_options --with-system-ldap
267 %else
268 ac_add_options --disable-ldap
269 %endif
270 %if %{with crashreporter}
271 ac_add_options --enable-crashreporter
272 %else
273 ac_add_options --disable-crashreporter
274 %endif
275 ac_add_options --disable-xterm-updates
276 ac_add_options --enable-postscript
277 %if %{with lightning}
278 ac_add_options --enable-calendar
279 %else
280 ac_add_options --disable-calendar
281 %endif
282 ac_add_options --disable-installer
283 ac_add_options --disable-updater
284 ac_add_options --disable-xprint
285 ac_add_options --disable-permissions
286 ac_add_options --disable-pref-extensions
287 ac_add_options --enable-canvas
288 ac_add_options --enable-crypto
289 ac_add_options --enable-mathml
290 ac_add_options --enable-pango
291 ac_add_options --enable-reorder
292 ac_add_options --enable-startup-notification
293 ac_add_options --enable-svg
294 ac_add_options --enable-system-cairo
295 ac_add_options --enable-system-hunspell
296 ac_add_options --enable-system-sqlite
297 ac_add_options --enable-xft
298 ac_add_options --enable-application=mail
299 ac_add_options --enable-default-toolkit=cairo-gtk2
300 ac_add_options --enable-xinerama
301 ac_add_options --with-distribution-id=org.pld-linux
302 ac_add_options --with-branding=icedove/branding
303 %if %{with xulrunner}
304 ac_add_options --enable-shared-js
305 ac_add_options --with-libxul-sdk=$(pkg-config --variable=sdkdir libxul)
306 ac_add_options --with-system-libxul
307 %endif
308 ac_add_options --with-pthreads
309 ac_add_options --with-system-bz2
310 ac_add_options --with-system-jpeg
311 ac_add_options --with-system-nspr
312 ac_add_options --with-system-nss
313 ac_add_options --with-system-png
314 ac_add_options --with-system-zlib
315 ac_add_options --enable-single-profile
316 ac_add_options --disable-profilesharing
317 ac_add_options --with-default-mozilla-five-home=%{_libdir}/%{name}
318 EOF
319
320 %{__make} -j1 -f client.mk build \
321         STRIP="/bin/true" \
322         MOZ_MAKE_FLAGS="%{?_smp_mflags}" \
323         CC="%{__cc}" \
324         CXX="%{__cxx}"
325
326 %if %{with crashreporter}
327 # create debuginfo for crash-stats.mozilla.com
328 %{__make} -j1 -C obj-%{_target_cpu} buildsymbols
329 %endif
330
331 %if %{with enigmail}
332 cd mailnews/extensions/enigmail
333 ./makemake -r -o %{objdir}
334 %{__make} -C %{objdir}/mailnews/extensions/enigmail \
335         STRIP="/bin/true" \
336         CC="%{__cc}" \
337         CXX="%{__cxx}"
338
339 %{__make} -C %{objdir}/mailnews/extensions/enigmail xpi \
340         STRIP="/bin/true" \
341         CC="%{__cc}" \
342         CXX="%{__cxx}"
343 %endif
344
345 %install
346 rm -rf $RPM_BUILD_ROOT
347 install -d $RPM_BUILD_ROOT{%{_bindir},%{_libdir}/%{name},%{_datadir}/%{name},%{_pixmapsdir},%{_desktopdir}}
348
349 cd %{objdir}
350 %{__make} -C mail/installer stage-package \
351         DESTDIR=$RPM_BUILD_ROOT \
352         MOZ_PKG_DIR=%{_libdir}/%{name} \
353         PKG_SKIP_STRIP=1
354
355 %if %{with xulrunner}
356 # needed to find mozilla runtime
357 ln -s ../xulrunner $RPM_BUILD_ROOT%{_libdir}/%{name}/xulrunner
358 %endif
359  
360 # Enable crash reporter for Thunderbird application
361 %if %{with crashreporter}
362 %{__sed} -i -e 's/\[Crash Reporter\]/[Crash Reporter]\nEnabled=1/' $RPM_BUILD_ROOT%{_libdir}/%{name}/application.ini
363
364 # Add debuginfo for crash-stats.mozilla.com
365 install -d $RPM_BUILD_ROOT%{_exec_prefix}/lib/debug%{_libdir}/%{name}
366 cp -a mozilla/dist/%{name}-%{version}.en-US.linux-*.crashreporter-symbols.zip $RPM_BUILD_ROOT%{_prefix}/lib/debug%{_libdir}/%{name}
367 %endif
368
369 # copy manually lightning files, somewhy they are not installed by make
370 cp -a mozilla/dist/bin/extensions/calendar-timezones@mozilla.org \
371         mozilla/dist/bin/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103} \
372         $RPM_BUILD_ROOT%{_libdir}/%{name}/extensions
373
374 # move arch independant ones to datadir
375 mv $RPM_BUILD_ROOT%{_libdir}/%{name}/chrome $RPM_BUILD_ROOT%{_datadir}/%{name}/chrome
376 mv $RPM_BUILD_ROOT%{_libdir}/%{name}/defaults $RPM_BUILD_ROOT%{_datadir}/%{name}/defaults
377 mv $RPM_BUILD_ROOT%{_libdir}/%{name}/isp $RPM_BUILD_ROOT%{_datadir}/%{name}/isp
378 mv $RPM_BUILD_ROOT%{_libdir}/%{name}/modules $RPM_BUILD_ROOT%{_datadir}/%{name}/modules
379 mv $RPM_BUILD_ROOT%{_libdir}/%{name}/searchplugins $RPM_BUILD_ROOT%{_datadir}/%{name}/searchplugins
380 ln -s ../../share/%{name}/chrome $RPM_BUILD_ROOT%{_libdir}/%{name}/chrome
381 ln -s ../../share/%{name}/defaults $RPM_BUILD_ROOT%{_libdir}/%{name}/defaults
382 ln -s ../../share/%{name}/isp $RPM_BUILD_ROOT%{_libdir}/%{name}/isp
383 ln -s ../../share/%{name}/modules $RPM_BUILD_ROOT%{_libdir}/%{name}/modules
384 ln -s ../../share/%{name}/searchplugins $RPM_BUILD_ROOT%{_libdir}/%{name}/searchplugins
385 %if %{without xulrunner}
386 mv $RPM_BUILD_ROOT%{_libdir}/%{name}/res $RPM_BUILD_ROOT%{_datadir}/%{name}/res
387 ln -s ../../share/%{name}/res $RPM_BUILD_ROOT%{_libdir}/%{name}/res
388 %endif
389
390 # dir for arch independant extensions besides arch dependant extensions
391 # see mozilla/xpcom/build/nsXULAppAPI.h
392 # XRE_SYS_LOCAL_EXTENSION_PARENT_DIR and XRE_SYS_SHARE_EXTENSION_PARENT_DIR
393 install -d $RPM_BUILD_ROOT%{_datadir}/%{name}/extensions
394
395 %if %{without xulrunner}
396 %{__rm} -r $RPM_BUILD_ROOT%{_libdir}/%{name}/dictionaries
397 ln -s %{_datadir}/myspell $RPM_BUILD_ROOT%{_libdir}/%{name}/dictionaries
398 %{__rm} -r $RPM_BUILD_ROOT%{_libdir}/%{name}/hyphenation
399 ln -s %{_datadir}/myspell $RPM_BUILD_ROOT%{_libdir}/%{name}/hyphenation
400 %endif
401
402 %{__sed} -e "s|%MOZAPPDIR%|%{_libdir}/%{name}|" \
403          -e "s|%MOZ_APP_DISPLAYNAME%|Icedove|" \
404         %{topdir}/mozilla/mozilla/build/unix/mozilla.in > $RPM_BUILD_ROOT%{_libdir}/%{name}/icedove
405
406 %{__sed} -e 's,@LIBDIR@,%{_libdir},' %{SOURCE5} > $RPM_BUILD_ROOT%{_bindir}/icedove
407 ln -s %{name} $RPM_BUILD_ROOT%{_bindir}/thunderbird
408 ln -s %{name} $RPM_BUILD_ROOT%{_bindir}/mozilla-thunderbird
409
410 cp -p %{SOURCE4} $RPM_BUILD_ROOT%{_desktopdir}/%{name}.desktop
411 cp -p %{topdir}/mozilla/icedove/branding/content/icon64.png $RPM_BUILD_ROOT%{_pixmapsdir}/%{name}.png
412
413 # files created by regxpcom -register in post
414 touch $RPM_BUILD_ROOT%{_libdir}/%{name}/components/compreg.dat
415 touch $RPM_BUILD_ROOT%{_libdir}/%{name}/components/xpti.dat
416 cat << 'EOF' > $RPM_BUILD_ROOT%{_libdir}/%{name}/register
417 #!/bin/sh
418 umask 022
419 # make temporary HOME, as it attempts to touch files in $HOME/.mozilla
420 # dangerous if you run this with sudo with keep_env += HOME
421 # also TMPDIR could be pointing to sudo user's homedir so we reset that too.
422 t=$(mktemp -d)
423 %{__rm} -f %{_libdir}/%{name}/components/{compreg,xpti}.dat
424 TMPDIR= TMP= HOME=$t %{_libdir}/%{name}/icedove -register
425 rm -rf $t
426 EOF
427 chmod a+rx $RPM_BUILD_ROOT%{_libdir}/%{name}/register
428
429 %if %{with enigmail}
430 ext_dir=$RPM_BUILD_ROOT%{_libdir}/%{name}/extensions/\{847b3a00-7ab1-11d4-8f02-006008948af5\}
431 install -d $ext_dir/{chrome,components,defaults/preferences,modules}
432 cd mozilla/dist/bin
433 cp -rfLp chrome/enigmail.jar $ext_dir/chrome
434 cp -rfLp components/enig* $ext_dir/components
435 cp -rfLp components/libenigmime.so $ext_dir/components
436 cp -rfLp components/libipc.so $ext_dir/components
437 cp -rfLp components/ipc.xpt $ext_dir/components
438 cp -rfLp defaults/preferences/enigmail.js $ext_dir/defaults/preferences
439 cp -rfLp modules/{commonFuncs,enigmailCommon,keyManagement,pipeConsole,pipeTransport,subprocess}.jsm $ext_dir/modules
440 cp -rfLp modules/{subprocess_worker_unix,subprocess_worker_win}.js $ext_dir/modules
441 cd -
442 cp -p %{topdir}/mozilla/mailnews/extensions/enigmail/package/install.rdf $ext_dir
443 cp -p %{topdir}/mozilla/mailnews/extensions/enigmail/package/chrome.manifest $ext_dir/chrome.manifest
444 %endif
445
446 # never package these. always remove
447 # nss
448 %{__rm} -f $RPM_BUILD_ROOT%{_libdir}/%{name}/lib{freebl3,nss3,nssckbi,nssdbm3,nssutil3,smime3,softokn3,ssl3}.*
449 # nspr
450 %{__rm} -f $RPM_BUILD_ROOT%{_libdir}/%{name}/lib{nspr4,plc4,plds4}.so
451 # mozldap
452 %{__rm} -f $RPM_BUILD_ROOT%{_libdir}/%{name}/lib{ldap,ldif,prldap,ssldap}60.so
453 # testpilot quiz
454 %{__rm} -f $RPM_BUILD_ROOT%{_libdir}/%{name}/distribution/extensions/tbtestpilot@labs.mozilla.com.xpi
455
456 %clean
457 rm -rf $RPM_BUILD_ROOT
458
459 %pretrans
460 if [ -d %{_libdir}/%{name}/dictionaries ] && [ ! -L %{_libdir}/%{name}/dictionaries ]; then
461         mv -v %{_libdir}/%{name}/dictionaries{,.rpmsave}
462 fi
463 for d in chrome defaults icons isp modules res searchplugins; do
464         if [ -d %{_libdir}/%{name}/$d ] && [ ! -L %{_libdir}/%{name}/$d ]; then
465                 install -d %{_datadir}/%{name}
466                 mv %{_libdir}/%{name}/$d %{_datadir}/%{name}/$d
467         fi
468 done
469 exit 0
470
471 %post
472 %{_libdir}/%{name}/register || :
473
474 %files
475 %defattr(644,root,root,755)
476 %attr(755,root,root) %{_bindir}/icedove
477 %attr(755,root,root) %{_bindir}/mozilla-thunderbird
478 %attr(755,root,root) %{_bindir}/thunderbird
479 %dir %{_libdir}/%{name}
480 %{_libdir}/%{name}/application.ini
481 %{_libdir}/%{name}/blocklist.xml
482 %{_libdir}/%{name}/chrome.manifest
483 %dir %{_libdir}/%{name}/components
484 %{_libdir}/%{name}/components/*.js
485 %{_libdir}/%{name}/components/*.xpt
486 %{_libdir}/%{name}/components/components.manifest
487 %{_libdir}/%{name}/components/interfaces.manifest
488 %attr(755,root,root) %{_libdir}/%{name}/*.sh
489 %attr(755,root,root) %{_libdir}/%{name}/*-bin
490 %attr(755,root,root) %{_libdir}/%{name}/icedove
491 %attr(755,root,root) %{_libdir}/%{name}/register
492 %if %{without xulrunner}
493 %{_libdir}/%{name}/platform.ini
494 %{_libdir}/%{name}/greprefs.js
495 %attr(755,root,root) %{_libdir}/%{name}/components/*.so
496 %attr(755,root,root) %{_libdir}/%{name}/libmozalloc.so
497 %attr(755,root,root) %{_libdir}/%{name}/libxpcom.so
498 %attr(755,root,root) %{_libdir}/%{name}/libxul.so
499 %attr(755,root,root) %{_libdir}/%{name}/mozilla-xremote-client
500 %attr(755,root,root) %{_libdir}/%{name}/plugin-container
501 %endif
502
503 # symlinks
504 %{_libdir}/%{name}/chrome
505 %{_libdir}/%{name}/defaults
506 %{_libdir}/%{name}/isp
507 %{_libdir}/%{name}/modules
508 %{_libdir}/%{name}/searchplugins
509 %if %{with xulrunner}
510 %{_libdir}/%{name}/xulrunner
511 %else
512 %{_libdir}/%{name}/dictionaries
513 %{_libdir}/%{name}/hyphenation
514 %{_libdir}/%{name}/res
515 %endif
516
517 %{_pixmapsdir}/icedove.png
518 %{_desktopdir}/icedove.desktop
519
520 %dir %{_datadir}/%{name}
521 %{_datadir}/%{name}/chrome
522 %{_datadir}/%{name}/defaults
523 %{_datadir}/%{name}/extensions
524 %{_datadir}/%{name}/isp
525 %{_datadir}/%{name}/modules
526 %if %{with enigmail}
527 %exclude %{_datadir}/%{name}/modules/commonFuncs.jsm
528 %exclude %{_datadir}/%{name}/modules/enigmailCommon.jsm
529 %exclude %{_datadir}/%{name}/modules/keyManagement.jsm
530 %exclude %{_datadir}/%{name}/modules/pipeConsole.jsm
531 %exclude %{_datadir}/%{name}/modules/pipeTransport.jsm
532 %exclude %{_datadir}/%{name}/modules/subprocess.jsm
533 %exclude %{_datadir}/%{name}/modules/subprocess_worker_unix.js
534 %exclude %{_datadir}/%{name}/modules/subprocess_worker_win.js
535 %endif
536 %{_datadir}/%{name}/searchplugins
537 %if %{without xulrunner}
538 %{_datadir}/%{name}/res
539 %endif
540
541 %if %{with crashreporter}
542 %attr(755,root,root) %{_libdir}/%{name}/crashreporter
543 %{_libdir}/%{name}/crashreporter.ini
544 %{_libdir}/%{name}/Throbber-small.gif
545 %endif
546
547 %dir %{_libdir}/%{name}/extensions
548 %{_libdir}/%{name}/extensions/{972ce4c6-7e08-4474-a285-3208198ce6fd}
549
550 # files created by regxpcom -register
551 %ghost %{_libdir}/%{name}/components/compreg.dat
552 %ghost %{_libdir}/%{name}/components/xpti.dat
553
554 %if %{with lightning}
555 %files addon-lightning
556 %defattr(644,root,root,755)
557 %dir %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}
558 %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/application.ini
559 %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/chrome
560 %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/chrome.manifest
561 %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/defaults
562 %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/install.rdf
563 %dir %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/components
564 %attr(755,root,root) %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/components/*.so
565 %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/components/*.js
566 %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/components/*.manifest
567 %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/components/*.xpt
568 %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/modules
569 %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/calendar-js
570 %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/timezones.sqlite
571 %{_libdir}/%{name}/extensions/calendar-timezones@mozilla.org
572 %endif
573
574 %if %{with enigmail}
575 %files addon-enigmail
576 %defattr(644,root,root,755)
577 %dir %{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}
578 %{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/defaults
579 %{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/chrome
580 %{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/chrome.manifest
581 %{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/install.rdf
582 %dir %{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/components
583 %attr(755,root,root) %{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/components/*.so
584 %{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/components/*.xpt
585 %{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/components/*.js
586 %dir %{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/modules
587 %{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/modules/*.jsm
588 %{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/modules/*.js
589 %endif
This page took 0.101811 seconds and 3 git commands to generate.