]> git.pld-linux.org Git - packages/thunderbird.git/blob - icedove.spec
- synced xulrunner bcond with mozilla-thunderbird; now at least builds
[packages/thunderbird.git] / icedove.spec
1 # TODO:
2 # - separate spec for enigmail
3 # - build with system mozldap
4 #
5 # Conditional builds
6 %bcond_without  enigmail        # don't build enigmail - GPG/PGP support
7 %bcond_without  gnomeui         # disable gnomeui support
8 %bcond_without  gnome           # alias for gnomeui
9 %bcond_without  ldap            # disable e-mail address lookups in LDAP directories
10 %bcond_without  lightning       # disable Sunbird/Lightning calendar
11 %bcond_with     xulrunner       # system xulrunner
12 %bcond_with     crashreporter   # report crashes to crash-stats.mozilla.com
13
14 %if %{without gnome}
15 %undefine       with_gnomeui
16 %endif
17
18 %if 0%{?_enable_debug_packages} != 1
19 %undefine       crashreporter
20 %endif
21
22 %define         enigmail_ver    1.4
23 %define         nspr_ver        4.9
24 %define         nss_ver         3.13.3
25
26 # convert thunderbird release number to platform version: 11.0.x -> 11.0.x
27 %define         xulrunner_main  11.0
28 %define         xulrunner_ver   %(v=%{version}; echo %{xulrunner_main}${v#11.0})
29
30 %if %{without xulrunner}
31 # The actual sqlite version (see RHBZ#480989):
32 %define         sqlite_build_version %(pkg-config --silence-errors --modversion sqlite3 2>/dev/null || echo ERROR)
33 %endif
34
35 Summary:        Icedove - email client
36 Summary(pl.UTF-8):      Icedove - klient poczty
37 Name:           icedove
38 Version:        11.0
39 Release:        1
40 License:        MPL 1.1 or GPL v2+ or LGPL v2.1+
41 Group:          X11/Applications/Networking
42 Source0:        http://releases.mozilla.org/pub/mozilla.org/thunderbird/releases/%{version}/source/thunderbird-%{version}.source.tar.bz2
43 # Source0-md5:  1d7127a3282e62d95eb9b59d47291b70
44 Source1:        http://www.mozilla-enigmail.org/download/source/enigmail-%{enigmail_ver}.tar.gz
45 # Source1-md5:  5cf3d9720ed1cda1b22eabe5457772c2
46 Source2:        %{name}-branding.tar.bz2
47 # Source2-md5:  2da351522bdd7f4a3bd8aaff4c776976
48 Source3:        %{name}-rm_nonfree.sh
49 Source4:        %{name}.desktop
50 Source5:        %{name}.sh
51 Patch0:         %{name}-branding.patch
52 Patch1:         %{name}-enigmail-shared.patch
53 Patch2:         %{name}-system-xulrunner.patch
54 Patch3:         %{name}-fonts.patch
55 Patch4:         %{name}-install.patch
56 Patch5:         %{name}-hunspell.patch
57 Patch6:         %{name}-prefs.patch
58 Patch7:         system-mozldap.patch
59 Patch8:         %{name}-makefile.patch
60
61 Patch10:        %{name}-extensiondir.patch
62 Patch11:        crashreporter.patch
63 Patch12:        no-subshell.patch
64 URL:            http://www.pld-linux.org/Packages/Icedove
65 BuildRequires:  GConf2-devel >= 1.2.1
66 BuildRequires:  alsa-lib-devel
67 BuildRequires:  automake
68 BuildRequires:  bzip2-devel
69 BuildRequires:  cairo-devel >= 1.10
70 BuildRequires:  dbus-glib-devel >= 0.60
71 BuildRequires:  freetype-devel >= 1:2.1.8
72 BuildRequires:  glib2-devel >= 2.0
73 BuildRequires:  gtk+2-devel >= 2:2.10.0
74 BuildRequires:  hunspell-devel
75 BuildRequires:  libIDL-devel >= 0.8.0
76 %{?with_gnomeui:BuildRequires:  libgnome-devel >= 2.0}
77 %{?with_gnomeui:BuildRequires:  libgnome-keyring-devel}
78 %{?with_gnomeui:BuildRequires:  libgnomeui-devel >= 2.2.0}
79 BuildRequires:  libiw-devel
80 BuildRequires:  libjpeg-devel >= 6b
81 BuildRequires:  libnotify-devel >= 0.4
82 BuildRequires:  libpng-devel >= 1.4.1
83 BuildRequires:  libstdc++-devel
84 BuildRequires:  nspr-devel >= 1:%{nspr_ver}
85 BuildRequires:  nss-devel >= 1:%{nss_ver}
86 BuildRequires:  pango-devel >= 1:1.1.0
87 BuildRequires:  perl-base >= 1:5.6
88 BuildRequires:  pkgconfig
89 BuildRequires:  python >= 1:2.5
90 BuildRequires:  sed >= 4.0
91 BuildRequires:  sqlite3-devel >= 3.7.4
92 BuildRequires:  startup-notification-devel >= 0.8
93 BuildRequires:  xorg-lib-libXext-devel
94 BuildRequires:  xorg-lib-libXinerama-devel
95 BuildRequires:  xorg-lib-libXt-devel
96 BuildRequires:  yasm
97 BuildRequires:  zip
98 %if %{with xulrunner}
99 BuildRequires:  xulrunner-devel >= 2:%{xulrunner_ver}
100 %else
101 Requires:       myspell-common
102 Requires:       nspr >= 1:%{nspr_ver}
103 Requires:       nss >= 1:%{nss_ver}
104 Requires:       sqlite3 >= %{sqlite_build_version}
105 %endif
106 Requires(post): mktemp >= 1.5-18
107 %if %{with xulrunner}
108 %requires_eq_to xulrunner xulrunner-devel
109 %endif
110 Obsoletes:      mozilla-thunderbird
111 Obsoletes:      mozilla-thunderbird-dictionary-en-US
112 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
113
114 %define         filterout_cpp           -D_FORTIFY_SOURCE=[0-9]+
115
116 # iceweasel/icedove/iceape provide their own versions
117 %define         _noautoprovfiles        %{_libdir}/%{name}/components
118 # we don't want these to satisfy xulrunner-devel
119 %define         _noautoprov             libmozjs.so libxpcom.so libxul.so
120 # and as we don't provide them, don't require either
121 %define         _noautoreq              libmozjs.so libxpcom.so libxul.so
122
123 %define         topdir          %{_builddir}/%{name}-%{version}
124 %define         objdir          %{topdir}/obj-%{_target_cpu}
125
126 %description
127 Icedove is an open-source, fast and portable email client.
128
129 %description -l pl.UTF-8
130 Icedove jest mającym otwarte źródła, szybkim i przenośnym klientem
131 poczty.
132
133 %package addon-lightning
134 Summary:        An integrated calendar for Icedove
135 Summary(pl.UTF-8):      Zintegrowany kalendarz dla Icedove
136 License:        MPL 1.1 or GPL v2+ or LGPL v2.1+
137 Group:          Applications/Networking
138 Requires:       %{name} = %{version}-%{release}
139
140 %description addon-lightning
141 Lightning is an calendar extension to Icedove email client.
142
143 %description addon-lightning -l pl.UTF-8
144 Lightning to rozszerzenie do klienta poczty Icedove dodające
145 funkcjonalność kalendarza.
146
147 %package addon-enigmail
148 Summary:        Extension for the authentication and encryption features provided by GnuPG
149 Summary(pl.UTF-8):      Rozszerzenie do uwierzytelniania i szyfrowania zapewnianego przez GnuPG
150 License:        MPL/LGPL
151 Group:          Applications/Networking
152 URL:            http://enigmail.mozdev.org/
153 Requires:       %{name} = %{version}-%{release}
154 Requires:       gnupg
155 Obsoletes:      mozilla-thunderbird-addon-enigmail
156
157 %description addon-enigmail
158 Enigmail is an extension to the Icedove mail client which allows users
159 to access the authentication and encryption features provided by
160 GnuPG.
161
162 Main Features:
163 - Encrypt/sign mail when sending, decrypt/authenticate received mail
164 - Support for inline-PGP (RFC 2440) and PGP/MIME (RFC 3156)
165 - Per-Account based encryption and signing defaults
166 - Per-Recipient rules for automated key selection, and
167   enabling/disabling encryption and signing
168 - OpenPGP key management interface
169
170 %description addon-enigmail -l pl.UTF-8
171 Enigmail to rozszerzenie klienta pocztowego Icedove pozwalające
172 użytkownikom na dostęp do uwierzytelniania i szyfrowania zapewnianego
173 przez GnuPG.
174
175 Główne możliwości:
176 - szyfrowanie/podpisywanie poczty przy wysyłaniu,
177   odszyfrowywanie/uwierzytelnianie poczty odebranej
178 - obsługa inline-PGP (RFC 2440) i PGP/MIME (RFC 3156)
179 - ustawienia domyślne szyfrowania i podpisywania dla każdego konta
180 - reguły automatycznego wyboru kluczy i włączenia szyfrowania oraz
181   podpisywania dla każdego adresata
182 - interfejs do zarządzania kluczami OpenPGP
183
184 %prep
185 %setup -qc
186 mv comm-release mozilla
187 %setup -q -T -D -a2
188 cd mozilla
189 %{?with_enigmail:%{__gzip} -dc %{SOURCE1} | %{__tar} -xf - -C mailnews/extensions}
190 /bin/sh %{SOURCE3}
191 %patch0 -p1
192 %{?with_enigmail:%patch1 -p1}
193 %{?with_xulrunner:%patch2 -p1}
194 %patch3 -p1
195 %patch4 -p1
196 %patch6 -p1
197 %patch7 -p1
198 %patch8 -p2
199 %patch10 -p2
200 %patch11 -p2
201 %patch12 -p1
202
203 %build
204 cd mozilla
205 cp -f %{_datadir}/automake/config.* mozilla/build/autoconf
206 cp -f %{_datadir}/automake/config.* mozilla/nsprpub/build/autoconf
207 cp -f %{_datadir}/automake/config.* ldap/sdks/c-sdk/config/autoconf
208
209 cat << EOF > .mozconfig
210 mk_add_options MOZ_OBJDIR=%{objdir}
211
212 export CFLAGS="%{rpmcflags}"
213 export CXXFLAGS="%{rpmcflags}"
214
215 %if %{with crashreporter}
216 export MOZ_DEBUG_SYMBOLS=1
217 %endif
218
219 # Options for 'configure' (same as command-line options).
220 ac_add_options --prefix=%{_prefix}
221 ac_add_options --exec-prefix=%{_exec_prefix}
222 ac_add_options --bindir=%{_bindir}
223 ac_add_options --sbindir=%{_sbindir}
224 ac_add_options --sysconfdir=%{_sysconfdir}
225 ac_add_options --datadir=%{_datadir}
226 ac_add_options --includedir=%{_includedir}
227 ac_add_options --libdir=%{_libdir}
228 ac_add_options --libexecdir=%{_libexecdir}
229 ac_add_options --localstatedir=%{_localstatedir}
230 ac_add_options --sharedstatedir=%{_sharedstatedir}
231 ac_add_options --mandir=%{_mandir}
232 ac_add_options --infodir=%{_infodir}
233 %if %{?debug:1}0
234 ac_add_options --disable-optimize
235 ac_add_options --enable-debug
236 ac_add_options --enable-debug-modules
237 ac_add_options --enable-debugger-info-modules
238 ac_add_options --enable-crash-on-assert
239 %else
240 ac_add_options --disable-debug
241 ac_add_options --disable-debug-modules
242 ac_add_options --disable-logging
243 ac_add_options --enable-optimize="%{rpmcflags} -Os"
244 %endif
245 ac_add_options --disable-strip
246 ac_add_options --disable-strip-libs
247 %if %{with tests}
248 ac_add_options --enable-tests
249 %else
250 ac_add_options --disable-tests
251 %endif
252 ac_add_options --enable-gio
253 %if %{with gnomeui}
254 ac_add_options --enable-gnomeui
255 %else
256 ac_add_options --disable-gnomeui
257 %endif
258 ac_add_options --disable-gnomevfs
259 %if %{with ldap}
260 ac_add_options --enable-ldap
261 ac_add_options --with-system-ldap
262 %else
263 ac_add_options --disable-ldap
264 %endif
265 %if %{with crashreporter}
266 ac_add_options --enable-crashreporter
267 %else
268 ac_add_options --disable-crashreporter
269 %endif
270 ac_add_options --disable-xterm-updates
271 ac_add_options --enable-postscript
272 %if %{with lightning}
273 ac_add_options --enable-calendar
274 %else
275 ac_add_options --disable-calendar
276 %endif
277 ac_add_options --disable-installer
278 ac_add_options --disable-updater
279 ac_add_options --disable-xprint
280 ac_add_options --disable-permissions
281 ac_add_options --disable-pref-extensions
282 ac_add_options --enable-canvas
283 ac_add_options --enable-crypto
284 ac_add_options --enable-mathml
285 ac_add_options --enable-pango
286 ac_add_options --enable-reorder
287 ac_add_options --enable-startup-notification
288 ac_add_options --enable-svg
289 ac_add_options --enable-system-cairo
290 ac_add_options --enable-system-hunspell
291 ac_add_options --enable-system-sqlite
292 ac_add_options --enable-xft
293 ac_add_options --enable-application=mail
294 ac_add_options --enable-default-toolkit=cairo-gtk2
295 ac_add_options --enable-xinerama
296 ac_add_options --with-distribution-id=org.pld-linux
297 ac_add_options --with-branding=icedove/branding
298 %if %{with xulrunner}
299 ac_add_options --enable-shared-js
300 ac_add_options --with-libxul-sdk=$(pkg-config --variable=sdkdir libxul)
301 ac_add_options --with-system-libxul
302 %endif
303 ac_add_options --with-pthreads
304 ac_add_options --with-system-bz2
305 ac_add_options --with-system-jpeg
306 ac_add_options --with-system-nspr
307 ac_add_options --with-system-nss
308 ac_add_options --with-system-png
309 ac_add_options --with-system-zlib
310 ac_add_options --enable-single-profile
311 ac_add_options --disable-profilesharing
312 ac_add_options --with-default-mozilla-five-home=%{_libdir}/%{name}
313 EOF
314
315 %{__make} -j1 -f client.mk build \
316         STRIP="/bin/true" \
317         MOZ_MAKE_FLAGS="%{?_smp_mflags}" \
318         CC="%{__cc}" \
319         CXX="%{__cxx}"
320
321 %if %{with crashreporter}
322 # create debuginfo for crash-stats.mozilla.com
323 %{__make} -j1 -C obj-%{_target_cpu} buildsymbols
324 %endif
325
326 %if %{with enigmail}
327 cd mailnews/extensions/enigmail
328 ./makemake -r -o %{objdir}
329 %{__make} -C %{objdir}/mailnews/extensions/enigmail \
330         STRIP="/bin/true" \
331         CC="%{__cc}" \
332         CXX="%{__cxx}"
333 %endif
334
335 %install
336 rm -rf $RPM_BUILD_ROOT
337 install -d $RPM_BUILD_ROOT{%{_bindir},%{_libdir}/%{name},%{_datadir}/%{name},%{_pixmapsdir},%{_desktopdir}}
338
339 cd %{objdir}
340 %{__make} -C mail/installer stage-package \
341         DESTDIR=$RPM_BUILD_ROOT \
342         MOZ_PKG_DIR=%{_libdir}/%{name} \
343         PKG_SKIP_STRIP=1
344
345 # Enable crash reporter for Firefox application
346 %if %{with crashreporter}
347 %{__sed} -i -e 's/\[Crash Reporter\]/[Crash Reporter]\nEnabled=1/' $RPM_BUILD_ROOT%{_libdir}/%{name}/application.ini
348
349 # Add debuginfo for crash-stats.mozilla.com
350 install -d $RPM_BUILD_ROOT%{_exec_prefix}/lib/debug%{_libdir}/%{name}
351 cp -a mozilla/dist/%{name}-%{version}.en-US.linux-*.crashreporter-symbols.zip $RPM_BUILD_ROOT%{_prefix}/lib/debug%{_libdir}/%{name}
352 %endif
353
354 # copy manually lightning files, somewhy they are not installed by make
355 cp -a mozilla/dist/bin/extensions/calendar-timezones@mozilla.org \
356         mozilla/dist/bin/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103} \
357         $RPM_BUILD_ROOT%{_libdir}/%{name}/extensions
358
359 # move arch independant ones to datadir
360 mv $RPM_BUILD_ROOT%{_libdir}/%{name}/chrome $RPM_BUILD_ROOT%{_datadir}/%{name}/chrome
361 mv $RPM_BUILD_ROOT%{_libdir}/%{name}/defaults $RPM_BUILD_ROOT%{_datadir}/%{name}/defaults
362 mv $RPM_BUILD_ROOT%{_libdir}/%{name}/isp $RPM_BUILD_ROOT%{_datadir}/%{name}/isp
363 mv $RPM_BUILD_ROOT%{_libdir}/%{name}/modules $RPM_BUILD_ROOT%{_datadir}/%{name}/modules
364 mv $RPM_BUILD_ROOT%{_libdir}/%{name}/searchplugins $RPM_BUILD_ROOT%{_datadir}/%{name}/searchplugins
365 ln -s ../../share/%{name}/chrome $RPM_BUILD_ROOT%{_libdir}/%{name}/chrome
366 ln -s ../../share/%{name}/defaults $RPM_BUILD_ROOT%{_libdir}/%{name}/defaults
367 ln -s ../../share/%{name}/isp $RPM_BUILD_ROOT%{_libdir}/%{name}/isp
368 ln -s ../../share/%{name}/modules $RPM_BUILD_ROOT%{_libdir}/%{name}/modules
369 ln -s ../../share/%{name}/searchplugins $RPM_BUILD_ROOT%{_libdir}/%{name}/searchplugins
370 %if %{without xulrunner}
371 mv $RPM_BUILD_ROOT%{_libdir}/%{name}/res $RPM_BUILD_ROOT%{_datadir}/%{name}/res
372 ln -s ../../share/%{name}/res $RPM_BUILD_ROOT%{_libdir}/%{name}/res
373 %endif
374
375 # dir for arch independant extensions besides arch dependant extensions
376 # see mozilla/xpcom/build/nsXULAppAPI.h
377 # XRE_SYS_LOCAL_EXTENSION_PARENT_DIR and XRE_SYS_SHARE_EXTENSION_PARENT_DIR
378 install -d $RPM_BUILD_ROOT%{_datadir}/%{name}/extensions
379
380 %if %{without xulrunner}
381 %{__rm} -r $RPM_BUILD_ROOT%{_libdir}/%{name}/dictionaries
382 ln -s %{_datadir}/myspell $RPM_BUILD_ROOT%{_libdir}/%{name}/dictionaries
383 %{__rm} -r $RPM_BUILD_ROOT%{_libdir}/%{name}/hyphenation
384 ln -s %{_datadir}/myspell $RPM_BUILD_ROOT%{_libdir}/%{name}/hyphenation
385 %endif
386
387 %{__sed} -e 's,@LIBDIR@,%{_libdir},' %{SOURCE5} > $RPM_BUILD_ROOT%{_bindir}/icedove
388 ln -s %{name} $RPM_BUILD_ROOT%{_bindir}/thunderbird
389 ln -s %{name} $RPM_BUILD_ROOT%{_bindir}/mozilla-thunderbird
390
391 cp -p %{SOURCE4} $RPM_BUILD_ROOT%{_desktopdir}/%{name}.desktop
392 cp -p %{topdir}/mozilla/icedove/branding/content/icon64.png $RPM_BUILD_ROOT%{_pixmapsdir}/%{name}.png
393
394 # files created by regxpcom -register in post
395 touch $RPM_BUILD_ROOT%{_libdir}/%{name}/components/compreg.dat
396 touch $RPM_BUILD_ROOT%{_libdir}/%{name}/components/xpti.dat
397 cat << 'EOF' > $RPM_BUILD_ROOT%{_libdir}/%{name}/register
398 #!/bin/sh
399 umask 022
400 # make temporary HOME, as it attempts to touch files in $HOME/.mozilla
401 # dangerous if you run this with sudo with keep_env += HOME
402 # also TMPDIR could be pointing to sudo user's homedir so we reset that too.
403 t=$(mktemp -d)
404 %{__rm} -f %{_libdir}/%{name}/components/{compreg,xpti}.dat
405 TMPDIR= TMP= HOME=$t %{_libdir}/%{name}/icedove -register
406 rm -rf $t
407 EOF
408 chmod a+rx $RPM_BUILD_ROOT%{_libdir}/%{name}/register
409
410 %if %{with enigmail}
411 ext_dir=$RPM_BUILD_ROOT%{_libdir}/%{name}/extensions/\{847b3a00-7ab1-11d4-8f02-006008948af5\}
412 install -d $ext_dir/{chrome,components,defaults/preferences}
413 cd mozilla/dist/bin
414 #cp -rfLp chrome/enigmail.jar $ext_dir/chrome
415 #cp -rfLp chrome/enigmime.jar $ext_dir/chrome
416 cp -rfLp components/enig* $ext_dir/components
417 cp -rfLp components/libenigmime.so $ext_dir/components
418 cp -rfLp components/libipc.so $ext_dir/components
419 cp -rfLp components/ipc.xpt $ext_dir/components
420 cp -rfLp defaults/preferences/enigmail.js $ext_dir/defaults/preferences
421 cd -
422 cp -p %{topdir}/mozilla/mailnews/extensions/enigmail/package/install.rdf $ext_dir
423 cp -p %{topdir}/mozilla/mailnews/extensions/enigmail/package/chrome.manifest $ext_dir/chrome.manifest
424 %endif
425
426 # never package these. always remove
427 # nss
428 %{__rm} -f $RPM_BUILD_ROOT%{_libdir}/%{name}/lib{freebl3,nss3,nssckbi,nssdbm3,nssutil3,smime3,softokn3,ssl3}.*
429 # nspr
430 %{__rm} -f $RPM_BUILD_ROOT%{_libdir}/%{name}/lib{nspr4,plc4,plds4}.so
431 # mozldap
432 %{__rm} -f $RPM_BUILD_ROOT%{_libdir}/%{name}/lib{ldap,ldif,prldap,ssldap}60.so
433
434 %clean
435 rm -rf $RPM_BUILD_ROOT
436
437 %pretrans
438 if [ -d %{_libdir}/%{name}/dictionaries ] && [ ! -L %{_libdir}/%{name}/dictionaries ]; then
439         mv -v %{_libdir}/%{name}/dictionaries{,.rpmsave}
440 fi
441 for d in chrome defaults icons isp modules res searchplugins; do
442         if [ -d %{_libdir}/%{name}/$d ] && [ ! -L %{_libdir}/%{name}/$d ]; then
443                 install -d %{_datadir}/%{name}
444                 mv %{_libdir}/%{name}/$d %{_datadir}/%{name}/$d
445         fi
446 done
447 exit 0
448
449 %post
450 %{_libdir}/%{name}/register || :
451
452 %files
453 %defattr(644,root,root,755)
454 %attr(755,root,root) %{_bindir}/icedove
455 %attr(755,root,root) %{_bindir}/mozilla-thunderbird
456 %attr(755,root,root) %{_bindir}/thunderbird
457 %dir %{_libdir}/%{name}
458 %{_libdir}/%{name}/application.ini
459 %{_libdir}/%{name}/blocklist.xml
460 %{_libdir}/%{name}/chrome.manifest
461 %dir %{_libdir}/%{name}/components
462 %{_libdir}/%{name}/components/*.js
463 %{_libdir}/%{name}/components/*.xpt
464 %{_libdir}/%{name}/components/components.manifest
465 %{_libdir}/%{name}/components/interfaces.manifest
466 %attr(755,root,root) %{_libdir}/%{name}/*.sh
467 %attr(755,root,root) %{_libdir}/%{name}/*-bin
468 %attr(755,root,root) %{_libdir}/%{name}/icedove
469 %attr(755,root,root) %{_libdir}/%{name}/register
470 %if %{without xulrunner}
471 %{_libdir}/%{name}/platform.ini
472 %{_libdir}/%{name}/greprefs.js
473 %attr(755,root,root) %{_libdir}/%{name}/components/*.so
474 %attr(755,root,root) %{_libdir}/%{name}/libmozalloc.so
475 %attr(755,root,root) %{_libdir}/%{name}/libxpcom.so
476 %attr(755,root,root) %{_libdir}/%{name}/libxul.so
477 %attr(755,root,root) %{_libdir}/%{name}/mozilla-xremote-client
478 %attr(755,root,root) %{_libdir}/%{name}/plugin-container
479 %endif
480
481 # symlinks
482 %{_libdir}/%{name}/chrome
483 %{_libdir}/%{name}/defaults
484 %{_libdir}/%{name}/isp
485 %{_libdir}/%{name}/modules
486 %{_libdir}/%{name}/searchplugins
487 %if %{without xulrunner}
488 %{_libdir}/%{name}/dictionaries
489 %{_libdir}/%{name}/hyphenation
490 %{_libdir}/%{name}/res
491 %endif
492
493 %{_pixmapsdir}/icedove.png
494 %{_desktopdir}/icedove.desktop
495
496 %dir %{_datadir}/%{name}
497 %{_datadir}/%{name}/chrome
498 %{_datadir}/%{name}/defaults
499 %{_datadir}/%{name}/extensions
500 %{_datadir}/%{name}/isp
501 %{_datadir}/%{name}/modules
502 %{_datadir}/%{name}/searchplugins
503 %if %{without xulrunner}
504 %{_datadir}/%{name}/res
505 %endif
506
507 %if %{with crashreporter}
508 %attr(755,root,root) %{_libdir}/%{name}/crashreporter
509 %{_libdir}/%{name}/crashreporter.ini
510 %{_libdir}/%{name}/Throbber-small.gif
511 %endif
512
513 %dir %{_libdir}/%{name}/extensions
514 %{_libdir}/%{name}/extensions/{972ce4c6-7e08-4474-a285-3208198ce6fd}
515
516 # files created by regxpcom -register
517 %ghost %{_libdir}/%{name}/components/compreg.dat
518 %ghost %{_libdir}/%{name}/components/xpti.dat
519
520 %if %{with lightning}
521 %files addon-lightning
522 %defattr(644,root,root,755)
523 %dir %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}
524 %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/application.ini
525 %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/chrome
526 %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/chrome.manifest
527 %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/defaults
528 %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/install.rdf
529 %dir %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/components
530 %attr(755,root,root) %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/components/*.so
531 %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/components/*.js
532 %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/components/*.manifest
533 %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/components/*.xpt
534 %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/modules
535 %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/calendar-js
536 %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/timezones.sqlite
537 %{_libdir}/%{name}/extensions/calendar-timezones@mozilla.org
538 %endif
539
540 %if %{with enigmail}
541 %files addon-enigmail
542 %defattr(644,root,root,755)
543 %dir %{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}
544 %{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/defaults
545 %{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/chrome
546 %{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/chrome.manifest
547 %{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/install.rdf
548 %dir %{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/components
549 %attr(755,root,root) %{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/components/*.so
550 %{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/components/*.xpt
551 %{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/components/*.js
552 %endif
This page took 0.076608 seconds and 3 git commands to generate.