]> git.pld-linux.org Git - packages/thunderbird.git/blob - icedove.spec
- -fpermissive is needed to build with gcc 4.6+ which has become stricter
[packages/thunderbird.git] / icedove.spec
1 # TODO:
2 # - separate spec for enigmail
3 # - fix icedove (building) and installing nss/nspr libs!
4 # - build with system mozldap
5 #
6 # Conditional builds
7 %bcond_without  enigmail        # don't build enigmail - GPG/PGP support
8 %bcond_without  gnomeui         # disable gnomeui support
9 %bcond_without  gnomevfs        # disable GNOME comp. (gconf+libgnome+gnomevfs) and gnomevfs ext.
10 %bcond_without  gnome           # disable all GNOME components (gnome+gnomeui+gnomevfs)
11 %bcond_without  ldap            # disable e-mail address lookups in LDAP directories
12 %bcond_without  lightning       # disable sunbird calendar
13 %bcond_with             xulrunner       # build with xulrunner
14 %bcond_with     crashreporter   # report crashes to crash-stats.mozilla.com
15
16 %if %{without gnome}
17 %undefine       with_gnomeui
18 %undefine       with_gnomevfs
19 %endif
20
21 %if %{?_enable_debug_packages} != 1
22 %undefine       crashreporter
23 %endif
24
25 %define         enigmail_ver            1.1.2
26
27 %if %{without xulrunner}
28 # The actual sqlite version (see RHBZ#480989):
29 %define         sqlite_build_version %(pkg-config --silence-errors --modversion sqlite3 2>/dev/null || echo ERROR)
30 %endif
31
32 Summary:        Icedove - email client
33 Summary(pl.UTF-8):      Icedove - klient poczty
34 Name:           icedove
35 Version:        3.1.11
36 Release:        2
37 License:        MPL 1.1 or GPL v2+ or LGPL v2.1+
38 Group:          X11/Applications/Networking
39 Source0:        http://releases.mozilla.org/pub/mozilla.org/thunderbird/releases/%{version}/source/thunderbird-%{version}.source.tar.bz2
40 # Source0-md5:  25833b3f90925d96285630d22c85cd5c
41 Source1:        http://www.mozilla-enigmail.org/download/source/enigmail-%{enigmail_ver}.tar.gz
42 # Source1-md5:  7d329d5e8afbbb28214ca1995beb09c9
43 Source2:        %{name}-branding.tar.bz2
44 # Source2-md5:  2da351522bdd7f4a3bd8aaff4c776976
45 Source3:        %{name}-rm_nonfree.sh
46 Source4:        %{name}.desktop
47 Source5:        %{name}.sh
48 Patch0:         %{name}-branding.patch
49 Patch1:         %{name}-enigmail-shared.patch
50 Patch2:         %{name}-gcc.patch
51 Patch3:         %{name}-fonts.patch
52 Patch4:         %{name}-install.patch
53 Patch5:         %{name}-hunspell.patch
54 Patch6:         %{name}-prefs.patch
55 Patch7:         system-mozldap.patch
56 Patch8:         %{name}-makefile.patch
57 Patch9:         %{name}-libpng.patch
58 Patch10:        %{name}-extensiondir.patch
59 Patch11:        crashreporter.patch
60 Patch12:        no-subshell.patch
61 URL:            http://www.pld-linux.org/Packages/Icedove
62 %{?with_gnomevfs:BuildRequires: GConf2-devel >= 1.2.1}
63 BuildRequires:  alsa-lib-devel
64 BuildRequires:  automake
65 BuildRequires:  bzip2-devel
66 BuildRequires:  freetype-devel >= 1:2.1.8
67 %{?with_gnomevfs:BuildRequires: gnome-vfs2-devel >= 2.0}
68 BuildRequires:  gtk+2-devel >= 1:2.0.0
69 BuildRequires:  hunspell-devel
70 BuildRequires:  libIDL-devel >= 0.8.0
71 %{?with_gnomevfs:BuildRequires: libgnome-devel >= 2.0}
72 %{?with_gnomeui:BuildRequires:  libgnome-keyring-devel}
73 %{?with_gnomeui:BuildRequires:  libgnomeui-devel >= 2.2.0}
74 BuildRequires:  libiw-devel
75 BuildRequires:  libjpeg-devel >= 6b
76 BuildRequires:  libnotify-devel >= 0.4
77 BuildRequires:  libpng-devel >= 1.2.0
78 BuildRequires:  libstdc++-devel
79 BuildRequires:  nspr-devel >= 1:4.8
80 BuildRequires:  nss-devel >= 1:3.12.0
81 BuildRequires:  pango-devel >= 1:1.1.0
82 BuildRequires:  pkgconfig
83 BuildRequires:  sed >= 4.0
84 BuildRequires:  sqlite3-devel >= 3.7.4
85 BuildRequires:  startup-notification-devel >= 0.8
86 BuildRequires:  xorg-lib-libXext-devel
87 BuildRequires:  xorg-lib-libXinerama-devel
88 BuildRequires:  xorg-lib-libXt-devel
89 BuildRequires:  zip
90 Requires(post): mktemp >= 1.5-18
91 %if %{with xulrunner}
92 %else
93 Requires:       myspell-common
94 Requires:       nspr >= 1:4.6.1
95 Requires:       nss >= 1:3.11.3
96 Requires:       sqlite3 >= %{sqlite_build_version}
97 %endif
98 Obsoletes:      mozilla-thunderbird
99 Obsoletes:      mozilla-thunderbird-dictionary-en-US
100 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
101
102 %define         filterout_cpp           -D_FORTIFY_SOURCE=[0-9]+
103
104 # iceweasel/icedove/iceape provide their own versions
105 %define         _noautoreqdep           libgfxpsshar.so libgkgfx.so libgtkxtbin.so libjsj.so libxpcom_compat.so libxpistub.so
106 %define         _noautoprovfiles        %{_libdir}/%{name}/components
107 # we don't want these to satisfy xulrunner-devel
108 %define         _noautoprov             libgtkembedmoz.so libmozjs.so libxpcom.so libxul.so libxpcom_core.so
109 # and as we don't provide them, don't require either
110 %define         _noautoreq              libgtkembedmoz.so libmozjs.so libxpcom.so libxul.so libxpcom_core.so
111
112 %define         topdir          %{_builddir}/%{name}-%{version}
113 %define         objdir          %{topdir}/obj-%{_target_cpu}
114
115 %description
116 Icedove is an open-source,fast and portable email client.
117
118 %description -l pl.UTF-8
119 Icedove jest open sourcowym, szybkim i przenośnym klientem poczty.
120
121 %package addon-lightning
122 Summary:        An integrated calendar for Icedove
123 Summary(pl.UTF-8):      Zintegrowany kalendarz dla Icedove
124 License:        MPL 1.1 or GPL v2+ or LGPL v2.1+
125 Group:          Applications/Networking
126 Requires:       %{name} = %{version}-%{release}
127
128 %description addon-lightning
129 Lightning is an calendar extension to Icedove email client.
130
131 %description addon-lightning -l pl.UTF-8
132 Lightning to rozszerzenie do klienta poczty Icedove dodające
133 funkcjonalność kalendarza.
134
135 %package addon-enigmail
136 Summary:        Extension for the authentication and encryption features provided by GnuPG
137 Summary(pl.UTF-8):      Rozszerzenie do uwierzytelniania i szyfrowania zapewnianego przez GnuPG
138 License:        MPL/LGPL
139 Group:          Applications/Networking
140 URL:            http://enigmail.mozdev.org/
141 Requires:       %{name} = %{version}-%{release}
142 Requires:       gnupg
143 Obsoletes:      mozilla-thunderbird-addon-enigmail
144
145 %description addon-enigmail
146 Enigmail is an extension to the Icedove mail client which allows users
147 to access the authentication and encryption features provided by
148 GnuPG.
149
150 Main Features:
151 - Encrypt/sign mail when sending, decrypt/authenticate received mail
152 - Support for inline-PGP (RFC 2440) and PGP/MIME (RFC 3156)
153 - Per-Account based encryption and signing defaults
154 - Per-Recipient rules for automated key selection, and
155   enabling/disabling encryption and signing
156 - OpenPGP key management interface
157
158 %description addon-enigmail -l pl.UTF-8
159 Enigmail to rozszerzenie klienta pocztowego Icedove pozwalające
160 użytkownikom na dostęp do uwierzytelniania i szyfrowania zapewnianego
161 przez GnuPG.
162
163 Główne możliwości:
164 - szyfrowanie/podpisywanie poczty przy wysyłaniu,
165   odszyfrowywanie/uwierzytelnianie poczty odebranej
166 - obsługa inline-PGP (RFC 2440) i PGP/MIME (RFC 3156)
167 - ustawienia domyślne szyfrowania i podpisywania dla każdego konta
168 - reguły automatycznego wyboru kluczy i włączenia szyfrowania oraz
169   podpisywania dla każdego adresata
170 - interfejs do zarządzania kluczami OpenPGP
171
172 %prep
173 %setup -qc
174 mv -f comm-1.9.2 mozilla
175 %setup -q -T -D -a2
176 cd mozilla
177 %{?with_enigmail:%{__gzip} -dc %{SOURCE1} | %{__tar} -xf - -C mailnews/extensions}
178 /bin/sh %{SOURCE3}
179 %patch0 -p1
180 %{?with_enigmail:%patch1 -p1}
181 %patch2 -p1
182 %patch3 -p1
183 %patch4 -p1
184 %patch5 -p1
185 %patch6 -p1
186 %patch7 -p1
187 %patch8 -p0
188 %patch9 -p0
189 %patch10 -p2
190 %patch11 -p2
191 %patch12 -p1
192
193 %build
194 cd mozilla
195 cp -f %{_datadir}/automake/config.* mozilla/build/autoconf
196 cp -f %{_datadir}/automake/config.* mozilla/nsprpub/build/autoconf
197 cp -f %{_datadir}/automake/config.* directory/sdks/c-sdk/config/autoconf
198
199 install -d libxul-sdk
200 ln -snf %{_libdir}/xulrunner-sdk libxul-sdk/sdk
201
202 cat << EOF > .mozconfig
203 mk_add_options MOZ_OBJDIR=%{objdir}
204
205 export CFLAGS="%{rpmcflags} -fpermissive"
206 export CXXFLAGS="%{rpmcflags} -fpermissive"
207
208 %if %{with crashreporter}
209 export MOZ_DEBUG_SYMBOLS=1
210 %endif
211
212 # Options for 'configure' (same as command-line options).
213 ac_add_options --prefix=%{_prefix}
214 ac_add_options --exec-prefix=%{_exec_prefix}
215 ac_add_options --bindir=%{_bindir}
216 ac_add_options --sbindir=%{_sbindir}
217 ac_add_options --sysconfdir=%{_sysconfdir}
218 ac_add_options --datadir=%{_datadir}
219 ac_add_options --includedir=%{_includedir}
220 ac_add_options --libdir=%{_libdir}
221 ac_add_options --libexecdir=%{_libexecdir}
222 ac_add_options --localstatedir=%{_localstatedir}
223 ac_add_options --sharedstatedir=%{_sharedstatedir}
224 ac_add_options --mandir=%{_mandir}
225 ac_add_options --infodir=%{_infodir}
226 %if %{?debug:1}0
227 ac_add_options --disable-optimize
228 ac_add_options --enable-debug
229 ac_add_options --enable-debug-modules
230 ac_add_options --enable-debugger-info-modules
231 ac_add_options --enable-crash-on-assert
232 %else
233 ac_add_options --disable-debug
234 ac_add_options --disable-debug-modules
235 ac_add_options --disable-logging
236 ac_add_options --enable-optimize="%{rpmcflags} -Os"
237 %endif
238 ac_add_options --disable-strip
239 ac_add_options --disable-strip-libs
240 %if %{with tests}
241 ac_add_options --enable-tests
242 %else
243 ac_add_options --disable-tests
244 %endif
245 %if %{with gnomeui}
246 ac_add_options --enable-gnomeui
247 %else
248 ac_add_options --disable-gnomeui
249 %endif
250 %if %{with gnomevfs}
251 ac_add_options --enable-gnomevfs
252 %else
253 ac_add_options --disable-gnomevfs
254 %endif
255 %if %{with ldap}
256 ac_add_options --enable-ldap
257 ac_add_options --with-system-ldap
258 %else
259 ac_add_options --disable-ldap
260 %endif
261 %if %{with crashreporter}
262 ac_add_options --enable-crashreporter
263 %else
264 ac_add_options --disable-crashreporter
265 %endif
266 ac_add_options --disable-xterm-updates
267 ac_add_options --enable-postscript
268 %if %{with lightning}
269 ac_add_options --enable-calendar
270 %else
271 ac_add_options --disable-calendar
272 %endif
273 ac_add_options --disable-installer
274 ac_add_options --disable-jsd
275 ac_add_options --disable-updater
276 ac_add_options --disable-xprint
277 ac_add_options --disable-permissions
278 ac_add_options --disable-pref-extensions
279 ac_add_options --enable-canvas
280 ac_add_options --enable-crypto
281 ac_add_options --enable-mathml
282 ac_add_options --enable-pango
283 ac_add_options --enable-reorder
284 ac_add_options --enable-startup-notification
285 ac_add_options --enable-svg
286 ac_add_options --enable-system-cairo
287 ac_add_options --enable-system-hunspell
288 ac_add_options --enable-system-sqlite
289 ac_add_options --enable-xft
290 ac_add_options --enable-application=mail
291 ac_add_options --enable-default-toolkit=cairo-gtk2
292 ac_add_options --enable-xinerama
293 ac_add_options --with-distribution-id=org.pld-linux
294 ac_add_options --with-branding=icedove/branding
295 %if %{with xulrunner}
296 ac_add_options --with-libxul-sdk=$(pwd)/libxul-sdk
297 ac_add_options --enable-shared
298 %else
299 ac_add_options --enable-static
300 %endif
301 ac_add_options --with-pthreads
302 ac_add_options --with-system-bz2
303 ac_add_options --with-system-jpeg
304 ac_add_options --with-system-nspr
305 ac_add_options --with-system-nss
306 ac_add_options --with-system-png
307 ac_add_options --with-system-zlib
308 ac_add_options --enable-single-profile
309 ac_add_options --disable-profilesharing
310 ac_add_options --with-default-mozilla-five-home=%{_libdir}/%{name}
311 EOF
312
313 %{__make} -j1 -f client.mk build \
314         STRIP="/bin/true" \
315         MOZ_MAKE_FLAGS="%{?_smp_mflags}" \
316         CC="%{__cc}" \
317         CXX="%{__cxx}"
318
319 %if %{with crashreporter}
320 # create debuginfo for crash-stats.mozilla.com
321 %{__make} -j1 -C obj-%{_target_cpu} buildsymbols
322 %endif
323
324 %if %{with enigmail}
325 cd mailnews/extensions/enigmail
326 ./makemake -r -o %{objdir}
327 %{__make} -C %{objdir}/mailnews/extensions/enigmail \
328         STRIP="/bin/true" \
329         CC="%{__cc}" \
330         CXX="%{__cxx}"
331 %endif
332
333 %install
334 rm -rf $RPM_BUILD_ROOT
335 install -d $RPM_BUILD_ROOT{%{_bindir},%{_libdir}/%{name},%{_datadir}/%{name},%{_pixmapsdir},%{_desktopdir}}
336
337 cd %{objdir}
338 %{__make} -C mail/installer stage-package \
339         DESTDIR=$RPM_BUILD_ROOT \
340         MOZ_PKG_APPDIR=%{_libdir}/%{name} \
341         PKG_SKIP_STRIP=1
342
343 # Enable crash reporter for Firefox application
344 %if %{with crashreporter}
345 %{__sed} -i -e 's/\[Crash Reporter\]/[Crash Reporter]\nEnabled=1/' $RPM_BUILD_ROOT%{_libdir}/%{name}/application.ini
346
347 # Add debuginfo for crash-stats.mozilla.com
348 install -d $RPM_BUILD_ROOT%{_exec_prefix}/lib/debug%{_libdir}/%{name}
349 cp -a mozilla/dist/%{name}-%{version}.en-US.linux-*.crashreporter-symbols.zip $RPM_BUILD_ROOT%{_prefix}/lib/debug%{_libdir}/%{name}
350 %endif
351
352 # copy manually lightning files, somewhy they are not installed by make
353 cp -a mozilla/dist/bin/extensions/calendar-timezones@mozilla.org \
354         mozilla/dist/bin/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103} \
355         $RPM_BUILD_ROOT%{_libdir}/%{name}/extensions
356
357 # move arch independant ones to datadir
358 mv $RPM_BUILD_ROOT%{_libdir}/%{name}/chrome $RPM_BUILD_ROOT%{_datadir}/%{name}/chrome
359 mv $RPM_BUILD_ROOT%{_libdir}/%{name}/defaults $RPM_BUILD_ROOT%{_datadir}/%{name}/defaults
360 mv $RPM_BUILD_ROOT%{_libdir}/%{name}/greprefs $RPM_BUILD_ROOT%{_datadir}/%{name}/greprefs
361 mv $RPM_BUILD_ROOT%{_libdir}/%{name}/isp $RPM_BUILD_ROOT%{_datadir}/%{name}/isp
362 mv $RPM_BUILD_ROOT%{_libdir}/%{name}/modules $RPM_BUILD_ROOT%{_datadir}/%{name}/modules
363 mv $RPM_BUILD_ROOT%{_libdir}/%{name}/res $RPM_BUILD_ROOT%{_datadir}/%{name}/res
364 ln -s ../../share/%{name}/chrome $RPM_BUILD_ROOT%{_libdir}/%{name}/chrome
365 ln -s ../../share/%{name}/defaults $RPM_BUILD_ROOT%{_libdir}/%{name}/defaults
366 ln -s ../../share/%{name}/greprefs $RPM_BUILD_ROOT%{_libdir}/%{name}/greprefs
367 ln -s ../../share/%{name}/isp $RPM_BUILD_ROOT%{_libdir}/%{name}/isp
368 ln -s ../../share/%{name}/modules $RPM_BUILD_ROOT%{_libdir}/%{name}/modules
369 ln -s ../../share/%{name}/res $RPM_BUILD_ROOT%{_libdir}/%{name}/res
370
371 # dir for arch independant extensions besides arch dependant extensions
372 # see mozilla/xpcom/build/nsXULAppAPI.h
373 # XRE_SYS_LOCAL_EXTENSION_PARENT_DIR and XRE_SYS_SHARE_EXTENSION_PARENT_DIR
374 install -d $RPM_BUILD_ROOT%{_datadir}/%{name}/extensions
375
376 %{__rm} -r $RPM_BUILD_ROOT%{_libdir}/%{name}/dictionaries
377 ln -s %{_datadir}/myspell $RPM_BUILD_ROOT%{_libdir}/%{name}/dictionaries
378
379 %{__sed} -e 's,@LIBDIR@,%{_libdir},' %{SOURCE5} > $RPM_BUILD_ROOT%{_bindir}/icedove
380 ln -s %{name} $RPM_BUILD_ROOT%{_bindir}/thunderbird
381 ln -s %{name} $RPM_BUILD_ROOT%{_bindir}/mozilla-thunderbird
382
383 cp -p %{SOURCE4} $RPM_BUILD_ROOT%{_desktopdir}/%{name}.desktop
384 cp -p %{topdir}/mozilla/icedove/branding/content/icon64.png $RPM_BUILD_ROOT%{_pixmapsdir}/%{name}.png
385
386 # files created by regxpcom -register in post
387 touch $RPM_BUILD_ROOT%{_libdir}/%{name}/components/compreg.dat
388 touch $RPM_BUILD_ROOT%{_libdir}/%{name}/components/xpti.dat
389 cat << 'EOF' > $RPM_BUILD_ROOT%{_libdir}/%{name}/register
390 #!/bin/sh
391 umask 022
392 # make temporary HOME, as it attempts to touch files in $HOME/.mozilla
393 # dangerous if you run this with sudo with keep_env += HOME
394 # also TMPDIR could be pointing to sudo user's homedir so we reset that too.
395 t=$(mktemp -d)
396 %{__rm} -f %{_libdir}/%{name}/components/{compreg,xpti}.dat
397 TMPDIR= TMP= HOME=$t %{_libdir}/%{name}/icedove -register
398 rm -rf $t
399 EOF
400 chmod a+rx $RPM_BUILD_ROOT%{_libdir}/%{name}/register
401
402 %if %{with enigmail}
403 ext_dir=$RPM_BUILD_ROOT%{_libdir}/%{name}/extensions/\{847b3a00-7ab1-11d4-8f02-006008948af5\}
404 install -d $ext_dir/{chrome,components,defaults/preferences}
405 cd mozilla/dist/bin
406 cp -rfLp chrome/enigmail.jar $ext_dir/chrome
407 cp -rfLp chrome/enigmime.jar $ext_dir/chrome
408 cp -rfLp components/enig* $ext_dir/components
409 cp -rfLp components/libenigmime.so $ext_dir/components
410 cp -rfLp components/libipc.so $ext_dir/components
411 cp -rfLp components/ipc.xpt $ext_dir/components
412 cp -rfLp defaults/preferences/enigmail.js $ext_dir/defaults/preferences
413 cd -
414 cp -p %{topdir}/mozilla/mailnews/extensions/enigmail/package/install.rdf $ext_dir
415 cp -p %{topdir}/mozilla/mailnews/extensions/enigmail/package/chrome.manifest $ext_dir/chrome.manifest
416 %endif
417
418 # remove unecessary stuff
419 %{__rm} $RPM_BUILD_ROOT%{_libdir}/%{name}/README.txt
420 %{__rm} $RPM_BUILD_ROOT%{_libdir}/%{name}/components/components.list
421 %{__rm} $RPM_BUILD_ROOT%{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/components/components.list
422
423 # never package these. always remove
424 # nss
425 %{__rm} -f $RPM_BUILD_ROOT%{_libdir}/%{name}/lib{freebl3,nss3,nssckbi,nssdbm3,nssutil3,smime3,softokn3,ssl3}.*
426 # nspr
427 %{__rm} -f $RPM_BUILD_ROOT%{_libdir}/%{name}/lib{nspr4,plc4,plds4}.so
428 # mozldap
429 %{__rm} -f $RPM_BUILD_ROOT%{_libdir}/%{name}/lib{ldap,ldif,prldap,ssldap}60.so
430
431 %clean
432 rm -rf $RPM_BUILD_ROOT
433
434 %pretrans
435 if [ -d %{_libdir}/%{name}/dictionaries ] && [ ! -L %{_libdir}/%{name}/dictionaries ]; then
436         mv -v %{_libdir}/%{name}/dictionaries{,.rpmsave}
437 fi
438 for d in chrome defaults greprefs icons isp modules res; do
439         if [ -d %{_libdir}/%{name}/$d ] && [ ! -L %{_libdir}/%{name}/$d ]; then
440                 install -d %{_datadir}/%{name}
441                 mv %{_libdir}/%{name}/$d %{_datadir}/%{name}/$d
442         fi
443 done
444 exit 0
445
446 %post
447 %{_libdir}/%{name}/register || :
448
449 %files
450 %defattr(644,root,root,755)
451 %attr(755,root,root) %{_bindir}/icedove
452 %attr(755,root,root) %{_bindir}/mozilla-thunderbird
453 %attr(755,root,root) %{_bindir}/thunderbird
454 %dir %{_libdir}/%{name}
455 %{_libdir}/%{name}/application.ini
456 %{_libdir}/%{name}/platform.ini
457 %dir %{_libdir}/%{name}/components
458 %attr(755,root,root) %{_libdir}/%{name}/components/*.so
459 %{_libdir}/%{name}/components/*.js
460 %{_libdir}/%{name}/components/*.xpt
461 %attr(755,root,root) %{_libdir}/%{name}/libmozjs.so
462 %attr(755,root,root) %{_libdir}/%{name}/libxpcom.so
463 %attr(755,root,root) %{_libdir}/%{name}/libxpcom_core.so
464 %attr(755,root,root) %{_libdir}/%{name}/*.sh
465 %attr(755,root,root) %{_libdir}/%{name}/*-bin
466 %attr(755,root,root) %{_libdir}/%{name}/mozilla-xremote-client
467 %attr(755,root,root) %{_libdir}/%{name}/icedove
468 %attr(755,root,root) %{_libdir}/%{name}/register
469
470 # symlinks
471 %{_libdir}/%{name}/chrome
472 %{_libdir}/%{name}/defaults
473 %{_libdir}/%{name}/dictionaries
474 %{_libdir}/%{name}/greprefs
475 %{_libdir}/%{name}/isp
476 %{_libdir}/%{name}/modules
477 %{_libdir}/%{name}/res
478
479 %{_pixmapsdir}/*.png
480 %{_desktopdir}/*.desktop
481
482 %dir %{_datadir}/%{name}
483 %{_datadir}/%{name}/chrome
484 %{_datadir}/%{name}/defaults
485 %{_datadir}/%{name}/greprefs
486 %{_datadir}/%{name}/isp
487 %{_datadir}/%{name}/modules
488 %{_datadir}/%{name}/res
489 %{_datadir}/%{name}/extensions
490
491 %if %{with crashreporter}
492 %attr(755,root,root) %{_libdir}/%{name}/crashreporter
493 %{_libdir}/%{name}/crashreporter.ini
494 %{_libdir}/%{name}/Throbber-small.gif
495 %endif
496
497 %dir %{_libdir}/%{name}/extensions
498 %{_libdir}/%{name}/extensions/{972ce4c6-7e08-4474-a285-3208198ce6fd}
499
500 # files created by regxpcom -register
501 %ghost %{_libdir}/%{name}/components/compreg.dat
502 %ghost %{_libdir}/%{name}/components/xpti.dat
503
504 %if %{with lightning}
505 %files addon-lightning
506 %defattr(644,root,root,755)
507 %dir %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}
508 %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/defaults
509 %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/chrome
510 %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/chrome.manifest
511 %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/install.rdf
512 %dir %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/components
513 %attr(755,root,root) %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/components/*.so
514 %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/components/*.xpt
515 %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/components/*.js
516 %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/modules
517 %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/calendar-js
518 %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/timezones.sqlite
519
520 %{_libdir}/%{name}/extensions/calendar-timezones@mozilla.org
521 %endif
522
523 %if %{with enigmail}
524 %files addon-enigmail
525 %defattr(644,root,root,755)
526 %dir %{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}
527 %{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/defaults
528 %{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/chrome
529 %{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/chrome.manifest
530 %{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/install.rdf
531 %dir %{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/components
532 %attr(755,root,root) %{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/components/*.so
533 %{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/components/*.xpt
534 %{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/components/*.js
535 %endif
This page took 0.067301 seconds and 3 git commands to generate.