]> git.pld-linux.org Git - packages/thunderbird.git/blob - icedove.spec
- rel 1
[packages/thunderbird.git] / icedove.spec
1 # TODO:
2 # - separate spec for enigmail
3 # - build with system mozldap
4 #
5 # Conditional builds
6 %bcond_without  enigmail        # don't build enigmail - GPG/PGP support
7 %bcond_without  ldap            # disable e-mail address lookups in LDAP directories
8 %bcond_without  lightning       # disable Sunbird/Lightning calendar
9 %bcond_with     xulrunner       # system xulrunner
10 %bcond_with     crashreporter   # report crashes to crash-stats.mozilla.com
11
12 %if 0%{?_enable_debug_packages} != 1
13 %undefine       crashreporter
14 %endif
15
16 %define         enigmail_ver    1.6
17 %define         nspr_ver        4.9.3
18 %define         nss_ver         3.15.3.1
19
20 %define         xulrunner_ver   2:24.0
21
22 %if %{without xulrunner}
23 # The actual sqlite version (see RHBZ#480989):
24 %define         sqlite_build_version %(pkg-config --silence-errors --modversion sqlite3 2>/dev/null || echo ERROR)
25 %endif
26
27 Summary:        Icedove - email client
28 Summary(pl.UTF-8):      Icedove - klient poczty
29 Name:           icedove
30 Version:        24.2.0
31 Release:        1
32 License:        MPL 1.1 or GPL v2+ or LGPL v2.1+
33 Group:          X11/Applications/Mail
34 Source0:        http://releases.mozilla.org/pub/mozilla.org/thunderbird/releases/%{version}/source/thunderbird-%{version}.source.tar.bz2
35 # Source0-md5:  53d457a8ff97a305d975c20d1bebff04
36 Source1:        http://www.mozilla-enigmail.org/download/source/enigmail-%{enigmail_ver}.tar.gz
37 # Source1-md5:  4a2bbcb020bdb282a660fda8c70d5608
38 Source2:        %{name}-branding.tar.bz2
39 # Source2-md5:  d8e6897870bf288fdf264c0e9ef85f7d
40 Source3:        %{name}-rm_nonfree.sh
41 Source4:        %{name}.desktop
42 Source5:        %{name}.sh
43 Patch0:         %{name}-branding.patch
44 Patch1:         %{name}-enigmail-shared.patch
45 Patch3:         %{name}-fonts.patch
46 Patch6:         %{name}-prefs.patch
47 Patch7:         system-mozldap.patch
48 Patch8:         %{name}-makefile.patch
49 Patch10:        %{name}-extensiondir.patch
50 Patch11:        crashreporter.patch
51 Patch12:        no-subshell.patch
52 # Edit patch below and restore --system-site-packages when system virtualenv gets 1.7 upgrade
53 Patch13:        system-virtualenv.patch
54 Patch14:        gyp-slashism.patch
55 Patch15:        enable-addons.patch
56 URL:            http://www.pld-linux.org/Packages/Icedove
57 BuildRequires:  GConf2-devel >= 1.2.1
58 BuildRequires:  alsa-lib-devel
59 BuildRequires:  automake
60 BuildRequires:  bzip2-devel
61 BuildRequires:  cairo-devel >= 1.10
62 BuildRequires:  dbus-glib-devel >= 0.60
63 BuildRequires:  freetype-devel >= 1:2.1.8
64 BuildRequires:  glib2-devel >= 2.0
65 BuildRequires:  gstreamer0.10-devel
66 BuildRequires:  gstreamer0.10-plugins-base-devel
67 BuildRequires:  gtk+2-devel >= 2:2.10.0
68 BuildRequires:  hunspell-devel
69 BuildRequires:  libIDL-devel >= 0.8.0
70 BuildRequires:  libevent-devel
71 BuildRequires:  libiw-devel
72 # requires libjpeg-turbo implementing at least libjpeg 6b API
73 BuildRequires:  libjpeg-devel >= 6b
74 BuildRequires:  libjpeg-turbo-devel
75 BuildRequires:  libnotify-devel >= 0.4
76 BuildRequires:  libpng-devel >= 1.4.1
77 BuildRequires:  libstdc++-devel
78 BuildRequires:  mozldap-devel
79 BuildRequires:  nspr-devel >= 1:%{nspr_ver}
80 BuildRequires:  nss-devel >= 1:%{nss_ver}
81 BuildRequires:  pango-devel >= 1:1.14.0
82 BuildRequires:  perl-base >= 1:5.6
83 BuildRequires:  python-virtualenv
84 BuildRequires:  pkgconfig
85 BuildRequires:  python >= 1:2.5
86 BuildRequires:  sed >= 4.0
87 BuildRequires:  sqlite3-devel >= 3.7.4
88 BuildRequires:  startup-notification-devel >= 0.8
89 BuildRequires:  libvpx-devel >= 1.0.0
90 BuildRequires:  xorg-lib-libXext-devel
91 BuildRequires:  xorg-lib-libXinerama-devel
92 BuildRequires:  xorg-lib-libXt-devel
93 BuildRequires:  yasm
94 BuildRequires:  zip
95 %if %{with xulrunner}
96 BuildRequires:  xulrunner-devel >= %{xulrunner_ver}
97 %else
98 Requires:       myspell-common
99 Requires:       nspr >= 1:%{nspr_ver}
100 Requires:       nss >= 1:%{nss_ver}
101 Requires:       sqlite3 >= %{sqlite_build_version}
102 %endif
103 Requires(post): mktemp >= 1.5-18
104 %if %{with xulrunner}
105 %requires_eq_to xulrunner xulrunner-devel
106 %endif
107 Requires:       libjpeg-turbo
108 Obsoletes:      mozilla-thunderbird
109 Obsoletes:      mozilla-thunderbird-dictionary-en-US
110 Conflicts:      icedove-lang-resources < %{version}
111 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
112
113 %define         filterout_cpp           -D_FORTIFY_SOURCE=[0-9]+
114
115 # iceweasel/icedove/iceape provide their own versions
116 %define         _noautoprovfiles        %{_libdir}/%{name}/components
117 %if %{without xulrunner}
118 # we don't want these to satisfy packages depending on xulrunner
119 %define         _noautoprov             libmozalloc.so libxpcom.so libxul.so
120 # and as we don't provide them, don't require either
121 %define         _noautoreq              libmozalloc.so libxpcom.so libxul.so
122 %endif
123
124 %define         topdir          %{_builddir}/%{name}-%{version}
125 %define         objdir          %{topdir}/obj-%{_target_cpu}
126
127 %description
128 Icedove is an open-source, fast and portable email client.
129
130 %description -l pl.UTF-8
131 Icedove jest mającym otwarte źródła, szybkim i przenośnym klientem
132 poczty.
133
134 %package addon-lightning
135 Summary:        An integrated calendar for Icedove
136 Summary(pl.UTF-8):      Zintegrowany kalendarz dla Icedove
137 License:        MPL 1.1 or GPL v2+ or LGPL v2.1+
138 Group:          Applications/Networking
139 Requires:       %{name} = %{version}-%{release}
140
141 %description addon-lightning
142 Lightning is an calendar extension to Icedove email client.
143
144 %description addon-lightning -l pl.UTF-8
145 Lightning to rozszerzenie do klienta poczty Icedove dodające
146 funkcjonalność kalendarza.
147
148 %package addon-enigmail
149 Summary:        Extension for the authentication and encryption features provided by GnuPG
150 Summary(pl.UTF-8):      Rozszerzenie do uwierzytelniania i szyfrowania zapewnianego przez GnuPG
151 License:        MPL/LGPL
152 Group:          Applications/Networking
153 URL:            http://enigmail.mozdev.org/
154 Requires:       %{name} = %{version}-%{release}
155 Requires:       gnupg
156 Obsoletes:      mozilla-thunderbird-addon-enigmail
157
158 %description addon-enigmail
159 Enigmail is an extension to the Icedove mail client which allows users
160 to access the authentication and encryption features provided by
161 GnuPG.
162
163 Main Features:
164 - Encrypt/sign mail when sending, decrypt/authenticate received mail
165 - Support for inline-PGP (RFC 2440) and PGP/MIME (RFC 3156)
166 - Per-Account based encryption and signing defaults
167 - Per-Recipient rules for automated key selection, and
168   enabling/disabling encryption and signing
169 - OpenPGP key management interface
170
171 %description addon-enigmail -l pl.UTF-8
172 Enigmail to rozszerzenie klienta pocztowego Icedove pozwalające
173 użytkownikom na dostęp do uwierzytelniania i szyfrowania zapewnianego
174 przez GnuPG.
175
176 Główne możliwości:
177 - szyfrowanie/podpisywanie poczty przy wysyłaniu,
178   odszyfrowywanie/uwierzytelnianie poczty odebranej
179 - obsługa inline-PGP (RFC 2440) i PGP/MIME (RFC 3156)
180 - ustawienia domyślne szyfrowania i podpisywania dla każdego konta
181 - reguły automatycznego wyboru kluczy i włączenia szyfrowania oraz
182   podpisywania dla każdego adresata
183 - interfejs do zarządzania kluczami OpenPGP
184
185 %prep
186 %setup -qc
187 mv comm-esr24 mozilla
188 %setup -q -T -D -a2
189 cd mozilla
190 %{?with_enigmail:%{__gzip} -dc %{SOURCE1} | %{__tar} -xf - -C mailnews/extensions}
191 /bin/sh %{SOURCE3}
192 %patch0 -p1
193 %{?with_enigmail:%patch1 -p1}
194 %patch3 -p1
195 %patch6 -p1
196 %patch7 -p1
197 %patch8 -p2
198 %patch10 -p2
199 #patch11 -p2
200 %patch12 -p1
201 %patch13 -p1
202 %patch14 -p1
203 %patch15 -p1
204
205 # the entire check in that configure is so wrong, it's simpler to just workaround it here temporarily
206 %{__sed} -i -e 's|min_nss_version=3.15.3.1|min_nss_version=3.15.3|' mozilla/configure
207
208 %build
209 cd mozilla
210 cp -f %{_datadir}/automake/config.* mozilla/build/autoconf
211 cp -f %{_datadir}/automake/config.* mozilla/nsprpub/build/autoconf
212 cp -f %{_datadir}/automake/config.* ldap/sdks/c-sdk/config/autoconf
213
214 cat << EOF > .mozconfig
215 mk_add_options MOZ_OBJDIR=%{objdir}
216
217 export CFLAGS="%{rpmcflags}"
218 export CXXFLAGS="%{rpmcflags}"
219
220 %if %{with crashreporter}
221 export MOZ_DEBUG_SYMBOLS=1
222 %endif
223
224 # Options for 'configure' (same as command-line options).
225 ac_add_options --prefix=%{_prefix}
226 ac_add_options --exec-prefix=%{_exec_prefix}
227 ac_add_options --bindir=%{_bindir}
228 ac_add_options --sbindir=%{_sbindir}
229 ac_add_options --sysconfdir=%{_sysconfdir}
230 ac_add_options --datadir=%{_datadir}
231 ac_add_options --includedir=%{_includedir}
232 ac_add_options --libdir=%{_libdir}
233 ac_add_options --libexecdir=%{_libexecdir}
234 ac_add_options --localstatedir=%{_localstatedir}
235 ac_add_options --sharedstatedir=%{_sharedstatedir}
236 ac_add_options --mandir=%{_mandir}
237 ac_add_options --infodir=%{_infodir}
238 %if %{?debug:1}0
239 ac_add_options --disable-optimize
240 ac_add_options --enable-debug
241 ac_add_options --enable-debug-modules
242 ac_add_options --enable-debugger-info-modules
243 ac_add_options --enable-crash-on-assert
244 %else
245 ac_add_options --disable-debug
246 ac_add_options --disable-debug-modules
247 ac_add_options --disable-logging
248 ac_add_options --enable-optimize="%{rpmcflags} -Os"
249 %endif
250 ac_add_options --disable-strip
251 ac_add_options --disable-strip-libs
252 %if %{with tests}
253 ac_add_options --enable-tests
254 %else
255 ac_add_options --disable-tests
256 %endif
257 ac_add_options --enable-gio
258 ac_add_options --disable-gnomeui
259 ac_add_options --disable-gnomevfs
260 %if %{with ldap}
261 ac_add_options --enable-ldap
262 ac_add_options --with-system-ldap
263 %else
264 ac_add_options --disable-ldap
265 %endif
266 %if %{with crashreporter}
267 ac_add_options --enable-crashreporter
268 %else
269 ac_add_options --disable-crashreporter
270 %endif
271 ac_add_options --disable-xterm-updates
272 ac_add_options --enable-postscript
273 %if %{with lightning}
274 ac_add_options --enable-calendar
275 %else
276 ac_add_options --disable-calendar
277 %endif
278 ac_add_options --disable-elf-dynstr-gc
279 ac_add_options --disable-installer
280 ac_add_options --disable-javaxpcom
281 ac_add_options --disable-updater
282 ac_add_options --enable-crypto
283 ac_add_options --enable-libxul
284 ac_add_options --enable-pango
285 ac_add_options --enable-shared-js
286 ac_add_options --enable-startup-notification
287 ac_add_options --enable-system-cairo
288 ac_add_options --enable-system-hunspell
289 ac_add_options --enable-system-sqlite
290 ac_add_options --enable-application=mail
291 ac_add_options --with-distribution-id=org.pld-linux
292 ac_add_options --with-branding=icedove/branding
293 %if %{with xulrunner}
294 ac_add_options --with-system-libxul
295 ac_add_options --with-libxul-sdk=$(pkg-config --variable=sdkdir libxul)
296 %endif
297 ac_add_options --with-pthreads
298 ac_add_options --with-system-bz2
299 ac_add_options --with-system-ffi
300 ac_add_options --with-system-jpeg
301 ac_add_options --with-system-libevent
302 ac_add_options --with-system-libvpx
303 ac_add_options --with-system-nspr
304 ac_add_options --with-system-nss
305 ac_add_options --with-system-png
306 ac_add_options --with-system-zlib
307 ac_add_options --enable-single-profile
308 ac_add_options --disable-profilesharing
309 ac_add_options --with-default-mozilla-five-home=%{_libdir}/%{name}
310 EOF
311
312 mkdir -p %{objdir}/config
313 ln -s %{topdir}/mozilla/config/*.mk %{objdir}/config
314
315 %{__make} -j1 -f client.mk build \
316         STRIP="/bin/true" \
317         MOZ_MAKE_FLAGS="%{?_smp_mflags}" \
318         installdir=%{_libdir}/%{name} \
319         XLIBS="-lX11 -lXt" \
320         CC="%{__cc}" \
321         CXX="%{__cxx}"
322
323 %if %{with crashreporter}
324 # create debuginfo for crash-stats.mozilla.com
325 %{__make} -j1 -C obj-%{_target_cpu} buildsymbols
326 %endif
327
328 %if %{with enigmail}
329 cd mailnews/extensions/enigmail
330 ./makemake -r -o %{objdir}
331 %{__make} -j1 -C %{objdir}/mailnews/extensions/enigmail \
332         STRIP="/bin/true" \
333         CC="%{__cc}" \
334         CXX="%{__cxx}"
335
336 %{__make} -j1 -C %{objdir}/mailnews/extensions/enigmail xpi \
337         STRIP="/bin/true" \
338         CC="%{__cc}" \
339         CXX="%{__cxx}"
340 %endif
341
342 %install
343 rm -rf $RPM_BUILD_ROOT
344 install -d $RPM_BUILD_ROOT{%{_bindir},%{_libdir}/%{name},%{_datadir}/%{name},%{_pixmapsdir},%{_desktopdir}}
345
346 cd %{objdir}
347 %{__make} -C mail/installer stage-package \
348         DESTDIR=$RPM_BUILD_ROOT \
349         installdir=%{_libdir}/%{name} \
350         PKG_SKIP_STRIP=1
351
352 %{__make} -C icedove/branding install \
353         DESTDIR=$RPM_BUILD_ROOT
354
355 cp -a mozilla/dist/icedove/* $RPM_BUILD_ROOT%{_libdir}/%{name}/
356  
357 %if %{with xulrunner}
358 # needed to find mozilla runtime
359 ln -s ../xulrunner $RPM_BUILD_ROOT%{_libdir}/%{name}/xulrunner
360 %endif
361  
362 # Enable crash reporter for Thunderbird application
363 %if %{with crashreporter}
364 %{__sed} -i -e 's/\[Crash Reporter\]/[Crash Reporter]\nEnabled=1/' $RPM_BUILD_ROOT%{_libdir}/%{name}/application.ini
365
366 # Add debuginfo for crash-stats.mozilla.com
367 install -d $RPM_BUILD_ROOT%{_exec_prefix}/lib/debug%{_libdir}/%{name}
368 cp -a mozilla/dist/%{name}-%{version}.en-US.linux-*.crashreporter-symbols.zip $RPM_BUILD_ROOT%{_prefix}/lib/debug%{_libdir}/%{name}
369 %endif
370
371 # copy manually lightning files, somewhy they are not installed by make
372 cp -a mozilla/dist/bin/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103} \
373         $RPM_BUILD_ROOT%{_libdir}/%{name}/extensions
374
375 # move arch independant ones to datadir
376 mv $RPM_BUILD_ROOT%{_libdir}/%{name}/searchplugins $RPM_BUILD_ROOT%{_datadir}/%{name}/searchplugins
377 ln -s ../../share/%{name}/searchplugins $RPM_BUILD_ROOT%{_libdir}/%{name}/searchplugins
378
379 # dir for arch independant extensions besides arch dependant extensions
380 # see mozilla/xpcom/build/nsXULAppAPI.h
381 # XRE_SYS_LOCAL_EXTENSION_PARENT_DIR and XRE_SYS_SHARE_EXTENSION_PARENT_DIR
382 install -d $RPM_BUILD_ROOT%{_datadir}/%{name}/extensions
383
384 %if %{without xulrunner}
385 %{__rm} -r $RPM_BUILD_ROOT%{_libdir}/%{name}/dictionaries
386 ln -s %{_datadir}/myspell $RPM_BUILD_ROOT%{_libdir}/%{name}/dictionaries
387 %endif
388
389 %{__sed} -e "s|%MOZAPPDIR%|%{_libdir}/%{name}|" \
390          -e "s|%MOZ_APP_DISPLAYNAME%|Icedove|" \
391         %{topdir}/mozilla/mozilla/build/unix/mozilla.in > $RPM_BUILD_ROOT%{_libdir}/%{name}/icedove
392
393 %{__sed} -e 's,@LIBDIR@,%{_libdir},' %{SOURCE5} > $RPM_BUILD_ROOT%{_bindir}/icedove
394 ln -s %{name} $RPM_BUILD_ROOT%{_bindir}/thunderbird
395 ln -s %{name} $RPM_BUILD_ROOT%{_bindir}/mozilla-thunderbird
396
397 # install icons and desktop file
398 cp -p %{topdir}/mozilla/icedove/branding/content/icon64.png $RPM_BUILD_ROOT%{_pixmapsdir}/%{name}.png
399 for i in 16 32 48 64 128 256; do
400         install -d $RPM_BUILD_ROOT%{_iconsdir}/hicolor/${i}x${i}/apps
401         cp -a %{topdir}/mozilla/icedove/branding/icedove${i}.png \
402                 $RPM_BUILD_ROOT%{_iconsdir}/hicolor/${i}x${i}/apps/icedove.png
403 done
404 install -d $RPM_BUILD_ROOT%{_iconsdir}/hicolor/scalable/apps
405 cp -a %{topdir}/mozilla/icedove/branding/icedove.svg $RPM_BUILD_ROOT%{_iconsdir}/hicolor/scalable/apps/icedove.svg
406
407 cp -p %{SOURCE4} $RPM_BUILD_ROOT%{_desktopdir}/%{name}.desktop
408
409 # files created by regxpcom -register in post
410 touch $RPM_BUILD_ROOT%{_libdir}/%{name}/components/compreg.dat
411 touch $RPM_BUILD_ROOT%{_libdir}/%{name}/components/xpti.dat
412 cat << 'EOF' > $RPM_BUILD_ROOT%{_libdir}/%{name}/register
413 #!/bin/sh
414 umask 022
415 # make temporary HOME, as it attempts to touch files in $HOME/.mozilla
416 # dangerous if you run this with sudo with keep_env += HOME
417 # also TMPDIR could be pointing to sudo user's homedir so we reset that too.
418 t=$(mktemp -d)
419 %{__rm} -f %{_libdir}/%{name}/components/{compreg,xpti}.dat
420 TMPDIR= TMP= HOME=$t %{_libdir}/%{name}/icedove -register
421 rm -rf $t
422 EOF
423 chmod a+rx $RPM_BUILD_ROOT%{_libdir}/%{name}/register
424
425 %if %{with enigmail}
426 ext_dir=$RPM_BUILD_ROOT%{_libdir}/%{name}/extensions/\{847b3a00-7ab1-11d4-8f02-006008948af5\}
427 install -d $ext_dir/{chrome,components,defaults/preferences,modules}
428 cd mozilla/dist/bin
429 cp -rfLp chrome/enigmail.jar $ext_dir/chrome
430 cp -rfLp components/enig* $ext_dir/components
431 cp -rfLp defaults/preferences/enigmail.js $ext_dir/defaults/preferences
432 cp -rfLp modules/{commonFuncs,enigmailCommon,keyManagement,pipeConsole,subprocess}.jsm $ext_dir/modules
433 cp -rfLp modules/{subprocess_worker_unix,subprocess_worker_win}.js $ext_dir/modules
434 cd -
435 cp -p %{topdir}/mozilla/mailnews/extensions/enigmail/package/install.rdf $ext_dir
436 cp -p %{topdir}/mozilla/mailnews/extensions/enigmail/package/chrome.manifest $ext_dir/chrome.manifest
437 %endif
438
439 # mozldap
440 %{__sed} -i '/lib\(ldap\|ldif\|prldap\)60.so/d' $RPM_BUILD_ROOT%{_libdir}/%{name}/dependentlibs.list
441 %{__rm} $RPM_BUILD_ROOT%{_libdir}/%{name}/lib{ldap,ldif,prldap}60.so
442
443 %clean
444 rm -rf $RPM_BUILD_ROOT
445
446 %pretrans
447 if [ -d %{_libdir}/%{name}/dictionaries ] && [ ! -L %{_libdir}/%{name}/dictionaries ]; then
448         mv -v %{_libdir}/%{name}/dictionaries{,.rpmsave}
449 fi
450 for d in chrome defaults icons isp modules res searchplugins; do
451         if [ -d %{_libdir}/%{name}/$d ] && [ ! -L %{_libdir}/%{name}/$d ]; then
452                 install -d %{_datadir}/%{name}
453                 mv %{_libdir}/%{name}/$d %{_datadir}/%{name}/$d
454         fi
455 done
456 exit 0
457
458 %post
459 %{_libdir}/%{name}/register || :
460
461 %files
462 %defattr(644,root,root,755)
463 %attr(755,root,root) %{_bindir}/icedove
464 %attr(755,root,root) %{_bindir}/mozilla-thunderbird
465 %attr(755,root,root) %{_bindir}/thunderbird
466 %dir %{_libdir}/%{name}
467 %{_libdir}/%{name}/application.ini
468 %{_libdir}/%{name}/blocklist.xml
469 %{_libdir}/%{name}/chrome.manifest
470 %dir %{_libdir}/%{name}/components
471 %{_libdir}/%{name}/components/components.manifest
472 %attr(755,root,root) %{_libdir}/%{name}/*.sh
473 %attr(755,root,root) %{_libdir}/%{name}/*-bin
474 %attr(755,root,root) %{_libdir}/%{name}/icedove
475 %attr(755,root,root) %{_libdir}/%{name}/register
476 %{_libdir}/%{name}/omni.ja
477 %if %{without xulrunner}
478 %{_libdir}/%{name}/dependentlibs.list
479 %{_libdir}/%{name}/platform.ini
480 #%{_libdir}/%{name}/greprefs.js
481 %attr(755,root,root) %{_libdir}/%{name}/components/*.so
482 %attr(755,root,root) %{_libdir}/%{name}/libmozalloc.so
483 %attr(755,root,root) %{_libdir}/%{name}/libmozjs.so
484 %attr(755,root,root) %{_libdir}/%{name}/libxul.so
485 %attr(755,root,root) %{_libdir}/%{name}/mozilla-xremote-client
486 %attr(755,root,root) %{_libdir}/%{name}/plugin-container
487 %endif
488
489 # symlinks
490 %{_libdir}/%{name}/chrome
491 %{_libdir}/%{name}/defaults
492 %{_libdir}/%{name}/isp
493 #%{_libdir}/%{name}/modules
494 %{_libdir}/%{name}/searchplugins
495 %if %{with xulrunner}
496 %{_libdir}/%{name}/xulrunner
497 %else
498 %{_libdir}/%{name}/dictionaries
499 %endif
500
501 %{_pixmapsdir}/icedove.png
502 %{_desktopdir}/icedove.desktop
503
504 %dir %{_datadir}/%{name}
505 %{_datadir}/%{name}/extensions
506 %{_datadir}/%{name}/searchplugins
507
508 %if %{with crashreporter}
509 %attr(755,root,root) %{_libdir}/%{name}/crashreporter
510 %{_libdir}/%{name}/crashreporter.ini
511 %{_libdir}/%{name}/Throbber-small.gif
512 %endif
513
514 %dir %{_libdir}/%{name}/extensions
515 %{_libdir}/%{name}/extensions/{972ce4c6-7e08-4474-a285-3208198ce6fd}
516
517 # files created by regxpcom -register
518 %ghost %{_libdir}/%{name}/components/compreg.dat
519 %ghost %{_libdir}/%{name}/components/xpti.dat
520
521 %{_iconsdir}/hicolor/*/apps/icedove.*
522
523 %if %{with lightning}
524 %files addon-lightning
525 %defattr(644,root,root,755)
526 %dir %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}
527 %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/application.ini
528 %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/chrome
529 %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/chrome.manifest
530 %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/defaults
531 %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/install.rdf
532 %dir %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/components
533 %attr(755,root,root) %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/components/*.so
534 %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/components/*.js
535 %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/components/*.manifest
536 %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/components/*.xpt
537 %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/modules
538 %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/calendar-js
539 %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/timezones.sqlite
540 %endif
541
542 %if %{with enigmail}
543 %files addon-enigmail
544 %defattr(644,root,root,755)
545 %dir %{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}
546 %{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/defaults
547 %{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/chrome
548 %{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/chrome.manifest
549 %{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/install.rdf
550 %dir %{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/components
551 %{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/components/*.xpt
552 %{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/components/*.js
553 %dir %{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/modules
554 %{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/modules/*.jsm
555 %{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/modules/*.js
556 %endif
This page took 0.10815 seconds and 3 git commands to generate.