]> git.pld-linux.org Git - packages/systemd.git/blame - systemd.spec
- R /etc/os-release (http://lists.freedesktop.org/archives/systemd-devel/2012-Februar...
[packages/systemd.git] / systemd.spec
CommitLineData
5d32f234 1#
d374e721
JR
2# TODO:
3# - remove compat-pld-var-run.tmpfiles and maybe tmpfiles-not-fatal.patch
4# after enough packages provide their own tmpfiles.d configs for
5# /var/run directories
6#
c3037397 7# Conditional build:
6c89bbd4
ER
8%bcond_without audit # without audit support
9%bcond_without cryptsetup # without cryptsetup support
23107006
TP
10%bcond_without gtk # build gtk tools
11%bcond_without pam # PAM authentication support
4389e6f9 12%bcond_with plymouth # plymouth support
23107006
TP
13%bcond_without selinux # without SELinux support
14%bcond_without tcpd # libwrap (tcp_wrappers) support
9c0b975d 15
c3037397 16Summary: A System and Service Manager
ede8d3e5 17Summary(pl.UTF-8): systemd - zarządca systemu i usług dla Linuksa
18Name: systemd
4389e6f9 19Version: 42
fcfde7e0 20Release: 1
ede8d3e5 21License: GPL v2+
22Group: Base
440d1d13 23Source0: http://www.freedesktop.org/software/systemd/%{name}-%{version}.tar.xz
4389e6f9 24# Source0-md5: 7686b44e368d2523901d3e903ed4dcea
4f25b6ac 25Source1: %{name}-sysv-convert
b0980573 26Source2: %{name}_booted.c
f1586299
JR
27Source3: ifup@.service
28Source4: network-post.service
29Source5: network.service
5c8fe698
JR
30Source6: compat-pld-media.tmpfiles
31Source7: compat-pld-var-run.tmpfiles
7619c097 32Patch0: target-pld.patch
252e1bad 33Patch1: config-pld.patch
8e088cd5 34Patch2: shut-sysv-up.patch
2e1f31c8 35Patch3: pld-sysv-network.patch
d374e721 36Patch4: tmpfiles-not-fatal.patch
ede8d3e5 37URL: http://www.freedesktop.org/wiki/Software/systemd
5b9bde26 38BuildRequires: acl-devel
6c89bbd4 39%{?with_audit:BuildRequires: audit-libs-devel}
6e34428f
MB
40BuildRequires: autoconf >= 2.63
41BuildRequires: automake >= 1:1.11
42%{?with_cryptsetup:BuildRequires: cryptsetup-luks-devel}
23107006 43BuildRequires: dbus-devel >= 1.3.2
c3037397 44BuildRequires: docbook-style-xsl
23107006
TP
45%if %{with gtk}
46BuildRequires: glib2-devel >= 1:2.26.1
47BuildRequires: gtk+2-devel >= 2:2.24.0
a86320a6 48BuildRequires: libgee-devel
23107006
TP
49BuildRequires: libnotify-devel >= 0.7.0
50%endif
9cd79e34 51BuildRequires: binutils >= 3:2.22.52.0.1-2
3fc7a1cc 52BuildRequires: gperf
5b9bde26 53BuildRequires: intltool >= 0.40.0
4389e6f9 54BuildRequires: kmod-devel >= 5
b82d0bf2 55BuildRequires: libcap-devel
6c89bbd4
ER
56%{?with_selinux:BuildRequires: libselinux-devel}
57BuildRequires: libtool >= 2:2.2
58%{?with_tcpd:BuildRequires: libwrap-devel}
6e34428f 59BuildRequires: libxslt-progs
961baf80 60BuildRequires: m4
6c89bbd4 61%{?with_pam:BuildRequires: pam-devel}
4389e6f9 62%{?with_plymouth:BuildRequires: plymouth-devel}
23107006 63BuildRequires: pkgconfig >= 0.9.0
4cc1cb1d 64BuildRequires: rpmbuild(macros) >= 1.627
58fd72e9 65BuildRequires: udev-devel >= 1:172
5b9bde26
JB
66# not required for building from release (which contains *.c for *.vala)
67#BuildRequires: vala >= 0.10.0
58fd72e9 68BuildRequires: xz-devel
011bccb6 69Requires: %{name}-libs = %{version}-%{release}
c3037397 70Requires: %{name}-units = %{version}-%{release}
58d6217a 71Requires: /etc/os-release
2ff27c26 72Requires: SysVinit-tools
37b8df82 73Requires: agetty
b0980573 74Requires: dbus >= 1.4.16-6
7cb5cfc8 75Requires: filesystem >= 4.0-2
851fb4d8 76Requires: rc-scripts >= 0.4.5.1-7
56701781 77Requires: setup >= 2.8.0-2
b0980573 78Requires: udev-core >= 1:175-5
fe6ae5ab 79Requires: udev-libs >= 1:172
e3134fe0 80Requires: virtual(module-tools)
b0980573 81Suggests: ConsoleKit
2a61be78 82Suggests: fsck >= 2.20
e3134fe0 83Suggests: kmod >= 5
4b15486a 84Suggests: nss_myhostname
2a61be78 85# python modules required by systemd-analyze
b0980573 86Suggests: %{name}-no-compat-tmpfiles
2a61be78
TP
87Suggests: python-dbus
88Suggests: python-modules
c35aa49c 89Suggests: service(klogd)
1cdd35cf 90Suggests: service(syslog)
fda563d5 91Provides: udev-acl
3baeefca
PG
92# systemd takes care of that and causes problems
93Conflicts: binfmt-detector
a6203073 94# sytemd wants pam with pam_systemd.so in system-auth...
3b292a99 95Conflicts: pam < 1:1.1.5-5
a6203073
JR
96# ...and sudo hates it
97Conflicts: sudo < 1:1.7.8p2-4
ff9cae1d 98Conflicts: upstart
ede8d3e5 99BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
100
85879912
ER
101%define _libexecdir %{_prefix}/lib
102
ede8d3e5 103%description
1c239f8b 104systemd is a system and service manager for Linux, compatible with
ede8d3e5 105SysV and LSB init scripts. systemd provides aggressive parallelization
106capabilities, uses socket and D-Bus activation for starting services,
107offers on-demand starting of daemons, keeps track of processes using
108Linux cgroups, supports snapshotting and restoring of the system
109state, maintains mount and automount points and implements an
110elaborate transactional dependency-based service control logic. It can
1c239f8b 111work as a drop-in replacement for sysvinit.
ede8d3e5 112
113%description -l pl.UTF-8
114systemd jest zarządcą systemu i usług dla Linuksa, kompatybilny ze
115skryptami SysV i LSB. systemd udostępnia rozbudowane zdolności
116paralelizacji, do uruchamiania usług używa socketów oraz D-Busa,
117oferuje uruchamianie usług na życzenie, monitoruje procesy używając
118linuksowych cgroups, wspomaga zapisywanie (snapshot) i odczytywanie
119(restore) stanu systemu, zarządza (auto)mount pointami oraz
120implementuje starannie opracowaną transakcjonalną, bazującą na
d45dfc3a 121zależnościach logikę kontroli usług. Może pracować jako zastępca dla
ede8d3e5 122sysvinit.
123
c97dacdd
TP
124%package init
125Summary: systemd /sbin/init and LSB/SysV compatibility symlinks
5b9bde26 126Summary(pl.UTF-8): /sbin/init z systemd i dowiązania dla kompatybilności z LSB/SysV
c97dacdd 127Group: Base
d6829efa 128Requires: systemd
c97dacdd
TP
129Provides: readahead = 1:1.5.7-3
130Provides: virtual(init-daemon)
131Obsoletes: SysVinit
132Obsoletes: readahead < 1:1.5.7-3
133Obsoletes: virtual(init-daemon)
134
135%description init
136Install this package when you are ready to final switch to systemd.
137
5b9bde26
JB
138%description init -l pl.UTF-8
139Ten pakiet należy zainstalować po przygotowaniu się do ostatecznego
140przejścia na systemd.
141
c3037397
ER
142%package units
143Summary: Configuration files, directories and installation tool for systemd
5b9bde26 144Summary(pl.UTF-8): Pliki konfiguracyjne, katalogi i narzędzie instalacyjne dla systemd
c3037397 145Group: Base
c3037397 146Requires(post): coreutils
a8d86f01 147Requires(post): /bin/awk
c3037397
ER
148
149%description units
150Basic configuration files, directories and installation tool for the
151systemd system and service manager.
152
f341cd9b 153This is common config, use %{_sysconfdir}/systemd/system to override.
10ffdcd2 154
5b9bde26
JB
155%description units -l pl.UTF-8
156Podstawowe pliki konfiguracyjne, katalogi i narzędzie instalacyjne dla
157zarządcy systemu i usług systemd.
158
159Ten pakiet zawiera ogólną konfigurację, ustawienia można nadpisać
160poprzez katalog %{_sysconfdir}/systemd/system.
161
c3037397
ER
162%package gtk
163Summary: Graphical frontend for systemd
5b9bde26 164Summary(pl.UTF-8): Graficzny interfejs do systemd
c3037397
ER
165Group: Base
166Requires: %{name} = %{version}-%{release}
167Requires: polkit
168
169%description gtk
170Graphical front-end for systemd.
171
5b9bde26
JB
172%description gtk -l pl.UTF-8
173Graficzny interfejs do systemd.
6c89bbd4 174
011bccb6 175%package libs
5b9bde26
JB
176Summary: Shared systemd libraries
177Summary(pl.UTF-8): Biblioteki współdzielone systemd
011bccb6
BZ
178Group: Libraries
179
180%description libs
5b9bde26
JB
181Shared systemd libraries.
182
183%description libs -l pl.UTF-8
184Biblioteki współdzielone systemd.
011bccb6 185
961baf80
AF
186%package devel
187Summary: Header files for systemd libraries
188Summary(pl.UTF-8): Pliki nagłówkowe bibliotek systemd
189Group: Development/Libraries
011bccb6 190Requires: %{name}-libs = %{version}-%{release}
961baf80
AF
191
192%description devel
193Header files for systemd libraries.
194
195%description devel -l pl.UTF-8
196Pliki nagłówkowe bibliotek systemd.
197
5b9bde26
JB
198%package -n bash-completion-systemd
199Summary: bash-completion for systemd
200Summary(pl.UTF-8): Bashowe dopełnianie składni dla systemd
201Group: Applications/Shells
202Requires: %{name}
203Requires: bash-completion
204
205%description -n bash-completion-systemd
206bash-completion for systemd.
207
208%description -n bash-completion-systemd -l pl.UTF-8
209Bashowe dopełnianie składni dla systemd
210
ae4d0acb
JR
211%package no-compat-tmpfiles
212Summary: Force update of packages that provide tmpfiles.d configuration
213Group: Base
214Requires(post): sed > 4.0
215Conflicts: ConsoleKit-dirs < 0.4.5-7
216Conflicts: NetworkManager < 2:0.9.2.0-3
217Conflicts: Zope < 2.11.8-2
218Conflicts: amavisd-new < 1:2.7.0-1
ae4d0acb
JR
219Conflicts: apache-base < 2.2.21-4
220Conflicts: apache-mod_bw < 0.92-3
221Conflicts: apache-mod_fastcgi < 2.4.6-6
b0980573
ŁK
222Conflicts: apache1-base < 1.3.42-5
223Conflicts: apache1-mod_fastcgi < 2.4.6-2
ae4d0acb
JR
224Conflicts: asterisk < 10.0.1-2
225Conflicts: autossh-init < 1.4b-3
226Conflicts: balance < 3.54-2
227Conflicts: bind < 7:9.8.1.P1-4
228Conflicts: bopm < 3.1.3-4
229Conflicts: callweaver < 1.2.1-9
230Conflicts: cassandra-bin < 0.8.9-2
231Conflicts: clamav < 0.97.3-3
232Conflicts: cups < 1:1.5.0-10
233Conflicts: dbus < 1.4.16-4
234Conflicts: dovecot < 1:2.0.16-3
235Conflicts: dspam < 3.9.0-6
236Conflicts: fail2ban < 0.8.4-4
237Conflicts: filesystem < 4.0-3
238Conflicts: gammu-smsd < 1:1.31.0-3
a6203073
JR
239# Break gdm2.20 installs
240#Conflicts: gdm < 2:3.2.1.1-9
ae4d0acb
JR
241Conflicts: greylistd < 0.8.8-2
242Conflicts: inn < 2.4.6-7
243Conflicts: ipsec-tools < 0.8.0-3
244Conflicts: jabber-common < 0-9
245Conflicts: laptop-mode-tools < 1.58-2
246Conflicts: libgpod < 0.8.0-6
247Conflicts: libvirt-utils < 0.9.9-4
248Conflicts: lighttpd < 1.4.30-5
249Conflicts: lirc < 0.9.0-20
250Conflicts: mailman < 5:2.1.14-4
251Conflicts: memcached < 1.4.11-2
252Conflicts: mpd < 0.16.5-4
253Conflicts: mrtg < 2.17.0-3
254Conflicts: munin-common < 1.4.5-5
255Conflicts: nagios-nrpe < 2.13-2
256Conflicts: ndisc6-rdnssd < 1.0.1-3
257Conflicts: nscd < 6:2.14.1-5
258Conflicts: nss_ldapd-nslcd < 0.8.4-2
259Conflicts: openct < 0.6.20-3
260Conflicts: openl2tp < 1.8-3
261Conflicts: openldap-overlay-nssov < 2.4.28-4
262Conflicts: openldap-servers < 2.4.28-4
263Conflicts: openvpn < 2.2.2-2
ae4d0acb
JR
264Conflicts: pam-pam_mount < 2.12-3
265Conflicts: pam-pam_ssh < 1.97-2
266Conflicts: pcsc-lite < 1.8.1-2
267Conflicts: php-dirs < 1.2-3
268Conflicts: policyd < 2.0.10-3
269Conflicts: pound < 2.6-2
270Conflicts: pptp < 1.7.2-3
271Conflicts: proftpd-common < 2:1.3.4a-2
272Conflicts: pulseaudio-server < 1.1-2
273Conflicts: quagga < 0.99.20-3
274Conflicts: radvd < 1.8.5-2
275Conflicts: rc-scripts < 0.4.5.2-3
276Conflicts: red5 < 0.9.0-2
277Conflicts: redis-server < 2.4.2-4
278Conflicts: smokeping < 2.4.2-10
279Conflicts: smtp-gated < 1.4.17-2
280Conflicts: socat < 1.7.2.0-2
281Conflicts: speech-dispatcher < 0.7.1-2
282Conflicts: sphinx < 2.0.3-4
283Conflicts: splashutils < 1.5.4.3-3
284Conflicts: stunnel < 4.50-2
ae4d0acb
JR
285Conflicts: tenshi < 0.12-2
286Conflicts: tor < 0.2.2.35-2
287Conflicts: ucarp < 1.5.2-3
288Conflicts: udisks < 1.0.4-3
289Conflicts: util-vserver < 0.30.216-1.pre3002.3
290Conflicts: vpnc < 0.5.3-2
291Conflicts: web2ldap < 1.1.0rc1-2
292Conflicts: wesnoth-server < 1:1.10-2
293Conflicts: wpa_supplicant < 0.7.3-10
294Conflicts: xl2tpd < 1.3.0-2
295
296%description no-compat-tmpfiles
297Force update of packages that provide tmpfiles.d configuration
298
ede8d3e5 299%prep
300%setup -q
4c5b5ab6 301%patch0 -p1
252e1bad 302%patch1 -p1
a6203073 303%patch2 -p1
942c9075 304%patch3 -p1
d374e721 305%patch4 -p1
b77423ae 306cp -p %{SOURCE2} src/systemd_booted.c
ede8d3e5 307
308%build
4c5b5ab6 309%{__aclocal} -I m4
ede8d3e5 310%{__autoconf}
6e34428f 311%{__autoheader}
ede8d3e5 312%{__automake}
9c0b975d 313%configure \
6c89bbd4
ER
314 %{__enable_disable audit} \
315 %{__enable_disable cryptsetup libcryptsetup} \
316 %{__enable_disable gtk} \
317 %{__enable_disable pam} \
4389e6f9 318 %{__enable_disable plymouth} \
6c89bbd4
ER
319 %{__enable_disable selinux} \
320 %{__enable_disable tcpd tcpwrap} \
321 --disable-silent-rules \
961baf80 322 --disable-static \
5b9bde26 323 --with-distro=pld \
391eea76 324 --with-rootprefix= \
4389e6f9
JR
325 --with-rootlibdir=/%{_lib} \
326 --enable-split-usr
e1d9cc15 327
ede8d3e5 328%{__make}
b77423ae 329./libtool --mode=link --tag=CC %{__cc} %{rpmcppflags} %{rpmcflags} -o systemd_booted %{rpmldflags} src/systemd_booted.c -L. -lsystemd-daemon
ede8d3e5 330
331%install
332rm -rf $RPM_BUILD_ROOT
23107006 333
ede8d3e5 334%{__make} install \
335 DESTDIR=$RPM_BUILD_ROOT
336
b77423ae
AF
337./libtool --mode=install install -m755 systemd_booted $RPM_BUILD_ROOT/bin/systemd_booted
338
4389e6f9
JR
339# Main binary has been moved, but we don't want to break existing installs
340ln -s ../lib/systemd/systemd $RPM_BUILD_ROOT/bin/systemd
341
1dcb74bb 342# Create SysV compatibility symlinks. systemctl/systemd are smart
2a61be78 343# enough to detect the way they were called
c28b0c1c 344install -d $RPM_BUILD_ROOT/sbin
4389e6f9 345ln -s ../lib/systemd/systemd $RPM_BUILD_ROOT/sbin/init
1dcb74bb 346ln -s ../bin/systemctl $RPM_BUILD_ROOT/sbin/halt
347ln -s ../bin/systemctl $RPM_BUILD_ROOT/sbin/poweroff
23107006
TP
348ln -s ../bin/systemctl $RPM_BUILD_ROOT/sbin/reboot
349ln -s ../bin/systemctl $RPM_BUILD_ROOT/sbin/runlevel
1dcb74bb 350ln -s ../bin/systemctl $RPM_BUILD_ROOT/sbin/shutdown
351ln -s ../bin/systemctl $RPM_BUILD_ROOT/sbin/telinit
1dcb74bb 352
5d32f234 353ln -s ../modules $RPM_BUILD_ROOT%{_sysconfdir}/modules-load.d/modules.conf
4cc1cb1d
ER
354# disable random and console SYSV service
355ln -s /dev/null $RPM_BUILD_ROOT%{systemdunitdir}/random.service
356ln -s /dev/null $RPM_BUILD_ROOT%{systemdunitdir}/console.service
5d32f234 357
f1586299 358# add static (non-NetworkManager) networking
4cc1cb1d
ER
359install %{SOURCE3} $RPM_BUILD_ROOT%{systemdunitdir}/ifup@.service
360install %{SOURCE4} $RPM_BUILD_ROOT%{systemdunitdir}/network-post.service
361install %{SOURCE5} $RPM_BUILD_ROOT%{systemdunitdir}/network.service
f1586299 362
5c8fe698
JR
363# install compatibility tmpfiles configs
364install %{SOURCE6} $RPM_BUILD_ROOT%{_sysconfdir}/tmpfiles.d/compat-pld-media.conf
d374e721 365install %{SOURCE7} $RPM_BUILD_ROOT%{_sysconfdir}/tmpfiles.d/compat-pld-var-run.conf
5c8fe698 366
2a61be78
TP
367# All wants links are created at %post to make sure they are not owned
368# and hence overriden by rpm if the user deletes them (missingok?)
23107006 369%{__rm} -r $RPM_BUILD_ROOT%{_sysconfdir}/systemd/system/*.target.wants
c3037397 370
e64703a8 371# it is in rc-scripts pkg
4cc1cb1d 372%{__rm} $RPM_BUILD_ROOT%{systemdunitdir}/rc-local.service
e64703a8 373
2a61be78
TP
374# Make sure these directories are properly owned:
375# - halt,kexec,poweroff,reboot: generic ones used by ConsoleKit-systemd,
376# - syslog _might_ be used by some syslog implementation (none for now),
377# - isn't dbus populated by dbus-systemd only (so to be moved there)?
4cc1cb1d 378install -d $RPM_BUILD_ROOT%{systemdunitdir}/{dbus,halt,kexec,poweroff,reboot,syslog}.target.wants
961baf80
AF
379
380# Create new-style configuration files so that we can ghost-own them
23107006 381touch $RPM_BUILD_ROOT%{_sysconfdir}/{hostname,locale.conf,machine-id,machine-info,os-release,timezone,vconsole.conf}
4bbef33c 382
9d8b5dfe 383# Install SysV conversion tool for systemd
4f25b6ac 384install -p %{SOURCE1} $RPM_BUILD_ROOT%{_bindir}
9d8b5dfe
BZ
385
386install -d $RPM_BUILD_ROOT/var/log
5a65c84e
TP
387:> $RPM_BUILD_ROOT/var/log/btmp
388:> $RPM_BUILD_ROOT/var/log/wtmp
a761f93e 389
5d32f234 390%if %{without gtk}
5d32f234
TP
391%{__rm} $RPM_BUILD_ROOT%{_mandir}/man1/systemadm.1*
392%endif
393
394%{__rm} -r $RPM_BUILD_ROOT%{_docdir}/%{name}
a86320a6 395%{__rm} $RPM_BUILD_ROOT/%{_lib}/security/pam_systemd.la
5d32f234
TP
396%{__rm} $RPM_BUILD_ROOT%{_libdir}/*.la
397
ede8d3e5 398%clean
399rm -rf $RPM_BUILD_ROOT
400
9638c72f 401%post
4bbef33c 402/bin/systemd-machine-id-setup > /dev/null 2>&1 || :
9638c72f 403/bin/systemctl daemon-reexec > /dev/null 2>&1 || :
c3037397 404
961baf80 405%postun
85879912 406if [ $1 -ge 1 ]; then
961baf80 407 /bin/systemctl try-restart systemd-logind.service >/dev/null 2>&1 || :
9638c72f 408fi
409
3edd52a6
TP
410%post libs -p /sbin/ldconfig
411%postun libs -p /sbin/ldconfig
011bccb6 412
961baf80 413%post units
85879912 414if [ $1 -eq 1 ]; then
961baf80
AF
415 # Try to read default runlevel from the old inittab if it exists
416 runlevel=$(/bin/awk -F ':' '$3 == "initdefault" && $1 !~ "^#" { print $2 }' /etc/inittab 2> /dev/null)
417 if [ -z "$runlevel" ] ; then
4cc1cb1d 418 target="%{systemdunitdir}/graphical.target"
961baf80 419 else
4cc1cb1d 420 target="%{systemdunitdir}/runlevel$runlevel.target"
961baf80
AF
421 fi
422
423 # And symlink what we found to the new-style default.target
f341cd9b 424 ln -s "$target" %{_sysconfdir}/systemd/system/default.target >/dev/null 2>&1 || :
cf819365
JR
425
426 # Setup hostname
427 [ -f /etc/sysconfig/network ] && . /etc/sysconfig/network
428 if [ -n "$HOSTNAME" -a "$HOSTNAME" != "pldmachine" ]; then
429 [ -f /etc/hostname ] && mv -f /etc/hostname /etc/hostname.rpmsave
430 echo $HOSTNAME > /etc/hostname
431 chmod 644 /etc/hostname
432 fi
9638c72f 433fi
f1586299
JR
434# Enable the services we install by default.
435/bin/systemctl enable \
436 getty@.service \
437 network.service \
438 network-post.service \
439 remote-fs.target \
440 systemd-readahead-replay.service \
441 systemd-readahead-collect.service >/dev/null 2>&1 || :
442
443# Find and enable all installed interfaces
d37b4980 444mkdir -p %{_sysconfdir}/systemd/system/network.target.wants >/dev/null 2>&1 || :
f1586299
JR
445for f in /etc/sysconfig/interfaces/ifcfg-* ; do
446 ff=$(basename $f)
447 ff=${ff##ifcfg-}
448 case "$ff" in
449 *.rpmorig|*.rpmnew|*.rpmsave|*~|*.orig)
450 continue
451 ;;
452 *)
663b637e 453 DEVICE="" ; ONBOOT="" ; USERS=""
72878cbd 454 . $f 2>/dev/null
663b637e 455 [ ${USERS:-no} != no ] && continue
90de2714 456 if [ "$DEVICE" = "$ff" -a ${ONBOOT:-no} = "yes" ]; then
4cc1cb1d 457 ln -s %{systemdunitdir}/ifup@.service \
90de2714
JR
458 %{_sysconfdir}/systemd/system/network.target.wants/ifcfg@$ff.service >/dev/null 2>&1 || :
459 fi
f1586299
JR
460 ;;
461 esac
462done
c3037397
ER
463
464%preun units
961baf80
AF
465if [ $1 -eq 0 ] ; then
466 /bin/systemctl disable \
467 getty@.service \
f1586299
JR
468 network.service \
469 network-post.service \
961baf80
AF
470 remote-fs.target \
471 systemd-readahead-replay.service \
472 systemd-readahead-collect.service >/dev/null 2>&1 || :
473
f341cd9b 474 %{__rm} -f %{_sysconfdir}/systemd/system/default.target >/dev/null 2>&1 || :
f1586299 475 %{__rm} -f %{_sysconfdir}/systemd/system/network.target.wants/ifcfg@*.service >/dev/null 2>&1 || :
c3037397 476fi
9638c72f 477
961baf80 478%postun units
85879912 479if [ $1 -ge 1 ]; then
9638c72f 480 /bin/systemctl daemon-reload > /dev/null 2>&1 || :
481fi
482
ae4d0acb 483%post no-compat-tmpfiles
a6203073 484%{__sed} -i -e '/^#/!s/^/# /g' %{_sysconfdir}/tmpfiles.d/compat-pld-var-run.conf
ae4d0acb 485
ede8d3e5 486%files
487%defattr(644,root,root,755)
1c239f8b 488%doc DISTRO_PORTING README TODO
6e34428f 489/etc/dbus-1/system.d/org.freedesktop.hostname1.conf
961baf80
AF
490/etc/dbus-1/system.d/org.freedesktop.locale1.conf
491/etc/dbus-1/system.d/org.freedesktop.login1.conf
c3037397 492/etc/dbus-1/system.d/org.freedesktop.systemd1.conf
961baf80 493/etc/dbus-1/system.d/org.freedesktop.timedate1.conf
3edd52a6 494%ghost %config(noreplace) %{_sysconfdir}/machine-id
b77423ae
AF
495%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/hostname
496%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/locale.conf
497%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/machine-info
498%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/os-release
499%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/timezone
500%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/vconsole.conf
5d32f234 501%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/systemd/*.conf
2a61be78 502%dir %{_sysconfdir}/systemd/user
abd479ee 503/etc/xdg/systemd
1dcb74bb 504%attr(755,root,root) /bin/systemd
505%attr(755,root,root) /bin/systemd-ask-password
c76a8951 506%attr(755,root,root) /bin/systemd-journalctl
961baf80 507%attr(755,root,root) /bin/systemd-loginctl
7a76bc86 508%attr(755,root,root) /bin/systemd-machine-id-setup
1dcb74bb 509%attr(755,root,root) /bin/systemd-notify
510%attr(755,root,root) /bin/systemd-tty-ask-password-agent
57cd0d13 511%attr(755,root,root) %{_bindir}/systemd-analyze
d374e721
JR
512%attr(755,root,root) %{_bindir}/systemd-cat
513%attr(755,root,root) %{_bindir}/systemd-cgtop
23107006 514%attr(755,root,root) %{_bindir}/systemd-cgls
57cd0d13
ZU
515%attr(755,root,root) %{_bindir}/systemd-nspawn
516%attr(755,root,root) %{_bindir}/systemd-stdio-bridge
2a61be78 517%attr(755,root,root) %{_bindir}/systemd-sysv-convert
abd479ee 518%attr(755,root,root) /lib/systemd/systemd-*
c3037397 519%dir /lib/systemd/system-generators
4389e6f9 520%attr(755,root,root) /lib/systemd/systemd
5d32f234 521%attr(755,root,root) /lib/systemd/system-generators/systemd-*-generator
abd479ee 522%dir /lib/systemd/system-shutdown
1c239f8b 523/lib/udev/rules.d/99-systemd.rules
961baf80
AF
524/lib/udev/rules.d/70-uaccess.rules
525/lib/udev/rules.d/71-seat.rules
526/lib/udev/rules.d/73-seat-late.rules
3edd52a6
TP
527%dir %{_libexecdir}/systemd
528%{_libexecdir}/systemd/user
2a61be78 529%dir %{_libexecdir}/systemd/user-generators
89d58574 530%config(noreplace,missingok) %{_libexecdir}/tmpfiles.d/*.conf
961baf80
AF
531%{_datadir}/dbus-1/interfaces/org.freedesktop.hostname1.xml
532%{_datadir}/dbus-1/interfaces/org.freedesktop.locale1.xml
c3037397 533%{_datadir}/dbus-1/interfaces/org.freedesktop.systemd1.*.xml
961baf80 534%{_datadir}/dbus-1/interfaces/org.freedesktop.timedate1.xml
1c239f8b 535%{_datadir}/dbus-1/services/org.freedesktop.systemd1.service
6e34428f 536%{_datadir}/dbus-1/system-services/org.freedesktop.hostname1.service
961baf80
AF
537%{_datadir}/dbus-1/system-services/org.freedesktop.locale1.service
538%{_datadir}/dbus-1/system-services/org.freedesktop.login1.service
1c239f8b 539%{_datadir}/dbus-1/system-services/org.freedesktop.systemd1.service
961baf80 540%{_datadir}/dbus-1/system-services/org.freedesktop.timedate1.service
6e34428f 541%{_datadir}/polkit-1/actions/org.freedesktop.hostname1.policy
961baf80
AF
542%{_datadir}/polkit-1/actions/org.freedesktop.locale1.policy
543%{_datadir}/polkit-1/actions/org.freedesktop.login1.policy
544%{_datadir}/polkit-1/actions/org.freedesktop.systemd1.policy
545%{_datadir}/polkit-1/actions/org.freedesktop.timedate1.policy
546%dir %{_datadir}/systemd
547%{_datadir}/systemd/kbd-model-map
7a76bc86 548%{_mandir}/man1/systemd.1*
2a61be78 549%{_mandir}/man1/systemd-*.1*
1c239f8b 550%{_mandir}/man3/sd_booted.3*
551%{_mandir}/man3/sd_is_fifo.3*
552%{_mandir}/man3/sd_is_socket.3
553%{_mandir}/man3/sd_is_socket_inet.3
554%{_mandir}/man3/sd_is_socket_unix.3
555%{_mandir}/man3/sd_listen_fds.3*
556%{_mandir}/man3/sd_notify.3*
557%{_mandir}/man3/sd_notifyf.3
558%{_mandir}/man3/sd_readahead.3*
6e34428f 559%{_mandir}/man5/binfmt.d.5*
1c239f8b 560%{_mandir}/man5/hostname.5*
561%{_mandir}/man5/locale.conf.5*
7a76bc86 562%{_mandir}/man5/machine-id.5*
6e34428f 563%{_mandir}/man5/machine-info.5*
1c239f8b 564%{_mandir}/man5/modules-load.d.5*
565%{_mandir}/man5/os-release.5*
6e34428f 566%{_mandir}/man5/sysctl.d.5*
89d58574 567%{_mandir}/man5/systemd.*.5*
961baf80
AF
568%{_mandir}/man5/systemd-logind.conf.5*
569%{_mandir}/man5/timezone.5*
23107006 570%{_mandir}/man5/vconsole.conf.5*
1c239f8b 571%{_mandir}/man7/daemon.7*
572%{_mandir}/man7/sd-daemon.7*
c76a8951 573%{_mandir}/man7/sd-login.7*
1c239f8b 574%{_mandir}/man7/sd-readahead.7*
575%{_mandir}/man7/systemd.special.7*
a761f93e
TP
576%attr(640,root,root) %ghost /var/log/btmp
577%attr(664,root,utmp) %ghost /var/log/wtmp
c3037397 578
6c89bbd4 579%if %{with pam}
a86320a6 580%attr(755,root,root) /%{_lib}/security/pam_systemd.so
6c89bbd4
ER
581%{_mandir}/man8/pam_systemd.8*
582%endif
583
c97dacdd 584%files init
5b9bde26 585%defattr(644,root,root,755)
c97dacdd
TP
586%attr(755,root,root) /sbin/halt
587%attr(755,root,root) /sbin/init
588%attr(755,root,root) /sbin/poweroff
589%attr(755,root,root) /sbin/reboot
590%attr(755,root,root) /sbin/runlevel
591%attr(755,root,root) /sbin/shutdown
592%attr(755,root,root) /sbin/telinit
593%{_mandir}/man1/init.1
594%{_mandir}/man8/halt.8*
595%{_mandir}/man8/poweroff.8
596%{_mandir}/man8/reboot.8
597%{_mandir}/man8/runlevel.8*
598%{_mandir}/man8/shutdown.8*
599%{_mandir}/man8/telinit.8*
600
c3037397
ER
601%files units
602%defattr(644,root,root,755)
abd479ee
MB
603%dir %{_sysconfdir}/binfmt.d
604%dir %{_sysconfdir}/modules-load.d
5d32f234 605%config(noreplace,missingok) %verify(not md5 mtime size) %{_sysconfdir}/modules-load.d/modules.conf
abd479ee 606%dir %{_sysconfdir}/sysctl.d
c3037397
ER
607%dir %{_sysconfdir}/systemd
608%dir %{_sysconfdir}/systemd/system
609%dir %{_sysconfdir}/tmpfiles.d
7cb5cfc8 610%config(noreplace,missingok) %verify(not md5 mtime size) %{_sysconfdir}/tmpfiles.d/*.conf
85879912
ER
611%dir %{_libexecdir}/binfmt.d
612%dir %{_libexecdir}/modules-load.d
613%dir %{_libexecdir}/sysctl.d
d374e721 614%{_libexecdir}/sysctl.d/coredump.conf
c3037397
ER
615%attr(755,root,root) /bin/systemctl
616%attr(755,root,root) /bin/systemd-tmpfiles
b77423ae 617%attr(755,root,root) /bin/systemd_booted
c3037397 618%{_mandir}/man1/systemctl.1*
89d58574 619%{_mandir}/man5/tmpfiles.d.5*
c3037397 620%{_mandir}/man8/systemd-tmpfiles.8*
961baf80 621%{_npkgconfigdir}/systemd.pc
c3037397 622
4cc1cb1d
ER
623%{systemdunitdir}/*.automount
624%{systemdunitdir}/*.mount
625%{systemdunitdir}/*.path
626%{systemdunitdir}/*.service
627%{systemdunitdir}/*.socket
628%{systemdunitdir}/*.target
629%{systemdunitdir}/*.timer
630%dir %{systemdunitdir}/*.wants
631%config(noreplace,missingok) %{systemdunitdir}/*.wants/*
10ffdcd2 632
c3037397
ER
633%if %{with gtk}
634%files gtk
635%defattr(644,root,root,755)
636%attr(755,root,root) %{_bindir}/systemadm
637%attr(755,root,root) %{_bindir}/systemd-gnome-ask-password-agent
c3037397
ER
638%{_mandir}/man1/systemadm.1*
639%endif
6c89bbd4 640
5b9bde26 641%files libs
6c89bbd4 642%defattr(644,root,root,755)
6ba1f779
MB
643%attr(755,root,root) /%{_lib}/libsystemd-daemon.so.*.*.*
644%attr(755,root,root) %ghost /%{_lib}/libsystemd-daemon.so.0
645%attr(755,root,root) /%{_lib}/libsystemd-id128.so.*.*.*
646%attr(755,root,root) %ghost /%{_lib}/libsystemd-id128.so.0
647%attr(755,root,root) /%{_lib}/libsystemd-journal.so.*.*.*
648%attr(755,root,root) %ghost /%{_lib}/libsystemd-journal.so.0
649%attr(755,root,root) /%{_lib}/libsystemd-login.so.*.*.*
650%attr(755,root,root) %ghost /%{_lib}/libsystemd-login.so.0
961baf80
AF
651
652%files devel
653%defattr(644,root,root,755)
89d58574 654%attr(755,root,root) %{_libdir}/libsystemd-daemon.so
c76a8951
BZ
655%attr(755,root,root) %{_libdir}/libsystemd-id128.so
656%attr(755,root,root) %{_libdir}/libsystemd-journal.so
89d58574 657%attr(755,root,root) %{_libdir}/libsystemd-login.so
5b9bde26 658%{_includedir}/%{name}
961baf80 659%{_pkgconfigdir}/libsystemd-daemon.pc
c76a8951
BZ
660%{_pkgconfigdir}/libsystemd-id128.pc
661%{_pkgconfigdir}/libsystemd-journal.pc
961baf80 662%{_pkgconfigdir}/libsystemd-login.pc
c76a8951
BZ
663%{_mandir}/man3/sd_get_seats.3*
664%{_mandir}/man3/sd_get_sessions.3*
665%{_mandir}/man3/sd_get_uids.3*
666%{_mandir}/man3/sd_is_mq.3*
667%{_mandir}/man3/sd_login_monitor_flush.3*
668%{_mandir}/man3/sd_login_monitor_get_fd.3*
669%{_mandir}/man3/sd_login_monitor_new.3*
670%{_mandir}/man3/sd_login_monitor_unref.3*
671%{_mandir}/man3/sd_pid_get_owner_uid.3*
672%{_mandir}/man3/sd_pid_get_session.3*
673%{_mandir}/man3/sd_pid_get_unit.3*
674%{_mandir}/man3/sd_seat_can_multi_session.3*
675%{_mandir}/man3/sd_seat_get_active.3*
676%{_mandir}/man3/sd_seat_get_sessions.3*
677%{_mandir}/man3/sd_session_get_seat.3*
678%{_mandir}/man3/sd_session_get_uid.3*
679%{_mandir}/man3/sd_session_is_active.3*
680%{_mandir}/man3/sd_uid_get_seats.3*
681%{_mandir}/man3/sd_uid_get_sessions.3*
682%{_mandir}/man3/sd_uid_get_state.3*
683%{_mandir}/man3/sd_uid_is_on_seat.3*
5b9bde26
JB
684
685%files -n bash-completion-systemd
686%defattr(644,root,root,755)
391eea76 687/etc/bash_completion.d/systemd-bash-completion.sh
ae4d0acb
JR
688
689%files no-compat-tmpfiles
690%defattr(644,root,root,755)
691# empty package
This page took 0.170714 seconds and 4 git commands to generate.