]> git.pld-linux.org Git - packages/subversion.git/blob - subversion.spec
- rel 3
[packages/subversion.git] / subversion.spec
1 #
2 # Conditional build:
3 %bcond_with     net_client_only         # build only net client
4 %bcond_without  neon                    # use serf instead of neon
5 %bcond_without  swig                    # disable bindings generation with Swig
6 %bcond_without  python                  # build without Python bindings (broken)
7 %bcond_without  csvn                    # build Python csvn bindings
8 %bcond_without  perl                    # build without Perl bindings
9 %bcond_with     ruby                    # build with Ruby bindings (only 1.8.x is supported)
10 %bcond_without  apache                  # build without Apache support (webdav, etc)
11 %bcond_without  javahl                  # build without javahl support (Java high-level bindings)
12 %bcond_without  tests                   # don't perform "make check"
13 %bcond_without  kwallet                 # build without kde4 wallet support
14 %bcond_without  kde                     # build without kde4 support (alias for kwallet)
15 %bcond_without  gnome                   # build without gnome keyring support
16 %bcond_without  db                      # disable Subversion Berkeley DB based filesystem library
17
18 %if %{with net_client_only}
19 %undefine       with_apache
20 %undefine       with_db
21 %undefine       with_swig
22 %undefine       with_javahl
23 %endif
24
25 %if %{without swig}
26 %undefine       with_perl
27 %undefine       with_python
28 %undefine       with_ruby
29 %endif
30
31 %if %{without kde}
32 %undefine       with_kwallet
33 %endif
34
35 %if %{without python} && %{without perl} && %{without ruby}
36 %undefine       with_swig
37 %endif
38
39 %define apxs    /usr/sbin/apxs
40 %define pdir    SVN
41 %define pnam    _Core
42
43 %if %{with neon}
44 %define webdavlib       neon
45 %else
46 %define webdavlib       serf
47 %endif
48 %{?with_perl:%include   /usr/lib/rpm/macros.perl}
49 Summary:        A Concurrent Versioning system similar to but better than CVS
50 Summary(pl.UTF-8):      System kontroli wersji podobny, ale lepszy, niż CVS
51 Summary(pt_BR.UTF-8):   Sistema de versionamento concorrente
52 Name:           subversion
53 Version:        1.7.0
54 Release:        3
55 License:        Apache/BSD-like
56 Group:          Development/Version Control
57 Source0:        http://www.apache.org/dist/subversion/%{name}-%{version}.tar.bz2
58 # Source0-md5:  930e6644a1b6094efd268fde6a318f04
59 Source1:        %{name}-dav_svn.conf
60 Source2:        %{name}-authz_svn.conf
61 Source3:        %{name}-svnserve.init
62 Source4:        %{name}-svnserve.sysconfig
63 # current subversion tarball has correct *.swg files
64 # but after regeneration these are broken again, so
65 # we still need this script
66 Source5:        %{name}-convert-typemaps-to-ifdef.py
67 Patch0:         %{name}-home_etc.patch
68 Patch1:         %{name}-DESTDIR.patch
69 Patch2:         %{name}-ruby-datadir-path.patch
70 Patch3:         %{name}-tests.patch
71 Patch4:         %{name}-mod_dav_svn-fix-hook.patch
72 URL:            http://subversion.apache.org/
73 %{?with_apache:BuildRequires:   apache-devel >= 2.2.0-8}
74 BuildRequires:  apr-devel >= 1:1.0.0
75 BuildRequires:  apr-util-devel >= 1:1.2.8-3
76 BuildRequires:  autoconf >= 2.59
77 BuildRequires:  automake
78 BuildRequires:  bison
79 BuildRequires:  cyrus-sasl-devel
80 %if %{with kwallet} || %{with gnome}
81 BuildRequires:  dbus-devel
82 %endif
83 BuildRequires:  db-devel >= 4.1.25
84 BuildRequires:  expat-devel
85 BuildRequires:  gettext-devel
86 %{?with_kwallet:BuildRequires:  kde4-kdelibs-devel}
87 %{?with_gnome:BuildRequires:    libgnome-keyring-devel}
88 BuildRequires:  libmagic-devel
89 BuildRequires:  libtool >= 1.4-9
90 BuildRequires:  pkgconfig
91 %{?with_csvn:BuildRequires:     python-ctypesgen}
92 BuildRequires:  rpm-pythonprov
93 BuildRequires:  rpmbuild(macros) >= 1.583
94 BuildRequires:  sed >= 4.0
95 BuildRequires:  sqlite3-devel >= 3.6.18
96 BuildRequires:  texinfo
97 BuildRequires:  which
98 %if %{with neon}
99 BuildRequires:  neon-devel >= 0.26.0
100 %else
101 BuildRequires:  serf-devel >= 0.7.1
102 %endif
103 %if %{with javahl}
104 BuildRequires:  jdk >= 1.5
105 BuildRequires:  libstdc++-devel
106 %endif
107 %if %{with perl}
108 BuildRequires:  perl-devel >= 1:5.8.0
109 BuildRequires:  rpm-perlprov >= 4.1-13
110 BuildRequires:  swig-perl >= 1.3.24
111 %endif
112 %if %{with python}
113 BuildRequires:  python-devel >= 1:2.4
114 BuildRequires:  swig-python >= 1.3.24
115 %endif
116 %if %{with ruby}
117 BuildRequires:  ruby-devel >= 1:1.8.2
118 BuildRequires:  ruby-devel < 1:1.9
119 BuildRequires:  ruby-rubygems
120 BuildRequires:  swig-ruby >= 1.3.24
121 %endif
122 Requires:       %{name}-libs = %{version}-%{release}
123 %requires_ge    sqlite3
124 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
125
126 %define         _libexecdir             %{_libdir}/svn
127 %define         apacheconfdir   %(%{apxs} -q SYSCONFDIR 2>/dev/null)/conf.d
128 %define         apachelibdir    %(%{apxs} -q LIBEXECDIR 2>/dev/null)
129
130 %define         skip_post_check_so      libsvn_swig_py-1.so.* libsvn_swig_perl-1.so.*
131
132 %description
133 The goal of the Subversion project is to build a version control
134 system that is a compelling replacement for CVS in the open source
135 community.
136
137 Our goals are:
138 - All current CVS features.
139 - Directories, renames, and file meta-data are versioned.
140 - Symbolic links, etc, are supported
141 - Commits are truly atomic.
142 - Branching and tagging are cheap (constant time) operations
143 - Repeated merges are handled gracefully
144 - Support for plug-in client side diff programs
145 - Natively client/server
146 - Client/server protocol sends diffs in both directions
147 - Costs are proportional to change size, not project size
148 - Internationalization
149 - Progressive multi-lingual support
150
151 %description -l pl.UTF-8
152 Celem projektu Subversion jest stworzenie systemu kontroli wersji jako
153 zamiennika dla CVS.
154
155 Cele projektu to:
156 - Wszystkie aktualne możliwości CVS.
157 - Katalogi, zmiany nazw oraz metadane plików są wersjonowane.
158 - Obsługa dowiązań symbolicznych itp.
159 - Commity są w pełni atomowe.
160 - Branchowanie oraz tagowanie są tanimi (stałymi w czasie) operacjami.
161 - Dobra obsługa powtarzanego łączenia (merge).
162 - Obsługa wtyczek diff po stronie klienta.
163 - Natywny klient/serwer.
164 - Klient/Serwer przesyłają diffy w obu kierunkach.
165 - Koszty proporcjonalne do rozmiaru zmiany, a nie rozmiaru projektu.
166 - Internacjonalizacja.
167 - Postępujące wsparcie dla wielu języków.
168
169 %description -l pt_BR.UTF-8
170 O objetivo do projeto Subversion é construir um sistema de controle de
171 versões que seja um substituto para o CVS (Concurrent Versioning
172 System) na comunidade opensource, fornecendo grandes melhorias.
173
174 %package libs
175 Summary:        Subversion libraries and modules
176 Summary(pl.UTF-8):      Biblioteka subversion oraz ładowalne moduły
177 Group:          Libraries
178 %if %{with neon}
179 Requires:       neon >= 0.26.0
180 %else
181 Requires:       serf >= 0.7.1
182 %endif
183 Obsoletes:      libsubversion0
184
185 %description libs
186 Subversion libraries and modules.
187
188 %description libs -l pl.UTF-8
189 Biblioteka subversion oraz ładowalne moduły.
190
191 %package devel
192 Summary:        Header files and develpment documentation for subversion
193 Summary(pl.UTF-8):      Pliki nagłówkowe i dokumetacja do subversion
194 Summary(pt_BR.UTF-8):   Arquivos de desenvolvimento para o Subversion
195 Group:          Development/Libraries
196 Requires:       %{name}-libs = %{version}-%{release}
197 Requires:       apr-util-devel >= 1:1.0.0
198 %{?with_neon:Requires:  neon-devel >= 0.26.0}
199 Obsoletes:      libsubversion0-devel
200
201 %description devel
202 Header files and develpment documentation for subversion.
203
204 %description devel -l pl.UTF-8
205 Pliki nagłówkowe i dokumetacja do subversion.
206
207 %description devel -l pt_BR.UTF-8
208 Este pacote provê os arquivos necessários para desenvolvedores
209 interagirem com o Subversion.
210
211 %package static
212 Summary:        Static subversion library
213 Summary(pl.UTF-8):      Biblioteka statyczna subversion
214 Summary(pt_BR.UTF-8):   Sistema de versionamento concorrente
215 Group:          Development/Libraries
216 Requires:       %{name}-devel = %{version}
217 Obsoletes:      libsubversion0-static-devel
218
219 %description static
220 Static subversion library.
221
222 %description static -l pl.UTF-8
223 Biblioteka statyczna subversion.
224
225 %description static -l pt_BR.UTF-8
226 Este pacote provê um cliente estático do subversion.
227
228 %package svnserve
229 Summary:        Subversion svnserve
230 Summary(pl.UTF-8):      Subversion svnserve
231 Group:          Networking/Daemons
232 Requires(post,preun):   /sbin/chkconfig
233 Requires(postun):       /usr/sbin/groupdel
234 Requires(postun):       /usr/sbin/userdel
235 Requires(pre):  /bin/id
236 Requires(pre):  /usr/bin/getgid
237 Requires(pre):  /usr/lib/rpm/user_group.sh
238 Requires(pre):  /usr/sbin/groupadd
239 Requires(pre):  /usr/sbin/useradd
240 Requires(pre):  /usr/sbin/usermod
241 Requires:       %{name} = %{version}-%{release}
242 Requires:       rc-scripts
243 Provides:       group(svn)
244 Provides:       user(svn)
245
246 %description svnserve
247 Subversion svnserve server.
248
249 %description svnserve -l pl.UTF-8
250 Serwer subversion svnserve.
251
252 %package tools
253 Summary:        Subversion tools and scripts
254 Summary(pl.UTF-8):      Narzędzia oraz skrypty dla subversion
255 Summary(pt_BR.UTF-8):   Módulos python para acessar os recursos do Subversion
256 Group:          Applications
257 %pyrequires_eq  python
258 Requires:       %{name} = %{version}-%{release}
259 Requires:       python-subversion = %{version}
260
261 %description tools
262 Subversion tools and scripts.
263
264 %description tools -l pl.UTF-8
265 Narzędzia oraz skrypty dla subversion.
266
267 %package -n bash-completion-subversion
268 Summary:        bash completion for subversion
269 Summary(pl.UTF-8):      Dopełnienia basha dla subversion
270 Group:          Applications/Shells
271 Requires:       %{name} = %{version}-%{release}
272 Requires:       bash-completion
273 Conflicts:      %{name}-tools <= 1.1.0-0.rc6.1
274
275 %description -n bash-completion-subversion
276 Bash completion for subversion.
277
278 %description -n bash-completion-subversion -l pl.UTF-8
279 Dopełnienia basha dla subversion.
280
281 %package -n java-subversion
282 Summary:        Subversion Java bindings
283 Summary(pl.UTF-8):      Dowiązania do Subversion dla Javy
284 Group:          Development/Languages/Java
285 Requires:       %{name}-libs = %{version}-%{release}
286
287 %description -n java-subversion
288 This is a set of Java classes which provide the functionality of
289 subversion-libs, the Subversion libraries. It is useful if you want
290 to, for example, write a Java class that manipulates a Subversion
291 repository or working copy. See the 'subversion' package for more
292 information.
293
294 %description -n java-subversion -l pl.UTF-8
295 Ten pakiet zawiera zestaw klas Javy udostępniających funkcjonalność
296 subversion-libs, czyli bibliotek Subversion. Jest przydatny przy
297 pisaniu klas Javy np. modyfikujących repozytorium Subversion lub kopię
298 roboczą. Więcej informacji w pakiecie subversion.
299
300 %package -n python-subversion
301 Summary:        Subversion Python bindings
302 Summary(pl.UTF-8):      Dowiązania do Subversion dla Pythona
303 Summary(pt_BR.UTF-8):   Módulos Python para acessar os recursos do Subversion
304 Group:          Development/Languages/Python
305 %pyrequires_eq  python
306 Requires:       %{name}-libs = %{version}-%{release}
307 Obsoletes:      subversion-python
308
309 %description -n python-subversion
310 Subversion Python bindings.
311
312 %description -n python-subversion -l pl.UTF-8
313 Dowiązania do Subversion dla Pythona.
314
315 %description -n python-subversion -l pt_BR.UTF-8
316 Módulos Python para acessar os recursos do Subversion.
317
318 %package -n python-csvn
319 Summary:        CTypes Subversion Python bindings
320 Summary(pl.UTF-8):      Dowiązania do Subversion dla Pythona
321 Summary(pt_BR.UTF-8):   Módulos Python para acessar os recursos do Subversion
322 Group:          Development/Languages/Python
323 %pyrequires_eq  python
324 Requires:       %{name}-libs = %{version}-%{release}
325
326 %description -n python-csvn
327 Subversion CTypes Python bindings.
328
329 %description -n python-csvn -l pl.UTF-8
330 Dowiązania do Subversion dla Pythona używające CTypes.
331
332 %description -n python-csvn -l pt_BR.UTF-8
333 Módulos Python para acessar os recursos do Subversion.
334
335 %package -n perl-subversion
336 Summary:        Subversion Perl bindings
337 Summary(pl.UTF-8):      Dowiązania do Subversion dla Perla
338 Summary(pt_BR.UTF-8):   Módulos Perl para acessar os recursos do Subversion
339 Group:          Development/Languages/Perl
340 Requires:       %{name}-libs = %{version}-%{release}
341 Obsoletes:      subversion-perl
342
343 %description -n perl-subversion
344 Subversion Perl bindings.
345
346 %description -n perl-subversion -l pl.UTF-8
347 Dowiązania do Subversion dla Perla.
348
349 %description -n perl-subversion -l pt_BR.UTF-8
350 Módulos Perl para acessar os recursos do Subversion.
351
352 %package -n ruby-subversion
353 Summary:        Subversion Ruby bindings
354 Summary(pl.UTF-8):      Dowiązania do Subversion dla języka Ruby
355 Summary(pt_BR.UTF-8):   Módulos Ruby para acessar os recursos do Subversion
356 Group:          Development/Languages
357 Requires:       %{name}-libs = %{version}-%{release}
358 Obsoletes:      subversion-ruby
359
360 %description -n ruby-subversion
361 Subversion Ruby bindings.
362
363 %description -n ruby-subversion -l pl.UTF-8
364 Dowiązania do Subversion dla języka Ruby.
365
366 %description -n ruby-subversion -l pt_BR.UTF-8
367 Módulos Ruby para acessar os recursos do Subversion.
368
369 %package -n apache-mod_dav_svn
370 Summary:        Apache module: Subversion Server
371 Summary(pl.UTF-8):      Moduł apache: Serwer Subversion
372 Group:          Networking/Daemons
373 Requires:       %{name} = %{version}-%{release}
374 Requires:       apache(modules-api) = %apache_modules_api
375 Requires:       apache-mod_dav
376
377 %description -n apache-mod_dav_svn
378 Apache module: Subversion Server.
379
380 %description -n apache-mod_dav_svn -l pl.UTF-8
381 Moduł apache: Serwer Subversion.
382
383 %package -n apache-mod_authz_svn
384 Summary:        Apache module: Subversion Server - path-based authorization
385 Summary(pl.UTF-8):      Moduł apache: autoryzacja na podstawie ścieżki dla serwera Subversion
386 Group:          Networking/Daemons
387 Requires:       apache(modules-api) = %apache_modules_api
388 Requires:       apache-mod_dav_svn = %{version}-%{release}
389
390 %description -n apache-mod_authz_svn
391 Apache module: Subversion Server - path-based authorization.
392
393 %description -n apache-mod_authz_svn -l pl.UTF-8
394 Moduł apache: autoryzacja na podstawie ścieżki dla serwera Subversion.
395
396 %package -n gnome-keyring-subversion
397 Summary:        GNOME Keyring authentication provider for Subversion
398 Summary(pl.UTF-8):      Moduł uwierzytelniający GNOME Keyring dla Subversion
399 Group:          X11/Applications
400
401 %description -n gnome-keyring-subversion
402 Authentication provider module for Subversion which allows SVN client
403 to authenticate using GNOME Keyring.
404
405 %description -n gnome-keyring-subversion -l pl.UTF-8
406 Moduł uwierzytelniający dla Subversion pozwalający klientom SVN
407 uwierzytelniać się przy użyciu mechanizmu GNOME Keyring.
408
409 %package -n kde4-kwallet-subversion
410 Summary:        KDE Wallet authentication provider for Subversion
411 Summary(pl.UTF-8):      Moduł uwierzytelniający dla Subversion wykorzystujący Portfel KDE
412 Group:          X11/Applications
413
414 %description -n kde4-kwallet-subversion
415 Authentication provider module for Subversion which allows SVN client
416 to authenticate using KDE Wallet.
417
418 %description -n kde4-kwallet-subversion -l pl.UTF-8
419 Moduł uwierzytelniający dla Subversion pozwalający klientom SVN
420 uwierzytelniać się przy użyciu Portfela KDE.
421
422 %prep
423 %setup -q
424 %patch0 -p0
425 %patch1 -p1
426 %patch2 -p0
427 %patch3 -p1
428 %patch4 -p1
429
430 sed -i -e 's#serf_prefix/lib#serf_prefix/%{_lib}#g' build/ac-macros/serf.m4
431
432 # serf.m4 macro is broken and ignores --without serf
433 %{?with_neon:sed -i -e 's#serf_found="yes"#serf_found="no"#g' build/ac-macros/serf.m4}
434
435 %build
436 # disabled regeneration - subversion 1.6.13 is not ready for swig 2.0.x
437 #%{__rm} subversion/bindings/swig/proxy/*.swg
438 #cd subversion/bindings/swig && python "%{SOURCE5}" && cd ../../..
439 chmod +x ./autogen.sh && ./autogen.sh
440 %{__libtoolize}
441 %configure \
442         --with-editor=vi \
443         --with-zlib=%{_libdir} \
444         --disable-runtime-module-search \
445         --disable-mod-activation \
446 %if %{with db}
447         --with-berkeley-db="db.h:%{_includedir}:%{_libdir}:db" \
448 %else
449         --without-berkeley-db \
450 %endif
451 %if %{with apache}
452         --with-apxs=%{_sbindir}/apxs \
453 %else
454         --without-apxs \
455 %endif
456 %if %{without swig}
457         --without-swig \
458 %endif
459 %if %{without ruby}
460         ac_cv_path_RUBY=none \
461 %endif
462 %if %{with csvn}
463         --with-ctypesgen=%{_bindir}/ctypesgen.py \
464 %endif
465 %if %{with javahl}
466         --enable-javahl \
467         --with-jdk="%{java_home}" \
468         --without-jikes \
469 %else
470         --disable-javahl \
471 %endif
472 %if %{with neon}
473         --without-serf \
474         --with-neon=%{_prefix} \
475         --disable-neon-version-check \
476 %else
477         --with-serf=%{_prefix} \
478         --without-neon \
479 %endif
480         --with-apr=%{_bindir}/apr-1-config \
481         --with-apr-util=%{_bindir}/apu-1-config \
482 %if %{with kwallet}
483         --with-kwallet \
484 %endif
485 %if %{with gnome}
486         --with-gnome-keyring
487 %endif
488
489 %{__make} -j1
490
491 %if %{with csvn}
492 # Python ctypes bindings
493 %{__make} ctypes-python
494 %endif
495 %if %{with python}
496 # Python swig bindings
497 %{__make} swig-py \
498         swig_pydir=%{py_sitedir}/libsvn \
499         swig_pydir_extra=%{py_sitedir}/svn
500 %endif
501 %if %{with perl}
502 # Perl swig bindings
503 %{__make} -j1 swig-pl-lib
504 cd subversion/bindings/swig/perl/native
505 %{__perl} Makefile.PL INSTALLDIRS=vendor
506 %{__make} -j1
507 cd -
508 %endif
509 %if %{with javahl}
510 %{__make} -j1 javahl \
511         javahl_javadir="%{_javadir}"
512 %endif
513 # ruby
514 %if %{with ruby}
515 %{__make} swig-rb
516 %endif
517
518 %if %{with tests}
519 %{__make} -j1 check
520 %if %{with csvn}
521 %{__make} -j1 check-ctypes-python
522 %endif
523 %if %{with python}
524 %{__make} -j1 check-swig-py
525 %endif
526 %if %{with perl}
527 %{__make} -j1 check-swig-pl
528 %endif
529 %if %{with ruby}
530 # disabled, see https://bugs.launchpad.net/pld-linux/+bug/734340
531 #%{__make} check-swig-rb
532 %endif
533 %endif
534
535 %install
536 rm -rf $RPM_BUILD_ROOT
537 install -d $RPM_BUILD_ROOT/etc/{rc.d/init.d,sysconfig,bash_completion.d} \
538         $RPM_BUILD_ROOT{%{apacheconfdir},%{apachelibdir},%{_infodir}} \
539         $RPM_BUILD_ROOT%{_examplesdir}/{%{name}-%{version},python-%{name}-%{version}} \
540         $RPM_BUILD_ROOT%{_sysconfdir}/%{name} \
541         $RPM_BUILD_ROOT/home/services/subversion{,/repos}
542
543 %{__make} install -j1 \
544         DESTDIR=$RPM_BUILD_ROOT \
545         APACHE_LIBEXECDIR="$(%{_sbindir}/apxs -q LIBEXECDIR)" \
546 %if %{with javahl}
547         install-javahl \
548         javahl_javadir="%{_javadir}" \
549 %endif
550 %if %{with python}
551         install-swig-py \
552         swig_pydir=%{py_sitedir}/libsvn \
553         swig_pydir_extra=%{py_sitedir}/svn \
554 %endif
555 %if %{with csvn}
556         install-ctypes-python \
557 %endif
558
559 %if %{with ruby}
560 %{__make} install -j1 \
561         DESTDIR=$RPM_BUILD_ROOT \
562         install-swig-rb install-swig-rb-doc \
563
564 # not our package
565 %{__rm} -r $RPM_BUILD_ROOT%{ruby_ridir}/Kernel
566 %{__rm} -r $RPM_BUILD_ROOT%{ruby_ridir}/OptionParser
567 %{__rm} -r $RPM_BUILD_ROOT%{ruby_ridir}/Time
568 %{__rm} -r $RPM_BUILD_ROOT%{ruby_ridir}/Uconv
569 %{__rm} $RPM_BUILD_ROOT%{ruby_ridir}/cache.ri
570 %{__rm} $RPM_BUILD_ROOT%{ruby_ridir}/created.rid
571 %endif
572
573 %if %{with perl}
574 %{__make} install-swig-pl-lib \
575         DESTDIR=$RPM_BUILD_ROOT
576 %{__make} -C subversion/bindings/swig/perl/native install \
577         DESTDIR=$RPM_BUILD_ROOT \
578         PREFIX=$RPM_BUILD_ROOT%{_prefix} \
579         LIBDIR=$RPM_BUILD_ROOT%{_libdir}
580 %endif
581
582 %if %{with apache}
583 cp -p %{SOURCE1} $RPM_BUILD_ROOT%{apacheconfdir}/65_mod_dav_svn.conf
584 cp -p %{SOURCE2} $RPM_BUILD_ROOT%{apacheconfdir}/66_mod_authz_svn.conf
585 cp -p %{SOURCE4} $RPM_BUILD_ROOT/etc/sysconfig/svnserve
586 install -p %{SOURCE3} $RPM_BUILD_ROOT/etc/rc.d/init.d/svnserve
587 %endif
588
589 %if %{without net_client_only}
590 install -p tools/backup/hot-backup.py $RPM_BUILD_ROOT%{_bindir}/svn-hot-backup
591 %endif
592 %if %{with python} || %{with csvn}
593 %py_ocomp $RPM_BUILD_ROOT%{py_sitedir}
594 %py_comp $RPM_BUILD_ROOT%{py_sitedir}
595 %py_postclean
596 %endif
597 %if %{with python}
598 %{__rm} $RPM_BUILD_ROOT%{py_sitedir}/libsvn/*.la
599 # .a created on ac only
600 %{__rm} -f $RPM_BUILD_ROOT%{py_sitedir}/libsvn/*.a
601 cp -p tools/examples/*.py $RPM_BUILD_ROOT%{_examplesdir}/python-%{name}-%{version}
602 %endif
603
604 cp -p tools/client-side/bash_completion $RPM_BUILD_ROOT/etc/bash_completion.d/%{name}
605 cp -p tools/examples/*.c $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
606
607 %if %{with javahl}
608 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libsvnjavahl*.{la,a}
609 %endif
610 %if %{with swig}
611 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libsvn_swig*.{la,a}
612 %if %{with ruby}
613 %{__rm} $RPM_BUILD_ROOT%{_libdir}/ruby/site_ruby/*/*/svn/ext/*.la
614 %endif
615 %endif
616 %if %{with gnome} || %{with kwallet}
617 # dlopened by soname (libsvn_auth_*-1.so.0)
618 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libsvn_auth_*-1.{so,la,a}
619 %endif
620
621 %find_lang %{name}
622
623 %clean
624 rm -rf $RPM_BUILD_ROOT
625
626 %pre svnserve
627 %groupadd -g 86 svn
628 %useradd -u 180 -d /home/services/subversion -c "Subversion svnserve" -g svn svn
629
630 %post   libs -p /sbin/ldconfig
631 %postun libs -p /sbin/ldconfig
632
633 %post   devel -p /sbin/postshell
634 -/usr/sbin/fix-info-dir -c %{_infodir}
635
636 %postun devel -p /sbin/postshell
637 -/usr/sbin/fix-info-dir -c %{_infodir}
638
639 %post   -n java-subversion -p /sbin/ldconfig
640 %postun -n java-subversion -p /sbin/ldconfig
641
642 %post   -n perl-subversion -p /sbin/ldconfig
643 %postun -n perl-subversion -p /sbin/ldconfig
644
645 %post   -n python-subversion -p /sbin/ldconfig
646 %postun -n python-subversion -p /sbin/ldconfig
647
648 %post   -n ruby-subversion -p /sbin/ldconfig
649 %postun -n ruby-subversion -p /sbin/ldconfig
650
651 %post   -n gnome-keyring-subversion -p /sbin/ldconfig
652 %postun -n gnome-keyring-subversion -p /sbin/ldconfig
653
654 %post   -n kde4-kwallet-subversion -p /sbin/ldconfig
655 %postun -n kde4-kwallet-subversion -p /sbin/ldconfig
656
657 %post svnserve
658 /sbin/chkconfig --add svnserve
659 %service svnserve restart "svnserve daemon"
660
661 %preun svnserve
662 if [ "$1" = "0" ]; then
663         %service svnserve stop
664         /sbin/chkconfig --del svnserve
665 fi
666
667 %postun svnserve
668 if [ "$1" = "0" ]; then
669         %userremove svn
670         %groupremove svn
671 fi
672
673 %post -n apache-mod_dav_svn
674 %service -q httpd restart
675
676 %postun -n apache-mod_dav_svn
677 if [ "$1" = "0" ]; then
678         %service -q httpd restart
679 fi
680
681 %post -n apache-mod_authz_svn
682 %service -q httpd restart
683
684 %postun -n apache-mod_authz_svn
685 if [ "$1" = "0" ]; then
686         %service -q httpd restart
687 fi
688
689 %files
690 %defattr(644,root,root,755)
691 %doc BUGS CHANGES INSTALL README
692 %doc doc/*/*.html
693 %doc tools/hook-scripts/*.{pl,py,example}
694 %doc tools/hook-scripts/mailer/*.{py,example}
695 %doc tools/xslt/*
696 %attr(755,root,root) %{_bindir}/svn
697 %attr(755,root,root) %{_bindir}/svnadmin
698 %attr(755,root,root) %{_bindir}/svndumpfilter
699 %attr(755,root,root) %{_bindir}/svnrdump
700 %attr(755,root,root) %{_bindir}/svnlook
701 %attr(755,root,root) %{_bindir}/svnsync
702 %attr(755,root,root) %{_bindir}/svnversion
703 %{_mandir}/man1/svn.1*
704 %{_mandir}/man1/svnadmin.1*
705 %{_mandir}/man1/svndumpfilter.1*
706 %{_mandir}/man1/svnrdump.1*
707 %{_mandir}/man1/svnlook.1*
708 %{_mandir}/man1/svnsync.1*
709 %{_mandir}/man1/svnversion.1*
710
711 %files libs -f %{name}.lang
712 %defattr(644,root,root,755)
713 %dir %{_sysconfdir}/%{name}
714 %attr(755,root,root) %{_libdir}/libsvn_client-1.so.*.*.*
715 %attr(755,root,root) %ghost %{_libdir}/libsvn_client-1.so.0
716 %attr(755,root,root) %{_libdir}/libsvn_delta-1.so.*.*.*
717 %attr(755,root,root) %ghost %{_libdir}/libsvn_delta-1.so.0
718 %attr(755,root,root) %{_libdir}/libsvn_diff-1.so.*.*.*
719 %attr(755,root,root) %ghost %{_libdir}/libsvn_diff-1.so.0
720 %attr(755,root,root) %{_libdir}/libsvn_fs-1.so.*.*.*
721 %attr(755,root,root) %ghost %{_libdir}/libsvn_fs-1.so.0
722 %if %{without net_client_only}
723 %attr(755,root,root) %{_libdir}/libsvn_fs_base-1.so.*.*.*
724 %attr(755,root,root) %ghost %{_libdir}/libsvn_fs_base-1.so.0
725 %endif
726 %attr(755,root,root) %{_libdir}/libsvn_fs_fs-1.so.*.*.*
727 %attr(755,root,root) %ghost %{_libdir}/libsvn_fs_fs-1.so.0
728 %attr(755,root,root) %{_libdir}/libsvn_fs_util-1.so.*.*.*
729 %attr(755,root,root) %ghost %{_libdir}/libsvn_fs_util-1.so.0
730 %attr(755,root,root) %{_libdir}/libsvn_ra-1.so.*.*.*
731 %attr(755,root,root) %ghost %{_libdir}/libsvn_ra-1.so.0
732 %attr(755,root,root) %{_libdir}/libsvn_ra_local-1.so.*.*.*
733 %attr(755,root,root) %ghost %{_libdir}/libsvn_ra_local-1.so.0
734 %attr(755,root,root) %{_libdir}/libsvn_ra_%{webdavlib}-1.so.*.*.*
735 %attr(755,root,root) %ghost %{_libdir}/libsvn_ra_%{webdavlib}-1.so.0
736 %attr(755,root,root) %{_libdir}/libsvn_ra_svn-1.so.*.*.*
737 %attr(755,root,root) %ghost %{_libdir}/libsvn_ra_svn-1.so.0
738 %attr(755,root,root) %{_libdir}/libsvn_repos-1.so.*.*.*
739 %attr(755,root,root) %ghost %{_libdir}/libsvn_repos-1.so.0
740 %attr(755,root,root) %{_libdir}/libsvn_subr-1.so.*.*.*
741 %attr(755,root,root) %ghost %{_libdir}/libsvn_subr-1.so.0
742 %attr(755,root,root) %{_libdir}/libsvn_wc-1.so.*.*.*
743 %attr(755,root,root) %ghost %{_libdir}/libsvn_wc-1.so.0
744
745 %files devel
746 %defattr(644,root,root,755)
747 %attr(755,root,root) %{_libdir}/libsvn_client-1.so
748 %attr(755,root,root) %{_libdir}/libsvn_delta-1.so
749 %attr(755,root,root) %{_libdir}/libsvn_diff-1.so
750 %attr(755,root,root) %{_libdir}/libsvn_fs-1.so
751 %if %{without net_client_only}
752 %attr(755,root,root) %{_libdir}/libsvn_fs_base-1.so
753 %endif
754 %attr(755,root,root) %{_libdir}/libsvn_fs_fs-1.so
755 %attr(755,root,root) %{_libdir}/libsvn_fs_util-1.so
756 %attr(755,root,root) %{_libdir}/libsvn_ra-1.so
757 %attr(755,root,root) %{_libdir}/libsvn_ra_local-1.so
758 %attr(755,root,root) %{_libdir}/libsvn_ra_%{webdavlib}-1.so
759 %attr(755,root,root) %{_libdir}/libsvn_ra_svn-1.so
760 %attr(755,root,root) %{_libdir}/libsvn_repos-1.so
761 %attr(755,root,root) %{_libdir}/libsvn_subr-1.so
762 %attr(755,root,root) %{_libdir}/libsvn_wc-1.so
763 %{_libdir}/libsvn_client-1.la
764 %{_libdir}/libsvn_delta-1.la
765 %{_libdir}/libsvn_diff-1.la
766 %{_libdir}/libsvn_fs-1.la
767 %if %{without net_client_only}
768 %{_libdir}/libsvn_fs_base-1.la
769 %endif
770 %{_libdir}/libsvn_fs_fs-1.la
771 %{_libdir}/libsvn_fs_util-1.la
772 %{_libdir}/libsvn_ra-1.la
773 %{_libdir}/libsvn_ra_local-1.la
774 %{_libdir}/libsvn_ra_%{webdavlib}-1.la
775 %{_libdir}/libsvn_ra_svn-1.la
776 %{_libdir}/libsvn_repos-1.la
777 %{_libdir}/libsvn_subr-1.la
778 %{_libdir}/libsvn_wc-1.la
779 %{_includedir}/%{name}-1
780 %{_examplesdir}/%{name}-%{version}
781
782 %files static
783 %defattr(644,root,root,755)
784 %{_libdir}/libsvn_client-1.a
785 %{_libdir}/libsvn_delta-1.a
786 %{_libdir}/libsvn_diff-1.a
787 %{_libdir}/libsvn_fs-1.a
788 %if %{without net_client_only}
789 %{_libdir}/libsvn_fs_base-1.a
790 %endif
791 %{_libdir}/libsvn_fs_fs-1.a
792 %{_libdir}/libsvn_fs_util-1.a
793 %{_libdir}/libsvn_ra-1.a
794 %{_libdir}/libsvn_ra_local-1.a
795 %{_libdir}/libsvn_ra_%{webdavlib}-1.a
796 %{_libdir}/libsvn_ra_svn-1.a
797 %{_libdir}/libsvn_repos-1.a
798 %{_libdir}/libsvn_subr-1.a
799 %{_libdir}/libsvn_wc-1.a
800
801 %if %{with gnome}
802 %files -n gnome-keyring-subversion
803 %defattr(644,root,root,755)
804 %attr(755,root,root) %{_libdir}/libsvn_auth_gnome_keyring-1.so.*.*.*
805 %attr(755,root,root) %ghost %{_libdir}/libsvn_auth_gnome_keyring-1.so.0
806 %endif
807
808 %if %{with kwallet}
809 %files -n kde4-kwallet-subversion
810 %defattr(644,root,root,755)
811 %attr(755,root,root) %{_libdir}/libsvn_auth_kwallet-1.so.*.*.*
812 %attr(755,root,root) %ghost %{_libdir}/libsvn_auth_kwallet-1.so.0
813 %endif
814
815 %if %{without net_client_only}
816 %files svnserve
817 %defattr(644,root,root,755)
818 %attr(755,root,root) %{_bindir}/svnserve
819 %{_mandir}/man5/svnserve.conf.5*
820 %{_mandir}/man8/svnserve.8*
821 %dir %attr(750,svn,svn) /home/services/subversion
822 %dir %attr(750,svn,svn) /home/services/subversion/repos
823 %if %{with apache}
824 %attr(754,root,root) /etc/rc.d/init.d/svnserve
825 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/svnserve
826 %endif
827
828 %files tools
829 %defattr(644,root,root,755)
830 %attr(755,root,root) %{_bindir}/svn-hot-backup
831
832 %files -n bash-completion-subversion
833 %defattr(644,root,root,755)
834 /etc/bash_completion.d/%{name}
835
836 %endif # net_client_only
837
838 %if %{with javahl}
839 %files -n java-subversion
840 %defattr(644,root,root,755)
841 %attr(755,root,root) %{_libdir}/libsvnjavahl-1.so.*.*.*
842 %attr(755,root,root) %ghost %{_libdir}/libsvnjavahl-1.so.0
843 %attr(755,root,root) %{_libdir}/libsvnjavahl-1.so
844 %{_javadir}/svn-javahl.jar
845 %endif
846
847 %if %{with python}
848 %files -n python-subversion
849 %defattr(644,root,root,755)
850 %doc tools/backup/*.py
851 %attr(755,root,root) %{_libdir}/libsvn_swig_py-1.so.*.*.*
852 %attr(755,root,root) %ghost %{_libdir}/libsvn_swig_py-1.so.0
853 %attr(755,root,root) %{_libdir}/libsvn_swig_py-1.so
854 %dir %{py_sitedir}/libsvn
855 %attr(755,root,root) %{py_sitedir}/libsvn/_*.so
856 %{py_sitedir}/libsvn/*.py[co]
857 %dir %{py_sitedir}/svn
858 %{py_sitedir}/svn/*.py[co]
859 %{_examplesdir}/python-%{name}-%{version}
860 %endif
861
862 %if %{with csvn}
863 %files -n python-csvn
864 %defattr(644,root,root,755)
865 %doc subversion/bindings/ctypes-python/{README,TODO}
866 %doc subversion/bindings/ctypes-python/examples/*.py
867 %dir %{py_sitescriptdir}/csvn
868 %{py_sitescriptdir}/csvn/*.py[co]
869 %dir %{py_sitescriptdir}/csvn/core
870 %{py_sitescriptdir}/csvn/core/*.py[co]
871 %dir %{py_sitescriptdir}/csvn/ext
872 %{py_sitescriptdir}/csvn/ext/*.py[co]
873 %{py_sitescriptdir}/svn_ctypes_python_bindings-0.1-py*.egg-info
874 %endif
875
876 %if %{with perl}
877 %files -n perl-subversion
878 %defattr(644,root,root,755)
879 %attr(755,root,root) %{_libdir}/libsvn_swig_perl-1.so.*.*.*
880 %attr(755,root,root) %ghost %{_libdir}/libsvn_swig_perl-1.so.0
881 %attr(755,root,root) %{_libdir}/libsvn_swig_perl-1.so
882 %{perl_vendorarch}/SVN
883 %dir %{perl_vendorarch}/auto/SVN
884 %dir %{perl_vendorarch}/auto/SVN/*
885 %attr(755,root,root) %{perl_vendorarch}/auto/SVN/*/*.so
886 %{perl_vendorarch}/auto/SVN/*/*.bs
887 %{_mandir}/man3/*.3pm*
888 %endif
889
890 %if %{with ruby}
891 %files -n ruby-subversion
892 %defattr(644,root,root,755)
893 %attr(755,root,root) %{_libdir}/libsvn_swig_ruby-1.so.*.*.*
894 %attr(755,root,root) %ghost %{_libdir}/libsvn_swig_ruby-1.so.0
895 %attr(755,root,root) %{_libdir}/libsvn_swig_ruby-1.so
896 %dir %{ruby_sitelibdir}/svn
897 %{ruby_sitelibdir}/svn/*.rb
898 %dir %{ruby_sitearchdir}/svn
899 %dir %{ruby_sitearchdir}/svn/ext
900 %attr(755,root,root) %{ruby_sitearchdir}/svn/ext/*.so
901 %{ruby_ridir}/Svn
902 %endif
903
904 %if %{with apache}
905 %files -n apache-mod_dav_svn
906 %defattr(644,root,root,755)
907 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{apacheconfdir}/*_mod_dav_svn.conf
908 %attr(755,root,root) %{apachelibdir}/mod_dav_svn.so
909
910 %files -n apache-mod_authz_svn
911 %defattr(644,root,root,755)
912 %doc subversion/mod_authz_svn/INSTALL
913 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{apacheconfdir}/*_mod_authz_svn.conf
914 %attr(755,root,root) %{apachelibdir}/mod_authz_svn.so
915 %endif
This page took 0.128821 seconds and 4 git commands to generate.