]> git.pld-linux.org Git - packages/subversion.git/commitdiff
- rel 3
authorJan Rękorajski <baggins@pld-linux.org>
Wed, 19 Oct 2011 19:31:34 +0000 (19:31 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
- only run dav_svn__handler if POST request is for DAV SVN location

Changed files:
    subversion-mod_dav_svn-fix-hook.patch -> 1.1
    subversion.spec -> 1.324

subversion-mod_dav_svn-fix-hook.patch [new file with mode: 0644]
subversion.spec

diff --git a/subversion-mod_dav_svn-fix-hook.patch b/subversion-mod_dav_svn-fix-hook.patch
new file mode 100644 (file)
index 0000000..3c99a2f
--- /dev/null
@@ -0,0 +1,19 @@
+--- subversion-1.7.0/subversion/mod_dav_svn/mod_dav_svn.c.orig 2011-08-19 19:15:15.000000000 +0200
++++ subversion-1.7.0/subversion/mod_dav_svn/mod_dav_svn.c      2011-10-19 21:27:58.273487075 +0200
+@@ -902,6 +902,7 @@
+ /* Response handler for POST requests (protocol-v2 commits).  */
+ static int dav_svn__handler(request_rec *r)
+ {
++ if (dav_svn__get_root_dir(r)) {
+   /* HTTP-defined Methods we handle */
+   r->allowed = 0
+     | (AP_METHOD_BIT << M_POST);
+@@ -909,7 +910,7 @@
+   if (r->method_number == M_POST) {
+     return dav_svn__method_post(r);
+   }
+-
++ }
+   return DECLINED;
+ }
index 361b69104d921c8e7f9e8d3b1fbb90b3a9d65504..afbd30fa0b25764d9b2652bfacc79dff5b8c53c0 100644 (file)
@@ -51,7 +51,7 @@ Summary(pl.UTF-8):    System kontroli wersji podobny, ale lepszy, niż CVS
 Summary(pt_BR.UTF-8):  Sistema de versionamento concorrente
 Name:          subversion
 Version:       1.7.0
-Release:       2
+Release:       3
 License:       Apache/BSD-like
 Group:         Development/Version Control
 Source0:       http://www.apache.org/dist/subversion/%{name}-%{version}.tar.bz2
@@ -68,6 +68,7 @@ Patch0:               %{name}-home_etc.patch
 Patch1:                %{name}-DESTDIR.patch
 Patch2:                %{name}-ruby-datadir-path.patch
 Patch3:                %{name}-tests.patch
+Patch4:                %{name}-mod_dav_svn-fix-hook.patch
 URL:           http://subversion.apache.org/
 %{?with_apache:BuildRequires:  apache-devel >= 2.2.0-8}
 BuildRequires: apr-devel >= 1:1.0.0
@@ -424,6 +425,7 @@ uwierzytelniać się przy użyciu Portfela KDE.
 %patch1 -p1
 %patch2 -p0
 %patch3 -p1
+%patch4 -p1
 
 sed -i -e 's#serf_prefix/lib#serf_prefix/%{_lib}#g' build/ac-macros/serf.m4
 
This page took 0.106038 seconds and 4 git commands to generate.