]> git.pld-linux.org Git - packages/spl.git/commitdiff
- up to 0.6.5.1
authorJan Rękorajski <baggins@pld-linux.org>
Sun, 27 Sep 2015 15:52:22 +0000 (17:52 +0200)
committerJan Rękorajski <baggins@pld-linux.org>
Sun, 27 Sep 2015 15:52:22 +0000 (17:52 +0200)
linux-3.17.patch [deleted file]
linux-3.18.patch [deleted file]
linux-3.19.patch [deleted file]
spl.spec

diff --git a/linux-3.17.patch b/linux-3.17.patch
deleted file mode 100644 (file)
index a5de0e3..0000000
+++ /dev/null
@@ -1,39 +0,0 @@
---- spl-0.6.3/module/spl/spl-kmem.c~   2014-06-12 22:59:01.000000000 +0200
-+++ spl-0.6.3/module/spl/spl-kmem.c    2014-11-09 16:42:21.157985621 +0100
-@@ -26,6 +26,7 @@
- #include <sys/kmem.h>
- #include <spl-debug.h>
-+#include <linux/version.h>
- #ifdef SS_DEBUG_SUBSYS
- #undef SS_DEBUG_SUBSYS
-@@ -1889,12 +1889,14 @@
-       return !test_bit(KMC_BIT_GROWING, &skc->skc_flags);
- }
-+#if ( LINUX_VERSION_CODE < KERNEL_VERSION(3,17,0) )
- static int
- spl_cache_reclaim_wait(void *word)
- {
-       schedule();
-       return 0;
- }
-+#endif
- /*
-  * No available objects on any slabs, create a new slab.  Note that this
-@@ -1917,8 +1919,13 @@
-        * then return so the local magazine can be rechecked for new objects.
-        */
-       if (test_bit(KMC_BIT_REAPING, &skc->skc_flags)) {
-+#if ( LINUX_VERSION_CODE < KERNEL_VERSION(3,17,0) )
-               rc = wait_on_bit(&skc->skc_flags, KMC_BIT_REAPING,
-                   spl_cache_reclaim_wait, TASK_UNINTERRUPTIBLE);
-+#else
-+              rc = wait_on_bit_io(&skc->skc_flags, KMC_BIT_REAPING,
-+                  TASK_UNINTERRUPTIBLE);
-+#endif
-               SRETURN(rc ? rc : -EAGAIN);
-       }
diff --git a/linux-3.18.patch b/linux-3.18.patch
deleted file mode 100644 (file)
index c33d8d9..0000000
+++ /dev/null
@@ -1,14 +0,0 @@
---- spl-0.6.3/module/spl/spl-kmem.c~   2015-01-26 00:23:23.000000000 +0100
-+++ spl-0.6.3/module/spl/spl-kmem.c    2015-01-26 00:24:13.312560884 +0100
-@@ -2369,7 +2369,11 @@
-       spl_slab_reclaim(skc, count, 1);
-       clear_bit(KMC_BIT_REAPING, &skc->skc_flags);
-+#if ( LINUX_VERSION_CODE < KERNEL_VERSION(3,18,0) )
-       smp_mb__after_clear_bit();
-+#else
-+      smp_mb__after_atomic();
-+#endif
-       wake_up_bit(&skc->skc_flags, KMC_BIT_REAPING);
- out:
-       atomic_dec(&skc->skc_ref);
diff --git a/linux-3.19.patch b/linux-3.19.patch
deleted file mode 100644 (file)
index 6625f3c..0000000
+++ /dev/null
@@ -1,58 +0,0 @@
---- spl-0.6.3/module/splat/splat-ctl.c~        2014-06-12 22:59:01.000000000 +0200
-+++ spl-0.6.3/module/splat/splat-ctl.c 2015-03-30 21:10:25.522172731 +0200
-@@ -49,6 +49,7 @@
- #include <linux/cdev.h>
- #include <linux/fs.h>
- #include <linux/uaccess.h>
-+#include <linux/version.h>
- #include <sys/types.h>
- #include <sys/debug.h>
- #include "splat-internal.h"
-@@ -457,7 +457,11 @@
- static long
- splat_unlocked_ioctl(struct file *file, unsigned int cmd, unsigned long arg)
- {
-+#if LINUX_VERSION_CODE >= KERNEL_VERSION(3,19,0)
-+        unsigned int minor = iminor(file->f_path.dentry->d_inode);
-+#else
-         unsigned int minor = iminor(file->f_dentry->d_inode);
-+#endif
-       int rc = 0;
-       /* Ignore tty ioctls */
-@@ -499,7 +503,11 @@
- static ssize_t splat_write(struct file *file, const char __user *buf,
-                          size_t count, loff_t *ppos)
- {
-+#if LINUX_VERSION_CODE >= KERNEL_VERSION(3,19,0)
-+        unsigned int minor = iminor(file->f_path.dentry->d_inode);
-+#else
-         unsigned int minor = iminor(file->f_dentry->d_inode);
-+#endif
-       splat_info_t *info = (splat_info_t *)file->private_data;
-       int rc = 0;
-@@ -536,7 +544,11 @@
- static ssize_t splat_read(struct file *file, char __user *buf,
-                       size_t count, loff_t *ppos)
- {
-+#if LINUX_VERSION_CODE >= KERNEL_VERSION(3,19,0)
-+        unsigned int minor = iminor(file->f_path.dentry->d_inode);
-+#else
-         unsigned int minor = iminor(file->f_dentry->d_inode);
-+#endif
-       splat_info_t *info = (splat_info_t *)file->private_data;
-       int rc = 0;
-@@ -570,7 +582,11 @@
- static loff_t splat_seek(struct file *file, loff_t offset, int origin)
- {
-+#if LINUX_VERSION_CODE >= KERNEL_VERSION(3,19,0)
-+        unsigned int minor = iminor(file->f_path.dentry->d_inode);
-+#else
-         unsigned int minor = iminor(file->f_dentry->d_inode);
-+#endif
-       splat_info_t *info = (splat_info_t *)file->private_data;
-       int rc = -EINVAL;
index abd9b7c4244f5e5a40fdd6cb84d6b478b8dd672f..0a458696aae16b5423e5e5d6b34a7ef66ee22242 100644 (file)
--- a/spl.spec
+++ b/spl.spec
@@ -21,19 +21,16 @@ exit 1
 %define                _duplicate_files_terminate_build        0
 
 %define                pname   spl
-%define                rel     7
+%define                rel     1
 Summary:       Solaris Porting Layer
 Summary(pl.UTF-8):     Solaris Porting Layer - warstwa do portowania kodu z Solarisa
 Name:          %{pname}%{?_pld_builder:%{?with_kernel:-kernel}}%{_alt_kernel}
-Version:       0.6.3
+Version:       0.6.5.1
 Release:       %{rel}%{?_pld_builder:%{?with_kernel:@%{_kernel_ver_str}}}
 License:       GPL v2+
 Group:         Applications/System
 Source0:       http://archive.zfsonlinux.org/downloads/zfsonlinux/spl/%{pname}-%{version}.tar.gz
-# Source0-md5: 8df6ce3c8f1d9af6526b36f5079cba59
-Patch0:                linux-3.17.patch
-Patch1:                linux-3.18.patch
-Patch2:                linux-3.19.patch
+# Source0-md5: 687bbaffd6b57328ea09dc97308c5ab4
 URL:           http://zfsonlinux.org/
 BuildRequires: rpmbuild(macros) >= 1.701
 %{?with_kernel:%{expand:%buildrequires_kernel kernel%%{_alt_kernel}-module-build >= 3:2.6.20.2}}
@@ -124,9 +121,6 @@ p=`pwd`\
 
 %prep
 %setup -q -n %{pname}-%{version}
-%patch0 -p1
-%patch1 -p1
-%patch2 -p1
 
 %build
 %{__aclocal} -I config
This page took 0.074121 seconds and 4 git commands to generate.