]> git.pld-linux.org Git - packages/spl.git/commitdiff
- fix building with linux 3.19 auto/th/spl-0.6.3-7
authorJan Rękorajski <baggins@pld-linux.org>
Mon, 30 Mar 2015 19:14:20 +0000 (21:14 +0200)
committerJan Rękorajski <baggins@pld-linux.org>
Mon, 30 Mar 2015 19:14:20 +0000 (21:14 +0200)
- rel 7

linux-3.19.patch [new file with mode: 0644]
spl.spec

diff --git a/linux-3.19.patch b/linux-3.19.patch
new file mode 100644 (file)
index 0000000..6625f3c
--- /dev/null
@@ -0,0 +1,58 @@
+--- spl-0.6.3/module/splat/splat-ctl.c~        2014-06-12 22:59:01.000000000 +0200
++++ spl-0.6.3/module/splat/splat-ctl.c 2015-03-30 21:10:25.522172731 +0200
+@@ -49,6 +49,7 @@
+ #include <linux/cdev.h>
+ #include <linux/fs.h>
+ #include <linux/uaccess.h>
++#include <linux/version.h>
+ #include <sys/types.h>
+ #include <sys/debug.h>
+ #include "splat-internal.h"
+@@ -457,7 +457,11 @@
+ static long
+ splat_unlocked_ioctl(struct file *file, unsigned int cmd, unsigned long arg)
+ {
++#if LINUX_VERSION_CODE >= KERNEL_VERSION(3,19,0)
++        unsigned int minor = iminor(file->f_path.dentry->d_inode);
++#else
+         unsigned int minor = iminor(file->f_dentry->d_inode);
++#endif
+       int rc = 0;
+       /* Ignore tty ioctls */
+@@ -499,7 +503,11 @@
+ static ssize_t splat_write(struct file *file, const char __user *buf,
+                          size_t count, loff_t *ppos)
+ {
++#if LINUX_VERSION_CODE >= KERNEL_VERSION(3,19,0)
++        unsigned int minor = iminor(file->f_path.dentry->d_inode);
++#else
+         unsigned int minor = iminor(file->f_dentry->d_inode);
++#endif
+       splat_info_t *info = (splat_info_t *)file->private_data;
+       int rc = 0;
+@@ -536,7 +544,11 @@
+ static ssize_t splat_read(struct file *file, char __user *buf,
+                       size_t count, loff_t *ppos)
+ {
++#if LINUX_VERSION_CODE >= KERNEL_VERSION(3,19,0)
++        unsigned int minor = iminor(file->f_path.dentry->d_inode);
++#else
+         unsigned int minor = iminor(file->f_dentry->d_inode);
++#endif
+       splat_info_t *info = (splat_info_t *)file->private_data;
+       int rc = 0;
+@@ -570,7 +582,11 @@
+ static loff_t splat_seek(struct file *file, loff_t offset, int origin)
+ {
++#if LINUX_VERSION_CODE >= KERNEL_VERSION(3,19,0)
++        unsigned int minor = iminor(file->f_path.dentry->d_inode);
++#else
+         unsigned int minor = iminor(file->f_dentry->d_inode);
++#endif
+       splat_info_t *info = (splat_info_t *)file->private_data;
+       int rc = -EINVAL;
index 8ea05033d00ca6e36807867194a6aff3801c5074..abd9b7c4244f5e5a40fdd6cb84d6b478b8dd672f 100644 (file)
--- a/spl.spec
+++ b/spl.spec
@@ -21,7 +21,7 @@ exit 1
 %define                _duplicate_files_terminate_build        0
 
 %define                pname   spl
-%define                rel     6
+%define                rel     7
 Summary:       Solaris Porting Layer
 Summary(pl.UTF-8):     Solaris Porting Layer - warstwa do portowania kodu z Solarisa
 Name:          %{pname}%{?_pld_builder:%{?with_kernel:-kernel}}%{_alt_kernel}
@@ -33,6 +33,7 @@ Source0:      http://archive.zfsonlinux.org/downloads/zfsonlinux/spl/%{pname}-%{versi
 # Source0-md5: 8df6ce3c8f1d9af6526b36f5079cba59
 Patch0:                linux-3.17.patch
 Patch1:                linux-3.18.patch
+Patch2:                linux-3.19.patch
 URL:           http://zfsonlinux.org/
 BuildRequires: rpmbuild(macros) >= 1.701
 %{?with_kernel:%{expand:%buildrequires_kernel kernel%%{_alt_kernel}-module-build >= 3:2.6.20.2}}
@@ -125,6 +126,7 @@ p=`pwd`\
 %setup -q -n %{pname}-%{version}
 %patch0 -p1
 %patch1 -p1
+%patch2 -p1
 
 %build
 %{__aclocal} -I config
This page took 0.061017 seconds and 4 git commands to generate.