]> git.pld-linux.org Git - packages/sbcl.git/blob - sbcl.spec
- updated to 1.1.6
[packages/sbcl.git] / sbcl.spec
1 #
2 # Conditional build:
3 %bcond_without  doc             # build without documentation
4 %bcond_with     clisp           # build using clisp instead of sbcl
5 #
6 # To build with an unpackaged Common Lisp implementation,
7 # pass --define bootstrap_cl /path/to/lisp/binary to builder.
8 #
9 Summary:        The Steel Bank Common Lisp development environment
10 Summary(pl.UTF-8):      Środowisko programowania Steel Bank Common Lisp
11 Name:           sbcl
12 Version:        1.1.6
13 Release:        0.1
14 License:        MIT
15 Group:          Development/Languages
16 Source0:        http://download.sourceforge.net/sbcl/%{name}-%{version}-source.tar.bz2
17 # Source0-md5:  5daeabb9eaf7197006c4402bfc552d72
18 Source10:       http://download.sourceforge.net/sbcl/sbcl-1.0.58-x86-linux-binary.tar.bz2
19 # Source10-md5: 28104cfb0ee2ac67000c77b9518377e8
20 Source11:       http://download.sourceforge.net/sbcl/sbcl-1.0.58-x86-64-linux-binary.tar.bz2
21 # Source11-md5: 3d02edfdc851904d1d8dafeec20d1d06
22 Patch1:         %{name}-threads.patch
23 URL:            http://sbcl.sourceforge.net/
24 %{?with_clisp:BuildRequires:    clisp}
25 %if %{with doc}
26 BuildRequires:  tetex-dvips
27 BuildRequires:  texinfo-texi2dvi
28 %endif
29 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
30
31 %description
32 Steel Bank Common Lisp (SBCL) is a Open Source development environment
33 for Common Lisp based on CMUCL. It includes an integrated native compiler,
34 interpreter, and debugger.
35
36 %description -l pl.UTF-8
37 Steel Bank Common Lisp (SBCL) to środowisko programistyczne Open
38 Source dla Common Lispa oparte na CMUCL. Zawiera zintegrowany natywny
39 kompilator, interpreter i debugger.
40
41 %package doc-info
42 Summary:        The Steel Bank Common Lisp documentation (info)
43 Summary(pl.UTF-8):      Dokumentacja Steel Bank Common Lisp (info)
44 Group:          Development/Languages
45
46 %description doc-info
47 Documentation of Steel Bank Common Lisp (SBCL) in info format.
48
49 %description doc-info -l pl.UTF-8
50 Dokumentacja Steel Bank Common Lisp (SBCL) w formacie info.
51
52 %package doc-html
53 Summary:        The Steel Bank Common Lisp documentation (HTML)
54 Summary(pl.UTF-8):      Dokumentacja Steel Bank Common Lisp (HTML)
55 Group:          Development/Languages
56
57 %description doc-html
58 Documentation of Steel Bank Common Lisp (SBCL) in HTML format.
59
60 %description doc-html -l pl.UTF-8
61 Dokumentacja Steel Bank Common Lisp (SBCL) w formacie HTML.
62
63 %package doc-pdf
64 Summary:        The Steel Bank Common Lisp documentation (PDF)
65 Summary(pl.UTF-8):      Dokumentacja Steel Bank Common Lisp (PDF)
66 Group:          Development/Languages
67
68 %description doc-pdf
69 Documentation of Steel Bank Common Lisp (SBCL) in PDF format.
70
71 %description doc-pdf -l pl.UTF-8
72 Dokumentacja Steel Bank Common Lisp (SBCL) w formacie PDF.
73
74 %prep
75 %ifarch %{ix86}
76 %setup -q -a 10
77 %endif
78 %ifarch %{x8664}
79 %setup -q -a 11
80 %endif
81 %ifarch %{ix86} %{x8664}
82 %patch1 -p1
83 %endif
84
85 mkdir sbcl-bootstrap
86 cd sbcl-*-linux
87 INSTALL_ROOT=`pwd`/../sbcl-bootstrap sh ./install.sh
88 cd -
89
90 # clean.sh is so stupid it removed sbcl-bootstrap contents
91 %{__mv} clean.sh clean.sh.orig
92 echo "#!/bin/sh" >clean.sh
93 chmod 755 clean.sh
94
95 %if %{with clisp}
96 %define bootstrap_cl "clisp"
97 %endif
98
99 %build
100 GNUMAKE="make"
101 CFLAGS="%{rpmcflags}"
102 CC="%{__cc}"
103 export GNUMAKE CC CFLAGS
104 export SBCL_HOME=`pwd`/sbcl-bootstrap/lib/sbcl
105 export PATH=`pwd`/sbcl-bootstrap/bin:${PATH}
106 ./make.sh \
107         --prefix=%{_prefix} \
108         %{?bootstrap_cl}
109
110 %if %{with doc}
111 make -C doc/manual
112 %endif
113
114 %install
115 rm -rf $RPM_BUILD_ROOT
116 install -d $RPM_BUILD_ROOT{%{_bindir},%{_libdir},%{_mandir},%{_infodir}} \
117         $RPM_BUILD_ROOT/etc/env.d
118
119 env -u SBCL_HOME INSTALL_ROOT=`pwd`/_install %{_buildshell} ./install.sh
120
121 %{__mv} _install/lib/sbcl $RPM_BUILD_ROOT%{_libdir}/%{name}
122 %{__mv} _install/bin/sbcl $RPM_BUILD_ROOT%{_bindir}/%{name}
123 %{__mv} _install/share/man/* $RPM_BUILD_ROOT%{_mandir}
124 %if %{with doc}
125 %{__mv} _install/share/info/*.info* $RPM_BUILD_ROOT%{_infodir}
126 %endif
127
128 echo SBCL_HOME=%{_libdir}/%{name} > $RPM_BUILD_ROOT/etc/env.d/SBCL_HOME
129
130 %clean
131 rm -rf $RPM_BUILD_ROOT
132
133 %post
134 %env_update
135
136 %postun
137 %env_update
138
139 %if %{with doc}
140 %post doc-info  -p /sbin/postshell
141 -/usr/sbin/fix-info-dir -c %{_infodir}
142
143 %postun doc-info
144 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
145 %endif
146
147 %files
148 %defattr(644,root,root,755)
149 %doc _install/share/doc/sbcl/[A-Z]*
150 %attr (755,root,root) %{_bindir}/%{name}
151 %{_libdir}/%{name}
152 %{_mandir}/man1/*
153 %config(noreplace,missingok) %verify(not md5 mtime size) /etc/env.d/*
154
155 %if %{with doc}
156 %files doc-info
157 %defattr(644,root,root,755)
158 %{_infodir}/*.info*
159
160 %files doc-html
161 %defattr(644,root,root,755)
162 %doc _install/share/doc/sbcl/*.html
163
164 %files doc-pdf
165 %defattr(644,root,root,755)
166 %doc _install/share/doc/sbcl/*.pdf
167 %endif
This page took 0.891741 seconds and 3 git commands to generate.