]> git.pld-linux.org Git - packages/sbcl.git/commitdiff
- updated to 1.1.6
authorJan Rękorajski <baggins@pld-linux.org>
Fri, 26 Apr 2013 10:37:27 +0000 (12:37 +0200)
committerJan Rękorajski <baggins@pld-linux.org>
Fri, 26 Apr 2013 10:37:27 +0000 (12:37 +0200)
- reworked bootstrap to use internal binaries (clisp no longer works)

sbcl-home.patch [deleted file]
sbcl-threads.patch
sbcl.spec

diff --git a/sbcl-home.patch b/sbcl-home.patch
deleted file mode 100644 (file)
index 3f5378c..0000000
+++ /dev/null
@@ -1,11 +0,0 @@
---- sbcl-0.9.0/src/runtime/runtime.c.~1.45.~   2005-04-02 12:30:53.000000000 +0200
-+++ sbcl-0.9.0/src/runtime/runtime.c   2005-05-04 17:42:30.015235075 +0200
-@@ -62,7 +62,7 @@
- #endif
- #ifndef SBCL_HOME
--#define SBCL_HOME "/usr/local/lib/sbcl/"
-+#define SBCL_HOME "/usr/lib/sbcl/"
- #endif
\f
index 2665eba4a763804ba930ece8998222b7c0ab7e3b..291fdc0e5fcf422fb94120bd8da797d03122414f 100644 (file)
@@ -1,9 +1,9 @@
 --- sbcl-0.9.10/base-target-features.lisp-expr.~1.38.~ 2006-02-21 20:53:56.000000000 +0100
 +++ sbcl-0.9.10/base-target-features.lisp-expr 2006-03-13 21:12:30.000000000 +0100
 @@ -160,7 +160,7 @@
-  ;; and the %fs segment register.  Note that no consistent effort to
-  ;; audit the SBCL library code for thread safety has been performed,
-  ;; so caveat executor.
+  ;; As of SBCL 1.0.33.26, threads are part of the default build on
+  ;; x86oid Linux. Other platforms that support them include
+  ;; x86oid Darwin, FreeBSD, and Solaris.
 - ; :sb-thread
 + :sb-thread
  
index 06f56c64697e83a8a58276cc96defec9e8168bdc..667ab8b7b6d11805ee40dbf661a774dd796f2911 100644 (file)
--- a/sbcl.spec
+++ b/sbcl.spec
@@ -9,22 +9,19 @@
 Summary:       The Steel Bank Common Lisp development environment
 Summary(pl.UTF-8):     Środowisko programowania Steel Bank Common Lisp
 Name:          sbcl
-Version:       1.0.16
-Release:       1
+Version:       1.1.6
+Release:       0.1
 License:       MIT
 Group:         Development/Languages
-Source0:       http://dl.sourceforge.net/sbcl/%{name}-%{version}-source.tar.bz2
-# Source0-md5: 7256bed59a34b0a3efef540711bd3786
-Patch0:                %{name}-home.patch
+Source0:       http://download.sourceforge.net/sbcl/%{name}-%{version}-source.tar.bz2
+# Source0-md5: 5daeabb9eaf7197006c4402bfc552d72
+Source10:      http://download.sourceforge.net/sbcl/sbcl-1.0.58-x86-linux-binary.tar.bz2
+# Source10-md5:        28104cfb0ee2ac67000c77b9518377e8
+Source11:      http://download.sourceforge.net/sbcl/sbcl-1.0.58-x86-64-linux-binary.tar.bz2
+# Source11-md5:        3d02edfdc851904d1d8dafeec20d1d06
 Patch1:                %{name}-threads.patch
 URL:           http://sbcl.sourceforge.net/
-%if %{undefined bootstrap_cl}
-%if %{with clisp}
-BuildRequires: clisp
-%else
-BuildRequires: sbcl
-%endif
-%endif
+%{?with_clisp:BuildRequires:   clisp}
 %if %{with doc}
 BuildRequires: tetex-dvips
 BuildRequires: texinfo-texi2dvi
@@ -75,18 +72,28 @@ Documentation of Steel Bank Common Lisp (SBCL) in PDF format.
 Dokumentacja Steel Bank Common Lisp (SBCL) w formacie PDF.
 
 %prep
-%setup -q
-%patch0 -p1
+%ifarch %{ix86}
+%setup -q -a 10
+%endif
+%ifarch %{x8664}
+%setup -q -a 11
+%endif
 %ifarch %{ix86} %{x8664}
 %patch1 -p1
 %endif
 
-%if %{undefined bootstrap_cl}
+mkdir sbcl-bootstrap
+cd sbcl-*-linux
+INSTALL_ROOT=`pwd`/../sbcl-bootstrap sh ./install.sh
+cd -
+
+# clean.sh is so stupid it removed sbcl-bootstrap contents
+%{__mv} clean.sh clean.sh.orig
+echo "#!/bin/sh" >clean.sh
+chmod 755 clean.sh
+
 %if %{with clisp}
 %define bootstrap_cl "clisp"
-%else
-%define bootstrap_cl "sbcl --disable-debugger"
-%endif
 %endif
 
 %build
@@ -94,22 +101,28 @@ GNUMAKE="make"
 CFLAGS="%{rpmcflags}"
 CC="%{__cc}"
 export GNUMAKE CC CFLAGS
-./make.sh %{bootstrap_cl}
+export SBCL_HOME=`pwd`/sbcl-bootstrap/lib/sbcl
+export PATH=`pwd`/sbcl-bootstrap/bin:${PATH}
+./make.sh \
+       --prefix=%{_prefix} \
+       %{?bootstrap_cl}
+
 %if %{with doc}
 make -C doc/manual
 %endif
 
 %install
 rm -rf $RPM_BUILD_ROOT
-mkdir -p $RPM_BUILD_ROOT%{_bindir} $RPM_BUILD_ROOT%{_libdir} \
-    $RPM_BUILD_ROOT%{_mandir} $RPM_BUILD_ROOT%{_infodir} \
-    $RPM_BUILD_ROOT/etc/env.d
+install -d $RPM_BUILD_ROOT{%{_bindir},%{_libdir},%{_mandir},%{_infodir}} \
+       $RPM_BUILD_ROOT/etc/env.d
+
 env -u SBCL_HOME INSTALL_ROOT=`pwd`/_install %{_buildshell} ./install.sh
-mv _install/lib/sbcl $RPM_BUILD_ROOT%{_libdir}/%{name}
-mv _install/bin/sbcl $RPM_BUILD_ROOT%{_bindir}/%{name}
-mv _install/share/man/* $RPM_BUILD_ROOT%{_mandir}
+
+%{__mv} _install/lib/sbcl $RPM_BUILD_ROOT%{_libdir}/%{name}
+%{__mv} _install/bin/sbcl $RPM_BUILD_ROOT%{_bindir}/%{name}
+%{__mv} _install/share/man/* $RPM_BUILD_ROOT%{_mandir}
 %if %{with doc}
-mv _install/share/info/*.info* $RPM_BUILD_ROOT%{_infodir}
+%{__mv} _install/share/info/*.info* $RPM_BUILD_ROOT%{_infodir}
 %endif
 
 echo SBCL_HOME=%{_libdir}/%{name} > $RPM_BUILD_ROOT/etc/env.d/SBCL_HOME
@@ -124,7 +137,7 @@ rm -rf $RPM_BUILD_ROOT
 %env_update
 
 %if %{with doc}
-%post doc-info -p      /sbin/postshell
+%post doc-info -p /sbin/postshell
 -/usr/sbin/fix-info-dir -c %{_infodir}
 
 %postun doc-info
@@ -146,7 +159,7 @@ rm -rf $RPM_BUILD_ROOT
 
 %files doc-html
 %defattr(644,root,root,755)
-%doc _install/share/doc/sbcl/html/*
+%doc _install/share/doc/sbcl/*.html
 
 %files doc-pdf
 %defattr(644,root,root,755)
This page took 0.121848 seconds and 4 git commands to generate.