]> git.pld-linux.org Git - packages/rstudio.git/blob - rstudio.spec
- fix moc parsing with boost 1.57.0
[packages/rstudio.git] / rstudio.spec
1 Summary:        IDE for R
2 Summary(pl.UTF-8):      IDE dla R
3 Name:           rstudio
4 Version:        0.99.39
5 Release:        2
6 License:        AGPLv3
7 Group:          Applications
8 Source0:        https://github.com/rstudio/rstudio/archive/v%{version}.tar.gz?/%{name}-%{version}.tar.gz
9 # Source0-md5:  8b340edf12a40806daafffad9e3849f0
10 Source1:        https://s3.amazonaws.com/rstudio-dictionaries/core-dictionaries.zip
11 # Source1-md5:  0e03798b8e53096c4a906bde05e32378
12 Source2:        https://s3.amazonaws.com/rstudio-buildtools/gwt-2.6.0.zip
13 # Source2-md5:  b08b2b0c50ef2249703aa8422388d5db
14 Source3:        https://s3.amazonaws.com/rstudio-buildtools/gin-1.5.zip
15 # Source3-md5:  2409168cc18bf5f341e107e6887fe359
16 Source4:        https://s3.amazonaws.com/rstudio-buildtools/mathjax-23.zip
17 # Source4-md5:  5853c0494c6b28557d6b7cecaa790019
18 Source5:        https://s3.amazonaws.com/rstudio-buildtools/pandoc-1.12.4.2.zip
19 # Source5-md5:  d0f7e3d23b42cb9d26d2783d659040cf
20 Source6:        https://s3.amazonaws.com/rstudio-buildtools/libclang-3.5.zip
21 # Source6-md5:  cf1a43d2d6203a765ef16d7b12382c8a
22 Source7:        https://s3.amazonaws.com/rstudio-buildtools/libclang-builtin-headers.zip
23 # Source7-md5:  e6790a3ee6c371968eba865fc0a84daf
24 Source8:        packrat_0.4.1.24_bbdab984134678db91b8f372e2550e59f266de37.tar.xz
25 # Source8-md5:  7607927c4adf507d67d2ba18d38c7bb0
26 Source9:        rmarkdown_0.3.12_8a78f712202263200f2110ec8aa24a55c2726e37.tar.xz
27 # Source9-md5:  358f9f4bf2f35dd58d4771f6b24d252e
28 Source10:       shinyapps_0.3.61_d3ab9e1cdd02f0067d69fe6fc816a61c8a5f2218.tar.xz
29 # Source10-md5: 3f5ce12f86b00a2e77067d7769fffe08
30 Patch0:         boost-moc.patch
31 URL:            http://rstudio.org/
32 BuildRequires:  QtWebKit-devel
33 BuildRequires:  QtXmlPatterns-devel
34 BuildRequires:  R >= 2.11.1
35 BuildRequires:  boost-devel >= 1.50
36 BuildRequires:  clang-devel >= 3.5.0
37 BuildRequires:  cmake >= 2.8.0
38 BuildRequires:  java-junit
39 BuildRequires:  openssl-devel
40 BuildRequires:  pam-devel
41 BuildRequires:  pandoc
42 BuildRequires:  pango-devel
43 Requires:       R >= 2.11.1
44 Requires:       pandoc
45 Requires:       clang >= 3.5.0
46 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
47
48 %description
49 RStudio(tm) is a free and open source integrated development
50 environment (IDE) for R. You can run it on your desktop (Windows, Mac,
51 or Linux) or even over the web using RStudio Server.
52
53 %prep
54 %setup -q
55 mkdir -p dependencies/common/dictionaries
56 unzip -qq %{SOURCE1} -d dependencies/common/dictionaries
57 mkdir -p src/gwt/lib/gwt
58 mkdir -p src/gwt/lib/gin/1.5
59 unzip -qq %{SOURCE2} -d src/gwt/lib/gwt
60 unzip -qq %{SOURCE3} -d src/gwt/lib/gin/1.5
61 %{__mv} src/gwt/lib/gwt/gwt-2.6.0 src/gwt/lib/gwt/2.6.0
62 unzip -qq %{SOURCE4} -d dependencies/common
63
64 xz -dc %{SOURCE8} | tar xf - -C dependencies/common/
65 xz -dc %{SOURCE9} | tar xf - -C dependencies/common/
66 xz -dc %{SOURCE10} | tar xf - -C dependencies/common/
67
68 # fix building with boost 1.56
69 # specify that namespace core is in the global namespace and not
70 # relative to some other namespace (like its ::core not ::boost::core)
71 find . \( -name *.cpp -or -name *.hpp \) -exec sed \
72         -e 's@<core::@< ::core::@g' -e 's@\([^:]\)core::@\1::core::@g' -i {} \;
73
74 # rstudio wants 1.12.4.2, let it think that
75 mkdir -p dependencies/common/pandoc/1.12.4.2
76 ln -s %{_bindir}/pandoc dependencies/common/pandoc/1.12.4.2/pandoc
77 ln -s %{_bindir}/pandoc dependencies/common/pandoc/1.12.4.2/pandoc-static
78
79 mkdir -p dependencies/common/libclang/3.5/include/
80 ln -s /usr/include/clang-c dependencies/common/libclang/3.5/include/
81 mkdir -p dependencies/common/libclang/builtin-headers
82 ln -s /usr/lib64/clang/3.5.0/include dependencies/common/libclang/builtin-headers/3.5
83 #dependencies/common/libclang/builtin-headers/libc++/3.5
84 %ifarch %{ix86}
85 mkdir -p dependencies/common/libclang/3.5/linux/x86
86 ln -s %{_libdir}/libclang.so dependencies/common/libclang/3.5/linux/x86/libclang.so
87 %endif
88 %ifarch %{x8664}
89 mkdir -p dependencies/common/libclang/3.5/linux/x86_64
90 ln -s %{_libdir}/libclang.so dependencies/common/libclang/3.5/linux/x86_64/libclang.so
91 %endif
92
93 %patch0 -p1
94
95 %build
96 install -d build
97 cd build
98 %cmake \
99         -DCMAKE_CXX_FLAGS_RELEASE="${CXXFLAGS:-%{rpmcxxflags} -DNDEBUG -DQT_NO_DEBUG}" \
100         -DCMAKE_C_FLAGS_RELEASE="${CFLAGS:-%{rpmcflags} -DNDEBUG -DQT_NO_DEBUG}" \
101         -DRSTUDIO_TARGET=Desktop \
102         -DCMAKE_BUILD_TYPE=Release \
103         -DCMAKE_INSTALL_PREFIX=%{_libdir}/%{name} \
104         ../
105
106 %{__make}
107
108 %install
109 rm -rf $RPM_BUILD_ROOT
110 install -d $RPM_BUILD_ROOT%{_bindir}
111
112 %{__make} -C build install/fast \
113         DESTDIR=$RPM_BUILD_ROOT
114
115 ln -s %{_libdir}/%{name}/bin/rstudio $RPM_BUILD_ROOT%{_bindir}
116
117 %clean
118 rm -rf $RPM_BUILD_ROOT
119
120 %files
121 %defattr(644,root,root,755)
122 %doc COPYING NOTICE README.md
123 %attr(755,root,root) %{_bindir}/*
124 %dir %{_libdir}/%{name}
125 %{_libdir}/%{name}/R
126 %dir %{_libdir}/%{name}/bin
127 %attr(755,root,root) %{_libdir}/%{name}/bin/diagnostics
128 %attr(755,root,root) %{_libdir}/%{name}/bin/r*
129 %dir %{_libdir}/%{name}/bin/postback
130 %attr(755,root,root) %{_libdir}/%{name}/bin/postback/*
131 %attr(755,root,root) %{_libdir}/%{name}/bin/pandoc*
132 %{_libdir}/%{name}/resources
133 %{_libdir}/%{name}/www
134 %{_libdir}/%{name}/www-symbolmaps
135 %{_libdir}/%{name}/rstudio.png
136 %{_desktopdir}/rstudio.desktop
137 %{_iconsdir}/hicolor/*x*/apps/*
138 %{_iconsdir}/hicolor/*x*/mimetypes/*
139 %{_datadir}/mime/packages/*.xml
140 %{_pixmapsdir}/rstudio.png
This page took 0.06855 seconds and 3 git commands to generate.