]> git.pld-linux.org Git - packages/rstudio.git/blame - rstudio.spec
- fix moc parsing with boost 1.57.0
[packages/rstudio.git] / rstudio.spec
CommitLineData
9d0bf5de
JR
1Summary: IDE for R
2Summary(pl.UTF-8): IDE dla R
3Name: rstudio
57694567 4Version: 0.99.39
ff706f6c 5Release: 2
9d0bf5de
JR
6License: AGPLv3
7Group: Applications
57694567
JR
8Source0: https://github.com/rstudio/rstudio/archive/v%{version}.tar.gz?/%{name}-%{version}.tar.gz
9# Source0-md5: 8b340edf12a40806daafffad9e3849f0
10Source1: https://s3.amazonaws.com/rstudio-dictionaries/core-dictionaries.zip
11# Source1-md5: 0e03798b8e53096c4a906bde05e32378
12Source2: https://s3.amazonaws.com/rstudio-buildtools/gwt-2.6.0.zip
13# Source2-md5: b08b2b0c50ef2249703aa8422388d5db
14Source3: https://s3.amazonaws.com/rstudio-buildtools/gin-1.5.zip
15# Source3-md5: 2409168cc18bf5f341e107e6887fe359
16Source4: https://s3.amazonaws.com/rstudio-buildtools/mathjax-23.zip
17# Source4-md5: 5853c0494c6b28557d6b7cecaa790019
18Source5: https://s3.amazonaws.com/rstudio-buildtools/pandoc-1.12.4.2.zip
19# Source5-md5: d0f7e3d23b42cb9d26d2783d659040cf
20Source6: https://s3.amazonaws.com/rstudio-buildtools/libclang-3.5.zip
21# Source6-md5: cf1a43d2d6203a765ef16d7b12382c8a
22Source7: https://s3.amazonaws.com/rstudio-buildtools/libclang-builtin-headers.zip
23# Source7-md5: e6790a3ee6c371968eba865fc0a84daf
24Source8: packrat_0.4.1.24_bbdab984134678db91b8f372e2550e59f266de37.tar.xz
25# Source8-md5: 7607927c4adf507d67d2ba18d38c7bb0
26Source9: rmarkdown_0.3.12_8a78f712202263200f2110ec8aa24a55c2726e37.tar.xz
27# Source9-md5: 358f9f4bf2f35dd58d4771f6b24d252e
28Source10: shinyapps_0.3.61_d3ab9e1cdd02f0067d69fe6fc816a61c8a5f2218.tar.xz
29# Source10-md5: 3f5ce12f86b00a2e77067d7769fffe08
ff706f6c 30Patch0: boost-moc.patch
9d0bf5de
JR
31URL: http://rstudio.org/
32BuildRequires: QtWebKit-devel
33BuildRequires: QtXmlPatterns-devel
34BuildRequires: R >= 2.11.1
57694567 35BuildRequires: boost-devel >= 1.50
4c3e022e 36BuildRequires: clang-devel >= 3.5.0
9d0bf5de
JR
37BuildRequires: cmake >= 2.8.0
38BuildRequires: java-junit
39BuildRequires: openssl-devel
40BuildRequires: pam-devel
74881e45 41BuildRequires: pandoc
9d0bf5de
JR
42BuildRequires: pango-devel
43Requires: R >= 2.11.1
78c56072
JR
44Requires: pandoc
45Requires: clang >= 3.5.0
9d0bf5de
JR
46BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
47
48%description
446bd661
ER
49RStudio(tm) is a free and open source integrated development
50environment (IDE) for R. You can run it on your desktop (Windows, Mac,
51or Linux) or even over the web using RStudio Server.
9d0bf5de
JR
52
53%prep
57694567
JR
54%setup -q
55mkdir -p dependencies/common/dictionaries
56unzip -qq %{SOURCE1} -d dependencies/common/dictionaries
9d0bf5de
JR
57mkdir -p src/gwt/lib/gwt
58mkdir -p src/gwt/lib/gin/1.5
57694567
JR
59unzip -qq %{SOURCE2} -d src/gwt/lib/gwt
60unzip -qq %{SOURCE3} -d src/gwt/lib/gin/1.5
61%{__mv} src/gwt/lib/gwt/gwt-2.6.0 src/gwt/lib/gwt/2.6.0
62unzip -qq %{SOURCE4} -d dependencies/common
57694567
JR
63
64xz -dc %{SOURCE8} | tar xf - -C dependencies/common/
65xz -dc %{SOURCE9} | tar xf - -C dependencies/common/
66xz -dc %{SOURCE10} | tar xf - -C dependencies/common/
67
68# fix building with boost 1.56
69# specify that namespace core is in the global namespace and not
70# relative to some other namespace (like its ::core not ::boost::core)
71find . \( -name *.cpp -or -name *.hpp \) -exec sed \
72 -e 's@<core::@< ::core::@g' -e 's@\([^:]\)core::@\1::core::@g' -i {} \;
9d0bf5de 73
74881e45
JR
74# rstudio wants 1.12.4.2, let it think that
75mkdir -p dependencies/common/pandoc/1.12.4.2
76ln -s %{_bindir}/pandoc dependencies/common/pandoc/1.12.4.2/pandoc
77ln -s %{_bindir}/pandoc dependencies/common/pandoc/1.12.4.2/pandoc-static
78
4c3e022e
JR
79mkdir -p dependencies/common/libclang/3.5/include/
80ln -s /usr/include/clang-c dependencies/common/libclang/3.5/include/
81mkdir -p dependencies/common/libclang/builtin-headers
82ln -s /usr/lib64/clang/3.5.0/include dependencies/common/libclang/builtin-headers/3.5
83#dependencies/common/libclang/builtin-headers/libc++/3.5
84%ifarch %{ix86}
85mkdir -p dependencies/common/libclang/3.5/linux/x86
86ln -s %{_libdir}/libclang.so dependencies/common/libclang/3.5/linux/x86/libclang.so
87%endif
88%ifarch %{x8664}
89mkdir -p dependencies/common/libclang/3.5/linux/x86_64
90ln -s %{_libdir}/libclang.so dependencies/common/libclang/3.5/linux/x86_64/libclang.so
91%endif
92
ff706f6c
JR
93%patch0 -p1
94
9d0bf5de
JR
95%build
96install -d build
97cd build
98%cmake \
57694567
JR
99 -DCMAKE_CXX_FLAGS_RELEASE="${CXXFLAGS:-%{rpmcxxflags} -DNDEBUG -DQT_NO_DEBUG}" \
100 -DCMAKE_C_FLAGS_RELEASE="${CFLAGS:-%{rpmcflags} -DNDEBUG -DQT_NO_DEBUG}" \
9d0bf5de
JR
101 -DRSTUDIO_TARGET=Desktop \
102 -DCMAKE_BUILD_TYPE=Release \
103 -DCMAKE_INSTALL_PREFIX=%{_libdir}/%{name} \
104 ../
105
106%{__make}
107
108%install
109rm -rf $RPM_BUILD_ROOT
110install -d $RPM_BUILD_ROOT%{_bindir}
111
112%{__make} -C build install/fast \
113 DESTDIR=$RPM_BUILD_ROOT
114
115ln -s %{_libdir}/%{name}/bin/rstudio $RPM_BUILD_ROOT%{_bindir}
116
117%clean
118rm -rf $RPM_BUILD_ROOT
119
120%files
121%defattr(644,root,root,755)
122%doc COPYING NOTICE README.md
123%attr(755,root,root) %{_bindir}/*
124%dir %{_libdir}/%{name}
125%{_libdir}/%{name}/R
126%dir %{_libdir}/%{name}/bin
1a5a515a 127%attr(755,root,root) %{_libdir}/%{name}/bin/diagnostics
9d0bf5de
JR
128%attr(755,root,root) %{_libdir}/%{name}/bin/r*
129%dir %{_libdir}/%{name}/bin/postback
130%attr(755,root,root) %{_libdir}/%{name}/bin/postback/*
78c56072 131%attr(755,root,root) %{_libdir}/%{name}/bin/pandoc*
9d0bf5de
JR
132%{_libdir}/%{name}/resources
133%{_libdir}/%{name}/www
4c3e022e 134%{_libdir}/%{name}/www-symbolmaps
9d0bf5de
JR
135%{_libdir}/%{name}/rstudio.png
136%{_desktopdir}/rstudio.desktop
137%{_iconsdir}/hicolor/*x*/apps/*
138%{_iconsdir}/hicolor/*x*/mimetypes/*
139%{_datadir}/mime/packages/*.xml
140%{_pixmapsdir}/rstudio.png
This page took 0.094141 seconds and 4 git commands to generate.