]> git.pld-linux.org Git - packages/rstudio.git/blob - rstudio.spec
- updated R and files
[packages/rstudio.git] / rstudio.spec
1 Summary:        IDE for R
2 Summary(pl.UTF-8):      IDE dla R
3 Name:           rstudio
4 Version:        0.99.39
5 Release:        1
6 License:        AGPLv3
7 Group:          Applications
8 Source0:        https://github.com/rstudio/rstudio/archive/v%{version}.tar.gz?/%{name}-%{version}.tar.gz
9 # Source0-md5:  8b340edf12a40806daafffad9e3849f0
10 Source1:        https://s3.amazonaws.com/rstudio-dictionaries/core-dictionaries.zip
11 # Source1-md5:  0e03798b8e53096c4a906bde05e32378
12 Source2:        https://s3.amazonaws.com/rstudio-buildtools/gwt-2.6.0.zip
13 # Source2-md5:  b08b2b0c50ef2249703aa8422388d5db
14 Source3:        https://s3.amazonaws.com/rstudio-buildtools/gin-1.5.zip
15 # Source3-md5:  2409168cc18bf5f341e107e6887fe359
16 Source4:        https://s3.amazonaws.com/rstudio-buildtools/mathjax-23.zip
17 # Source4-md5:  5853c0494c6b28557d6b7cecaa790019
18 Source5:        https://s3.amazonaws.com/rstudio-buildtools/pandoc-1.12.4.2.zip
19 # Source5-md5:  d0f7e3d23b42cb9d26d2783d659040cf
20 Source6:        https://s3.amazonaws.com/rstudio-buildtools/libclang-3.5.zip
21 # Source6-md5:  cf1a43d2d6203a765ef16d7b12382c8a
22 Source7:        https://s3.amazonaws.com/rstudio-buildtools/libclang-builtin-headers.zip
23 # Source7-md5:  e6790a3ee6c371968eba865fc0a84daf
24 Source8:        packrat_0.4.1.24_bbdab984134678db91b8f372e2550e59f266de37.tar.xz
25 # Source8-md5:  7607927c4adf507d67d2ba18d38c7bb0
26 Source9:        rmarkdown_0.3.12_8a78f712202263200f2110ec8aa24a55c2726e37.tar.xz
27 # Source9-md5:  358f9f4bf2f35dd58d4771f6b24d252e
28 Source10:       shinyapps_0.3.61_d3ab9e1cdd02f0067d69fe6fc816a61c8a5f2218.tar.xz
29 # Source10-md5: 3f5ce12f86b00a2e77067d7769fffe08
30 URL:            http://rstudio.org/
31 BuildRequires:  QtWebKit-devel
32 BuildRequires:  QtXmlPatterns-devel
33 BuildRequires:  R >= 2.11.1
34 BuildRequires:  boost-devel >= 1.50
35 BuildRequires:  clang-devel >= 3.5.0
36 BuildRequires:  cmake >= 2.8.0
37 BuildRequires:  java-junit
38 BuildRequires:  openssl-devel
39 BuildRequires:  pam-devel
40 BuildRequires:  pandoc
41 BuildRequires:  pango-devel
42 Requires:       R >= 2.11.1
43 Requires:       pandoc
44 Requires:       clang >= 3.5.0
45 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
46
47 %description
48 RStudio(tm) is a free and open source integrated development
49 environment (IDE) for R. You can run it on your desktop (Windows, Mac,
50 or Linux) or even over the web using RStudio Server.
51
52 %prep
53 %setup -q
54 mkdir -p dependencies/common/dictionaries
55 unzip -qq %{SOURCE1} -d dependencies/common/dictionaries
56 mkdir -p src/gwt/lib/gwt
57 mkdir -p src/gwt/lib/gin/1.5
58 unzip -qq %{SOURCE2} -d src/gwt/lib/gwt
59 unzip -qq %{SOURCE3} -d src/gwt/lib/gin/1.5
60 %{__mv} src/gwt/lib/gwt/gwt-2.6.0 src/gwt/lib/gwt/2.6.0
61 unzip -qq %{SOURCE4} -d dependencies/common
62
63 xz -dc %{SOURCE8} | tar xf - -C dependencies/common/
64 xz -dc %{SOURCE9} | tar xf - -C dependencies/common/
65 xz -dc %{SOURCE10} | tar xf - -C dependencies/common/
66
67 # fix building with boost 1.56
68 # specify that namespace core is in the global namespace and not
69 # relative to some other namespace (like its ::core not ::boost::core)
70 find . \( -name *.cpp -or -name *.hpp \) -exec sed \
71         -e 's@<core::@< ::core::@g' -e 's@\([^:]\)core::@\1::core::@g' -i {} \;
72
73 # rstudio wants 1.12.4.2, let it think that
74 mkdir -p dependencies/common/pandoc/1.12.4.2
75 ln -s %{_bindir}/pandoc dependencies/common/pandoc/1.12.4.2/pandoc
76 ln -s %{_bindir}/pandoc dependencies/common/pandoc/1.12.4.2/pandoc-static
77
78 mkdir -p dependencies/common/libclang/3.5/include/
79 ln -s /usr/include/clang-c dependencies/common/libclang/3.5/include/
80 mkdir -p dependencies/common/libclang/builtin-headers
81 ln -s /usr/lib64/clang/3.5.0/include dependencies/common/libclang/builtin-headers/3.5
82 #dependencies/common/libclang/builtin-headers/libc++/3.5
83 %ifarch %{ix86}
84 mkdir -p dependencies/common/libclang/3.5/linux/x86
85 ln -s %{_libdir}/libclang.so dependencies/common/libclang/3.5/linux/x86/libclang.so
86 %endif
87 %ifarch %{x8664}
88 mkdir -p dependencies/common/libclang/3.5/linux/x86_64
89 ln -s %{_libdir}/libclang.so dependencies/common/libclang/3.5/linux/x86_64/libclang.so
90 %endif
91
92 %build
93 install -d build
94 cd build
95 %cmake \
96         -DCMAKE_CXX_FLAGS_RELEASE="${CXXFLAGS:-%{rpmcxxflags} -DNDEBUG -DQT_NO_DEBUG}" \
97         -DCMAKE_C_FLAGS_RELEASE="${CFLAGS:-%{rpmcflags} -DNDEBUG -DQT_NO_DEBUG}" \
98         -DRSTUDIO_TARGET=Desktop \
99         -DCMAKE_BUILD_TYPE=Release \
100         -DCMAKE_INSTALL_PREFIX=%{_libdir}/%{name} \
101         ../
102
103 %{__make}
104
105 %install
106 rm -rf $RPM_BUILD_ROOT
107 install -d $RPM_BUILD_ROOT%{_bindir}
108
109 %{__make} -C build install/fast \
110         DESTDIR=$RPM_BUILD_ROOT
111
112 ln -s %{_libdir}/%{name}/bin/rstudio $RPM_BUILD_ROOT%{_bindir}
113
114 %clean
115 rm -rf $RPM_BUILD_ROOT
116
117 %files
118 %defattr(644,root,root,755)
119 %doc COPYING NOTICE README.md
120 %attr(755,root,root) %{_bindir}/*
121 %dir %{_libdir}/%{name}
122 %{_libdir}/%{name}/R
123 %dir %{_libdir}/%{name}/bin
124 %attr(755,root,root) %{_libdir}/%{name}/bin/diagnostics
125 %attr(755,root,root) %{_libdir}/%{name}/bin/r*
126 %dir %{_libdir}/%{name}/bin/postback
127 %attr(755,root,root) %{_libdir}/%{name}/bin/postback/*
128 %attr(755,root,root) %{_libdir}/%{name}/bin/pandoc*
129 %{_libdir}/%{name}/resources
130 %{_libdir}/%{name}/www
131 %{_libdir}/%{name}/www-symbolmaps
132 %{_libdir}/%{name}/rstudio.png
133 %{_desktopdir}/rstudio.desktop
134 %{_iconsdir}/hicolor/*x*/apps/*
135 %{_iconsdir}/hicolor/*x*/mimetypes/*
136 %{_datadir}/mime/packages/*.xml
137 %{_pixmapsdir}/rstudio.png
This page took 0.058671 seconds and 3 git commands to generate.