]> git.pld-linux.org Git - packages/rstudio.git/blame - rstudio.spec
- updated R and files
[packages/rstudio.git] / rstudio.spec
CommitLineData
9d0bf5de
JR
1Summary: IDE for R
2Summary(pl.UTF-8): IDE dla R
3Name: rstudio
57694567 4Version: 0.99.39
4c3e022e 5Release: 1
9d0bf5de
JR
6License: AGPLv3
7Group: Applications
57694567
JR
8Source0: https://github.com/rstudio/rstudio/archive/v%{version}.tar.gz?/%{name}-%{version}.tar.gz
9# Source0-md5: 8b340edf12a40806daafffad9e3849f0
10Source1: https://s3.amazonaws.com/rstudio-dictionaries/core-dictionaries.zip
11# Source1-md5: 0e03798b8e53096c4a906bde05e32378
12Source2: https://s3.amazonaws.com/rstudio-buildtools/gwt-2.6.0.zip
13# Source2-md5: b08b2b0c50ef2249703aa8422388d5db
14Source3: https://s3.amazonaws.com/rstudio-buildtools/gin-1.5.zip
15# Source3-md5: 2409168cc18bf5f341e107e6887fe359
16Source4: https://s3.amazonaws.com/rstudio-buildtools/mathjax-23.zip
17# Source4-md5: 5853c0494c6b28557d6b7cecaa790019
18Source5: https://s3.amazonaws.com/rstudio-buildtools/pandoc-1.12.4.2.zip
19# Source5-md5: d0f7e3d23b42cb9d26d2783d659040cf
20Source6: https://s3.amazonaws.com/rstudio-buildtools/libclang-3.5.zip
21# Source6-md5: cf1a43d2d6203a765ef16d7b12382c8a
22Source7: https://s3.amazonaws.com/rstudio-buildtools/libclang-builtin-headers.zip
23# Source7-md5: e6790a3ee6c371968eba865fc0a84daf
24Source8: packrat_0.4.1.24_bbdab984134678db91b8f372e2550e59f266de37.tar.xz
25# Source8-md5: 7607927c4adf507d67d2ba18d38c7bb0
26Source9: rmarkdown_0.3.12_8a78f712202263200f2110ec8aa24a55c2726e37.tar.xz
27# Source9-md5: 358f9f4bf2f35dd58d4771f6b24d252e
28Source10: shinyapps_0.3.61_d3ab9e1cdd02f0067d69fe6fc816a61c8a5f2218.tar.xz
29# Source10-md5: 3f5ce12f86b00a2e77067d7769fffe08
9d0bf5de
JR
30URL: http://rstudio.org/
31BuildRequires: QtWebKit-devel
32BuildRequires: QtXmlPatterns-devel
33BuildRequires: R >= 2.11.1
57694567 34BuildRequires: boost-devel >= 1.50
4c3e022e 35BuildRequires: clang-devel >= 3.5.0
9d0bf5de
JR
36BuildRequires: cmake >= 2.8.0
37BuildRequires: java-junit
38BuildRequires: openssl-devel
39BuildRequires: pam-devel
74881e45 40BuildRequires: pandoc
9d0bf5de
JR
41BuildRequires: pango-devel
42Requires: R >= 2.11.1
78c56072
JR
43Requires: pandoc
44Requires: clang >= 3.5.0
9d0bf5de
JR
45BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
46
47%description
446bd661
ER
48RStudio(tm) is a free and open source integrated development
49environment (IDE) for R. You can run it on your desktop (Windows, Mac,
50or Linux) or even over the web using RStudio Server.
9d0bf5de
JR
51
52%prep
57694567
JR
53%setup -q
54mkdir -p dependencies/common/dictionaries
55unzip -qq %{SOURCE1} -d dependencies/common/dictionaries
9d0bf5de
JR
56mkdir -p src/gwt/lib/gwt
57mkdir -p src/gwt/lib/gin/1.5
57694567
JR
58unzip -qq %{SOURCE2} -d src/gwt/lib/gwt
59unzip -qq %{SOURCE3} -d src/gwt/lib/gin/1.5
60%{__mv} src/gwt/lib/gwt/gwt-2.6.0 src/gwt/lib/gwt/2.6.0
61unzip -qq %{SOURCE4} -d dependencies/common
57694567
JR
62
63xz -dc %{SOURCE8} | tar xf - -C dependencies/common/
64xz -dc %{SOURCE9} | tar xf - -C dependencies/common/
65xz -dc %{SOURCE10} | tar xf - -C dependencies/common/
66
67# fix building with boost 1.56
68# specify that namespace core is in the global namespace and not
69# relative to some other namespace (like its ::core not ::boost::core)
70find . \( -name *.cpp -or -name *.hpp \) -exec sed \
71 -e 's@<core::@< ::core::@g' -e 's@\([^:]\)core::@\1::core::@g' -i {} \;
9d0bf5de 72
74881e45
JR
73# rstudio wants 1.12.4.2, let it think that
74mkdir -p dependencies/common/pandoc/1.12.4.2
75ln -s %{_bindir}/pandoc dependencies/common/pandoc/1.12.4.2/pandoc
76ln -s %{_bindir}/pandoc dependencies/common/pandoc/1.12.4.2/pandoc-static
77
4c3e022e
JR
78mkdir -p dependencies/common/libclang/3.5/include/
79ln -s /usr/include/clang-c dependencies/common/libclang/3.5/include/
80mkdir -p dependencies/common/libclang/builtin-headers
81ln -s /usr/lib64/clang/3.5.0/include dependencies/common/libclang/builtin-headers/3.5
82#dependencies/common/libclang/builtin-headers/libc++/3.5
83%ifarch %{ix86}
84mkdir -p dependencies/common/libclang/3.5/linux/x86
85ln -s %{_libdir}/libclang.so dependencies/common/libclang/3.5/linux/x86/libclang.so
86%endif
87%ifarch %{x8664}
88mkdir -p dependencies/common/libclang/3.5/linux/x86_64
89ln -s %{_libdir}/libclang.so dependencies/common/libclang/3.5/linux/x86_64/libclang.so
90%endif
91
9d0bf5de
JR
92%build
93install -d build
94cd build
95%cmake \
57694567
JR
96 -DCMAKE_CXX_FLAGS_RELEASE="${CXXFLAGS:-%{rpmcxxflags} -DNDEBUG -DQT_NO_DEBUG}" \
97 -DCMAKE_C_FLAGS_RELEASE="${CFLAGS:-%{rpmcflags} -DNDEBUG -DQT_NO_DEBUG}" \
9d0bf5de
JR
98 -DRSTUDIO_TARGET=Desktop \
99 -DCMAKE_BUILD_TYPE=Release \
100 -DCMAKE_INSTALL_PREFIX=%{_libdir}/%{name} \
101 ../
102
103%{__make}
104
105%install
106rm -rf $RPM_BUILD_ROOT
107install -d $RPM_BUILD_ROOT%{_bindir}
108
109%{__make} -C build install/fast \
110 DESTDIR=$RPM_BUILD_ROOT
111
112ln -s %{_libdir}/%{name}/bin/rstudio $RPM_BUILD_ROOT%{_bindir}
113
114%clean
115rm -rf $RPM_BUILD_ROOT
116
117%files
118%defattr(644,root,root,755)
119%doc COPYING NOTICE README.md
120%attr(755,root,root) %{_bindir}/*
121%dir %{_libdir}/%{name}
122%{_libdir}/%{name}/R
123%dir %{_libdir}/%{name}/bin
1a5a515a 124%attr(755,root,root) %{_libdir}/%{name}/bin/diagnostics
9d0bf5de
JR
125%attr(755,root,root) %{_libdir}/%{name}/bin/r*
126%dir %{_libdir}/%{name}/bin/postback
127%attr(755,root,root) %{_libdir}/%{name}/bin/postback/*
78c56072 128%attr(755,root,root) %{_libdir}/%{name}/bin/pandoc*
9d0bf5de
JR
129%{_libdir}/%{name}/resources
130%{_libdir}/%{name}/www
4c3e022e 131%{_libdir}/%{name}/www-symbolmaps
9d0bf5de
JR
132%{_libdir}/%{name}/rstudio.png
133%{_desktopdir}/rstudio.desktop
134%{_iconsdir}/hicolor/*x*/apps/*
135%{_iconsdir}/hicolor/*x*/mimetypes/*
136%{_datadir}/mime/packages/*.xml
137%{_pixmapsdir}/rstudio.png
This page took 0.094237 seconds and 4 git commands to generate.