]> git.pld-linux.org Git - packages/rpm.git/commitdiff
- drop lua hacks and look for default lua version
authorJan Rękorajski <baggins@pld-linux.org>
Sat, 24 Oct 2020 13:50:57 +0000 (15:50 +0200)
committerJan Rękorajski <baggins@pld-linux.org>
Sat, 24 Oct 2020 13:50:57 +0000 (15:50 +0200)
- don't obsolete rpm-getdeps, this rpm does not support --specsrpm

rpm-lua.patch [deleted file]
rpm.spec

diff --git a/rpm-lua.patch b/rpm-lua.patch
deleted file mode 100644 (file)
index 4e92e7b..0000000
+++ /dev/null
@@ -1,11 +0,0 @@
---- rpm-5.0.2/configure.ac~    2008-02-19 20:09:59.000000000 +0200
-+++ rpm-5.0.2/configure.ac     2008-02-19 20:21:41.000000000 +0200
-@@ -1042,7 +1042,7 @@
- AS_IF([test "$with_lua" != no],[
-   PKG_CHECK_MODULES([LUA],
--    [lua >= 5.1],
-+    [lua5.3 >= 5.3],
-     [AC_DEFINE(WITH_LUA, 1, [Build with lua support?])],
-     [AC_MSG_ERROR([lua not present (--without-lua to disable)])])
-   AC_SUBST(LUA_CFLAGS)
index 1280ac6a91230cb6402f68d3d8d765861008d1a6..d9dd581ce5c32971f9b6bcfe17cb52cfd76e986e 100644 (file)
--- a/rpm.spec
+++ b/rpm.spec
@@ -55,7 +55,6 @@ Patch1:               %{name}-popt-aliases.patch
 Patch2:                %{name}-perl-macros.patch
 Patch3:                %{name}-perl-req-perlfile.patch
 Patch4:                %{name}-scripts-closefds.patch
-Patch5:                %{name}-lua.patch
 Patch6:                %{name}-perl_req-INC_dirs.patch
 Patch7:                %{name}-debuginfo.patch
 Patch8:                %{name}-libtool-deps.patch
@@ -90,7 +89,7 @@ BuildRequires:        libselinux-devel >= 2.1.0
 # needed only for AM_PROG_CXX used for CXX substitution in rpm.macros
 BuildRequires: libstdc++-devel
 BuildRequires: libtool >= 1:1.4.2-9
-BuildRequires: lua53-devel >= 5.3.5
+BuildRequires: lua-devel >= 5.1
 BuildRequires: ossp-uuid-devel
 BuildRequires: patch >= 2.2
 BuildRequires: popt-devel >= %{popt_ver}
@@ -123,7 +122,6 @@ Recommends: rpm-plugin-prioreset
 Recommends:    rpm-plugin-syslog
 Recommends:    rpm-plugin-systemd-inhibit
 %endif
-Obsoletes:     rpm-getdeps
 Obsoletes:     rpm-utils-perl
 Obsoletes:     rpm-utils-static
 Conflicts:     glibc < 2.2.92
@@ -541,7 +539,6 @@ Dokumentacja API RPM-a oraz przewodniki w formacie HTML generowane ze
 %patch2 -p1
 %patch3 -p1
 %patch4 -p1
-%patch5 -p1
 %patch6 -p0
 %patch7 -p1
 %patch8 -p1
@@ -584,7 +581,6 @@ sed -i \
        -e 's|@host_os@|%{_target_os}|' \
        macros.in
 
-CPPFLAGS="-I/usr/include/lua53 %{rpmcppflags}"
 %configure \
        WITH_PERL_VERSION=no \
        __GST_INSPECT=%{_bindir}/gst-inspect-1.0 \
This page took 0.081514 seconds and 4 git commands to generate.