]> git.pld-linux.org Git - packages/rpm.git/blob - rpm.spec
- drop lua hacks and look for default lua version
[packages/rpm.git] / rpm.spec
1 #
2 # TODO:
3 # - rebuild database after upgrading from rpm5
4 # - when adopting, use 4.5 ticket for checklist: https://bugs.launchpad.net/pld-linux/+bug/262985
5 #
6 # Conditional build:
7 %bcond_without  apidocs         # don't generate documentation with doxygen
8 %bcond_without  python3         # don't build python bindings
9 %bcond_without  plugins         # build plugins
10 %bcond_without  recommends_tags # build without Recommends tag (bootstrapping)
11 %bcond_with     imaevm          # build with IMA/EVM support (requires libimaevm from ima-evm-utils)
12
13 %define         db_ver          5.3.28.0
14 %define         popt_ver        1.15
15 %define         openssl_ver     1.1.1d
16 %define         sover           9.1.0
17
18 Summary:        RPM Package Manager
19 Summary(de.UTF-8):      RPM Packet-Manager
20 Summary(es.UTF-8):      Gestor de paquetes RPM
21 Summary(pl.UTF-8):      Aplikacja do zarządzania pakietami RPM
22 Summary(pt_BR.UTF-8):   Gerenciador de pacotes RPM
23 Summary(ru.UTF-8):      Менеджер пакетов от RPM
24 Summary(uk.UTF-8):      Менеджер пакетів від RPM
25 Name:           rpm
26 Version:        4.16.0
27 Release:        0.1
28 Epoch:          1
29 License:        GPL v2 / LGPL v2.1
30 Group:          Base
31 Source0:        http://ftp.rpm.org/releases/rpm-4.16.x/%{name}-%{version}.tar.bz2
32 # Source0-md5:  434e166a812e35ef181f6dd176326920
33 Source1:        ftp://ftp.pld-linux.org/dists/th/PLD-3.0-Th-GPG-key.asc
34 # Source1-md5:  23914bb49fafe7153cee87126d966461
35 Source2:        macros.local
36 Source3:        macros.lang
37 Source4:        %{name}.sysconfig
38 Source5:        %{name}.groups
39 Source6:        %{name}-groups-po.awk
40 Source7:        %{name}-install-tree
41 Source8:        %{name}-hrmib-cache
42 Source9:        %{name}-user_group.sh
43 # http://svn.pld-linux.org/banner.sh/
44 Source10:       banner.sh
45 Source11:       %{name}.noautoprov
46 Source12:       %{name}.noautoprovfiles
47 Source13:       %{name}.noautoreq
48 Source14:       %{name}.noautoreqfiles
49 Source15:       perl.prov
50 Source16:       %{name}db_checkversion.c
51 Source17:       %{name}db_reset.c
52 Source18:       dbupgrade.sh
53 Patch0:         %{name}-man_pl.patch
54 Patch1:         %{name}-popt-aliases.patch
55 Patch2:         %{name}-perl-macros.patch
56 Patch3:         %{name}-perl-req-perlfile.patch
57 Patch4:         %{name}-scripts-closefds.patch
58 Patch6:         %{name}-perl_req-INC_dirs.patch
59 Patch7:         %{name}-debuginfo.patch
60 Patch8:         %{name}-libtool-deps.patch
61 Patch9:         %{name}-builddir-readlink.patch
62 Patch10:        %{name}-changelog_order_check_nonfatal.patch
63 Patch11:        %{name}-postun-nofail.patch
64 Patch12:        %{name}-clean-docdir.patch
65 Patch13:        %{name}-perl-magic.patch
66 Patch14:        %{name}-ignore-missing-macro-files.patch
67 Patch15:        x32.patch
68 Patch16:        rpm5-db-compat.patch
69 Patch17:        python-internal-build.patch
70 Patch18:        rpmversion.patch
71 Patch19:        pkgconfig.patch
72 Patch20:        uname-deps.patch
73 URL:            https://rpm.org/
74 BuildRequires:  db-devel >= %{db_ver}
75 BuildRequires:  autoconf >= 2.63
76 BuildRequires:  automake >= 1.4
77 BuildRequires:  bzip2-devel >= 1.0.2-17
78 BuildRequires:  elfutils-devel >= 0.108
79 BuildRequires:  gettext-tools >= 0.19.2
80 BuildRequires:  libarchive-devel
81 BuildRequires:  libmagic-devel
82 BuildRequires:  openssl-devel >= %{openssl_ver}
83 %if %{with plugins}
84 BuildRequires:  audit-libs-devel
85 BuildRequires:  dbus-devel
86 %{?with_imaevm:BuildRequires:   libimaevm-devel >= 1.0}
87 BuildRequires:  libselinux-devel >= 2.1.0
88 %endif
89 # needed only for AM_PROG_CXX used for CXX substitution in rpm.macros
90 BuildRequires:  libstdc++-devel
91 BuildRequires:  libtool >= 1:1.4.2-9
92 BuildRequires:  lua-devel >= 5.1
93 BuildRequires:  ossp-uuid-devel
94 BuildRequires:  patch >= 2.2
95 BuildRequires:  popt-devel >= %{popt_ver}
96 BuildRequires:  python3-modules
97 %if %{with python3}
98 BuildRequires:  python3-devel
99 BuildRequires:  rpm-pythonprov
100 %endif
101 BuildRequires:  sqlite3-devel >= 3.22.0
102 BuildRequires:  tcl
103 BuildRequires:  xz-devel
104 BuildRequires:  zlib-devel
105 BuildRequires:  zstd-devel
106 %if %{with apidocs}
107 BuildRequires:  doxygen
108 BuildRequires:  ghostscript
109 BuildRequires:  graphviz
110 BuildRequires:  tetex-pdftex
111 %endif
112 Requires(posttrans):    coreutils
113 Requires:       %{name}-base = %{epoch}:%{version}-%{release}
114 Requires:       %{name}-lib = %{epoch}:%{version}-%{release}
115 Requires:       rpm-pld-macros >= 1.744
116 Requires:       FHS >= 3.0-2
117 Requires:       openssl >= %{openssl_ver}
118 Requires:       popt >= %{popt_ver}
119 %if %{with recommends_tags}
120 Recommends:     rpm-plugin-audit
121 Recommends:     rpm-plugin-prioreset
122 Recommends:     rpm-plugin-syslog
123 Recommends:     rpm-plugin-systemd-inhibit
124 %endif
125 Obsoletes:      rpm-utils-perl
126 Obsoletes:      rpm-utils-static
127 Conflicts:      glibc < 2.2.92
128 # db4.6 poldek needed
129 Conflicts:      poldek < 0.21-0.20070703.00.3
130 # segfaults with lzma 0.42.2
131 Conflicts:      lzma-libs < 4.999.3
132 Conflicts:      util-vserver < 0.30.216-1.pre3034.7
133 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
134
135 %define         _binary_payload         w9.gzdio
136
137 # don't require very fresh rpm.macros to build
138 %define         find_lang sh ./scripts/find-lang.sh $RPM_BUILD_ROOT
139 %define         ix86    i386 i486 i586 i686 athlon geode pentium3 pentium4
140 %define         ppc     ppc ppc7400 ppc7450
141 %define         x8664   amd64 ia32e x86_64
142
143 %define         _rpmlibdir /usr/lib/rpm
144
145 %description
146 RPM is a powerful package manager, which can be used to build,
147 install, query, verify, update, and uninstall individual software
148 packages. A package consists of an archive of files, and package
149 information, including name, version, and description.
150
151 %description -l de.UTF-8
152 RPM ist ein kräftiger Packet-Manager, der verwendet sein kann zur
153 Installation, Anfrage, Verifizierung, Aktualisierung und
154 Uninstallation individueller Softwarepakete. Ein Paket besteht aus
155 einem Archiv Dateien und Paketinformation, inklusive Name, Version und
156 Beschreibung.
157
158 %description -l es.UTF-8
159 RPM es un poderoso administrador de paquetes, que puede ser usado para
160 construir, instalar, pesquisar, verificar, actualizar y desinstalar
161 paquetes individuales de software. Un paquete consiste en un
162 almacenaje de archivos, y información sobre el paquete, incluyendo
163 nombre, versión y descripción.
164
165 %description -l pl.UTF-8
166 RPM jest doskonałym programem zarządzającym pakietami. Umożliwia on
167 przebudowanie, instalację czy weryfikację dowolnego pakietu.
168 Informacje dotyczące każdego pakietu, takie jak jego opis, lista
169 plików wchodzących w skład pakietu, zależności od innych pakietów, są
170 przechowywane w bazie danych i można je uzyskać za pomocą opcji
171 odpytywania programu rpm.
172
173 %description -l pt_BR.UTF-8
174 RPM é um poderoso gerenciador de pacotes, que pode ser usado para
175 construir, instalar, pesquisar, verificar, atualizar e desinstalar
176 pacotes individuais de software. Um pacote consiste de um conjunto de
177 arquivos e informações adicionais, incluindo nome, versão e descrição
178 do pacote, permissões dos arquivos, etc.
179
180 %description -l ru.UTF-8
181 RPM - это мощный менеджер пакетов, который может быть использован для
182 создания, инсталляции, запросов (query), проверки, обновления и
183 удаления программных пакетов. Пакет состоит из файлового архива и
184 служебной информации, включающей название, версию, описание и другие
185 данные о пакете.
186
187 %description -l uk.UTF-8
188 RPM - це потужний менеджер пакетів, що може бути використаний для
189 створення, інсталяції, запитів (query), перевірки, поновлення та
190 видалення програмних пакетів. Пакет складається з файлового архіву та
191 службової інформації, що містить назву, версію, опис та іншу
192 інформацію про пакет.
193
194 %package base
195 Summary:        RPM base package - scripts used by rpm packages themselves
196 Summary(pl.UTF-8):      Podstawowy pakiet RPM - skrypty używane przez same pakiety rpm
197 Group:          Base
198 Requires:       filesystem
199 Obsoletes:      rpm-scripts
200 Obsoletes:      vserver-rpm
201
202 %description base
203 The RPM base package contains scripts used by rpm packages themselves.
204 These include:
205 - scripts for adding/removing groups and users needed for rpm
206   packages,
207 - banner.sh to display %%banner messages from rpm scriptlets.
208
209 %description base -l pl.UTF-8
210 Pakiet podstawowy RPM zwiera skrypty używane przez same pakiety rpm.
211 Zawiera on:
212 - skrypty dodające/usuwające grupy i użytkowników dla pakietów rpm,
213 - banner.sh do pokazywania komunikatów %%banner dla skryptletów rpm.
214
215 %package lib
216 Summary:        RPMs library
217 Summary(pl.UTF-8):      Biblioteki RPM-a
218 Group:          Libraries
219 Requires:       db >= %{db_ver}
220 Requires:       libmagic >= 1.15-2
221 Requires:       openssl >= %{openssl_ver}
222 Requires:       popt >= %{popt_ver}
223 Obsoletes:      rpm-libs
224 # avoid SEGV caused by mixed db versions
225 Conflicts:      poldek < 0.18.1-16
226
227 %description lib
228 RPMs library.
229
230 %description lib -l pl.UTF-8
231 Biblioteki RPM-a.
232
233 %package devel
234 Summary:        Header files for rpm libraries
235 Summary(de.UTF-8):      Header-Dateien für rpm Libraries
236 Summary(es.UTF-8):      Archivos de inclusión y bibliotecas para programas de manipulación de paquetes rpm
237 Summary(pl.UTF-8):      Pliki nagłówkowe bibliotek rpm
238 Summary(pt_BR.UTF-8):   Arquivos de inclusão e bibliotecas para programas de manipulação de pacotes RPM
239 Summary(ru.UTF-8):      Хедеры и библиотеки для программ, работающих с rpm-пакетами
240 Summary(uk.UTF-8):      Хедери та бібліотеки для програм, що працюють з пакетами rpm
241 Group:          Development/Libraries
242 Requires:       %{name}-lib = %{epoch}:%{version}-%{release}
243 Requires:       bzip2-devel
244 Requires:       db-devel >= %{db_ver}
245 Requires:       elfutils-devel
246 Requires:       libmagic-devel
247 Requires:       openssl-devel >= %{openssl_ver}
248 %if %{with selinux}
249 Requires:       libselinux-devel
250 Requires:       libsemanage-devel
251 Requires:       libsepol-devel
252 %endif
253 Requires:       popt-devel >= %{popt_ver}
254 Requires:       zlib-devel
255
256 %description devel
257 The RPM packaging system includes C libraries that make it easy to
258 manipulate RPM packages and databases. They are intended to ease the
259 creation of graphical package managers and other tools that need
260 intimate knowledge of RPM packages. This package contains header files
261 for these libraries.
262
263 %description devel -l de.UTF-8
264 Der RPM-Packensystem enthält eine C-Library, die macht es einfach
265 RPM-Pakete und Dateibanken zu manipulieren. Er eignet sich für
266 Vereinfachung des Schaffens grafischer Paket-Manager und anderer
267 Werkzeuge, die intime Kenntnis von RPM-Paketen brauchen.
268
269 %description devel -l es.UTF-8
270 El sistema de empaquetado RPM incluye una biblioteca C que vuelve
271 fácil la manipulación de paquetes y bases de datos RPM. Su objetivo es
272 facilitar la creación de administradores gráficos de paquetes y otras
273 herramientas que necesiten un conocimiento profundo de paquetes RPM.
274
275 %description devel -l pl.UTF-8
276 System RPM zawiera biblioteki C, które ułatwiają manipulowanie
277 pakietami RPM oraz bazami danych. W zamiarze ma to uprościć tworzenie
278 graficznych programów zarządzających pakietami oraz innych narzędzi,
279 które wymagają szczegółowej wiedzy na temat pakietów RPM. Ten pakiet
280 zawiera pliki nagłówkowe wspomnianych bibliotek.
281
282 %description devel -l pt_BR.UTF-8
283 O sistema de empacotamento RPM inclui uma biblioteca C que torna fácil
284 a manipulação de pacotes e bases de dados RPM. Seu objetivo é
285 facilitar a criação de gerenciadores gráficos de pacotes e outras
286 ferramentas que precisem de conhecimento profundo de pacotes RPM.
287
288 %description devel -l ru.UTF-8
289 Система управления пакетами RPM содержит библиотеку C, которая
290 упрощает манипуляцию пакетами RPM и соответствующими базами данных.
291 Эта библиотека предназначена для облегчения создания графических
292 пакетных менеджеров и других утилит, которым необходимо работать с
293 пакетами RPM.
294
295 %description devel -l uk.UTF-8
296 Система керування пакетами RPM містить бібліотеку C, котра спрощує
297 роботу з пакетами RPM та відповідними базами даних. Ця бібліотека
298 призначена для полегшення створення графічних пакетних менеджерів та
299 інших утиліт, що працюють з пакетами RPM.
300
301 %package utils
302 Summary:        Additional utilities for managing RPM packages and database
303 Summary(de.UTF-8):      Zusatzwerkzeuge für Verwaltung RPM-Pakete und Datenbanken
304 Summary(pl.UTF-8):      Dodatkowe narzędzia do zarządzania bazą RPM-a i pakietami
305 Group:          Applications/File
306 Requires:       %{name} = %{epoch}:%{version}-%{release}
307 Requires:       popt >= %{popt_ver}
308 %if %{with recommends_tags}
309 Recommends:     bzip2
310 Recommends:     gzip
311 %endif
312 Conflicts:      filesystem-debuginfo < 3.0-16
313
314 %description utils
315 Additional utilities for managing RPM packages and database.
316
317 %description utils -l de.UTF-8
318 Zusatzwerkzeuge für Verwaltung RPM-Pakete und Datenbanken.
319
320 %description utils -l pl.UTF-8
321 Dodatkowe narzędzia do zarządzania bazą RPM-a i pakietami.
322
323 %package build
324 Summary:        Scripts for building binary RPM packages
325 Summary(de.UTF-8):      Scripts fürs Bauen binärer RPM-Pakete
326 Summary(pl.UTF-8):      Skrypty pomocnicze do budowania binarnych RPM-ów
327 Summary(pt_BR.UTF-8):   Scripts e programas executáveis usados para construir pacotes
328 Summary(ru.UTF-8):      Скрипты и утилиты, необходимые для сборки пакетов
329 Summary(uk.UTF-8):      Скрипти та утиліти, необхідні для побудови пакетів
330 Group:          Applications/File
331 Requires(pretrans):     coreutils
332 Requires(pretrans):     findutils
333 Requires:       %{name}-utils = %{epoch}:%{version}-%{release}
334 Requires:       rpm-pld-macros-build >= 1.744
335 Requires:       /bin/id
336 Requires:       awk
337 Requires:       bzip2
338 Requires:       chrpath >= 0.10-4
339 Requires:       cpio
340 Requires:       diffutils
341 Requires:       elfutils
342 Requires:       file >= 4.17
343 Requires:       fileutils
344 Requires:       findutils
345 %ifarch athlon
346 Requires:       gcc >= 3.0.3
347 %else
348 Requires:       gcc
349 %endif
350 Requires:       glibc-devel
351 Requires:       grep
352 Requires:       gzip
353 Requires:       make
354 Requires:       patch
355 Requires:       sed >= 4.0
356 Requires:       sh-utils
357 Requires:       tar >= 1:1.22
358 Requires:       textutils
359 Requires:       which
360 Requires:       xz
361 Provides:       rpmbuild(noauto) = 3
362 %ifarch %{x8664}
363 Conflicts:      automake < 1:1.7.9-2
364 Conflicts:      libtool < 2:1.5-13
365 %endif
366
367 %description build
368 Scripts for building binary RPM packages.
369
370 %description build -l de.UTF-8
371 Scripts fürs Bauen binärer RPM-Pakete.
372
373 %description build -l pl.UTF-8
374 Skrypty pomocnicze do budowania binarnych RPM-ów.
375
376 %description build -l pt_BR.UTF-8
377 Este pacote contém scripts e programas executáveis que são usados para
378 construir pacotes usando o RPM.
379
380 %description build -l ru.UTF-8
381 Различные вспомогательные скрипты и исполняемые программы, которые
382 используются для сборки RPM'ов.
383
384 %description build -l uk.UTF-8
385 Різноманітні допоміжні скрипти та утиліти, які використовуються для
386 побудови RPM'ів.
387
388 %package perlprov
389 Summary:        Additional utilities for checking Perl provides/requires in RPM packages
390 Summary(de.UTF-8):      Zusatzwerkzeuge fürs Nachsehen Perl-Abhängigkeiten in RPM-Paketen
391 Summary(pl.UTF-8):      Dodatkowe narzędzia do sprawdzenia zależności skryptów Perla w pakietach RPM
392 Group:          Applications/File
393 Requires:       %{name} = %{epoch}:%{version}-%{release}
394 Requires:       perl-Encode
395 Requires:       perl-devel
396 Requires:       perl-modules
397
398 %description perlprov
399 Additional utilities for checking Perl provides/requires in RPM
400 packages.
401
402 %description perlprov -l de.UTF-8
403 Zusatzwerkzeuge fürs Nachsehen Perl-Abhängigkeiten in RPM-Paketen.
404
405 %description perlprov -l pl.UTF-8
406 Dodatkowe narzędzia do sprawdzenia zależności skryptów Perla w
407 pakietach RPM.
408
409 %package pythonprov
410 Summary:        Python macros, which simplifies creation of RPM packages with Python software
411 Summary(pl.UTF-8):      Makra ułatwiające tworzenie pakietów RPM z programami napisanymi w Pythonie
412 Group:          Applications/File
413 Requires:       %{name} = %{epoch}:%{version}-%{release}
414 Requires:       python3
415 Requires:       python3-modules
416 Requires:       python3-setuptools
417
418 %description pythonprov
419 Python macros, which simplifies creation of RPM packages with Python
420 software.
421
422 %description pythonprov -l pl.UTF-8
423 Makra ułatwiające tworzenie pakietów RPM z programami napisanymi w
424 Pythonie.
425
426 %package -n python3-rpm
427 Summary:        Python 3 interface to RPM library
428 Summary(pl.UTF-8):      Interfejs Pythona 3 do biblioteki RPM-a
429 Summary(pt_BR.UTF-8):   Módulo Python 3 para aplicativos que manipulam pacotes RPM
430 Group:          Development/Languages/Python
431 Requires:       %{name} = %{epoch}:%{version}-%{release}
432 Requires:       python3
433 Obsoletes:      python-rpm < 1:4.16.0
434 Obsoletes:      rpm-python
435
436 %description -n python3-rpm
437 The python3-rpm package contains a module which permits applications
438 written in the Python 3 programming language to use the interface
439 supplied by RPM (RPM Package Manager) libraries.
440
441 This package should be installed if you want to develop Python 3
442 programs that will manipulate RPM packages and databases.
443
444 %description -n python3-rpm -l pl.UTF-8
445 Pakiet python3-rpm zawiera moduł, który pozwala aplikacjom napisanym w
446 Pythonie 3 na używanie interfejsu dostarczanego przez biblioteki
447 RPM-a.
448
449 Pakiet ten powinien zostać zainstalowany, jeśli chcesz pisać w
450 Pythonie 3 programy manipulujące pakietami i bazami danych rpm.
451
452 %description -n python3-rpm -l pt_BR.UTF-8
453 O pacote python3-rpm contém um módulo que permite que aplicações
454 escritas em Python 3 utilizem a interface fornecida pelas bibliotecas
455 RPM (RPM Package Manager).
456
457 Esse pacote deve ser instalado se você quiser desenvolver programas em
458 Python 3 para manipular pacotes e bancos de dados RPM.
459
460 %package plugin-audit
461 Summary:        Plugin for logging audit events on package operations
462 Group:          Base
463 Requires:       %{name}-lib = %{epoch}:%{version}-%{release}
464
465 %description plugin-audit
466 Plugin for libaudit support
467
468 %package plugin-syslog
469 Summary:        Plugin for syslog functionality
470 Group:          Base
471 Requires:       %{name}-lib = %{epoch}:%{version}-%{release}
472
473 %description plugin-syslog
474 This plugin exports RPM actions to the system log.
475
476 %package plugin-systemd-inhibit
477 Summary:        Plugin for systemd inhibit functionality
478 Group:          Base
479 Requires:       %{name}-lib = %{epoch}:%{version}-%{release}
480
481 %description plugin-systemd-inhibit
482 This plugin blocks systemd from entering idle, sleep or shutdown while
483 an rpm transaction is running using the systemd-inhibit mechanism.
484
485 %package plugin-ima
486 Summary:        Plugin for IMA file signatures
487 Group:          Base
488 Requires:       %{name}-lib = %{epoch}:%{version}-%{release}
489
490 %description plugin-ima
491 This plugin adds support for enforcing and verifying IMA file
492 signatures in an rpm.
493
494 %package plugin-prioreset
495 Summary:        Plugin for resetting scriptlet priorities for SysV init
496 Group:          Base
497 Requires:       %{name}-lib = %{epoch}:%{version}-%{release}
498
499 %description plugin-prioreset
500 This plugin is useful on legacy SysV init systems if you run rpm
501 transactions with nice/ionice priorities. Should not be used on
502 systemd systems.
503
504 %package plugin-selinux
505 Summary:        Plugin for SELinux functionality
506 Group:          Base
507 Requires:       %{name}-lib = %{epoch}:%{version}-%{release}
508 Requires:       libselinux >= 2.1.0
509
510 %description plugin-selinux
511 Plugin for SELinux functionality.
512
513 %package sign
514 Summary:        Package signing support
515 Group:          Base
516 Requires:       %{name}-lib = %{epoch}:%{version}-%{release}
517
518 %description sign
519 This package contains support for digitally signing RPM packages.
520
521 %package apidocs
522 Summary:        RPM API documentation and guides
523 Summary(pl.UTF-8):      Documentacja API RPM-a i przewodniki
524 Group:          Documentation
525 BuildArch:      noarch
526
527 %description apidocs
528 Documentation for RPM API and guides in HTML format generated from rpm
529 sources by doxygen.
530
531 %description apidocs -l pl.UTF-8
532 Dokumentacja API RPM-a oraz przewodniki w formacie HTML generowane ze
533 źrodeł RPM-a przez doxygen.
534
535 %prep
536 %setup -q -n %{name}-%{version}%{?subver}
537 %patch0 -p1
538 %patch1 -p1
539 %patch2 -p1
540 %patch3 -p1
541 %patch4 -p1
542 %patch6 -p0
543 %patch7 -p1
544 %patch8 -p1
545 %patch9 -p1
546 %patch10 -p1
547 %patch11 -p1
548 %patch12 -p1
549 %patch13 -p1
550 %patch14 -p1
551 %patch15 -p1
552 %patch16 -p1
553 %patch17 -p1
554 %patch18 -p1
555 %patch19 -p1
556 %patch20 -p1
557
558 install %{SOURCE15} scripts/perl.prov.in
559
560 %{__mv} -f scripts/perl.req{,.in}
561
562 # generate Group translations to *.po
563 awk -f %{SOURCE6} %{SOURCE5}
564
565 install %{SOURCE16} tools/rpmdb_checkversion.c
566 install %{SOURCE17} tools/rpmdb_reset.c
567
568 %{__sed} -i -e '1s,/usr/bin/python,%{__python3},' scripts/pythondistdeps.py
569
570 %build
571 %{__libtoolize}
572 %{__aclocal}
573 %{__autoheader}
574 %{__autoconf}
575 %{__automake}
576
577 # rpm checks for CPU type at runtime, but it looks better
578 sed -i \
579         -e 's|@host@|%{_target_cpu}-%{_target_vendor}-%{_target_os}|' \
580         -e 's|@host_cpu@|%{_target_cpu}|' \
581         -e 's|@host_os@|%{_target_os}|' \
582         macros.in
583
584 %configure \
585         WITH_PERL_VERSION=no \
586         __GST_INSPECT=%{_bindir}/gst-inspect-1.0 \
587         __GPG=%{_bindir}/gpg \
588 %if %{with python3}
589         PYTHON=python3 \
590         --enable-python \
591 %endif
592         --disable-silent-rules \
593         --enable-shared \
594         --enable-bdb \
595         --enable-ndb \
596         --enable-sqlite \
597         --enable-zstd \
598         --with-crypto=openssl \
599         --with-lua \
600         %{?with_imaevm:--with-imaevm} \
601         --with-cap \
602         --with-acl \
603         --with-audit \
604         --with-archive \
605         --with-selinux=%{!?with_plugins:no}%{?with_plugins:yes} \
606         %{!?with_plugins:--disable-plugins} \
607         --with-vendor=pld
608
609 %{__make}
610
611 %{__cc} %{rpmcflags} tools/rpmdb_checkversion.c -o tools/rpmdb_checkversion -ldb
612 %{__cc} %{rpmcflags} tools/rpmdb_reset.c -o tools/rpmdb_reset -ldb
613
614 if tools/rpmdb_checkversion -V 2>&1 | grep "t match library version"; then
615         echo "Error linking rpmdb tools!"
616         exit 1
617 fi
618 if tools/rpmdb_reset -V 2>&1 | grep "t match library version"; then
619         echo "Error linking rpmdb tools!"
620         exit 1
621 fi
622
623 %if %{with python3}
624 cd python
625 %py3_build
626 %endif
627
628 %install
629 rm -rf $RPM_BUILD_ROOT
630 install -d $RPM_BUILD_ROOT{/bin,/%{_lib},/etc/sysconfig,%{_sysconfdir}/{rpm,pki/rpm-gpg}} \
631         $RPM_BUILD_ROOT{/var/lib/{banner,rpm},/var/cache/hrmib}
632
633 cp -p %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/pki/rpm-gpg/PLD-3.0-Th-GPG-key.asc
634
635 %{__make} install \
636         pkgconfigdir=%{_pkgconfigdir} \
637         DESTDIR=$RPM_BUILD_ROOT
638
639 # cleanup
640 %ifnarch %{ix86} %{x8664} x32
641 rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/athlon-linux/macros
642 rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/geode-linux/macros
643 rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/i386-linux/macros
644 rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/i486-linux/macros
645 rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/i586-linux/macros
646 rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/i686-linux/macros
647 rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/pentium3-linux/macros
648 rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/pentium4-linux/macros
649 %endif
650
651 %ifnarch %{x8664} x32
652 rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/amd64-linux/macros
653 rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/ia32e-linux/macros
654 rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/x32-linux/macros
655 rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/x86_64-linux/macros
656 %endif
657
658 %ifnarch %{ppc}
659 rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/m68k-linux/macros
660 rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/ppc32dy4-linux/macros
661 rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/ppc64*-linux/macros
662 rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/ppc8260-linux/macros
663 rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/ppc8560-linux/macros
664 rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/ppc-linux/macros
665 rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/ppc*series-linux/macros
666 %endif
667
668 rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/aarch64-linux/macros
669 rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/alpha*-linux/macros
670 rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/arm*-linux/macros
671 rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/ia64-linux/macros
672 rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/mips*-linux/macros
673 rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/riscv64-linux/macros
674 rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/s390*-linux/macros
675 rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/sh*-linux/macros
676 rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/sparc*-linux/macros
677
678 %{__rm} $RPM_BUILD_ROOT%{_rpmlibdir}/find-lang.sh
679
680 install -d $RPM_BUILD_ROOT%{_rpmlibdir}/pld
681
682 cp -p %{SOURCE7} $RPM_BUILD_ROOT%{_rpmlibdir}/install-build-tree
683 cp -p %{SOURCE9} $RPM_BUILD_ROOT%{_rpmlibdir}/user_group.sh
684 cp -p %{SOURCE8} $RPM_BUILD_ROOT%{_rpmlibdir}/hrmib-cache
685 cp -p %{SOURCE4} $RPM_BUILD_ROOT/etc/sysconfig/rpm
686
687 cp -p %{SOURCE10} $RPM_BUILD_ROOT%{_bindir}/banner.sh
688
689 cp -p %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}/rpm/macros
690 cp -p %{SOURCE3} $RPM_BUILD_ROOT%{_sysconfdir}/rpm/macros.lang
691 cp -p %{SOURCE11} $RPM_BUILD_ROOT%{_sysconfdir}/rpm/noautoprov
692 cp -p %{SOURCE12} $RPM_BUILD_ROOT%{_sysconfdir}/rpm/noautoprovfiles
693 cp -p %{SOURCE13} $RPM_BUILD_ROOT%{_sysconfdir}/rpm/noautoreq
694 cp -p %{SOURCE14} $RPM_BUILD_ROOT%{_sysconfdir}/rpm/noautoreqfiles
695
696 cp -p tools/rpmdb_checkversion $RPM_BUILD_ROOT%{_rpmlibdir}/
697 cp -p tools/rpmdb_reset $RPM_BUILD_ROOT%{_rpmlibdir}/
698 cp -p %{SOURCE18} $RPM_BUILD_ROOT%{_rpmlibdir}/dbupgrade.sh
699
700 # move rpm to /bin
701 %{__mv} $RPM_BUILD_ROOT%{_bindir}/rpm $RPM_BUILD_ROOT/bin
702 ln -sf /bin/rpm $RPM_BUILD_ROOT%{_bindir}/rpmquery
703 ln -sf /bin/rpm $RPM_BUILD_ROOT%{_bindir}/rpmverify
704
705 # move essential libs to /lib (libs that /bin/rpm links to)
706 for a in librpm.so librpmbuild.so librpmio.so librpmsign.so; do
707         mv -f $RPM_BUILD_ROOT%{_libdir}/${a}.* $RPM_BUILD_ROOT/%{_lib}
708         ln -sf /%{_lib}/$(basename $RPM_BUILD_ROOT/%{_lib}/${a}.*.*.*) $RPM_BUILD_ROOT%{_libdir}/${a}
709 done
710
711 #./rpmdb --macros=macros --rcfile=rpmrc --dbpath=/home/users/baggins/devel/PLD/rpm/BUILD/rpm-4.15.1/x/ --initdb
712
713 # Make sure we have bdb set a default backend
714 grep -qE "db_backend[[:blank:]]+bdb" $RPM_BUILD_ROOT%{_rpmlibdir}/macros
715
716 %if %{with python3}
717 # Remove anything that rpm make install might put there
718 %{__rm} -rf $RPM_BUILD_ROOT%{py3_sitedir}
719 cd python
720 %py3_install
721 cd ..
722 %endif
723
724 %{__rm} $RPM_BUILD_ROOT%{_libdir}/rpm-plugins/*.la
725
726 # wrong location, not used anyway
727 %{__rm} $RPM_BUILD_ROOT%{_rpmlibdir}/rpm.{daily,log}
728
729 %find_lang %{name}
730
731 %clean
732 rm -rf $RPM_BUILD_ROOT
733
734 %posttrans
735 if [ -e /var/lib/rpm/Packages ] && \
736                 ! %{_rpmlibdir}/rpmdb_checkversion -h /var/lib/rpm -d /var/lib/rpm; then
737         if [ ! -e /var/lib/rpm.rpmbackup-%{version}-%{release} ] && \
738                         /bin/cp -a /var/lib/rpm /var/lib/rpm.rpmbackup-%{version}-%{release}; then
739                 echo
740                 echo "Backup of the rpm database has been created in /var/lib/rpm.rpmbackup-%{version}-%{release}"
741                 echo
742         fi
743         echo
744         echo 'If poldek aborts after migration with rpmdb error, this is expected behaviour,'
745         echo 'you should ignore it and restart poldek'
746         echo
747         %{_rpmlibdir}/dbupgrade.sh
748 fi
749
750 %triggerpostun -- %{name} < 4.4.9-44
751 %{_rpmlibdir}/hrmib-cache
752
753 %post   lib -p /sbin/ldconfig
754 %postun lib -p /sbin/ldconfig
755
756 %pretrans build
757 find %{_rpmlibdir} -name '*-linux' -type l | xargs rm -f
758
759 %files -f %{name}.lang
760 %defattr(644,root,root,755)
761 %doc ChangeLog CREDITS README
762
763 %dir /etc/pki/rpm-gpg
764 /etc/pki/rpm-gpg/PLD-3.0-Th-GPG-key.asc
765
766 %attr(755,root,root) /bin/rpm
767 %attr(755,root,root) %{_bindir}/rpmdb
768 %attr(755,root,root) %{_bindir}/rpmkeys
769 %attr(755,root,root) %{_bindir}/rpmquery
770 %attr(755,root,root) %{_bindir}/rpmverify
771
772 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/rpm/macros
773 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/rpm/macros.lang
774
775 %{_mandir}/man8/rpm.8*
776 %{_mandir}/man8/rpmdb.8*
777 %{_mandir}/man8/rpmkeys.8*
778 %{_mandir}/man8/rpm-misc.8*
779 %{?with_plugins:%{_mandir}/man8/rpm-plugins.8*}
780 %lang(fr) %{_mandir}/fr/man8/rpm.8*
781 %lang(ja) %{_mandir}/ja/man8/rpm.8*
782 %lang(ko) %{_mandir}/ko/man8/rpm.8*
783 %lang(pl) %{_mandir}/pl/man8/rpm.8*
784 %lang(ru) %{_mandir}/ru/man8/rpm.8*
785 %lang(sk) %{_mandir}/sk/man8/rpm.8*
786
787 %dir /var/lib/rpm
788
789 # exported package NVRA (stamped with install tid)
790 # net-snmp hrSWInstalledName queries, bash-completions
791 %dir /var/cache/hrmib
792
793 %{_rpmlibdir}/rpmpopt*
794 %{_rpmlibdir}/rpmrc
795 %{_rpmlibdir}/macros
796 %dir %{_rpmlibdir}/macros.d
797 %dir %{_rpmlibdir}/platform
798 %{_rpmlibdir}/platform/noarch-*
799 %ifarch %{ix86} %{x8664} x32
800 %{_rpmlibdir}/platform/athlon*
801 %{_rpmlibdir}/platform/geode*
802 %{_rpmlibdir}/platform/i?86*
803 %{_rpmlibdir}/platform/pentium*
804 %endif
805 %ifarch %{x8664} x32
806 %{_rpmlibdir}/platform/amd64*
807 %{_rpmlibdir}/platform/ia32e*
808 %{_rpmlibdir}/platform/x86_64*
809 %{_rpmlibdir}/platform/x32*
810 %endif
811 %ifarch alpha
812 %{_rpmlibdir}/platform/alpha*
813 %endif
814 %ifarch ia64
815 %{_rpmlibdir}/platform/ia64*
816 %endif
817 %ifarch mips mipsel mips64 mips64el
818 %{_rpmlibdir}/platform/mips*
819 %endif
820 %ifarch %{ppc}
821 %{_rpmlibdir}/platform/ppc*
822 %endif
823 %ifarch sparc sparc64
824 %{_rpmlibdir}/platform/sparc*
825 %endif
826
827 %dir %{_rpmlibdir}/pld
828
829 %attr(755,root,root) %{_rpmlibdir}/hrmib-cache
830
831 %attr(755,root,root) %{_rpmlibdir}/dbupgrade.sh
832 %attr(755,root,root) %{_rpmlibdir}/rpmdb_checkversion
833 %attr(755,root,root) %{_rpmlibdir}/rpmdb_reset
834 %attr(755,root,root) %{_rpmlibdir}/rpmdb_dump
835 %attr(755,root,root) %{_rpmlibdir}/rpmdb_load
836
837 # valgrind suppression file for rpm
838 %{_rpmlibdir}/rpm.supp
839
840 %files base
841 %defattr(644,root,root,755)
842 %dir %{_sysconfdir}/rpm
843 %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/rpm
844 %dir %{_rpmlibdir}
845 %attr(755,root,root) %{_bindir}/banner.sh
846 %attr(755,root,root) %{_rpmlibdir}/user_group.sh
847 %dir /var/lib/banner
848
849 %files lib
850 %defattr(644,root,root,755)
851 %attr(755,root,root) /%{_lib}/librpm.so.9
852 %attr(755,root,root) /%{_lib}/librpm.so.%{sover}
853 %attr(755,root,root) /%{_lib}/librpmbuild.so.9
854 %attr(755,root,root) /%{_lib}/librpmbuild.so.%{sover}
855 %attr(755,root,root) /%{_lib}/librpmio.so.9
856 %attr(755,root,root) /%{_lib}/librpmio.so.%{sover}
857 %attr(755,root,root) /%{_lib}/librpmsign.so.9
858 %attr(755,root,root) /%{_lib}/librpmsign.so.%{sover}
859 %{?with_plugins:%dir %{_libdir}/rpm-plugins}
860
861 %files devel
862 %defattr(644,root,root,755)
863 %attr(755,root,root) %{_libdir}/librpm.so
864 %attr(755,root,root) %{_libdir}/librpmbuild.so
865 %attr(755,root,root) %{_libdir}/librpmio.so
866 %attr(755,root,root) %{_libdir}/librpmsign.so
867 %{_libdir}/librpm*.la
868 %{_includedir}/rpm
869 %{_pkgconfigdir}/*.pc
870
871 %files utils
872 %defattr(644,root,root,755)
873 %attr(755,root,root) %{_bindir}/rpm2archive
874 %attr(755,root,root) %{_bindir}/rpm2cpio
875 %attr(755,root,root) %{_bindir}/rpmgraph
876 %attr(755,root,root) %{_rpmlibdir}/rpm2cpio.sh
877 %attr(755,root,root) %{_rpmlibdir}/find-debuginfo.sh
878 %attr(755,root,root) %{_rpmlibdir}/tgpg
879 %attr(755,root,root) %{_rpmlibdir}/debugedit
880 %attr(755,root,root) %{_rpmlibdir}/rpmdeps
881 %{_mandir}/man8/rpm2archive.8*
882 %{_mandir}/man8/rpm2cpio.8*
883 %{_mandir}/man8/rpmdeps.8*
884 %{_mandir}/man8/rpmgraph.8*
885 %lang(ja) %{_mandir}/ja/man8/rpm2cpio.8*
886 %lang(ko) %{_mandir}/ko/man8/rpm2cpio.8*
887 %lang(pl) %{_mandir}/pl/man8/rpm2cpio.8*
888 %lang(ru) %{_mandir}/ru/man8/rpm2cpio.8*
889 %lang(pl) %{_mandir}/pl/man8/rpmdeps.8*
890 %lang(ja) %{_mandir}/ja/man8/rpmgraph.8*
891 %lang(pl) %{_mandir}/pl/man8/rpmgraph.8*
892
893 %files build
894 %defattr(644,root,root,755)
895 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/rpm/noauto*
896 %attr(755,root,root) %{_rpmlibdir}/brp-*
897 %attr(755,root,root) %{_rpmlibdir}/check-files
898 %attr(755,root,root) %{_rpmlibdir}/install-build-tree
899 %attr(755,root,root) %{_rpmlibdir}/elfdeps
900 %attr(755,root,root) %{_rpmlibdir}/libtooldeps.sh
901 # needs hacked pkg-config to return anything
902 %attr(755,root,root) %{_rpmlibdir}/pkgconfigdeps.sh
903 %attr(755,root,root) %{_rpmlibdir}/mkinstalldirs
904
905 %attr(755,root,root) %{_rpmlibdir}/fontconfig.prov
906 # must be here for "Requires: rpm-*prov" to work
907 #%{_rpmlibdir}/macros.d/cmake
908 #%{_rpmlibdir}/macros.d/gstreamer
909 #%{_rpmlibdir}/macros.d/libtool
910 #%{_rpmlibdir}/macros.d/perl
911 #%{_rpmlibdir}/macros.d/pkgconfig
912 #%{_rpmlibdir}/macros.d/python
913 #%{_rpmlibdir}/macros.d/selinux
914 #%{_rpmlibdir}/macros.d/tcl
915 #%{_rpmlibdir}/macros.rpmbuild
916
917 %attr(755,root,root) %{_rpmlibdir}/check-buildroot
918 %attr(755,root,root) %{_rpmlibdir}/check-prereqs
919 %attr(755,root,root) %{_rpmlibdir}/check-rpaths
920 %attr(755,root,root) %{_rpmlibdir}/check-rpaths-worker
921 %attr(755,root,root) %{_rpmlibdir}/find-provides
922 %attr(755,root,root) %{_rpmlibdir}/find-requires
923 %attr(755,root,root) %{_rpmlibdir}/ocamldeps.sh
924 %attr(755,root,root) %{_rpmlibdir}/script.req
925 %attr(755,root,root) %{_rpmlibdir}/sepdebugcrcfix
926
927 %dir %{_rpmlibdir}/fileattrs
928 %{_rpmlibdir}/fileattrs/debuginfo.attr
929 %{_rpmlibdir}/fileattrs/desktop.attr
930 %{_rpmlibdir}/fileattrs/elf.attr
931 %{_rpmlibdir}/fileattrs/font.attr
932 %{_rpmlibdir}/fileattrs/libtool.attr
933 %{_rpmlibdir}/fileattrs/metainfo.attr
934 %{_rpmlibdir}/fileattrs/ocaml.attr
935 %{_rpmlibdir}/fileattrs/perl.attr
936 %{_rpmlibdir}/fileattrs/perllib.attr
937 %{_rpmlibdir}/fileattrs/pkgconfig.attr
938 %{_rpmlibdir}/fileattrs/python.attr
939 %{_rpmlibdir}/fileattrs/pythondist.attr
940 %{_rpmlibdir}/fileattrs/script.attr
941
942 %attr(755,root,root) %{_bindir}/gendiff
943 %attr(755,root,root) %{_bindir}/rpmbuild
944 %attr(755,root,root) %{_bindir}/rpmspec
945
946 %{_mandir}/man1/gendiff.1*
947 %lang(pl) %{_mandir}/pl/man1/gendiff.1*
948 %{_mandir}/man8/rpmbuild.8*
949 %lang(ja) %{_mandir}/ja/man8/rpmbuild.8*
950 %lang(pl) %{_mandir}/pl/man8/rpmbuild.8*
951 %{_mandir}/man8/rpmspec.8*
952
953 %files perlprov
954 %defattr(644,root,root,755)
955 %attr(755,root,root) %{_rpmlibdir}/perl.*
956
957 %files pythonprov
958 %defattr(644,root,root,755)
959 %attr(755,root,root) %{_rpmlibdir}/pythondistdeps.py
960
961 %if %{with python3}
962 %files -n python3-rpm
963 %defattr(644,root,root,755)
964 %dir %{py3_sitedir}/rpm
965 %attr(755,root,root) %{py3_sitedir}/rpm/*.so
966 %{py3_sitedir}/rpm/*.py
967 %{py3_sitedir}/rpm-%{version}-py*.egg-info
968 %{py3_sitedir}/rpm/__pycache__
969 %endif
970
971 %if %{with plugins}
972 %files plugin-audit
973 %defattr(644,root,root,755)
974 %attr(755,root,root) %{_libdir}/rpm-plugins/audit.so
975 %{_mandir}/man8/rpm-plugin-audit.8*
976
977 %files plugin-syslog
978 %defattr(644,root,root,755)
979 %attr(755,root,root) %{_libdir}/rpm-plugins/syslog.so
980 %{_mandir}/man8/rpm-plugin-syslog.8*
981
982 %files plugin-systemd-inhibit
983 %defattr(644,root,root,755)
984 %attr(755,root,root) %{_libdir}/rpm-plugins/systemd_inhibit.so
985 %{_mandir}/man8/rpm-plugin-systemd-inhibit.8*
986
987 %files plugin-ima
988 %defattr(644,root,root,755)
989 %attr(755,root,root) %{_libdir}/rpm-plugins/ima.so
990 %{_mandir}/man8/rpm-plugin-ima.8*
991
992 %files plugin-prioreset
993 %defattr(644,root,root,755)
994 %attr(755,root,root) %{_libdir}/rpm-plugins/prioreset.so
995 %{_mandir}/man8/rpm-plugin-prioreset.8*
996
997 %files plugin-selinux
998 %defattr(644,root,root,755)
999 %attr(755,root,root) %{_libdir}/rpm-plugins/selinux.so
1000 %{_mandir}/man8/rpm-plugin-selinux.8*
1001 %endif
1002
1003 %files sign
1004 %defattr(644,root,root,755)
1005 %attr(755,root,root) %{_bindir}/rpmsign
1006 %{_mandir}/man8/rpmsign.8*
1007
1008 %if %{with apidocs}
1009 %files apidocs
1010 %defattr(644,root,root,755)
1011 %doc doc/librpm/html/*
1012 %endif
This page took 0.196598 seconds and 3 git commands to generate.