]> git.pld-linux.org Git - packages/rpm.git/commitdiff
- added fdClose-typo patch (s/fdCLose/fdClose/ in rpmio.h)
authorJakub Bogusz <qboosh@pld-linux.org>
Thu, 19 Jun 2003 22:49:09 +0000 (22:49 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
- one more etc_dir patch update: dots are back
- s/""/%%{nil}/ in specflags patch to avoid those strange configure warnings
- release .10

Changed files:
    rpm-etc_dir.patch -> 1.3
    rpm-fdClose-typo.patch -> 1.1
    rpm-specflags.patch -> 1.2
    rpm.spec -> 1.440

rpm-etc_dir.patch
rpm-fdClose-typo.patch [new file with mode: 0644]
rpm-specflags.patch
rpm.spec

index 7437042ae7a8090cf7d0ba5795b5b846c94da889..39ca19a9b40a330da6a29074d6188b187c08d05e 100644 (file)
@@ -1,7 +1,7 @@
 diff -Nru rpm-4.1/lib/rpmrc.c rpm-4.1.new/lib/rpmrc.c
 --- rpm-4.1/lib/rpmrc.c        Tue Aug 20 16:53:44 2002
 +++ rpm-4.1.new/lib/rpmrc.c    Tue Mar 11 18:41:48 2003
-@@ -1756,27 +1756,40 @@
+@@ -1756,27 +1756,39 @@
        /* Expand ~/ to $HOME/ */
        fn[0] = '\0';
        if (r[0] == '~' && r[1] == '/') {
@@ -18,7 +18,6 @@ diff -Nru rpm-4.1/lib/rpmrc.c rpm-4.1.new/lib/rpmrc.c
 +                              strncat(fn, "/", sizeof(fn) - strlen(fn));                              
 +                r+=2;
 +              
-+                              if (r[0] == '.') r++;
 +                      } else {
 +              if (home == NULL) {
            /* XXX Only /usr/lib/rpm/rpmrc must exist in default rcfiles list */
@@ -63,7 +62,7 @@ diff -Nru rpm-4.1/lib/rpmrc.c rpm-4.1.new/lib/rpmrc.c
 diff -Nru rpm-4.1/rpmio/macro.c rpm-4.1.new/rpmio/macro.c
 --- rpm-4.1/rpmio/macro.c      Tue Sep 17 14:58:23 2002
 +++ rpm-4.1.new/rpmio/macro.c  Tue Mar 11 18:21:59 2003
-@@ -1614,15 +1614,23 @@
+@@ -1614,15 +1614,22 @@
        buf[0] = '\0';
        if (mfile[0] == '~' && mfile[1] == '/') {
            char *home;
@@ -75,7 +74,6 @@ diff -Nru rpm-4.1/rpmio/macro.c rpm-4.1.new/rpmio/macro.c
 +
 +                      if (etc_dir) {
 +                              mfile += 2;
-+                              if (mfile[0] == '.') mfile++;
 +                              strncpy(buf, etc_dir, sizeof(buf));
 +                              strncat(buf, "/", sizeof(buf) - strlen(buf));                           
 +                      } else {
diff --git a/rpm-fdClose-typo.patch b/rpm-fdClose-typo.patch
new file mode 100644 (file)
index 0000000..95681d1
--- /dev/null
@@ -0,0 +1,11 @@
+--- rpm-4.3/rpmio/rpmio.h.orig 2003-05-10 17:20:20.000000000 +0200
++++ rpm-4.3/rpmio/rpmio.h      2003-06-19 23:08:44.000000000 +0200
+@@ -501,7 +501,7 @@
+ int fdClose( /*@only@*/ void * cookie)
+       /*@globals errno, fileSystem, systemState, internalState @*/
+       /*@modifies *cookie, errno, fileSystem, systemState, internalState @*/;
+-#define       fdCLose(_fd)            fdio->close(_fd)
++#define       fdClose(_fd)            fdio->close(_fd)
+ /**
+  */
index 23d5a591a578b4a973640e2ed269d7e2cf480ce2..68a9b99d80b0d653470528c55cd372459c7c7c82 100644 (file)
  # unchanged
  %pyrequires_eq() Requires:       %1 >= %py_ver %1 < %(echo `python -c "import sys; import string; ver=sys.version[:3].split('.'); ver[1]=str(int(ver[1])+1); print string.join(ver, '.')"`)
  
-+%specflags            ""
-+%specflags_ia32               ""
-+%specflags_i386               ""
-+%specflags_i486               ""
-+%specflags_i586               ""
-+%specflags_i686               ""
-+%specflags_athlon     ""
-+%specflags_ia64               ""
-+%specflags_x86_64     ""
-+%specflags_alpha      ""
-+%specflags_alphaev5   ""
-+%specflags_alphaev56  ""
-+%specflags_alphapca56 ""
-+%specflags_alphaev6   ""
-+%specflags_alphaev67  ""
-+%specflags_sparc      ""
-+%specflags_sparcv9    ""
-+%specflags_sparc64    ""
-+%specflags_m68k               ""
-+%specflags_ppc                ""
-+%specflags_ppciseries ""
-+%specflags_ppcpseries ""
-+%specflags_ppc64      ""
-+%specflags_parisc     ""
-+%specflags_hppa1_0    ""
-+%specflags_hppa1_1    ""
-+%specflags_hppa1_1    ""
-+%specflags_hppa2_0    ""
-+%specflags_mips               ""
-+%specflags_mipsel     ""
-+%specflags_armv3l     ""
-+%specflags_armv4b     ""
-+%specflags_armv4l     ""
-+%specflags_atarist    ""
-+%specflags_atariste   ""
-+%specflags_ataritt    ""
-+%specflags_falcon     ""
-+%specflags_atariclone ""
-+%specflags_milan      ""
-+%specflags_hades      ""
-+%specflags_s390               ""
-+%specflags_s390x      ""
++%specflags            %{nil}
++%specflags_ia32               %{nil}
++%specflags_i386               %{nil}
++%specflags_i486               %{nil}
++%specflags_i586               %{nil}
++%specflags_i686               %{nil}
++%specflags_athlon     %{nil}
++%specflags_ia64               %{nil}
++%specflags_x86_64     %{nil}
++%specflags_alpha      %{nil}
++%specflags_alphaev5   %{nil}
++%specflags_alphaev56  %{nil}
++%specflags_alphapca56 %{nil}
++%specflags_alphaev6   %{nil}
++%specflags_alphaev67  %{nil}
++%specflags_sparc      %{nil}
++%specflags_sparcv9    %{nil}
++%specflags_sparc64    %{nil}
++%specflags_m68k               %{nil}
++%specflags_ppc                %{nil}
++%specflags_ppciseries %{nil}
++%specflags_ppcpseries %{nil}
++%specflags_ppc64      %{nil}
++%specflags_parisc     %{nil}
++%specflags_hppa1_0    %{nil}
++%specflags_hppa1_1    %{nil}
++%specflags_hppa1_1    %{nil}
++%specflags_hppa2_0    %{nil}
++%specflags_mips               %{nil}
++%specflags_mipsel     %{nil}
++%specflags_armv3l     %{nil}
++%specflags_armv4b     %{nil}
++%specflags_armv4l     %{nil}
++%specflags_atarist    %{nil}
++%specflags_atariste   %{nil}
++%specflags_ataritt    %{nil}
++%specflags_falcon     %{nil}
++%specflags_atariclone %{nil}
++%specflags_milan      %{nil}
++%specflags_hades      %{nil}
++%specflags_s390               %{nil}
++%specflags_s390x      %{nil}
index c244a2a058cbe1aa28996b09bebe149e9dd1780b..33990f80bb54a31e52db3bc1d785fd17e0b57c5f 100644 (file)
--- a/rpm.spec
+++ b/rpm.spec
@@ -26,7 +26,7 @@ Summary(uk):  
 Name:          rpm
 %define        ver     4.3
 Version:       %{ver}
-%define        rel     0.%{snap}.9
+%define        rel     0.%{snap}.10
 Release:       %{rel}
 License:       GPL
 Group:         Base
@@ -82,6 +82,7 @@ Patch27:      %{name}-dontneedutils.patch
 Patch28:       %{name}-python-beecrypt.patch
 Patch29:       %{name}-man-typos.patch
 Patch30:       %{name}-man-pl.patch
+Patch31:       %{name}-fdClose-typo.patch
 URL:           http://www.rpm.org/
 Icon:          rpm.gif
 BuildRequires: autoconf >= 2.52
@@ -539,6 +540,7 @@ cat %{SOURCE14} >> macros.in
 %patch28 -p1
 %patch29 -p1
 %patch30 -p1
+%patch31 -p1
 
 cd scripts;
 mv -f perl.req perl.req.in
This page took 0.080326 seconds and 4 git commands to generate.